Поздравление с Новым Годом 2010

Публикация № 61649

Сообщество - Поздравления

Идея позаимствованная. Автор оригинальной версии - djkxfhf(точка)nm(точка)ru

Я лишь доработал поправил картинки + добавил слои и т.д и немного текст.

Скачать файлы

Наименование Файл Версия Размер
сам файл ert

.ert 2,67Mb
15.02.10
656
.ert 2,67Mb 656 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Abadonna 3858 26.11.09 14:47 Сейчас в теме
Идея не моя. Я лишь доработал поправил картинку и немного текст.

Ну и положи тогда в раздел Life.
4. Abadonna 3858 26.11.09 15:30 Сейчас в теме
плюс за правильную реакцию на (1) :D
2. vovan519 275 26.11.09 14:51 Сейчас в теме
Заголовок не хочешь откорректировать?
3. kenshin 234 26.11.09 14:53 Сейчас в теме
5. Доня 276 26.11.09 18:33 Сейчас в теме
Красиво и глаз от цифр отдыхает, а можно побольше прикольных картинок
6. kenshin 234 26.11.09 20:28 Сейчас в теме
можно, но только весить оно будет больше, каждая картинка это дополнительных 180 кб -200кб
7. bav 19 27.11.09 17:35 Сейчас в теме
Че-то с переменными напутано немного:
НадоПоздравитьс8марта=Нет; Переменная не определена (Нет)
НадоПоздравитьс8марта=Да; Переменная не определена (Да)

И анекдоты старенькие))
А так, конечно, плюс: остальное всё новенькое, да и вообще раньше всех в этом году спохватился)
8. Tatitutu 3834 27.11.09 18:34 Сейчас в теме
+7
это должна быть или переменная или перечисление ДА или НЕТ

а вот размер можно было и поменьше сделать в 5 РАЗ посмотри
всего 499 кб и не в архиве
Прикрепленные файлы:
ПоздравляемНовыйГод.ert
wolfsoft; +1 Ответить
9. kenshin 234 28.11.09 02:31 Сейчас в теме
bav 27.11.2009 17:35:55

Че-то с переменными напутано немного:
НадоПоздравитьс8марта=Нет; Переменная не определена (Нет)
НадоПоздравитьс8марта=Да; Переменная не определена (Да)

Может быть
если у кого в друг будет вопрос, почему 8марта, ответ потому что влом переменную в глобальнике было переписывать, она у мя там просто за 15 дней до нового года на машинах данный отчет запускает, или когда 8 марта ))
10. kenshin 234 28.11.09 02:34 Сейчас в теме
Спасибо за + кто поставил :D
11. Solo1 29.11.09 23:17 Сейчас в теме
А у меня не работает :( С переменными чего-то
12. kenshin 234 30.11.09 12:16 Сейчас в теме
Solo что за ошибку пишет напиши
13. lukas 01.12.09 12:47 Сейчас в теме
Эх, такую бы разработку да под 8.1... Тоже хочется поздравить ;)
14. kenshin 234 01.12.09 19:43 Сейчас в теме
если успею напишу для 8 ки
AlexBugs; Людо4ка; lukas; +3 Ответить
15. AlexBugs 02.12.09 07:37 Сейчас в теме
А как вы такие картинки вставили в отчет?
хочу вырезать из картинки "AfalinaSoft", но не получается сохранить картинку в отчете :(
16. galyna 66 02.12.09 08:28 Сейчас в теме
17. mayka 02.12.09 09:36 Сейчас в теме
18. marina4183 02.12.09 09:52 Сейчас в теме
Спасибо, очень понравилось :)
19. громозека 02.12.09 10:08 Сейчас в теме
20. kenshin 234 02.12.09 10:29 Сейчас в теме
AlexBugs 02.12.2009 07:37:21
Просто вставь туда текст или кнопку какую со своим логотипом и все ))
21. NatMar 4 02.12.09 10:49 Сейчас в теме
Ошибочку выдает :( НадоПоздравитьс8марта=Нет<<?>>;
22. kenshin 234 02.12.09 10:56 Сейчас в теме
23. Nicholas 748 02.12.09 10:56 Сейчас в теме
Раз уж указываете платформу 1С: Расчет 7.7 как поддерживаемую, то будьте добры проверить работоспособность в типовой конфигурации 1С: Зарплата и Кадры.

НадоПоздравитьс8марта=Нет<<?>>;
{D:\1C CALC\EXTFORMS\ОБРАБОТКИ АЙТИШНЫЕ\ПОЗДРАВЛЯЕМНОВЫЙГОД\ПОЗДРАВЛЯЕМНОВЫЙГОД.ERT(49)}: Переменная не определена (Нет)
НадоПоздравитьс8марта=Да<<?>>;
{D:\1C CALC\EXTFORMS\ОБРАБОТКИ АЙТИШНЫЕ\ПОЗДРАВЛЯЕМНОВЫЙГОД\ПОЗДРАВЛЯЕМНОВЫЙГОД.ERT(53)}: Переменная не определена (Да)
Если НадоПоздравитьс8марта=Нет <<?>>Тогда
{D:\1C CALC\EXTFORMS\ОБРАБОТКИ АЙТИШНЫЕ\ПОЗДРАВЛЯЕМНОВЫЙГОД\ПОЗДРАВЛЯЕМНОВЫЙГОД.ERT(55)}: Переменная не определена (Нет)

Нет таких переменных в типовой конфигурации. Чтобы заработало, надо все это дело исправить или хотя бы закомментировать.

В целом идея хорошая, хоть и не Ваша.
24. kenshin 234 02.12.09 11:00 Сейчас в теме
NatMar 02.12.2009 10:49:38
//НадоПоздравитьс8марта=Нет;
//ПредупредитьЗаДней=10;
//ДатаСКоторойПоздравлять="24.11."+Строка(ДатаГод(ТекущаяДата()));
//Если (НомерДняГода(ДатаСКоторойПоздравлять)-(НомерДняГода(ТекущаяДата()))<ПредупредитьЗаДней) и (НомерДняГода(ДатаСКоторойПоздравлять)-(НомерДняГода(ТекущаяДата()))>=0) тогда
// НадоПоздравитьс8марта=Да;
//КонецЕсли;
//Если НадоПоздравитьс8марта=Нет Тогда
// Форма.Закрыть(0);
// СтатусВозврата(0);
//КонецЕсли;

за Комментируй это в конфигураторе и будет счастье
25. kenshin 234 02.12.09 11:01 Сейчас в теме
Nicholas 02.12.2009 10:56:55 я это написал в шапке что идея по заимствованная
26. kenshin 234 02.12.09 11:12 Сейчас в теме
27. AlexBugs 02.12.09 11:49 Сейчас в теме
kenshin 02.12.2009 10:29:36
Хочу картинку почищенную от логотипа ставить. И так много всяких кнопочек... Подскажите как, pls...
28. kenshin 234 02.12.09 12:03 Сейчас в теме
я уже выложил почищенную от логотипа
29. AlexBugs 02.12.09 13:57 Сейчас в теме
kenshin 02.12.2009 12:03:18
Спасибо! за чустую картинку :)
а все-таки... расскажи как их вставлял...
30. kenshin 234 02.12.09 14:13 Сейчас в теме
Вставить можно по разному, ну я что б не использовать другие папка в которых бы лежали картинки, решил использовать слои, то есть правой кнопкой мыши нажимаешь на слое, далее свойства закладка картинка - изменить картинку - добавить (сверку синяя кнопочка с пальцем) - далее добавляю и вуаля
34. Craig 263 04.12.09 21:26 Сейчас в теме
(30)Что то быстро пропадают сообщения фокусника (( что делать???
31. irina_ph 02.12.09 18:38 Сейчас в теме
Спасибо. Порадуем бухов
32. Veduin 04.12.09 08:12 Сейчас в теме
Довольно таки интересная затея... Колективу понравилось!
Спасибо!
33. pavlo 04.12.09 09:18 Сейчас в теме
то, что картинка не разворачивается на весь экран вместе с отчетом и загружается очень долго - не айс.
а так прикольно!
35. support 4479 04.12.09 23:54 Сейчас в теме
Напомните, где шутка про сканер отпечатка пальца на мониторе.
37. Shaman100M 1193 07.12.09 08:51 Сейчас в теме
36. nixoli 06.12.09 13:55 Сейчас в теме
38. kenshin 234 08.12.09 02:26 Сейчас в теме
народ отпишите, как вам и что под редактировать в дальнейшем, какая реакция бухгалтеров 717 скачало уже ))
Спасибо за Спасибо :!:
39. len2304 14.12.09 07:38 Сейчас в теме
а написать, что для обработки надо установить spchapi и движок Дигало, не надо было? :) или это все знают? :oops:
40. kenshin 234 14.12.09 14:33 Сейчас в теме
ну кому надо поймут, да и у большинства бухгалтеров нет колонок на рабочем месте все завалено макулатурой ;)
41. vlas 18.12.09 07:42 Сейчас в теме
В Новогодней зимней стуже
Пусть согреет Вашу кровь :
Елка, горка, добрый ужин
И взаимная любовь!
42. dobraleks 136 21.12.09 21:45 Сейчас в теме
43. dobraleks 136 22.12.09 22:24 Сейчас в теме
сижу вот под себя перестраиваю, впечатлений от данного поздравления море.
Автор порекомендовал бы Вам на кнопку повесить не просто стрелочки ">>" а добавить к примеру так " ЕЩЕ>>".

Не каждый сразу догадается что можно еще раз нажать на кнопку и будет продолжение, а так к примеру :
"Поздравляем" -- "Поздравляем! ЕЩЕ>>" --- "Поздравляем! ЕЩЕ>>" ----"Поздравляем!".
Я думаю Вы меня поняли что я имел ввиду!
:)
44. Littleboy72 24.12.09 13:52 Сейчас в теме
Подскажите новичку, как заставить обработку автоматически загружаться при входе пользователя, плизззззз :)
45. kenshin 234 28.12.09 11:24 Сейчас в теме
Процедура ПриНачалеРаботыСистемы()
ПредупредитьЗаДней=12;
ДатаСКоторойПоздравлять="31.12."+Строка(ДатаГод(ТекущаяДата()));
Если (НомерДняГода(ДатаСКоторойПоздравлять)-(НомерДняГода(ТекущаяДата()))<ПредупредитьЗаДней) и (НомерДняГода(ДатаСКоторойПоздравлять)-(НомерДняГода(ТекущаяДата()))>=0) тогда
НадоПоздравитьс8марта=Да;
КонецЕсли;
Если НадоПоздравитьс8марта=Да Тогда
ОбработкаПоздравление=КаталогИБ()+"extforms\Поздравляем.ert";
Если ФС.СуществуетФайл(ОбработкаПоздравление)=1 тогда
ОткрытьФорму("Отчет",,ОбработкаПоздравление);
КонецЕсли;
КонецЕсли;
КонецПроцедуры;
47. artbear 1184 28.12.09 17:12 Сейчас в теме
Выложил свой вариант поздравлялки для 8.1
http://infostart.ru/public/63428/
моя версия основана на данной обработке + серьезная переделка кода и т.п.
Подробнее на странице моей разработки.

ЗЫ долго ждал, пока кто-нибудь сделает для 8.1, но народ не спешил, пришлось самому заняться :)
52. a237 01.11.11 14:46 Сейчас в теме
53. artbear 1184 01.11.11 16:42 Сейчас в теме
(52) Спасибо лучше всего выразить плюсом за публикацию из (47)
48. bav 19 29.12.09 10:34 Сейчас в теме
В общем в старой комплексной (2.6) после запуска обработки - проявляется следующий глюк:
В гм следующие переменные:
Да=Перечисление.Булево.Да;
Нет=Перечисление.Булево.Нет;
До поздравлялки, соответственно: в отладчике Да=Да Нет=Нет
После запуска: Да="" Нет=""

Оказалось в обработке тоже эти переменные есть.((
А я уж на агента стал грешить.
49. kenshin 234 29.12.09 16:19 Сейчас в теме
Выложил свой вариант поздравлялки для 8.1
http://infostart.ru/public/63428/
моя версия основана на данной обработке + серьезная переделка кода и т.п.
Подробнее на странице моей разработки.

Я НАЧИНАЛ ДЕЛАТЬ НА 8-ке но как написано очень много переделки а времени свободного нет так что молодец что сделал народ надо баловать
50. kenshin 234 29.12.09 16:48 Сейчас в теме
НУ что какой следующий праздник делать ;) :idea:
51. a237 01.11.11 13:03 Сейчас в теме
Ставим юзерам- все довольны (и мы тоже) спасибо.
54. milkers 2407 19.12.18 11:31 Сейчас в теме
(0) Поздравление на управляемых формах https://infostart.ru/public/960899/
Оставьте свое сообщение

См. также

Мультфильм к новому году Промо

Поздравления v7.7 1cv7.md Россия Абонемент ($m)

Простенькая внешняя обработка, с мультфильмом, поднимающая настроение всем пользователям 1С.

1 стартмани

04.12.2012    16928    5    alf2006x    9    

С Новым Годом 2014

Поздравления v7.7 1cv7.md Россия Абонемент ($m)

Если кто-то еще до сих пор пользуется семеркой то бухгалтерам надеюсь понравится. Требует установленного Microsoft Agent.

1 стартмани

26.12.2013    13562    1    lushka    9    

С Новым Годом 2013!

Поздравления v7.7 1cv7.md Россия Абонемент ($m)

Доработанный вариант обработки Vital451 http://infostart.ru/public/166790/ Анекдоты, гороскоп и прочее наполнение позаимствованы отсюда http://infostart.ru/public/164866/

1 стартмани

28.12.2012    13275    0    lushka    6    

Поздравление с Новым Годом 2013

Поздравления v7.7 1cv7.md Абонемент ($m)

Поздравлялка с Наступающим 2013 от имени программистов. Содержит открытки, поздравления, гороскоп, советы проведения праздника.

1 стартмани

19.12.2012    16833    0    Vital451    20    

Поздравление с 8 Марта Промо

Поздравления v7.7 1cv7.md Россия Абонемент ($m)

Для наших любимых дам простое поздравление.

1 стартмани

25.01.2011    16097    2    kenshin    17    

Поздравление с новым годом 2012

Поздравления v7.7 1cv7.md Россия Абонемент ($m)

Поздравление с Новым Годом 2012 для 1С предприятие 7.7 порадуйте бухгалтеров

1 стартмани

30.11.2011    16091    0    kenshin    57    

Исполнитель желаний - можно ВСЁ!!! Скачай и получи в подарок 1 доллар США

Поздравления openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

от себя пожелаю тебе, всего того , чего нельзя купить за деньги... Здоровья, Любви, Удачи, Счастья, Славы, Успехов И настоящих верных Друзей С уважением, Tatitutu

1 стартмани

27.12.2010    19705    1    Tatitutu    70    

"пАздрАвлЯлкА" для семёрки ...

Поздравления v7.7 1cv7.md Россия Абонемент ($m)

Решил сделать «поздравлялку» с праздниками в 1С 7.7. Проблема в том, что если захотеть устроить калейдоскоп картинок формы (фона), то такой возможности в 7-ке нет. Поиском ничего не нашёл. Хоть и «первая программа» а радует. Решение искалось исключительно штатными средствами.

1 стартмани

13.12.2010    16328    2    Шёпот теней    37    

Оригинальное поздравление с 23 февраля ! Промо

Поздравления v7.7 1cv7.md Россия Абонемент ($m)

Поздравляю вас с 23 февраля, оригинально - как программист программистов. Это как раз тот случай , когда с кодом в конфигураторе очень приятно разбираться. Больше не скажу, но это стоит видеть ))) С праздником вас , мужики !

1 стартмани

21.02.2010    31342    3    Tatitutu    58    

Поздравление с Новым Годом 2011

Поздравления v7.7 1cv7.md Россия Абонемент ($m)

Поздравление с Новым Годом 2011. Внешний отчет с поздравительными картинками, который можно поставить в автозапуск 1С.

1 стартмани

23.11.2010    16418    0    kenshin    28    

Смешные "советы дня" для 1С77

Поздравления v77::БУ 1cv7.md Абонемент ($m)

Шутки вместо стандартных советов дня для любой базы 7.7.

1 стартмани

07.10.2009    13792    0    adapter    8    

МОЗГОДЕР - универсальное решение для пользователей

Поздравления v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Наконец то найдено универсальное решение всех проблем в 1С Решение практически любого вопроса и проблемы Более 1000 ! любых отчетов все на Ваш вкус. Стоит только сильно захотеть. Теперь пользователь не будет отвлекать Вас от важных дел. Он решит проблему сам.

1 стартмани

17.06.2009    20923    3    Tatitutu    22