Небольшая доработка УТ 10.3 для открытия денежного ящика из 1С для онлайн ККТ (ШТРИХ-М-01-Ф, ШТРИХ-М-02-Ф)

Оборудование - ККМ

Актуально для релиза: 10.3.41.1. Доработка УТ 10.3 для открытия денежного ящика из 1С для онлайн ККТ (ШТРИХ-М-01-Ф, ШТРИХ-М-02-Ф) + немного доработанная обработка обслуживания с функцией открытия денежного ящика.

Для открытия денежного ящика на форму чека ККМ "ФормаРегистрацииПродаж" нужно добавить кнопку, в обработчике прописать:

Процедура ДействияФормыОткрытьДенежныйЯщик(Кнопка)
			
	Если мФУ <> Неопределено Тогда
		Результат = ПолучитьСерверТО().ОткрытьДенежныйЯщик(мФУ);
		Если ЗначениеЗаполнено(Результат) Тогда
			ТекстОшибки = ПолучитьСерверТО().ПолучитьТекстОшибкиФРТО(Результат);
			Предупреждение(ТекстОшибки);
		КонецЕсли;
	КонецЕсли;
		
КонецПроцедуры

В переменной мФУ должен быть идентификатор ККТ.

В модуль объекта обработки "ТОСервер" добавить функцию:

Функция ОткрытьДенежныйЯщик(Идентификатор) Экспорт
	
	Обработка = Неопределено;
	Объект    = Неопределено;
	Результат = ПолучитьОбъектДрайвера(Идентификатор, Обработка, Объект);

	Если Не ЗначениеЗаполнено(Результат) Тогда
		Результат = Обработка.ОткрытьДенежныйЯщик(Объект);
		мОписаниеОшибки = Объект.ОписаниеОшибки;
	Иначе
		мОписаниеОшибки = ПолучитьТекстОшибкиПодключенияТО("ФР");
	КонецЕсли;

	Возврат Результат;
	
КонецФункции

В обработке обслуживания ShtrihMkkt.epf уже есть готовая функция ОткрытьДенежныйЯщик.

Скачать файлы

Наименование Файл Версия Размер
ShtrihMkkt.epf
.epf 279,59Kb
03.05.17
6
.epf 279,59Kb 6 Скачать

См. также

В этой теме еще нет сообщений.
Оставьте свое сообщение