Перенос данных из базы с поврежденными таблицами

Публикация № 631562

Администрирование - Администрирование данных 1С - Тестирование и исправление

Конвертация данных

15
У клиента что-то произошло с жестким диском, что потребовало восстановления данных на нем. Базу 1С вроде бы сохранили, и она даже открылась. Однако при попытке доступа к документу "Платежный ордер, списание денежных средств" база вылетает с ошибкой. Также при получении оборотов за период в целом и по декадам выводились разные цифры. Обработка переноса данных в идентичную конфигурацию не подошла, из-за того, что так же вылетала с ошибкой БД. Ниже опишу мои действия по созданию новой конфигурации.

При попытке доступа к документу "Платежный ордер списание денежных средств" база вылетает с ошибкой.

Ошибка СУБД:
Ошибка SQL: Таблица не найдена '_Document151_VT3126'
по причине:
Ошибка SQL: Таблица не найдена '_Document151_VT3126'

Так же (как выяснилось позже) при получении оборотов за период в целом и по декадам выводились разные цифры. 

Обработка переноса данных в идентичную конфигурацию не подошла, из за того, что так же вылетала с ошибкой БД.

Первой мыслью было перенести все документы, кроме битых. Однако ее даже не начал реализовывать, т.к. не хотелось бы бороться с пересортами.

Поэтому решил переносить документы вместе с движениями. Задача не замысловатая. В режиме "Предприятие" открыл обработку MD82Exp.epf. Снял все галки и выгрузил описание метаданных в XML файл

Далее запустил конвертацию данных 2.0 и загрузил метаданные в нее.

Так же создал новую конфигурацию но основе имеющейся конфигурации. Запустил ее, произвел первоначальную настройку. Это нужно для того, что бы на счетах, контролируемых системой была установлена соответствующая аналитика.

Далее все просто. Создал новую конвертацию и с помощью мастера автоматический создал правила конвертации объектов.

Нашел ПКО для документа "Платежный ордер списание денежных средств" и событии выгрузки "ПередВыгрузкой" написал два слова:

Отказ = Истина;

Так же с помощью мастера создал правила выгрузки данных.

Пришло время "испорченных" документов. Дело в том, что получить доступ к оборотам по счету я мог, и они включали движения документов, таблица которого повреждена. Поэтому я решил вытащить эти обороты из ОСВ. Для этого в настройках правил обмена на закладе "Алгоритмы/Запросы" создал новый запрос с именем БУ

ВЫБРАТЬ
	НАЧАЛОПЕРИОДА(БУ.Период, ДЕНЬ) КАК Дата,
	ИСТИНА КАК Активность,
	БУ.СчетДт,
	БУ.СчетКт,
	БУ.СубконтоДт1,
	БУ.СубконтоДт2,
	БУ.СубконтоДт3,
	БУ.СубконтоКт1,
	БУ.СубконтоКт2,
	БУ.СубконтоКт3,
	БУ.Организация,
	БУ.ВалютаДт,
	БУ.ВалютаКт,
	БУ.СтруктурноеПодразделениеДт,
	БУ.СтруктурноеПодразделениеКт,
	БУ.СуммаОборот КАК Сумма,
	БУ.ВалютнаяСуммаОборотДт КАК ВалютнаяСуммаДт,
	БУ.ВалютнаяСуммаОборотКт КАК ВалютнаяСуммаКт,
	БУ.КоличествоОборотДт КАК КоличествоДт,
	БУ.КоличествоОборотКт КАК КоличествоКт
ИЗ
	РегистрБухгалтерии.Типовой.ОборотыДтКт(, , Регистратор, , , СчетКт = ЗНАЧЕНИЕ(ПланСчетов.Типовой.ДенежныеСредстваНаТекущихБанковскихСчетах), , ) КАК БУ
ГДЕ
	ТИПЗНАЧЕНИЯ(БУ.Регистратор) = ТИП(Документ.ПлатежныйОрдерСписаниеДенежныхСредств)

УПОРЯДОЧИТЬ ПО
	БУ.Период

т.е. "вытащил" все проводки документа "ПлатежныйОрдерСписаниеДенежныхСредств". Периодичность "Регистратор" нужна для того, что бы можно было поставить отбор на его тип. Аналогично создал запрос НУ, который получает данные из налогового учета.

ВЫБРАТЬ
	НАЧАЛОПЕРИОДА(НУ.Период, ДЕНЬ) КАК Дата,
	ИСТИНА КАК Активность,
	НУ.СчетДт КАК СчетДт,
	НУ.СчетКт КАК СчетКт,
	НУ.СубконтоДт1 КАК СубконтоДт1,
	НУ.СубконтоДт2 КАК СубконтоДт2,
	НУ.СубконтоДт3 КАК СубконтоДт3,
	НУ.СубконтоКт1 КАК СубконтоКт1,
	НУ.СубконтоКт2 КАК СубконтоКт2,
	НУ.СубконтоКт3 КАК СубконтоКт3,
	НУ.Организация КАК Организация,
	НУ.ВидУчетаДт,
	НУ.ВидУчетаКт,
	НУ.СтруктурноеПодразделениеДт КАК СтруктурноеПодразделениеДт,
	НУ.СтруктурноеПодразделениеКт КАК СтруктурноеПодразделениеКт,
	НУ.СуммаОборот КАК Сумма,
	НУ.КоличествоОборотДт КАК КоличествоДт,
	НУ.КоличествоОборотКт КАК КоличествоКт
ИЗ
	РегистрБухгалтерии.Налоговый.ОборотыДтКт(, , Регистратор, , , СчетКт = ЗНАЧЕНИЕ(ПланСчетов.Налоговый.ДенежныеСредстваВКассеИНаРасчетныхСчетах), , ) КАК НУ
ГДЕ
	ТИПЗНАЧЕНИЯ(НУ.Регистратор) = ТИП(Документ.ПлатежныйОрдерСписаниеДенежныхСредств)

УПОРЯДОЧИТЬ ПО
	НУ.Период

Создал новое ПКО, где объект источник -- пустое значение, а объект приемник -- документ ОперацияБух. Назвал его ОперацияБухПО. Правила конвертации свойств для него так же заполнил автоматически. Создал в ручную ПравилоВыгрузкиДанных со следующими настройками Объект выборки: Не указан Способ выборки: Произвольный алгоритм Правило конвертации: ОперацияБухПО.

Организация = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, "ОсновнаяОрганизация");
БУ = Запросы.БУ.Выполнить().Выгрузить();
НУ = Запросы.НУ.Выполнить().Выгрузить();

Операции = БУ.Скопировать(,"Дата");
Операции.Свернуть("Дата");
Операции.Колонки.Добавить("Номер");
Операции.Колонки.Добавить("ПометкаУдаления");
Операции.Колонки.Добавить("Организация");
Операции.Колонки.Добавить("Автор");
Операции.Колонки.Добавить("Комментарий");
Операции.Колонки.Добавить("Ответственный");
Операции.Колонки.Добавить("Содержание");
Операции.Колонки.Добавить("СтруктурноеПодразделение");
Операции.Колонки.Добавить("ТиповаяОперация");
Операции.Колонки.Добавить("СуммаОперации");

Операции.Колонки.Добавить("Типовой");
Операции.Колонки.Добавить("Налоговый");
Операции.Колонки.Добавить("ЗапрашиваемыеПараметры");

Типовой = Неопределено;
Налоговый = Неопределено;	
ЗапрашиваемыеПараметры = Неопределено;

Выполнить(Алгоритмы.ПодготовитьТаблицыПроводок);

Год = 0;
СЦ = 0;
Для Каждого Операция ИЗ Операции Цикл
	Если Год <> Год(Операция.Дата) Тогда
		Год = Год(Операция.Дата);СЦ = 0;
	КонецЕсли;
	СЦ = СЦ+1;
	Операция.Номер = ПривестиНомерКДлине(Строка(СЦ),11,,"ПО-");
	Операция.ПометкаУдаления = ЛОЖЬ;
	Операция.ТиповаяОперация = Справочники.ТиповыеОперации.ПустаяСсылка();
	Операция.Организация = Организация;
	Операция.Комментарий = "Перенос проводок списания денежных средств за "+Формат(Операция.Дата,"ДФ='dd MMMM yyyy'");
	Операция.Автор = глТекущийПользователь;
	Операция.Ответственный = глТекущийПользователь;
	Операция.Содержание = Операция.Комментарий;
	//
	Операция.Типовой = Типовой.СкопироватьКолонки();
	Операция.Налоговый = Налоговый.СкопироватьКолонки();
	Операция.ЗапрашиваемыеПараметры = ЗапрашиваемыеПараметры.СкопироватьКолонки();
	Строки = БУ.НайтиСтроки(Новый Структура("Дата", Операция.Дата));
	
	СуммаОперации = 0;
	ТЧ = Операция.Типовой;
	Выполнить(Алгоритмы.ПолучитьПроводки);
	Операция.СуммаОперации = СуммаОперации;
	Строки = НУ.НайтиСтроки(Новый Структура("Дата", Операция.Дата));
	ТЧ = Операция.Налоговый;
	Выполнить(Алгоритмы.ПолучитьПроводки);
КонецЦикла;

ВыборкаДанных = Операции;

Что бы не плодить кучу документов сделал так, что бы обороты содились по дням, в независимости от того, сколько за этот день было фактические документов, создается одна операция.

В модуле, для сокращения его размера (и повышения читабельности) создание служебных таблиц вынес в алгоритмы. ПодготовитьТаблицыПроводок и ПолучитьПроводки

//ПодготовитьТаблицыПроводок
Типовой = Новый ТаблицаЗначений;
Типовой.Колонки.Добавить("Активность");
Типовой.Колонки.Добавить("ВалютаДт");
Типовой.Колонки.Добавить("ВалютаКт");
Типовой.Колонки.Добавить("ВалютнаяСуммаДт");
Типовой.Колонки.Добавить("ВалютнаяСуммаКт");
Типовой.Колонки.Добавить("ВидРегламентнойОперации");
Типовой.Колонки.Добавить("КоличествоДт");
Типовой.Колонки.Добавить("КоличествоКт");
Типовой.Колонки.Добавить("НомерЖурнала");
Типовой.Колонки.Добавить("Организация");
Типовой.Колонки.Добавить("Период");
Типовой.Колонки.Добавить("Регистратор");
Типовой.Колонки.Добавить("Содержание");
Типовой.Колонки.Добавить("СтруктурноеПодразделениеДт");
Типовой.Колонки.Добавить("СтруктурноеПодразделениеКт");
Типовой.Колонки.Добавить("СубконтоДт");
Типовой.Колонки.Добавить("СубконтоКт");
Типовой.Колонки.Добавить("Сумма");
Типовой.Колонки.Добавить("СчетДт");
Типовой.Колонки.Добавить("СчетКт");
Налоговый = Новый ТаблицаЗначений;
Налоговый.Колонки.Добавить("Активность");
Налоговый.Колонки.Добавить("ВидРегламентнойОперации");
Налоговый.Колонки.Добавить("ВидУчетаДт");
Налоговый.Колонки.Добавить("ВидУчетаКт");
Налоговый.Колонки.Добавить("КоличествоДт");
Налоговый.Колонки.Добавить("КоличествоКт");
Налоговый.Колонки.Добавить("НомерЖурнала");
Налоговый.Колонки.Добавить("Организация");
Налоговый.Колонки.Добавить("Период");
Налоговый.Колонки.Добавить("Регистратор");
Налоговый.Колонки.Добавить("Содержание");
Налоговый.Колонки.Добавить("СтруктурноеПодразделениеДт");
Налоговый.Колонки.Добавить("СтруктурноеПодразделениеКт");
Налоговый.Колонки.Добавить("СубконтоДт");
Налоговый.Колонки.Добавить("СубконтоКт");
Налоговый.Колонки.Добавить("Сумма");
Налоговый.Колонки.Добавить("СчетДт");
Налоговый.Колонки.Добавить("СчетКт");
ЗапрашиваемыеПараметры = Новый ТаблицаЗначений;
ЗапрашиваемыеПараметры.Колонки.Добавить("Значение");
ЗапрашиваемыеПараметры.Колонки.Добавить("Имя");
ЗапрашиваемыеПараметры.Колонки.Добавить("Представление");
//ПолучитьПроводки
Для Каждого Проводка ИЗ Строки Цикл
	СуммаОперации = СуммаОперации + Проводка.Сумма;
	стрТЧ = ТЧ.Добавить();
	ЗаполнитьЗначенияСвойств(стрТЧ, Проводка);
	стрТЧ.Период = КонецДня(Проводка.Дата);
	стрТЧ.СубконтоДт = Новый Соответствие;
	Если Проводка.СчетДт.ВидыСубконто.Количество() > 0 Тогда
		стрТЧ.СубконтоДт.Вставить(Проводка.СчетДт.ВидыСубконто[0].ВидСубконто, Проводка.СубконтоДт1);
	КонецЕсли;
	Если Проводка.СчетДт.ВидыСубконто.Количество() > 1 Тогда
		стрТЧ.СубконтоДт.Вставить(Проводка.СчетДт.ВидыСубконто[1].ВидСубконто, Проводка.СубконтоДт2);
	КонецЕсли;
	Если Проводка.СчетДт.ВидыСубконто.Количество() > 2 Тогда
		стрТЧ.СубконтоДт.Вставить(Проводка.СчетДт.ВидыСубконто[2].ВидСубконто, Проводка.СубконтоДт3);
	КонецЕсли;
	стрТЧ.СубконтоКт = Новый Соответствие;
	Если Проводка.СчетКт.ВидыСубконто.Количество() > 0 Тогда
		стрТЧ.СубконтоКт.Вставить(Проводка.СчетКт.ВидыСубконто[0].ВидСубконто, Проводка.СубконтоКт1);
	КонецЕсли;
	Если Проводка.СчетКт.ВидыСубконто.Количество() > 1 Тогда
		стрТЧ.СубконтоКт.Вставить(Проводка.СчетКт.ВидыСубконто[1].ВидСубконто, Проводка.СубконтоКт2);
	КонецЕсли;
	Если Проводка.СчетКт.ВидыСубконто.Количество() > 2 Тогда
		стрТЧ.СубконтоКт.Вставить(Проводка.СчетКт.ВидыСубконто[2].ВидСубконто, Проводка.СубконтоКт3);
	КонецЕсли;
КонецЦикла;

Алгоритм "ПодготовитьТаблицыПроводок" просто создает нужные ТЗ.

Алгоритм "ПолучитьПроводки" заполняет аналитику.

На этом, мне казалось, что все. Сохранил правила обмена. Выгрузил данные из битой конфы, загрузил в новую. Все прошло без ошибок.

Но тут меня ждал сюрприз с таблицами итогов. По видимому они тоже повредились, что привело к расхождению данных за период с разным видом оборотов.

По согласованию с заказчиком было решено перенести лишь входящие остатки на начало года. Для этого создал новый запрос ОСВ_БУ

ВЫБРАТЬ
     &ДатаОкончания КАК Дата,
	БУ.Счет КАК Счет,
	ИСТИНА КАК Активность,
	ВЫБОР  КОГДА БУ.Счет.Вид = &Активный ТОГДА БУ.Счет
			ИНАЧЕ &Счет0  КОНЕЦ КАК СчетДт,
	ВЫБОР КОГДА БУ.Счет.Вид = &Пассивный ТОГДА БУ.Счет
			ИНАЧЕ &Счет0 КОНЕЦ КАК СчетКт,
	ВЫБОР КОГДА БУ.Счет.Вид = &Активный ТОГДА БУ.Субконто1
			ИНАЧЕ NULL КОНЕЦ КАК СубконтоДт1,
	ВЫБОР КОГДА БУ.Счет.Вид = &Активный  ТОГДА БУ.Субконто2
			ИНАЧЕ NULL КОНЕЦ КАК СубконтоДт2,
	ВЫБОР КОГДА БУ.Счет.Вид = &Активный  ТОГДА БУ.Субконто3
			ИНАЧЕ NULL КОНЕЦ КАК СубконтоДт3,
	ВЫБОР КОГДА БУ.Счет.Вид = &Пассивный ТОГДА БУ.Субконто1
			ИНАЧЕ NULL  КОНЕЦ КАК СубконтоКт1,
	ВЫБОР КОГДА БУ.Счет.Вид = &Пассивный  ТОГДА БУ.Субконто2
			ИНАЧЕ NULL КОНЕЦ КАК СубконтоКт2,
	ВЫБОР КОГДА БУ.Счет.Вид = &Пассивный ТОГДА БУ.Субконто3
			ИНАЧЕ NULL КОНЕЦ КАК СубконтоКт3,
	ВЫБОР КОГДА БУ.Счет.Вид = &Активный ТОГДА БУ.Валюта
			ИНАЧЕ NULL КОНЕЦ КАК ВалютаДт,
	ВЫБОР КОГДА БУ.Счет.Вид = &Пассивный ТОГДА БУ.Валюта
			ИНАЧЕ NULL КОНЕЦ КАК ВалютаКт,
	ВЫБОР КОГДА БУ.Счет.Вид = &Активный ТОГДА БУ.СуммаОстатокДт
			ИНАЧЕ БУ.СуммаОстатокКт КОНЕЦ КАК Сумма,
	БУ.Организация,
	БУ.СтруктурноеПодразделение КАК СтруктурноеПодразделениеДт,
	БУ.СтруктурноеПодразделение КАК СтруктурноеПодразделениеКт,
	БУ.ВалютнаяСуммаОстатокДт КАК ВалютнаяСуммаДт,
	БУ.ВалютнаяСуммаОстатокКт КАК ВалютнаяСуммаКт,
	БУ.КоличествоОстатокДт КАК КоличествоДт,
	БУ.КоличествоОстатокКт КАК КоличествоКт
ИЗ
	РегистрБухгалтерии.Типовой.Остатки(&ДатаОкончания, , , ) КАК БУ
УПОРЯДОЧИТЬ ПО
	БУ.Счет.Код

который получает остатки по всем счетам. Создал правило правило выгрузки данных "Перенос ОСВ", так же по произвольному алгоритму. И указал для него следующий текст.

Организация = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, "ОсновнаяОрганизация");
Запросы.ОСВ_БУ.УстановитьПараметр("ДатаОкончания", ДатаОкончания);
Запросы.ОСВ_БУ.УстановитьПараметр("Счет0", ПланыСчетов.Типовой.Вспомогательный);
Запросы.ОСВ_БУ.УстановитьПараметр("Активный", ВидСчета.Активный);
Запросы.ОСВ_БУ.УстановитьПараметр("Пассивный", ВидСчета.Пассивный);

БУ = Запросы.ОСВ_БУ.Выполнить().Выгрузить();

Операции = БУ.Скопировать(,"Счет");
Операции.Свернуть("Счет");
Операции.Колонки.Добавить("Дата");
Операции.Колонки.Добавить("Номер");
Операции.Колонки.Добавить("ПометкаУдаления");
Операции.Колонки.Добавить("Организация");
Операции.Колонки.Добавить("Автор");
Операции.Колонки.Добавить("Комментарий");
Операции.Колонки.Добавить("Ответственный");
Операции.Колонки.Добавить("Содержание");
Операции.Колонки.Добавить("СтруктурноеПодразделение");
Операции.Колонки.Добавить("ТиповаяОперация");
Операции.Колонки.Добавить("СуммаОперации");

Операции.Колонки.Добавить("Типовой");
Операции.Колонки.Добавить("Налоговый");
Операции.Колонки.Добавить("ЗапрашиваемыеПараметры");

Типовой = Неопределено;
Налоговый = Неопределено;	
ЗапрашиваемыеПараметры = Неопределено;

Выполнить(Алгоритмы.ПодготовитьТаблицыПроводок);
СЦ = 0;
Для Каждого Операция ИЗ Операции Цикл
	СЦ = СЦ + 1;
	Операция.Номер = ПривестиНомерКДлине(Строка(СЦ),11,,"ОСВ-");
	Операция.Дата = ДатаОкончания;
	Операция.ПометкаУдаления = ЛОЖЬ;
	Операция.ТиповаяОперация = Справочники.ТиповыеОперации.ПустаяСсылка();
	Операция.Организация = Организация;
	Операция.Автор = глТекущийПользователь;
	Операция.Комментарий = "Перенос остатов по счету БУ "+Операция.Счет;
	Операция.Содержание = Операция.Комментарий;

	Операция.Типовой = Типовой.СкопироватьКолонки();
	Операция.Налоговый = Налоговый.СкопироватьКолонки();
	Операция.ЗапрашиваемыеПараметры = ЗапрашиваемыеПараметры.СкопироватьКолонки();
	
	Строки = БУ.НайтиСтроки(Новый Структура("Счет", Операция.Счет));
	ТЧ = Операция.Типовой;
	СуммаОперации = 0;
	Выполнить(Алгоритмы.ПолучитьПроводки);
	Операция.СуммаОперации = СуммаОперации;
КонецЦикла;

ВыборкаДанных = Операции;

После этого данные бух. учета у меня сели нормально.

Остались регистры накопления. Начну с правила выгрузки данных. т.к. ПКО зависит него. Назвал его "ОстаткиРегистрыНакопления". Они так же выгружаются по произвольному алгоритму Событие "ПередВыгрузкой" содержит следующий код:

ВыборкаДанных = Новый ТаблицаЗначений;
ВыборкаДанных.Колонки.Добавить("Автор");
ВыборкаДанных.Колонки.Добавить("Комментарий");
ВыборкаДанных.Колонки.Добавить("Организация");
ВыборкаДанных.Колонки.Добавить("Ответственный");
ВыборкаДанных.Колонки.Добавить("Дата");
ВыборкаДанных.Колонки.Добавить("Номер");
ВыборкаДанных.Колонки.Добавить("ТаблицаРегистровНакопления");

Запрос = Новый Запрос;
Имена = Новый Структура;

Запрос.УстановитьПараметр("Дата", ДатаОкончания+1);

Для Каждого Рег ИЗ Метаданные.РегистрыНакопления Цикл
	Если Рег.ВидРегистра = Метаданные.СвойстваОбъектов.ВидРегистраНакопления.Обороты Тогда
		Продолжить;			
	КонецЕсли;
	
	Запрос.Текст = "ВЫБРАТЬ * ИЗ РегистрНакопления."+Рег.Имя+".Остатки(&Дата)";
	Результат = Запрос.Выполнить();
	Если НЕ Результат.Пустой() Тогда
		Поля = "";
		Для Каждого Изм ИЗ Рег.Измерения Цикл
			Поля = Поля + Изм.Имя+",";
		КонецЦикла;
		Для Каждого Рес ИЗ Рег.Ресурсы Цикл
			Поля = Поля + Рес.Имя+"Остаток КАК "+Рес.Имя+",";
		КонецЦикла;
		
		Поля = Лев(Поля,СтрДлина(Поля)-1);
		Имена.Вставить(Рег.Имя,Поля);
		ВыборкаДанных.Колонки.Добавить(Рег.Имя);
	КонецЕсли;
КонецЦикла;

Стр = ВыборкаДанных.Добавить();
Стр.ТаблицаРегистровНакопления = Новый ТаблицаЗначений;
Стр.ТаблицаРегистровНакопления.Колонки.Добавить("Имя");
Стр.ТаблицаРегистровНакопления.Колонки.Добавить("Представление");

Для Каждого КиЗ ИЗ Имена Цикл
	сРг = Стр.ТаблицаРегистровНакопления.Добавить();
	сРг.Имя = КиЗ.Ключ;
	сРг.Представление = Метаданные.РегистрыНакопления[КиЗ.Ключ].Синоним;
	
	Запрос.Текст = "ВЫБРАТЬ ИСТИНА КАК Активность,
					|"+КиЗ.Значение+"
					|ИЗ РегистрНакопления."+КиЗ.Ключ+".Остатки(&Дата)";
					
	Стр[Киз.Ключ] = Запрос.Выполнить().Выгрузить();
	Стр[Киз.Ключ].Колонки.Добавить("ВидДвижения");
	Стр[Киз.Ключ].Колонки.Добавить("Период");
	Стр[Киз.Ключ].Колонки.Добавить("Регистратор");
	Стр[Киз.Ключ].ЗаполнитьЗначения(ВидДвиженияНакопления.Приход,"ВидДвижения");
	Стр[Киз.Ключ].ЗаполнитьЗначения(ДатаОкончания,"Период");
КонецЦикла;

Стр.Номер = "ОР-00000001";
Стр.Дата = ДатаОкончания;
Стр.Автор = глТекущийПользователь;
Стр.Организация = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глТекущийПользователь,"ОсновнаяОрганизация");
Стр.Комментарий = "Перенос остатков регистров накопления";
Стр.Ответственный = глТекущийПользователь;

т.е. у меня выгружаются только те регистры, которые имеют остатки.

Проверил в режиме "предприятие" эту обработку, и посмотрел, какие регистры имеют остатки. Создал ПКО для документ "КорректировкаЗаписейРегистров". В нем объект источник так же не указан.

В правила конвертации свойств добавил только те таблицы, которые мне нужны. При настройке ПКС для регистров необходимо снять галочки с реквизитов. т.к. по ним мы в любом случае не получим остатки, соответственно их переносить не нужно. Получилось вот такая картина На этом настройка закончилась, перенос данных отработал и все жили долго и счастливо :) А базы настроили на регулярную резервную архивацию на дисках, не связанных с диском БД!!!

15

Специальные предложения

Лучшие комментарии
9. the1 388 09.06.17 12:17 Сейчас в теме
(8) А можно было бы управиться за четверть часа
Консоль запросов -> Запрос к остаткам регистра -> Вывести список в табличный документ -> Загрузка данных из табличного документа в Документ.ОперацияБух или КорректировкаЗаписейРегистров

Тут на ИС есть инструменты, которые загружают движения РН
ВикторП; +1 Ответить
Остальные комментарии
Избранное Подписка Сортировка: Древо
1. trntv 08.06.17 09:43 Сейчас в теме
Почему ничего не написано про "Тестирование и исправление" из конфигуратора. К чему приводило, чем не подошло.
4. ermek6 22 08.06.17 18:19 Сейчас в теме
(1)
При тестировании база вылетала с той же ошибкой
2. iskdv 08.06.17 09:47 Сейчас в теме
начать с физики "Чек ДБ ФЛ"
5. ermek6 22 08.06.17 18:20 Сейчас в теме
(2) Да. Тоже была первая мысль. Но она ошибку не увидела
3. nk25 08.06.17 14:44 Сейчас в теме
6. ermek6 22 08.06.17 18:23 Сейчас в теме
(3)Нет. Если честно, то даже не искал особо. Да и способ вряд ли подошел бы.
Документ используется, а посему удалять объект конфигурации -- это не наш метод
Судя по тому, что по разным видам оборотов за один и тот же период выдавались разные суммы, были аналогичные проблемы и с служебными таблицами.

Причем картина такая, что неправильные данные подходили бухгалтеру, а вот правильные -- нет.
Это обнаружилось в новой базе, после переноса всех документов с движениями. В ней данные совпадали, и были не подходящими :)
7. nk25 09.06.17 06:05 Сейчас в теме
(6) сколько в итоге потратил времени на перенос?
8. ermek6 22 09.06.17 11:23 Сейчас в теме
(7) Делал в 2 подхода. Каждый часа по 3
9. the1 388 09.06.17 12:17 Сейчас в теме
(8) А можно было бы управиться за четверть часа
Консоль запросов -> Запрос к остаткам регистра -> Вывести список в табличный документ -> Загрузка данных из табличного документа в Документ.ОперацияБух или КорректировкаЗаписейРегистров

Тут на ИС есть инструменты, которые загружают движения РН
ВикторП; +1 Ответить
14. nvv1970 22.10.17 12:43 Сейчас в теме
(6)
по разным видам оборотов за один и тот же период выдавались разные суммы
Чтобы не задаваться такими вопросами нужно понимать как 1с хранит итоги и какие запросы (с какой периодичностью) их используют.
Цифры итогов не должны соответствовать бухгалтеру! Они должны соответствовать движениям! А уж где лишние движения - бухи и сами разберутся.
ИМХО конвертация - самый сложный метод для решения такого рода задач. SQL - наше все. Как минимум Select, Update, Delete должен уметь использовать любой 1с программист. Необычных случаев, сбоев в работе баз хватает. Делать какие-то глобальные переливки данных через 1с - нонсенс.
10. webester 29 10.06.17 09:29 Сейчас в теме
Странно, что никто никто не написал, что автору надо настроить бекапы. КЭПы в отпуска, что ли уехали.
nvv1970; dominatorwarr; +2 Ответить
11. echo77 1094 11.06.17 16:39 Сейчас в теме
У меня что-то с глазами или шрифты во всех формах имеют некий другой размер?
12. the1 388 13.06.17 11:22 Сейчас в теме
13. ermek6 22 13.06.17 18:21 Сейчас в теме
(11) Да просто я под убунтой сижу. специально по мельче сделал, что бы больше инфы влезало
Оставьте свое сообщение

См. также

EnterpriseData: простой способ защиты данных в базе получателя при одностороннем обмене 20

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Очень часто бухгалтеры ругаются, когда уже отраженные документы в бухгалтерском учета меняются сотрудниками.

04.10.2019    1594    handscenter    11       

Практика XDTO. Нюансы 51

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Обмен через XML

Некоторые практические моменты работы с XDTO. Дополнения к очевидному.

23.09.2019    3266    Yashazz    24       

Конвертация Данных. Нюансы использования конструкции "НеЗамещатьОбъект = Истина" в обработчике события "ПриЗагрузке" 28

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

У конвертации данных есть «особенности», которые «пьют кровь» программистов. Эта статья про очередную обнаруженную «особенность».

10.09.2019    1955    ivanek    21       

Обмен данными через Web Сервисы 80

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Ознакомительная статья о том, как загружать\выгружать данные с одной базы в другую, используя Web Сервисы.

02.09.2019    4079    user5300    27       

EnterpriseData – часть 3. Загрузка данных, идентификация объектов 61

Статья Программист Нет файла v8 v8::УФ 1cv8.cf ОС Бесплатно (free) Практика программирования Математика и алгоритмы Перенос данных из 1C8 в 1C8 Разработка

Основные этапы загрузки данных через EnterpriseData. Идентификация объектов загружаемых полностью и по ссылке. Приведены схемы процессов загрузки данных. Описание основных операций и обработчиков. Перечень процедур БСП, используемых при загрузке данных, структура «КомпонентыОбмена».

22.08.2019    3317    ids79    7       

Перенос дополнительных реквизитов в Конвертации данных 2.0 16

Статья Программист Нет файла v8 КД Россия УУ Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример написания правил обмена (КД 2.0) для переноса дополнительных реквизитов справочника "Номенклатура", в том числе перенос ПВХ с разными типами значений.

13.08.2019    1869    vikulinamari    3       

Конвертация 3.0. Пример доработки: два справочника в один 31

Статья Программист Нет файла v8 КД ERP2 БП3.0 Россия Бесплатно (free) Обмен через XML

Доработка правил конвертации путем расширения конфигурации: номенклатура и характеристика (ERP) в номенклатуру (БП).

15.05.2019    3140    forusing    4       

Полезные приемы при работе с Конвертацией данных 2.1. Логирование, интерактивное управление, дозаполнение и постпроведение документов 43

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Некоторые полезные приемы для КД 2.1, которые могут пригодиться как при доработке типовых правил, так и самописных.

22.04.2019    4061    maks_20    9       

MS SQL Ошибка СУБД: Предоставленный поток статистики разрушен. Как решить проблему с разрушенной статистикой 17

Статья Системный администратор Нет файла v8 1cv8.cf Бесплатно (free) Тестирование и исправление

MS SQL Ошибка СУБД: Предоставленный поток статистики разрушен... Как решить проблему с разрушенной статистикой

16.04.2019    2409    ikorulev    1       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7282    m-rv    16       

Работа с ComОбъектом 1С 8.2; 8.3 100

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Определение типов и значений через COM соединение между конфигурациями.

15.04.2019    10476    vik070777    12       

RabbitMQ + Конвертация Данных 3.0 178

Статья Системный администратор Программист Бизнес-аналитик Руководитель проекта Нет файла v8 КД Бесплатно (free) Внешние источники данных Обмен через XML Интеграция Перенос данных из 1C8 в 1C8

Предлагаем ознакомиться с хронологией проекта, проследить ход мыслей от снятия потребностей до реализации, и решить, удалось ли проектной команде найти оптимальное архитектурное решение под конкретный кейс заказчика путем совмещения двух известных, но до сих пор не пересекавшихся технологий, и получилось ли сложить плюсы и устранить минусы каждой из них.

21.03.2019    13707    barelpro    82       

Малоизвестная хитрость определения модуля и номера строки при возникновении исключения (без запуска отладки и конфигуратора). Несколько очень удобных, но малоиспользуемых возможностей работы в конфигураторе 302

Статья Программист Нет файла v8 Россия Бесплатно (free) Тестирование и исправление

В статье описана возможность получить место возникновения исключения при работе пользователей без участия конфигуратора. Подробно описаны еще некоторые очень полезные приемы при работе в отладке.

17.01.2019    16152    PoZiTiFFF    52       

Конвертация данных 2.1: поиск по условию 18

Статья Программист Нет файла v8 КД ERP2 Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

Задача. При обмене документами "Реализация товаров и услуг", поиск контрагента осуществлять по полям "ИНН", "КПП". Если вид договора с комиссионером, то поиск осуществлять по полям "ИНН", "КПП", "Наименование".

15.01.2019    5667    wowik    13       

Восстановление базы 1С, ошибка источника потока 89

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) Тестирование и исправление

Очередной кирпичик в основу решения проблемы восстановления работоспособности базы после динамического обновления.

09.01.2019    10566    idle    23       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12640    ids79    27       

Новый подход к обмену данными EnterpriseData 203

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21292    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 118

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    18803    ids79    20       

Заметки КД 2.1: Как передать файл, динамически создаваемый в источнике, в справочник присоединенных файлов приемника 25

Статья Программист Нет файла v8 КД Россия Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

В БП 3.0 есть документ "Книга Продаж Для Передачи В ЭлектронномВиде" из которого выгружается XML файл. Задача: Нужно из БП 3.0 посредством правил обмена, вместе с документом книга продаж сформировать и перенести XML файл в базу приемник. В приемнике файл будет храниться в справочнике "Книга Продаж Присоединенные Файлы".

10.10.2018    5297    Viktor_Ermakov    6       

Планы обмена 1С 158

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

В статье - мастер-классе Дмитрий Жичкин рассказывает, для чего нужны планы обмена 1С и какие задачи они решают. Он подробно описывает физическую структуру планов обмена и механизмов регистрации изменений, рассматривает основные проблемы, возникающие при выгрузке изменений и предлагает методы их решения.

10.09.2018    30056    zhichkin    4       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19233    olegtymko    43       

hsИнтегратор - технология онлайнового обмена данными между базами на платформе 1С:Предприятие. Использование технологии в виде расширения, без изменения конфигураций баз данных, участвующих в обмене 33

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

hsИнтегратор : Простое в использовании решение, работает в качестве клиента и сервиса (в мобильном приложении – только клиента). Не обязательно требует внесения изменений в конфигурации интегрируемых баз данных. Маленький трафик обмена между клиентом и сервером, быстрая реакция на запросы со стороны клиента. Единый сервис для обмена данными различной структуры, механизмы для обеспечения безопасности.

25.06.2018    8570    12    hobi    8       

Обмен через универсальный формат. Пример нестандартной конвертации данных 82

Статья Программист Нет файла v8 УТ11 Россия Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

В статье описан небольшой пример обмена данными через EnterpriseData без снятия конфигурации с поддержки. Тестовая площадка: Управление торговлей, редакция 11 (11.4.3.126), версия платформы 8.3.11

18.06.2018    22223    artkor    12       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІІ: Регистры сведений 16

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Часть III публикаций об универсальном обмен через REST интерфейс OData - обмен регистрами сведений

26.05.2018    6305    V.Stavinsky    3       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІ: Документы 30

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Продолжение статьи об универсальном обмене между идентичными конфигурации через REST интерфейс OData (https://infostart.ru/public/829356/). В части второй разберем особенности обмена документами.

19.05.2018    7640    V.Stavinsky    5       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники 96

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    16174    V.Stavinsky    11       

Как написать обмен с 50 поставщиками и не сойти с ума. Техника 20

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

О том как из обмена с одним идеальным поставщиком сделать обмены с 50 реальными поставщиками.

16.04.2018    6868    m-rv    1       

Перенос помеченных на удаление объектов. Конвертация 2.1 18

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Иногда при переносе данных возникает задача: не переносить помеченные на удаление документы, а те документы, которые были ранее перенесены в базу приемник и теперь в приемнике стали помеченными на удаления - переносить так, чтобы в базу приемник не тянулись связанные с объектом ссылки, но искомый объект помечался на удаление. В данной статье будет рассказано, как это можно сделать достаточно просто, используя конфигурацию "Конвертация 2.1".

02.04.2018    10116    Shmell    2       

Настройка обмена через универсальный формат между СВОЕЙ КОНФИГУРАЦИЕЙ и ТИПОВОЙ, не снимая типовую с поддержки (+ фишка БСП) 53

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Возникла необходимость настроить синхронизацию между своей отраслевой конфигурацией и Бухгалтерией 3.0, основным условием было - НЕ снимать Бухгалтерию с поддержки. Предлагаю краткую инструкцию + одну "фишку" БСП, которая по умолчанию не отображается.

25.12.2017    19808    tmn72.1C    18       

Как самому написать обмен между Бухгалтерией 2.0 и ЗУП 3.1. (Часть 1) 29

Статья Программист Нет файла v8 БП2.0 ЗУП3.x БУ Windows Зарплата Бесплатно (free) Перенос данных из 1C8 в 1C8

Речь пойдет о том, как можно осуществить переход на ЗУП 3.1 и при этом сохранить работоспособность системы обмена, написав свой обмен между конфигурациями разных поколений в Конвертации данных. В этой части речь пойдет только об документе Отражения зарплаты (перенос начислений).

15.12.2017    11304    alex_bitti    0       

Конвертация данных. Выгрузка контактной информации из регистра сведений в табличную часть 20

Статья Программист Нет файла v8 КД Бесплатно (free) Обмен через XML

Довольно часто встречается задача выгрузить при помощи «Конвертация данных, редакция 2.1» контактной информации контрагента из «Управление торговлей", редакция 10.3» в «Бухгалтерия предприятия, редакция 3.0». Сложность заключается в том, что в УТ контактная информация хранится в регистре сведений, а в БП - в табличной части справочника «Контрагенты». Предлагаю мое, достаточно простое, решение данной задачи.

11.12.2017    14935    Nicholas    9       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 720

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    137205    MaxS    251       

Обмен между базами 1С 8.3. Доработка типового плана обмена (синхронизации) между конфигурациями 1С на примере обмена 1С: Зарплата и управление персоналом 3 и 1С: Бухгалтерия предприятия 3 112

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Для чего нужно изучить данную статью и когда эти знания могут пригодиться? В первую очередь приведенная ниже информация потребуется программистам 1С, когда перед ними встанет задача доработать типовой обмен между конфигурациями, который настроен через синхронизацию данных, т.е. по плану обмена. Что же такое «План обмена»? План обмена в 1С – это объект, который входит в состав метаданных конфигурации и служит для синхронизации данных между информационными базами.

09.11.2017    49442    user858846    36       

Конвертация данных. Удобная навигация (Открыть алгоритм или запрос) v0.5 48

Статья Программист Нет файла v8 КД Россия Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Цель: выявить (зафиксировать) и реализовать удобную навигацию в КД, например: -Открытие алгоритмов в правилах конвертации объектов и правилах выгрузки данных.

27.10.2017    9107    Trise    6       

1С: Конвертация данных 2. Разработка с "нуля" на простых примерах разработки 155

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

1. Вступление 2. Что понадобится: конфигурация 1С: Конвертация данных 2. и обработки из пакета. Для примера задач возьмем конфигурации 1С: Управление торговлей 11 и 1С: БП 3.*. 3. Нам понадобятся Обработки для выгрузки структуры метаданных и обмена. 4. Выгрузка структуры метаданных конфигурации 1С: Управление торговлей 11.3 и 1С: Бухгалтерия предприятия 3.0.* 5. Загрузка структур метаданных конфигураций в базу конвертации. 6. Создание правил конвертации в 1С на конкретном примере задачи. 7. Подводим итоги: Выгрузка и загрузка данных с помощью разработанных правил обмена данными.

26.10.2017    57626    somel    21       

Основные концепции Конвертации данных (КД) для новичков 120

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

В КД очень важно понять основные принципы работы. Вроде и самой КД сто лет в обед, и понаписано уже не счесть, но все как-то не так, как мне бы хотелось. Постепенно крепло желание написать эдакое послание самому себе, начинающему изучать КД, да никак руки не доходили. Последней каплей стала очередная попавшаяся на глаза "неправильная" статья, и я решил - ничего страшного, пусть будет еще одна статья, зато гештальт закрою :) Даже если я излишне самонадеян, авось кому-то она все же поможет. Скриншотов не будет, будет только унылый текст. Но я бы в свое время за него многое отдал. Чтобы не перегружать статью, в ней не освещаются особенности вроде правил регистрации, особенностей КД 3.0 и т.п.

17.10.2017    23516    herfis    26       

Настройка автоматического обмена между конфигурациями Управление торговлей 10.3 и Управление торговлей 11. 3 при помощи механизмов планов обмена и правил обмена 54

Статья Программист Нет файла v8 УТ10 УТ11 Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

В статье описывается методика настройки автоматического обмена между конфигурациями УТ 10 -УТ 11 3 при помощи механизмов планов обмена и правил обмена

25.09.2017    14106    The Ded    18       

Правила конвертации между регистрами сведений подчиненным регистратору и независимым 16

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Принцип настройки правил обмена в БСП между регистрами сведений, когда один из них подчинен регистратору, а второй независимый.

31.08.2017    12633    Pervuy    2       

Что такое конвертация данных 1С (статья написана исключительно для новичков) 79

Статья Программист Стажер Нет файла v8 КД Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

О том, что "Конвертация данных" - мощный инструмент и прочую терминологию, вы прочтёте в любом источнике. Я хочу поделиться кратким пояснением как пользоваться данной конфигурацией. Речь пойдет о версии 2.1.

07.08.2017    29392    perepetulichka    33       

Окно "Зарегистрировано 0 изменений из 1 на узле "Имя узла"" 14

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Тестирование и исправление

Почему может появляться окно предупреждения "Регистрация изменений" с текстом " Зарегистрировано 0 изменений из 1 на узле "Имя узла" "" ? Как исправить проблему?

02.08.2017    15428    StudentM    3       

Отладка не работает, или отладка фоновых заданий 15

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Тестирование и исправление

На написание данной статьи вдохновила статья http://infostart.ru/public/633522/ Я разработчик старой формации, до сих пор обслуживаю клиентов на платформах 7.7, 8.1, 8.2, времени изучать все мануалы и отслеживать новые тенденции не хватает. Цель этой статьи помочь разработчикам, таким же людям, как и я. Если эта статья сэкономит, хотя бы, 1 человеко-час жизни, значит, написана не зря.

16.06.2017    16341    IvanovAV    22       

Когда перестает работать отладчик 105

Статья Системный администратор Программист Нет файла v8 Россия Windows Бесплатно (free) Тестирование и исправление

Полагаю, некоторые коллеги уже оказывались в ситуации, когда отладка внезапно пропадала, и различные "шаманские" методики (переустановка платформы, чистка локального кэша и прочее) результата не давали. Опишу свой опыт по выявлению и устранению причины.

13.06.2017    21247    mickey.1cx    20       

Использование инструментов разработчика для отладки обменов КД 2.0 67

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Пара трюков, благодаря которым жить становится намного проще...

05.05.2017    22540    unichkin    3       

Ошибка формата потока. Решение с описанием проблемы 103

Статья Системный администратор Нет файла v8 1cv8.cf Россия Бесплатно (free) Тестирование и исправление

Ошибка формата потока. Страшная, но симпатишная своей загадочностью. 1С ничего толком не объясняет и не подсказывает. Ниже решение, которое мне помогает решать данную проблему на 100%. Всё очень просто. Данная ошибка возникает (на моей практике) только у клиент серверного варианта. просто потому что с другим форматом не работаю. Рекомендация: Старайтесь избегать динамического обновления, особенно если у вас возможны кратковременные проблемы с 220 и LAN. Далее описание лечения:

25.04.2017    20657    juker    1       

Работа с конвертацией данных 349

Статья Программист Нет файла v8 КД Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Поскольку к конвертации обращаюсь время от времени и какие-то детали забываются, хочу выделить несколько пунктов, чтобы "было где посмотреть". Статья сделана преимущественно «для себя», так что просьба не судить строго. (Примечание читающим/комментирующим: код в примерах очень сильно сокращен.)

16.03.2017    61723    perepetulichka    25