Исправление ошибки в декларации НДС за 4 кв 2009 для Предприниматель 7.7

Печать - Регламентированная отчетность

4
В 1С.Предприниматель 7.7 - регламентированная отчетность за 4 кв 2009 в декларации НДС ошибка, не позволяющая сформировать разделы (формирует корректно только титульный лист). Исправить можно заменив процедуру "Заполнить реквизиты" в файлах отчета: NDS902.ert - NDS910.ert на исправленную:

Заменяете Процедуру "Заполнить реквизиты" во всех файлах отчета декларации НДС (не путаем со старыми формами, их 1С оставило в комплекте отчетности), на м нужно исправить файлы отчетности : NDS902.ert - NDS910.ert. В указанных 8 файлах заменяем 1С ную процедуру на такой код: //*******************************************************************************
Процедура ЗаполнитьРеквизиты( ИзмФирма=0 )
                 
    СписокДанных = СоздатьОбъект( "СписокЗначений" );
        
    Если ИдентКонфигурации <> "NLGPL" Тогда
       
        СписокДанных.Установить( "Контекст",         Контекст );
        СписокДанных.Установить( "Дата",             Дата2 );
        СписокДанных.Установить( "ИНН",             "" ); 
           
        СписокДанных.Установить( "КаталогХранения", "" );
       
        Попытка
            глПолучитьДанные( СписокДанных );  
        Исключение
        КонецПопытки;   
       
        ОргИНН = СписокДанных.Получить( "ИНН" );     
        ИНН       = СРЕД(ОргИНН, 1, 10);
        КПП       = СРЕД(ОргИНН, 12,20);
       
    Иначе
        // для конфигурации 1С:Налогоплательщик     
        СписокДанных.Установить( "Контекст",        Контекст );
        СписокДанных.Установить( "Дата",            Дата2 );
        СписокДанных.Установить( "ИНН",             "" );
        СписокДанных.Установить( "КППЮЛ",           "" );
   
        СписокДанных.Установить( "КаталогХранения", "" );
       
        Попытка
            глПолучитьДанные( СписокДанных );  
        Исключение
        КонецПопытки;
       
        ОргИНН = СписокДанных.Получить( "ИНН" );
        ОргКПП = СписокДанных.Получить( "КППЮЛ" );
        ИНН       = СРЕД(ОргИНН, 1, 10);
        КПП    = ОргКПП;
       
    КонецЕсли;   
    Если СтрДлина(ОргИНН) <> 12 Тогда
        // Налогоплательщик - юр. лицо       
        ИНН = "00" + ИНН;       
    Иначе                                    
        // Налогоплательщик - физ. лицо
        ИНН = ОргИНН;
        КПП = "";       
    КонецЕсли;     
  
    Если  ПустоеЗначение(КаталогХранения)=1 Тогда
        // Определяем каталог хранения из ИБ
        КаталогХранения = СокрЛП(СписокДанных.Получить("КаталогХранения"));
    КонецЕсли;         
   
    ЗаполнитьИНН_КПП();
             
КонецПроцедуры // ЗаполнитьРеквизиты()

4

См. также

Специальные предложения