Предварительный просмотр прикрепленных файлов

Программирование - Работа с интерфейсом

7
Демонстрация добавления функционала предварительного просмотра прикрепленных файлов.

Здравствуйте, уважаемые читатели. Сразу скажу, что мой метод не претендует на звание самого лучшего! Просто решил продемонстрировать, как можно сделать предварительный просмотр прикрепленных фотографий или картинок к документам или справочникам. Использовал этот механизм в своей самописной конфигурации на базе БСП 2.2 Итак, приступим.

  1. Первое что нужно сделать - это добавить в общую форму Присоединенные файлы реквизит формы - СсылкаНаКартинку (тип: Строка неограниченной длины);
  2. Размещаем созданный реквизит на форме, и устанавливаем вид реквизита - Поле картинки
  3. В обработчике При активизации строки табличной части Список прописываем код:
&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
    //для вывода предварительного просмотра изображения
    Если Элементы.Список.ТекущиеДанные <> Неопределено Тогда
        ДанныеФайла = ПолучитьДанныеФайла(Элементы.Список.ТекущиеДанные.Ссылка, УникальныйИдентификатор);
        Если ДанныеФайла.Расширение = "jpg"
            ИЛИ ДанныеФайла.Расширение = "jpeg"
            ИЛИ ДанныеФайла.Расширение = "png"
            ИЛИ ДанныеФайла.Расширение = "gif" Тогда
            СсылкаНаКартинку = ДанныеФайла.СсылкаНаДвоичныеДанныеФайла;        
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Вот как легко и просто создать функционал по предварительному просмотру прикрепленных фотографий или картинок :)

7

См. также

Лучшие комментарии
2. vgrichuk 25.09.17 10:02 Сейчас в теме
правильнее было бы при активизации строки подключить обработчик ожидания, чтобы при быстром перемещении по списку не дергать напрасно картинки.
Остальные комментарии
Сортировка: Древо
1. rpgshnik 824 08.09.17 04:25 Сейчас в теме
Если храниться в базе то решение давно есть в типовой.
Если храниться не в базе то куча подобных:
https://infostart.ru/public/370818/
https://infostart.ru/public/120714/
https://infostart.ru/public/293839/
3. CBo6oDa 04.10.17 08:19 Сейчас в теме
(1) Не важно где хранятся файлы. В БСП 2.3.1 реализван подобный фунционал.
2. vgrichuk 25.09.17 10:02 Сейчас в теме
правильнее было бы при активизации строки подключить обработчик ожидания, чтобы при быстром перемещении по списку не дергать напрасно картинки.
Оставьте свое сообщение