Шамсутдинов Артем | Руководитель проектов автоматизации | ООО «ОйлГИС»

«Советы бывалого: практика внедрения 1С:ERP в машиностроении.»

1) Предпосылки внедрения. Почему не 1С:УПП 2) Выбор партнера (франчайзи), а так ли он необходим? 3) Работа только на типовом функционале. Какого это? 4) Внедрение складского учета и интеграция с торговым оборудованием 5) Диспетчеризация производства. Разработка АРМов, подключение POS-терминалов. Что? Где? Когда? 6) Как учитывать инструментальное оснащение в производстве? 7) Как узнать все потребности в материалах по всем заказам и планируемым заявкам в один клик? 8) Автоматизация простого документооборота и системы оповещений (SMS, E-Mail) в 1С:ERP через расширение конфигурации.

Перезапись или отключение всех регламентных заданий. ОФ+УФ

Администрирование - Системное

В файловой базе нельзя простым способом отключить все регламентные задания - нужно открывать монитор и щелкать галочки по всем включенным задачам. В БП 3 конфигурация сама спрашивает, была ли база скопирована, и для копии отключает регламентные задания. В остальных конфигурациях проще отключить все регламентные задания. Также обработка умеет перезаписывать регламентные задания - на некоторых серверах это позволяет реанимировать выполнение регламентных заданий 1С, не перезапуская сервер.

Можно было включить обработку в монитор, но целью было сделать простенькую обработку из двух кнопок для обычных и управляемых форм.

 

Обычная форма:

 

 

Управляемая форма:

 

 

Пример работы в УТ11, список заданий до выполнения отключения:

 

 

Список заданий после выполнения отключения:

 

 

Рекомендую после отключения сразу выйти из 1С, чтобы отключились фоновые задания, запущенные под текущим сеансом.

 

Если требуется чтобы и при первом запуске 1С не запускались регламентные задания, можно использовать ключ:

    /AllowExecuteScheduledJobs –Off

 

Код обработки простейший:

Функция ПерезаписатьВсеРегламентныеЗадания () Экспорт
    М = РегламентныеЗадания.ПолучитьРегламентныеЗадания();
    Для Каждого РЗ из М Цикл
        РЗ.Записать();
        Сообщить(РЗ);
    КонецЦикла;
КонецФункции

Функция ОтключитьВсеРегламентныеЗадания () Экспорт
    М = РегламентныеЗадания.ПолучитьРегламентныеЗадания();
    Для Каждого РЗ из М Цикл
        РЗ.Использование = ложь;
        РЗ.Записать();
        Сообщить(РЗ);
    КонецЦикла;
    Сообщить("Все регламентные задания отключены!");
КонецФункции

 

Скачать файлы

Наименование Файл Версия Размер
Перезаписать или отключить все регламентные задания ОФ+УФ:
.zip 5,44Kb
13.10.17
7
.zip 5,44Kb 7 Скачать

См. также

Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение