УкрПочта - групповая проверка трек-номеров

Публикация № 689803

Разработка - Системная интеграция - Интеграция с WEB

9
Необходимо в течение относительно небольшого промежутка времени получить актуальное состояние по трек номеру в системе УкрПочта большого количества сообщений? Тогда во второй раз воспользуемся неофициальным парсингом страницы сервиса УкрПочты.

После написания предыдущей статьи про отслеживание одного трек кода (//infostart.ru/public/649861/) произошло три события:

- Сервис http://services.ukrposhta.ua/bardcodesingle/ перешел в режим нетрудоспособности, встречая своих посетителей обнадеживающей надписью о том, что в ближайшее врем все опять будет работать. 

- УкрПочта запустила новый сервис по адресу http://ukrposhta.ua/ua/vidslidkuvati-forma-poshuku и добавила изюминку в виде "невидимой" рекапчи от Google ("невидимый" режим - это отсутствие какого-либо намека на ввод капчи (даже банальной галочки "Я не робот") до тех пор пока Google не считает Вас ботом. Если считает - то всплывает капча).

- Мы наконец-то доделали возможность проверять последний статус групповым запросом (до 240 треков за раз), используя сервис по адресу http://services.ukrposhta.ua/barcodestatistic Скорость работы одного такого запроса на 240 записей намного больше чем аналогичные 240 запросов по одному треку.

Как и в прошлый раз, при помощи программы Fiddler подсматриваем протокол общения и внедряем его у себя.

Изначально запрос GET идет первый раз без указания файла на страницу http://services.ukrposhta.ua/barcodestatistic/default.aspx, в которой мы узнаем Cookies и значения переменных hiddenSessionGuid и VIEWSTATE. Формируем запрос и отправляем его по тому же адресу, но уже методом POST. Собственно, сами функции (в качестве параметра функции ОтслеживаниеПосылкиУкрПочта - массив со списком трек номеров).

Функция RegExp_Exec(Текст,ШаблонРегВыр)
	RegExp = Новый COMОбъект("VBScript.RegExp");
    RegExp.IgnoreCase = Ложь; 
    RegExp.Global = Истина;
    RegExp.MultiLine = Ложь;
	Текст_ = Новый ТекстовыйДокумент;
	Текст_.ДобавитьСтроку(текст);
	Для а=0 по текст_.КоличествоСтрок() Цикл
		строка = Текст_.ПолучитьСтроку(а);
		RegExp.Pattern = ШаблонРегВыр;
		Matches=RegExp.Execute(строка);
	    ЧислоВхождений=Matches.Count();
	    Если ЧислоВхождений>0 Тогда 
            Match = Matches.Item(0);
			Значение = Match.Submatches.Item(0);
            Прервать;
		КонецЕсли;
	КонецЦикла;		
	Возврат СокрЛ(Значение);
КонецФункции




Функция ОтслеживаниеПосылкиУкрПочта(Знач Данные)
	Соединение = Новый HTTPСоединение("services.ukrposhta.ua"); 
	ЗаголовокHTTP = Новый Соответствие(); 
	ЗаголовокHTTP.Вставить("Host", "services.ukrposhta.ua"); 
	ЗаголовокHTTP.Вставить("Upgrade-Insecure-Requests", "1");
	ЗаголовокHTTP.Вставить("User-Agent", "Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36");
	ЗаголовокHTTP.Вставить("Accept", "text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8");
	ЗаголовокHTTP.Вставить("Accept-Encoding", "deflate");
	ЗаголовокHTTP.Вставить("Accept-Language", "ru-RU,ru;q=0.8,en-US;q=0.6,en;q=0.4");
	Запрос = Новый HTTPЗапрос("/barcodestatistic/Default.aspx",ЗаголовокHTTP); 
	Ответ = Соединение.Получить(Запрос); 
	ОтветВВидеСтроки = Ответ.ПолучитьТелоКакСтроку();
	Cookie = ответ.Заголовки.Получить("Set-Cookie");
	поз = Найти(Cookie,";");
	Если поз>0 тогда
		Cookie=Лев(Cookie,поз-1);
	КонецЕсли;
	ЗначениеVIEWSTATE = RegExp_exec(ОтветВВидеСтроки,"<input type=""hidden"" name=""__VIEWSTATE"" id=""__VIEWSTATE"" value=[^>](.*)"" />");
	ЗначениеhiddenSessionGuid = RegExp_exec(ОтветВВидеСтроки, "<input type=""hidden"" name=""ctl00\$centerContent\$hiddenSessionGuid"" id=""ctl00_centerContent_hiddenSessionGuid"" value=[^>](.*)"" />");
	Boundary ="----WebKitFormBoundaryLQSVHmY12nEZdO0l";
	ЗаписьТекста=("--" + Boundary);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("Content-Disposition: form-data; name=""__VIEWSTATE""" + Символы.ВК + Символы.ПС);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+(ЗначениеVIEWSTATE);	   
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("--" + Boundary);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("Content-Disposition: form-data; name=""__VIEWSTATEGENERATOR""" + Символы.ВК + Символы.ПС);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("0D589B25");	
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("--" + Boundary);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("Content-Disposition: form-data; name=""ctl00$centerContent$hiddenSessionGuid""" + Символы.ВК + Символы.ПС);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+(ЗначениеhiddenSessionGuid);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("--"+Boundary);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("Content-Disposition: form-data; name=""ctl00$centerContent$fileUploadXmlBarcodes""; filename=""re.txt""");
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("Content-Type: text/plain");
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС;
	Для тмп=0 по Данные.Количество()-1 Цикл 
		ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+(Данные.Получить(тмп));	
	КонецЦикла;
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("--" + Boundary);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("Content-Disposition: form-data; name=""ctl00$centerContent$btnUpload""" + Символы.ВК + Символы.ПС);
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("Пошук");
	ЗаписьТекста=ЗаписьТекста+Символы.ВК + Символы.ПС+("--" + Boundary+"--")+Символы.ВК + Символы.ПС;
	РазмерФайлаОтправки = Формат(СтрДлина(ЗаписьТекста)+3,"ЧГ=");			
		
		
	ЗаголовокHTTP = Новый Соответствие(); 
	ЗаголовокHTTP.Вставить("Host", "services.ukrposhta.ua"); 
	ЗаголовокHTTP.Вставить("Cache-Control", "max-age=0");
	ЗаголовокHTTP.Вставить("Origin", "http://services.ukrposhta.ua");
	ЗаголовокHTTP.Вставить("Upgrade-Insecure-Requests", "1");
	ЗаголовокHTTP.Вставить("User-Agent", "Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36");
	ЗаголовокHTTP.Вставить("Accept", "text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8");
	ЗаголовокHTTP.Вставить("Referer", "http://services.ukrposhta.ua/barcodestatistic/Default.aspx");
	ЗаголовокHTTP.Вставить("Accept-Encoding", "deflate");
	ЗаголовокHTTP.Вставить("Accept-Language", "ru-RU,ru;q=0.8,en-US;q=0.6,en;q=0.4");
	ЗаголовокHTTP.Вставить("Cookie", Cookie); 
	ЗаголовокHTTP.Вставить("Content-Type", "multipart/form-data; boundary=" + Boundary);
	ЗаголовокHTTP.Вставить("Content-Length", РазмерФайлаОтправки);
		
	Запрос = Новый HTTPЗапрос("/barcodestatistic/Default.aspx",ЗаголовокHTTP); 
	Запрос.УстановитьТелоИзСтроки(ЗаписьТекста,КодировкаТекста.UTF8,ИспользованиеByteOrderMark.НеИспользовать);	
	Ответ = Соединение.ОтправитьДляОбработки(Запрос); 
	ОтветВВидеСтроки = Ответ.ПолучитьТелоКакСтроку();
	ЧтениеHTML = Новый ЧтениеHTML;
	ЧтениеHTML.УстановитьСтроку(ОтветВВидеСтроки,"UTF-8");
	тз = НОвый ТаблицаЗначений;
	тз.Колонки.Добавить("Номер");
	тз.Колонки.Добавить("Дата_");
	тз.Колонки.Добавить("Код_");
	тз.Колонки.Добавить("Описание");
	
	ПостроительDOM = Новый ПостроительDOM;
	ДокументHTML = ПостроительDOM.Прочитать(ЧтениеHTML);
	всякое = ДокументHTML.ПолучитьЭлементыПоИмени("td");
	индекс = 0;
	Пока индекс < всякое.Количество() Цикл
		НС = тз.Добавить();
		НС.Номер = СокрЛП(всякое.Элемент(индекс).ТекстовоеСодержимое);
		НС.Дата_ = СокрЛП(всякое.Элемент(индекс+2).ТекстовоеСодержимое);
		НС.Код_ = СокрЛП(всякое.Элемент(индекс+3).ТекстовоеСодержимое);
		НС.Описание = СокрЛП(всякое.Элемент(индекс+4).ТекстовоеСодержимое);
		индекс = индекс + 6;
	КонецЦикла;
	ЧтениеHTML.Закрыть();
	ВОЗВРАТ тз;
КонецФункции

 

9

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. V_V_V 26.10.17 16:19 Сейчас в теме
А зачем дважды
RegExp.IgnoreCase = Ложь;
RegExp.Global = Истина;
RegExp.MultiLine = Ложь;
2. abavas 14 29.10.17 21:46 Сейчас в теме
(1) Без злого умысла. Опечатка. Спасибо. Исправил.
Оставьте свое сообщение

См. также

Простой способ опубликовать базу 1C из дома в интернет, когда Ваш провайдер этого не обеспечивает (3G, 4G модем и т.п.) 35

Статья Системный администратор Нет файла v8 1cv8.cf Бесплатно (free) WEB Облачные сервисы, хостинг

Если у Вас возникла потребность опубликовать из дома во всемирную паутину базу 1С (например, для тестирования), в т.ч. интерфейс OData, HTTP или Web-сервисы, а интернет-провайдер (например, 3G Мегафон) не предоставляет возможности инициировать соединения извне, то в конце статьи Вы найдете простой, быстрый и условно-бесплатный способ это сделать.

14.10.2019    2027    uno-c    16       

Самый примитивный HTTP-сервис в мире 164

Статья Программист Нет файла v8 Бесплатно (free) WEB

Пошаговый пример создания простейшего HTTP-сервиса, который генерирует HTML-страницу для поиска товара, а также реализует асинхронное получение данных из базы.

12.09.2019    6188    YPermitin    25       

Свой веб интерфейс к 1С: побеждаем CORS на IIS, сохраняя авторизацию 56

Статья Системный администратор Программист Нет файла v8 Windows Бесплатно (free) WEB Администрирование данных 1С

Если "веб морда" расположена не по тому же адресу, что и публикация 1С (что часто бывает, например, при разработке, публикация 1С на http://localhost/1c, а разрабатываемое веб-приложение на http://localhost:8080) или, например, мы заходим на веб приложение то по ip адресу, то по имени сервера, или просто веб сервер и сервер, на котором опубликована 1С - это разные сервера, то для большинства запросов от браузера к 1С срабатывает политика CORS, которая заключается в том, что браузер сначала посылает запрос OPTIONS, на который сервер должен ответить определенным образом, заголовками, содержащими разрешения, а потом уже (если разрешение есть), браузер посылает основной запрос. В случае, когда в публикации 1С (default.vrd) жестко прописан логин и пароль, разрулить ситуацию можно средствами 1С. В случае же, когда нужно сохранить авторизацию (или используется стандартный интерфейс odata), начинаются проблемы.

20.08.2019    3168    Fragster    7       

Вывод отчетов из Штрих-М Торговое предприятие 5 на кассовое ПО Кассир 5 через веб-сервис 3

Статья Системный администратор Программист Нет файла v8 1cv8.cf Розничная и сетевая торговля (FMCG) Россия УУ Windows Розничная торговля Бесплатно (free) WEB

Универсальный механизм вывода отчетов товароучетной системы Штрих-М Торговое предприятие в кассовое ПО Кассир 5 посредством веб-сервиса.

14.08.2019    950    Van2507    1       

Совсем простой обмен HTTP, 2 функции 60

Статья Программист Нет файла v8 Бесплатно (free) WEB

Функция для вызова рест-сервиса и функция для разбора результата. Быстро, просто, универсально.

12.08.2019    3623    Yashazz    15       

Использование HTTP-сервиса для создания "фронтенда" HTML/CSS/jQuery. Продолжение 51

Статья Программист Расширение (cfe) v8 1cv8.cf Бесплатно (free) WEB

Получение изображений из информационной базы и отправка файлов через "фронт" на HTML/CSS/JS.

08.08.2019    3283    Sedaiko    1       

1Script.Web. Интернет-приложения на языке 1С 119

Статья Программист Нет файла v8 Бесплатно (free) WEB OneScript

Запросы рынка таковы, что любое современное клиент-серверное приложение должно иметь веб-интерфейс. Почему бы не писать такие приложения на языке 1С? Андрей Овсянкин расскажет о возможностях разработки веб-приложений на базе 1Script, рассмотрит перспективы этого направления и в качестве демонстрации покажет «боевое» веб-приложение на новом движке – кроссплатформенную консоль администрирования парка кластеров 1С.

20.05.2019    11693    Evil Beaver    32       

Неверные остатки на сайте битрикс 2

Статья Программист Нет файла v8 УТ11 Бесплатно (free) WEB

Исправление процедуры выгрузки остатков на сайт битрикс из УТ 11

25.04.2019    1811    distorshion    4       

Отправка файлов через SOAP. SOAP with attachments, MTOM 38

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) WEB

В продолжение «своеобразной» поддержки 1С протокола SOAP, описанной в https://infostart.ru/public/965259/, опишу еще одну особенность. 1С не поддерживает возможность отправки файлов-вложений. Для решения этой проблемы пришлось самостоятельно писать формирование пакетов SOAP и разбор ответов сервера.

18.04.2019    2796    mysm    2       

HTML-клиент у конфигурации 1С 138

Статья Программист Нет файла v8 Бесплатно (free) WEB

Приветствую. В этой публикации опишу свой опыт создания html-клиента для конфигурации 1С с помощью http-сервисов. HTML-клиент в этом случае - это frontend (html + css+ js), который генерирует и выдает пользователю конфигурация + backend, который тоже реализован в этой же конфигурации.

17.04.2019    10936    Smaylukk    119       

Парсинг сайтов из 1С на примере ломбарды.рф с помощью XPATH для ДокументDOM 67

Статья Программист Нет файла v8 Бесплатно (free) WEB

На всякую хитрую гайку всегда найдется болт с резьбой (с)

01.04.2019    7218    starik-2005    33       

Логируй больше! 1С + UPD + GELF + Graylog 28

Статья Системный администратор Программист Нет файла v8 Windows Бесплатно (free) Практика программирования Администрирование данных 1С WEB Разработка

Наличие производительной платформы управления логами - это жизненно важный элемент в ландшафте систем с высокой активностью. Рассмотрим один из подходов логирования активности систем на платформе 1С в Graylog.

26.02.2019    5235    Lars Ulrich    15       

Создание телеграм бота с гугл авторизацией, обратными вызовами и уведомлениями об обновлении через сервер-маршрутизатор 157

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) WEB

Статья детально рассказывает обо всех аспектах настройки телеграм бота, работающего через сервер-маршрутизатор посредством обратных вызовов. Приведены примеры работы отправки/исправления сообщений, отправки файлов, работы с внутренними и встроенными запросами. Создание клавиатуры. Авторизация пользователей через gmail.

07.11.2018    17303    🅵🅾️🆇    40       

Мой опыт небольшого проекта с веб-сервисами (Часть 2) 20

Статья Программист Нет файла v8 Windows Бесплатно (free) WEB

Продолжение публикации по веб-сервису для реализации странички с выводом данных.

05.10.2018    4266    alex_bitti    0       

Как запустить работу Google Maps в поле HTML формы 1С? 25

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования WEB

Как справиться с передачей события в поле HTML, если надо передать данные. Переход на новую версию Google Maps.

26.09.2018    6384    Green2    10       

Мой опыт небольшого проекта с веб-сервисами (Часть 1) 22

Статья Программист Нет файла v8 Windows Бесплатно (free) WEB

Хочу поделиться своим опытом использования веб-сервисов на небольшом проекте, который в принципе расширяем до чего-нибудь более существенного.

08.08.2018    6460    alex_bitti    33       

Создание web-площадки на технологиях 1С, или как Водоканал сделал "Личный кабинет потребителя" 54

Статья Программист Нет файла v8 Энергетика и ЖКХ УУ Управление взаимоотношениями с клиентами (СRM) Дебиторская и кредиторская задолженность Бесплатно (free) WEB

Гончаров Максим делится опытом создания «Личного кабинета потребителя» на сайте водоканала. Он описывает архитектуру системы и объясняет, какую роль в ней играют технологии: «Битрикс», OData, веб-сервисы, «1С:БСП». Также в статье раскрываются возможности использования подсистемы «Анкетирование» в «1С:БСП» как конструктора документов.

25.06.2018    10461    maxx    31       

На что действительно способны HTTP-сервисы 174

Статья Программист Нет файла v8 Бесплатно (free) WEB

В статье я собираюсь не только рассказать вам про HTTP-сервисы 1С, но и показать много прикольных слайдов с картинками. Я думаю, будет весело, и вы найдете для себя что-то полезное.

14.06.2018    23006    dalgaso2010    45       

Подготовка тестового контура с помощью gitlab-ci и Яндекс.Диска 18

Статья Системный администратор Нет файла v8 1cv8.cf Бесплатно (free) WEB

В статье описан пример использования gitlab-ci для копирования продуктовой базы в Яндекс.Диск и разворачивания на другом контуре.

04.05.2018    7209    pallid    0       

Запуск Apache 2.4 с модулем 1С внутри Docker контейнера 87

Статья Системный администратор Программист Нет файла v8 Linux Бесплатно (free) Администрирование данных 1С WEB docker Apache

Про Apache и про Linux слышали, наверное, все. А вот про Docker пока нет, но он сильно набирает популярность последнее время и не зря. Поделюсь своим опытом и дам пошаговую инструкцию настройки веб-сервера Apache с модулем 1С внутри Docker контейнера на Linux хосте. При этом сам сервер 1С может находиться совсем на другой машине и на другой операционной системе. Это не важно, главное чтобы Apache смог достучаться до сервера 1С по TCP. В статье дам подробное пояснение по каждой используемой команде со ссылками на документацию по Docker, чтобы не создавалось ощущение непонятной магии. Также прилагаю git репозиторий с описанием всей конфигурации, можете попробовать развернуть у себя буквально за 10 минут.

04.04.2018    17830    petr.myazin    35       

1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом (не Битрикс) ч.6 2

Статья Программист Нет файла v8 1cv8.cf Автомобили, автосервисы Бесплатно (free) WEB

Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу. PHP-Скрипт публикации выборки данных сайта работающего на WordPress.

19.03.2018    5904    osivv    0       

Интеграция 1С УТ 11.2 и Битрикс. Настройка выгрузки старой цены для интернет-магазина 8

Статья Программист Нет файла v8 УТ11 Россия УУ Розничная торговля Бесплатно (free) WEB

Настройки позволят вытащить информацию о старой цене из 1С и передать её в CMS Битрикс.

24.01.2018    7906    Consultant_1C    2       

1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом (не Битрикс) ч.3 3

Статья Программист Нет файла v8 1cv8.cf Автомобили, автосервисы УУ Windows Бесплатно (free) WEB

Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу. PHP-Скрипт автоматической загрузки данных из файла данных в формате CSV в базу данных сайта работающего на WordPress.

09.01.2018    6785    osivv    0       

Готовим Soap для Web-сервисов. Рецепты 130

Статья Программист Нет файла v8 Россия Windows Бесплатно (free) WEB

В статье описаны различные варианты обмена данными с web-сервисами по протоколу Soap, основанные на личном опыте.

28.12.2017    28672    987ww765    27       

1С:Альфа-Авто Автосалон Автосервис: обмен с сайтом (не Битрикс) 5

Статья Программист Нет файла v8 1cv8.cf Автомобили, автосервисы Windows Бесплатно (free) WEB

Принцип обмена данными из 1С с сайтом (на MySQL) и выдачи (публикации) этих данных по запросу.

16.10.2017    8697    osivv    3       

1С, oauth2, Google API и Google Merchant. Сбор данных и парсинг 18

Статья Программист Нет файла v8 УТ10 Россия Бесплатно (free) Практика программирования WEB

Всем привет. Стала задача, собрать данные с Google Merchants и внести их в 1С, для более детального анализа того, что сейчас показывается, что нет и какие проблемы при этом есть. Если кому это интересно, прошу под кат.

14.09.2017    13162    Mi11er    8       

Отслеживание почтовых сообщений парсингом страницы (УкрПочта) 5

Статья Программист Нет файла v8 Украина Бесплатно (free) WEB

Когда официальное API есть, но по факту не работает. Возвращаемся к старому способу - парсинг страниц.

17.07.2017    7756    abavas    2       

XPath и пространства имен на примере разбора файла ответа сервиса геокодирования Яндекс 34

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования WEB

Есть некоторые нюансы разбора с помощью Xpath xml-файла, в котором используются несколько пространств имен. Приведен разбор такого файла на примере файла ответа сервиса геокодирования Яндекс.

14.04.2017    9824    brr    6       

PHP OData драйвер 17

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) WEB

Удобный доступ к OData данным через SQL синтаксис

03.04.2017    8185    virtex3    4       

Online телефонный справочник из 1С: Зарплата и управление персоналом 33

Статья Системный администратор Программист Нет файла v8 ЗУП3.x Россия Управление персоналом (HRM) Бесплатно (free) WEB

В интернете представлено много реализаций online телефонных справочников организаций. Есть справочники, которые использует для хранения информации базу Active Directory (LDAP), есть справочники, которые реализованы с использованием СУБД (например, MySQL). Но я не нашел справочника, который использует информацию из базы 1С. Далее я рассмотрю данную разработку.

10.03.2017    19060    ruha    14       

Веб-сервисы и 1С: «Здравствуй, Name», время-деньги и «Жизнь» 75

Статья Программист Нет файла v8 Бесплатно (free) WEB

Несколько статей о создании веб-сервисов на платформе 1С

09.03.2017    21057    hayroff    11       

Интерактивный ввод капчи 26

Статья Программист Нет файла v8 Бесплатно (free) WEB

Краткое описание того, что делать, если нужно получить некоторые данные с определенного сайта, требующего от пользователя ввода текстовой капчи.

17.02.2017    8496    gaabora    3       

Отправка PUT запроса средствами 1С 8.3 65

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования WEB

HTTP запрос с использованием метода PUT средствами 1С 8.3 на практике - проблема и решение

16.02.2017    20356    hspeed79    16       

Нагрузочное тестирование сервера 1С при использовании WEB сервисов 51

Статья Системный администратор Программист Нет файла v8 ИТ-компания Бесплатно (free) Производительность и оптимизация (HighLoad) Внешние источники данных WEB

Проведение нагрузочного тестирования WEB-сервисов, развернутых на платформе 1С. Целью тестирования является ознакомление с возможностями платформы 1С при работе с большим количеством запросов через опубликованные WEB сервисы на IIS 7.5

01.02.2017    22995    BraunAlex    34       

Еще немного об обмене на web-сервисах 18

Статья Программист Нет файла v8 Россия Бесплатно (free) WEB Перенос данных из 1C8 в 1C8

Расскажу о собственном опыте по передаче данных через web-сервисы

26.08.2016    10539    savostin.alex    8       

HOWTO: создание и отладка HTTP-сервиса в 1С:Предприятие 123

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) WEB Практика программирования Универсальные функции

Статья о том, как можно быстро создать HTTP-сервис в 1С:Предприятие и как выполнять его отладку.

25.07.2016    39462    serg_infostart    19       

SOAP-сервисы с предварительной Cookie-аутентификацией 16

Статья Программист Нет файла v8 Бесплатно (free) WEB

Платформа 1С не позволяет использовать cookie при работе со статичной WS-ссылкой или WS-прокси. Вследствие этого работа со многими веб-сервисами крупных поставщиков (например, DHL) напрямую невозможна.

05.06.2016    9053    blackschool    1       

Google Analytics API, Oauth2.0 и 1c8 51

Статья Системный администратор Нет файла v8 1С:Франчайзи, автоматизация бизнеса Windows Бесплатно (free) Практика программирования WEB

Обращение к Google Analytics API, Протокол Oauth 2.0 и запросы от 1С:8 без авторизации пользователя

02.05.2016    21749    Ольга_tmp    18       

HTTP-сервисы для тех, кто ничего не понимает в WEB 426

Статья Программист Нет файла v8 Windows Бесплатно (free) WEB

Если вы ничего не понимаете в WEB технологиях и такие слова, как json, get, post и прочее для вас ничего не значат и вы просто заядлый 1С-ник до мозга костей, но вам кровь из носу надо подружить 1С со сторонними приложениями или сайтом, то эта статья для вас

21.04.2016    100721    YAGolova    55       

Дай дернуть-2! Обращение к веб-сервисам с помощью подручных средств 97

Статья Программист Нет файла v8 Бесплатно (free) WEB

Как показала практика, о веб-сервисах знает почти каждый программист, но о том, как их готовить, - весьма ограниченный круг. Давайте интереса ради замутим сервис и дернем его с помощью простого подручного средства - "Бумеранг"!

21.04.2016    29976    starik-2005    32       

Отладка обмена с web-сайтом на Битрикс 71

Статья Системный администратор Программист Нет файла v8 Windows Бесплатно (free) WEB

Часто возникает необходимость отладки обмена между 1С и web-сайтом на Битрикс. Разберемся, какие инструменты есть для этого...

04.04.2016    14979    vital1c    6       

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция 111

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования WEB

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    48343    Serginio    33       

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д. 37

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент WEB

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    25370    Serginio    22       

Управление магазином ECWID из 1С 11

Статья Программист Нет файла v8 Windows Бесплатно (free) WEB

Вероятно многие (в том числе и я) используют для поддержки интернет-магазина стороннего поставщика, выплачивая ему энную сумму денег в месяц. Я выбрал ECWID. Не реклама, но не жалуюсь. Услуги вполне качественные. В этой статье пойдет речь об инструментах, с помощью которых можно из 1С через API Эквида общаться с их движком.

01.02.2016    9685    Sardukar    3       

Дай дернуть! О веб-сервисах, Linux'ах и добрых поисковых сайтах 61

Статья Программист Нет файла v8 1cv8.cf Linux Бесплатно (free) Инструментарий разработчика Администрирование данных 1С WEB

О веб-сервисах, апачах и *nix'ах. - установим на новенький убунту старенький апач с php. - дернем сервис из php-скрипта. - создадим приложение, позволяющее дергать произвольный сервис с произвольными данными. - ну и что там получится по пути в лес...

30.12.2015    22508    starik-2005    4