Расширение конфигурации "Выгрузка в Frontol с признаком расчетов" для 1С:Розница 2.2

Публикация № 693523

Учет и отчетность - Кассовые операции

Атол Frontol фронтол Розница Маркируемая продукция акцизная марка алкогольная продукция сканер ккм касса оффлайн offline

6
Расширение исправляет ошибку стандартной выгрузки в оффлайн кассу. Исправлена ошибка выгрузки признака расчетов для онлайн касс.

В выгрузке в поле 58 ставит признак расчетов = 2 (полный расчет)


Расширение подойдет для следующих форматов обмена:   

// ФорматОбмена:
    // 0 - АТОЛ: РМК
    // 1 - Frontol 5
    // 2 - Frontol Win32 v.4.x
    // 3 - Frontol WinCE v.2.x
    // 4 - Frontol xPOS 1.6.x
    // 5 - Frontol xPOS 1.5.x
    // 6 - Frontol xPOS 1.7.x

Тестировалось на конфигурации 2.2.6.33, 2.2.7.37, 2.2.7.39 , 2.2.7.40, 2.2.7.42, 2.2.8.24

Подключение расширения:

1С Предприятие -> Администрирование - Печетные формы, отчеты и обработки - расширения  - добавить

или

Конфигуратор ->  Конфигурация-Расширения конфигурации (кнопка конфигурация) загрузить конфигурацию из файла.

6

Скачать файлы

Наименование Файл Версия Размер
Расширение конфигурации "Выгрузка алкогольной продукции в Frontol" для 1С:Розница 2,2:
.cfe 6,95Kb
16.05.18
22
.cfe 6,95Kb 22 Скачать
Расширение конфигурации "Выгрузка в Frontol с признаком расчетов" для 1С:Розница 2.2.7-2.2.8:
.cfe 6,95Kb
16.05.18
53
.cfe 6,95Kb 53 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. coolseo 53 31.10.17 12:44 Сейчас в теме
С января 2017 года этой проблемы в рознице нет.
2. bob_ 44 31.10.17 13:05 Сейчас в теме
это дата выхода какого-то релиза розницы? В 2.2.6.33 она есть.
6. coolseo 53 19.11.17 03:11 Сейчас в теме
(2) Прошу прошения, я спутал с признаком алкогольный.
А это недавнее обновление от фронтола 5.20? В котором требуют его заполнение?
7. bob_ 44 19.11.17 16:21 Сейчас в теме
3. lytsaltykov 31.10.17 14:44 Сейчас в теме
8. nuke-nv 1 06.01.18 21:36 Сейчас в теме
На версию 2.2.7.32 расширение подключается, но горит красным и не выгружает признаки.
Прикрепленные файлы:
9. bob_ 44 08.01.18 09:37 Сейчас в теме
снимите галку безопасный режим
10. coolseo 53 30.01.18 08:02 Сейчас в теме
(9)
Здравствуйте, нашел "баг" в общем модуле расширения при проверке какой у нас алкоголь с акцизом или нет, перепутаны местами 0, 1 (Всегда ставит 0 - акцизный алкоголь (ложь)
Прикладываю исправление:

+ ?(ДанныеДляЗаполнения.Алкоголь И ДанныеДляЗаполнения.Маркируемый, "0", "1") + Разделитель	// Маркировка алкогольной продукции (56)   //bob  // //Радченко М.В. 30.01.2018
11. bob_ 44 30.01.18 08:15 Сейчас в теме
Спасибо, да действительно по формату фронтол 0 (ноль) это маркируемый алкоголь..
12. coolseo 53 30.01.18 08:29 Сейчас в теме
(11) А я сегодня "настрадался":

- ошибка признака расчетова (вспомнил про вашу обработку)
- ошибка признака алкоголя (исправили)
- смена в атоле 5.2.1 не открывается при первом чеке, нужно руками ее открывать
13. coolseo 53 02.02.18 02:53 Сейчас в теме
(11)
Здравствуйте, еще предлагаю вот это добавить в расширение, не правильно выгружается налоговая ставка во фронтол, всем ставит 0, а если нужно без ндс тогда ставим 4

&Вместо("СформироватьФайлНастроек")
Функция Расш1_СформироватьФайлНастроек(СтруктураНастроек, ТекстовыйФайл, ТекстОшибки)
	
	Результат = Истина;
	
	Налоги = СтруктураНастроек.Налоги;
	КомбинацииНалогов = СтруктураНастроек.КомбинацииНалогов;
	
	БлокСтавок = "$$$ADDTAXRATES";
	БлокГрупп = "$$$ADDTAXGROUPS";
	БлокСтавокГрупп = "$$$ADDTAXGROUPRATES";
	
	Если Налоги.Количество() = 0 Тогда
		ТекстОшибки = НСтр("ru='Выгрузка настроек невозможна. Список ставок налога пуст.'");
		Результат = Ложь;
	Иначе
		
		Если КомбинацииНалогов.Количество() = 0 Тогда
			
			Если Налоги.Количество() > 1 Тогда
				ТекстОшибки = НСтр("ru='Выгрузка настроек невозможна. На товары начисляется несколько налогов, необходимо заполнить комбинации налогов.'");
				Результат = Ложь;
			Иначе
				
				Для Каждого ТекНалог Из Налоги Цикл
					
					Если ТекНалог.Ставки.Количество() = 0 Тогда
						ТекстОшибки = НСтр("ru='Выгрузка настроек невозможна. Список ставок налога пуст.'");
						Результат = Ложь;
						Прервать;
					КонецЕсли;
					
					Для Каждого ТекСтавка Из ТекНалог.Ставки Цикл
						
						Текст = ?(СтрДлина(ТекСтавка.Текст)>100, Лев(ТекСтавка.Текст, 100), ТекСтавка.Текст);
						
						БлокСтавок = БлокСтавок + Символы.ПС
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";"	// Код
									+ Текст + ";"								// Наименование
									+ Текст + ";"								// Текст
									+ "0;"										// Тип налога
									+ Формат(ТекСтавка.Значение, "ЧН=0; ЧГ=0") + ";" // Значение налога
     								+  ?(ТекСтавка.Код = 3, "4", "1");	//Номер налога для без НДС ставим 4  //Радченко М.В. 02.02.2018
						
						БлокГрупп = БлокГрупп + Символы.ПС
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";" // Код
									+ Текст + ";"								// Наименование
									+ Текст;									// Текст
									
						БлокСтавокГрупп = БлокСтавокГрупп + Символы.ПС
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";"	// Код
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";"	// Код налоговой группы
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";"	// Код налоговой ставки
									+ "1";										// Смена базы
						
					КонецЦикла;
					
				КонецЦикла;
				
			КонецЕсли;
			
		Иначе
			
			ИндексСтавки = 1;
			
			Для Каждого ТекНалог Из Налоги Цикл
				
				Если ТекНалог.Ставки.Количество() = 0 Тогда
					ТекстОшибки = НСтр("ru='Выгрузка настроек невозможна. Список ставок налога пуст.'");
					Результат = Ложь;
					Прервать;
				КонецЕсли;
				
				Для Каждого ТекСтавка Из ТекНалог.Ставки Цикл
					
					Текст = ?(СтрДлина(ТекСтавка.Текст)>100, Лев(ТекСтавка.Текст, 100), ТекСтавка.Текст);
					
					ТекСтавка.Вставить("Индекс", ИндексСтавки);
					
					БлокСтавок = БлокСтавок + Символы.ПС
								+ Формат(ИндексСтавки, "ЧДЦ=; ЧГ=0") + ";"	// Код
								+ Текст + ";"								// Наименование
								+ Текст + ";"								// Текст
								+ "0;"										// Тип налога
								+ Формат(ТекСтавка.Значение, "ЧН=0; ЧГ=0");	// Значение налога
					
					ИндексСтавки = ИндексСтавки + 1;
					
				КонецЦикла;
				
			КонецЦикла;
			
			ИндексНалоговойСтавкиГруппы = 1;
			
			Для Каждого ТекКомбинация Из КомбинацииНалогов Цикл
				
				КодКомбинации = Формат(ТекКомбинация.Код, "ЧДЦ=; ЧГ=0");
				Текст = НСтр("ru = 'Группа №'") + КодКомбинации;
				
				БлокГрупп = БлокГрупп + Символы.ПС
							+ КодКомбинации + ";"	// Код
							+ Текст + ";"			// Наименование
							+ Текст;				// Текст
				
				Для Каждого ТекСтавкаКомбинации Из ТекКомбинация.Ставки Цикл
					
					Для Каждого ТекНалог Из Налоги Цикл
						
						Если ТекНалог.Код = ТекСтавкаКомбинации.КодНалога Тогда
							
							Для Каждого ТекСтавка Из ТекНалог.Ставки Цикл
								
								Если ТекСтавка.Код = ТекСтавкаКомбинации.КодСтавки Тогда
									
									БлокСтавокГрупп = БлокСтавокГрупп + Символы.ПС
													+ Формат(ИндексНалоговойСтавкиГруппы, "ЧДЦ=; ЧГ=0") + ";"	// Код
													+ КодКомбинации + ";"										// Код налоговой группы
													+ Формат(ТекСтавка.Индекс, "ЧДЦ=; ЧГ=0") + ";"				// Код налоговой ставки
													+ "0";														// Смена базы
													
									Прервать;
									
								КонецЕсли;
								
							КонецЦикла;
							
							Прервать;
							
						КонецЕсли;
						
					КонецЦикла;
					
					ИндексНалоговойСтавкиГруппы = ИндексНалоговойСтавкиГруппы + 1;
					
				КонецЦикла;
				
			КонецЦикла;
			
		КонецЕсли;
		
		БлокНалогов = "$$$DELETEALLTAXGROUPRATES
				|$$$DELETEALLTAXGROUPS
				|$$$DELETEALLTAXRATES" + Символы.ПС
				+ БлокСтавок + Символы.ПС
				+ БлокГрупп + Символы.ПС
				+ БлокСтавокГрупп;
	
	КонецЕсли;
	
	Если Результат Тогда
		
		Если ТекстовыйФайл.КоличествоСтрок()>0 Тогда
			
			// Определяем и удаляем блок видов оплаты.
			ТекстФайла = ТекстовыйФайл.ПолучитьТекст();
			
			Если Найти(ТекстФайла, "$$$DELETEALLTAXGROUPRATES")<>0 Тогда
				
				Для ИндексСтроки = 3 По ТекстовыйФайл.КоличествоСтрок() Цикл
					
					ТекущаяСтрока = ТекстовыйФайл.ПолучитьСтроку(ИндексСтроки);
					
					Если ТекущаяСтрока = "$$$DELETEALLTAXGROUPRATES" Тогда
						
						Пока Истина Цикл
							
							Если ИндексСтроки = ТекстовыйФайл.КоличествоСтрок() + 1 Тогда
								Прервать;
							КонецЕсли;
							
							ТекущаяСтрока = ТекстовыйФайл.ПолучитьСтроку(ИндексСтроки);
							
							Если ТекущаяСтрока <> "$$$REPLACEQUANTITY" И ТекущаяСтрока <> "$$$DELETEALLWARES" Тогда
								ТекстовыйФайл.УдалитьСтроку(ИндексСтроки);
							Иначе
								Прервать;
							КонецЕсли;
							
						КонецЦикла;
						
						Прервать;
						
					КонецЕсли;
					
				КонецЦикла;
				
			КонецЕсли;
			
		Иначе
			// Выгружаем в новый файл
			ТекстовыйФайл.ДобавитьСтроку("##@@&&");
			ТекстовыйФайл.ДобавитьСтроку("#");
		КонецЕсли;
		
		ТекстовыйФайл.ВставитьСтроку(3, БлокНалогов);
		
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции
Показать
14. dd93rus 19.03.18 12:28 Сейчас в теме
Розница 2.2 версии 2.2.7.40, франтол 5.21.1 признак
15. dd93rus 19.03.18 12:30 Сейчас в теме
Розница 2.2.7.40 франтол 5 2.21.1 признак предмета расчета не выгружается не на стандартном обмене, и с вашим расширением. В чем может быть причина?
16. coolseo 53 20.03.18 02:16 Сейчас в теме
(15)
Проверьте что у вас там стоит
17. bob_ 44 20.03.18 19:07 Сейчас в теме
проверил, расширение работает на релизе 2.2.7.40
18. silverr 14.04.18 13:26 Сейчас в теме
Доброго времени суток!
Ваша разработка "Расширение конфигурации "Выгрузка в Frontol с признаком расчетов" для 1С:Розница 2.2.7" обрабатывает файл выгрузки из Frontola?
У меня при загрузке отчета вылетает ошибка:
{ОбщийМодуль.ПодключаемоеОборудованиеАтолККМOfflineКлиент.Модуль(1410)}: Поле объекта не обнаружено (Тип)
19. ecstazi 02.05.18 18:25 Сейчас в теме
Для бухгалтерии подойдет?
21. bob_ 44 05.05.18 13:13 Сейчас в теме
23. Gallakr 22.06.18 12:49 Сейчас в теме
Добрый день! Пробую расширение на релизе 2.2.7.32 -не работает (см скриншоты). В справочнике вид номенклатуры признак указан(Экран 1). Прдскажите, что нужно сделать, чтобы выгрузить товары во Фронтол 5 правильно( с нудным признаком).
Прикрепленные файлы:
24. bob_ 44 22.06.18 20:09 Сейчас в теме
Не получается повторить ошибку, попробуйте использовать формат выгрузки Frontol 5 , ошибка будет такой же?
25. Gallakr 25.06.18 08:46 Сейчас в теме
Установила обновление розницы 2.2.8.29 и формат обмена Frontol 5- все заработало (даже без расширения). Спасибо.
26. 57rus 21.07.18 14:17 Сейчас в теме
(25)
формат обмена Frontol 5


подскажите где устанавливали? извиняюсь, затупил - в с-вах ккм
27. dron-s 10.08.18 23:06 Сейчас в теме
обновился на розницу 2.2.9.20 и при обмене с оборудованием выходит загрузка с эвотор??? каким эвотор интересно если стоит фронтол 5 протокол обмена... как быть?
28. bob_ 44 13.08.18 07:54 Сейчас в теме
попробовать без расширения, убедится, что действительно проблема в расширении, сообщить мне, сделаю расширение для версии 2.2.9.20, если оно действительно требуется.
29. dron-s 23.08.18 10:18 Сейчас в теме
скажите, почему сейчас при пробитии электронными в чеке печатается Кредит а не Электронными... и в итоговой сумме берётся к итогу только выручка наличкой а кредит не берётся...
30. dron-s 23.08.18 10:22 Сейчас в теме
вот есть наличка и есть кредит, а в итоговой необнуляемой сумме только наличка.. как исправить ситуацию?
Прикрепленные файлы:
31. dron-s 23.08.18 10:23 Сейчас в теме
32. bob_ 44 23.08.18 10:55 Сейчас в теме
электронными - это пластик (эквайринг) у вас? Последующая оплата (кредит) значит, что вы отдали товар без оплаты , предполагаю что у вас настроена связка - терминал - розница - ккт , и терминал не подтверждает оплату. В итоге получается, что по терминалу операция прошла, а на ккм идет - отдали товар без оплаты. (мое предположение)
33. dron-s 23.08.18 12:16 Сейчас в теме
(32) терминал не связан с фронтол, он автономный... просто во фронтоле выбирают оплата картой и всё
34. dron-s 23.08.18 12:16 Сейчас в теме
а должно быть пластиковая карта по чеку (либо электронными)
35. bob_ 44 23.08.18 13:30 Сейчас в теме
значит во фронтоле косяк, или в настройках фронтола
36. dron-s 23.08.18 13:54 Сейчас в теме
(35)
или в настройках фронтола

где посмотреть?
37. bob_ 44 23.08.18 14:34 Сейчас в теме
не знаю, задать вопрос техподдержке Frontol
38. dron-s 05.10.18 20:42 Сейчас в теме
Добрый день
а с группами печати кто то пробовал побороть проблему, чтобы Товарные группы выгружались во фронтол в группы печати...
необходимо для того чтобы во фронтол организовать работу с двумя организациями и продажу по разным ККМ
39. medvedkiller 05.06.19 12:30 Сейчас в теме
Добрый день! Розница, редакция 2.2 (2.2.12.26)
Вот такая ошибка

ПризнакРасчетовВФронтол: Критичная: Значение контролируемого свойства РежимСовместимости у объекта не совпадает со значением в расширяемой конфигурации
40. bob_ 44 06.06.19 21:18 Сейчас в теме
измените режим совместимости
Оставьте свое сообщение

См. также

Рекомендательный сервис на основе коллаборативной фильтрации на 1С. Расширение формы подбора для УТ 11.4 30

Инструменты и обработки Программист Расширение (cfe) v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m) Оптовая торговля Розничная торговля Практика программирования Математика и алгоритмы

В данной разработке реализован механизм рекомендаций товаров по принципу схожести товаров в корзине на основе алгоритма Item-to-Item от Amazon. Разобран алгоритм с демо базой и сделано расширение для УТ11.4 которое добавляет в форму подбора таблицу рекомендаций. Протестировано на 8.3.13.1865 на Управление торговлей, редакция 11 (11.4.8.63)

3 стартмани

25.09.2019    1780    5    informa1555    21       

Выгрузка номенклатуры в социальную сеть Вконтакте 30

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Оптовая торговля Розничная торговля Абонемент ($m) WEB

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    2091    11    kalyuzhny    20       

Печать покупателя в чеке ККМ с 01.07.2019 25

Отчеты и формы Программист Бухгалтер Пользователь Расширение (cfe) v8 ERP2 БУ Кассовые операции Абонемент ($m) ККМ Печатные формы документов

C 01.07.2019 если организация/ИП покупает у другой организации/ИП товары, работы или услуги, то в Чеке ККМ требуется указать: Покупателя (тег 1227) и ИНН (тег 1228). Если чек отправляется в ОФД без этих данных, то будет штраф . Но в 1С ERP вывод данных полей не предусмотрен. Предлагаемое расширение устраняет данную проблему.

1 стартмани

17.07.2019    6938    15    sapervodichka    10       

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android 20

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 v8::Mobile Розница УНФ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Внешние источники данных Сканер штрих-кода Терминал сбора данных Работа с интерфейсом Мобильная разработка

Простой мобильный терминал сбора данных для iOS и Android, не требующий сложных настроек и установки дополнительных программ. Для выгрузки базы штрихкодов и загрузки собранных штрихкодов в документы учетной системы используется Яндекс Диск или облачный сервис и расширение конфигурации. Работает с конфигурациями Розница 2, УНФ 1.6, УТ 11, ERP, КА2.

3 стартмани

22.04.2019    9980    53    suepifanov    61       

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь полноценный оффлайн (обновление от 15.08.19)! 169

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    19914    212    informa1555    167       

ККТ Атол: настраиваем работу по новому порядку. 54ФЗ, ФФД 1.05, НДС 20%. + Работа ККТ по сети или как работать c ККТ из терминального сервера RDP + Работа в LINUX 22

Инструменты и обработки Системный администратор Архив с данными v8 УТ10 УПП1 ОС Кассовые операции Розничная торговля Абонемент ($m) ККМ

Настройка ККТ АТОЛ для работы по сети. Обработка обслуживания ККТ для конфигураций на обычных формах. Тестировал на УПП 1.3.106.2, УТ10.3.47.3. Платформа 8.3.10.2753

1 стартмани

14.12.2018    30420    49    Johny_v    42       

АТОЛ ВЕБ-СЕРВИС. Обработка для работы с ККТ 54 ФЗ + ИЗМЕНЕНИЯ С 01.07.2019 36

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 КА1 УТ10 УПП1 БГУ БАУ 1С:CRM Россия Windows Кассовые операции Абонемент ($m) ККМ

Хотите ускорить печать чеков, или печатать с разных рабочих мест на один фискальный регистратор? В этом вам поможет, настроенный веб-сервис от фирмы АТОЛ, а данная разработка позволит интегрировать его с вашей программой 1С.

4 стартмани

03.12.2018    18986    150    karpik666    168       

Загрузка чека онлайн-касс (загрузка товаров из чека) 38

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Кассовые операции Розничная торговля Абонемент ($m) Внешние источники данных WEB

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) с сервера ФНС proverkacheka.nalog.ru

2 стартмани

08.10.2018    7165    23    echo77    32       

Кое-что простое о сложных штрих-кодах 33

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf УУ Розничная торговля Абонемент ($m) Сканер штрих-кода Бухгалтерский учет

На просторах и-нета часто встречаю публикации, в которых авторы с энтузиазмом рассказывают о том, как в штрих-код внести информацию о нескольких сущностях: например, как сделать, чтобы при сканировании одного штрих-кода на ярлыке товара, 1С определяла что это за товар, его качество и приходную накладную по которой этот товар поступил. Увы, но делается это "в лоб". Я предлагаю более разумный способ. Он очевиден - так что не претендую на лавры первооткрывателя.

1 стартмани

28.09.2018    7151    6    torch    15       

Расширение "Интерфейс Плюс" 40

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия УУ Розничная торговля Абонемент ($m) Рабочее место

Расширение для 1С:Розница 2.2 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

3 стартмани

22.09.2018    9970    88    RocKeR_13    81       

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    13755    78    asdfgcom    45       

Быстрая настройка ККМ из 1С с использованием драйвера от Атол без тест-драйвера 8

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 Розница Windows Кассовые операции Абонемент ($m) ККМ

В нашей компании на кассовых местах подключено несколько ККМ от Атола. При подключении к штатным разъемам USB на материнской плате все работает без проблем. Проблемы в тех магазинах, где кассы подключаются через USB-Hub. Данная обработка позволяет быстро, без запуска "Тест-драйвера" и "Управление драйверами", настроить кассовое оборудование. Протестировано на 32-х битной версии 1С и конфигурации 1С:Розница 2.2 с версиями драйверов от Атол 8.16.1.8701 и 9.12.1.6236

1 стартмани

27.08.2018    10294    14    valerasv    7       

Загрузка файлов/картинок/изображений/фото номенклатуры PRO 16

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ Розница УНФ УТ11 Россия Оптовая торговля Розничная торговля Абонемент ($m) Управленческий учет (прочее)

Пожалуй, самая многофункциональная обработка для пополнения каталога. Сопоставление изображений с номенклатурой по артикулу, коду и подстроке; обновление/замена, удаление фото; установка основного изображения по расширению или по любой части наименования файла. Информация о файлах и результаты сопоставления с номенклатурой отображается в таблице. Для каждого изображения есть возможность предпросмотра. Процесс загрузки картинок отображается через прогресс-бар.

1 стартмани

03.08.2018    7386    61    zannv    18       

ЕГАИС 3 Контролёр для 1С:Розница 7

Инструменты и обработки Системный администратор Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Android Розничная торговля Абонемент ($m) Терминал сбора данных

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    9107    16    kuld    30       

Пробитие чеков через ККМ в офисе (для курьеров) 12

Инструменты и обработки Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    17209    27    Kutuzov    12       

Корректировка остатков ЕГАИС для 1С:Розница/УТ 10.3 - альтернативный вариант 54

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) БУ Розничная торговля Учет ТМЦ Абонемент ($m) Обработка документов

Обработка корректировки остатков ЕГАИС для 1С Розница версии 2.2.7/2.2.8/2.2.9/2.2.10/2.2.11/УТ 10.3.47.ХХХ-48.XXX-49.XXX-50.XXX раздельно по маркируемому/немаркируемому алкоголю + создание документов постановки/списания по пересортице.

1 стартмани

02.06.2018    17769    292    independ    211       

Yep Cart. Пишем интернет-магазин на http-сервисах OneScript 44

Статья Программист Конфигурация (md, cf) v8 УУ Оптовая торговля Розничная торговля Абонемент ($m) OneScript

В статье описана демонстрационная конфигурация, реализующая простейший интернет магазин на http-сервисах OneScript, интегрированный с 1С:Предприятие.

1 стартмани

16.04.2018    9836    15    blackhole321    33       

Расширение для 1С Розница - форма справочника номенклатуры с ценами, остатками, штрихкодами 32

Отчеты и формы Пользователь Расширение (cfe) v8 Розница УУ Розничная торговля Абонемент ($m) Обработка справочников

Форма справочника номенклатуры с расширенными возможностями для 1С Розница версии 2.2.6.ХХХ и выше, платформа не ниже 8.3.10.

1 стартмани

17.03.2018    7022    47    independ    14       

Время продаж чеков по магазинам в УТ 11, КА. Аналитический отчет + Диаграмма 7

Отчеты и формы Руководитель проекта Внешний отчет (ert,erf) v8 v8::ОУ УТ10 УТ11 КА2 Розничная и сетевая торговля (FMCG) УУ Розничная торговля Абонемент ($m) Управленческие

Отчет "Диаграмма по времени продаж чеков" предназначен для планирования графиков работы продавцов-менеджеров, для планирования маркетинговых мероприятий.

2 стартмани

16.03.2018    10484    8    zaika007    12       

СМС-верификация при регистрации клиента, списании бонусных баллов, СМС о начислении баллов 25

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Розничная и сетевая торговля (FMCG) УУ Управление взаимоотношениями с клиентами (СRM) Розничная торговля Абонемент ($m) SMS рассылки Управление торговлей

Предлагаемое расширение для конфигурации 1С Управление Торговлей 11, и Розница 2 позволяет подтверждать операции с бонусными баллами с помощью СМС, отправляемых на телефон клиента. Также предлагается внешняя обработка для отправки информации о начислении бонусных баллов по СМС.

2 стартмани

16.03.2018    15911    96    Kutuzov    69       

Организация обмена с базой филиала (розничного магазина) в торговой сети через XML (универсальный обмен) 70

Статья Программист Архив с данными v8 КД УТ11 Розничная и сетевая торговля (FMCG) Розничная торговля Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

В статье по шагам рассматривается создание обмена между центральной базой и базами филиалов на базе конфигурации УТ 11. Для решения поставленной задачи было решено не использовать РИБ, т.к. требуется односторонний обмен ограниченным набором данных, к тому же по определенным условиям. Обмен реализован на основе типовой синхронизации на основе универсального обмена в формате EnterpriseData. Данная публикация может быть полезна внедренцам, которые работают с торговыми сетями, в том числе по модели франчайзинга.

1 стартмани

26.02.2018    24954    14    Kutuzov    18       

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия БУ Розничная торговля Абонемент ($m) Обработка документов

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    16895    5    biz-intel    3       

Печать ценников из документа Внутреннее перемещение. 1С: Розница 23

Отчеты и формы Пользователь Внешняя обработка (ert,epf) v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Розничная торговля Абонемент ($m) Ценники

Вызов обработки Печать ценников и этикеток из документа внутреннего перемещения для 1С Розница 2.2.X.XX.

1 стартмани

22.11.2017    9108    30    independ    20       

Загрузка кассовых чеков с сервера ФНС. Расширение для 1С: Деньги 22

Инструменты и обработки no Расширение (cfe) v8 1cv8.cf Домашние учет и финансы Россия УУ Кассовые операции Абонемент ($m) WEB

Для тех, кто ведет домашние финансы в 1С:Деньги. Расширение поможет сократить время на ввод данных о расходах, вместо набивания данных руками, данные чека (сумму и товары) можно загрузить из электронного чека, который хранится на сервере ФНС.

1 стартмани

17.11.2017    14797    62    Bazil    49       

Android беспроводной Bluetooth сканер 1D/2D штрихкода и терминал сбора данных для 1С 78

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf УУ Android Оптовая торговля Розничная торговля Абонемент ($m) Сканер штрих-кода

Бесплатное приложение, превращающее Android-смартфон в беспроводной 1D/2D Bluetooth сканер и терминал сбора данных для 1С и прочих POS систем. Не требует драйверов и доработки конфигураций.

1 стартмани

12.09.2017    26750    24    kuld    43       

Работа с интегрированным терминалом Сбербанка через утилиту upwin.exe 23

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Розничная и сетевая торговля (FMCG) Россия Windows Банковские операции Розничная торговля Абонемент ($m) Обмен с банком

Утилита UPWIN.exe от Сбербанка, коды команд для управления интегрированным банковским терминалом (управляемые формы, обычные под 8.1). Обработка на управляемых формах запускается под любой конфигурацией, обработка на обычных формах также запускается под любой конфигурацией на платформе от 8.1 и выше

1 стартмани

05.09.2017    15419    59    independ    12       

Рабочее место кассира 1С:Розница 2.2 (РМК) как Фронт-офис с поиском по цене и только положительными остатками 30

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ УУ Кассовые операции Розничная торговля Абонемент ($m) Рабочее место

РМК Розница 2.2.9 с изменениями: 1) Только положительные остатки 2) Поиск по цене 3) Форма РМК с полем ввода (полем поиска) 4) Форма подбора товаров с окном характеристик 5) Внесение ден.средств без РКО и др.

1 стартмани

11.07.2017    31163    121    Vlx    79       

БП 2.0 онлайн-касса (ККТ с передачей данных) 54 ФЗ 20

Инструменты и обработки Системный администратор Программист Бухгалтер Конфигурация (md, cf) v8 v8::БУ БП2.0 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Изменения для объединения с конфигурацией "Бухгалтерия предприятия 2.0" с функционалом для работы с ККТ с передачей данных в ОФД (онлайн-касса), сделана согласно методическим указаниям.

3 стартмани

09.07.2017    30781    135    bob_    53       

Простая печать чеков в соответствии с 54-ФЗ. 4

Инструменты и обработки Системный администратор Программист Бухгалтер Руководитель проекта Архив с данными v8 v8::БУ БП3.0 Россия БУ Windows Кассовые операции Абонемент ($m) Фискальный регистратор

Простая программа для печати чеков на фискальных регистраторах через драйвер компании Штрих-М. Соответствует 54-ФЗ. Подходит для интернет-магазинов.

3 стартмани

07.07.2017    22274    25    Rik30    14       

Опыт интеграции ФР Штрих-М с 1С 24

Статья Программист Архив с данными v8 1cv8.cf Россия БУ Кассовые операции Абонемент ($m) Фискальный регистратор

Надвигается 1 июля и всем срочно нужны ККМ-онлайн. Публикую свой опыт быстрого и простого решения на базе фискального регистратора Штрих-М для обычных форм.

1 стартмани

01.05.2017    40206    23    Yashazz    75       

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол 12

Инструменты и обработки Системный администратор Программист Архив с данными v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    41498    127    Atom74    69       

FR_Atol_Shtrih.exe печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54ФЗ поддержка изменений от 01/07/19). Для 1С (7.7 и:8 УФ, Обычных Формы) есть готовые обработки 68

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Windows Кассовые операции Оптовая торговля Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

7 стартмани

11.04.2017    50987    173    ah7777777    473       

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2 99

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Обработка справочников Ценообразование, прайсы

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    40000    49    myALKleon    37       

Загрузка из Excel-файла данных в документ Поступление товаров и услуг 42

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 Розница БП3.0 УТ11 КА2 Россия БУ УУ Оптовая торговля Розничная торговля Учет ТМЦ Абонемент ($m) Обработка документов Загрузка и выгрузка в Excel

Загрузка из произвольного Excel-файла документов Поступление товаров и услуг с возможностью создания номенклатуры, обработка позволяет автоматизировать процесс оформления новых поступлений товара.

1 стартмани

04.03.2017    19987    320    ifal    77       

ФЗ-54 Подключение фискальных регистраторов с ФН по TCP. Доработка Розницы 1.0. Обработка обслуживания Штрих-М для драйверов версии 4.13 30

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 КА1 УТ10 Розница Розничная и сетевая торговля (FMCG) УУ Розничная торговля Абонемент ($m) Фискальный регистратор

Обработка осуществляет обслуживание фискальных регистраторов, поддерживаемых драйвером "Штрих-М" версии 4.13 для конфигураций на обычных формах. Обработка позволяет подключать ФР как по TCP, так и через COM. Поддерживается работа двух компонент: "AddIn.SMDrvFR1C20" и "AddIn.SMDrvFR1C". Соответственно обе компоненты должны быть зарегистрированы в системе.

2 стартмани

26.01.2017    60959    171    sdv88    120       

Android Штрихкод сканер + драйвер устройства для 1С 135

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 1cv8.cf 1cv7.md Android Розничная торговля Абонемент ($m) Сканер штрих-кода

Драйвер торгового оборудования и приложение для Android, телефон или планшет в качестве стандартного штрихкод сканера для платформы 1С.

3 стартмани

29.11.2016    35595    188    dreamadv    99