Кирилкин Дмитрий | Ведущий разработчик | Торговая сеть Реми

«Scrum - серебряной пули не существует»

В своем докладе я хотел бы осветить практический опыт использования Scrum в команде из 5 разработчиков 1С. Ранее никто из участников команды не сталкивался в своей работе со Scrum. Для всех разработчиков это был новый опыт и новые вызовы. Тезисы: Предпосылки, явившиеся катализатором перехода на использование Scrum. Scrum наши ожидания после ознакомления с методологией. Заманчивые "Делать в два раза больше за половину времени..." Популяризация Scrum в команде, как это было. Владелец продукта и Scrum мастер где их взять или вы работаете во внутреннем отделе разработки. События Scrum (Ежедневные собрания, ретроспектива и обзор спринта). Поход к работе с задачами спринты, эпики, пользовательские истории и оценка задач. Что получилось, а что нет. Программное обеспечение, что и как используем. К чему мы пришли через год после начала работы по Scrum. Что дал нам Scrum. Оправдались ли ожидания.

Расширение конфигурации "Выгрузка в Frontol с признаком расчетов" для 1С:Розница 2.2

Оборудование - ККМ

Расширение исправляет ошибку стандартной выгрузки в оффлайн кассу. Исправлена ошибка выгрузки признака расчетов для онлайн касс.

В выгрузке в поле 58 ставит признак расчетов = 2 (полный расчет)


Расширение подойдет для следующих форматов обмена:   

// ФорматОбмена:
    // 0 - АТОЛ: РМК
    // 1 - Frontol 5
    // 2 - Frontol Win32 v.4.x
    // 3 - Frontol WinCE v.2.x
    // 4 - Frontol xPOS 1.6.x
    // 5 - Frontol xPOS 1.5.x
    // 6 - Frontol xPOS 1.7.x

Тестировалось на конфигурации 2.2.6.33, 2.2.7.37, 2.2.7.39 , 2.2.7.40, 2.2.7.42, 2.2.8.24

Подключение расширения:

1С Предприятие -> Администрирование - Печетные формы, отчеты и обработки - расширения  - добавить

или

Конфигуратор ->  Конфигурация-Расширения конфигурации (кнопка конфигурация) загрузить конфигурацию из файла.

Скачать файлы

Наименование Файл Версия Размер
Расширение конфигурации "Выгрузка алкогольной продукции в Frontol" для 1С:Розница 2,2:
.cfe 6,95Kb
16.05.18
14
.cfe 6,95Kb 14 Скачать
Расширение конфигурации "Выгрузка в Frontol с признаком расчетов" для 1С:Розница 2.2.7-2.2.8:
.cfe 6,95Kb
16.05.18
34
.cfe 6,95Kb 34 Скачать

См. также

Комментарии
Сортировка: Древо
1. coolseo 45 31.10.17 12:44 Сейчас в теме
С января 2017 года этой проблемы в рознице нет.
2. bob_ 26 31.10.17 13:05 Сейчас в теме
это дата выхода какого-то релиза розницы? В 2.2.6.33 она есть.
6. coolseo 45 19.11.17 03:11 Сейчас в теме
(2) Прошу прошения, я спутал с признаком алкогольный.
А это недавнее обновление от фронтола 5.20? В котором требуют его заполнение?
7. bob_ 26 19.11.17 16:21 Сейчас в теме
3. lytsaltykov 31.10.17 14:44 Сейчас в теме
8. nuke-nv 1 06.01.18 21:36 Сейчас в теме
На версию 2.2.7.32 расширение подключается, но горит красным и не выгружает признаки.
Прикрепленные файлы:
9. bob_ 26 08.01.18 09:37 Сейчас в теме
снимите галку безопасный режим
10. coolseo 45 30.01.18 08:02 Сейчас в теме
(9)
Здравствуйте, нашел "баг" в общем модуле расширения при проверке какой у нас алкоголь с акцизом или нет, перепутаны местами 0, 1 (Всегда ставит 0 - акцизный алкоголь (ложь)
Прикладываю исправление:

+ ?(ДанныеДляЗаполнения.Алкоголь И ДанныеДляЗаполнения.Маркируемый, "0", "1") + Разделитель	// Маркировка алкогольной продукции (56)   //bob  // //Радченко М.В. 30.01.2018
11. bob_ 26 30.01.18 08:15 Сейчас в теме
Спасибо, да действительно по формату фронтол 0 (ноль) это маркируемый алкоголь..
12. coolseo 45 30.01.18 08:29 Сейчас в теме
(11) А я сегодня "настрадался":

- ошибка признака расчетова (вспомнил про вашу обработку)
- ошибка признака алкоголя (исправили)
- смена в атоле 5.2.1 не открывается при первом чеке, нужно руками ее открывать
13. coolseo 45 02.02.18 02:53 Сейчас в теме
(11)
Здравствуйте, еще предлагаю вот это добавить в расширение, не правильно выгружается налоговая ставка во фронтол, всем ставит 0, а если нужно без ндс тогда ставим 4

&Вместо("СформироватьФайлНастроек")
Функция Расш1_СформироватьФайлНастроек(СтруктураНастроек, ТекстовыйФайл, ТекстОшибки)
	
	Результат = Истина;
	
	Налоги = СтруктураНастроек.Налоги;
	КомбинацииНалогов = СтруктураНастроек.КомбинацииНалогов;
	
	БлокСтавок = "$$$ADDTAXRATES";
	БлокГрупп = "$$$ADDTAXGROUPS";
	БлокСтавокГрупп = "$$$ADDTAXGROUPRATES";
	
	Если Налоги.Количество() = 0 Тогда
		ТекстОшибки = НСтр("ru='Выгрузка настроек невозможна. Список ставок налога пуст.'");
		Результат = Ложь;
	Иначе
		
		Если КомбинацииНалогов.Количество() = 0 Тогда
			
			Если Налоги.Количество() > 1 Тогда
				ТекстОшибки = НСтр("ru='Выгрузка настроек невозможна. На товары начисляется несколько налогов, необходимо заполнить комбинации налогов.'");
				Результат = Ложь;
			Иначе
				
				Для Каждого ТекНалог Из Налоги Цикл
					
					Если ТекНалог.Ставки.Количество() = 0 Тогда
						ТекстОшибки = НСтр("ru='Выгрузка настроек невозможна. Список ставок налога пуст.'");
						Результат = Ложь;
						Прервать;
					КонецЕсли;
					
					Для Каждого ТекСтавка Из ТекНалог.Ставки Цикл
						
						Текст = ?(СтрДлина(ТекСтавка.Текст)>100, Лев(ТекСтавка.Текст, 100), ТекСтавка.Текст);
						
						БлокСтавок = БлокСтавок + Символы.ПС
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";"	// Код
									+ Текст + ";"								// Наименование
									+ Текст + ";"								// Текст
									+ "0;"										// Тип налога
									+ Формат(ТекСтавка.Значение, "ЧН=0; ЧГ=0") + ";" // Значение налога
     								+  ?(ТекСтавка.Код = 3, "4", "1");	//Номер налога для без НДС ставим 4  //Радченко М.В. 02.02.2018
						
						БлокГрупп = БлокГрупп + Символы.ПС
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";" // Код
									+ Текст + ";"								// Наименование
									+ Текст;									// Текст
									
						БлокСтавокГрупп = БлокСтавокГрупп + Символы.ПС
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";"	// Код
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";"	// Код налоговой группы
									+ Формат(ТекСтавка.Код, "ЧДЦ=; ЧГ=0") + ";"	// Код налоговой ставки
									+ "1";										// Смена базы
						
					КонецЦикла;
					
				КонецЦикла;
				
			КонецЕсли;
			
		Иначе
			
			ИндексСтавки = 1;
			
			Для Каждого ТекНалог Из Налоги Цикл
				
				Если ТекНалог.Ставки.Количество() = 0 Тогда
					ТекстОшибки = НСтр("ru='Выгрузка настроек невозможна. Список ставок налога пуст.'");
					Результат = Ложь;
					Прервать;
				КонецЕсли;
				
				Для Каждого ТекСтавка Из ТекНалог.Ставки Цикл
					
					Текст = ?(СтрДлина(ТекСтавка.Текст)>100, Лев(ТекСтавка.Текст, 100), ТекСтавка.Текст);
					
					ТекСтавка.Вставить("Индекс", ИндексСтавки);
					
					БлокСтавок = БлокСтавок + Символы.ПС
								+ Формат(ИндексСтавки, "ЧДЦ=; ЧГ=0") + ";"	// Код
								+ Текст + ";"								// Наименование
								+ Текст + ";"								// Текст
								+ "0;"										// Тип налога
								+ Формат(ТекСтавка.Значение, "ЧН=0; ЧГ=0");	// Значение налога
					
					ИндексСтавки = ИндексСтавки + 1;
					
				КонецЦикла;
				
			КонецЦикла;
			
			ИндексНалоговойСтавкиГруппы = 1;
			
			Для Каждого ТекКомбинация Из КомбинацииНалогов Цикл
				
				КодКомбинации = Формат(ТекКомбинация.Код, "ЧДЦ=; ЧГ=0");
				Текст = НСтр("ru = 'Группа №'") + КодКомбинации;
				
				БлокГрупп = БлокГрупп + Символы.ПС
							+ КодКомбинации + ";"	// Код
							+ Текст + ";"			// Наименование
							+ Текст;				// Текст
				
				Для Каждого ТекСтавкаКомбинации Из ТекКомбинация.Ставки Цикл
					
					Для Каждого ТекНалог Из Налоги Цикл
						
						Если ТекНалог.Код = ТекСтавкаКомбинации.КодНалога Тогда
							
							Для Каждого ТекСтавка Из ТекНалог.Ставки Цикл
								
								Если ТекСтавка.Код = ТекСтавкаКомбинации.КодСтавки Тогда
									
									БлокСтавокГрупп = БлокСтавокГрупп + Символы.ПС
													+ Формат(ИндексНалоговойСтавкиГруппы, "ЧДЦ=; ЧГ=0") + ";"	// Код
													+ КодКомбинации + ";"										// Код налоговой группы
													+ Формат(ТекСтавка.Индекс, "ЧДЦ=; ЧГ=0") + ";"				// Код налоговой ставки
													+ "0";														// Смена базы
													
									Прервать;
									
								КонецЕсли;
								
							КонецЦикла;
							
							Прервать;
							
						КонецЕсли;
						
					КонецЦикла;
					
					ИндексНалоговойСтавкиГруппы = ИндексНалоговойСтавкиГруппы + 1;
					
				КонецЦикла;
				
			КонецЦикла;
			
		КонецЕсли;
		
		БлокНалогов = "$$$DELETEALLTAXGROUPRATES
				|$$$DELETEALLTAXGROUPS
				|$$$DELETEALLTAXRATES" + Символы.ПС
				+ БлокСтавок + Символы.ПС
				+ БлокГрупп + Символы.ПС
				+ БлокСтавокГрупп;
	
	КонецЕсли;
	
	Если Результат Тогда
		
		Если ТекстовыйФайл.КоличествоСтрок()>0 Тогда
			
			// Определяем и удаляем блок видов оплаты.
			ТекстФайла = ТекстовыйФайл.ПолучитьТекст();
			
			Если Найти(ТекстФайла, "$$$DELETEALLTAXGROUPRATES")<>0 Тогда
				
				Для ИндексСтроки = 3 По ТекстовыйФайл.КоличествоСтрок() Цикл
					
					ТекущаяСтрока = ТекстовыйФайл.ПолучитьСтроку(ИндексСтроки);
					
					Если ТекущаяСтрока = "$$$DELETEALLTAXGROUPRATES" Тогда
						
						Пока Истина Цикл
							
							Если ИндексСтроки = ТекстовыйФайл.КоличествоСтрок() + 1 Тогда
								Прервать;
							КонецЕсли;
							
							ТекущаяСтрока = ТекстовыйФайл.ПолучитьСтроку(ИндексСтроки);
							
							Если ТекущаяСтрока <> "$$$REPLACEQUANTITY" И ТекущаяСтрока <> "$$$DELETEALLWARES" Тогда
								ТекстовыйФайл.УдалитьСтроку(ИндексСтроки);
							Иначе
								Прервать;
							КонецЕсли;
							
						КонецЦикла;
						
						Прервать;
						
					КонецЕсли;
					
				КонецЦикла;
				
			КонецЕсли;
			
		Иначе
			// Выгружаем в новый файл
			ТекстовыйФайл.ДобавитьСтроку("##@@&&");
			ТекстовыйФайл.ДобавитьСтроку("#");
		КонецЕсли;
		
		ТекстовыйФайл.ВставитьСтроку(3, БлокНалогов);
		
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции
Показать
14. dd93rus 19.03.18 12:28 Сейчас в теме
Розница 2.2 версии 2.2.7.40, франтол 5.21.1 признак
15. dd93rus 19.03.18 12:30 Сейчас в теме
Розница 2.2.7.40 франтол 5 2.21.1 признак предмета расчета не выгружается не на стандартном обмене, и с вашим расширением. В чем может быть причина?
16. coolseo 45 20.03.18 02:16 Сейчас в теме
(15)
Проверьте что у вас там стоит
17. bob_ 26 20.03.18 19:07 Сейчас в теме
проверил, расширение работает на релизе 2.2.7.40
18. silverr 14.04.18 13:26 Сейчас в теме
Доброго времени суток!
Ваша разработка "Расширение конфигурации "Выгрузка в Frontol с признаком расчетов" для 1С:Розница 2.2.7" обрабатывает файл выгрузки из Frontola?
У меня при загрузке отчета вылетает ошибка:
{ОбщийМодуль.ПодключаемоеОборудованиеАтолККМOfflineКлиент.Модуль(1410)}: Поле объекта не обнаружено (Тип)
19. ecstazi 02.05.18 18:25 Сейчас в теме
Для бухгалтерии подойдет?
21. bob_ 26 05.05.18 13:13 Сейчас в теме
23. Gallakr 22.06.18 12:49 Сейчас в теме
Добрый день! Пробую расширение на релизе 2.2.7.32 -не работает (см скриншоты). В справочнике вид номенклатуры признак указан(Экран 1). Прдскажите, что нужно сделать, чтобы выгрузить товары во Фронтол 5 правильно( с нудным признаком).
Прикрепленные файлы:
24. bob_ 26 22.06.18 20:09 Сейчас в теме
Не получается повторить ошибку, попробуйте использовать формат выгрузки Frontol 5 , ошибка будет такой же?
25. Gallakr 25.06.18 08:46 Сейчас в теме
Установила обновление розницы 2.2.8.29 и формат обмена Frontol 5- все заработало (даже без расширения). Спасибо.
Оставьте свое сообщение