Красивые графики. Пошаговая инструкция (Highstock)

Публикация № 704022

Разработка - Работа с интерфейсом

122
Данный подход опробован на библиотеках: Нighcharts и Highstock. Для работы будет необходима 1С и браузер Google Chrome. Чукча не писатель (первая публикация).

1) Скачиваем необходимую библиотеку https://www.highcharts.com/download

2) Открываем:

3) Ищем подходящий график (выбрал Spline):

 4) Для примера:

5) Правый клик. Открываем исходный код:

6) Копируем код страницы в шаблон:

7) Ищем дополнительные файлы (сразу за заголовком):

8) Указываем пути в нашу библиотеку:

9) Указываем нужные заголовки диаграммы:

10) Открываем отладчик кода:

11) Ставим точку останова там, где передаются данные (клик по номеру строки):

12) Обновляем страницу и смотрим формат массива «data»:

Тут всё просто. Массив состоит из массива массивов, в нижнем уровне два элемента: «Дата» и «Цена»

13) Для примера я взял данные курса доллара США по курсу ЦБ:

14) В макете ставим «метку» куда будем вставлять необходимые данные:

Было:

Стало:

15) Собираем данные и заполняем макет:

////Собираем данные для отображения графика в формате "[ [1290556800000,44.97],[1290556900000,44.98]......]
ДанныеДляГрафика = "[";
Для Каждого СтрокаКурса Из ТиблицаКурс Цикл
   ДанныеДляГрафика = ДанныеДляГрафика + "[" + Строка(Формат(СтрокаКурса.Дата - дата(1970,1,1,1,0,0) + 3600,"ЧГ=0")) + "000," + Строка(Формат(СтрокаКурса.Курс,"ЧРД=.; ЧГ=0")) + "]" + ",";			
КонецЦикла;
ДанныеДляГрафика = Лев(ДанныеДляГрафика,СтрДлина(ДанныеДляГрафика)-1) + "]";
		
		
////Заполняем макет
Макет = ЭтотОбъект.ПолучитьМакет("МакетГрафика");
Текст = Макет.ПолучитьТекст();
Текст = СтрЗаменить(Текст,"~ДанныеДляГрафика~",ДанныеДляГрафика);

16) Записываем в файл и открываем в браузере (как вариант можно вывести в поле HTML):

файлОтчёта = Новый ТекстовыйДокумент;
файлОтчёта.УстановитьТекст(Текст); 
ИмяФайлаОтчета = "C:\Users\KlyavlinFN\Desktop\Highstock\test.html";
файлОтчёта.Записать(ИмяФайлаОтчета);
ЗапуститьПриложение(ИмяФайлаОтчета);

17) Готовый результат:

122

Специальные предложения

Лучшие комментарии
3. Stepa86 1258 22.11.17 16:04 Сейчас в теме
1) Идем на https://www.highcharts.com/demo
Выбираем понравившийся график
Нажимаем на него
Внизу жмем кнопку "Едит ин джиэсфидле"
Экспериментируем с параметрами и данными

2) Идем на https://api.highcharts.com/highcharts/
кликаем, смотрим, читаем, переходим в примеры
Описание API тут короче.

3) Я тело функции собираю через JSON. Сперва накидываю все в структуру, потом формирую по нему json, потом подменяю

Процедура Инициализация() Экспорт

	Диаграмма = Новый Структура;
	
	_Свойство( "credits" ).Вставить( "enabled", Ложь );
	_Свойство( "exporting" ).Вставить( "enabled", Ложь );

КонецПроцедуры

Процедура УстановитьОсьX( Знач пДанные) Экспорт
	
	ось = _Свойство( "xAxis" );
	
	ось.Вставить( "crosshair", Истина );
	ось.Вставить( "categories", пДанные );
	ПолучитьСвойство( ось, "labels" ).Вставить("enabled", Ложь );
	
	ПолучитьСвойство( ось, "events" ).Вставить( "setExtremes", "__syncExtremes__" );
	
КонецПроцедуры

...

Функция Контейнер( Знач пИмяКонтейнера = "container") Экспорт
	
	Возврат "$('<div class=""chart"">')
	|        .appendTo('#" + пИмяКонтейнера + "')
	|        .highcharts( " + ПолучитьJSON() + ")
	|";
	
КонецФункции

Функция ПолучитьJSON()
	
	записьJSON = Новый ЗаписьJSON;
	записьJSON.УстановитьСтроку();
	
	ЗаписатьJSON( записьJSON, Диаграмма );
	
	строкаJSON = записьJSON.Закрыть();
	
	Для каждого цЭлемент Из Подмены() Цикл
		
		строкаJSON = СтрЗаменить( строкаJSON, цЭлемент.Ключ, цЭлемент.Значение );
		
	КонецЦикла;
	
	Возврат строкаJSON;
	
КонецФункции

Функция Подмены()

	подмены = Новый Соответствие;
	подмены.Вставить( """Null""", "null" );
	подмены.Вставить( """__positioner__right""", "function() { return { x: this.chart.chartWidth - this.label.width, y: 10 }; }" );
	подмены.Вставить( """__positioner__left""", "function() { return { x: 50, y: 10 }; }" );
	подмены.Вставить( """__syncExtremes__""", "syncExtremes" );
	
	Возврат подмены;

КонецФункции
Показать
DrAku1a; RabadanovAG; wunderland; CrackedBone; perpleks; dour-dead; 🅵🅾️🆇; Lem0n; Dracarys; ZSS2014; rhtr; Saint13; shalimski; TreeDogNight; kirillkr; kiruha; +16 Ответить
Остальные комментарии
Избранное Подписка Сортировка: Древо
1. kiruha 380 22.11.17 15:03 Сейчас в теме
Есть еще рисунки получаемых графиков ?
Алгоритм везде одинаковый ?
Как задается масштаб графика ?
2. Degrement 121 22.11.17 15:23 Сейчас в теме
Из того что делал:
1) Биржевые свечи.
2) Биржевые свечи + объём.
3) Несколько серий на одном графике.

Алгоритм "примерно" везде одинаковый:
Находим нужный график => открываем код в хроме => ищем где задаются данные => формируем данные на стороне 1С => передаём в шаблон выбранного графика(макета) => получаем нужный график.

Для нескольких серий на одном графике пришлось поплясать с бубном и часть взять из другого примера.

Что вы подразумеваете под масштабом графика?

В прикреплённом файле обработка по нескольким сериям.
Прикрепленные файлы:
График показатели.epf
3. Stepa86 1258 22.11.17 16:04 Сейчас в теме
1) Идем на https://www.highcharts.com/demo
Выбираем понравившийся график
Нажимаем на него
Внизу жмем кнопку "Едит ин джиэсфидле"
Экспериментируем с параметрами и данными

2) Идем на https://api.highcharts.com/highcharts/
кликаем, смотрим, читаем, переходим в примеры
Описание API тут короче.

3) Я тело функции собираю через JSON. Сперва накидываю все в структуру, потом формирую по нему json, потом подменяю

Процедура Инициализация() Экспорт

	Диаграмма = Новый Структура;
	
	_Свойство( "credits" ).Вставить( "enabled", Ложь );
	_Свойство( "exporting" ).Вставить( "enabled", Ложь );

КонецПроцедуры

Процедура УстановитьОсьX( Знач пДанные) Экспорт
	
	ось = _Свойство( "xAxis" );
	
	ось.Вставить( "crosshair", Истина );
	ось.Вставить( "categories", пДанные );
	ПолучитьСвойство( ось, "labels" ).Вставить("enabled", Ложь );
	
	ПолучитьСвойство( ось, "events" ).Вставить( "setExtremes", "__syncExtremes__" );
	
КонецПроцедуры

...

Функция Контейнер( Знач пИмяКонтейнера = "container") Экспорт
	
	Возврат "$('<div class=""chart"">')
	|        .appendTo('#" + пИмяКонтейнера + "')
	|        .highcharts( " + ПолучитьJSON() + ")
	|";
	
КонецФункции

Функция ПолучитьJSON()
	
	записьJSON = Новый ЗаписьJSON;
	записьJSON.УстановитьСтроку();
	
	ЗаписатьJSON( записьJSON, Диаграмма );
	
	строкаJSON = записьJSON.Закрыть();
	
	Для каждого цЭлемент Из Подмены() Цикл
		
		строкаJSON = СтрЗаменить( строкаJSON, цЭлемент.Ключ, цЭлемент.Значение );
		
	КонецЦикла;
	
	Возврат строкаJSON;
	
КонецФункции

Функция Подмены()

	подмены = Новый Соответствие;
	подмены.Вставить( """Null""", "null" );
	подмены.Вставить( """__positioner__right""", "function() { return { x: this.chart.chartWidth - this.label.width, y: 10 }; }" );
	подмены.Вставить( """__positioner__left""", "function() { return { x: 50, y: 10 }; }" );
	подмены.Вставить( """__syncExtremes__""", "syncExtremes" );
	
	Возврат подмены;

КонецФункции
Показать
DrAku1a; RabadanovAG; wunderland; CrackedBone; perpleks; dour-dead; 🅵🅾️🆇; Lem0n; Dracarys; ZSS2014; rhtr; Saint13; shalimski; TreeDogNight; kirillkr; kiruha; +16 Ответить
4. Degrement 121 22.11.17 16:10 Сейчас в теме
(3)
строкаJSON

Спасибо за пример. Я сейчас тоже в этом направлении рыть начал. Пока написал инструкцию для "чайников", чтоб было с чего начать.
5. ABudnikov 3 22.11.17 17:17 Сейчас в теме
А можно каким-то образом скрипт подключить к html полю 1С и получить такой красивый график внутри 1С?
6. Degrement 121 22.11.17 17:23 Сейчас в теме
(5)
ЭтаФорма.ЭлементыФормы.ПолеHTMLДокумента1.УстановитьТекст(""); 
	ЭтаФорма.ЭлементыФормы.ПолеHTMLДокумента1.Перейти(имяФайлаОтчета)
13. nayd 8 23.11.17 16:07 Сейчас в теме
ЭтаФорма.ЭлементыФормы.ПолеHTMLДокумента1.УстановитьТекст("");
ЭтаФорма.ЭлементыФормы.ПолеHTMLДокумента1.Перейти(имяФайлаОтчета)


В управляемой форме не могу разобраться, как вывести результат графика на форму.
Выдает 4 ошибки "На этой странице произошла ошибка сценария"

PS: кажется, дело в том, что html в 1с работает в режиме совместимости IE7
7. ILM 237 23.11.17 05:42 Сейчас в теме
Я так понимаю, что с отключенным интернетом в локалке красивых графиков не видать?
Честно сознаюсь - сам ещё не пробовал
8. Degrement 121 23.11.17 07:59 Сейчас в теме
(7)
По идее должно работать и без интернета, надо будет проверить, библиотеки все локальные.
9. ILM 237 23.11.17 11:11 Сейчас в теме
20. webester 29 04.02.18 20:00 Сейчас в теме
(7)Да вполне себе видать. Можно даже поле HTML документа на форму положить и получить графики внутри 1С правда за счет того, что там движок кривоват, выходит не всегда хорошо. Но в целом простые графики, две три штуки вполне себе получались.
10. acsent 1138 23.11.17 11:25 Сейчас в теме
вместо
СтрокаКурса.Дата - дата(1970,1,1,1,0,0) + 3600
можно
СтрокаКурса.Дата - дата(1970,1,1,0,0,0)
11. DitriX 1715 23.11.17 11:59 Сейчас в теме
как то странно сделано, а не проще сделать функцию в листе, куда вы будете слать данные из 1с, а то сейчас получается, если надо изменить данные - будет пересоздана страница, я верно понимаю?
12. Degrement 121 23.11.17 12:03 Сейчас в теме
(11)
В вэб программировании не силён, но я думаю такое реализовать возможно. Кстати вот пример на сайте разработчиков с динамическим выводом данных: https://www.highcharts.com/stock/demo/dynamic-update
14. Dimasik2007 407 23.11.17 22:05 Сейчас в теме
Не забываем - что этот движок не является бесплатным, и лицензия начинается от $430. Также на сайте часто примеры на его основе выкладываются. Особо богаты комментарии к подобным темам на решение подводных камней.
15. TreeDogNight 16 24.11.17 21:31 Сейчас в теме
(14) Можете скинуть ссылку где выкладывают эти примеры?
16. Dimasik2007 407 27.11.17 22:36 Сейчас в теме
17. Dimasik2007 407 27.11.17 22:38 Сейчас в теме
(15) И да, вы там бывали (в 16-м году, см. комменты :))
19. TreeDogNight 16 09.12.17 07:33 Сейчас в теме
18. borda4ev 29.11.17 09:24 Сейчас в теме
Идем сюда: https://datavizcatalogue.com/RU/index.html
Выбираем понравившийся график, идем и читаем API. Профит!
palsergeich; Dimasik2007; +2 Ответить
Оставьте свое сообщение

См. также

Создание асинхронных виджетов 75

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Описание нескольких способов создания асинхронных виджетов для 1С:Предприятия. Рассматриваются способы с использованием HTTP-сервисов и фоновых заданий.

16.10.2019    1996    YPermitin    15       

Формы. Трудности программной работы 71

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Бесплатно (free) Работа с интерфейсом

Рассматриваем основные подводные камни, с которыми приходится сталкиваться при программной работе с формами, а также способы обхода самых частых проблем.

06.10.2019    3525    YPermitin    21       

Лайфхаки 1С (часть 1). Настройки отчетов и печатных форм 1С 34

Статья Программист Пользователь Стажер Нет файла v8 1cv8.cf Россия Бесплатно (free) Работа с интерфейсом

Статья рассчитана на пользователей или программистов, которые только начинают работать с 1С, для максимально быстрого ознакомления с интерфейсом программы. В статье приведены лайфхаки, которые позволят вам быстро и эффективно научиться настраивать отчёты и печатные в среде программных продуктов 1С. Полученные знания значительно упростят взаимодействие с интерфейсом 1С и повысят продуктивность работы оператора.

02.10.2019    4134    VachKirp    8       

Добавляем виджет "Задачи от меня" в Документооборот 2.1 22

Статья Программист Нет файла v8 v8::Бизнес-процессы ДО Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Небольшая доработка Документооборота 2.1 для возможности добавления виджета "Задачи от меня" в обработку Текущие дела.

25.09.2019    1591    Sergey_Borisovi4    2       

[Механизм интерфейса] Часы 54

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом Практика программирования Разработка

Добавляем цифровые часы на форму, как бонус рассмотрим вариант и с аналоговыми.

26.08.2019    3132    rpgshnik    33       

Произвольная начальная страница через расширение (программно) 41

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Установка своей формы произвольному пользователю на начальную страницу.

14.08.2019    2576    nagaitseff    11       

Подходы, методы и инструменты UX/UI для разработки эффективных интерфейсов на 1С 31

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

Интерфейсам в 1С обычно уделяют мало внимания. Это в итоге снижает востребованность платформы, делает ее неконкурентной, лишает большой доли рынка. Как не потерять старых клиентов и привлекать новых с помощью интерфейсов, а главное – как сделать «правильный» интерфейс, рассказал участникам конференции Infostart Event 2018 Education управляющий партнер и основатель консалтинговой группы WiseAdvice Иван Тягунов.

07.08.2019    4556    IvanAT1981    14       

Пользовательские настройки системы компоновки данных 87

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Работа с интерфейсом

Работа с отчетами в пользовательском режиме, формы отчетов. Понятие пользовательских настроек в отчетах на СКД. Определение состава пользовательских настроек для разделов в целом и для отдельных элементов, для всего отчета и для отдельных группировок. Видимость функциональных опций в отчетах на СКД.

09.07.2019    6437    ids79    0       

Подсистема "Варианты отчетов". Используете ли Вы ее правильно? 212

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    14512    YPermitin    49       

Расшифровка отчета на СКД с детализацией по выбранному полю на основе БСП 91

Статья Программист Нет файла v8 v8::УФ v8::СКД 1cv8.cf Россия Бесплатно (free) Практика программирования Работа с интерфейсом Разработка

В данной статье рассмотрим механизм работы с расшифровкой отчета, созданного при помощи системы компоновки данных, в управляемом приложении. Показывать буду на примере реальной задачи. Условие: использовать имеющиеся в конфигурации механизмы БСП, с минимальными и "правильными" изменениями. Расшифровка должны быть двух видов на каждом поле: 1. Открывать ссылочный объект 2. Открывать новую форму с детализацией табличной части документа. Собственно ради второго пункта и писалась статья, в основном для себя, чтобы не забыть.

14.05.2019    7472    Viktor_Ermakov    6       

Свой макет оформления отчета 33

Статья Программист Нет файла v8 v8::СКД Россия Windows Бесплатно (free) Работа с интерфейсом

Пример создания и оформления и применения своего (пользовательского ) макета оформления для СКД.

24.04.2019    4567    olegpkc    5       

Динамический вывод таблицы значений на форму 35

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Вывести на форму таблицу значений, а потом на её место другую, третью, четвёртую? Не вопрос.

11.01.2019    5713    Vlad1917    26       

Прикладной пример переработки стандартной формы РМК - Розница 74

Статья Программист Нет файла v8 Розница УУ Кассовые операции Розничная торговля Бесплатно (free) Работа с интерфейсом

Простой пример, как с помощью программного изменения шрифтов элементов формы достичь наилучшего результата отображения на примере формы РМК.

04.10.2018    10871    asdfgcom    56       

Cправочная информация. Картинки. 16

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Справочную информацию мало кто любит писать, но вот захотелось. И что с этим делать?

06.06.2018    6422    aspirator23    2       

Итоги в динамическом списке 47

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Предлагаю вариант, как быстро сделать итоги в динамическом списке, например в форме списка журнала документов.

28.05.2018    9017    CXY    16       

Программное управление обычными формами документов и справочников в УПП/КА 32

Статья Программист Нет файла v8 v8::УФ КА1 УПП1 Россия Бесплатно (free) Работа с интерфейсом

Если с программным изменением управляемых форм 1С все более или менее понятно, то с программированием обычных форм примеров не так уж много в сети. А уж примеров готовых решений совсем не видно. В данной статье я покажу, как можно реализовать аналог "управляемых" форм в своих конфигурациях с обычными формами и забыть о сложностях обновлений форм.

09.05.2018    8444    dima_home    7       

Решение проблемы отображения интерфейса Такси на экранах с маленьким разрешением 26

Статья Программист Нет файла v8 v8::УФ Беларусь Windows Бесплатно (free) Работа с интерфейсом

Решение возникшей проблемы при переходе с интерфейса 8.2 на интерфейс Такси на экранах с маленьким разрешением.

06.04.2018    9798    Drak87    18       

Меняем стандартную форму выбора для реквизита формы на свою форму с запросом 51

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Алгоритм действий для смены стандартной формы выбора для реквизита формы на свою форму со своей выборкой данных и возвратом нескольких параметров в вызывающую форму

30.09.2017    15819    ah7777777    24       

"Мигаем" интерфейсом, или цепочки асинхронных вызовов 71

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Работа с интерфейсом

Как, не блокируя интерфейс, привлечь внимание пользователя к интерфейсным элементам. Или, попросту говоря, "мигнуть" чем-то.

06.09.2017    12658    Chrizt    13       

"Восстановить положение окна" - не помогает. Как я решил проблему. 28

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Как получилось решить проблему глюков отображения формы документа.

28.05.2017    46800    niko11s    44       

Как добавить/убрать кота в отчет? 78

Статья Программист Нет файла v8 БП3.0 Бесплатно (free) Работа с интерфейсом

Кот в отчете: кому-то нравится, кого-то жутко бесит. Как избавиться, заменить, оставить (нужное подчеркнуть)?

12.05.2017    23143    starik-2005    16       

Итоги в динамическом списке 46

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Работа с интерфейсом

Как быстро посчитать итоги в динамическом списке

03.04.2017    21013    Восьмой    34       

Исправление проблем со встраиванием внешних отчетов в УНФ 1.6 12

Статья Программист Нет файла v8 УНФ Россия Бесплатно (free) Работа с интерфейсом

В УНФ 1.6 (тестил на версии 1.6.7.43) существуют следующие проблемы: 1. при встраивании доп. отчета в базу, он не отображается, пока не собьешь фильтр подсистемы 2. при встраивании доп. отчета в базу, отсутствует команда «Дополнительные отчеты» (по аналогии с командной «Дополнительные обработки») . В статье описывается решение перечисленных проблем.

16.11.2016    11520    TheRealStanly    3       

Как "перемотать" динамический список в начало при открытии? (или некоторые нюансы получения данных динамического списка) 57

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

В современных интерфейсах (новостях, социальных сетях и прочим) принято размещать новые данные сверху, более старые - внизу. К сожалению, в 1C сделано несколько по-другому - по умолчанию списки документов отсортированы по возрастанию даты и далее возможно два варианта: либо список при открытии проматывается в конец, либо список может запоминать "последнюю" текущую строку.

03.11.2016    19102    Fragster    25       

Программное создание графических схем (v.2): API для ГрафическойСхемы 73

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Работа с интерфейсом Универсальные функции

Пример динамического создания графических схем, добавления элементов любых видов. Любые схемы без бизнес-процессов. Программная работа со схемой. Отличие от существующей статьи в том, что здесь используется объектная модель. Исправил и упростил некоторые моменты - результат соответствует схеме, созданной руками. Добавил возможность рисования произвольных форм для существующих фигур.

27.09.2016    16930    serg_infostart    15       

Автоматическое добавление новых реквизитов на форму (УФ) 38

Статья Программист Нет файла v8 v8::УФ Бесплатно (free) Работа с интерфейсом Универсальные функции

Идея такая: Программист добавил реквизит в объект. В комментарии этого реквизита прописал некое спец. слово (можно не матерное). На форму объекта новый реквизит далее попадает автоматом в спец. группу "Дополнительно".

03.08.2016    16268    Патриот    23       

Управляемые формы: Поле HTML Документа и веб-клиент 57

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Взаимодействие javascript и интерфейса 1С дает огромные возможности для реализации нестандартных функций. Раньше можно было напрямую вызывать функции JavaScript через DOM объект document Поля HTML документа. В современных браузерах эта возможность ушла. Более того, в веб-клиенте появляется тип ВнешнийОбъект, который вообще нигде не описан. На Инфостарте были предложения вызывать JavaScript через fireEvent, но это очень неудобно. Предлагаю свой вариант решения.

18.07.2016    24243    compguru    10       

Как вывести динамическое представление для пустого значения (в таблице)? 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Работа с интерфейсом

Есть таблица. Часть полей в ней заполняется автоматически, а часть - должен заполнить пользователь. Нужно подсказать пользователю, что именно в какую ячейку вводить - для этого выведем серым текст подсказки внутри каждой незаполненной ячейки. На поиски решения этой задачки я потратил половину субботы. Надеюсь, моя небольшая заметка поможет кому то провести выходные более продуктивно)

29.03.2016    9755    weissfeuer    9       

Выделение документов в динамическом списке 20

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

Допустим, пользователю конфигурации на управляемых формах захотелось выделять документы в списке привычным образом и производить какие-то манипуляции с выделенными документами. Например, делать на их основании какие-то документы.

01.02.2016    15833    Sardukar    7       

Три приёма, позволяющие сделать интерфейс конфигураций 1С на управляемых формах удобнее при большом шрифте 52

Статья Программист Нет файла v8 УНФ ERP2 БП3.0 Windows Бесплатно (free) Работа с интерфейсом Универсальные функции

С появлением управляемых форм вообще и БП 3.0 в частности пользователи, которые не хотят портить своё зрение рассматриванием мелкого шрифта, оказались в невыгодном положении. Многих элементов на экране в "тяжёлых" документах вообще оказалось не видно. Все попытки решить вопрос штатными средствами настройки предприятия оказались неэффективны. Вот несколько приёмов, которые буквально в два щелчка мышкой и парой строк кода помогут решить проблему.

05.11.2015    15050    H-Labs    11       

Как скрыть "пустые группы" в списке выбора справочника при отборе 46

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

Когда требуется открыть список справочника с отбором, например, по определённой группе, видны также все остальные группы с пустым содержимым. Мой способ избавления от ненужных групп ниже.

29.10.2015    25669    shevelyov    25       

Открытие форм нескольких новых документов в тонком и толстом клиенте, УФ 23

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Windows Бесплатно (free) Работа с интерфейсом

Если Вам необходимо создать несколько документов, а затем открыть их формы для пользователя.

1 стартмани

29.09.2015    18083    Wezoowy    13       

Параметры сеанса. 47

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Работа с интерфейсом

Параметры сеанса - это объекты метаданных конфигурации. Поговорим об их назначении и принципах работы с ними.

06.09.2015    55572    niko11s    8       

Шкала в строке состояния 51

Статья Программист Нет файла v8 Windows Бесплатно (free) Работа с интерфейсом

Простая шкала, не требующая дополнительных форм и элементов управления

31.08.2015    13493    Ivon    26       

Назначение сочетания клавиш для кнопок командной панели (Обычные формы) 13

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Работа с интерфейсом

Назначение сочетания клавиш кнопкам командной панели Формы списка/выбора для любой конфигурации (Обычные формы)

07.08.2015    15181    bld    7       

Развитие управляемого интерфейса в 1С 8.2 - 1С 8.3 55

Статья Программист Нет файла v8 Windows Бесплатно (free) Практика программирования Математика и алгоритмы Работа с интерфейсом

К управляемым формам, которые появились в 8.2, я до сих пор относился презрительно. Считал это неудачной попыткой 1С следовать модным тенденциям в разработке интерфейсов и прогибом для возможности работать через браузер. Я считал, что 1С пожертвовала простотой разработки в угоду веб-доступу. Но после курсов Арутюнова Сергея по управляемому интерфейсу в июле 2015 года в УЦ1 я поменял ненависть на любовь. Звучит парадоксально, но это так. А теперь подробнее…

27.07.2015    35090    fixin    103       

Идея или как сохранить ЦВЕТ, ШРИФТ, ОФОРМЛЕНИЕ пользователя 25

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Простой и оригинальный способ сохранять ЦВЕТОВУЮ СХЕМУ и ОФОРМЛЕНИЕ пользователей. Как сохранить ЦВЕТ

22.06.2015    21484    Tatitutu    12       

Недокументированное использование стандартных обработок из меню "Все функции". 903

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Работа с интерфейсом

Рассмотрены возможности произвольного использования стандартных функций, вызываемых из меню платформы "Все функции" - "Стандартные" (Активные пользователи, Журнал регистрации, Поиск ссылок на объект, Проведение документов ...).

19.06.2015    100692    ekaruk    121       

Быстрый ввод строковых значений в поля составного типа 64

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Когда нужно дать пользователю возможность вводить с клавиатуры строковые значения в поле ввода составного типа

04.06.2015    17270    Cyberhawk    14       

Личный опыт эскплуатации интерфейса "Такси" 11

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Работа с интерфейсом

Уважаемые коллеги, предлагаю вам мой личный опыт использования интерфейса "Такси"

07.02.2015    15443    Marik    30       

Как перенести форму документа (справочника, ...) из одного документа (справочника, ...) в другой похожий документ (справочник, ...) 54

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Работа с интерфейсом

При попытке изменить Тип Реквизита «Объект» все элементы формы теряли путь к данным, ладно бы «поля ввода» (можно было выбрать заново «путь к данным»), но с табличными частями вообще труба, при выборе в «Таблице» все колонки в этом элементе банально удалялись. Можно, конечно, потратить кучу времени и вручную продублировать все то, что есть в форме оригинала, но я нашел другой путь!

26.11.2014    14328    RomanBor    18       

Создание интерфейса со всеми блокировками прав пользователя 20

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Работа с интерфейсом

Создание интерфейса (напр. Продавец) со всеми блокировками прав пользователя (доступ к конфигуратору, меню Операции, Все функции, правам пользователей в меню сервис и др.)

10.10.2014    12385    ~ADm!t_@vd~    8       

Свернуть с учетом уровня дерево значений на управляемой форме 11

Статья Программист Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Работа с интерфейсом

Набор процедур, которые сворачивают дерево значений на управляемой форме до определенного уровня

03.10.2014    13056    ivashka    2       

Добавление дополнительных отчетов и обработок в тонком клиенте. 44

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Работа с интерфейсом

Для того чтобы добавить дополнительную обработку или отчет в тонкий клиент нужно в модули отчета или обработки прописать одну процедуру и две функции.

30.09.2014    63092    John_d    14