ЗиК 7.7 заполнение данных по донорским дням в карточке "Сведения о стаже"

Публикация № 72726

Разработка - Практика программирования

2
Сначала оговорюсь, что наша конфигурация неоднократно изменялась и от стандартной очень отличается, поэтому буду приводить куски кода без указания номеров строк. Документы по донорским дням вводятся в систему через документ «Оплата по среднему» вид расчета указывается «Дни доноров» (собственно добавленный нами вид расчета). Так как донорские дни не облагаются страховыми взносами, то и в стаж эти дни попадать не должны. Соответственно при сдачи отчетности в ПФР нужно заполнять карточку «Сведения о стаже». Это конечно можно было сделать вручную, когда документов не больше десятка, но когда их более 250, то бухгалтерам проблематично внести все отклонения в систему. Поэтому автоматизируем процесс :)  

1. Перечисление- СЗВПараметр3ИТС2010 добавить значение «ДОНОРСКИЕ»

      2. Добавить в процедуру глЗаполнитьТаблицуСотрудниковСОсобымиПериодами передаваемый параметр СписокВРДонорскиеДни

Процедура глЗаполнитьТаблицуСотрудниковСОсобымиПериодами(ТаблицаСотрудниковСОсобымиПериодами, СписокСотрудников, ДатаНачала, ДатаОкончания,СписокВРБольничныеЛисты,СписокВРОтпускаБезСохранения,

СписокВРОтпускаИсключаемыеИзСтажа,СписокВРДонорскиеДни)  

 

      3. Добавить запрос а процедуру глЗаполнитьТаблицуСотрудниковСОсобымиПериодами

Запрос=СоздатьОбъект("Запрос"); 

      ТекстЗапроса = "//{{ЗАПРОС(ТаблицаПериодовДействияОтпуск)

      |с ДатаЗапросаС по ДатаЗапросаПо;

      |Сотрудник = ЖурналРасчетов.Зарплата.Объект;

      |ВидРасч = ЖурналРасчетов.Зарплата.ВидРасч;

      |Группировка Сотрудник без групп;

      |Условие(Сотрудник в СписокСотрудников);

      |Условие(ВидРасч в СписокВРОтпускаИсключаемыеИзСтажа);

      |"//}}ЗАПРОС

      ;

            Если Запрос.Выполнить(ТекстЗапроса) =1 Тогда

                  Пока Запрос.Группировка("Сотрудник")=1 Цикл

                             ТаблицаСотрудниковСОсобымиПериодами.НоваяСтрока();

                             ТаблицаСотрудниковСОсобымиПериодами.Сотрудник = Запрос.Сотрудник;

                             ТаблицаСотрудниковСОсобымиПериодами.ЕстьОтпуск = 1;

                  КонецЦикла;

      КонецЕсли;

     Запрос=СоздатьОбъект("Запрос");   //Zarema ДонорскиеДни начало изм. 

      ТекстЗапроса = "//{{ЗАПРОС(ТаблицаПериодовДействияДонорскиеДни)

      |с ДатаЗапросаС по ДатаЗапросаПо;

      |Сотрудник = ЖурналРасчетов.Зарплата.Объект;

      |ВидРасч = ЖурналРасчетов.Зарплата.ВидРасч;

      |Группировка Сотрудник без групп;

      |Условие(Сотрудник в СписокСотрудников);

      |Условие(ВидРасч в СписокВРДонорскиеДни);

      |"//}}ЗАПРОС

      ;

     

      Если Запрос.Выполнить(ТекстЗапроса) =1 Тогда

                  Пока Запрос.Группировка("Сотрудник")=1 Цикл

                             ТаблицаСотрудниковСОсобымиПериодами.НоваяСтрока();

                             ТаблицаСотрудниковСОсобымиПериодами.Сотрудник = Запрос.Сотрудник;

                             ТаблицаСотрудниковСОсобымиПериодами.ЕстьДонорские = 1;

                  КонецЦикла;

      КонецЕсли;                                                         // Zarema  ДонорскиеДни конец изм.

 

  1. В процедуру глСобратьДанныеДляСЗВ2010 добавить список значений

// заполним списоки в.р. которые используем в дальнейшем для выделения периода стажа

      СписокВРБольничныеЛисты = СоздатьОбъект("СписокЗначений"); 

      СписокВРОтпускаБезСохранения = СоздатьОбъект("СписокЗначений");

      СписокВРОтпускаИсключаемыеИзСтажа = СоздатьОбъект("СписокЗначений");

      СписокВРДонорскиеДни = СоздатьОбъект("СписокЗначений"); //Zarema ДонорскиеДни

      Для Сч = 1 По ГруппаРасчетов.УчитыватьДни.Количество() Цикл // эти в.р. определяют отработанное время

                  ВР = ГруппаРасчетов.УчитыватьДни.ПолучитьРасчет(Сч);

                  Если ВР.ВходитВГруппу(ГруппаРасчетов.БольничныеЛисты) = 1 Тогда

                             Если (ВР <> ВидРасчета.ОтпускПоБеременностиПоТекущемуМесяцу)

                             и (ВР <> ВидРасчета.ОтпускПоБеременности)

                             и (ВР <> ВидРасчета.ОтпускПоБеременностис2004)

                             и (ВР <> ВидРасчета.ОтпускПоБеременностис2005)

                             и (ВР <> ВидРасчета.ОтпускПоБеременностис2007)

                             и (ВР <> ВидРасчета.ОтпускПоБеременностис2010) Тогда

                                         // больничные листы, кроме отпуска по беременности и родам

                                         СписокВРБольничныеЛисты.ДобавитьЗначение(ВР);

                             КонецЕсли;

                  ИначеЕсли (ВР = ВидРасчета.ОтпускЗаСвойСчетКраткосрочный)или (ВР = ВидРасчета.ОтпускЗаСвойСчетДолгосрочный)  Тогда

                             //отпуска без сохранения заработной платы  

                             СписокВРОтпускаБезСохранения.ДобавитьЗначение(ВР);

                             СписокВРОтпускаИсключаемыеИзСтажа.ДобавитьЗначение(ВР);

                  ИначеЕсли (ВР = ВидРасчета.ОтпускУчебный)  Тогда

                      СписокВРОтпускаИсключаемыеИзСтажа.ДобавитьЗначение(ВР);

                  ИначеЕсли (ВР = ВидРасчета.ДниДоноров) Тогда         //Zarema ДонорскиеДни

                             СписокВРДонорскиеДни.ДобавитьЗначение(ВР);

                  КонецЕсли;

      КонецЦикла; 

// получим таблицу значений в которй будут сотрудники, имевшие в периоде отчета

      // отпуск без сохранения ЗП, больничные или отпуска, исключаемые из льготного стажа

      ТаблицаСотрудниковСОсобымиПериодами=СоздатьОбъект("ТаблицаЗначений");

      ТаблицаСотрудниковСОсобымиПериодами.НоваяКолонка("Сотрудник");

      ТаблицаСотрудниковСОсобымиПериодами.НоваяКолонка("ЕстьБЛ", "Число", 1, 0);

      ТаблицаСотрудниковСОсобымиПериодами.НоваяКолонка("ЕстьОтпускЗаСвойСчет", "Число", 1, 0);

      ТаблицаСотрудниковСОсобымиПериодами.НоваяКолонка("ЕстьОтпуск", "Число", 1, 0);

      ТаблицаСотрудниковСОсобымиПериодами.НоваяКолонка("ЕстьДонорские","Число",1,0); //Zarema ДонорскиеДни

глЗаполнитьТаблицуСотрудниковСОсобымиПериодами(ТаблицаСотрудниковСОсобымиПериодами, Сотрудники, ДатаНачала, ДатаОкончания,

                                                           СписокВРБольничныеЛисты,СписокВРОтпускаБезСохранения,СписокВРОтпускаИсключаемыеИзСтажа,

СписокВРДонорскиеДни);   // Zarema ДонорскиеДни

     

    Обнуляем все в той же процедуре значение ЕстьДонорские и получаем значения из таблицы 

ЕстьОтпуск = 0;

ЕстьБЛ = 0;

ЕстьОтпускЗаСвойСчет = 0;

ЕстьДонорские=0;     // Zarema ДонорскиеДни

НомСтрокиТОС = "";

                        ТаблицаСотрудниковСОсобымиПериодами.НайтиЗначение(Сотрудник,НомСтрокиТОС,"Сотрудник");

                             Если НомСтрокиТОС>0 Тогда

                                         ЕстьБЛ = ТаблицаСотрудниковСОсобымиПериодами.ПолучитьЗначение(НомСтрокиТОС,"ЕстьБЛ");

                                         ЕстьОтпускЗаСвойСчет = ТаблицаСотрудниковСОсобымиПериодами.ПолучитьЗначение(НомСтрокиТОС,"ЕстьОтпускЗаСвойСчет");

                                         ЕстьОтпуск = ТаблицаСотрудниковСОсобымиПериодами.ПолучитьЗначение(НомСтрокиТОС,"ЕстьОтпуск");

                                         ЕстьДонорские = ТаблицаСотрудниковСОсобымиПериодами.ПолучитьЗначение(НомСтрокиТОС,"ЕстьДонорские");  // Zarema ДонорскиеДни

                             КонецЕсли;

    Добавляем новое условие если есть донорские дни все в той же процедуре

 Если ЕстьБЛ = 1 Тогда

ТаблицаБЛ="";

       Если глЗаполнитьТаблицуПериодовДействияВР(Сотрудник,ТаблицаБЛ,Начало, Окончание, СписокВРБольничныеЛисты)=1 Тогда

//Создадим набор для стажа, которым будем замещать периоды

        НаборДляСтажа.УдалитьВсе();

        НаборДляСтажа.ДобавитьЗначение("");

        НаборДляСтажа.ДобавитьЗначение("");

        НаборДляСтажа.ДобавитьЗначение(Перечисление.СЗВПараметр3ИТС2010.ВРНЕТРУД);

        НаборДляСтажа.ДобавитьЗначение("");

        НаборДляСтажа.ДобавитьЗначение("");

        //впишем периоды отпусков за свой счет 

        ТаблицаБЛ.ВыбратьСтроки();

                  Пока ТаблицаБЛ.ПолучитьСтроку()=1 Цикл

                        НачалоПериода=ТаблицаБЛ.НачалоПериода;

                        ОкончаниеПериода=ТаблицаБЛ.ОкончаниеПериода;

                        //"впишем" во временную таблицу период

                        глВписатьОсновнуюЗаписьОСтаже2010("Вписать",ВремТаблицаСоСтажем,НомерЗаписи,НачалоПериода,ОкончаниеПериода, НаборДляСтажа);

                КонецЦикла;

           КонецЕсли;

       КонецЕсли;                                        

   // Zarema ДонорскиеДни          началоизм.

   Если  ЕстьДонорские = 1 Тогда

   ТаблицаДонор="";

   Если глЗаполнитьТаблицуПериодовДействияВР(Сотрудник,ТаблицаДонор,Начало, Окончание, СписокВРДонорскиеДни)=1 Тогда

 //Создадим набор для стажа, которым будем замещать периоды

 НаборДляСтажа.УдалитьВсе();

 НаборДляСтажа.ДобавитьЗначение("");

 НаборДляСтажа.ДобавитьЗначение("");

 НаборДляСтажа.ДобавитьЗначение(Перечисление.СЗВПараметр3ИТС2010.ДОНОРСКИЕ);

 НаборДляСтажа.ДобавитьЗначение("");

 НаборДляСтажа.ДобавитьЗначение("");

 ТаблицаДонор.ВыбратьСтроки();

 Пока ТаблицаДонор.ПолучитьСтроку()=1 Цикл

     НачалоПериода=ТаблицаДонор.НачалоПериода;

    ОкончаниеПериода=ТаблицаДонор.ОкончаниеПериода;

глВписатьОсновнуюЗаписьОСтаже2010("Вписать",ВремТаблицаСоСтажем,НомерЗаписи,НачалоПериода,ОкончаниеПериода, НаборДляСтажа);

       КонецЦикла;

    КонецЕсли;

  КонецЕсли;                          

                      // Zarema ДонорскиеДни      конецизм.             

 

                     

 

2

Специальные предложения

См. также

Записки на память. Зарплата и кадры 1С 7.7 (ЗиК 7.7 ) 54

Статья Системный администратор Программист Бухгалтер Нет файла v77::Расчет 1С7:ЗиК Россия БУ НУ УУ Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерский учет

ЗиК 7.7 постепенно сходит на нет. Но, возможно, кому-то из нас все-таки когда-либо еще не раз придется столкнуться с этой конфигурацией. Поскольку работы по ней и заказов всё меньше и меньше, знания о ней и опыт постепенно угасают. Мой опыт с ЗиК 7.7 длиной в 14 лет терять просто так неохота. В этой статье я запишу, чтобы не забыть, важные моменты об этой конфигурации, чтобы самому не забыть, и вдруг кто-то получит это в наследство на сопровождение и будет вынужден (иначе не скажешь) это обслуживать. Или еще можно рассматривать эту статью как модное нынче «Письмо самому себе в прошлое».

18.11.2014    35690    Lapitskiy    26       

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая 25

Статья Программист Нет файла v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    4881    filh    19       

Перерасчет ФСС НС за предыдущий период в ЗиК 315 11

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Адаптация типовых решений

Если изменить базу вида расчета «ФСС НС», то в релизе 1С:Зарплата и Кадры 7.70.315, в текущем расчетном периоде не происходит перерасчет за предыдущие периоды.

02.11.2011    15062    Nicholas    13       

ЗиК: Заполнение данных о заработке у предыдущих работодателей в больничном 9

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Доработка ЗиК 314. Заполнение данных в больничном за 2 предыдущих года у другого работодателя. Для работы необходимо добавить в конфигурацию новый справочник.

04.10.2011    9401    allexe    13       

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК 18

Статья Программист Нет файла v77::Расчет 1cv7.md 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    6891    maxim305    18       

1С 7.7 ЗиК. Доработка документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке 8

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Маленькая доработка модуля документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке. Не забудьте, когда будете заполнять документ "Бригадный наряд", поставить галочку "Учитывать отработанные часы".

08.09.2011    4879    Ироида    14       

Расчет сверхурочной работы 25

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата Учет рабочего времени Бесплатно (free) Бухгалтерские

Сверхурочной работой считается работа, производимая работником по инициативе работодателя сверх нормального числа рабочих часов за учетный период (п.1 ч.2 ст. 99 ТК РФ). Данная обработка позволяет автоматически по итогам учетного периода (месяц, квартал, год) расчитать переработку сотрудников и расчитать им доплату за сверхурочную работу.

31.08.2011    19096    151    victuan    29       

Расшифровка внутренних расчетов 1С:Зарплата 10

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Трассировка (расшифровка) промежуточных расчетов документов в 1С:Зарплата

20.07.2011    8682    buhinfo    5       

Кнопка обновления версии внешнего отчета 18

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет Россия Бесплатно (free) Практика программирования

После исправления внешнего отчета вместо рекомендации пользователю: "Закрой отчет и открой его заново", говорим: "Нажми на кнопку".

18.06.2011    11930    Shaman100M    8       

Методика расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года (вариант) 32

Статья Программист Нет файла v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

В статье рассмотрен один из возможных вариантов расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года.

14.06.2011    19589    vkr    48       

Особенности сортировки в 1С:Предприятие 7.7 22

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Бесплатно (free) Практика программирования

Подобная "разработка" использовалась для анализа/сравнения порядка индексов таблиц БД в различных СУБД: "родные" DBF, MS SQL, CodeBase 6.5, Advantage 7.x/8.x/9.x. Тогда было выяснено, что в этих СУБД разный порядок сортировки индекса.

29.05.2011    15429    68    hogik    4       

Лицевой счет для ЗиК 7.7 8

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные печатные формы Бухгалтерские

В ЗиКе есть отчет Лицевые счета и карточки-справки. Для хозрасчетных организаций печатная форма только одна Т-54а, для бюджетных организаций имеется еще 2 печатных формы довольно удобных. В обработке сохранен отчет с установленным флагом бюджетной организации. Может кому пригодится.

12.05.2011    7936    165    VladB50    7       

Форма 1-НДФЛ для 2011 года (Зарплата и Кадры 7.7, релиз 310) 29

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Бесплатно (free) Практика программирования

В прежних релизах была возможность из справочника "Сотрудники" сформировать форму 1-НДФЛ по кнопке "Ввод данных" (там была возможность расшифровки сумм). Вернём полезную функцию!

29.04.2011    4655    Q-Q    9       

Некоторые ошибки и «проблемные» особенности реализации встроенного языка платформы 1С:Предприятие 7.7 96

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Описание некоторых ошибок и особенностей реализации встроенного языка, которые создают «подводные камни» при программировании, а также возможных способов обхода этих проблем из собственного опыта работы на платформе 1С:Предприятие 7.7.

08.04.2011    42500    AleksR    102       

Вариант реализации динамического табло в 1С 7.7 12

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Позволяет отображать на экране (монитора или большого телевизора) результат работы требуемого отчета при изменении определенных данных без необходимости интерактивного участия пользователя

14.03.2011    7333    1с2с    19       

Отпуск по уходу за ребенком. Расчет по-новому и по-старому 32

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Управление персоналом (HRM) Бесплатно (free) Практика программирования

По новому законодательству расчет среднего заработка для отпуска по уходу можно производить как по старым правилам, так и по новым, на усмотрение сотрудника. Реализуем это в ЗиК.

11.03.2011    10410    Nicholas    9       

Две простенькие функции для правильного учета сторно-записей и записей-перерасчетов 9

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Часто при подсчете дней по записям журнала расчетов "Зарплата" берется знак "+" или "-" в зависимости от признака сторно-записи. Но рано или поздно результат получится ошибочным.

19.02.2011    8840    jack19    3       

Ошибки формата файла 2-НДФЛ в ЗиК релиз 306 100

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия НУ Зарплата НДФЛ Бесплатно (free) Практика программирования

Ошибки 2НДФЛ в релизе: файл формируется как для ЮЛ, даже если работодатель ИП, опечатка "Отчетсвто", и указание имени файла с расширением. Нужно подправить отчет "СправкиПоНДФЛ".

02.02.2011    17423    1st    6       

ПФР за год 10

Статья Бухгалтер Нет файла v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Учет и отчетность

Могу подсказать алгоритм, как надо заполнять документ "Расчеты по страховым взносам", чтобы отчет для ПФР сошелся в копеечку

29.01.2011    6982    Lika-Kalika    3       

ЗиК 305 ЗиК 306 Больничный лист. 107

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Для переходящих больничных листов за счет работодателя оплачивается 2 дня, а не 3. Первоисточник: http://forums.kuban.ru/forum/viewtopi...669&page=2

25.01.2011    12475    Cvetic    26       

ЗиК 306 и ЗиК 305. Единовременные пособия из ФСС для организаций уплащивающих ЕНВД 10

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

Возникла ошибка когда Единовременные пособия из ФСС неправильно вставали в "Карточку расчета страховых взносов" если были выплаченны после сентября месяца. и сотвественно неправильно формируеться РСВ-1

25.01.2011    8037    *Zed*    2       

Тюнинг Бух 7.7.: Микрографики в ТЧ документа. 49

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Как вставить в документ что-то вроде диаграммы распределения сумм…

25.01.2011    18513    Арчибальд    18       

ЗиК 2011 (ставки ФОМС) 90

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ НУ Windows Зарплата Управление персоналом (HRM) ФОМС, ПФ, ФСС Бесплатно (free) Обработка справочников

Обработка устанавливает в типовой конфигурации "Зарплата и Кадры 7.7" (релиз 305) ставки страховых взносов, измененные с 1 января 2011 года Федеральным законом от 16.10.10 № 272-ФЗ.

09.01.2011    11746    588    Antia    11       

Быстрый подсчет элементов справочника 17

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Частенько бывает нужно подсчитать количество элементов в справочнике, чтобы показать пользователю прогресс выполнения обработки. Быстро это сделать позволяет следующая функция.

18.10.2010    21475    brr    11       

ЗиК.300 Загогулина 59

Инструменты и обработки Программист Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

В конфигурации ЗиК.300 при использовании при расчетах любого единовременного пособия из соцстраха (рождение, погребение…) - возможна ошибка в своде проводок...

24.08.2010    13184    UV2    14       

Изменяем вид кнопок на форме 1С 7.7 25

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Бесплатно (free) Практика программирования

Изменяем вид кнопок на форме 1С 7.7. Статья для разработчиков ВК (Delphi) Реализовано в http://infostart.ru/public/59436/?PAGEN_1=22#comm

20.08.2010    20959    Abadonna    12       

Максимум изменений в стандартной конфигурации при их минимуме с использованием formex.dll 34

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Практика программирования Разработка внешних компонент

Восстанавливаю ранее опубликованную статью. Может кому пригодится... Иногда очень хочется что-нибудь добавить в стандартную конфигурацию, но потом возникают проблемы, связанные с "затиранием" кода при обновлении. Каждый раз помнить где и что - напряжно. При данном подходе в Глобальный Модуль добавляется всего одна (!) строчка

15.08.2010    16751    Abadonna    33       

Список сотрудников с особыми условиями труда для ПФР. (Версия от 16.07.2011) 25

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

Формирование и выгрузка списка сотрудников с особыми условиями труда в xml-файл под версию 1.9 Отчет переписан почти заново. Обновление 16.07.2011.

23.07.2010    16577    403    rechvladmir    22       

Ускоритель СЗВ 2010 для ЗиК 2.99 30

Статья Системный администратор Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Ускоряет формирование СЗВ примерно вполовину за счет уменьшения числа запросов. Реально полезно, когда надо часто и много заходить в редактирование форм СЗВ. ЗиК 2.99

20.07.2010    8173    aves    7       

ЗиК 298 Ошибка в исчислении стажа. Отчетность ПФР СЗВ-6. 34

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Проблемы у сотрудников, имеющих Больничные листы, у которых либо Начало болезни = конец месяца либо Окончание болезни = начало месяца. В первом случае в СЗВ-6 началом болезни считается начало следующего месяца, во втором окончание болезни - конец месяца.

13.07.2010    11213    Cvetic    19       

Подготовка сведений для ПФР за 1 полугодие 2010 года - ошибка (Конфигурация Зарплата и кадры 7.7. Релиз 298) 8

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Регламентированная отчетность

Обработка по формированию печатных форм и выгружаемых файлов в соответствии с требованиями ПФ РФ, полученная от krein, по ссылке http://infostart.ru/public/72604!

04.07.2010    9249    218    vladimir_astapov    7       

Штатное расписание по факту (со всеми надбавками, с оплатой по окладам и тарифам) 23

Отчеты и формы no Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

Учитываются не только оклады, но и часовые тарифы сотрудников, а также все постоянные надбавки, введены ли они через справочник "Штатное расписание" или документами.

18.06.2010    8969    312    pr_skm    12       

Разбор строки CSV при помощи RegExp 12

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Вроде бы все просто, пока не встретилось что-то наподобие "111;111""";111

27.05.2010    12557    Berrimor    16       

Фильтрация иерархического справочника по какому-либо условию в форме списка 13

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Перед 1С программистами порой встаёт задача реализовать фильтрацию справочника по какому-нибудь условию прямо в форме списка (Например "ФормаСписка" или "ДляПодбора"). Вот и передо мной, недавно, поставили такую задачу. Она оказалась не такой уж и тривиальной, особенно для иерархического справочника...

19.05.2010    10863    Antoska    19       

Как получить GUID без v7plus.dll в Предприятии 7.7 10

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Универсальные функции

Часто в терминальных сессиях у пользователю Windows не хватает прав на регистрацию v7plus.dll. Соответственно нельзя воспользоваться, например методом СоздатьGUID() класса V7SysInfo.

12.05.2010    12435    prolancer    5       

Расчетная ведомость с детализацией по месяцам 46

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Бесплатно (free) Универсальные печатные формы Бухгалтерские

Стандартная расчетная ведомость с возможностью формирования за произвольный период. С детализацией по месяцам.

04.05.2010    17737    676    Diamante    14