ПрогрессБар отдельной формой

Публикация № 78034

Программирование - Работа с интерфейсом

14
ПрогрессБар отдельной формой. Со "статистикой" (без ВК)

 

В Глобальный модуль вставить процедуру:

 

 

//*****************************************************************************

Процедура глПрогрессБар(Сейчас=0,Всего=0) Экспорт

Попытка

Если Всего>0 Тогда

Если ПустоеЗначение(глКонтПрогрессБар)=0 Тогда

глКонтПрогрессБар.Сейчас=Сейчас;

глКонтПрогрессБар.Всего=Всего;

глКонтПрогрессБар.Форма.Обновить();

КонецЕсли;

Иначе

Если ТипЗначенияСтр(Сейчас)="Строка" Тогда

ОткрытьФорму("Обработка.ПрогрессБар",глКонтПрогрессБар);

глКонтПрогрессБар.Форма.Заголовок(Сейчас);

Иначе

Если ПустоеЗначение(глКонтПрогрессБар)=0 Тогда

глКонтПрогрессБар.Форма.Закрыть();

КонецЕсли;

КонецЕсли;

КонецЕсли;

Исключение

КонецПопытки;

КонецПроцедуры

 

... Ну и Обработку "ПрогрессБар"

 

И пользовать.. Вот пример:

 

глПрогрессБар("Тест ПрогрессБара...");

Для ин=1 По 10000 Цикл

глПрогрессБар(ин,10000);

КонецЦикла;

глПрогрессБар();

 

14

Скачать файлы

Наименование Файл Версия Размер
ПрогрессБар.ert
.ert 49,00Kb
13.02.12
21
.ert 49,00Kb 21 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. via 86 19.11.10 13:24 Сейчас в теме
! Обратите внимание на бегающие часики
10. Lyns_owner 339 14.12.12 17:35 Сейчас в теме
(1) Очередной изобретатель велосипеда)

В общих формах в типовых решениях "ХодВыполненияОбработкиДанных", не?

11. via 86 17.12.12 12:00 Сейчас в теме
(10) Lyns_owner, Когда я это делал - делал в 7-ке (в 8-ку не смотрел)... Когда потом (в свое время) мне такое же понадобилось в 8-ке - увидел, что там уже такое есть (причем как оказалось очень похоже реализовано). В данном случае это как раз для 7-ки было выложено.
12. Lyns_owner 339 17.12.12 13:09 Сейчас в теме
(11) Не заметил, что для 7.7, убрал минус.
2. alex_merfi 24.11.10 08:26 Сейчас в теме
3. DeniNikitin 33 30.11.10 12:07 Сейчас в теме
А файл конечно выкладывать не надо!!!
4. romanuil 11.02.12 15:44 Сейчас в теме
5. via 86 13.02.12 10:44 Сейчас в теме
6. romanuil 13.02.12 13:02 Сейчас в теме
О, появилось. Оперативно!
Осталось поднять свой рейтинг больше 50

:(
7. flash82 16.02.12 08:12 Сейчас в теме
классно давно искал что то подобное спасибо и конечно +
8. via 86 16.02.12 09:29 Сейчас в теме
Такую форму прогрессбара (в отличие от прогрессбара в строке состояния) можно использовать, например, при перепроведении документов (т.к. строка состояния там всякой лабудой забивается)
9. Rockman 14.03.12 16:01 Сейчас в теме
13. etmarket 458 15.12.14 00:10 Сейчас в теме
А где изображение прогресс бара? Неясно, стоит ли тратить СМ...
14. via 86 15.12.14 10:30 Сейчас в теме
(13) etmarket, Да вроде как видно же.. Мелковато, конечно, но общее представление даёт.
Оставьте свое сообщение