Заполнение справочника с изображениями элементами по умолчанию

Публикация № 805510

Разработка - Практика программирования

XDTO XML MapSourceImage картинки загрузка макет

Пример одного из решений, как можно заполнить справочник с изображениями значениями по умолчанию включая сами изображения. Сами изображения взяты из программы MapSource 6.16.3. Данные для загрузки хранятся в макете в формате XML.

Добрый день, коллеги.

В процессе работы понадобилось мне создать справочник изображений и заполнить его начальными значениями (значениями по умолчанию). Т.е. суть задачи стоит в том, чтобы создать и загрузить небольшую кучку изображений.

На начальном этапе мы имеем список данных изображений вида:

Outdoor;Улица
1.Trail Head;Начало тропы
2.Bike Trail;Велосипедная дорожка
3.Skiing Area;Лыжная зона
4.Swimming Area;Зона купания
5.Ski Resort;Лыжный курорт
6.Ice Skating;Каток
7.Golf Course;Поле для гольфа
8.Ball Park;Футбольне поле
9.Scenic Area;Живописная местность
10.Picnic Area;Место для пикников
11.Park;Парк
12.Forest;Лес
13.Summit;Вершина
14.Campground;Кэмпинг
15.Lodge;Охотничий домик
16.RV Park;Кемпинг
17.Shower;Душевая
18.Drinking Water;Питевая вода
19.Geocache;Тайник
20.Multi-Cache;Несколько тайников
21.Letterbox Cache;Тайник почтовый щик
22.Puzzle Cache;Тайник-загадка
23.Geocache Found;Тайник найден
24.Truck;Грузовик
25.ATV;Вездеход
26.Cemetery;Кладбище
27.Ghost Town;Город без жителей
28.TracBack Point;Точка обратного отсчета

Hunting;Преследование
1.Hunting Area;Охотничьи угодья
2.Blind;Вслепую
3.Tree Stand;Древесное насаждения
4.Cover;Укрытие
5.Food Source;Источник пищи
6.Water Source;Источник воды
.....

Тут у нас есть группы изображений и потом пронумерованные изображения, которые входят в саму группу. Наименования у нас на двух языках: русский и английский.

Так же у нас есть архив изображений, состоящий из 274 изображений формата PNG. Наименование изображений соответствует английскому наименованию без лишних символов (запятые, скобки, тире и тд).

Создавать предопределенные элементы в справочнике, загружать картинки, копирую по 100 раз наименования - не наш путь.

Было принято решение: делаем макет предопределенных значений и из него грузим все элементы с группами.

Таким образом решение задачи было разбито на 2 части:

1) Формирование макета XML с данными, в том числе картинками в виде двоичных данных.

2) написание механизма загрузки предопределенных значений из макета.

Для работы с XML и создания пакета данных было решено использовать пакеты XDTO. Для нашего случая был разработан следующий пакет:

<xs:schema xmlns:tns="http://www.MapsImage.Kim" xmlns:xs="http://www.w3.org/2001/XMLSchema" targetNamespace="http://www.MapsImage.Kim" attributeFormDefault="unqualified" elementFormDefault="qualified">
	<xs:element name="Images" type="tns:ImagesType"/>
	<xs:complexType name="ImageGroupType">
		<xs:sequence>
			<xs:element name="Image" type="tns:ImageType" maxOccurs="unbounded"/>
			<xs:element name="NameEnglish" type="xs:string"/>
			<xs:element name="NameRussian" type="xs:string"/>
		</xs:sequence>
	</xs:complexType>
	<xs:complexType name="ImageType">
		<xs:sequence>
			<xs:element name="NameEnglish" type="xs:string"/>
			<xs:element name="NameRussian" type="xs:string"/>
			<xs:element name="binImage" type="xs:base64Binary" nillable="true"/>
			<xs:element name="fileNameImage" type="xs:string" nillable="true"/>
		</xs:sequence>
	</xs:complexType>
	<xs:complexType name="ImagesType">
		<xs:sequence>
			<xs:element name="ImageGroup" type="tns:ImageGroupType" maxOccurs="unbounded"/>
		</xs:sequence>
	</xs:complexType>
</xs:schema>

Для формирования нашего XML разработал простую обработку:

Мы указывали файл txt в котором лежит список всех изображений, указали путь к папке с изображениями. С этими данными мы и будем работать.

Рассмотрим самые интересные моменты. В первую очередь мы разбираем файл .txt на составляющие и сохраняем прочитанные значения в массив структур. По факту мы повторяем дерево, которое будет грузится в объект XDTO и потом выгружаться в XML. Пришлось делать так, потому что наш добавленный пакет XDTO не доступен на клиенте и доступен только на сервере. В итоге начальная функция разбора входящих данных выглядит так:

&НаКлиенте
Процедура СоздатьXML(Команда)
	Если ФайлTXT = "" ИЛИ ПапкаИзображений = "" Тогда
		Возврат;
	КонецЕсли;
	Файл = Новый ЧтениеТекста(ФайлTXT,КодировкаТекста.UTF8);
	ТекстФайла = Файл.Прочитать();
	Файл.Закрыть();
	
	МассивПодстрок = СтрРазделить(ТекстФайла,Символы.ПС,Ложь);
		
	СтрокаЦифр = "0123456789";
	МассивГрупп = Новый Массив;
	СтруктураГруппы = НЕОПРЕДЕЛЕНО;
			
	Для Каждого СтрМассива ИЗ МассивПодстрок Цикл
		ПервыйСимвол = Лев(СтрМассива,1);
		Если Найти(СтрокаЦифр,ПервыйСимвол) = 0 Тогда
			//Это группа
			СтруктураГруппы = ПолучитьСтруктуруДанных(Истина);
			РазобратьСтрокуНаИмена(СтрМассива,СтруктураГруппы,Истина);
			
			МассивГрупп.Добавить(СтруктураГруппы);
		Иначе
			//Это элемент
			СтруктураИзображения = ПолучитьСтруктуруДанных();
			РазобратьСтрокуНаИмена(СтрМассива,СтруктураИзображения);
			
			СтруктураГруппы["Image"].Добавить(СтруктураИзображения);
			
	//		Картинка = ПолучитьИмяФайлаИзображения(МассивФайлов,СтруктураИзображения["fileNameImage"]);
		КонецЕсли;
	КонецЦикла;
	
	СтрукутраПараметров = Новый Структура;
	СтрукутраПараметров.Вставить("МассивГрупп",МассивГрупп);
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ЗавершениеПоискФайлов",ЭтотОбъект,СтрукутраПараметров);
	
	НачатьПоискФайлов(ОписаниеОповещения,ПапкаИзображений,"*",Истина);
	
КонецПроцедуры

Функция "ПолучитьСтруктуруДанных" возвращают структуру нужного, а "РазобратьСтрокуНаИмена" работает со строкой, преобразуя ее и заполняя данные структуры. Они просты в реализации и не представляют большого интереса.

На этом этапе мы получили массив структур групп изображений и самих изображений. Теперь нам надо подтянуть к каждому изображению конкретно само изображение (в виде двоичных данных) и имена файлов. У меня данная база работает наплатформе версии 8.3.10.2580 и по умолчанию отключено использование модальных окон. Воспользуемся асинхронной функцией поиска файлов "НачатьПоискФайлов".

Когда все файлы найдены, мы устанавливаем соответствие между объектами в наших структурах и файлами, параллельно вычитывая их и запоминая в виде двоичных данных. Данные действия совершает следующая функция:

&НаКлиенте
Процедура ЗавершениеПоискФайлов (Результат, ДополнительныеПараметры) ЭКСПОРТ
	Если Результат = НЕОПРЕДЕЛЕНО Тогда
		Возврат;
	КонецЕсли;
	МассивГрупп = ДополнительныеПараметры.МассивГрупп;
	Для Каждого СтрГруппы ИЗ МассивГрупп Цикл
		Для Каждого СтрИзображения ИЗ СтрГруппы["Image"] Цикл
			Картинка = ПолучитьИмяФайлаИзображения(Результат,СтрИзображения["fileNameImage"]);
			Если Картинка = НЕОПРЕДЕЛЕНО Тогда
				Продолжить;
			КонецЕсли;
			
			СтрИзображения["binImage"] = Новый ДвоичныеДанные(Картинка.ПолноеИмя);
			СтрИзображения["fileNameImage"] = СтрИзображения["fileNameImage"] + Картинка.Расширение;
		КонецЦикла;
	КонецЦикла;
	
	ТекстXML = ПолучитьОбъектXDTOПоПространствуИмен(МассивГрупп);
КонецПроцедуры

Получив всю нужную информацию мы, наконец, можем приступить в формированию файла XML. Это можно сделать, например, следующим образом:

&НаСервереБезКонтекста
Функция ПолучитьОбъектXDTOПоПространствуИмен (МассивГрупп)
	ПространствоИмен = "http://www.MapsImage.Kim";
	КорневоеСвойство = "Images";
	ОбъектИзображений = ФабрикаXDTO.Создать(ФабрикаXDTO.Пакеты.Получить(ПространствоИмен).КорневыеСвойства.Получить(КорневоеСвойство).Тип);
	
	Для Каждого СтрМассива ИЗ МассивГрупп Цикл
		ГруппаИзображений = ОбъектИзображений.ImageGroup.Добавить(ФабрикаXDTO.Создать(ФабрикаXDTO.Тип(ПространствоИмен,"ImageGroupType")));
		ЗаполнитьЗначенияСвойств(ГруппаИзображений,СтрМассива,"NameEnglish,NameRussian");
		Для Каждого СтрМассиваИзображения ИЗ СтрМассива["Image"] Цикл
			Если СтрМассиваИзображения.binImage = НЕОПРЕДЕЛЕНО Тогда
				Сообщить ("Нет изображения!! + " + СтрМассиваИзображения["NameEnglish"]);
			КонецЕсли;
			Изображение = ГруппаИзображений.Image.Добавить(ФабрикаXDTO.Создать(ФабрикаXDTO.Тип(ПространствоИмен,"ImageType")));
			ЗаполнитьЗначенияСвойств(Изображение,СтрМассиваИзображения,"NameEnglish,NameRussian,fileNameImage");
			Если СтрМассиваИзображения.binImage <> НЕОПРЕДЕЛЕНО Тогда
				Изображение["binImage"] = Base64Строка(СтрМассиваИзображения.binImage);
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	
	ИмяВременногоФайла = ПолучитьИмяВременногоФайла(".gpx");
	
	ЗаписьXML = Новый ЗаписьXML;
	ЗаписьXML.ОткрытьФайл(ИмяВременногоФайла,"UTF-8");
	
	ЗаписьXML.ЗаписатьОбъявлениеXML();	
	
	ФабрикаXDTO.ЗаписатьXML(ЗаписьXML, ОбъектИзображений, КорневоеСвойство,ПространствоИмен,,НазначениеТипаXML.Явное);
	
	ЗаписьXML.Закрыть();

	Файл = Новый ЧтениеТекста(ИмяВременногоФайла, КодировкаТекста.UTF8);
	ДанныеXML = Файл.Прочитать();

	Возврат ДанныеXML;
	
КонецФункции

По факту мы обходим ранее сформированную структуру и переносим ее в XDTO пакет.

На выходе (в форме обработки) получим текст вида:

<?xml version="1.0" encoding="UTF-8"?>
<Images xmlns="http://www.MapsImage.Kim" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="ImagesType">
	<ImageGroup>
		<Image>
			<NameEnglish>Trail Head</NameEnglish>
			<NameRussian>Начало тропы</NameRussian>
			<binImage>iVBORw0KGgoAAAANSUhEUgAAABgAAAAYCAIAAABvFaqvAAAFNElEQVR42q2Ve0xT
VxzH77n3tvTBbWtb+rAtSHlUYTBAqHMmytBNYerM3hvJ1KETH5s4l/iIcZs6o5vT
GLOIBKawuanzkbiJM1s0M06GTBxCZGB59mGhpbTYQh/33rNz2w5dsj89f9z8cs65
n/u939/v/A6AEGJPYgAEamlpqVy/zelJBNGBZnEcjwWxQdM0y7IEQaAY7UdxLAAM
UKnGa776zGw2c6CCovm0pMZgMIjEOEviPAgwErE4ECQwNsza+i0YHZSp9GKhlImO
GC7gZxz9g6HRir7uWxxIbVyWkf99fq4QicBJGJOFAsRiWXinqWnpginGFOpmy+jA
0FS1QREJcVpoThbW0uoaaK9w2S5yIK1xaWbBqSyTiFshMRLHAA8LB+H4OIuEhMea
T31dglZ8Y+zbq/9KnZHPRDgKUoRwHZ3uvraVQ7af4qC0p09mZFJoNwEg4IFwkPUO
W7Rquq8HuWP/5UIpWnrgpFe8fzc5vQBGYARAPCrpbqfH1vFuHKRJXWLM/TbNKOXM
BxhfBFv/uFs2N7R7h7lqy+9T9ZLyl7O6LZ4r14dvd8r1yRr0azGPcIzt7B513Fv1
CKTPakgzSCEJUWoikUhvx/WTNbNmTE/s6Q2nGfnoA7X1XZ8fsc2ZPz80hqwGGEvH
cmfp9dq7Kobtl6JmT1usz2wwGChkMo9H9tzvnmceO7i3cMTLKmT4ZBG8sfL2BPaU
gE9GUNKYSAzU3+91Wt6LgzSGJVrTca2awkmW5Avampv37JCXv57ZP8BMSyEmQWcv
2D/cacufWQQBEh3BaG5y0OZx9a39V5F+sSq9VqOKFiRPaO1rN2ePmDIUFStyVUng
8fI9dKSr4YyVJ8iQyZWoStGM3erz2CpdjkYOpNK9qEg9ppTLIAFR9tHTZb1vSvec
qX+OR0a1/GgXJxClL2hQHKGxdZvu3GihVCoVqsyhIZ/Xse4RSK6vlsglSBBXRATP
4x5O0fSeaygWiTlFxWWNg9aEvBy4f09xhpE8Vmfddzig1qmRUy7XwzHnBveDy3EQ
pT1KURQgmChLYLf3zMrznK2fhxMcqP60de+XExAQBNt59GBR05/B2m8YiUSC/PZ6
vf7hD0acP3OgpKllwqQjiYmJseOKngM9zT8cz1+0UDfpTmHxNW8gXaOwHfg08+R5
z6Vf+SIBH/2a3+sf91bFQUptaYLisCCBq2xSQDrt1tl57sZzzyM57ff8OVncB747
71y+qqOslNq9PWvj1q5+m5YE0XMbCITHqjxDVziQQrMoQXoYJ8RY1Fq3tX3/Pv3G
NTkoznvmzCfb5ix7SefxQYXsxDuVubu25BSW3BKJ0wAdpCEIhf1MYHMcJFcv5FGH
WCAmSdLtceZNd/zWuBjZXF3bvWX73/Pmii6eXfDQj0mo2g1V2ZurzKmma6oUE2BC
qMQhO86Of/QIBIRfAJw7/QGvZc/H6s0b86PJunqzVaaTdvd1vYmyrk6uW16euWbV
s1m5N6bokwFkOP1w4j8gXHQAYgJUY0zQUn80+5VXjY2XrRXr7ROsMjh6LehbjV6Z
Oft0+Vum7OnJZa91yZSa/wMpFmLSQzjGRwmO+B0pyYOFecqm27TDqeMJqbCvbcNa
nUBEVle3lZRopVN0J07hQqEQgdB+CCcw3ybPSBSUU1Bic+8EpIpLP2TYMGpoYUBQ
OEgAOM3dDrQXdQUaI5mQHSdVJC8JAxG0mUHb6WG9cld769V486+o3GqzkZNVwzX2
x5p/7KZBM5PB5JJeT9dV7ysqKgJP6jr6B+fh0+/Kt4cZAAAAAElFTkSuQmCC</binImage>
			<fileNameImage>TrailHead.png</fileNameImage>
		</Image>
		<Image>
			<NameEnglish>Bike Trail</NameEnglish>
			<NameRussian>Велосипедная дорожка</NameRussian>
			<binImage>iVBORw0KGgoAAAANSUhEUgAAABgAAAAYCAIAAABvFaqvAAACAklEQVR42q2UMUtc
QRDH//O880wgnyCtVnYRLEISxBQBQQsJBGxCLAQNCrk010UsUlj4EQJJITY2Ymfl
VTYJWJmQFAEhnyBwp+c5zszue2/29BQOH8Pe8t7u7/4z898lZsZ9PBRARDQwIhLk
Ryi8CK4BFQvlymdQF7jQ4A7orBzRBrV1DPPsj7Ii6HIZVI0gHgJ9dvm+Jw+K+1vl
PPvpQasKCqIoA9ZLENdJJZyVEnTeinNVlIA+RBANm66GU/SRij0eV4iikxSEEaOM
....

На этом процесс генерации XML файла с данными завершен и мы переходить ко второй части задачи - загрузке данных в справочник.

Справочник будет иметь следующий вид:

Как мы видим, в справочник я добавил 2 макета.

Описание данных - это макет и с итоговой XML для загрузки.

Описание пакета - это XDS схема пакет XDTO. Мы будем загружать XML так же через пакет XDTO.

В форме списка справочника добавим команду загрузки. Выглядеть она будет так:

&НаСервереБезКонтекста
Процедура ЗагрузитьЗначенияПоУмолчаниюНаСервере()
	
	//Получим описание пакета
	ИмяФайла = ПолучитьИмяФайлаМакета("ОписаниеПакета");
			
	//Получим свою фабрику XDTO
	Фабрика = ПолучитьСвоюФабрикуXDTO(ИмяФайла);
	
	//Получим из макета данные XML и сохраним в файл
	ИмяФайлаДанных = ПолучитьИмяФайлаМакета("ОписаниеДанных");
		
	//Прочитаем данные из фабрики
	ОбъектИзображений = ПолучитьОбъектXDTOДанных(Фабрика,ИмяФайлаДанных);
	
	//Загрузим данные в справочник
	ЗагрузкаСпискаИзображений (ОбъектИзображений);
КонецПроцедуры

Загрузку изображений так же можно разбить на несколько этапов:

1) Получение своей фабрики XDTO

2) Получение объекта XDTO из XML

3) Разбор объекта XDTO

Для получения данных воспользуемся универсальной функцией, которая сохраняет данные из макета в файл и возвращает полный путь к этому файлу:

&НаСервереБезКонтекста
Функция ПолучитьИмяФайлаМакета (ИмяМакета)
	ИмяФайла = ПолучитьИмяВременногоФайла(".xml");
	
	МакетОписанияПакета = Справочники.ИзображенияMapSource.ПолучитьМакет(ИмяМакета);
	ТекстОписанияПакета = МакетОписанияПакета.ПолучитьТекст();
		
	ТекстовыйФайл = Новый ТекстовыйДокумент;
	ТекстовыйФайл.ДобавитьСтроку(ТекстОписанияПакета);
	ТекстовыйФайл.Записать(ИмяФайла,КодировкаТекста.UTF8);
	
	Возврат ИмяФайла
КонецФункции

Для получения своей фабрики воспользуемся следующим кодом (спасибо большое за понимание принципов работы с XDTO Андрею Овсянкину и его циклу статей про XDTO)

&НаСервереБезКонтекста
Функция ПолучитьСвоюФабрикуXDTO(ИмяФайлаОписанияПакета)
	Чтение = Новый ЧтениеXML;
	Чтение.ОткрытьФайл(ИмяФайлаОписанияПакета);

	ПостроительDOM = Новый ПостроительDOM;
	Документ = ПостроительDOM.Прочитать(Чтение);
	ПостроительСхем = Новый ПостроительСхемXML;

	Схема = ПостроительСхем.СоздатьСхемуXML(Документ.ЭлементДокумента);

	НаборСхем = Новый НаборСхемXML;
	НаборСхем.Добавить(Схема);
	Фабрика = Новый ФабрикаXDTO(НаборСхем);
	
	Возврат Фабрика;
КонецФункции

С помощью нашей фабрики мы и прочитывали объект XDTO и уже исходя из объекта формируем элементы справочника.

Для получения объекта XDTO с помощью нашей созданной фабрики используется функция:

&НаСервереБезКонтекста
Функция ПолучитьОбъектXDTOДанных(Фабрика,ИмяФайлаДанных)
	ЧтениеXMLДанных = Новый ЧтениеXML;
	ЧтениеXMLДанных.ОткрытьФайл(ИмяФайлаДанных);
	
	ОбъектModel = Фабрика.ПрочитатьXML(ЧтениеXMLДанных);
	
	Возврат ОбъектModel;
КонецФункции

Создаем элементы, на основании объекта XDTO в следующем коде:

&НаСервереБезКонтекста
Процедура ЗагрузкаСпискаИзображений (ОбъектИзображений)
	ШаблонПоиска = "Custom";
	Для Каждого СтрГруппы ИЗ ОбъектИзображений.ImageGroup Цикл
		ГруппаИзображения = Справочники.ИзображенияMapSource.СоздатьГруппу();
		ГруппаИзображения.Наименование = СтрГруппы["NameRussian"];
		ГруппаИзображения.НаименованиеАнглийское = СтрГруппы["NameEnglish"];
		ГруппаИзображения.ЗначениеПоУмолчанию = Истина;
		ГруппаИзображения.Записать();
		
		СсылкаНаГруппу = ГруппаИзображения.Ссылка;
				
		Для Каждого СтрИзображения ИЗ СтрГруппы.Image Цикл
			Изображение = Справочники.ИзображенияMapSource.СоздатьЭлемент();
			Изображение.Наименование = СтрИзображения["NameRussian"];
			Изображение.НаименованиеАнглийское = СтрИзображения["NameEnglish"];
			Изображение.ЗначениеПоУмолчанию = Истина;
			Изображение.ИмяФайла = СтрИзображения["fileNameImage"];
			Если Найти(Изображение.ИмяФайла,ШаблонПоиска) Тогда
				Изображение.ИмяФайла = ПолучитьНовоеИмяФайла(СтрИзображения["fileNameImage"],ШаблонПоиска);
			КонецЕсли;
			ДвоичныеДанныеИзображения = СтрИзображения["binImage"];
			Изображение.ДанныеФайла = Новый ХранилищеЗначения(ДвоичныеДанныеИзображения,Новый СжатиеДанных(9));
			Изображение.Родитель = СсылкаНаГруппу;
			Изображение.Записать();
		КонецЦикла;
		
		
	КонецЦикла;
КонецПроцедуры

В итоге мы получаем то, что нам и требовалось:

Прикрепил архив с конфигурацией, с описанными объектами, изображениями и текстовым файлом, а так же отдельно изображения - вдруг кому-нибудь понадобятся

Скачать файлы

Наименование Файл Версия Размер
Демо конфигурация (с файлами для загрузки)

.rar 332,90Kb
28.03.18
1
.rar 1.0.1 332,90Kb 1 Скачать
Изображения

.rar 160,80Kb
26.03.18
1
.rar 1.1.1 160,80Kb 1 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    44836    155    ekaruk    31    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    17290    4    m-rv    86    

Безопасная работа с транзакциями во встроенном языке

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    30358    10    tormozit    44    

Редактор объектов информационной базы 8.3

Универсальные обработки Обмен через XML v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.47 от 08.06.2020

2 стартмани

23.01.2019    24482    257    ROL32    33    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    27596    86    m-rv    57    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом

Печатные формы документов Универсальные функции Email v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    21264    13    stvorl    0    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    25108    66    vasvl123    9    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    18832    12    RocKeR_13    16    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    25409    25    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    39320    17    kalyaka    16    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    41155    33    dsdred    36    

Как выполнить отчет на СКД через COM и получить данные отчета?

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    25696    8    wowik    3    

Работа со схемой запроса

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    41009    85    kalyaka    34    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    36622    151    kostya_whiskas    24    

Создание в 1С 7.7 XML в формате EnterpriseData (универсальный формат обмена), версия 1.5. Инструкции и примеры переноса данных из устаревшей конфигурации 1С 7.7 в любую современную 1С 8.3, поддерживающую EnterpriseData, через Конвертацию данных 3

Перенос данных из 1С7.7 в 1C8.X Обмен через XML v7.7 v8 1cv7.md Россия Абонемент ($m)

Воспользоваться современным средством переноса данных "Конвертация данных 3.0.5.3" можно только выгрузив из системы - источника данных XML в формате обмена данными EnterpriseData. В этой публикации можно скачать приемы выгрузки из 1С 7.7 универсального формата обмена для Конвертации данных 3. Выполняем перенос данных из «1С:Предприятие 7.7» в «1С:Предприятие 8.3». Используем Конвертацию данных КД 3.0 из 1c 7.7 --> 1С 8.3. На первой стадии еще не опубликовано иного способа подложить файл для Конвертации данных 3 кроме как сформировать его вручную, постараемся решить данную проблему.

1 стартмани

26.02.2018    36133    51    ksnik    3    

Заполняем по шаблону (по умолчанию)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    25484    19    mvxyz    17    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    33143    54    rpgshnik    48    

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    36588    27    agent00mouse    0    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    24835    49    kwazi    6    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    116600    13    signum2009    46    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    47328    15    DarkAn    86    

Простой способ индексирования интервалов

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    38131    38    ildarovich    22    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Обмен через XML v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    39018    153    Aphanas    4    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    44708    36    Demanoidos    60    

Загрузка файлов грузовых таможенных деклараций из файлов ФТС формата xml (Альта софт, Сигма софт, Декларант +)

Внешнеэкономическая деятельность (ВЭД) Обмен через XML Внешнеэкономическая деятельность (ВЭД) v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Федеральная таможенная служба России давно поддерживает унифицированный формат электронных документов для обмена с информационными системами предприятий. xmlns="urn:customs.ru:Information:ExchangeDocuments:" если что. Структура, утвержденная комиссией Таможенного союза. Осталось только сделать загрузку в 1С из этого формата. На выходе - два документа ГТД по импорту и Поступление (акты, накладные)

5 стартмани

09.08.2016    43682    176    capitan    298    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    53161    7    wowik    31    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    51792    19    arakelyan    18    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    74520    150    igo1    52    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    16538    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    46042    49    yuraos    17    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    21581    8    Tatitutu    5    

Генерация QR-кода программная и интерактивная (код открыт, управляемая форма, обычное и управляемое приложение, API)

Универсальные функции Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработку можно быстро и легко интегрировать в любую конфигурацию с и без БСП (Библиотека Стандартных Подсистем).

3 стартмани

04.02.2016    45026    169    TuneSoft    26    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    35422    19    milkers    4    

1С:Интеграция ЕГАИС + Инвентаризация на ТСД

Обработка справочников Обмен через XML Оптовая торговля Оптовая торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Интеграция ЕГАИС модуля для 1С: 8.3 + модуль WMS контура для инвентаризации алкогольных марок на ТСД.

1 стартмани

10.12.2015    35074    27    JetBrain    5    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    53214    47    YPermitin    19    

Автоматическая подстановка уничтожений временных таблиц в текст запроса

Универсальные функции v8 1cv8.cf Абонемент ($m)

Функция, которая сама подставляет в текст запроса "УНИЧТОЖИТЬ" в местах последнего использования ВТ.

1 стартмани

14.11.2015    18997    0    SeiOkami    3    

Быстрое определение интервалов в запросе

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    47822    32    ildarovich    41    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    179597    429    Zerocl    65