ЗиК 305 ЗиК 306 Больничный лист.

Публикация № 80704

Разработка - Практика программирования

107
Для переходящих больничных листов за счет работодателя оплачивается 2 дня, а не 3.
Первоисточник: http://forums.kuban.ru/forum/viewtopi...669&page=2

1. Глобалльный модуль ЗиК 305 строка 51086;  ЗиК 306 строка 51164

//Если (ДатаНачалаБолезни+2) >= НачалоБолезниТекМесяца Тогда
Если (ДатаНачалаБолезни+2-1) >= НачалоБолезниТекМесяца Тогда

ЗиК 305  строка 51090;  ЗиК 306 строка  51168

//ОкончаниеДнейРаботодателя = Мин(НачалоБолезниТекМесяца+2-(НачалоБолезниТекМесяца-ДатаНачалаБолезни),ОкончаниеБолезниТекМесяца);
ОкончаниеДнейРаботодателя = Мин(НачалоБолезниТекМесяца+2-1-(НачалоБолезниТекМесяца-ДатаНачалаБолезни),ОкончаниеБолезниТекМесяца);





2. БольничныйЛист модуль документа строка 345

ИначеЕсли ТипБольничного=Тогда  //Заболевание работника, бытовая травма

     Если НачалоБолезни < '01.01.2011' Тогда
         Дней = 2;
     Иначе
         Дней = 3;
     КонецЕсли;

     ЕстьДниЗаСчетРаботодателя = 0;
     //Если  (Начало < НачалоБолезни + 3) Тогда
     Если  (Начало < НачалоБолезни + Дней) Тогда
         ЕстьДниЗаСчетРаботодателя = 1;
     КонецЕсли;

     Если ЕстьДниЗаСчетРаботодателя = 1 Тогда
         //НачалоЗаСчетФСС = Макс(Начало,НачалоБолезни + 3)
         НачалоЗаСчетФСС = Макс(Начало,НачалоБолезни + Дней)
     Иначе
         НачалоЗаСчетФСС = Начало;
     КонецЕсли;
     //ОкончаниеДнейРаботодателя = Мин(НачалоБолезни + 2,Окончание);
     ОкончаниеДнейРаботодателя = Мин(НачалоБолезни + Дней - 1,Окончание);

     ВвестиРасчет(ЖрнЗарплата,ЭлСотрудника,ВидРасчета.ОплатаБЛЗаСчетРаботодателяс2011, Начало, Мин(ОкончаниеДнейРаботодателя,ОкончаниеПериодаОплаты), ДатаНарушенияРежима);
     Если (Окончание > НачалоБолезни + 1) Тогда
      ВвестиРасчет(ЖрнЗарплата,ЭлСотрудника,ВидРасчета.ОплатаБЛс2011, НачалоЗаСчетФСС, ОкончаниеПериодаОплаты, ДатаНарушенияРежима);
     КонецЕсли;


КонецЕсли;

 

 

 

3. Отчет.РасходыПредприятияЗаСчетФСС  в процедуре Сформировать2011()  меняем строку

//ДниРаботодателя = ?(ДнейОплатыПервичныйБЛ > 3, 0, 3 - ДнейОплатыПервичныйБЛ);
на

Если ДокументЗаписи.Начало < '01.01.11' тогда
     ДниРаботодателя = ?(ДнейОплатыПервичныйБЛ > 2, 0, 2 - ДнейОплатыПервичныйБЛ);
Иначе
     ДниРаботодателя = ?(ДнейОплатыПервичныйБЛ > 3, 0, 3 - ДнейОплатыПервичныйБЛ);
КонецЕсли;

строку

//ДниРаботодателя = Мин(3,ДнейОплаты);
на

Если ДокументЗаписи.Начало < '01.01.11' тогда
     ДниРаботодателя = Мин(2,ДнейОплаты);
Иначе
     ДниРаботодателя = Мин(3,ДнейОплаты);
КонецЕсли;

107

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. WiseSnake 1786 25.01.11 21:17 Сейчас в теме
А в глобальном модуле условие НачалоБолезни < '01.01.2011' не надо использовать?
2. Cvetic 304 26.01.11 09:53 Сейчас в теме
3. kdv 26.01.11 09:53 Сейчас в теме
Почему это в разделе исправление ошибок 1С?
По закону правильно именно 3 дня, по крайней мере дополнительных комментариев на этот счет не было.

Не советую вносить такие изменения без консультации с местным ФСС :)
4. Cvetic 304 26.01.11 09:55 Сейчас в теме
(3) исправления внесла после семинара в ФСС :)
5. isadora 26.01.11 12:29 Сейчас в теме
Поскольку страховой случай наступил в 2010 году,то и оплачивать следует за счет работодателя по правилам 2010 года,то есть 2 дня.
6. vat-74 166 27.01.11 07:18 Сейчас в теме
(5) В таком случае достаточно поправить только БЛ, в том месте где вычисляется по какому правилу будет считаться. т.е. вместо стр 18 ставим
	Если ДатаНачалаСобытия <= ДатаНачалаРеформыСоцСтрахования Тогда 
		ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
	ИначеЕсли ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаНачалаРеформыСоцСтрахования Тогда
7. valexeeva 27.01.11 11:17 Сейчас в теме
Вчера клиенты (Министерство) консультировались в ФСС (Москва,ЦО). Там подтвердили,что оплачиваться за счет работодателя должны 3 дня для ВСЕХ больничных, сданных в организацию в январе.
В скором времени будет официальное разъяснение.
9. Cvetic 304 27.01.11 14:04 Сейчас в теме
(7) Странно нам на семинаре в ФСС (Ульяновск) объясняли, что переходящие б/л 2 дня. Не может быть в каждом регионе своего учета. Быстрее бы разъяснения вышли, чтобы потом пересчетов не делать.
8. Cobranet123 355 27.01.11 12:06 Сейчас в теме
А я так понял, например если переходящий больничный с 2010 на 2011 год формируется в декабре 2010, то он по старым расчетам, а если больничный формируется в январе 2011, то уже расчет должен быть по новым правилам расчета.
10. serg76 27.01.11 15:11 Сейчас в теме
Вот ссылка на статейку от 1С где они объясняют почему сделали по всем б/л 3 дня за счет работодателя. Так что это не ошибка 1Сников - так было задумано
http://www.buh.ru/newsDescr-7079
11. 1Cworking 368 28.01.11 14:41 Сейчас в теме
Еще вариант:
Поскольку страховой случай наступил в 2010 году, то оплачивать следует по правилам 2010: за счет работодателя 2 дня и расчет БЛ по правилам 2010 (ВР-..с2010, а не с2011).
Кому подходит этот вариант, надо сделать следующие изменения:

Документ.БольничныйЛист, модуль формы
============================================================­=
Функция ПередЗаписью()
Если ПустоеЗначение(ТипРасчетаБольничного) = 1 Тогда
Если ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаНачалаРеформыСоцСтрахования Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
ИначеЕсли ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаПереходаНаСтраховыеВзносы Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
ИначеЕсли ДатаНачалаСобытия <'01.01.2004' Тогда
ТипРасчетаБольничного = ?(ФТипРасчетаБольничного1 = 1,Перечисление.ТипРасчетаБольничного.ПоТекущемуМесяцу,Перечисление.ТипРасчетаБольничного.ПоДвумМесяцам);
ИначеЕсли ДатаНачалаСобытия <'01.01.2005' Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2004года;
ИначеЕсли ДатаНачалаСобытия <'01.01.2007' Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2005года;
Иначе
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2007года;
КонецЕсли;
КонецЕсли;
//вставить (это если сменили дату начала бл с 2011 на 2010)
Если ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаНачалаРеформыСоцСтрахования Тогда
Если ДатаНачалаСобытия < ДатаНачалаРеформыСоцСтрахования Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
КонецЕсли;
КонецЕсли;
//до

------------------------------------------------------------------
Процедура ПриОткрытии()
....
Если ДатаНачалаСобытия >='01.01.2004' Тогда
Если (ДатаПервойЗаписи < '01.01.2005') И (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2004года) Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2004года;
ИначеЕсли (ДатаПервойЗаписи < '01.01.2007') Тогда
Если (ПроведенВПрошлом = 0) и (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2005года) Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2005года;
КонецЕсли;
ИначеЕсли (ПроведенВПрошлом = 0) Тогда
Если ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаНачалаРеформыСоцСтрахования Тогда
//было
Если (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2011года) Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
КонецЕсли;
//заменить на
Если ДатаПервойЗаписи < ДатаНачалаРеформыСоцСтрахования Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
Иначе
Если (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2011года) Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
КонецЕсли;
КонецЕсли;
//до

------------------------------------------------------------------
Процедура УстановитьТипРасчетаБЛ()
Если ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаНачалаРеформыСоцСтрахования Тогда
//было
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
//заменить на
Если Начало >= ДатаПереходаНаСтраховыеВзносы Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
Иначе
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
КонецЕсли;
//до

------------------------------------------------------------------

Документ.БольничныйЛист, модуль документа
============================================================­=
Процедура ОбработкаПроведения(ОбработчикСообщений)
.......
Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
ЭлСотрудника = СпрСотрудники.ТекущийЭлемент();
Если СпрСотрудники.ОсновнойЭлемент = ЭлСотрудника Тогда // по основному месту работы введем оплату больничного
//было
Если ПериодРегистрации >= глДатаНачалаРеформыСоцСтрахования() Тогда
//заменить на
Если НачалоБолезни >= глДатаНачалаРеформыСоцСтрахования() Тогда
//до
patnaumov; +1 Ответить
12. 1Cworking 368 31.01.11 09:06 Сейчас в теме
(11) при смене даты начала периода бл с 2010 на 2011 и обратно не меняется форма
здесь представлен код с учетом этих изменений:

Документ.БольничныйЛист, модуль формы
============================================================­=
Функция ПередЗаписью()
Если ПустоеЗначение(ТипРасчетаБольничного) = 1 Тогда
Если ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаНачалаРеформыСоцСтрахования Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
ИначеЕсли ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаПереходаНаСтраховыеВзносы Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
ИначеЕсли ДатаНачалаСобытия <'01.01.2004' Тогда
ТипРасчетаБольничного = ?(ФТипРасчетаБольничного1 = 1,Перечисление.ТипРасчетаБольничного.ПоТекущемуМесяцу,Перечисление.ТипРасчетаБольничного.ПоДвумМесяцам);
ИначеЕсли ДатаНачалаСобытия <'01.01.2005' Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2004года;
ИначеЕсли ДатаНачалаСобытия <'01.01.2007' Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2005года;
Иначе
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2007года;
КонецЕсли;
КонецЕсли;
//вставить (это если сменили дату начала бл с 2011 на 2010)
Если ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаНачалаРеформыСоцСтрахования Тогда
Если ДатаНачалаСобытия < ДатаНачалаРеформыСоцСтрахования Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
КонецЕсли;
КонецЕсли;
//до

------------------------------------------------------------------
Процедура ПриОткрытии()
....
// сформируем заголовок в зависимости от наличия первичного БЛ
СформироватьЗаголовокДокумента();

// установим закладки и заголовок
Форма.ИспользоватьЗакладки(1);
//было
СформироватьСлои();
//закомментировать
//СформироватьСлои();
//до
.............
Если ДатаНачалаСобытия >='01.01.2004' Тогда
Если (ДатаПервойЗаписи < '01.01.2005') И (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2004года) Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2004года;
ИначеЕсли (ДатаПервойЗаписи < '01.01.2007') Тогда
Если (ПроведенВПрошлом = 0) и (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2005года) Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2005года;
КонецЕсли;
ИначеЕсли (ПроведенВПрошлом = 0) Тогда
Если ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаНачалаРеформыСоцСтрахования Тогда
//было
Если (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2011года) Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
КонецЕсли;
//заменить на
Если ДатаПервойЗаписи < ДатаНачалаРеформыСоцСтрахования Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
Иначе
Если (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2011года) Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
КонецЕсли;
КонецЕсли;
//до
ИначеЕсли ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаПереходаНаСтраховыеВзносы Тогда
Если (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2010года) Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
КонецЕсли;
ИначеЕсли (ТипРасчетаБольничного <> Перечисление.ТипРасчетаБольничного.С2007года) Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2007года;
КонецЕсли;
КонецЕсли;
ИначеЕсли ДатаНачалаСобытия < '01.01.2004' Тогда
Если (ПервичныйБольничный.Выбран() = 1) и (ТипРасчетаБольничного <> ПервичныйБольничный.ТипРасчетаБольничного) Тогда
ТипРасчетаБольничного = ПервичныйБольничный.ТипРасчетаБольничного;
ИначеЕсли (ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2004года) или (ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.С2005года) Тогда
ТипРасчетаБольничного = Перечисление.ТипРасчетаБольничного.ПоДвумМесяцам;
КонецЕсли;
КонецЕсли;
//добавить
СформироватьСлои();
//до

------------------------------------------------------------------
Процедура УстановитьТипРасчетаБЛ()
Если ЖрнЗарплата.НачалоТекущегоПериода() >= ДатаНачалаРеформыСоцСтрахования Тогда
//было
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
//заменить на
Если Начало >= ДатаНачалаРеформыСоцСтрахования Тогда
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года;
Иначе
ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2010года;
КонецЕсли;
//до

------------------------------------------------------------------

Документ.БольничныйЛист, модуль документа
============================================================­=
Процедура ОбработкаПроведения(ОбработчикСообщений)
.......
Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
ЭлСотрудника = СпрСотрудники.ТекущийЭлемент();
Если СпрСотрудники.ОсновнойЭлемент = ЭлСотрудника Тогда // по основному месту работы введем оплату больничного
//было
Если ПериодРегистрации >= глДатаНачалаРеформыСоцСтрахования() Тогда
//заменить на
Если НачалоБолезни >= глДатаНачалаРеформыСоцСтрахования() Тогда
//до
13. rdv 02.02.11 08:00 Сейчас в теме
Кто перешел на 306 релиз, как оно там то ?
14. Cvetic 304 02.02.11 11:44 Сейчас в теме
15. *Zed* 278 03.02.11 11:35 Сейчас в теме
Наш ФСС (Псков) сказали что надо оплачивать 2 дня для таких больничных
16. Варя_Варя 8 04.02.11 11:56 Сейчас в теме
наш ФСС (Рязань) тоже сказали, что надо оплачивать 2 дня за счет средств работодателя для переходящих больничных, объяснив это тем, что страховой случай наступил до вступления в силу нового закона, поэтому расчет по старому.
17. B00RblY 08.02.11 11:50 Сейчас в теме
В общем, как я понял, сейчас ничего не менять в модуле, а ждать где-нибудь весной выхода нового релиза. К тому времени, думаю, уж определяться наши власти сколько брать с работодателя 2 или 3 дня. В худшем случае делать перерасчет.
18. hasp_x 154 10.02.11 13:25 Сейчас в теме
можно на панель документа больничный лист вывести реквизит "Тип расчета больничного", тогда в модуле и править ничего не надо будет
19. I love pivo 14.02.11 20:45 Сейчас в теме
вообще то у приличных людей принято давать ссылку на первоисточник:
http://forums.kuban.ru/forum/viewtopic_new.php?t=3612669&page=2

вот это "+2-1" - это коронный стиль Гены.

поэтому - за плагиат - жирный минус.
20. Cvetic 304 22.02.11 15:26 Сейчас в теме
(19) Правда, списала у Гены. Но он не разместил на этом сайте, а людям очень нужно. Поэтому решилась на плагиат :oops: Надеюсь, что Гена не обидется.
21. support 4454 02.03.11 15:02 Сейчас в теме
(20) Пожалуйста, укажите в тексте публикации первоисточник и авторство.
22. Гена 02.03.11 15:31 Сейчас в теме
(21) не надо грязи... автор уникально и независимо решила давать 2 дня по всем случаям, начавшимся до 01.01.2011

у меня другое мнение... я выделяю 30-е и 31 декабря... поэтому Cvetic имеет право на (с) данной публикации полностью и неоспоримо... плюсуйте смело... у меня почему-то нет такого права...
24. Cvetic 304 03.03.11 08:30 Сейчас в теме
(22) Гена, спасибо что не сердитесь.
23. Cvetic 304 03.03.11 08:29 Сейчас в теме
Хорошо, укажу первоисточник.
25. lushka 8 10.03.11 08:51 Сейчас в теме
Оставьте свое сообщение

См. также

Записки на память. Зарплата и кадры 1С 7.7 (ЗиК 7.7 ) 54

Статья Системный администратор Программист Бухгалтер Нет файла v77::Расчет 1С7:ЗиК Россия БУ НУ УУ Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерский учет

ЗиК 7.7 постепенно сходит на нет. Но, возможно, кому-то из нас все-таки когда-либо еще не раз придется столкнуться с этой конфигурацией. Поскольку работы по ней и заказов всё меньше и меньше, знания о ней и опыт постепенно угасают. Мой опыт с ЗиК 7.7 длиной в 14 лет терять просто так неохота. В этой статье я запишу, чтобы не забыть, важные моменты об этой конфигурации, чтобы самому не забыть, и вдруг кто-то получит это в наследство на сопровождение и будет вынужден (иначе не скажешь) это обслуживать. Или еще можно рассматривать эту статью как модное нынче «Письмо самому себе в прошлое».

18.11.2014    35240    Lapitskiy    26       

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая 25

Статья Программист Нет файла v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    4582    filh    19       

Перерасчет ФСС НС за предыдущий период в ЗиК 315 11

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Адаптация типовых решений

Если изменить базу вида расчета «ФСС НС», то в релизе 1С:Зарплата и Кадры 7.70.315, в текущем расчетном периоде не происходит перерасчет за предыдущие периоды.

02.11.2011    14852    Nicholas    13       

ЗиК: Заполнение данных о заработке у предыдущих работодателей в больничном 9

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Доработка ЗиК 314. Заполнение данных в больничном за 2 предыдущих года у другого работодателя. Для работы необходимо добавить в конфигурацию новый справочник.

04.10.2011    9122    allexe    13       

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК 18

Статья Программист Нет файла v77::Расчет 1cv7.md 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    6592    maxim305    18       

1С 7.7 ЗиК. Доработка документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке 8

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Маленькая доработка модуля документа "Бригадный наряд" с возможностью увидеть часы в расчетном листке. Не забудьте, когда будете заполнять документ "Бригадный наряд", поставить галочку "Учитывать отработанные часы".

08.09.2011    4653    Ироида    14       

Расчет сверхурочной работы 25

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата Учет рабочего времени Бесплатно (free) Бухгалтерские

Сверхурочной работой считается работа, производимая работником по инициативе работодателя сверх нормального числа рабочих часов за учетный период (п.1 ч.2 ст. 99 ТК РФ). Данная обработка позволяет автоматически по итогам учетного периода (месяц, квартал, год) расчитать переработку сотрудников и расчитать им доплату за сверхурочную работу.

31.08.2011    18918    151    victuan    29       

Расшифровка внутренних расчетов 1С:Зарплата 10

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Трассировка (расшифровка) промежуточных расчетов документов в 1С:Зарплата

20.07.2011    8490    buhinfo    5       

Кнопка обновления версии внешнего отчета 18

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет Россия Бесплатно (free) Практика программирования

После исправления внешнего отчета вместо рекомендации пользователю: "Закрой отчет и открой его заново", говорим: "Нажми на кнопку".

18.06.2011    11698    Shaman100M    8       

Методика расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года (вариант) 32

Статья Программист Нет файла v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

В статье рассмотрен один из возможных вариантов расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года.

14.06.2011    19390    vkr    48       

Особенности сортировки в 1С:Предприятие 7.7 22

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Бесплатно (free) Практика программирования

Подобная "разработка" использовалась для анализа/сравнения порядка индексов таблиц БД в различных СУБД: "родные" DBF, MS SQL, CodeBase 6.5, Advantage 7.x/8.x/9.x. Тогда было выяснено, что в этих СУБД разный порядок сортировки индекса.

29.05.2011    15221    68    hogik    4       

Лицевой счет для ЗиК 7.7 8

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные печатные формы Бухгалтерские

В ЗиКе есть отчет Лицевые счета и карточки-справки. Для хозрасчетных организаций печатная форма только одна Т-54а, для бюджетных организаций имеется еще 2 печатных формы довольно удобных. В обработке сохранен отчет с установленным флагом бюджетной организации. Может кому пригодится.

12.05.2011    7770    165    VladB50    7       

Форма 1-НДФЛ для 2011 года (Зарплата и Кадры 7.7, релиз 310) 29

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Бесплатно (free) Практика программирования

В прежних релизах была возможность из справочника "Сотрудники" сформировать форму 1-НДФЛ по кнопке "Ввод данных" (там была возможность расшифровки сумм). Вернём полезную функцию!

29.04.2011    4373    Q-Q    9       

Некоторые ошибки и «проблемные» особенности реализации встроенного языка платформы 1С:Предприятие 7.7 96

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Описание некоторых ошибок и особенностей реализации встроенного языка, которые создают «подводные камни» при программировании, а также возможных способов обхода этих проблем из собственного опыта работы на платформе 1С:Предприятие 7.7.

08.04.2011    42003    AleksR    102       

Вариант реализации динамического табло в 1С 7.7 12

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Позволяет отображать на экране (монитора или большого телевизора) результат работы требуемого отчета при изменении определенных данных без необходимости интерактивного участия пользователя

14.03.2011    7141    1с2с    19       

Отпуск по уходу за ребенком. Расчет по-новому и по-старому 32

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Управление персоналом (HRM) Бесплатно (free) Практика программирования

По новому законодательству расчет среднего заработка для отпуска по уходу можно производить как по старым правилам, так и по новым, на усмотрение сотрудника. Реализуем это в ЗиК.

11.03.2011    10176    Nicholas    9       

Две простенькие функции для правильного учета сторно-записей и записей-перерасчетов 9

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Часто при подсчете дней по записям журнала расчетов "Зарплата" берется знак "+" или "-" в зависимости от признака сторно-записи. Но рано или поздно результат получится ошибочным.

19.02.2011    8673    jack19    3       

Ошибки формата файла 2-НДФЛ в ЗиК релиз 306 100

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия НУ Зарплата НДФЛ Бесплатно (free) Практика программирования

Ошибки 2НДФЛ в релизе: файл формируется как для ЮЛ, даже если работодатель ИП, опечатка "Отчетсвто", и указание имени файла с расширением. Нужно подправить отчет "СправкиПоНДФЛ".

02.02.2011    17100    1st    6       

ПФР за год 10

Статья Бухгалтер Нет файла v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Учет и отчетность

Могу подсказать алгоритм, как надо заполнять документ "Расчеты по страховым взносам", чтобы отчет для ПФР сошелся в копеечку

29.01.2011    6801    Lika-Kalika    3       

ЗиК 306 и ЗиК 305. Единовременные пособия из ФСС для организаций уплащивающих ЕНВД 10

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

Возникла ошибка когда Единовременные пособия из ФСС неправильно вставали в "Карточку расчета страховых взносов" если были выплаченны после сентября месяца. и сотвественно неправильно формируеться РСВ-1

25.01.2011    7823    *Zed*    2       

Тюнинг Бух 7.7.: Микрографики в ТЧ документа. 49

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Как вставить в документ что-то вроде диаграммы распределения сумм…

25.01.2011    18168    Арчибальд    18       

ЗиК 2011 (ставки ФОМС) 90

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ НУ Windows Зарплата Управление персоналом (HRM) ФОМС, ПФ, ФСС Бесплатно (free) Обработка справочников

Обработка устанавливает в типовой конфигурации "Зарплата и Кадры 7.7" (релиз 305) ставки страховых взносов, измененные с 1 января 2011 года Федеральным законом от 16.10.10 № 272-ФЗ.

09.01.2011    11517    588    Antia    11       

Быстрый подсчет элементов справочника 17

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Частенько бывает нужно подсчитать количество элементов в справочнике, чтобы показать пользователю прогресс выполнения обработки. Быстро это сделать позволяет следующая функция.

18.10.2010    21244    brr    11       

ЗиК.300 Загогулина 59

Инструменты и обработки Программист Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

В конфигурации ЗиК.300 при использовании при расчетах любого единовременного пособия из соцстраха (рождение, погребение…) - возможна ошибка в своде проводок...

24.08.2010    12952    UV2    14       

Изменяем вид кнопок на форме 1С 7.7 25

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Бесплатно (free) Практика программирования

Изменяем вид кнопок на форме 1С 7.7. Статья для разработчиков ВК (Delphi) Реализовано в http://infostart.ru/public/59436/?PAGEN_1=22#comm

20.08.2010    20712    Abadonna    12       

Максимум изменений в стандартной конфигурации при их минимуме с использованием formex.dll 34

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Практика программирования Разработка внешних компонент

Восстанавливаю ранее опубликованную статью. Может кому пригодится... Иногда очень хочется что-нибудь добавить в стандартную конфигурацию, но потом возникают проблемы, связанные с "затиранием" кода при обновлении. Каждый раз помнить где и что - напряжно. При данном подходе в Глобальный Модуль добавляется всего одна (!) строчка

15.08.2010    16440    Abadonna    33       

Список сотрудников с особыми условиями труда для ПФР. (Версия от 16.07.2011) 25

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

Формирование и выгрузка списка сотрудников с особыми условиями труда в xml-файл под версию 1.9 Отчет переписан почти заново. Обновление 16.07.2011.

23.07.2010    16375    403    rechvladmir    22       

Ускоритель СЗВ 2010 для ЗиК 2.99 30

Статья Системный администратор Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Ускоряет формирование СЗВ примерно вполовину за счет уменьшения числа запросов. Реально полезно, когда надо часто и много заходить в редактирование форм СЗВ. ЗиК 2.99

20.07.2010    7990    aves    7       

ЗиК 298 Ошибка в исчислении стажа. Отчетность ПФР СЗВ-6. 34

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Проблемы у сотрудников, имеющих Больничные листы, у которых либо Начало болезни = конец месяца либо Окончание болезни = начало месяца. В первом случае в СЗВ-6 началом болезни считается начало следующего месяца, во втором окончание болезни - конец месяца.

13.07.2010    11059    Cvetic    19       

Подготовка сведений для ПФР за 1 полугодие 2010 года - ошибка (Конфигурация Зарплата и кадры 7.7. Релиз 298) 8

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Регламентированная отчетность

Обработка по формированию печатных форм и выгружаемых файлов в соответствии с требованиями ПФ РФ, полученная от krein, по ссылке http://infostart.ru/public/72604!

04.07.2010    9075    218    vladimir_astapov    7       

Штатное расписание по факту (со всеми надбавками, с оплатой по окладам и тарифам) 23

Отчеты и формы no Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

Учитываются не только оклады, но и часовые тарифы сотрудников, а также все постоянные надбавки, введены ли они через справочник "Штатное расписание" или документами.

18.06.2010    8781    312    pr_skm    12       

Разбор строки CSV при помощи RegExp 12

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Вроде бы все просто, пока не встретилось что-то наподобие "111;111""";111

27.05.2010    12398    Berrimor    16       

Фильтрация иерархического справочника по какому-либо условию в форме списка 13

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Перед 1С программистами порой встаёт задача реализовать фильтрацию справочника по какому-нибудь условию прямо в форме списка (Например "ФормаСписка" или "ДляПодбора"). Вот и передо мной, недавно, поставили такую задачу. Она оказалась не такой уж и тривиальной, особенно для иерархического справочника...

19.05.2010    10640    Antoska    19       

Как получить GUID без v7plus.dll в Предприятии 7.7 10

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Универсальные функции

Часто в терминальных сессиях у пользователю Windows не хватает прав на регистрацию v7plus.dll. Соответственно нельзя воспользоваться, например методом СоздатьGUID() класса V7SysInfo.

12.05.2010    12237    prolancer    5       

Расчетная ведомость с детализацией по месяцам 46

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Бесплатно (free) Универсальные печатные формы Бухгалтерские

Стандартная расчетная ведомость с возможностью формирования за произвольный период. С детализацией по месяцам.

04.05.2010    17507    676    Diamante    14       

1c v 7.7. Установка владельца для справочника, имеющего записи. 9

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Итак, в конфигурацию я должен был добавить новый справочник, и, самое странное, должен был поставить ему в подчинение уже существующий справочник, причем активно использующийся. Если делать это штатными средствами, 1с при сохранении конфигурации выдает сообщение, что справочник такой-то имеет записи и не может быть подчинен.

28.04.2010    7454    Майкопчанин    12