Поздравление с 8 марта [2011]

Сообщество - Поздравления

40
Обработка-поздравлялка пользователей базы с 8 марта. Используется персонаж Merlin (читает текст вслух). Используется внешнее приложение "цветы", при вызове которого экран заполняется цветами.

Скоро праздник.  Решил выложить свою версию поздравлялки с 8 марта.

Навеяно вот этой разработкой (//infostart.ru/public/80721/).

В обработке есть 2 формы с разными обоями. Выбирайте на ваш вкус =)).

Если хочется использовать "цветы", то путь к внешнему приложению нужно указать в переменной ПутьКПриложению_Цветы в процедуре ПриОткрытии().

Чтобы обработка сама запустилась при открытии базы в последний рабочий день перед праздником (05.03.2011) в модуль приложения нужна воткнуть это:

Процедура ПриНачалеРаботыСистемы()

#Если Клиент Тогда
Если НачалоДня(ТекущаяДата()) = НачалоДня(Дата(2011,03,05)) Тогда
           Попытка
                         ФормаПоздравлениеСПраздником = Обработки.ПоздравлялкаС8Марта.ПолучитьФорму("Форма");
                         Если ФормаПоздравлениеСПраздником.Открыта() Тогда
                                 ФормаПоздравлениеСПраздником.Активизировать();
                         Иначе
                                 Если Не ВосстановитьЗначение("ПоздравлялкаС8Марта_НеПоказыватьПовторно") Тогда
                                         ФормаПоздравлениеСПраздником.Открыть();  
                                 КонецЕсли;
                         КонецЕсли;
           Исключение
           КонецПопытки;
КонецЕсли
#КонецЕсли

КонецПроцедуры

40

Скачать файлы

Наименование Файл Версия Размер
Архив с обработками для платформ 1С8.1,1С8.2 и внешнее приложение "Цветы"
.zip 547,57Kb
07.03.17
344
.zip 547,57Kb 344 Скачать бесплатно

См. также

Специальные предложения