IE2017

Поздравление с 8 марта [2011]

Сообщество - Поздравления

Обработка-поздравлялка пользователей базы с 8 марта. Используется персонаж Merlin (читает текст вслух). Используется внешнее приложение "цветы", при вызове которого экран заполняется цветами.

Скоро праздник.  Решил выложить свою версию поздравлялки с 8 марта.

Навеяно вот этой разработкой (//infostart.ru/public/80721/).

В обработке есть 2 формы с разными обоями. Выбирайте на ваш вкус =)).

Если хочется использовать "цветы", то путь к внешнему приложению нужно указать в переменной ПутьКПриложению_Цветы в процедуре ПриОткрытии().

Чтобы обработка сама запустилась при открытии базы в последний рабочий день перед праздником (05.03.2011) в модуль приложения нужна воткнуть это:

Процедура ПриНачалеРаботыСистемы()

#Если Клиент Тогда
Если НачалоДня(ТекущаяДата()) = НачалоДня(Дата(2011,03,05)) Тогда
           Попытка
                         ФормаПоздравлениеСПраздником = Обработки.ПоздравлялкаС8Марта.ПолучитьФорму("Форма");
                         Если ФормаПоздравлениеСПраздником.Открыта() Тогда
                                 ФормаПоздравлениеСПраздником.Активизировать();
                         Иначе
                                 Если Не ВосстановитьЗначение("ПоздравлялкаС8Марта_НеПоказыватьПовторно") Тогда
                                         ФормаПоздравлениеСПраздником.Открыть();  
                                 КонецЕсли;
                         КонецЕсли;
           Исключение
           КонецПопытки;
КонецЕсли
#КонецЕсли

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
Архив с обработками для платформ 1С8.1,1С8.2 и внешнее приложение "Цветы"
.zip 547,57Kb
07.03.17
344
.zip 547,57Kb 344 Скачать бесплатно

См. также

Комментарии
0. execombat 39 02.03.11 16:17 Сейчас в теме
Обработка-поздравлялка пользователей базы с 8 марта.
Используется персонаж Merlin (читает текст вслух).
Используется внешнее приложение "цветы", при вызове которого экран заполняется цветами.

Перейти к публикации

1. Аркадий Кучер (Abadonna) 3683 02.03.11 16:17 Сейчас в теме
Когда ж, блин, они закончатся, эти поздравлялки? :cry:
Неистребимы прям, как перенумераторы.
И Мерлин, читающий вслух, - у вас там юзверей всех колонками побаловали?
2. Владимир (vladismi) 149 02.03.11 16:21 Сейчас в теме
Картинка качается, а где же поздравлялка?
3. SpiderRu (WolfKgn) 02.03.11 16:45 Сейчас в теме
таки да - а где сама поздравлялка? :)
ЗЫ.. нашел.. но как-то странно она выложена
4. execombat 39 02.03.11 16:47 Сейчас в теме
vladismi
SpiderRu
Исправлено. Можно качать.
5. execombat 39 02.03.11 16:53 Сейчас в теме
Abadonna пишет:

Когда ж, блин, они закончатся, эти поздравлялки?

Не пойму. Чего плохого в поздравлялках? Кому не нужно, те и не качают.
Abadonna пишет:
... у вас там юзверей всех колонками побаловали?

Колонки легко заменяются гарнитурой.
6. Альтаир (Altair777) 638 02.03.11 18:52 Сейчас в теме
Abadonna пишет:
Когда ж, блин, они закончатся, эти поздравлялки? :cry:
Неистребимы прям, как перенумераторы.

от перенумераторов хоть какой-то практический прок был ;)
7. Вадим Скакун (UncleVader) 126 03.03.11 09:27 Сейчас в теме
Abadonna пишет:
Когда ж, блин, они закончатся, эти поздравлялки? smile:cry:
Неистребимы прям, как перенумераторы.
Altair777 пишет:
от перенумераторов хоть какой-то практический прок был smile;)

Необоснованное ворчание!
А что плохого или вредного?!
8. Альтаир (Altair777) 638 03.03.11 10:21 Сейчас в теме
(7) полезного ничего, а вредного?... засорение каталога разработок :)
9. Вадим Скакун (UncleVader) 126 03.03.11 10:38 Сейчас в теме
(8) Не соглашусь! Как источник эндорфинов с медицинской точки зрения очень даже полезно, особенно после затяжной унылой зимы!
10. Роман Семенов (rsu55) 03.03.11 10:57 Сейчас в теме
антивирусник файл flower.exe определяет как вирус Joke.Rosenu
11. execombat 39 03.03.11 11:22 Сейчас в теме
А что за антивирусник? NOD32 и Avast молчат.
12. Андрей Мухин (Muhin555) 12 03.03.11 13:46 Сейчас в теме
неплохо было бы не из конфигурации, а из доп.обработок эти поздравлялки запускать....
13. Роман Семенов (rsu55) 03.03.11 17:10 Сейчас в теме
execombat пишет:

А что за антивирусник? NOD32 и Avast молчат.


Symantec...
14. Вадим Скакун (UncleVader) 126 04.03.11 12:16 Сейчас в теме
Разделил логон-скрипты на мужской и женский, в женский закинул flower.exe, все просто счастливы :D
15. execombat 39 04.03.11 12:38 Сейчас в теме
Я так понимаю теперь девушки получают цветы сразу после включения компьютера и ввода пароля? :D
16. Сергей (floodprog) 17 07.03.11 05:12 Сейчас в теме
работать некому. заводы стоят ! :D
17. Сергей Сергеевич (onyx) 20 21.09.11 08:30 Сейчас в теме
Когда ж, блин, они закончатся, эти поздравлялки?
Неистребимы прям, как перенумераторы.
18. Алексей Прокопенко (axelload) 26.09.11 11:58 Сейчас в теме
Отличная обработка. только вот говорящие фигурки на windows7 не работают. пришлось выпрашивать патч у мелкомягких
19. Алексей Прокопенко (axelload) 26.09.11 11:59 Сейчас в теме
патч прислали. фигурки заработали но анимация win7 работает весьма странно
20. execombat 39 27.09.11 09:24 Сейчас в теме
А что за патч? Есть ссылка? У меня на win 7 персонажи работают. Только фон у фигурок не прозрачный (
21. Юлия Петрова (petrovaUL) 21.02.12 12:43 Сейчас в теме
Отличная обработка. только вот говорящие фигурки на windows7 не работают. Какай патч нужен?
22. execombat 39 22.02.12 12:13 Сейчас в теме
Для Win 7 нужно установить MS Agent. Скачал патч здесь
23. ivan ivanov (ivan07) 06.03.12 11:48 Сейчас в теме
Интересная обработка, испытаю на своих коллегах. Спасибо!
24. Александр Щемелёв (zavyzka) 48 07.03.12 14:47 Сейчас в теме
25. Дмитрий Алиулов (freezetron) 11.03.12 08:31 Сейчас в теме
Спасибо! Всем очень понравилось!
26. grey_X (GREY_x) 22.02.13 10:29 Сейчас в теме
Кто-нибудь решил проблему с не прозрачным фоном у фигурок в винде 7-ке?
27. С. Дмитрий (spa07) 04.03.13 10:25 Сейчас в теме
КУсок вставки в процедуру ПриНачалеРАботыСИстемы отрабатывает некорректно, а именно
ВосстановитьЗначение("ПоздравлялкаС8Марта_НеПоказыватьПовторно") первый раз возвращает неопределено и форма не открывается.
Пришлось допиливать.
28. execombat 39 06.03.13 16:23 Сейчас в теме
(26) GREY_x,
Для того чтобы на WIN 7 фон у фигурок был прозрачным нужно установить патч. Ссылка есть выше. А вот с фоном цветов не знаю что делать.
29. Татьяна bDFYJDF (stata) 06.12.15 19:29 Сейчас в теме
внешнее приложение "цветы", при вызове которого экран заполняется цветами можно такое скачать или нет. Очень хочется
30. Татьяна bDFYJDF (stata) 06.12.15 19:46 Сейчас в теме
хОЧУ СКАЧАТЬ ПРОСТО внешнее приложение "цветы", при вызове которого экран заполняется цветами, МОЖНО ЭТО КАК ТО ИЛИ НЕТ.
Оставьте свое сообщение