Добавление печати кода аналитики в формах ПКО и РКО (Бух. бюджет v. 7.7)

Публикация № 82512

Разработка - Практика программирования

0

Добавление печати кода аналитики в формах ПКО и РКО (Бух. бюджет v. 7.7)

ПКО (Документы.ПриходныйОрдер.Форма.Модуль)

До

КодАналитики="";
//ВыбратьСтроки();
//Пока ПолучитьСтроку() = 1 Цикл
//Если ЭКР.Выбран() = 1 Тогда
//Если Найти(КодАналитики, ЭКР.Код+",") = 0 Тогда
//КодАналитики=КодАналитики+ЭКР.Код+", ";
//КонецЕсли;
//КонецЕсли;
//КонецЦикла;
//ДлинаКода = СтрДлина(КодАналитики);
//Если ДлинаКода>2 Тогда
//КодАналитики=Лев(КодАналитики,ДлинаКода-2);
//КонецЕсли;

 

После

 

КодАналитики="";
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
Если ЭКР.Выбран() = 1 Тогда
Если Найти(КодАналитики, ЭКР.Код+",") = 0 Тогда
КодАналитики=КодАналитики+ЭКР.Код+", ";
КонецЕсли;
КонецЕсли;
КонецЦикла;
ДлинаКода = СтрДлина(КодАналитики);
Если ДлинаКода>2 Тогда
КодАналитики=Лев(КодАналитики,ДлинаКода-2);
КонецЕсли;
 
РКО (Документы.РасходныйОрдер.Форма.Модуль) 

До 

КодАналитики="";
//ВыбратьСтроки();
//Пока ПолучитьСтроку()=1 Цикл
//Если ЭКР.Выбран()=1 Тогда
//Если Найти(КодАналитики, ЭКР.Код+", ")=0 Тогда
//КодАналитики=КодАналитики+ЭКР.Код+", ";
//КонецЕсли;
//КонецЕсли;
//КонецЦикла;
//ДлинаКода = СтрДлина(КодАналитики);
//Если ДлинаКода>2 Тогда
//КодАналитики=Лев(КодАналитики,ДлинаКода-2);
//КонецЕсли;

 

После

КодАналитики="";
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если ЭКР.Выбран()=1 Тогда
Если Найти(КодАналитики, ЭКР.Код+", ")=0 Тогда
КодАналитики=КодАналитики+ЭКР.Код+", ";
КонецЕсли;
КонецЕсли;
КонецЦикла;
ДлинаКода = СтрДлина(КодАналитики);
Если ДлинаКода>2 Тогда
КодАналитики=Лев(КодАналитики,ДлинаКода-2);
КонецЕсли;

 

К сожалению, после обновления изменения приходится делать заново. Либо просто отключать обновления этих документов. 

0

Специальные предложения

См. также

Важные изменения в 54-ФЗ: какой будет ККМ в 2017 году 31

Статья Бухгалтер Пользователь Нет файла v7.7 v8 Розничная и сетевая торговля (FMCG) Россия Кассовые операции Розничная торговля Бесплатно (free) ККМ Фискальный регистратор

Уже начиная с апреля 2016 года нас ждут довольно серьезные изменения по передаче данных о продажах в налоговую. Не только ожесточится контроль над тем, сколько мы продаем, но и изменятся сами ККМ.

11.05.2016    91456    alis112358    80       

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция 111

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования WEB

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    49074    Serginio    33       

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д. 37

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент WEB

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    26018    Serginio    22       

Использование классов .Net в 1С для новичков 147

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент Универсальные функции

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    63796    Serginio    104       

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним 78

Статья Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    72242    shmellevich    35       

Скрытие помеченных на удаление в справочнике 5

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Корректно скрываем помеченных на удаление в справочнике, с иерархией и без. Вроде простая и нужная вещь, но почему-то нигде не встречалась

08.08.2012    11425    mikukrnet    7       

Исправление и проведение документов 5

Статья Программист Нет файла v77::БУ 1С7:ПУБ Россия Бесплатно (free) Практика программирования

Исправление и проведение документов, например, счетов-фактур, введенных на основании документов реализации, можно организовать многими способами. Описан сравнительно простой подход, реализованный и работающий несколько лет в реальной бухгалтерии 1Cv7.7. Без внешних компонентов.

23.07.2012    11615    BorisBelov    11       

Ввод остатков по 76.ВА в 1С ПУБ 2

Статья Программист Нет файла v77::ОУ v77::БУ 1С7:ПУБ Россия БУ Бесплатно (free) Практика программирования

Статья посвящена найденному мной недостатку в конфигурации 1С 7.7 "Производство-услуги-бухгалтерия", связанному с вводом начальных остатков по 76.ВА.

29.04.2012    8117    Пользователь 1С    0       

Обновление базы 1с 7.7. с помощью движка 1с 8.х 92

Статья Системный администратор Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования Администрирование данных 1С

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    16184    Valerich    31       

Ошибка при формировании отчета Авансы по налогу на имущество. В 1С:Предприятие 7.7. Регламентированная отчетность за I квартал 2012 года Обновление 12q1009 от 18.04.2012 г. 18

Статья Программист Нет файла v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free) Практика программирования

При формировании отчета NIMAVP1.ERT Авансы по налогу на имущество (версия 5.03) в разделе № 1-3 не сохраняет номера Страниц при выборе, что ведет к не сохранению и выводу печати двухмерного кода.

24.04.2012    7441    leo072    7       

Ошибка при формировании отчета 4-ФСС для УСН 7,7 12q1007 6

Статья Программист Нет файла v77::БУ 1С7:Бух Россия НУ Бесплатно (free) Практика программирования

При формировании таблицы 6,7 раздела 2 возникает ошибка ИтАн.ИспользоватьСубконто(ВидыСубконто.ВидыПлатежейВФонды, Перечисление.ВидыПлатежей.Штраф); {C:\PROGRAM FILES\1CV77\SSTDEMO\EXTFORMS\RP12Q1.GRP\FSS4_1212.ERT(2330)}: Поле агрегатного объекта не обнаружено (ВидыПлатежейВФонды)

11.04.2012    9300    *Zed*    1       

v77. Робот 43

Инструменты и обработки no Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Исполнитель Робот. Учебное пособие по программированию для детей дошкольного возраста. Без внешних компонент.

09.04.2012    10430    54    item    18       

Запуск внешней обработки по расписанию v7.7 39

Статья Программист Нет файла v7.7 1cv7.md Россия Windows Бесплатно (free) Практика программирования Администрирование данных 1С

Неоднократно возникали задачи организовать, например ежедневную выгрузку и отправку отчетов по эл.почте, и вот…

20.03.2012    39990    Yury1001    17       

v77. Паинт 53

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

v77. 1С:Паинт :) Такая вот игрушка. Без внешних компонент.

06.03.2012    12260    81    item    38       

Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД 11

Статья Программист Нет файла v77::БУ 1С7:Бух Россия Зарплата Бесплатно (free) Практика программирования

При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".

22.01.2012    8133    lelbraun    3       

Как уменьшить количество заблокированных объектов 26

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    13459    ShEvOvIcH    18       

Медленное формирование отчета в ФСС. Ошибка в алгоритме файл: ESN_GET.ERT 6

Статья Системный администратор Программист Нет файла v77::БУ 1С7:Бух Россия Бесплатно (free) Практика программирования

Достаточно старая ошибка 1С (исправляю уже пару лет) в файле ESN_GET.ERT (1С7.7 бухгалтерский учет). Проявляется в том, что очень медленно формируются регламентные отчеты в фонды ФСС и ПФР, если в типовой бухгалтерии ведётся начисление зарплаты сотрудникам и количество сотрудников превышает определённое количество (в моём примере 90, но замедление скорости видно и на 20)

11.01.2012    5575    Digo65    2       

Ошибка в обработке "ПодборЗатратПоУслугам" в типовой Бухгалтерии для бюджетных учреждений 6.2 (647) 2

Статья Программист Нет файла v77::БУ 1С7:ББУ Государственные, бюджетные структуры Россия Бесплатно (free) Практика программирования

В текущем на момент публикации релизе 647 конфигурации "Бухгалтерия для бюджетных учреждений 6.2" при заполнении документа "Списание затрат по услугам" наблюдается следующая ошибка: в режиме заполнения (F5) невозможно выбрать значение субконто, если тип субконто - подчиненный справочник.

30.12.2011    8533    demon_infernal    1       

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7) 15

Статья Программист Нет файла openconf v77::БУ 1cv7.md Россия Бесплатно (free) Практика программирования

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7). Данную функцию можно вставить в Глобальный модуль и пользоваться, например, при вводе или сохранении e-mail.

30.10.2011    9151    zaursoft    11       

Ошибка при формировании Отчета по налогу на прибыль за 9 месяцев 2011 г. (версия 11q300x) для Бухгалтерии 7.7 6

Статья Программист Нет файла v77::БУ 1С7:Бух Россия Налог на прибыль Бесплатно (free) Регламентированная отчетность Практика программирования

При формировании Отчета по налогу на прибыль из конфигурации Бухгалтерский учет - Регламентированная отчетность за 9 месяцев 2011 года (версия 11q3002/11q3003/11q3004) - неправильно формируются суммы ежемесячных авансовых платежей в бюджет субъекта Российской Федерации для организаций, имеющих обособленные подразделения (подраздел 1.2 раздела 1 ОСН, строки 220-240)

28.10.2011    11668    vkr    5       

7.7.: Готовим md-файл для публикации. В картинках. 46

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Вы доработали типовую конфигурацию: скажем, добавили новый Документ, и хотите им поделиться с обществом ИС. Но нельзя же выложить МД-шник целиком, это будет нарушением правил. И как тут быть?

14.09.2011    15287    Арчибальд    21       

Дата запрета редактирования 17

Статья Программист Нет файла v77::БУ 1cv7.md Россия Бесплатно (free) Практика программирования

Очень часто необходимо постоянно закрывать период для редактирования документов. Вот как я вышла из этой ситуации.

15.07.2011    9180    natalika1601    14       

Методика учета предоплаты на 01.04.2011 после перехода на положения Налогового Кодекса Украины в конфигурации Бухгалтерский учет для Украины 7.7 0

Статья Программист Нет файла v77::БУ 1С7:Бух Украина БУ Windows Налог на прибыль Бесплатно (free) Пользователю системы Практика программирования

В релизе 287 конфигурации 1С Бухгалтерия для Украины предусмотрено, что пользователи будут вручную устанавливать в документах сумму авансов на 01.04.2011, которую нужно исключать из расчета прибыли. Эта методика показывает, как можно автоматизировать этот процесс. По методике созданы программные средства (Обработка для создания забалансовых счетов учета такой предоплаты и операции с такой предоплатой, + 2 процедуры глобального модуля и их вызов в документах). Методика протестирована на крупных базах данных и успешно используется.

08.07.2011    7882    Analitik    5       

Кнопка обновления версии внешнего отчета 18

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет Россия Бесплатно (free) Практика программирования

После исправления внешнего отчета вместо рекомендации пользователю: "Закрой отчет и открой его заново", говорим: "Нажми на кнопку".

18.06.2011    11941    Shaman100M    8       

Методика расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года (вариант) 32

Статья Программист Нет файла v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

В статье рассмотрен один из возможных вариантов расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года.

14.06.2011    19601    vkr    48       

Бюджетка ББУ 7.7 "Новый план счетов" без обновления на 645 :) 9

Статья Программист Нет файла v77::БУ 1С7:ББУ Россия БУ Бесплатно (free) Практика программирования

Дешевый и сердитый вариант привыкания к новому плану счетов в 7-ке ББУ (за 2-3 минуты) (конфигурация 644 и менее ). 1. Оставляем план счетов как есть, пусть пока бухгалеры работают по-прежнему, а программист вдумчиво готовится к Настоящему Переводу. 2. Для отчетности на печать во всех стандартных отчетах (оборотки, карточки, анализы и пр.) выводим "новый план счетов". Подменой один к одному. Главное - идея. Реализацию можете подправить самостоятельно, кому нужно. Печатные формы подшиваются, бухгалтеры привыкают к новым счетам. Скажете: временный вариант. Конечно, зато какой простой!

05.06.2011    4741    alexolder    12       

Особенности сортировки в 1С:Предприятие 7.7 22

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Бесплатно (free) Практика программирования

Подобная "разработка" использовалась для анализа/сравнения порядка индексов таблиц БД в различных СУБД: "родные" DBF, MS SQL, CodeBase 6.5, Advantage 7.x/8.x/9.x. Тогда было выяснено, что в этих СУБД разный порядок сортировки индекса.

29.05.2011    15441    68    hogik    4       

Конвертация прериодических реквизитов справочников 6

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Активно работаю с конфигурацией "Конвертация" версии 2.0, но возникают ситуации, когда необходимо написать правила обмена между базами данных 1С:Предприятие. Когда и источник и приемник имеют версию 7.7. И камень преткновения - выгрузка периодических реквизитов справочников.

29.04.2011    13141    lvictor58    2       

Ошибка в файле выгрузки отчета РСВ-1 8

Статья Программист Бухгалтер Нет файла v77::БУ 1С7:Бух Россия Бесплатно (free) Практика программирования

Ошибка в файле выгрузки отчета РСВ-1 При проверке файла выгрузки программа chek xml 2011 выдает следующею ошибку. Ошибка в формате десятичного числа. Содержимое элемента ДоляДохода> не соответствует нужному типу. Источник

28.04.2011    3332    link1c    2       

Некоторые ошибки и «проблемные» особенности реализации встроенного языка платформы 1С:Предприятие 7.7 96

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Описание некоторых ошибок и особенностей реализации встроенного языка, которые создают «подводные камни» при программировании, а также возможных способов обхода этих проблем из собственного опыта работы на платформе 1С:Предприятие 7.7.

08.04.2011    42520    AleksR    102       

Несколько видов НДС. Как нумеровать налоговые накладные. 2

Статья Программист Нет файла v77::БУ 1С7:Бух Украина БУ НУ Windows НДС Бесплатно (free) Практика программирования

Все знают, что помесячная нумерация налоговых накладных для украинской бухгалтерской "семерки" появилась в релизе 7.70.282 Однако, никто из "великих" не озаботился проблемами тех бухгалтеров, которые например, ведут перерабатывающие предприятия, а посему сдают две декларации, два реестра и, благодаря извращениям в законодательстве должны нумеровать налоговые накладные начиная с единицы для двух реестров. Мною сделана попытка решить эту проблему.

16.03.2011    7984    ValeryZ    6       

Вариант реализации динамического табло в 1С 7.7 12

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Позволяет отображать на экране (монитора или большого телевизора) результат работы требуемого отчета при изменении определенных данных без необходимости интерактивного участия пользователя

14.03.2011    7345    1с2с    19       

Отпуск по уходу за ребенком. Расчет по-новому и по-старому 32

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Управление персоналом (HRM) Бесплатно (free) Практика программирования

По новому законодательству расчет среднего заработка для отпуска по уходу можно производить как по старым правилам, так и по новым, на усмотрение сотрудника. Реализуем это в ЗиК.

11.03.2011    10432    Nicholas    9       

Ошибки формата файла 2-НДФЛ в ЗиК релиз 306 100

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия НУ Зарплата НДФЛ Бесплатно (free) Практика программирования

Ошибки 2НДФЛ в релизе: файл формируется как для ЮЛ, даже если работодатель ИП, опечатка "Отчетсвто", и указание имени файла с расширением. Нужно подправить отчет "СправкиПоНДФЛ".

02.02.2011    17445    1st    6       

ЗиК 305 ЗиК 306 Больничный лист. 107

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Для переходящих больничных листов за счет работодателя оплачивается 2 дня, а не 3. Первоисточник: http://forums.kuban.ru/forum/viewtopi...669&page=2

25.01.2011    12489    Cvetic    26       

Тюнинг Бух 7.7.: Микрографики в ТЧ документа. 49

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Как вставить в документ что-то вроде диаграммы распределения сумм…

25.01.2011    18531    Арчибальд    18       

Быстрый подсчет элементов справочника 17

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Частенько бывает нужно подсчитать количество элементов в справочнике, чтобы показать пользователю прогресс выполнения обработки. Быстро это сделать позволяет следующая функция.

18.10.2010    21504    brr    11       

Печатные формы приходного и расходного кассового ордера с выводом 26-значного номера бухгалтерского счета 10

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:ББУ Россия БУ Кассовые операции Бесплатно (free) Печатные формы документов

Некоторые бухгалтера не желают распечатывать бухгалтерскую справку к документу ПКО или РКО, а хотят видеть полные номера счетов (с КБК) прямо в печатной форме ПКО и РКО. Выглядит странно, но тем не менее...

21.09.2010    12446    176    ipeg43    6       

ЗиК.300 Загогулина 59

Инструменты и обработки Программист Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

В конфигурации ЗиК.300 при использовании при расчетах любого единовременного пособия из соцстраха (рождение, погребение…) - возможна ошибка в своде проводок...

24.08.2010    13202    UV2    14