Прикол над пользователями. 1 апреля

Публикация № 83484

Разработка - Работа с интерфейсом

46
Завтра первое апреля. День смеха)) Разбавление обычных будней.
При открытии формы раскрашивает цветами радуги табличную часть.

 

 

При открытии формы раскрашивает цветами радуги табличную часть.
Выглядит очень  симпатично.

Реализовано в глобальном модуле:

Раскрашивать можно табличные части, таблицы значений и списки (справочников, документов и т.д.)

Перем глМассивЦветов; // 01.04.2011

Перем глГСЧ; // 01.04.2011


#Если Клиент Тогда
Функция РаскраситьСтрокиРадиШутки() Экспорт // 01.04.2011

    
Если Формат(ТекущаяДата(), "ДФ=ddMM")="0104" Тогда
        Возврат Ложь;
    КонецЕсли;

    Если 
глГСЧ.СлучайноеЧисло(0, 100)>13 Тогда
        Возврат Ложь;
    КонецЕсли;

    Возврат Истина;

КонецФункции

Процедура 
РаскраситьТЧ(Элемент, ОформленияСтрок) Экспорт  // 01.04.2011
    
Попытка

        
Сч = 0;
        
макс = глМассивЦветов.Количество();
        
ЭтоТЗ = ТипЗнч(Элемент.Значение)=Тип("ТаблицаЗначений") Или Найти(ТипЗнч(Элемент.Значение), "табличная часть")>0;

        Для Каждого 
Оформление Из ОформленияСтрок Цикл

            Если 
ЭтоТЗ Тогда
                
Оформление.ЦветФона = глМассивЦветов[ Элемент.Значение.Индекс(Оформление.ДанныеСтроки) % макс];
            Иначе
                
Оформление.ЦветФона = глМассивЦветов[ Сч % макс ];
                
Сч = Сч+1;
            КонецЕсли;

        КонецЦикла;

    Исключение
    КонецПопытки;
КонецПроцедуры
#КонецЕсли

глГСЧ = Новый ГенераторСлучайныхЧисел;
глМассивЦветов = Новый Массив;
глМассивЦветов.Добавить(Новый Цвет(255, 255, 255));
глМассивЦветов.Добавить(Новый Цвет(254, 251, 251));
глМассивЦветов.Добавить(Новый Цвет(254, 192, 192));
глМассивЦветов.Добавить(Новый Цвет(254, 106, 106));
глМассивЦветов.Добавить(Новый Цвет(254, 68, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 84, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 116, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 164, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 215, 62));
глМассивЦветов.Добавить(Новый Цвет(249, 249, 64));
глМассивЦветов.Добавить(Новый Цвет(165, 234, 74));
глМассивЦветов.Добавить(Новый Цвет(99, 207, 86));
глМассивЦветов.Добавить(Новый Цвет(62, 230, 200));
глМассивЦветов.Добавить(Новый Цвет(62, 237, 254));
глМассивЦветов.Добавить(Новый Цвет(62, 181, 232));
глМассивЦветов.Добавить(Новый Цвет(62, 109, 190));
глМассивЦветов.Добавить(Новый Цвет(160, 62, 185));
глМассивЦветов.Добавить(Новый Цвет(254, 95, 219));
глМассивЦветов.Добавить(Новый Цвет(254, 207, 243));

Для раскраски нужно приписать событие в обработчик ПриПолученииДанных:

Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)

    
РаскраситьТЧ(Элемент, ОформленияСтрок); //01.04.2011

КонецПроцедуры

 

 

 

 

46

Скачать файлы

Наименование Файл Версия Размер
Раскраска.epf
.epf 8,10Kb
21.02.13
85
.epf 8,10Kb 85 Скачать бесплатно

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. rsu5 31.03.11 18:00 Сейчас в теме
2. Serj1C 478 31.03.11 20:43 Сейчас в теме
(1) всего то в двух строках
3. DrAku1a 1306 01.04.11 09:08 Сейчас в теме
Ага... давайте внесем в стандартную конфу такие изменения, при этом надо включить режим изменения конфигурации, и потом будем огребать по попе при каждом обновлении баз )))
dj_serega; hansolo686; +2 2 Ответить
4. Serj1C 478 01.04.11 10:36 Сейчас в теме
(3) Всегда можно вернуться к конфигурации поставщика
5. IDija 150 01.04.11 15:15 Сейчас в теме
(0) Мне очень даже симпатично!!!Да и пользователи довольны! А изменение кода - ерунда! Можно и откатить...
6. esa35 87 10.11.11 10:51 Сейчас в теме
да, прикольненько!надо будет попробовать подшутить!
7. Lokiy 133 10.11.11 11:05 Сейчас в теме
Чето ломает меня конфу ради прикола такого обновлять, еще в переферийки ее тащить.
9. balabani 23.11.11 02:21 Сейчас в теме
Спасибо хорошая обработка
10. dardroze 11.01.12 16:25 Сейчас в теме
поставлю, посмотрим, что скажут бухгалтера
11. lilly 12.01.12 20:37 Сейчас в теме
12. andreysan 03.04.12 09:58 Сейчас в теме
Да ладно, до ума довести недолго , доработать под личные нужды, а идея неплохая
13. curys 05.04.12 12:37 Сейчас в теме
отличная шутка, спасибо автору, попробую сейчас заюзаем=)
14. glek 112 03.09.12 15:36 Сейчас в теме
Пошутить - можно. Только не массово. Потому что замаешься по клиентам откатывать. Не хватает какого-то отключения.
15. KillHunter 7 03.09.12 17:25 Сейчас в теме
16. dj_serega 368 24.10.12 11:42 Сейчас в теме
Если бы было внешней обработкой было бы круче.
17. taste 24.10.12 12:04 Сейчас в теме
кто оценил данную приколюху ??
18. shuhorov 24.10.12 12:36 Сейчас в теме
+ 1 за внешнюю, можно будет добавить в запуск при старте платформы
19. Xleo777 11 29.03.13 18:25 Сейчас в теме
Можно сделать свой общий модуль


#Если Клиент Тогда
Функция РаскраситьСтрокиРадиШутки() Экспорт // 01.04.2011
глГСЧ = Новый ГенераторСлучайныхЧисел;
Если Формат(ТекущаяДата(), "ДФ=ddMM")="0104" Тогда
Возврат Ложь;
КонецЕсли;

Если глГСЧ.СлучайноеЧисло(0, 100)>13 Тогда
Возврат Ложь;
КонецЕсли;

Возврат Истина;

КонецФункции

Процедура РаскраситьТЧ(Элемент, ОформленияСтрок) Экспорт // 01.04.2011
Попытка

Сч = 0;
глМассивЦветов = ПолучитьМассивЦветов();
макс = глМассивЦветов.Количество();
ЭтоТЗ = ТипЗнч(Элемент.Значение)=Тип("ТаблицаЗначений") Или Найти(ТипЗнч(Элемент.Значение), "табличная часть")>0;

Для Каждого Оформление Из ОформленияСтрок Цикл

Если ЭтоТЗ Тогда
Оформление.ЦветФона = глМассивЦветов[ Элемент.Значение.Индекс(Оформление.ДанныеСтроки) % макс];
Иначе
Оформление.ЦветФона = глМассивЦветов[ Сч % макс ];
Сч = Сч+1;
КонецЕсли;

КонецЦикла;

Исключение
КонецПопытки;
КонецПроцедуры
#КонецЕсли

Функция ПолучитьМассивЦветов()
глМассивЦветов = Новый Массив;
глМассивЦветов.Добавить(Новый Цвет(255, 255, 255));
глМассивЦветов.Добавить(Новый Цвет(254, 251, 251));
глМассивЦветов.Добавить(Новый Цвет(254, 192, 192));
глМассивЦветов.Добавить(Новый Цвет(254, 106, 106));
глМассивЦветов.Добавить(Новый Цвет(254, 68, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 84, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 116, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 164, 62));
глМассивЦветов.Добавить(Новый Цвет(254, 215, 62));
глМассивЦветов.Добавить(Новый Цвет(249, 249, 64));
глМассивЦветов.Добавить(Новый Цвет(165, 234, 74));
глМассивЦветов.Добавить(Новый Цвет(99, 207, 86));
глМассивЦветов.Добавить(Новый Цвет(62, 230, 200));
глМассивЦветов.Добавить(Новый Цвет(62, 237, 254));
глМассивЦветов.Добавить(Новый Цвет(62, 181, 232));
глМассивЦветов.Добавить(Новый Цвет(62, 109, 190));
глМассивЦветов.Добавить(Новый Цвет(160, 62, 185));
глМассивЦветов.Добавить(Новый Цвет(254, 95, 219));
глМассивЦветов.Добавить(Новый Цвет(254, 207, 243));
Возврат глМассивЦветов
КонецФункции
20. Niberu 5 23.04.13 10:14 Сейчас в теме
И может в подписку на какое-нибудь событие запихать.
Оставьте свое сообщение

См. также

СКД. Шаг 3. Используем макеты для оформления отчета 74

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Работа с интерфейсом

В данной публикации рассмотрим базовый подход к использованию собственных макетов в СКД на примере формирования небольшого отчета.

13.01.2020    2019    aximo    11       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Добавление собственного поля и состояния в настройки доступности по состоянию в 1С:Документооборот 15

Статья Программист Нет файла v8 ДО Бесплатно (free) Практика программирования Работа с интерфейсом

В данной публикации я хочу описать процесс добавления собственного поля и состояния в функционал настройки доступности по состоянию в 1С:Документооборот.

30.12.2019    952    pavelpribytkin96    1       

[СКД] Вывод картинки в результат любого отчета на СКД 104

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Работа с интерфейсом

Если у вас в справочнике Номенклатура (или другом справочнике) заполнена картинка, то ее можно легко вывести для наглядности отчета.

09.12.2019    4353    1    John_d    16       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Лайфхаки 1С. Настройка списков (Часть 3) 18

Статья Бухгалтер Пользователь Нет файла v8 Бесплатно (free) Работа с интерфейсом

Новая порция лайфхаков по работе с интерфейсом 1С. На этот раз разбираем работу со списками - учимся их упорядочивать, сортировать, создавать новые и перемещать старые. Это очень полезное дополнение к уже имеющимся знаниям по интерфейсу 1С.

03.12.2019    3759    VachKirp    13       

В новой платформе пропала кнопка "Печать". Имитируем БСП 18

Статья Программист Нет файла v8 Россия Бесплатно (free) Работа с интерфейсом

"Приятным" сюрпризом для многих пользователей 1С стало то, что при обновлении платформы (начиная с 8.3.15) полностью поменялся интерфейс. Можно долго спорить о целесообразности этого новшества, но самым главным минусом стало то, что пропали стандартные кнопки на панели инструментов. Разработчики предполагают повсеместное использование БСП, но что делать тем, кто давно и успешно использует самописные конфигурации, в которых формирование печатной формы происходит по ТабДок.Показать(), и не желает их "утяжелять"? Добавим общую форму с нужными нам кнопками.

03.12.2019    4128    Vlan    37       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.130.х, КА 2.4.11.х и ERP 2.4.11.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Управляемые формы. Изменение формы списка или формы объекта без внесения изменений в типовые формы (без использования расширений) 89

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Вносим изменения в типовые формы объектов (документы, справочники, журналы, обработки, общие формы). Не снимая с поддержки эти формы. Создаем программно элементы из общего модуля. Для примера рассмотрю добавление колонки "Скрепка" в форму списка документа. Если к документу привязан файл, то в списке в новой колонке должна отображаться "скрепка".

12.11.2019    6023    John_d    23       

ELK. Время изумительных историй! 27

Статья Системный администратор Программист Бизнес-аналитик Руководитель проекта Нет файла v8 1cv8.cf Бесплатно (free) Журнал регистрации Работа с интерфейсом

Всем привет! Сегодня хочу рассказать вам несколько полезных историй про то как нам помог Elastic search в связке с Kibana. Про сам Elastic рассказывать не буду, уже все давным давно описали и до меня. Все обычно говорят что это полезно, это классно. В то же время, очень мало кто рассказывает про практические ситуации: когда и как помог Elastic. Итак, начнем.

31.10.2019    4549    slozhenikin_com    26       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Лайфхаки 1С (часть 2) Настройка работы интерфейса такси. Настройка и советы по работе 14

Статья no Нет файла v8 1cv8.cf Россия Бесплатно (free) Работа с интерфейсом

Советы по настройке интерфейса Такси и особенности работы в этой среде.

24.10.2019    4078    VachKirp    7       

Создание асинхронных виджетов 103

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Описание нескольких способов создания асинхронных виджетов для 1С:Предприятия. Рассматриваются способы с использованием HTTP-сервисов и фоновых заданий.

16.10.2019    6310    YPermitin    15       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Формы. Трудности программной работы 79

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Бесплатно (free) Работа с интерфейсом

Рассматриваем основные подводные камни, с которыми приходится сталкиваться при программной работе с формами, а также способы обхода самых частых проблем.

06.10.2019    6417    YPermitin    21       

Лайфхаки 1С (часть 1). Настройки отчетов и печатных форм 1С 41

Статья Программист Пользователь Стажер Нет файла v8 1cv8.cf Россия Бесплатно (free) Работа с интерфейсом

Статья рассчитана на пользователей или программистов, которые только начинают работать с 1С, для максимально быстрого ознакомления с интерфейсом программы. В статье приведены лайфхаки, которые позволят вам быстро и эффективно научиться настраивать отчёты и печатные в среде программных продуктов 1С. Полученные знания значительно упростят взаимодействие с интерфейсом 1С и повысят продуктивность работы оператора.

02.10.2019    7459    VachKirp    9       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Добавляем виджет "Задачи от меня" в Документооборот 2.1 31

Статья Программист Нет файла v8 v8::Бизнес-процессы ДО Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Небольшая доработка Документооборота 2.1 для возможности добавления виджета "Задачи от меня" в обработку Текущие дела.

25.09.2019    3483    Sergey_Borisovi4    3       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

[Механизм интерфейса] Часы 56

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом Практика программирования Разработка

Добавляем цифровые часы на форму, как бонус рассмотрим вариант и с аналоговыми.

26.08.2019    5107    rpgshnik    34       

Произвольная начальная страница через расширение (программно) 42

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Установка своей формы произвольному пользователю на начальную страницу.

14.08.2019    4756    nagaitseff    14       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Подходы, методы и инструменты UX/UI для разработки эффективных интерфейсов на 1С 34

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

Интерфейсам в 1С обычно уделяют мало внимания. Это в итоге снижает востребованность платформы, делает ее неконкурентной, лишает большой доли рынка. Как не потерять старых клиентов и привлекать новых с помощью интерфейсов, а главное – как сделать «правильный» интерфейс, рассказал участникам конференции Infostart Event 2018 Education управляющий партнер и основатель консалтинговой группы WiseAdvice Иван Тягунов.

07.08.2019    6400    IvanAT1981    14       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Пользовательские настройки системы компоновки данных 91

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Работа с интерфейсом

Работа с отчетами в пользовательском режиме, формы отчетов. Понятие пользовательских настроек в отчетах на СКД. Определение состава пользовательских настроек для разделов в целом и для отдельных элементов, для всего отчета и для отдельных группировок. Видимость функциональных опций в отчетах на СКД.

09.07.2019    11191    ids79    2       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Подсистема "Варианты отчетов". Используете ли Вы ее правильно? 230

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    22893    YPermitin    49       

Расшифровка отчета на СКД с детализацией по выбранному полю на основе БСП 93

Статья Программист Нет файла v8 v8::УФ v8::СКД 1cv8.cf Россия Бесплатно (free) Практика программирования Работа с интерфейсом Разработка

В данной статье рассмотрим механизм работы с расшифровкой отчета, созданного при помощи системы компоновки данных, в управляемом приложении. Показывать буду на примере реальной задачи. Условие: использовать имеющиеся в конфигурации механизмы БСП, с минимальными и "правильными" изменениями. Расшифровка должны быть двух видов на каждом поле: 1. Открывать ссылочный объект 2. Открывать новую форму с детализацией табличной части документа. Собственно ради второго пункта и писалась статья, в основном для себя, чтобы не забыть.

14.05.2019    10848    Viktor_Ermakov    6       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Свой макет оформления отчета 35

Статья Программист Нет файла v8 v8::СКД Россия Windows Бесплатно (free) Работа с интерфейсом

Пример создания и оформления и применения своего (пользовательского ) макета оформления для СКД.

24.04.2019    7060    olegpkc    5       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Динамический вывод таблицы значений на форму 36

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Вывести на форму таблицу значений, а потом на её место другую, третью, четвёртую? Не вопрос.

11.01.2019    7621    Vlad1917    30       

Прикладной пример переработки стандартной формы РМК - Розница 76

Статья Программист Нет файла v8 Розница УУ Кассовые операции Розничная торговля Бесплатно (free) Работа с интерфейсом

Простой пример, как с помощью программного изменения шрифтов элементов формы достичь наилучшего результата отображения на примере формы РМК.

04.10.2018    13392    asdfgcom    56