INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Кантер Андрей | Руководитель отдела, зам директора по работе с учебными заведениями | ООО НПФ "Форус"

«Новые кадры никто не завезет»

Мы попали в интересную ситуацию на рынке, когда число возможных проектов превысило число потенциальных исполнителей. Кадры нужны всем, но где же их взять? Нужны сегодняшние студенты, которые станут нашими сотрудниками завтра. В докладе я расскажу: 1. Как меняется подход работодателей к работе со студентами и почему уже нельзя позвонить в деканат и попросить "Дайте мне кого-нибудь умного"; 2. Как мы создали студенческое предприятие совместно с ВУЗом, в котором трудятся более 10 человек. Студенты получают реальных клиентов, опыт и стаж по специальности без отрыва от учебы. Но выгодна ли эта схема партнеру 1С? 3. Как набирать 15 человек в год на вакансии программистов и консультантов через ВУЗы. Крутых человек, которые через 3-4 года становятся ведущими. 4. Как не растерять студентов за время их обучения ("отвал" не более 50% - и почему это все равно выгоднее, чем искать на рынке); 5. Как построить для студентов систему мотивации, адаптации и обучения в компании. Нам есть с чем сравнивать: год назад мы потеряли почти всех, в этом году - почти всех удержали. Покажу в чем была разница; 6. Выжать максимум. Зачем писать со студентами дипломные проекты? Действительно ли они не могут сделать ничего серьезного? 7. Студенты кончились. Что дальше? Школьники!

Дата (год) прописью после цифрового значения

Программирование - Практика программирования

8
Бывают случаи, когда необходимо после цифрового значения "года" писать словом "год, лет, года". Предлагаю такое решение.

Допустим, вам необходимо написать, что срок гарантии для стиральной машины составляет 15 лет. Но! Может быть, у Вас разные стиральные машины, для которых установлен разный период гарантии. У одной может быть 15 лет, а у другой 3 года.

В случае, когда в печатную форму (или договор) Вам необходимо занести строчку "Гарантия на устройство [N]".

Чтобы не вставлять в печатную форму неказистое выражение "года\год\лет" - предлагаю функцию, которая делает это за Вас.  

 

Функция глГодПропись (ПеременнаяПрописи) Экспорт
    МассивПрописей = Новый Массив;
    МассивПрописей.Добавить("лет");  //если год оканчивается на 0,5,6,7,8,9
    МассивПрописей.Добавить("год");  //если год оканчивается на 1
    МассивПрописей.Добавить("года"); //если год оканчивается на 2,3,4
    Если Число(Прав(Строка(ПеременнаяПрописи),2)) = 11 ИЛИ Число(Прав(Строка(ПеременнаяПрописи),2)) = 12 ИЛИ Число(Прав(Строка(ПеременнаяПрописи),2)) = 13 ИЛИ Число(Прав(Строка(ПеременнаяПрописи),2)) = 14 Тогда
        Возврат Строка(ПеременнаяПрописи) + " " + МассивПрописей.Получить(0);
    Иначе
        Индекс = Число(Прав(Строка(ПеременнаяПрописи),1));
    КонецЕсли;
    Если Индекс = 0 ИЛИ Индекс = 5 ИЛИ Индекс = 6 ИЛИ Индекс = 7 ИЛИ Индекс = 8 ИЛИ Индекс = 9 Тогда
        Возврат Строка(ПеременнаяПрописи) + " " + МассивПрописей.Получить(0);
    ИначеЕсли Индекс = 1 Тогда 
        Возврат Строка(ПеременнаяПрописи) + " " + МассивПрописей.Получить(1);
    ИначеЕсли Индекс = 2 ИЛИ Индекс = 3 ИЛИ Индекс = 4  Тогда
        Возврат Строка(ПеременнаяПрописи) + " " + МассивПрописей.Получить(2);
    Иначе
        Возврат "ошибка передачи";
    КонецЕсли;
    //кдс    
КонецФункции


 

8

См. также

Комментарии
Сортировка: Древо
1. madonov 160 04.06.18 07:36 Сейчас в теме
Функция глГодПропись(ПеременнаяПрописи=0) Экспорт
   Возврат Нрег(ЧислоПрописью(ПеременнаяПрописи,,"год,года,лет,м , , , , , 0"));
КонецФункции
apostal86; mickey.1cx; +2 Ответить
2. madonov 160 04.06.18 07:47 Сейчас в теме
Вообще срок гарантии лучше писать в месяцах - универсальнее. Иначе алгоритм рано или поздно споткнется о стиральную машину с гарантией 1,5 года и потребуется обучить его выделению целых лет из числа месяцев и тд..

Функция глМесяцПропись(ПеременнаяПрописи=0) Экспорт
   Возврат Нрег(ЧислоПрописью(ПеременнаяПрописи,,"месяц,месяца,месяцев,м , , , , , 0"));
КонецФункции
mai@kopak.ru; nagimo; PVG_73; Danila-Master; PhoenixAOD; +5 Ответить
3. EvgeniuXP 06.06.18 22:16 Сейчас в теме
Я проще написал, нужно было выводить стаж в годах, месяцах и днях.
Оставьте свое сообщение