Автоматизация обмена между базами используя обработку "Универсальный обмен данными в формате XML"

Публикация № 86109

Разработка - Системная интеграция - Обмен через XML

В основу данной публикации положены найденные мною материалы по созданию обмена между двумя базами с использованием обработки "Универсальный обмен данными в формате XML". Но предлагается вариант автоматизации решения задачи, которая позволяет выполнять обмен неквалифицированным пользователям, либо по регламенту. Скажем, такой обмен применим, если вы не можете по ряду причин использовать РБД, либо у вас совсем разные конфигурации баз (случаи бывают разные, а хочется максимально настраиваемой гибкости).

Вначале, безусловно, воспользуемся конфигурацией "Конвертация данных", чтобы создать необходимые нам правила обмена (как - это отдельная тема).

Итак, собственно сама ВЫГРУЗКА: 

 Обработка = Обработки.УниверсальныйОбменДаннымиXML.Создать();
 
Обработка.РежимОбмена = "Выгрузка";
 
Обработка.ВыводВОкноСообщенийИнформационныхСообщений = Истина;

При необходимости можно задать период выгрузки (как пример):

 Обработка.ДатаНачала  = ТекущаяДата();
 
Обработка.ДатаОкончания   = ТекущаяДата();

 
Обработка.ИмяФайлаПравилОбмена = "D:\ПравилаОбменаДанными.xml";

 Источник = ЭтотОбъект.Ссылка;
 ИмяФайла = Строка(ТипЗнч(Источник)) + " " + Строка(Источник.Номер);
 
Обработка.ИмяФайлаОбмена = "D:\E\"+ Источник +".xml";
 

 Обработка.ЗагрузитьПравилаОбмена(); 

Основные параметры мы определили, теперь надо настроить отбор. Если в этом нет необходимости, то просто запускаете выгрузку:

Обработка.ВыполнитьВыгрузку();

Настройка ОТБОРА:
Тут надо обратить внимание на массив "ВременнаяТаблицаПравил.Строки[1]" и в частности на индекс массива строк,
1 - это ветка "Справочники". Ну и так далее по аналогии              

ВременнаяТаблицаПравил = Обработка.ТаблицаПравилВыгрузки.Скопировать();
 Для Каждого
СтрокаУровня2 Из ВременнаяТаблицаПравил.Строки[1].Строки Цикл
    
Наименование = СтрокаУровня2.Имя;
     Если
Наименование <> "ПеремещениеТоваров00001" Тогда
        
СтрокаУровня2.Включить = 0;
     КонецЕсли;
 КонецЦикла;
 Для Каждого
СтрокаУровня2 Из ВременнаяТаблицаПравил.Строки[2].Строки Цикл
    
Наименование = СтрокаУровня2.Имя;
     Если
Наименование <> "ПеремещениеТоваров00001" Тогда
        
СтрокаУровня2.Включить = 0;
     КонецЕсли;
 КонецЦикла;

Здесь вы определяете искомое правило выгрузки, которое нужно оставить включенным на определенной ветке (сами можете варьировать чего и сколько):

 Для Каждого СтрокаУровня2 Из ВременнаяТаблицаПравил.Строки[0].Строки Цикл
   
Наименование = СтрокаУровня2.Имя;
    Если
Наименование = "ПеремещениеТоваров00001" Тогда
       
СтрокаУровня2.Включить = 1;
    Иначе
       
СтрокаУровня2.Включить = 0;
    КонецЕсли;
 КонецЦикла;
 
Обработка.ТаблицаПравилВыгрузки = ВременнаяТаблицаПравил.Скопировать();

Теперь настраиваем ОТБОР, смысл которого в том, чтобы передать в нашу выгрузку ссылку на документ(ты) который(е) хотим выгрузить:

Для Каждого СтрокаУровня2 Из ВременнаяТаблицаПравил.Строки[0].Строки Цикл
 
Наименование = СтрокаУровня2.Имя;
  Если
Наименование = "ПеремещениеТоваров00001" Тогда
 
ТекущееПВД = СтрокаУровня2;

    
Построитель = Новый ПостроительОтчета;
     Если
ТекущееПВД.ИмяОбъектаДляЗапроса <> Неопределено Тогда

        
Построитель.Текст =
        
"ВЫБРАТЬ Разрешенные _.* ИЗ " + ТекущееПВД.ИмяОбъектаДляЗапроса + " КАК _
          |
          |
          |{ГДЕ _.Ссылка.* КАК "
+ СтрЗаменить(ТекущееПВД.ИмяОбъектаДляЗапроса, ".", "_") + "}";
     КонецЕсли;

    
Отбор = Построитель.Отбор;

     Если
Отбор.Найти("Документ_ПеремещениеТоваров") = Неопределено Тогда
       
Отбор.Добавить("Документ_ПеремещениеТоваров");
     КонецЕсли;

    
Массив = Новый Массив;
    
Массив.Добавить(Тип("ДокументСсылка.ПеремещениеТоваров"));
    
ОписаниеТиповС = Новый ОписаниеТипов(Массив, , );

    
Отбор["Документ_ПеремещениеТоваров"].Использование = Истина;
    
Отбор["Документ_ПеремещениеТоваров"].Значение = ЭтотОбъект.Ссылка;
    
Отбор["Документ_ПеремещениеТоваров"].ВидСравнения = ВидСравнения.Равно;

    
ДоступностьПостроителя = Истина;
     Если
Построитель.Отбор.Количество() > 0 Тогда
         
ТекущееПВД.НастройкиПостроителя = Построитель.ПолучитьНастройки();
        
ТекущееПВД.ИспользоватьОтбор    = ИСТИНА;
     КонецЕсли;
  КонецЕсли;
КонецЦикла;

Обработка.ТаблицаПравилВыгрузки = ВременнаяТаблицаПравил.Скопировать();

Ну и, собственно, запускаем саму выгрузку и получаем файл для загрузки:

  Обработка.АрхивироватьФайл = Истина;
  Обработка.ВыполнитьВыгрузку();

Далее процесс загрузки:
Он довольно прост

МассивФайлов = НайтиФайлы("D:\E\", "*.zip");
Для Каждого
Стм Из МассивФайлов Цикл
ТекстВопроса = "Загрузить - " + Стм.ПолноеИмя;
Ответ = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет,, КодВозвратаДиалога.Да);
    Если
Ответ = КодВозвратаДиалога.Да Тогда
       
Обработка  = Обработки.УниверсальныйОбменДаннымиXML.Создать();
       
Обработка.ИмяФайлаОбмена = Стм.ПолноеИмя;
       
Обработка.РежимОбмена    = "Загрузка";
       
Обработка.ЗаписыватьРегистрыНаборамиЗаписей = Истина;
       
Обработка.ЗаписыватьВИнформационнуюБазуТолькоИзмененныеОбъекты = Истина;
       
Обработка.ЗагружатьДанныеВРежимеОбмена = Истина;
       
Обработка.ВыполнитьЗагрузку();
       
УдалитьФайлы(Стм.ПолноеИмя);
    КонецЕсли;
КонецЦикла;

Расширение .zip для файлов обмена пусть вас не смущает, обработка самостоятельно упакует .xml файл в архив:

 Обработка.АрхивироватьФайл = Истина;

И также самостоятельно уже без дополнительных указаний распакует и загрузит. Это существенно уменьшает размеры файла обмена.

Вот примерно так можно поступить.

Продолжение темы :

//infostart.ru/public/87057/

Скачать файлы

Наименование Файл Версия Размер
Вариант статьи для скачивания

.doc 44,00Kb
300
.doc 44,00Kb 300 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. samamoiloff 859 12.06.11 19:23 Сейчас в теме
Отбор["Документ_ПеремещениеТоваров"].Значение = ЭтотОбъект.Ссылка;

Пример выгрузки из документа получается?
2. wiranata 274 13.06.11 20:31 Сейчас в теме
Завтра выложу пример (обработку).

(1)Не совсем понял в чем вопрос, если вы имеете ввиду вигрузку только табличной части документа (скажем товары) в другой документ либо такой же но с обработкой этих данных - то это надо описывать в обработчиках событий в Конвертации данных (когда будите писать правила обмена). Я только показал как сделать некий регламент обмена а не запрограммировать его логику (это отдельная тема).
4. plevakin 20.06.11 16:32 Сейчас в теме
(1)Не совсем понял в чем вопрос

Насколько я понял данный пример в отборе отбирает только один документ, что на практике бывает редко. Попробовал изменить строки на
Отбор["Документ_РеализацияТоваровУслуг"].ВидСравнения = ВидСравнения.ВСписке;
Отбор["Документ_РеализацияТоваровУслуг"].Значение = Массив;

где Массив это мой программно создаваемый список значений заполненный ссылками на документ. Ничего не получилось.
Завтра выложу пример (обработку).

Можно в качестве примера указать выгрузку списка документов. Думаю формирование списка каждый может сделать под себя, и по дате и по контрагенту и по чему угодно.
5. ARL 302 24.06.11 13:38 Сейчас в теме
(4) Отбор["Документ_РеализацияТоваровУслуг"].Значение = Массив.Скопировать();
где Массив имеет тип СписокЗначений.
3. ARL 302 16.06.11 18:06 Сейчас в теме
Информация удобная, автору благодарность.
Мне потребовалось выгружать по плану обмена. Поэтому немного добавлю:
НашУзел = ПланыОбмена.ХХХХ.НайтиПоКоду("2");
УстановитьУзелОбменаУСтрокДерева(Обработка.ТаблицаПравилВыгрузки.Строки, НашУзел);
Процедуру УстановитьУзелОбменаУСтрокДерева просто копируем из формы обработки.
DenDSMG; user611975_na__svyazi; AlexeyK1; antonio_i; tatarenko.an; +5 Ответить
6. plevakin 24.06.11 13:53 Сейчас в теме
 Отбор = Построитель.Отбор;

     Если Отбор.Найти("Документ_РеализацияТоваровУслуг") = Неопределено Тогда
        Отбор.Добавить("Документ_РеализацияТоваровУслуг");
     КонецЕсли;

     Массив = Новый СписокЗначений;
     Выборка = Документы.РеализацияТоваровУслуг.Выбрать(начПериода,КонПериода);
	 Пока Выборка.Следующий() Цикл
		Массив.Добавить(Выборка.Ссылка);	 
	 КонецЦикла;
	 
     Отбор["Документ_РеализацияТоваровУслуг"].Использование = Истина;
     Отбор["Документ_РеализацияТоваровУслуг"].ВидСравнения = ВидСравнения.ВСписке;
     Отбор["Документ_РеализацияТоваровУслуг"].Значение = Массив.Скопировать();
     
Показать

После этих строк смотрю в отладчике отбор и вижу



Выгружено объектов 0.
oleganatolievich; +1 Ответить
7. wiranata 274 24.06.11 18:47 Сейчас в теме
(6) Как я понял проблема настроить отбор в варианте "ВСписке" программно... обработку не буду ради это писать... но где то так:

Структура = Новый СписокЗначений;

Запрос = Новый Запрос();
Запрос.Текст =
"ВЫБРАТЬ
| ПеремещениеТоваров.Ссылка,
| ПеремещениеТоваров.Дата
|ИЗ
| Документ.ПеремещениеТоваров КАК ПеремещениеТоваров
|ГДЕ
| ПеремещениеТоваров.Дата МЕЖДУ &датаНачала И &датаКонца";

Запрос.УстановитьПараметр("ДатаНачала", НачалоМесяца(ТекущаяДата()));
Запрос.УстановитьПараметр("ДатаКонца", ТекущаяДата());
Структура = Запрос.Выполнить().Выгрузить();


Отбор["Документ_ПеремещениеТоваров"].Использование = Истина;
Отбор["Документ_ПеремещениеТоваров"].ВидСравнения = ВидСравнения.ВСписке;//Равно;
Отбор["Документ_ПеремещениеТоваров"].Значение.ЗагрузитьЗначения(Структура.ВыгрузитьКолонку("Ссылка"));//Источник;


Вот так список значений заполняется, я детально не встраивал в обработку но вызвав форму обработки видел что список значений заполнился ссылками, по ошибке ничего не вывалилось.
AlexeyK1; esenins; +2 Ответить
31. oleganatolievich 13.07.16 15:32 Сейчас в теме
(7) еще дело может быть в отсутствии галочки у корневых разделов ПВД (Справочники, Документы), при установленной галке в строках этих разделов.
8. mirkomp 22.12.11 00:26 Сейчас в теме
Данная методика будет работать с выгрузкой из базы в которой две организации (ИП и ООО)? конф УТ ред 11 (управляемое приложение)
10. wiranata 274 23.12.11 22:02 Сейчас в теме
(8) Данная методика будет работать не зависимо от форм отганизационно-правовой формы. Но на версии УТ 11 я ее не тестировал за неимением (Конфигурации где будет работать написаны в заголовке).
9. xaker1C 22.12.11 04:51 Сейчас в теме
спасибо очень помогло правда пришлось с легка модифицировать
11. Paul_Nevada 05.01.12 23:41 Сейчас в теме
Привет! Спасибо за тему - очень актуальная для меня оказалась. Такой вопрос - можно ли этот "кусок" развить до полуавтоматического общения двух идентичных БД via e-mail?
12. wiranata 274 07.01.12 13:39 Сейчас в теме
(11) Привет! количества вариантов (автоматического, например как у меня по регламенту... много, надо будет дописать схему реализации) ограниченно лишь функционалом самой 1С. Там есть возможность авто пересылки сообщений и их автоматического приема и обработки НО! данная обработка "вытаскивает" весь объект вместе с подчиненными ссылками и в итоге мы получаем файл где то на 60 метров (и это в архиве!).
Можно правилами обмена пробовать ограничивать объем выгрузки но тогда не факт что мы в пакете обмена будем иметь весь объем необходимой инфы.
По этому почта возможна но... как неполноценный по эффективности вариант когда имеет дело с файлом сформированным описанной обработкой... но попытка не пытка, это лишь мое мнение.
13. Maks888 1 01.02.12 09:42 Сейчас в теме
Хочу поблагодарить автора! Очень и очень замечательную вещь выложили! Буквально меня спасли =) очень сократил время на разработку! + 10 !!!
16. нинас 03.04.12 09:22 Сейчас в теме
17. binex 271 28.05.12 15:24 Сейчас в теме
Я не пойму зачем нужно копировать ТаблицуПравилВыгрузки? Почему бы сразу в неё изменения не вносить?
18. wiranata 274 29.05.12 10:32 Сейчас в теме
(17) Публикация не подвергалась оптимизации если вам так удобнее то почему нет.. тут лишь изложена одна из идей обмена а не обработки данных в процессе этого обмена.
19. binex 271 29.05.12 10:36 Сейчас в теме
Спасибо! Статья помогла.
20. galyausik1 11.07.12 16:22 Сейчас в теме
Спасибо! Очень полезная статейка
21. alon 171 31.07.12 17:08 Сейчас в теме

Обработка.ВыполнитьЗагрузку();
УдалитьФайлы(Стм.ПолноеИмя);


У вас не возникает ошибки совместного доступа к файлу в последней строке?
22. wiranata 274 31.07.12 20:33 Сейчас в теме
(21)Нет не возникает, а должно?
23. uri1978 130 16.10.13 12:27 Сейчас в теме
Спасибо за статью. Подтолкнули на мысль, использовал в работе. Очень пригодилось.
24. Al777 04.12.14 10:22 Сейчас в теме
Спасибо за статью! Как раз возникла необходимость постоянной перегрузки документов из одной базы в другую через универсальный отчет.
25. dyak84 04.01.15 09:55 Сейчас в теме
Спасибо буду пробовать, интересная статья
26. Steelvan 52 05.02.15 12:53 Сейчас в теме
...применим если вы не можите...

*можЕте
27. orfos 85 14.02.15 15:47 Сейчас в теме
А как настроить отбор только по справочникам (у)??
28. lion11 143 24.08.15 16:36 Сейчас в теме
Можете подсказать, как сделать то же самое, но только в УФ? Есть внешняя обработка на УФ с кнопкой выгрузить, по нажатию на которую нужно выгрузить по правилу обмена используя обработку УниверсальныйОбменДаннымиXML на УФ, например, в БП3.
Не актуально, разобрался.
29. nef744 02.09.15 18:54 Сейчас в теме
30. Гость 02.03.16 14:38
Всё работает, но возникает проблема с добавлением отбора на регистр сведений, у кого нибудь есть пример кода?
32. AlekSo 13 07.10.16 10:46 Сейчас в теме
(30) Гость,
Вряд ли кто нибудь теперь уже ответит.
Тоже бьюсь над этим - как отобрать независимые регистры сведений?
В частности нужно отобрать по периоду или по дате ключевого документа.
33. AlekSo 13 11.10.16 08:37 Сейчас в теме
Если кому ещё интересно.

В самой обработке универсального обмена в модуле формы есть процедура НастроитьПостроитель().
Оттуда можно выдернуть нужные строки.

коротко вот пример для независимого периодического регистра сведений:

Функция УстановитьОтборПериодическимРС(ВнешняяОбработкаОбмена, ИмяРегистра)
	СтрокаГруппыДокументов = ВнешняяОбработкаОбмена.ТаблицаПравилВыгрузки.Строки.Найти("РегистрыСведений");
	СтрокаПВД = СтрокаГруппыДокументов.Строки.Найти(ИмяРегистра);
	
        ИмяПВД = СтрокаПВД.ИмяОбъектаДляЗапросаРегистра;

	Построитель.Текст = "ВЫБРАТЬ Разрешенные
	 |   *,
	 |	NULL КАК Активность,
	 |	NULL КАК Регистратор,
	 |  NULL КАК НомерСтроки       
	 |
	 |ИЗ "+ИмяПВД;
	 
	Построитель.ЗаполнитьНастройки();
	
	ЭлемОтбора = Построитель.Отбор.Добавить("Период");
	Если ЭлемОтбора = Неопределено Тогда
		Сообщить("Не удалось настроить ОТбор по документам");
	КонецЕсли;
	
	ЭлемОтбора.ВидСравнения  = ВидСравнения.ИнтервалВключаяГраницы;
	ЭлемОтбора.ЗначениеС     = НачПериода;
	ЭлемОтбора.ЗначениеПо    = КонПериода;
	ЭлемОтбора.Использование = Истина;
	
	СтрокаПВД.НастройкиПостроителя = Построитель.ПолучитьНастройки();
	СтрокаПВД.ИспользоватьОтбор    = ИСТИНА;
	
	Возврат Истина;
КонецФункции
Показать

Здесь важно брать именно ИмяОбъектаДляЗапросаРегистра.
36. Butuff 15.04.17 12:45 Сейчас в теме
(33) а есть пример выгрузки только измененных записей регистра сведений? (не периодического и без регистратора)
34. wau8824ru 26.03.17 20:54 Сейчас в теме
Для Каждого СтрокаУровня1 Из ТаблицаПравилВыгрузки.Строки Цикл
	Для Каждого СтрокаУровня2 Из ТаблицаПравилВыгрузки.Строки[0].Строки Цикл
		Наименование = 	СтрокаУровня2.Имя;
		Если Наименование = "ВозвратТоваровОтПокупателя" Тогда
			Построитель = Новый ПостроительОтчета;
			Если СтрокаУровня2.ИмяОбъектаДляЗапроса <> Неопределено Тогда
			Построитель.Текст =
			"ВЫБРАТЬ Разрешенные _.* ИЗ " + СтрокаУровня2.ИмяОбъектаДляЗапроса + " КАК _
			|{ГДЕ _.Ссылка.* КАК " + СтрЗаменить(СтрокаУровня2.ИмяОбъектаДляЗапроса, ".", "_") + "}";
			КонецЕсли;
			Отбор = Построитель.Отбор;
			Если Отбор.Найти("Документ_ВозвратТоваровОтПокупателя") = Неопределено Тогда
				Отбор.Добавить("Документ_ВозвратТоваровОтПокупателя");
			КонецЕсли;
			СписокДокументов = Новый СписокЗначений;
			Отбор["Документ_ВозвратТоваровОтПокупателя"].Использование	= Истина;
			Отбор["Документ_ВозвратТоваровОтПокупателя"].ВидСравнения	= ВидСравнения.ВСписке;
			Отбор["Документ_ВозвратТоваровОтПокупателя"].Значение		= СписокДокументов;
			ДоступностьПостроителя = Истина;
			Если Построитель.Отбор.Количество() > 0 Тогда
				СтрокаУровня2.НастройкиПостроителя = Построитель.ПолучитьНастройки();
				СтрокаУровня2.ИспользоватьОтбор    = Ложь;
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
КонецЦикла;
Показать

Работает, Спасибо! А нет возможности добавить реквизит в отбор?
Примерно следущее?
Отбор["Документ_ВозвратТоваровОтПокупателя.Организация"].Использование	= Истина;
Отбор["Документ_ВозвратТоваровОтПокупателя.Организация"].ВидСравнения	= ВидСравнения.ВСписке;
Отбор["Документ_ВозвратТоваровОтПокупателя.Организация"].Значение		= ПланыОбмена.ОбменУправлениеТорговлейБухгалтерияКОРП.НайтиПоКоду("002").Организации.ВыгрузитьКолонку("Организация");
35. wau8824ru 27.03.17 07:57 Сейчас в теме
Если Отбор.Найти("Документ_ВозвратТоваровОтПокупателя.Организация") = Неопределено Тогда
   Отбор.Добавить("Документ_ВозвратТоваровОтПокупателя.Организация");
КонецЕсли;

Отбор добавляется но при
Отбор["Документ_ВозвратТоваровОтПокупателя.Организация"].Использование    = Истина;

выводится ошибка
37. wau8824ru 24.10.17 08:58 Сейчас в теме
Для Каждого СтрокаУровня1 Из ТаблицаПравилВыгрузки.Строки Цикл
		Для Каждого СтрокаУровня2 Из ТаблицаПравилВыгрузки.Строки[0].Строки Цикл
			Наименование = 	СтрокаУровня2.Имя;
			Если Наименование = "ВозвратТоваровОтПокупателя" Тогда
				Построитель = Новый ПостроительОтчета;
				Если СтрокаУровня2.ИмяОбъектаДляЗапроса <> Неопределено Тогда
					Построитель.Текст =
					"ВЫБРАТЬ Разрешенные _.* ИЗ " + СтрокаУровня2.ИмяОбъектаДляЗапроса + " КАК _
					|{ГДЕ _.Ссылка.* КАК " + СтрЗаменить(СтрокаУровня2.ИмяОбъектаДляЗапроса, ".", "_") + "}";
				КонецЕсли;
				Отбор = Построитель.Отбор;
				Если Отбор.Найти("Документ_ВозвратТоваровОтПокупателя") = Неопределено Тогда
					Отбор.Добавить("Документ_ВозвратТоваровОтПокупателя");
					Отбор.Добавить("Документ_ВозвратТоваровОтПокупателя.Организация", "ОсновнаяОрганизация");
				КонецЕсли;
				СписокДокументов = Новый СписокЗначений;
				Отбор["Документ_ВозвратТоваровОтПокупателя"].Использование	= Истина;
				Отбор["Документ_ВозвратТоваровОтПокупателя"].ВидСравнения	= ВидСравнения.ВСписке;
				Отбор["Документ_ВозвратТоваровОтПокупателя"].Значение		= СписокДокументов;
				ОсновнаяОрганизация = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ПараметрыСеанса.ТекущийПользователь, "ОсновнаяОрганизация");;
				Отбор["ОсновнаяОрганизация"].Использование	= Истина;
				Отбор["ОсновнаяОрганизация"].ВидСравнения	= ВидСравнения.Равно;
				Отбор["ОсновнаяОрганизация"].Значение		= РеглОрганизация;
				ДоступностьПостроителя = Истина;
				Если Построитель.Отбор.Количество() > 0 Тогда
					СтрокаУровня2.НастройкиПостроителя = Построитель.ПолучитьНастройки();
					СтрокаУровня2.ИспользоватьОтбор    = Истина;
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
Показать

Вот так работает, мож пригодится кому...
43. softmaker 1 26.01.21 17:04 Сейчас в теме
(37) Главное, чтобы СписокДокументов состоял из ссылочных типов, а не из типов ЭлементСпискаЗначений.
38. PhoenixAOD 60 14.06.18 10:21 Сейчас в теме
Доброго времени суток. Спасибо за статью, но у меня возникла проблема.
Если Отбор.Найти("Документ_РеализацияТоваровУслуг") = Неопределено Тогда
				Отбор.Добавить("Документ_РеализацияТоваровУслуг");
			КонецЕсли;
			
			Структура = Новый СписокЗначений; 

			Запрос = Новый Запрос;	
			Запрос.Текст = 
			"ВЫБРАТЬ
			|	РеализацияТоваровУслугИзменения.Ссылка КАК Ссылка
			|ИЗ
			|	Документ.РеализацияТоваровУслуг.Изменения КАК РеализацияТоваровУслугИзменения
			|ГДЕ
			|	РеализацияТоваровУслугИзменения.Узел = &Узел
			|	И РеализацияТоваровУслугИзменения.Ссылка.Менеджер В(&СпАвтор)
			|	И РеализацияТоваровУслугИзменения.Ссылка.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания";


			Запрос.УстановитьПараметр("Узел", ПланыОбмена.ОбменСКА2.НайтиПоКоду("77777")); 
			Запрос.УстановитьПараметр("СпАвтор", СпАвтор);
			Запрос.УстановитьПараметр("ДатаНачала", НачалоДня(Объект.ДатаНачала));
			Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(Объект.ДатаОкончания));
			Структура = Запрос.Выполнить().Выгрузить(); 


			Отбор["Документ_РеализацияТоваровУслуг"].Использование = Истина;	
			Отбор["Документ_РеализацияТоваровУслуг"].ВидСравнения = ВидСравнения.ВСписке; 
			Отбор["Документ_РеализацияТоваровУслуг"].Значение.ЗагрузитьЗначения(Структура.ВыгрузитьКолонку("Ссылка"));
Показать

Сделал вот так, но почему то попадют все документы "СпАвтор" почему то не отрабатывается условие. Не подскажете в чем дело?
39. user639784_kuz_val87 14.06.18 15:34 Сейчас в теме
Добрый день! может кто-нибудь выложить код полностью рабочей обработки? у меня почему-то только справочники выгружаются, документы никак не могу выгрузить, как ни пытался... буду очень благодарен)
40. user639784_kuz_val87 14.06.18 15:38 Сейчас в теме
#Если Сервер Тогда
Обработка = Обработки.УниверсальныйОбменДаннымиXML.Создать();
Обработка.РежимОбмена = "Выгрузка";
Обработка.ВыводВОкноСообщенийИнформационныхСообщений = Ложь;
Обработка.ИмяФайлаПравилОбмена = "\\192.168.16.137\shared\ПравилаОбменаДанными4.xml";
Обработка.ДатаНачала = ТекущаяДата()- 60*60*24*5 ;
Обработка.ДатаОкончания = КонецДня(ТекущаяДата());
Обработка.ЗагрузитьПравилаОбмена();

ВременнаяТаблицаПравил = Обработка.ТаблицаПравилВыгрузки.Скопировать();
Для Каждого СтрокаУровня2 Из ВременнаяТаблицаПравил.Строки[0].Строки Цикл
	Наименование = СтрокаУровня2.Имя;
	Сообщить(Наименование);
	Если Наименование = "Номенклатура" Тогда
		СтрокаУровня2.Включить = 0;
		Сообщить(СтрокаУровня2.Включить);
	ИначеЕсли Наименование = "Контрагенты" Тогда
		СтрокаУровня2.Включить = 1;
		Сообщить(СтрокаУровня2.Включить);
	Иначе
		СтрокаУровня2.Включить = 0;
		Сообщить(СтрокаУровня2.Включить);
	КонецЕсли;
КонецЦикла;
Сообщить("Цикл2");
 Для Каждого СтрокаУровня2 Из ВременнаяТаблицаПравил.Строки[1].Строки Цикл
     Наименование = СтрокаУровня2.Имя;
     Сообщить(Наименование);
     Если Наименование = "ПоступлениеТоваровУслуг" Тогда
         СтрокаУровня2.Включить = 1;
    	 Сообщить(СтрокаУровня2.Включить);
     Иначе
    	СтрокаУровня2.Включить = 0;
    	Сообщить(СтрокаУровня2.Включить);
     КонецЕсли;
 КонецЦикла;
 
 Для Каждого СтрокаУровня2 Из ВременнаяТаблицаПравил.Строки[1].Строки Цикл
  Наименование = СтрокаУровня2.Имя;
  Если Наименование = "ПоступлениеТоваровУслуг" Тогда
	  ТекущееПВД = СтрокаУровня2;

     Построитель = Новый ПостроительОтчета;
     Если ТекущееПВД.ИмяОбъектаДляЗапроса <> Неопределено Тогда

         Построитель.Текст =
         "ВЫБРАТЬ Разрешенные _.* ИЗ " + ТекущееПВД.ИмяОбъектаДляЗапроса + " КАК _
          |
          |
          |{ГДЕ _.Ссылка.* КАК " + СтрЗаменить(ТекущееПВД.ИмяОбъектаДляЗапроса, ".", "_") + "}";
     КонецЕсли;

     Отбор = Построитель.Отбор;

     Если Отбор.Найти("Документ_ПоступлениеТоваровУслуг") = Неопределено Тогда
        Отбор.Добавить("Документ_ПоступлениеТоваровУслуг");
     КонецЕсли;
	 Структура = Новый СписокЗначений; 

            Запрос = Новый Запрос;    
            Запрос.Текст = 
            "ВЫБРАТЬ
            |ПоступлениеТоваровУслуг.Ссылка КАК Ссылка
            |ИЗ
            |Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
            |ГДЕ
            |    ПоступлениеТоваровУслуг.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания";


            Запрос.УстановитьПараметр("ДатаНачала", НачалоДня(Обработка.ДатаНачала));
            Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(Обработка.ДатаОкончания));
            Структура = Запрос.Выполнить().Выгрузить(); 


            Отбор["Документ_ПоступлениеТоваровУслуг"].Использование = Истина;    
            Отбор["Документ_ПоступлениеТоваровУслуг"].ВидСравнения = ВидСравнения.ВСписке; 
            Отбор["Документ_ПоступлениеТоваровУслуг"].Значение.ЗагрузитьЗначения(Структура.ВыгрузитьКолонку("Ссылка"));

	 ДоступностьПостроителя = Истина;
	 Если Построитель.Отбор.Количество() > 0 Тогда
	     ТекущееПВД.НастройкиПостроителя = Построитель.ПолучитьНастройки();
	     ТекущееПВД.ИспользоватьОтбор    = ИСТИНА;
	 КонецЕсли;
  КонецЕсли;
КонецЦикла;

Обработка.ТаблицаПравилВыгрузки = ВременнаяТаблицаПравил.Скопировать();
Обработка.ИмяФайлаОбмена = "\\192.168.16.137\shared\ВыгрузкаДА.xml"; 

Обработка.ВыполнитьВыгрузку();
#КонецЕсли
Показать


что у меня не так?
41. arz 23.07.18 11:37 Сейчас в теме
Доброго дня. В серверном варианте на линуксе ( скорее всего на виндоус так же будет) загрузка файла блокировала файл обмена. Помогло удаление файла, причем только функцией из самой обработки.

Обработка.ВыполнитьЗагрузку();
Обработка.УдалитьВременныеФайлы(Путь +"выгрузка.xml");
42. чингачгук 16 29.09.20 10:14 Сейчас в теме
Может что-то за это время поменялось в универсальной выгрузке, но ни как не взлетало, пока не поменял следующие параметры:
Правила я вытащил из обрабоки в следующей публикации Обмен БП-УНФ (до этого руками запускал, сейчас решил в регламент засунуть)
А так статья шикарная, спасибо!



Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды) Экспорт	
	    
	Обработка = Обработки.УниверсальныйОбменДаннымиXML.Создать();
	Обработка.РежимОбмена = "Выгрузка";
	Обработка.ВыводВОкноСообщенийИнформационныхСообщений = Истина;
	
	Обработка.ДатаНачала  = НачалоДня(ТекущаяДата()-60*60*24*4);
	Обработка.ДатаОкончания   = КонецДня(ТекущаяДата());
	
	Обработка.ИмяФайлаПравилОбмена = "C:\install\PR_BP_UNF202009.xml";
	Обработка.ВыводВПротоколИнформационныхСообщений = Истина;
	Обработка.ИмяФайлаПротоколаОбмена = "c:\install\LOG.txt";
	ИмяФайла = "C:\install\tt.xml";
	Обработка.ИмяФайлаОбмена = "C:\install\tt.xml"; 
	
	Обработка.ЗагрузитьПравилаОбмена(); 
	
	Обработка.ИнициализироватьПервоначальныеЗначенияПараметров();
	ВременнаяТаблицаПравил = Обработка.ТаблицаПравилВыгрузки.Скопировать();
	
	Для Каждого СтрокаУровня2 Из ВременнаяТаблицаПравил.Строки Цикл
		Наименование = СтрокаУровня2.Имя;
		Если Наименование = "Документы" Тогда
			СтрокаУровня2.Включить = 1;
		ИначеЕсли Наименование = "СчетНаОплатуПокупателю" Тогда
			СтрокаУровня2.Включить = 1;
		ИначеЕсли Наименование = "Счет на оплату" Тогда
			СтрокаУровня2.Включить = 1;
		Иначе
			СтрокаУровня2.Включить = 0;
		КонецЕсли;
		Для Каждого СтрокаУровня1 Из СтрокаУровня2.Строки Цикл
			Наименование = СтрокаУровня1.Имя;
			Если Наименование = "Документы" Тогда
				СтрокаУровня1.Включить = 1;
			ИначеЕсли Наименование = "СчетНаОплатуПокупателю" Тогда
				СтрокаУровня1.Включить = 1;
			ИначеЕсли Наименование = "Счет на оплату" Тогда
				СтрокаУровня1.Включить = 1;
			Иначе
				СтрокаУровня1.Включить = 0;
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	
	Обработка.Параметры.ДатаНачала 		= НачалоДня(Обработка.ДатаНачала);
	Обработка.Параметры.ДатаОкончания 	= КонецДня(Обработка.ДатаОкончания);   	
	Обработка.Параметры.ВыгружатьПомеченныеНаУдалениеДокументы = Истина;
	
	ИзменитьДеревоПравилВыгрузки(Обработка.ТаблицаПравилВыгрузки.Строки, ВременнаяТаблицаПравил.Строки);
	Обработка.ТаблицаПравилВыгрузки = ВременнаяТаблицаПравил.Скопировать();
	Попытка
		Обработка.ВыполнитьВыгрузку();
	Исключение
	КонецПопытки;
	
	
КонецПроцедуры	



&НаСервере     
Процедура ИзменитьДеревоПравилВыгрузки(СтрокиИсходногоДерева, СтрокиЗаменяемогоДерева)
	
	КолонкаВключить = СтрокиЗаменяемогоДерева.ВыгрузитьКолонку("Включить");
	СтрокиИсходногоДерева.ЗагрузитьКолонку(КолонкаВключить, "Включить");
	
	Для Каждого СтрокаИсходногоДерева Из СтрокиИсходногоДерева Цикл
		
		ИндексСтроки = СтрокиИсходногоДерева.Индекс(СтрокаИсходногоДерева);
		СтрокаИзменяемогоДерева = СтрокиЗаменяемогоДерева.Получить(ИндексСтроки);
		
		ИзменитьДеревоПравилВыгрузки(СтрокаИсходногоДерева.Строки, СтрокаИзменяемогоДерева.Строки);
		
	КонецЦикла;
	
КонецПроцедуры
Показать




Загрузка кстати заработала сразу без проблем
Отборы из статьи тоже нормально прикручиваются.
Еще добавил регистр, в который пишу изменения по нужным объектам, и уже из этого регистра по типу объектов делаю выборку для выгрузки. Работает быстро.
Оставьте свое сообщение

См. также

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1 Промо

Зарплата Бухгалтерский учет Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    32767    149    utrumar    3    

Внешняя форма РСВ (в ред. приказа ФНС России от 15.10.2020 № ЕД-7-11/751@). Для УПП 1.3

Налоговые Регламентированная отчетность Обмен через XML v8 УПП1 Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Внешняя форма РСВ в ред. приказа ФНС России от 15.10.2020 № ЕД-7-11/751@, с возможностью автозаполнения и выгрузки электронного представления в XML-формате версии 5.02 (версия внешнего отчета: 1.3.152.2). Возможна работа в релизах УПП до 1.3.152.2. Работоспособность проверена на релизах 1.3.151.1, 1.3.144.1.

1 стартмани

26.01.2021    1464    10    alexbur    0    

Заявление о предоставлении субсидии (КНД 1150102, постановление Правительства РФ от 24 апреля 2020 года №576) в формате ФНС (XML)

Налоговые Обмен через XML v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Формирование заявления о предоставлении субсидии КНД 1150102 (МРОТ на каждого работника) в формате XML согласно формату, рекомендованному письмом ФНС от 27 апреля 2020 г. N БС-4-11/7080@. Проверено на конфигурации Бухгалтерия предприятия 3.0.76.73.

1 стартмани

05.05.2020    13220    5    period    0    

Формирование транспортной накладной для ЭДО для БП 3

Печатные формы документов Документооборот и делопроизводство Оптовая торговля Обмен через XML v8 1cv8.cf БУ Абонемент ($m)

Обработка для создания файла XML транспортной накладной (далее ТН) для отправки в электронный документооборот (ЭДО). Опробовал Synerdocs, ошибок нет. Для конфигураций БП 3.0 последних версий.

2 стартмани

14.01.2020    2173    1    program345    1    

Секреты профессионалов: поддержка и сопровождение правил обмена — сложное становится простым! Промо

Обмен через XML v8 КД Абонемент ($m)

В вышедший недавно релиз 2.1.7.1 конфигурации "1С:Конвертация данных" разработчики включили интересную обработку - «Сравнение и объединение правил обмена». Хотите узнать, какие новые возможности она может Вам предложить?

1 стартмани

12.03.2013    71070    285    tomvlad    110    

Гособоронзаказ: доработка учета в УПП и обмен с БП 3.0

Перенос данных из 1C8 в 1C8 Бухгалтерия v8 УПП1 Государственные, бюджетные структуры Россия БУ Абонемент ($m)

Доработка конфигурации 1С: Управление производственным предприятием, редакция 1.3 для ведения учета по ГОЗ. Разработка правил обмена: 1С: Бухгалтерия предприятия КОРП редакция 3.0. -> 1С: Управление производственным предприятием редакция 1.3 с учетом доработок конфигураций под ГОЗ.

1 стартмани

26.09.2019    6263    6    LanGrid    0    

Заявление на получение карты Сбербанка (новый формат)

Обмен с банком Обмен через XML Банковские операции Зарплата Банковские операции Зарплата v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Обработка формирует заявление, доверенность и xml файл для загрузки в клиент-банк.

1 стартмани

30.05.2019    3816    3    ejka    0    

Вывод в табличный документ из xml запросов, полученных из ИФНС

Обмен через XML Зарплата Зарплата v8 1cv8.cf Россия БУ НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Простая обработка позволяет вывести ответ на запрос из ИФНС в формате xml в табличный документ.

1 стартмани

10.04.2019    3447    2    maksbl    0    

Программное обращение к обработке "Универсальный обмен данными в формате xml" Промо

Перенос данных из 1C8 в 1C8 Обмен через XML v8 1cv8.cf Абонемент ($m)

В статье рассказывается о быстром написании обработок для выгрузки и загрузки данных, используя методы обработки "Универсальный обмен данными в формате xml".

1 стартмани

09.10.2012    49610    276    Oleg_nsk    35    

Автоматическое обновление прочих форм статистической отчетности

Регламентированная отчетность Обмен через XML v8::БУ БП2.0 Россия БУ Абонемент ($m)

Обработка для автоматической загрузки XML-шаблонов отчетов с интернет-портала Росстата.

1 стартмани

08.04.2019    5254    2    ИТ-Терминал    2    

Заявление-расчет в ФСС из УПП для Украины в XML

Зарплата Обмен через XML Бухгалтерские Зарплата v8 УПП1 Украина БУ Абонемент ($m)

Выгрузка документа "Заявление-расчет в ФСС" в XML для последующей загрузки в MEDOC.

2 стартмани

28.02.2019    2686    5    Vlad93Malahov    6    

Список предпенсионеров с выгрузкой в xml

Управление персоналом (HRM) Обмен через XML Бухгалтерские Специальные Управление персоналом (HRM) v8 УПП1 Россия БУ Абонемент ($m)

Обработка для формирования и выгрузки в xml-файл списка предпенсионеров (для ПФР).

2 стартмани

25.02.2019    4007    10    olga2272    9    

Обновление 2-НДФЛ 2019 года для ЗУП 2.5

Зарплата Печатные формы документов Обмен через XML Зарплата v8::СПР ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Обновление справок 2-НДФЛ 2019 года для конфигурации ЗУП 2.5.130.2 проф.

1 стартмани

16.01.2019    8721    66    xeon    13    

Правила обмена данными между УПП 1.3 и БП 3.0

Оптовая торговля Обмен через XML Перенос данных из 1C8 в 1C8 Оптовая торговля v8 УПП1 БП3.0 Россия БУ УУ Абонемент ($m)

Правила обмена данными между УПП 1.3.113.1 и БП 3.0.66.47 для Универсального обмена данными в формате XML.

2 стартмани

14.12.2018    6836    9    KrasinC    0    

Регламентированный отчет Единый Социальный Взнос (ЕСВ) + выгрузка DBF и XML 2018 г

Бухгалтерские Регламентированная отчетность Файловые протоколы обмена, FTP Обмен через XML Зарплата Зарплата v8 v8::БУ 1cv8.cf Украина БУ Абонемент ($m)

Внешний регламентированный отчет по единому социальному взносу (ЕСВ), в который возвращена возможность выгрузки в DBF для украинских конфигураций.

1 стартмани

05.09.2018    11675    17    pihy    6    

Регламентированный отчет Статистика П-4 под новый шаблон от 19.06.2018

Управление персоналом (HRM) Регламентированная отчетность Статистики Обмен через XML Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

ЗАПОЛНЯЕМЫЙ И ВЫГРУЖАЕМЫЙ отчет П-4 под актуальный шаблон. Комплект для сборки(перенести в конфигурацию ЗУП 3.1.5, 3.1.6, 3.1.7): 1) внутренний отчет РегламентированныйОтчетСтатистикаФормаП4 + 2) МодульМенеджера этого отчета(не выгружается во внешний отчет) + 3) одна процедура ОбщийМодуль.РегламентированнаяОтчетность.ДополнитьСтруктуруПараметров Последние тест на релизе 3.1.7.105

1 стартмани

16.08.2018    8541    7    milov.aleksey    0    

Мониторинг выполнения обмена

Перенос данных из 1C8 в 1C8 v8 1cv8.cf 1С:Франчайзи, автоматизация бизнеса Казахстан Абонемент ($m)

Отчет отображает даты, статус и результат обмена.

1 стартмани

03.05.2018    5788    2    Almaz    0    

Концепция постановки задачи на разработку правил обмена КД 2.0

Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

А также отчет по правилам конвертации

1 стартмани

27.10.2017    11108    4    unichkin    2    

Синхронизация данных по правилам КД2.0

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    26610    115    vikad    36    

Налоговая накладная. Новый формат выгрузки на 2019 год с 01.12.18 для Украины

Налоговые Обмен через XML v8 1cv8.cf Украина БУ НУ НДС Абонемент ($m)

Новый формат выгрузки налоговых документов для типовых украинских конфигураций.

2 стартмани

04.04.2017    11680    0    Igortid    2    

Регламентированный отчет Единый Социальный Взнос ЕСВ + выгрузка XML и DBF 2017г

Зарплата Регламентированная отчетность Обмен через XML Файловые протоколы обмена, FTP Зарплата v77::БУ v8::БУ 1cv8.cf 1cv7.md Украина БУ Абонемент ($m)

Внешний регламентированный отчет по единому социальному взносу (ЕСВ) с возможностью выгрузки в XML и DBF для украинских конфигураций.

1 стартмани

11.01.2017    20183    32    Igortid    4    

Детализация звонков МТС в формате XML: загрузка файла и анализ расходов

Обмен через XML v8 Россия Абонемент ($m)

Конфигурация позволяет загружать и сохранять детализацию звонков в документ, анализировать расходы по видам услуг и телефонным номерам, просматривать детализацию по отдельным номерам.

1 стартмани

31.10.2016    13403    32    vkoljan    6    

Реестр полученных счетов-фактур, включенных в декларацию по НДС (УФ)

Бухгалтерские Налоговые Обмен через XML Оптовая торговля Оптовая торговля v8::БУ v8::УФ БП3.0 Россия БУ НУ НДС Абонемент ($m)

Внешняя обработка "Реестр полученных счетов-фактур, включенных в декларацию по НДС" формирует таблицу счетов-фактур из файла выгрузки .XML декларации по НДС. В реестре указываются дата и номер счета-фактуры, ИНН/КПП и полное наименование клиента, код вида операции и суммы: стоимость покупки и сумма НДС. Реестр может быть необходим при передаче документов в ФНС для камеральной или встречной проверок, для внутреннего анализа. Реестр показывает именно те данные, которые указаны в декларации по НДС и переданы в ФНС.

1 стартмани

26.10.2016    16360    28    chkurs    4    

Заполнение «Приложения №2» к «Декларации налога на прибыль» из файла XML выгрузки справок НДФЛ для налоговой по коду дохода 1010 (отчетность за 2016г.)

Налоговые Регламентированная отчетность Обмен через XML Зарплата Зарплата v8 БП2.0 ЗУП2.5 УПП1 Россия БУ НУ Налог на прибыль НДФЛ Абонемент ($m)

Для Бухгалтерии 2.0, ЗУП 2.5, УПП 1.3. Назначение: Заполнение «Приложение №2» к декларации налога на прибыль на основании файла XML выгрузки справок НДФЛ для налоговой для одного кода доходов НДФЛ (1010 "Дивиденды").

3 стартмани

07.03.2016    12923    30    stgy65    1    

Декларант-Алко: формирование xml контрагентов и 12 форма (пиво в розницу) по данным декларации поставщика (форма 6)

Налоговые Розничная торговля Обмен через XML Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Россия БУ Акцизы Абонемент ($m)

Поставщик реализует в опт пиво. Его покупателям (розничникам) необходимо формировать декларацию 12. Розница для этого использует "Декларант-Алко"

1 стартмани

14.04.2015    11488    23    O_Yurec    3    

Правила обмена для свертки БП 3.0 -> БП 3.0 (3.0.77.106), БП 2.0 -> БП 2.0 (2.0.64.33) документами Ввод начальных остатков / Ночной перенос остатков

Свертка базы Перенос данных из 1C8 в 1C8 v8 БП2.0 БП3.0 БУ Абонемент ($m)

Правила обмена и шаблон внешней обработки для ночного переноса остатков в документы ВводНачальныхОстатков (свертка базы) для бухгалтерия предприятия 2.0 (БП). Задача: ежесуточно ночью переносить из старой базы новые остатки (после исправлений) и документы изменённые за период с начала года из старой в новую базу данных, обе из которых находятся на поддержке без возможности изменений.

3 стартмани

01.02.2014    27679    170    jdo    48    

Автоматизация обменов в распределённой базе данных средствами VisualBatch

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Стандартный механизм распределённых баз данных на основе планов обменов не даёт гибкости в доставке XML пакетов. Что делать, если нет связи или FTP недоступен? Как узнать текущее состояние репликации? Как передать XML пакет в IP сеть за NAT маршрутизатор? Попробуем дать ответы на эти вопросы.

1 стартмани

11.06.2013    11980    18    dzuyba    5    

Штрихкодирование документов бухгалтерии - обмен данными "Бухгалтерия предприятия" - "Документооборот"

Документооборот и делопроизводство Сканер штрих-кода Перенос данных из 1C8 в 1C8 Документооборот и делопроизводство v8 БП2.0 ДО Абонемент ($m)

В процессе автоматизации документооборота организации возникла задача хранить сканы бумажных документов (первичных) в базе 1С Документооборот КОРП. Статья рассказывает о варианте решения.

1 стартмани

22.04.2013    22121    37    Dach    4    

Настройка 1С обмена данными между 1С:Бухгалтерия 8 и 1С:Запрлата и управление персоналом

Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 БП2.0 Россия БУ Абонемент ($m)

Для того чтобы настроить обмен данных между двумя этими программами нужно из программы «1С:Зарплата и управления персоналом» в «1С бухгалтерию» выгрузить информацию о плане счетов 1С:Бухгалтерии

1 стартмани

22.10.2012    29666    57    zlojpomidor    8    

Настройка интеграции «1С:Управление торговлей 8 Редакция 11» и «1С:Документооборот». Бизнес-процессы, внешние роли исполнителей.

Документооборот и делопроизводство Управление бизнес-процессами (BPM) Перенос данных из 1C8 в 1C8 Документооборот и делопроизводство v8 УТ10 ДО Россия Абонемент ($m)

Моя первая статья про настройку интеграции 1С:Управление торговлей 8 Редакция 11 и 1С:Документооборот оказалась достаточно востребованной. Благодарю за отзывы. В продолжение темы хочу представить вашему вниманию продолжение - настройку бизнес-процессов и внешних ролей исполнителей.

1 стартмани

11.07.2012    45509    29    ReSY    11    

Автоматизация обмена между базами, используя обработку "Универсальный обмен данными в формате XML". Подумаем о регистрации объектов обмена

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Данный материал является продолжением начатой мною темы относительно использования обработки «Универсальный обмен данными в формате XML» при организации регламентного обмена между различными базами (http://infostart.ru/public/86109/ ).

1 стартмани

07.07.2011    25451    137    wiranata    6