Подготовка сведений для ПФР 2011 с расчетом уплаченных НЕ через коэффициент

Публикация № 86473

Разработка - Практика программирования

16
Создан для исправления любого предыдущего отчета  с последующим созданием отчетов в свете новых требований ПФР.

Использует файл сохраненный настроек отчета за прошлый период (например - "_1_ИСХОДНАЯ_12010.pf")

Сделан для себя (НЕ ДЛЯ УПРОЩЕНКИ).

Старался минимизировать свои изменения, они помечены "// новое начало" и "// новое конец"

Для  исправления предыдущего отчета или создания нового, но с учетом доплаты или переплаты в прошлом отчете, поставить флажок  "в прошлом периоде"

Для создания нового без исправлений, с расчетом не коэффициентом, и с условием, что прошлый период был рассчитан не коэфф. и не требуется доплата/удержание за него, оба флажка: "в этом периоде" и  "в прошлом периоде" НЕ ставить.

 

По сути изменения:

Добавил процедурку:

 

// Новое начало           СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц()
//******************************************************************************
// СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц() 
//Описание:
//процедура заполняет суммы уплаченных взносов пересчитав начисленные
//по сотрудникам  за тот-же  период со сдвигом на месяц назад
//
Процедура  СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц() 
ТабПоУплатамПредПериод = СоздатьОбъект("ТаблицаЗначений");
ТабПоУплатамПредПериод.НоваяКолонка("Объект");
ТабПоУплатамПредПериод.НоваяКолонка("Период"); 
ТабПоУплатамПредПериод.НоваяКолонка("УплачСтрах"); 
ТабПоУплатамПредПериод.НоваяКолонка("УплачНакоп");
ТабПоУплатамТекПериод = СоздатьОбъект("ТаблицаЗначений");
ТабПоУплатамПредПериод.Выгрузить(ТабПоУплатамТекПериод);
 
    // вычислим период, за который начисленные СтрахВзносы входили в уплату по текущему периоду
ТекущийОтченыйПериод= ПолучитьДатуНачала(); 
НачОтсчТекПериодаРасчета= НачМесяца(ТекущийОтченыйПериод - 1); 
КонОтсчТекПериодаРасчета= КонМесяца((Мин(глПолучитьДатуОкончанияОтчетногоПериодаСЗВ(ТекущийОтченыйПериод),ДатаОтчета))-32); 
 
// вычислим период, за который начисленные СтрахВзносы входили в уплату по предыдущему периоду
// что-бы узнать остатки с прошлого периода. Если Сотр был уволен в середине предыдущего периода
ДатаСоЗдвигом= ПолучитьОтчетныйПериодПоДате(НачОтсчТекПериодаРасчета);
ВременОтчетныйПериод= ОтчетныйПериод;
ОтчетныйПериод= ДатаСоЗдвигом; 
 
ПредыдущийОтченыйПериод= ПолучитьДатуНачала();
ОтчетныйПериод = ВременОтчетныйПериод;
ТекущийОтченыйПериод= ПолучитьДатуНачала();  // возможно лишнее обращение и можно удалить
НачОтсчПредПериодаРасчета= НачМесяца(ПредыдущийОтченыйПериод - 1); 
КонОтсчПредПериодаРасчета= КонМесяца((Мин(глПолучитьДатуОкончанияОтчетногоПериодаСЗВ(ПредыдущийОтченыйПериод),ДатаОтчета))-32); 
 
// Сообщить("ТекущийОтченыйПериод");
// Сообщить(ТекущийОтченыйПериод);
// Сообщить("НачОтсчТекПериодаРасчета");
// Сообщить(НачОтсчТекПериодаРасчета);
// Сообщить("КонОтсчТекПериодаРасчета");
// Сообщить(КонОтсчТекПериодаРасчета);
// Сообщить("ПредыдущийОтченыйПериод");
// Сообщить(ПредыдущийОтченыйПериод);
// Сообщить("НачОтсчПредПериодаРасчета");
// Сообщить(НачОтсчПредПериодаРасчета);
// Сообщить("КонОтсчПредПериодаРасчета");
// Сообщить(КонОтсчПредПериодаРасчета);
 
 
 
ТабПоУплатам = СоздатьОбъект("ТаблицаЗначений");
 
ЗапросПоВзносам=СоздатьОбъект("Запрос");
 
ТекстЗапроса="//{{ЗАПРОС(ЗапросПоВзносам)
|С НачОтсчПредПериодаРасчета по КонОтсчТекПериодаРасчета;
|Объект = ЖурналРасчетов.СтраховыеВзносы.Объект;
|ВР = ЖурналРасчетов.СтраховыеВзносы.ВидРасч;
|Результат = ЖурналРасчетов.СтраховыеВзносы.Результат;
|Регистрация = ЖурналРасчетов.СтраховыеВзносы.ДатаОкончания;
|Группировка Объект Без Групп Без Упорядочивания; 
|Группировка ВР Без Групп Без Упорядочивания; 
|Группировка Результат Без Групп;
|Без Итогов;
|Группировка Регистрация;
|Условие((Результат <> 0) И ((ВР = ВидРасчета.ПФРСтраховаяЧастьс2010) ИЛИ (ВР = ВидРасчета.ПФРНакопительнаяЧастьс2010)));
|"//}}ЗАПРОС
;
 
Если ЗапросПоВзносам.Выполнить(ТекстЗапроса)=0 Тогда 
Сообщить("Не удалось обработать журнал взносов");
КонецЕсли; 
ЗапросПоВзносам.Выгрузить(ТабПоУплатам);
ТабПоУплатам.Сортировать("Объект,Регистрация");
ТабПоУплатам.НоваяКолонка("ПериодОплаты"); 
 
ТабПоУплатам.ВыбратьСтроки();
Пока ТабПоУплатам.ПолучитьСтроку()=1 Цикл
Если ТабПоУплатам.Регистрация>=НачОтсчТекПериодаРасчета Тогда 
ТабПоУплатамТекПериод.НоваяСтрока();
ТабПоУплатамТекПериод.Период = ТекущийОтченыйПериод;
ТабПоУплатамТекПериод.Объект = ТабПоУплатам.Объект;   // удалить
ТабПоУплатам.ПериодОплаты = ТекущийОтченыйПериод;
Если ТабПоУплатам.ВР = ВидРасчета.ПФРСтраховаяЧастьс2010  Тогда
ТабПоУплатамТекПериод.УплачСтрах = ТабПоУплатам.Результат;
ТабПоУплатамТекПериод.УплачНакоп = 0;
ТабПоУплатам.ПериодОплаты = ТекущийОтченыйПериод;  // удалить
Иначе
ТабПоУплатамТекПериод.УплачНакоп = ТабПоУплатам.Результат;
ТабПоУплатамТекПериод.УплачСтрах = 0; 
КонецЕсли;
Иначе 
ТабПоУплатамПредПериод.НоваяСтрока();
ТабПоУплатамПредПериод.Период = ПредыдущийОтченыйПериод;  
ТабПоУплатамПредПериод.Объект = ТабПоУплатам.Объект;  
ТабПоУплатам.ПериодОплаты  = ПредыдущийОтченыйПериод;  // удалить
Если ТабПоУплатам.ВР = ВидРасчета.ПФРСтраховаяЧастьс2010  Тогда
ТабПоУплатамПредПериод.УплачСтрах = ТабПоУплатам.Результат;
ТабПоУплатамПредПериод.УплачНакоп = 0; 
Иначе
ТабПоУплатамПредПериод.УплачНакоп = ТабПоУплатам.Результат;
ТабПоУплатамПредПериод.УплачСтрах = 0; 
КонецЕсли;
КонецЕсли;
КонецЦикла; 
 
ТабПоУплатамТекПериод.Свернуть("Объект,Период","УплачСтрах,УплачНакоп");
ТабПоУплатамТекПериод.Сортировать("Объект,Период");
//ТабПоУплатамТекПериод.ВыбратьСтроку(,"ТабПоУплатамТекПериод_3_ВнутриПроцедуры");
 
ТабПоУплатамПредПериод.Свернуть("Объект,Период","УплачСтрах,УплачНакоп");
ТабПоУплатамПредПериод.Сортировать("Объект,Период");
//ТабПоУплатамПредПериод.ВыбратьСтроку(,"ТабПоУплатамПредПериод_3_ВнутриПроцедуры");
 
 
// ------------------------------------------------------------------------------------------
    // получим из файла настроек    
 
ОтчетныйПериодВременный= ОтчетныйПериод ;       
ОтчетныйПериод = ПредыдущийОтченыйПериод;
ДатаПериода = ОтчетныйПериод; 
 
ИмяФайла    = ПолучитьИмяФайлаНастроек();       
УплатыПредПериод= СоздатьОбъект("ТаблицаЗначений");
 
Если ФС.СуществуетФайл(ИмяФайла) =1 Тогда
ФайлНастр = СоздатьОбъект("Текст");
ФайлНастр.Открыть(ИмяФайла);
Иначе Возврат;
КонецЕсли;  
// список документов в 3-й строке
СтрокаСписокДокументов  = СтрЗаменить(ФайлНастр.ПолучитьСтроку(3), констКод1, констКод10);
УплатыПредПериод= ЗначениеИзСтрокиВнутр(СтрокаСписокДокументов); 
//УплатыПредПериод.ВыбратьСтроку(,"СписокДокументов УплатыПредПериод");
// очистим и восстановим переменные
    ОтчетныйПериод   = ОтчетныйПериодВременный;
ДатаПериода = ОтчетныйПериод; 
ИмяФайлаНастроек   = ПолучитьИмяФайлаНастроек();
ТаблицаПачки= "";
СтрокаСписокДокументов  = ""; 
ТабПоУплатам = "";
КонецПроцедуры      // СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц()   
// новое конец      // СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц()
 
 
ну и в процедуре  ЗаполнитьСуммыВзносов()  добавил:
 
ТабИсчисленоВзносов.ВыбратьСтроки();
Пока ТабИсчисленоВзносов.ПолучитьСтроку()=1 Цикл
 
КоэффициентСтраховая = 0;
КоэффициентНакопительная = 0;
 
ДатаПериода = ТабИсчисленоВзносов.ОтчетныйПериод;
НомСтроки = "";
Если ТабУплатыВзносов.НайтиЗначение(ДатаПериода,НомСтроки,"ОтчетныйПериод")=1 Тогда
КоэффициентСтраховая = ТабУплатыВзносов.ПолучитьЗначение(НомСтроки,"КоэффициентСтраховая");
КоэффициентНакопительная = ТабУплатыВзносов.ПолучитьЗначение(НомСтроки,"КоэффициентНакопительная");
КонецЕсли;
 
ТабИсчисленоВзносов.Ключ = ПолучитьКлючСотрудника(ТабИсчисленоВзносов.Сотрудник,ТабИсчисленоВзносов.КатегорияЗЛ);     
   // новое начало
НомСтрок1 = 0; 
НомСтрок2 = 0;
НомСтрок3 = 0;
НовУплачСтрах = 0;  
НовУплачНакоп = 0; 
Если  (КоэфДА=0) И (ДатаПериода=ТекущийОтченыйПериод) Тогда   // это  начислен/удерж тек периода и по новому
   ТабПоУплатамТекПериод.НайтиЗначение(ТабИсчисленоВзносов.Сотрудник,НомСтрок1,"Объект");
Если  (НомСтрок1=0) Тогда// не найдена, значт не было начислений и они будут состоять только из остатков с пр периода  
   ТабИсчисленоВзносов.УплаченоСтраховая = 0;
ТабИсчисленоВзносов.УплаченоНакопительная = 0;
Иначе    // нашли, плюсуем
ТабПоУплатамТекПериод.ПолучитьСтрокуПоНомеру(НомСтрок1);
ТабИсчисленоВзносов.УплаченоСтраховая = ТабПоУплатамТекПериод.УплачСтрах;   
ТабИсчисленоВзносов.УплаченоНакопительная = ТабПоУплатамТекПериод.УплачНакоп;  
КонецЕсли;
ИначеЕсли (КоэфДА=0) И (ДатаПериода<>ТекущийОтченыйПериод)  Тогда  //это  начислен\удерж прошл периода и по новому
Если  (КоэфДА1=0) Тогда// прошлый период был посчитан по новому
ТабИсчисленоВзносов.УплаченоСтраховая = 0;  
ТабИсчисленоВзносов.УплаченоНакопительная = 0;
ИначеЕсли  (КоэфДА1=1)  Тогда  // прошлый период был посчитан по старому 
   ТабПоУплатамПредПериод.НайтиЗначение(ТабИсчисленоВзносов.Сотрудник,НомСтрок2,"Объект");
   УплатыПредПериод.НайтиЗначение(ТабИсчисленоВзносов.Сотрудник,НомСтрок3,"Сотрудник");
Если  (НомСтрок2=0) и (НомСтрок3<>0)  Тогда// значт были начисления, но не должны были быть ????????????
// нашли, считываем начисления прошлого периода старым способом, полученные из файла
УплатыПредПериод.ПолучитьСтрокуПоНомеру(НомСтрок3);
ТабИсчисленоВзносов.УплаченоСтраховая = УплатыПредПериод.УплаченоСтраховая;  
ТабИсчисленоВзносов.УплаченоНакопительная = УплатыПредПериод.УплаченоНакопительная;
Сообщить(Строка(ТабИсчисленоВзносов.Сотрудник) + "   были начисления, но не должны были быть ?????  НЕДОУПЛАТА");
// реальная недоуплата должна быть разницей (Правильно - ЧерезКоэф)
ТабИсчисленоВзносов.УплаченоСтраховая = 0 - ТабИсчисленоВзносов.УплаченоСтраховая;  
ТабИсчисленоВзносов.УплаченоНакопительная = 0 - ТабИсчисленоВзносов.УплаченоНакопительная; 
ИначеЕсли  (НомСтрок2<>0) и (НомСтрок3=0)  Тогда// значт не было начислений, но должны были быть ???????????? 
//  сколько должны были начислить, еслиб считали не коэффициентом 
ТабПоУплатамПредПериод.ПолучитьСтрокуПоНомеру(НомСтрок2);
ТабИсчисленоВзносов.УплаченоСтраховая = ТабПоУплатамПредПериод.УплачСтрах;  
ТабИсчисленоВзносов.УплаченоНакопительная = ТабПоУплатамПредПериод.УплачНакоп;
Сообщить(Строка(ТабИсчисленоВзносов.Сотрудник) + "   не было начислений, но должны были быть  ПЕРЕПЛАТА  ???????");
ИначеЕсли  (НомСтрок2=0) и (НомСтрок3=0)  Тогда// значт не было начислений, и не должно было быть
ТабИсчисленоВзносов.УплаченоСтраховая = 0;  
ТабИсчисленоВзносов.УплаченоНакопительная = 0;
Иначе 
// нашли, считываем начисления прошлого периода старым способом, полученные из файла
УплатыПредПериод.ПолучитьСтрокуПоНомеру(НомСтрок3);
ТабИсчисленоВзносов.УплаченоСтраховая = УплатыПредПериод.УплаченоСтраховая;  
ТабИсчисленоВзносов.УплаченоНакопительная = УплатыПредПериод.УплаченоНакопительная;
//  сколько должны были начислить, еслиб считали не коэффициентом 
ТабПоУплатамПредПериод.ПолучитьСтрокуПоНомеру(НомСтрок2);
НовУплачСтрах = ТабПоУплатамПредПериод.УплачСтрах;  
НовУплачНакоп = ТабПоУплатамПредПериод.УплачНакоп;   // 2222222222222222222222222
// реальная недоуплата должна быть разницей (Правильно - ЧерезКоэф)
ТабИсчисленоВзносов.УплаченоСтраховая = НовУплачСтрах - ТабИсчисленоВзносов.УплаченоСтраховая;  
ТабИсчисленоВзносов.УплаченоНакопительная = НовУплачНакоп - ТабИсчисленоВзносов.УплаченоНакопительная;
КонецЕсли; 
КонецЕсли;  
ИначеЕсли (КоэфДА=1) и (КоэфДА1=1) Тогда  // всё считаем по  старому
// новое конец
ТабИсчисленоВзносов.УплаченоСтраховая = ОКР(ТабИсчисленоВзносов.ИсчисленоСтраховая * КоэффициентСтраховая,2);
ТабИсчисленоВзносов.УплаченоНакопительная = ОКР(ТабИсчисленоВзносов.ИсчисленоНакопительная * КоэффициентНакопительная,2);
// новое начало    
КонецЕсли;
// новое конец
Если ДатаПериода<>ТекущийОтченыйПериод Тогда
ТабИсчисленоВзносов.ИсчисленоСтраховая = 0;
ТабИсчисленоВзносов.ИсчисленоНакопительная = 0;    
КонецЕсли;
 
КонецЦикла;  

 

Это из крупных изменений =) остальное так... по мелочи =)

 

Исходник: //infostart.ru/public/84659/

Удачи в борьбе с 1С.

 

ИСПРАВЛЕНИЯ:

Поправил немного, были пара-тройка уволенных невовремя) сотров потеряны правил в спешке, но  теперь НОВЫЙ отчет без ошибок!

 

16

Скачать файлы

Наименование Файл Версия Размер
ПодготовкаСведПФР_НЕ_коэффициентомРелиз3.ert
.ert 453,50Kb
13.08.13
246
.ert 453,50Kb 246 Скачать

Специальные предложения

См. также

Подготовка сведений в ПФР за 2013 год с распределением суммы уплаченных взносов, превышающих начисленные 41

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Windows Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Регламентированная отчетность

При подготовке к сдаче отчета в ПФР столкнулся с тем, что программа не учитывает переплату - не распределяет сумму уплаченных взносов, превышающую начисленную, даже если это оплата проходит в январе 2013 за декабрь 2012. В случае, когда есть долг по оплате на начало периода (например, за декабрь 2012 платят в январе 2013) сумма уплаченных взносов может быть больше суммы начисленных. Программа же ставит сумму уплаченных взносов равную сумме начисленных. В этой обработке распределяются суммы уплаченных взносов, превышающих начисленные, а так же внесены исправления, связанные с возможными ошибками при формировании штатной обработки из 335 релиза (в пачки попадали ненужные уволенные, неправильно распределялись уплаты взносов, при выгрузке в файл возникали ошибки).

1 стартмани

20.04.2013    21531    425    mirrr    65       

Быстрая проверка расчета страховых взносов (ЗиК 7.7) 32

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские Анализ учета

Пользуюсь этим отчетом для проверки расчета страховых взносов. Даже если в базе несколько сотен сотрудников, легко увидеть у кого неверно считаются страховые взносы. Получаем расшифровку, щелкая по цифре процентов.

1 стартмани

05.07.2012    11839    239    asi24    21       

Свод проводок с детализацией по сотрудникам и видам расчетов 37

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Доработанный свод проводок, позволяющий детализировать данные по сотрудникам и видам расчетов в любом порядке следования - полезен расчетчикам в случаях когда "непонятно откуда взялась такая сумма в проводке".

1 стартмани

12.04.2012    22140    269    alx300    17       

НДФЛ как на ладони 37

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата НДФЛ Абонемент ($m) Обработка документов Бухгалтерские Налоговые

НДФЛ посчитали... А когда, как и куда уплатили? А за кого и сколько еще надо уплатить? А почему столько? А можно документ создать автоматически?

1 стартмани

27.03.2012    21320    325    DarkAn    41       

Расчет резерва отпусков, Зарплата и кадры. 35

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Для бухгалтеров, кадровиков и руководителей. Расчет резерва отпусков всего предприятия или несколькими выборками в необходимых разрезах -это несложно! Есть широкие возможности настройки параметров отчета.

1 стартмани

21.03.2012    29502    365    sergdem486    48       

Вывод и перенумерация отчета с заранее неизвестным количеством группировок. 19

Инструменты и обработки Программист Внешняя обработка (ert,epf) openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m) Практика программирования Работа с интерфейсом

1C v.7.7 Пример вывода отчета с заранее неизвестным количеством группировок, с возможностью изменять уровень вложенности группировок из списка значений на форме, с нумерацией конечного отчета, с выводом структуры вложенности группировок (с помощью внешней компоненты Йоксель - http://yoksel.net.ru/Hotfixes). В приложенном файле показан пример вывода отчета из сформированной таблицы значений. Код я старался закомментировать как можно подробней. Хоть семерка и вымирающая платформа, думаю еще есть люди, которые только начинают ей заниматься, и им это может пригодиться.

1 стартмани

21.03.2012    23532    20    unichkin    11       

Расчет остатка дней отпуска 42

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Бухгалтерские

Надо уволить сотрудника, а сколько дней отпуска ему компенсировать или наоборот???

1 стартмани

13.03.2012    20011    234    DarkAn    42       

Автоматическое создание документов "Перечисление НДФЛ в бюджет" для ЗиК 7.7 27

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК 1С7:Комплекс 1С7:ТиС Россия БУ Зарплата НДФЛ Абонемент ($m) Обработка документов

Уж недалек отчет, а документы распределения НДФЛ по работникам за 2011 год не введены. Можно ввести их вручную, а можно воспользоваться обработкой, выгрузить их в MS Excel и сформировать автоматически. Для этого подготовлен данный комплекс обработок.

1 стартмани

05.03.2012    19660    95    Krasnyj    44       

Алгоритм распределения перечисленного НДФЛ в ЗиК 7.7 и вариант его улучшения 46

Инструменты и обработки Бухгалтер Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Абонемент ($m) Обработка документов

Доработка конфигурации ЗиК 7.7 релизы 320-322 с целью улучшить распределение сумм перечисленного НДФЛ по сотрудникам. Полезна, если Вы хотите видеть "красивые" регистры налогового учета по НДФЛ - с подробной расшифровкой перечисленных налогов до даты платежа и номера платежки. Ну и разумеется годовую отчетность по НДФЛ в полном соответствии с этими регистрами. Внимание! Если Вам просто надо показать в справке/отчете 2-НДФЛ перечисленную сумму равной начисленной и удержанной, - можно дальше не читать, а сразу идти сюда: http://infostart.ru/public/115064/

1 стартмани

28.02.2012    15230    243    sam41    75       

Свод проводок + страховые взносы (в разрезе видов расчета) 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Отчет рекомендуется для использования с конфигурацией "1С:Зарплата и кадры 7.7" (начиная релиза 7.70.320). Преимущества отчета: 1. Группировка данных о начислениях и страховых взносах по видам расчета (легко сверяется со сводом по зарплате и налоговой ведомостью); 2. Данные об удержаниях формируются отдельно; 2. Возможность расшифровки до конечных проводок с указанием всей аналитики; 3. Дополнительный сводный анализ по счетам участвующим проводках; 4. Использование типового механизма получения данных о проводках (глПроводкиЗаПериод).

1 стартмани

24.02.2012    18388    202    kondrp    11       

Расчет компенсации за неиспользованный отпуск при увольнении, а также расчет причитающегося сотруднику отпуска на выбранную дату 104

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Windows Зарплата Абонемент ($m) Обработка документов

Обработка позволяет рассчитывать количество дней компенсации за неиспользованный отпуск при увольнении, а также причитающийся сотруднику отпуск на определенную дату. Теперь с возможностью ввода дополнительных данных!!!!

3 стартмани

23.02.2012    24487    222    Krasnyj    38       

Отчет по изменению окладов для ЗиК 7.7 43

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Вам необходимо отследить оклады сотрудников и повышение их по датам? Этот отчет для Вас.

1 стартмани

22.02.2012    12079    35    Krasnyj    9       

Исправляем СЗВ 6-3 53

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские

Переделанный отчет "Подготовка сведений для ПФР" с возможностью редактировать данные таблицы СЗВ 6-3

1 стартмани

06.02.2012    13841    254    legioner    47       

Модернизация формы 2-НДФЛ 2015 г. для ЗиК 102

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ НУ Зарплата НДФЛ Абонемент ($m) Справки

Форма 2-НДФЛ 2015 для конфигурации ЗиК. Добавлены некоторые механизмы для более удобной и успешной сдачи отчета. Утверждена приказом ФНС России от 30.10.2015 № ММВ-7-11/485@.

1 стартмани

01.02.2012    26416    649    victuan    98       

Справки по НДФЛ 2011: сделаем перечисленный равным удержанному (ЗиК 7.7, Бух 7.7) 35

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата НДФЛ Абонемент ($m) Справки Налоговые

Отчет "Справки по НДФЛ" для бухгалтеров, которые просто хотят отчитаться в ИФНС и выдать сотрудникам справки 2-НДФЛ и не хотят вводить документы "Перечисление НДФЛ в бюджет" и разбираться с тем, как в них считается перечисленный налог. Для "1С:Зарплата и кадры 7.7.320" и "1С:Бухгалтерия 7.7.535".

1 стартмани

01.02.2012    15699    200    Antia    22       

Нумерация справок для "Зарплаты и Кадры", ред.2.3 8

Отчеты и формы Бухгалтер Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ ФОМС, ПФ, ФСС Абонемент ($m) Справки

Нумерация в отчетах: "ПодготовкаСведенийДляИМНС" "СправкаВыплатЗа3Года" "СправкаОДоходах" "СправкиПоНДФЛ"

1 стартмани

05.01.2012    15601    34    Одинец    9       

Исправленный и улучшенный отчет 2НДФЛ (318 релиз ЗиК) 60

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Абонемент ($m) Налоговые

- Исправлена ошибка размера применненого имущественного вычета - В печатную форму "Реестр2011Дополнительный" добавлена колонка с суммой перечисленного НДФЛ. - Добавлена новая печатная форма "Список справок 2-НДФЛ" - Добавлены режимы формирования отчета, в которых суммы перечисленного НДФЛ берутся не из документов "Перечисление НДФЛ в бюджет РФ", а приравнивается к суммам исчисленного или удержанного налога.

1 стартмани

25.12.2011    16278    251    Kapitan911    46       

Проверка соответствия НДФЛ удержанного/перечисленного (ЗиК) 63

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Абонемент ($m) Анализ учета

Отчет, позволяющий выявить ошибки при распределении сумм НДФЛ уплаченных (ЗиК)

1 стартмани

17.11.2011    20418    374    legioner    97       

Сверка начисленных, уплаченных и перечисленных сумм НДФЛ для ЗиК 43

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата НДФЛ Абонемент ($m) Налоговые

Отчет, позволяющий видеть исчисленные, уплаченные и перечисленные в бюджет суммы НДФЛ с отбором по сотрудникам за указанный период.

1 стартмани

16.11.2011    12465    269    Livsi    47       

Плагин для лечения выгрузки и загрузки больших баз в 1С 7.7 (портирование под Win7) 61

Инструменты и обработки Системный администратор Компонента, плагин (dll, vbs,..) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Абонемент ($m) Практика программирования

В связи с изменением состава DLL в Wiindows 7 оригинальный плагин выложенный здесь http://infostart.ru/public/15364/ перестал работать в Windows7/WindowsServer 2008 R2. (Что именно там изменилось можно посмотреть здесь http://ru.wikipedia.org/wiki/MinWin) Данный плагин - это простое портирование оригинального плагина под Windows 7

1 стартмани

31.10.2011    50073    572    avgreen    90       

Налоговая ведомость для конфигурации 1С:Зарплата и Кадры 7.7 47

Отчеты и формы Бухгалтер Архив с данными v77::Расчет 1С7:ЗиК Россия БУ НУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские Налоговые

28.03.2015 г. файл отчета обновлен. В данной версии отчета "Налоговая ведомость для конфигурации 1С:Зарплата и Кадры 7.7" реализована поддержка изменений законодательства в части начисления страховых взносов в 2015 г. Отчет предназначен для использования в версии 350 и выше конфигурации 1С:Зарплата и Кадры 7.7.

1 стартмани

25.10.2011    17583    140    oyua2011    34       

Анализ НДФЛ (начислено, удержано, перечислено) для ЗиК 62

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Абонемент ($m) Бухгалтерские Налоговые

Отчёт пригодится для анализа НДФЛ в различных разрезах: Сотрудник, Период, ОКАТО, Ставка.

1 стартмани

13.10.2011    15790    252    AleksSl    51       

Отчет по среднесписочной численности с разбивкой по подразделениям и должностям (для П-4) 29

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия БУ Управление персоналом (HRM) Абонемент ($m) Бухгалтерские Статистические

Отчет по среднесписочной численности с разбивкой по подразделениям и должностям, выводом суммы начисленной зарплаты и количества отработанных часов Поможет при подготовке данных для формы П-4

1 стартмани

05.10.2011    13706    245    FarhadIlyazov    27       

Отчет по страховым взносам с облагаемой базой (+группировки) 2011 34

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские

Отчет о начисленных страховых взносах с облагаемой базой для ЗиК 7.7 с механизмом группировки по подразделениям и по должностям.

1 стартмани

23.09.2011    15232    222    XOCTEP    49       

Отчет по страховым взносам за период, с итогами с начала года (для 2014, 2015г.) 53

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские

Обработка http://infostart.ru/public/65918/ была переработана по формам, придуманным нашим расчетчиком зарплаты в целях проверки правильности сдаваемых в ПФР сведений.

1 стартмани

08.09.2011    15102    490    gsnls15    75       

Заполнение листка нетрудоспособности c 2011 53

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Печатные формы документов

Подготавливает данные для раздела "Заполняется работодателем" и заполняет шаблон для вывода на печать на листке нетрудоспособности.

10.08.2011    11942    686    mike_grig    62       

Расчет стажа 73

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия БУ Управление персоналом (HRM) Абонемент ($m) Бухгалтерские

В помощь кадровику или бухгалтеру для расчета общего трудового стажа сотрудников по записям из трудовых книжек. Переход между полями дат по клавише Tab или Enter. Имеется калькулятор дат, вывод стажа в таблицу, а так же его запись выбранному сотруднику.

1 стартмани

25.07.2011    33621    459    rom-x    69       

Реестр по работникам расчета страховых взносов за любое количество месяцев в пределах года версия 2014 59

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Реестр страховых взносов за месяц или с начала года (теперь за любое количество месяцев в пределах года)

1 стартмани

15.07.2011    10645    615    Rauil    30       

Подготовка сведений в ПФР "три в одном" 129

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские

Комплексная подготовка сведений в ПФР с анализом соответствия уплат взносов начислениям и автозаполнением документов "Расчеты по страховым взносам".

1 стартмани

07.07.2011    21884    292    GSokolov    57       

Свод проводок ЗиК с 97 счетом 37

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Отчет "Свод проводок" ЗиК с отражением РБП на счете 97 в 2011 году.

1 стартмани

10.06.2011    12647    76    GSokolov    19       

1С:ЗиК. Перепроведение ЛЮБЫХ документов, проведенных в прошлых периодах с сохранением "проводок" (записей в Журнале расчетов). 49

Инструменты и обработки no Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Абонемент ($m) Обработка документов

1С:Зарплата и кадры. Перепроведение ЛЮБЫХ документов, проведенных в прошлых периодах с сохранением "проводок" (записей в Журнале расчетов). В некоторых случаях АРХИПОЛЕЗНАЯ обработка, помогала решать вопросы за 5 минут, которые другие решали целый час. В результате теряем заработок за 55 минут :-)))) (кто работает на почасовой оплате)

1 стартмани

30.05.2011    23913    570    gucci76    34       

Справка о зарплате за 2 года 29

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Справки

Внешний отчет для Зарплата и Кадры 7.7 показывает сумму зарплаты, разбитую по годам

1 стартмани

24.05.2011    9867    354    Shumaher1870    12       

Отчет по очередным отпускам 29

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ УУ Управление персоналом (HRM) Абонемент ($m) Бухгалтерские

Отчет по очередным отпускам. Просмотрел кучу подобных обработок (,, и т.д) в расчете выявления недочета в своей, везде обращаются к Документам.

1 стартмани

18.05.2011    7940    307    010280    36       

Индивидуальные сведения ПФР 2011 + Анализ сальдо по сотрудникам 53

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские

Индивидульные сведения ПФР 2011 (использован внешний отчет 1С от 22.04.11, т.е. их исправленние ошибок после выхода 310 релиза ) + Анализ сальдо по сотрудникам (в виде отчета, позволяющего бухгалтеру увидеть сальдо пенсионных по сотруднику с накоплением начиная с 2010 г)

1 стартмани

29.04.2011    8232    722    bnk72    8       

Автозаполнение документов "Расчеты по страховым взносам". 39

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ НУ Windows Зарплата Управление персоналом (HRM) ФОМС, ПФ, ФСС Абонемент ($m) Обработка документов 1С7.7<->1C7.7

Доработка http://infostart.ru/public/80122/. В новых отчетах "Подготовка сведений для ПФР" корректное распределение уплат возможно лишь при точном заполнении документов "Расчеты по страховым взносам", которые появились в последних релизах. Т.е. проблему распределения 1С решили (см. ниже как они ее решили), но таким образом, что правильность этого распределения полностью зависит от пользователя.

1 стартмани

16.04.2011    13929    211    Pin    30       

Карточка учета страховых взносов Рекомендуемая форма ПФР 64

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия Windows Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские

Карточка учета страховых взносов Рекомендуемая форма ПФР. Переделанная карточка для Зарплаты 7.7 Источник http://infostart.ru/public/75408/ автор pirat123457

1 стартмани

10.04.2011    13488    476    sdn31    25       

"Расходы предприятия за счет ФСС" ЗиК 309 (исправление и дополнение) 71

Отчеты и формы Бухгалтер Архив с данными v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские Специальные

В файле архива - 2 варианта отчета: исправленный типовой и отчет Расходы предприятия за счет ФСС с реестром больничных

1 стартмани

08.04.2011    13064    647    pikul    13       

ЗиК 309. Исправление дней за счет работодателя в переходящих больничных. 38

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Обработка документов Практика программирования

07.04.2011 Внесена небольшая поправка, на случай "разорванных" дней за счет работодателя. Для тех кто уже обновился или запускал обработку, скачайте ее снова и перезапустите разок. ЗиК 309. Для тех кто делал исправление количества дней за счет работодателя в переходящих больничных с 2010 на 2011, например как было описано тут:

1 стартмани

06.04.2011    12285    184    Ulfhedhinn    12       

Расходы предприятия за счет ФСС - 2011 34

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Специальные

Не претендуя на авторство (мы все здесь делаем одно общее дело), хочу предложить исправленный вариант отчёта "Расходы предприятия за счет ФСС".

1 стартмани

31.03.2011    10613    352    Вова    10       

Убранные отчеты в расходы предприятия за счет ФСС 2011 39

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ УУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Анализ учета

Переписан отчет Расходы предприятия за счет ФСС, добавлена галочка Формат 2010, после чего доступны отчеты, которые были в 2010 г.

1 стартмани

21.03.2011    8330    167    Franchiser    13       

Отпуск по уходу и больничный по беременности и родам по старому на базе ЗИК 308 релиз 54

Отчеты и формы no Архив с данными v77::Расчет 1С7:ЗиК Россия Зарплата Абонемент ($m) Учет и отчетность

Изменения законодательства, позволяющие по заявлению рассчитывать заработок по старому порядку

1 стартмани

20.03.2011    11165    530    Jacob34    33       

РСВ-1 с 2011(12) года 246

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Регламентированная отчетность

Решил выложить, прочитав топик http://infostart.ru/public/82695/ Править конфу ненадо, подключается как внешний отчет

1 стартмани

17.03.2011    20927    190    MegaMouse    125