Вывод результата отчета СКД в разные табличные документы

Публикация № 890264

Разработка - Практика программирования

Отчет СКД программный вывод результата

В ходе выполнения своей повседневной работы столкнулся с интересной клиентской задачей - требовалось результат отчета СКД вывести на форму отчета в разные вкладки формы в разные табличные документы. Как оказалось, информации по такому выводу отчета в интернете маловато, поэтому решил скомпоновать свой опыт решения этой задачи в одной статье.

Дано:

-Отчет на СКД с кучей независимых друг от друга группировок.

-Форма отчета со страницами и табличными документами результата отчета на них.

Требуется вывести каждую группировку в соответствующий ей табличный документ.

Что я сделал:

На форме отчета сделал свою кнопку "Сформировать". Событием "ПриКомпоновкеРезультата" не удалось воспользоваться, т.к. из этого события нет доступа к табличным документам на форме отчета.

В процедуре вывода отчета используем следующий код:

&НаКлиенте
Процедура СформироватьОтчет(Команда)
	СформироватьОтчетНаСервере();
КонецПроцедуры

&НаСервере
Процедура СформироватьОтчетНаСервере()
	
	ОбъектОтчета = РеквизитФормыВЗначение("Отчет");
	
	//Подготавливаем таблицы отчета для вывода
	МассивТаблиц = Новый Массив;
	МассивТаблиц.Добавить(Таблица1);
	МассивТаблиц.Добавить(Таблица2);
	МассивТаблиц.Добавить(Таблица3);
	МассивТаблиц.Добавить(Таблица4);
	МассивТаблиц.Добавить(Таблица5);
	МассивТаблиц.Добавить(Таблица6);
	МассивТаблиц.Добавить(Таблица7);
	МассивТаблиц.Добавить(ТаблицаДополнительно);
	
	Для Каждого Таблица из МассивТаблиц Цикл
		Таблица.Очистить();	
	КонецЦикла;
	
	//Подготавливаем процессоры вывода для каждой таблицы
	МассивПроцессоровВыводаТаблиц = Новый Массив;
	ПроцессорВывода1 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода2 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода3 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода4 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода5 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода6 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода7 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВыводаДополнительно = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода1);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода2);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода3);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода4);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода5);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода6);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода7);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВыводаДополнительно);
	
	Итератор = 0;
	Для Каждого ПроцессорВывода из МассивПроцессоровВыводаТаблиц Цикл
		ПроцессорВывода.ОтображатьПроцентВывода = Ложь;
		ПроцессорВывода.УстановитьДокумент(МассивТаблиц[Итератор]);
		ПроцессорВывода.НачатьВывод();
		Итератор = Итератор + 1;
	КонецЦикла;
	
	//Компонуем отчет	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	Настройки = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
	СхемаКомпоновкиДанных = ОбъектОтчета.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки);
	
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);
	
	//Выводим результат в наши таблицы
	Итератор = 0;
	
	Пока Истина Цикл		
		ЭлементРезультата = ПроцессорКомпоновки.Следующий();
		Если ЭлементРезультата = Неопределено Тогда
			МассивПроцессоровВыводаТаблиц[Итератор].ЗакончитьВывод();
			Прервать;
		Иначе	
			Если ЭлементРезультата.Макеты.Количество() > 0 Тогда
				Для Каждого ПроцессорВывода Из МассивПроцессоровВыводаТаблиц Цикл
					ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);					
				КонецЦикла;
			Иначе
				//Нужно подобрать условия, когда переходим на следующую страницу
				Если ЗначениеЗаполнено(ЭлементРезультата.ЗначенияПараметров) и ЭлементРезультата.ЗначенияПараметров.П1.Значение = "Разрыв" Тогда
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
					//Выводим конец нашей группировки разрыва страницы
					ЭлементРезультата = ПроцессорКомпоновки.Следующий();
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
					ЭлементРезультата = ПроцессорКомпоновки.Следующий();
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
					Итератор = Итератор + 1;
				Иначе
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
				КонецЕсли;
			КонецЕсли;			
		КонецЕсли; 
	КонецЦикла;
		
КонецПроцедуры

Сначала, запихиваем все табличные документы результата в массив и очищаем эти табличные документы.

Затем готовим процессоры вывода и пихаем их в свой массив. Суть метода в том, чтобы отчет скомпоновать один раз, а вот результат отчета вывести с помощью отдельных процессоров вывода для каждой таблицы. В цикле устанавливаем каждому процессору вывода свой табличный документ и начинаем вывод.

Последним этапом является вывод нашего результата отчета. Он происходит в немного модифицированном типовом цикле вывода.

Важный момент. Первый элемент результата СКД содержит все макеты результата, поэтому его нужно вывести во все табличные документы.

Чтобы определить момент, когда нужно перейти в новую таблицу для вывода следующей группировки я между группировками отчета добавил служебную группировку ПереходВДругуюТаблицу и в параметры отчета СКД новый параметр данных Разрыв, который и вывожу в этой служебной группировке. Это сделано, чтобы однозначно определить, что выводимый элемент отчета является сигналом к переходу на новую страницу. Для служебной группировки сделал условное оформление - Цвет фона, Цвет текста и Цвет границы - белый, чтобы не засорять нам отчет. Кстати, этот же метод можно использовать для вставки разрыва страницы после группировки в результате отчета, если для нашей служебной группировке настроить макет и добавить туда горизонтальный разделитель страницы.

Скачать файлы

Наименование Файл Версия Размер
Вывод результата отчета СКД в разные табличные документы:

.erf 31,65Kb
21.08.18
11
.erf 31,65Kb 11 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. A_Max 18 21.08.18 23:22 Сейчас в теме
На вскидку:

	МассивТаблиц = Новый Массив;
	МассивТаблиц.Добавить(Таблица1);
	МассивТаблиц.Добавить(Таблица2);
	МассивТаблиц.Добавить(Таблица3);
	МассивТаблиц.Добавить(Таблица4);
	МассивТаблиц.Добавить(Таблица5);
	МассивТаблиц.Добавить(Таблица6);
	МассивТаблиц.Добавить(Таблица7);
	МассивТаблиц.Добавить(ТаблицаДополнительно);
	
	МассивПроцессоровВыводаТаблиц = Новый Массив;
	Для Каждого Таблица из МассивТаблиц Цикл
		Таблица.Очистить();
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
		ПроцессорВывода.ОтображатьПроцентВывода = Ложь;
		ПроцессорВывода.УстановитьДокумент(Таблица);
		ПроцессорВывода.НачатьВывод();
	КонецЦикла;
Показать


И дальше вместо получения по индексу каждый раз лучше определить один раз
ТекущийПроцессорВывода=МассивПроцессоровВыводаТаблиц[Итератор];
2. Dipod 38 22.08.18 00:13 Сейчас в теме
(1)Согласен, в смысле стиля кода, так будет лучше.
3. acanta 13.01.19 16:44 Сейчас в теме
Спасибо, очень хороший метод. Можно так же сохранить отчет в табличные части документа и схему компоновки с отборами в реквизиты.
4. Dipod 38 14.01.19 10:20 Сейчас в теме
(3) О, я правильно понял, что этим способом можно воспользоваться для какого-то сложного заполнения документа средствами СКД? То есть, мы программно формируем отчет, а из отчета пишем не в табличный документ, а сразу в табличные части документа?

Очень интересная идея, спасибо.
Оставьте свое сообщение

См. также

Расширение: Темы для 1С: Предприятия Промо

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Расширение позволяет сменить цвет оформления для интерфейса Такси.

1 стартмани

10.02.2019    14914    69    spec8s    10    

Два способа реализации ABC-анализа контрагентов для БП 3.0

Практика программирования Оптовая торговля v8 БП3.0 Россия УУ Абонемент ($m)

В данной статье рассматриваются 2 способа реализации ABC анализа контрагентов для конфигурации Бухгалтерия предприятия 3.0 (версия  3.0.75.109).

1 стартмани

17.03.2020    2138    8    Астиг    8    

Задачка: Список всех документов за заданный период, используя СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Вывести все документы за заданный период, используя СКД.

1 стартмани

11.03.2020    2249    3    MaxxiMiliSan    7    

Шпаргалка разработчика для работы с формами Промо

Работа с интерфейсом v8 Россия Абонемент ($m)

Сборник помогает быстро освоить встроенный язык и средства конфигурирования при разработке обычных и управляемых форм.

3 стартмани

31.10.2018    15789    78    ELAM    3    

Отображение времени в документах и списках

Расширения Работа с интерфейсом v8 ЗУП3.x Абонемент ($m)

Расширение предназначено для отображения времени документов в списках и журналах, а также для ручного редактирования времени в открытых формах.

1 стартмани

10.03.2020    1853    0    Nuuq    4    

СКД: красивые надписи в заголовках колонок

Практика программирования Работа с интерфейсом v8 v8::СКД УПП1 Россия Абонемент ($m)

Необходимо немного исправить вывод надписей в заголовках колонок, сделать более читаемый вариант. Как это сделать?

2 стартмани

27.02.2020    10011    7    wowik    36    

Пример реализации HTML-формы календаря для мобильного приложения

Работа с интерфейсом Мобильная разработка v8::Mobile Абонемент ($m)

Реализация функциональной мобильной формы календаря, которая красиво трансформируется в список задач.

5 стартмани

13.02.2020    3817    11    ingeneerz@gmail.com    0    

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула Промо

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    41583    28    agent00mouse    0    

Прорыв и провал 3D графики в 1С

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Здравствуйте, уважаемые. Эта статья опоздала, хотя я спешил как мог. В любом случае, речь тут пойдет про WebGL и технологии работы с 3D в 1C. Сразу оговорюсь, что всё это работало до последнего времени и на тонком, толстом, вэб клиентах, платформах 8.3 и на 8.2. Единственное, что изменило ситуацию, это WebKit, внедренный в 1С начиная с релиза 8.3.14.1565.

1 стартмани

11.02.2020    6416    9    dinopopyys    23    

Скромный вклад в юзабилити

Работа с интерфейсом Рабочее место v8::УФ УТ11 Абонемент ($m)

Оптимизация рутинных действий. Вызов отчетов по Партнеру и Номенклатуре сразу из документа. Выбор объекта для журнала регистрации из открытых окон.

2 стартмани

11.02.2020    2980    5    andryandry    0    

Общая форма отчета (для отчета с СКД)

Работа с интерфейсом v8 v8::СКД Россия Абонемент ($m)

Единообразная форма отчёта для отчётов с СКД. Режим совместимости платформы должен быть не ниже версии 8.3.7.

1 стартмани

04.02.2020    2219    1    olegpkc    4    

Подборка иконок для подсистем 1С:8.2, 8.3 (740 шт.) PNG 48х48 Промо

Практика программирования Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

Подборка иконок для подсистем 1С: Предприятие 8.2, 8.3 (УП) в формате PNG 48*48 с сохранением прозрачности.

3 стартмани

19.12.2011    104992    194    Lesha1C    74    

Сохранение и изменение настроек форм у всех пользователей 1С: Документооборот

Документооборот и делопроизводство Расширения Работа с интерфейсом v8 v8::УФ ДО Абонемент ($m)

Расширение позволяет быстро и удобно сохранять и тиражировать настройки форм от Администратора всем пользователям программы.

5 стартмани

01.02.2020    5129    20    st_Etlau    2    

Примерная схема проведения документов (Механизм проведения) в ERP 2.5.x.x

Практика программирования v8 ERP2 Абонемент ($m)

Некий шаблон "общей" картины связи процедур выполняемых типовым механизмом проведения в ERP 2.5.

1 стартмани

27.01.2020    6260    11    s14adow    7    

Подпись в почтовом клиенте 1С управляемые формы HTML кодом

Работа с интерфейсом v8::УФ ERP2 УТ11 КА2 Абонемент ($m)

Хоть в 1С:Комплексная автоматизация 2.4 и есть возможность добавить подпись в формате HTML типовыми средствами, в форме создания подписи нет возможности размещения нескольких строк справа или слева от картинки, а также невозможно создать таблицу.

1 стартмани

23.01.2020    3045    0    DevilBit    0    

Изменение масштаба интерфейса "Такси" 1С (управляемые формы)

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка меняет текущему пользователю режим интерфейса "Такси" - крупный, мелкий, авто.

1 стартмани

13.01.2020    2643    3    Denr83    0    

Отчет на СКД с выводом остатков по всем датам периода для УТ 10.3 (обычные формы)

Практика программирования v8::СКД УТ10 Россия УУ Абонемент ($m)

Требовалось получить остатки на каждую дату периода с целью дальнейшего вывода в любых целях. В обработке используется вспомогательный макет СКД, из которого и получается таблица остатков. Далее ее просто вывожу через другое СКД, так как это просто пример. Вы можете встроить это себе в любую обработку.

1 стартмани

23.12.2019    3608    4    jump0    0    

Альтернатива меню "Все функции"

Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

Просмотр доступных объектов, когда не знаешь, где их найти, и недоступно меню "Все функции" Доступно с версии платформы 8.3.6.1977 (используется СтрРазделить()) Тестировалось на 8.3.11.

1 стартмани

07.12.2019    3783    5    user1217016    1    

Решение задач по мотивам статьи "30 задач. Странных и не очень"

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка по мотивам статьи: https://infostart.ru/public/1161686/

1 стартмани

04.12.2019    3159    2    batsy66    9    

Программное добавление параметров редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

В данной публикации приводится пример программного добавления параметров редактирования для поля выборки в СКД.

1 стартмани

25.11.2019    5953    1    Isonic    8    

Динамическое управление свойствами реквизитов управляемых форм

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Расширение позволяет для указанных пользователей или роли динамически изменять доступность, видимость и заголовок реквизитов форм справочников или документов.

1 стартмани

20.11.2019    4913    10    shalex5    5    

Наглядные доп.реквизиты товара в табличной части документа за 5 минут

Розничная торговля Учет ТМЦ Работа с интерфейсом Производство Управление торговлей v8::УФ Розница ERP2 УТ11 КА2 УУ Абонемент ($m)

Это расширение конфигурации даёт возможность отображать произвольные "дополнительные реквизиты" Номенклатуры и Характеристик в колонках табличной части «Товары». Позволяет свои настройки доп.реквизитов для каждого пользователя и для каждого типа документа. Без программиста и без конфигуратора, подключи в базу файл, задай настройки и получи в документах СВОИ столбцы с доп.данными о товаре.

3 стартмани

20.11.2019    5867    14    itsmith    12    

Список открытых форм (УФ)

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Обработка, показывающая список форм открытых окон в текущем сеансе (УФ).

1 стартмани

20.11.2019    2843    1    darkultro37    0    

Формы открытых окон

Работа с интерфейсом v8::УФ 1cv8.cf Абонемент ($m)

Какие формы сейчас открыты? Обработка ответит на этот вопрос.

1 стартмани

12.11.2019    3195    1    user1214217    1    

html + css + js в поле HTML документа 1С на примере решения задачи ханойских башен

Практика программирования v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Рассматривается пример использования html + css + js в полеHTMLдокумента 1с. Вызов функций javascript со стороны 1С с передачей параметров. Решение головоломки "Ханойская башня" с визуализацией в среде 1С.

1 стартмани

11.11.2019    6415    9    mangushov    0    

Коллекция иконок Material Design для 1С

Работа с интерфейсом v8 Абонемент ($m)

Стандартная коллекция иконок от Google, импортированная в отдельную конфигурацию для удобного использования в различных проектах.

1 стартмани

06.11.2019    7199    41    L0z4    6    

"Все функции" с плюшками

Универсальные обработки Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Замена штатному меню для тех, кто хочет открывать "Все функции" быстро и кто скучает по быстрому позиционированию по первым символам как было раньше

1 стартмани

06.11.2019    6602    20    codejs    6    

Отображение дополнительных сведений на форме документа как реквизитов

Обработка документов Работа с интерфейсом v8 v8::БУ БП3.0 Россия Абонемент ($m)

Расширение позволяет редактировать дополнительные сведения не в отдельно открываемом окне, а непосредственно на форме документа.

1 стартмани

05.11.2019    10228    20    9269477065    15    

Кадровый отчет сохранением и загрузкой настроек в Камин 3.5

Зарплата Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

Доработан "Кадровый отчет с "понятным" сохранением и загрузкой настроек в конфигурации КАМИН:Расчет заработной платы для бюджетных учреждений. Версия 3.5.

1 стартмани

25.10.2019    4064    1    dendzu    0    

Пример вывода картинок в отчете на СКД.

Работа с интерфейсом v8::СКД ERP2 УТ11 КА2 Абонемент ($m)

Коллеги, в данной публикации я хочу поделиться отчетом "Остатки и доступность товаров" для ERP 2.4, КА 2.4, УТ 11 с выводом картинок.

1 стартмани

21.10.2019    4187    3    pavelpribytkin96    0    

Инициалы имени иностранного сотрудника в ЗУП 3.1

Практика программирования Печатные формы документов v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Решение проблемы лишнего дефиса в двойном имени иностранного сотрудника с помощью простого расширения.

1 стартмани

10.10.2019    4785    0    accounting_cons    2    

Индикатор выполнения (прогресс-бар) с таймером остаточного времени выполнения (обычное приложение + УФ)

Практика программирования Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Индикатор (прогресс-бар) - элемент формы, отображающий ход выполнения операций по счетчику. В данном решении разработана возможность отслеживания остаточного времени выполнения.

1 стартмани

08.10.2019    5360    13    slayer-ekb    5    

Быстрый просмотр табличной части "Товары" без открытия формы документа

Работа с интерфейсом v8 v8::ОУ v8::УФ УТ11 УУ Абонемент ($m)

Разработка позволят осуществить "быстрый просмотр" табличных частей документов "Реализация товаров и услуг", "Корректировка реализации", "Возврат товаров от клиента" из формы списка "Документы продажи (все)" без необходимости открытия формы просматриваемого документа.

2 стартмани

08.10.2019    3832    8    simuljakr    6    

Заголовок окна операционной системы при работе под управлением ОС Windows в терминальном режиме или в режиме удаленного рабочего стола (Такси)

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

После перехода на версию 8.3.15 переключение вариантов отображения главного окна приложения выполняется автоматически, в зависимости от того, в какой ОС и каком окружении запускается клиентское приложение. Кроме того, при работе клиентского приложения в ОС Windows имеется возможность управления отображением заголовка ОС с помощью методов ПолучитьОтображениеЗаголовкаОС()/УстановитьОтображениеЗаголовкаОС() объекта КлиентскоеПриложение. Установить отображение заголовка окна ОС можно только в обработчике события ПередНачаломРаботыСистемы.

1 стартмани

17.09.2019    2683    1    tsatsur    8    

Картинки конфигурации

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда перед разработчиками 1С встает вопрос: есть ли подходящая общая картинка в конфигурации или нужно рисовать свою для кнопки? А какие вообще картинки есть в конфигурации и какие у них размеры? Поиск подходящей картинки через конфигуратор мне показался не совсем удобным, поэтому и появился отчет по общим картинкам конфигурации. Отчет универсальный, должен работать в любой конфигурации и на обычных, и на управляемых формах. Важно: версия платформы 1С должна быть 8.3.14 или выше.

1 стартмани

10.09.2019    5217    16    rusmil    6    

Пример простого и приятного внешнего HTML интерфейса для мобильного приложения

Работа с интерфейсом Мобильная разработка v8::Mobile Абонемент ($m)

Реализация простого и приятного внешнего HTML интерфейса для мобильного приложения. Делимся исходниками, чтобы разработчики мобильных приложений разрабатывали больше приятных интерфейсов для приложений.

5 стартмани

05.09.2019    7867    60    Baksheev-Nikita    13    

Дополнительная анимация при построении отчетов в ЗУП 3.1

Работа с интерфейсом v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Расширение для ЗУП 3.1, которое позволяет назначить произвольным пользователям дополнительные анимационные картинки при формировании отчетов. Данное расширение создавалось под концепцию геймификации ЗУП, целью разработки было пробудить дополнительный интерес пользователей к использованию отчетов и PR ИТ службы.

3 стартмани

30.08.2019    3209    1    Silenser    2    

Вывод напоминаний со звуком

Работа с интерфейсом v8 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Вывод напоминания пользователю со звуком для привлечения внимания.

1 стартмани

29.08.2019    3118    7    Kutuzov    11    

Как изменить видимость, доступность и взаимозависимости дополнительных реквизитов видов номенклатуры в 1С:ERP?

Работа с интерфейсом v8::УФ ERP2 Россия Абонемент ($m)

Как изменить видимость, доступность и взаимозависимости дополнительных реквизитов видов номенклатуры в 1С:ERP? Есть решение, а точнее расширение для типовой конфигурации, которое не потребует снимать её с полной поддержки.

1 стартмани

26.08.2019    4444    9    Igor030370    1    

Формирование внешнего отчета в фоне

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Принципы формирования внешнего отчета в фоновом режиме. Используя стандартную форму отчета БСП или свою. Вопросы передачи параметров от команды внешнего отчета в фоновом процессе к ожидающей завершения процедуре формы.

1 стартмани

07.08.2019    8950    4    partizand    14    

Расчет сложных итогов СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Малоизвестный прием для расчета итогов в отчетах на СКД.

1 стартмани

05.08.2019    20124    16    masterkio    17    

Иерархическая нумерация в отчете СКД с помощью макета поля

Практика программирования Разработка v8 v8::СКД 1cv8.cf Абонемент ($m)

Представляю Вашему вниманию вариант решения задачи нумерации строк иерархического отчета на СКД.

1 стартмани

28.06.2019    7969    5    Isonic    14    

Перемещение дополнительных реквизитов на форме

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Перемещение дополнительных реквизитов, без изменения конфигурации (расширение) (конфигурация остается типовой).

5 стартмани

27.06.2019    2551    3    sulig    3