Вывод результата отчета СКД в разные табличные документы

21.08.18

Разработка - СКД

В ходе выполнения своей повседневной работы столкнулся с интересной клиентской задачей - требовалось результат отчета СКД вывести на форму отчета в разные вкладки формы в разные табличные документы. Как оказалось, информации по такому выводу отчета в интернете маловато, поэтому решил скомпоновать свой опыт решения этой задачи в одной статье.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Вывод результата отчета СКД в разные табличные документы:
.erf 31,65Kb
31
31
1 SM
Скачать Купить за 1 850 руб.

Дано:

-Отчет на СКД с кучей независимых друг от друга группировок.

-Форма отчета со страницами и табличными документами результата отчета на них.

Требуется вывести каждую группировку в соответствующий ей табличный документ.

Что я сделал:

На форме отчета сделал свою кнопку "Сформировать". Событием "ПриКомпоновкеРезультата" не удалось воспользоваться, т.к. из этого события нет доступа к табличным документам на форме отчета.

В процедуре вывода отчета используем следующий код:

&НаКлиенте
Процедура СформироватьОтчет(Команда)
	СформироватьОтчетНаСервере();
КонецПроцедуры

&НаСервере
Процедура СформироватьОтчетНаСервере()
	
	ОбъектОтчета = РеквизитФормыВЗначение("Отчет");
	
	//Подготавливаем таблицы отчета для вывода
	МассивТаблиц = Новый Массив;
	МассивТаблиц.Добавить(Таблица1);
	МассивТаблиц.Добавить(Таблица2);
	МассивТаблиц.Добавить(Таблица3);
	МассивТаблиц.Добавить(Таблица4);
	МассивТаблиц.Добавить(Таблица5);
	МассивТаблиц.Добавить(Таблица6);
	МассивТаблиц.Добавить(Таблица7);
	МассивТаблиц.Добавить(ТаблицаДополнительно);
	
	Для Каждого Таблица из МассивТаблиц Цикл
		Таблица.Очистить();	
	КонецЦикла;
	
	//Подготавливаем процессоры вывода для каждой таблицы
	МассивПроцессоровВыводаТаблиц = Новый Массив;
	ПроцессорВывода1 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода2 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода3 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода4 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода5 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода6 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода7 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВыводаДополнительно = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода1);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода2);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода3);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода4);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода5);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода6);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода7);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВыводаДополнительно);
	
	Итератор = 0;
	Для Каждого ПроцессорВывода из МассивПроцессоровВыводаТаблиц Цикл
		ПроцессорВывода.ОтображатьПроцентВывода = Ложь;
		ПроцессорВывода.УстановитьДокумент(МассивТаблиц[Итератор]);
		ПроцессорВывода.НачатьВывод();
		Итератор = Итератор + 1;
	КонецЦикла;
	
	//Компонуем отчет	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	Настройки = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
	СхемаКомпоновкиДанных = ОбъектОтчета.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки);
	
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);
	
	//Выводим результат в наши таблицы
	Итератор = 0;
	
	Пока Истина Цикл		
		ЭлементРезультата = ПроцессорКомпоновки.Следующий();
		Если ЭлементРезультата = Неопределено Тогда
			МассивПроцессоровВыводаТаблиц[Итератор].ЗакончитьВывод();
			Прервать;
		Иначе	
			Если ЭлементРезультата.Макеты.Количество() > 0 Тогда
				Для Каждого ПроцессорВывода Из МассивПроцессоровВыводаТаблиц Цикл
					ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);					
				КонецЦикла;
			Иначе
				//Нужно подобрать условия, когда переходим на следующую страницу
				Если ЗначениеЗаполнено(ЭлементРезультата.ЗначенияПараметров) и ЭлементРезультата.ЗначенияПараметров.П1.Значение = "Разрыв" Тогда
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
					//Выводим конец нашей группировки разрыва страницы
					ЭлементРезультата = ПроцессорКомпоновки.Следующий();
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
					ЭлементРезультата = ПроцессорКомпоновки.Следующий();
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
					Итератор = Итератор + 1;
				Иначе
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
				КонецЕсли;
			КонецЕсли;			
		КонецЕсли; 
	КонецЦикла;
		
КонецПроцедуры

Сначала, запихиваем все табличные документы результата в массив и очищаем эти табличные документы.

Затем готовим процессоры вывода и пихаем их в свой массив. Суть метода в том, чтобы отчет скомпоновать один раз, а вот результат отчета вывести с помощью отдельных процессоров вывода для каждой таблицы. В цикле устанавливаем каждому процессору вывода свой табличный документ и начинаем вывод.

Последним этапом является вывод нашего результата отчета. Он происходит в немного модифицированном типовом цикле вывода.

Важный момент. Первый элемент результата СКД содержит все макеты результата, поэтому его нужно вывести во все табличные документы.

Чтобы определить момент, когда нужно перейти в новую таблицу для вывода следующей группировки я между группировками отчета добавил служебную группировку ПереходВДругуюТаблицу и в параметры отчета СКД новый параметр данных Разрыв, который и вывожу в этой служебной группировке. Это сделано, чтобы однозначно определить, что выводимый элемент отчета является сигналом к переходу на новую страницу. Для служебной группировки сделал условное оформление - Цвет фона, Цвет текста и Цвет границы - белый, чтобы не засорять нам отчет. Кстати, этот же метод можно использовать для вставки разрыва страницы после группировки в результате отчета, если для нашей служебной группировке настроить макет и добавить туда горизонтальный разделитель страницы.

Отчет СКД программный вывод результата

См. также

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    140527    770    391    

803

Запросы СКД Программист Стажер Система компоновки данных Россия Бесплатно (free)

Часто при разработке отчетов в СКД возникает ситуация, когда не совсем понятно, почему отчет выводит не те данные, которые нужны, либо не выводит вовсе. Возникает потребность увидеть конечный запрос, который формирует СКД. Как это сделать, рассмотрим в этой статье.

15.05.2024    5188    implecs_team    6    

43

Инструментарий разработчика СКД Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

По выбранной схеме компоновки данных генерирует программный код, который генерирует СКД, аналогичную исходной схеме. Есть дополнительные инструменты для просмотра дерева схемы, сравнение исходной схемы и полученной по коду, а также сравнение изменений в сгенерированном коде для исходной схемы и для измененной.

3 стартмани

05.02.2024    5558    43    obmailok    21    

78

Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Есть список полей в виде текста, или запрос - закидываем в набор СКД.

1 стартмани

31.01.2024    2574    2    Yashazz    0    

33

СКД WEB-интеграция Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Долгое время поддерживаю web-портал, в котором появилась необходимость создавать отчеты. Просмотрев различные фреймворки на js, я решил сделать свое решение, которое позволяло бы быстро разрабатывать и добавлять новые отчеты на web-портал.

2 стартмани

11.12.2023    9456    21    John_d    25    

124

СКД Программист Платформа 1С v8.3 Система компоновки данных Конфигурации 1cv8 Бесплатно (free)

Рассмотрим еще не получивший широкого распространения способ работы с внешними данным в СКД. В процессе обсуждения работы с СКД выяснилось, что многие не знакомы со способом помещения туда временной таблицы, полученной предварительно. Статья будет полезна разработчикам, знакомым с программным созданием СКД.

05.12.2023    6187    PROSTO-1C    13    

67
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. A_Max 20 21.08.18 23:22 Сейчас в теме
На вскидку:

	МассивТаблиц = Новый Массив;
	МассивТаблиц.Добавить(Таблица1);
	МассивТаблиц.Добавить(Таблица2);
	МассивТаблиц.Добавить(Таблица3);
	МассивТаблиц.Добавить(Таблица4);
	МассивТаблиц.Добавить(Таблица5);
	МассивТаблиц.Добавить(Таблица6);
	МассивТаблиц.Добавить(Таблица7);
	МассивТаблиц.Добавить(ТаблицаДополнительно);
	
	МассивПроцессоровВыводаТаблиц = Новый Массив;
	Для Каждого Таблица из МассивТаблиц Цикл
		Таблица.Очистить();
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
		ПроцессорВывода.ОтображатьПроцентВывода = Ложь;
		ПроцессорВывода.УстановитьДокумент(Таблица);
		ПроцессорВывода.НачатьВывод();
	КонецЦикла;
Показать


И дальше вместо получения по индексу каждый раз лучше определить один раз
ТекущийПроцессорВывода=МассивПроцессоровВыводаТаблиц[Итератор];
2. Dipod 114 22.08.18 00:13 Сейчас в теме
(1)Согласен, в смысле стиля кода, так будет лучше.
3. acanta 13.01.19 16:44 Сейчас в теме
Спасибо, очень хороший метод. Можно так же сохранить отчет в табличные части документа и схему компоновки с отборами в реквизиты.
4. Dipod 114 14.01.19 10:20 Сейчас в теме
(3) О, я правильно понял, что этим способом можно воспользоваться для какого-то сложного заполнения документа средствами СКД? То есть, мы программно формируем отчет, а из отчета пишем не в табличный документ, а сразу в табличные части документа?

Очень интересная идея, спасибо.
5. user2069633 26.03.24 10:58 Сейчас в теме
(4) Попробовал использовать ваш код для того чтобы вывести таблицы отчета в два столбца (всего шесть таблиц) и что-то не вышло. Вывожу результат в два разных табдока, потом вывожу их в Документ результат. По-одному выводятся, вместе нет, точнее второй табдок не выводится.
Не подскажете в чем может быть дело?
6. Dipod 114 26.03.24 11:04 Сейчас в теме
(5) Скиньте свой код, хотя бы :-)
7. user2069633 26.03.24 12:19 Сейчас в теме
(6)
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка 	= Ложь;
	
	СхемаКомпоновкиДанных 			= ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
	НастройкиКомпоновки 			= КомпоновщикНастроек.ПолучитьНастройки();
	
	КоллекцияПараметров 			= НастройкиКомпоновки.ПараметрыДанных;  
	
	Параметр_ПериодСклад 			= КоллекцияПараметров.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ПериодСклад"));
	Параметр_ПериодСкладЗначение 	= Параметр_ПериодСклад.Значение;
	
	ПериодСкладДатаНачала 			= Параметр_ПериодСкладЗначение.ДатаНачала;
	ПериодСкладДатаОкончания 		= Параметр_ПериодСкладЗначение.ДатаОкончания;
			
	Если ПериодСкладДатаНачала = НачалоГода(ПериодСкладДатаНачала) И ПериодСкладДатаОкончания = КонецГода(ПериодСкладДатаОкончания) Тогда
		
		НачалоПериодаСкладПредыдущий 	= ДобавитьМесяц(ПериодСкладДатаНачала, -12);
		КонецПериодаСкладПредыдущий 	= КонецГода(НачалоПериодаСкладПредыдущий);
		
	ИначеЕсли ПериодСкладДатаНачала = НачалоКвартала(ПериодСкладДатаНачала) И ПериодСкладДатаОкончания = КонецКвартала(ПериодСкладДатаОкончания) Тогда
		
		НачалоПериодаСкладПредыдущий 	= ДобавитьМесяц(ПериодСкладДатаНачала, -3);
		КонецПериодаСкладПредыдущий 	= КонецКвартала(НачалоПериодаСкладПредыдущий);
		
	ИначеЕсли ПериодСкладДатаНачала = НачалоМесяца(ПериодСкладДатаНачала) И ПериодСкладДатаОкончания = КонецМесяца(ПериодСкладДатаОкончания) Тогда
		
		НачалоПериодаСкладПредыдущий 	= ДобавитьМесяц(ПериодСкладДатаНачала, -1);
		КонецПериодаСкладПредыдущий 	= КонецМесяца(НачалоПериодаСкладПредыдущий);
		
	Иначе 
		
		РазностьДат 					= ПериодСкладДатаОкончания - ПериодСкладДатаНачала; 	
	    НачалоПериодаСкладПредыдущий 	= ПериодСкладДатаНачала - РазностьДат - 1;
	    КонецПериодаСкладПредыдущий 	= НачалоПериодаСкладПредыдущий + РазностьДат;
		
	КонецЕсли; 
	
	КоллекцияПараметров.УстановитьЗначениеПараметра("НачалоПериодаСкладПредыдущий", НачалоПериодаСкладПредыдущий);
	КоллекцияПараметров.УстановитьЗначениеПараметра("КонецПериодаСкладПредыдущий", КонецПериодаСкладПредыдущий); 
	
	КомпоновщикМакета 	= Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки 	= КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных,НастройкиКомпоновки,ДанныеРасшифровки);
	
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,,ДанныеРасшифровки); 
	
	МакетВывода = ПолучитьМакет("ДвеКолонки");
	//ЛеваяКолонка = МакетВывода.ПолучитьОбласть("ЛеваяКолонка");
	//ПраваяКолонка = МакетВывода.ПолучитьОбласть("ПраваяКолонка");
	
	МассивТаблиц = Новый Массив;
	МассивТаблиц.Добавить(МакетВывода.ПолучитьОбласть("ЛеваяКолонка"));
	МассивТаблиц.Добавить(МакетВывода.ПолучитьОбласть("ЛеваяКолонка")); 
	
	МассивПроцессоровВыводаТаблиц = Новый Массив; 
	ПроцессорВывода1 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода2 = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент; 
	
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода1);
	МассивПроцессоровВыводаТаблиц.Добавить(ПроцессорВывода2);
	
	Итератор = 0;
	Для Каждого ПроцессорВывода из МассивПроцессоровВыводаТаблиц Цикл
		ПроцессорВывода.ОтображатьПроцентВывода = Ложь;
		ПроцессорВывода.УстановитьДокумент(МассивТаблиц[Итератор]);
		ПроцессорВывода.НачатьВывод();
		Итератор = Итератор + 1;
	КонецЦикла;
		
	//Выводим результат в наши таблицы
	Итератор = 0;
	
	Пока Истина Цикл		
		ЭлементРезультата = ПроцессорКомпоновки.Следующий();
		Если ЭлементРезультата = Неопределено Тогда
			МассивПроцессоровВыводаТаблиц[Итератор].ЗакончитьВывод();
			Прервать;
		Иначе	
			Если ЭлементРезультата.Макеты.Количество() > 0 Тогда
				Для Каждого ПроцессорВывода Из МассивПроцессоровВыводаТаблиц Цикл
					ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);					
				КонецЦикла;
			Иначе
				//Нужно подобрать условия, когда переходим на следующую страницу
				Если ЗначениеЗаполнено(ЭлементРезультата.ЗначенияПараметров) и ЭлементРезультата.ЗначенияПараметров.П1.Значение = "Разрыв" Тогда
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
					//Выводим конец нашей группировки разрыва страницы
					ЭлементРезультата = ПроцессорКомпоновки.Следующий();
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
					ЭлементРезультата = ПроцессорКомпоновки.Следующий();
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
					Итератор = Итератор + 1;
				Иначе
					МассивПроцессоровВыводаТаблиц[Итератор].ВывестиЭлемент(ЭлементРезультата);
				КонецЕсли;
			КонецЕсли;			
		КонецЕсли; 
	КонецЦикла;
			
	
	
	ДокументРезультат.Вывести(МассивТаблиц[0]);
	ДокументРезультат.Присоединить(МассивТаблиц[1]);
	
	ДокументРезультат.ОтображатьСетку = Ложь;
	ДокументРезультат.ПоказатьУровеньГруппировокСтрок(2);
	
КонецПроцедуры
Показать
9. Dipod 114 26.03.24 12:50 Сейчас в теме
8. Dipod 114 26.03.24 12:49 Сейчас в теме
МассивТаблиц = Новый Массив;
    МассивТаблиц.Добавить(МакетВывода.ПолучитьОбласть("ЛеваяКолонка"));
    МассивТаблиц.Добавить(МакетВывода.ПолучитьОбласть("ЛеваяКолонка")); 


Может проблема в том, что тут дважды область "Левая колонка"?
10. user2069633 26.03.24 14:00 Сейчас в теме
(8)нет, можно разные области получить, результат тот же
обе табдока заполняются (по отладке видно), но выводится только первый
если вывод первого табдока закоментировать, то второй выводится
есть такое ощущение, что оба табдока выводятся в ДокументРезультат, но отображается только первый
может первый результат компоновки выводить надо только в первом столбце?
Оставьте свое сообщение