Имитация наследования для методов документов.

Публикация № 893818

Разработка - Практика программирования

ООП практика программирования

Если Вы делали несколько похожих документов, то Вам приходилось раз за разом вставлять одни и те же обработчики в стандартные процедуры (ПриСозданииНаСервере, ПриОткрытии, ПередЗаписью и т. д.). Даже если они уже убраны в общие модули, с течением времени их может стать много - подсистемы печати, доп. отчетов и обработок, заполнение по умолчанию, контроль активности пользователей, APDEX и еще много чего может быть придумано. С течением времени махина становится неповоротливой, а пользователи жалуются что в разных документах все работает по разному. Один из вариантов решения проблемы - под катом.

В большинстве современных языков программирования подобные проблемы решаются с помощью наследования, когда наследующий объект получает все свойства родителя. В 1С наследования по умолчанию нет. Но мы же программисты, и ничто не запрещает нам это построить! В данной статье я предлагаю одну из возможных реализаций. Она кажется мне достаточно простой и применимой на практике.

Ядром механизма будет функция

Функция УниверсальныйОбработчик(Источник, ИмяСобытия, Отказ = Ложь, ДополнительныеПараметры = Неопределено) Экспорт

Эту процедуру нужно вставить в соответствующие стандартные процедуры, например так:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ЭНГ_МодельООП.УниверсальныйОбработчик(ЭтаФорма, "ПриСозданииНаСервере");
КонецПроцедуры

При вызове эта процедура опросит дерево классов, задаваемое в модуле МодельООП. Например, так:

Функция ДеревоКлассов()
	СтруктураКлассов = Новый Структура;
	
	ДобавитьДеревоКлассовРеализации(СтруктураКлассов);
	
	Возврат СтруктураКлассов;
КонецФункции

Функция ДобавитьДеревоКлассовРеализации(Структура)
	
	Структура.Вставить("ДокументРеализации","");

    Структура.Вставить("РеализацияТоваровУслуг", "ДокументРеализации");
    Структура.Вставить("КорректировкаРеализации", "ДокументРеализации");
    
КонецФункции

Таким образом мы указали, что документы (в общем случае любые объекты; но документ и справочник с одинаковым именем будут одним классом) РеализацияТоваровУслуг и КорректировкаРеализации наследуются от родительского класса "ДокументРеализации" (не являющегося объектом метаданных), который является корневым элементом и не наследуется ни от чего.

Далее необходимо будет задать обработчики, которые мы хотим выполнить. Сделать это можно в процедуре СтрукутраОпераций. Например так:

Функция СтруктураОпераций(ИмяКласса, ИмяСобытия)
	СтруктураОпераций = Новый Структура;
	
	Если ИмяКласса = "ДокументРеализации" Тогда
		Возврат СтруктураОперацийДокументаРеализации(ИмяСобытия);
	КонецЕсли;
	
	Если ИмяКласса = "КорректировкаРеализации" Тогда
		Возврат СтруктураОперацийКорректировкиРеализации(ИмяСобытия);
	КонецЕсли;
	
	Возврат СтруктураОпераций;
КонецФункции

Функция СтруктураОперацийДокументаРеализации(ИмяСобытия)
	СтруктураОпераций = Новый Структура;
	
	Если ИмяСобытия = "ПриСозданииНаСервере" Тогда
		
		СтруктураОпераций.Вставить("ПриветИнфостарт",
		НовыйОбработчикСобытия("ЭНГ_Общее.ПриветИнфостарт()"));
		
		СтруктураОпераций.Вставить("УстановкаДаты",
		НовыйОбработчикСобытия("ЭНГ_Общее.УстановитьДатуДокумента(Источник)",,));
		
		СтруктураОпераций.Вставить("СообщениеСДатой",
		НовыйОбработчикСобытия("ЭНГ_Общее.СообщитьДатуДокумента(Источник)",,10));
	КонецЕсли;
	
	Возврат СтруктураОпераций;
КонецФункции

Функция СтруктураОперацийКорректировкиРеализации(ИмяСобытия)
	СтруктураОпераций = Новый Структура;
	
	Если ИмяСобытия = "ПриСозданииНаСервере" Тогда
		
		СтруктураОпераций.Вставить("ПриветИнфостарт",
		НовыйОбработчикСобытия("ЭНГ_Общее.ПриветИнфостарт()",-10));
		
	КонецЕсли;
	
	Возврат СтруктураОпераций;

КонецФункции




//В модуле ЭНГ_Общее

Процедура УстановитьДатуДокумента(Форма) Экспорт
    Форма.Объект.Дата = ТекущаяДата();
КонецПроцедуры

Процедура ПриветИнфостарт() Экспорт
    Сообщить("Привет Инфостарт");
КонецПроцедуры

Процедура СообщитьДатуДокумента(Форма) Экспорт
	Сообщить(""+Форма.Объект.Дата);
КонецПроцедуры


В данном примере проиллюстрированы возможности механизма. Результат работы примера можно посмотреть в прилагаемой конфигурации. Можно видеть, что т. к. Порядок обработчика "СообщениеСДатой" больше порядка "УстановитьДату", то сообщение происходит после установки. Кроме того, приветственное сообщение в КорректировкеРеализации не появляется, т. к. этот обработчик имеет более высокий по модулю (перекрывает унаследованный обработчик) и отрицательный (не выполняется) приоритет.

В приложенных файлах - конфигурация, демонстрирующая механизм. Кроме того, прикладываю полный листинг основного модуля:

#Область НастройкиООП

Функция СтруктураОпераций(ИмяКласса, ИмяСобытия)
	СтруктураОпераций = Новый Структура;
	
	Если ИмяКласса = "ДокументРеализации" Тогда
		Возврат СтруктураОперацийДокументаРеализации(ИмяСобытия);
	КонецЕсли;
	
	Если ИмяКласса = "КорректировкаРеализации" Тогда
		Возврат СтруктураОперацийКорректировкиРеализации(ИмяСобытия);
	КонецЕсли;
	
	Возврат СтруктураОпераций;
КонецФункции

//Функция возвращает дерево классов. Дерево представляет из себя структуру { Ключ: ИмяКласса, Значение: ИмяРодителя }.
//Если у класса нет родителя, ИмяРодителя должно быть пустой строкой.
//Классы бывают двух типов - объектные и виртуальные. 
//Объектные классы соответствуют объектам метаданных. При вызове Универссального Обработчика он определяет, какой класс его вызвал по метаданным переданного источника.
//Виртуальные классы - это произвольные строки. Они предназначены для группировки схожих Объектных классов.
//Дерево классов используется для определения структур операций.
Функция ДеревоКлассов()
	СтруктураКлассов = Новый Структура;
	
	ДобавитьДеревоКлассовРеализации(СтруктураКлассов);
	
	Возврат СтруктураКлассов;
КонецФункции

#КонецОбласти

#Область ДвижокООП
//Это входная точка движка. Данная процедура размещается в коде объектов.
//На вход необходимо передавать:
//Источник: ЭтаФорма при размещении в модуле формы, ЭтотОбъект при размещении в модуле объекта.
//ИмяСобытия: Имя процедуры, в которой размещен обработчик. Например, "ПриСозданииНаСервере".
//Отказ: если у процедуры, в которой размещен универсальный обработчик, есть параметр "Отказ", его можно передать сюда.
//В этом случае его можно будет использовать в Обработчиках Событий.
//В ходе выполнения функция получит все операции в соответствии с деревом классов и выполнит те, у которых неотрицательный приоритет.
Функция УниверсальныйОбработчик(Источник, ИмяСобытия, Отказ = Ложь, ДополнительныеПараметры = Неопределено) Экспорт
	ИмяКласса = ЭНГ_ОбщееСервер.ИмяМетаданных(ЭНГ_Формы.ИсточникДанных(Источник).Ссылка);
	ДеревоКлассов = ДеревоКлассов();
	СтруктураОпераций = СтруктураОперацийСНаследованием(ИмяКласса, ИмяСобытия, ДеревоКлассов);
	//Для сортировки операций, чтобы выполнять их в правильном порядке, используем сортировку списка значений.
	//Не используем таблицу потому что она недоступна на клиенте.
	//Эта же процедура убирает операции с отрицательным приоритетом, которые не нужно выполнять.
	УпорядоченныеОперации = УпорядоченныеОперации(СтруктураОпераций);
	Если УпорядоченныеОперации.Количество() = 0 Тогда
		ЭНГ_Общее.СлужебноеСообщение(
		"Модель ООП: предупреждение - для класса " + ИмяКласса + " и события " + ИмяСобытия + 
		" не определены выполняемые обработчики! Это может являться ошибкой"); 
	КонецЕсли;
	Для Каждого Элемент Из УпорядоченныеОперации Цикл
		Попытка
			Выполнить(СтруктураОпераций[Элемент.Представление].Код);
		Исключение
			ОписаниеОшибки = ОписаниеОшибки();
		КонецПопытки;
		Если Отказ Тогда
			Возврат Неопределено;
		КонецЕсли;
	КонецЦикла;
	
КонецФункции

//Эта процедура формирует список операций согласно дереву классов.
//При выполнении она идет вверх по дереву классов до тех пор, пока не находит класс без родителя.
//Этот класс считается корневым; функция получает для него структуру операций, где Ключ: ИмяОперации, Значение: ОбработчикСобытия(Структура).
//Дальше функция идет вниз по дереву классов, последовательно модифицируя список операций.
//Для каждого дочернего узла дерева получаем его структуру операций. Если её нет в структуре операций родителя, тогда добавляем.
//Если модифицируемая Операция уже есть в структуре операций, тогда сравниваем приоритет по модулю. Если приоритет новой операции ниже, тогда игнорируем эту модификацию.
//В противном случае полностью заменяем старый ОбработчикСобытия на новый.
Функция СтруктураОперацийСНаследованием(ИмяКласса, ИмяСобытия, ДеревоКлассов)
	Перем ИмяРодителя;
	Если НЕ ДеревоКлассов.Свойство(ИмяКласса, ИмяРодителя) Тогда
		Сообщить("Объект " + ИмяКласса + " обращается к механизму ООП, но не включен в иерархию классов! Необходимо добавить соответствующую запись в структуру, возвращаемую функцией ДеревоКлассов()");
		Возврат Новый Структура;
	КонецЕсли;
	Если ИмяРодителя = "" Тогда
		Возврат СтруктураОпераций(ИмяКласса, ИмяСобытия);
	КонецЕсли;
	СтруктураОперацийРодителя = СтруктураОперацийСНаследованием(ИмяРодителя, ИмяСобытия, ДеревоКлассов);
	СтруктураОпераций = СтруктураОпераций(ИмяКласса, ИмяСобытия);
	Для Каждого Элемент Из СтруктураОпераций Цикл
		Если НЕ СтруктураОперацийРодителя.Свойство(Элемент.Ключ) Тогда
			СтруктураОперацийРодителя.Вставить(Элемент.Ключ, Элемент.Значение);
			Продолжить;
		КонецЕсли;
		Если ЭНГ_Числа.Модуль(СтруктураОперацийРодителя[Элемент.Ключ].Приоритет) > ЭНГ_Числа.Модуль(Элемент.Значение.Приоритет) Тогда
			Продолжить;
		КонецЕсли;
		ЗаполнитьЗначенияСвойств(СтруктураОперацийРодителя[Элемент.Ключ], Элемент.Значение);
	КонецЦикла;
	Возврат СтруктураОперацийРодителя;
	
КонецФункции

//Создает структуру ОбработчикСобытия.
//Код: программный код, который будет выполнен через УниверсальныйОбработчик.
//Приоритет: величина по модулю определяет, насколько критиченм этот вариант по сравнению с другими. Знак определяет выполнение - если Приоритет отрицателен, ОбработчикСобытия выполнен не будет. 
//Порядок: определяет порядок выполнения, от меньшего к большему. Если порядки одинаковы, ОбработчикиСобытия выполнятся "как получится". 
Функция НовыйОбработчикСобытия(Код, Приоритет = 1, Порядок = 1)
	
	Структура = Новый Структура;
	
	Структура.Вставить("Код", Код);
	Структура.Вставить("Приоритет", Приоритет);
	Структура.Вставить("Порядок", Порядок);
	
	Возврат Структура;
	
КонецФункции

Функция УпорядоченныеОперации(СтруктураОпераций)
	СписокИменОпераций = Новый СписокЗначений;
	Для Каждого Элемент Из СтруктураОпераций Цикл
		Если Элемент.Значение.Приоритет < 0 Тогда
			Продолжить;
		КонецЕсли;
		СписокИменОпераций.Добавить(Элемент.Значение.Порядок,Элемент.Ключ);
	КонецЦикла;
	СписокИменОпераций.СортироватьПоЗначению();
	Возврат СписокИменОпераций;	
КонецФункции

#КонецОбласти

#Область ПрикладнойКод

Функция ДобавитьДеревоКлассовРеализации(Структура)
	
	Структура.Вставить("ДокументРеализации","");

    Структура.Вставить("РеализацияТоваровУслуг", "ДокументРеализации");
    Структура.Вставить("КорректировкаРеализации", "ДокументРеализации");
    
КонецФункции

Функция СтруктураОперацийДокументаРеализации(ИмяСобытия)
	СтруктураОпераций = Новый Структура;
	
	Если ИмяСобытия = "ПриСозданииНаСервере" Тогда
		
		СтруктураОпераций.Вставить("ПриветИнфостарт",
		НовыйОбработчикСобытия("ЭНГ_Общее.ПриветИнфостарт()"));
		
		СтруктураОпераций.Вставить("УстановкаДаты",
		НовыйОбработчикСобытия("ЭНГ_Общее.УстановитьДатуДокумента(Источник)",,));
		
		СтруктураОпераций.Вставить("СообщениеСДатой",
		НовыйОбработчикСобытия("ЭНГ_Общее.СообщитьДатуДокумента(Источник)",,10));
	КонецЕсли;
	
	Возврат СтруктураОпераций;
КонецФункции

Функция СтруктураОперацийКорректировкиРеализации(ИмяСобытия)
	СтруктураОпераций = Новый Структура;
	
	Если ИмяСобытия = "ПриСозданииНаСервере" Тогда
		
		СтруктураОпераций.Вставить("ПриветИнфостарт",
		НовыйОбработчикСобытия("ЭНГ_Общее.ПриветИнфостарт()",-10));
		
	КонецЕсли;
	
	Возврат СтруктураОпераций;

КонецФункции

#КонецОбласти

 

Скачать файлы

Наименование Файл Версия Размер
Демонстрационная конфигурация

.cf 20,04Kb
28.08.18
1
.cf 1.0.0.0 20,04Kb 1 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. CyberCerber 574 28.08.18 17:01 Сейчас в теме
"При вызове эта процедура опросит дерево классов, задаваемое в модуле МодельООП. Например, так:"
Кажется, картинка не вставилась
2. Enigma 28.08.18 17:11 Сейчас в теме
3. CyberCerber 574 28.08.18 17:13 Сейчас в теме
Идея понятна, но в итоге получается какой-то спагетти-код. ООП создан для упрощения работы со сложными системами, а тут если будет больше 10 документов в иерархии, уже черт ногу сломит.
Тут для красоты и удобства надо разбивать классы на модули, совпадающие с названием класса.
И использовать оператор Выполнить, хоть это и официально не рекомендуется.
В итоге будет не куча Если, а что-то типа Выполнить(ИмяКласса + "." + ИмяМетода + "(Параметры)")
albert.goncharov; o.nikolaev; +2 Ответить
5. albert.goncharov 86 01.09.18 16:03 Сейчас в теме
(3) Логичней как в БСП - имена методов в базовом классе известны заранее, и вызов идёт
Модуль.ИмяМетода(Параметры);
А Модуль получается предварительно из имени модуля с помощью Вычислить(ИмяМодуля)
4. Enigma 38 28.08.18 17:26 Сейчас в теме
Я думал о том, что все, связанное со специфическим классом, должно быть или в модуле менеджера соответствующего объекта метаданных, или в общем модуле. Но для решения первоначальной задачи, ради которой был построен механизм, больше подходило хранение всего в одном месте (16 классов, но максимальная глубина наследования только 2; итоговая структура получается вполне читаемая).

Выполнить используется в любом случае. К сожалению, 1С не дает возможности передать функцию в качестве переменной.
7. kote 516 07.07.19 16:36 Сейчас в теме
Наследование - зло и довольно быстро "цементирует" приложение лишая возможности внесения изменений

Используйте композицию - тот же момент наступит сильно позже

Код будет чище и проще для понимания

Потом, интересно было бы посмотреть как бы Вы предложили эмулировать миксины. По моему они без проблем могут быть встроены в вашу подсистему.
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    18620    4    m-rv    86    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    22135    21    Stepa86    44    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    16170    11    RonX01    10    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    20221    13    RocKeR_13    16    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    28906    86    m-rv    57    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    32988    51    dsdred    15    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    26252    26    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    42318    17    kalyaka    16    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    26648    19    mvxyz    17    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    28411    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    25554    49    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    40190    11    swimdog    41    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    26055    67    vasvl123    9    

Макет в СКД - пример всех возможных типовых вариантов

Практика программирования Инструментарий разработчика v8 v8::СКД 1cv8.cf Абонемент ($m)

Макет СКД: наглядное представление того, что, как и куда выводится при типовых настройках.

1 стартмани

09.11.2017    20481    76    freelancer    4    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    30184    128    PLAstic    54    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    21274    20    sasha777666    63    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    46328    36    Demanoidos    60    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    120447    13    signum2009    46    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    29679    112    romasna    49    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    26621    120    kiv1c    18    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    49418    35    ildarovich    41    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    20384    100    Alxby    21    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    19632    91    igel9780    22    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    23766    16    Anton64    22    

Загрузка файлов на сервер с прогрессом и докачкой

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    12198    53    mrstomak    21    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    35083    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    24918    132    Stepa86    15    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    26545    75    ZhokhovM    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    54509    7    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    58065    167    rozer    64    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    53945    19    arakelyan    18    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    32887    48    ildarovich    23    

Вывод печатных форм с запросом данных в форму "Печать документов" из подсистемы БСП "Печать".

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Все не раз видели, как в типовых конфигурациях, построенных на основе БСП (Библиотека стандартных подсистем), печатные формы, построенные на основе Табличного документа, выводятся в специальную форму "ПечатьДокументов". Эта форма входит в состав подсистемы "Печать" из БСП. При разработке своих печатных форм, иногда необходимо запросить у пользователя дополнительные данные необходимые для печати. Тут встает вопрос, как в этом случае вывести печатную форму в форму "Печать документа". В этой статье я рассмотрю, как реализовать вывод печатной формы в упомянутую форму из подсистемы "Печать", в случае если мы хотим перед выводом печатной формы запросить у пользователя дополнительные данные. Здесь будут рассмотрены два случая: когда реализуется печатная форма с использованием подсистемы "Дополнительные отчеты и обработки" и когда печатная форма добавляется в конфигурацию в режиме конфигуратора, т.е. вносятся изменения в типовую конфигурацию.

1 стартмани

29.03.2016    83384    166    lopatin    13    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    76573    152    igo1    53    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    17045    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    47599    50    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    51356    166    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    22045    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    35871    19    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    54294    47    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    87610    446    Luchik    202