Универсальный ввод на основании

Обработки - Обработка документов

87
Заполняет один произвольный документ на основании другого произвольного документа для 1с 8.2.
Работает для любой конфигурации.

Заполняет один произвольный документ на основании другого произвольного документа.

При этом заполняются шапка документа и табличные части при совпадении по наименованию
реквизитов документа основания и заполняемого документа.
Созданный и заполненный документ сразу в базу 1с не записывается, а открывается как новый.

87

Скачать файлы

Наименование Файл Версия Размер
Универсальный ввод на основании.epf
.epf 8,06Kb
27.09.11
605
.epf 8,06Kb 605 Скачать

См. также

Комментарии
Сортировка: Древо
0. Klinov 177 28.09.11 11:49 Сейчас в теме
Заполняет один произвольный документ на основании другого произвольного документа для 1с 8.2.
Работает для любой конфигурации.



Перейти к публикации

0. Klinov 177 28.09.11 11:49 Сейчас в теме
Заполняет один произвольный документ на основании другого произвольного документа для 1с 8.2.
Работает для любой конфигурации.



Перейти к публикации

1. boutinol 1 28.09.11 11:49 Сейчас в теме
Была обработка, которая еще и позволяла табличные части указывать, какая в какую загружать. Колонки сопоставлялись по наименованиям.
Эту качать не буду, видел код той обработки - все гениальное просто.
желаю успехов в доработке этой.
3. Klinov 177 28.09.11 13:30 Сейчас в теме
(1) Спасибо за пожелание успехов.
Время чуть появится, доработаю. В принципе думаю там недолго это реализовать.

(2) Чтобы данные перенеслись, необходимо чтобы совпадали наименования реквизитов (если для табличной части, то еще и наименование табличной части). Попробуйте заполнить, обработка сама ничего в базе не создает (кроме нового документа, который еще не записан в базу).
19. Trof@ 05.10.11 16:23 Сейчас в теме
23. sevipa 07.10.11 10:30 Сейчас в теме
(1) boutin

А может ту обработку в студию? очень нужна обработка у указанием табличных частей
24. boutinol 1 07.10.11 11:04 Сейчас в теме
(23) sevipa,Пользуюсь этой http://infostart.ru/public/19133/
но есть еще http://infostart.ru/public/22454/ .
Пользуйтесь поиском - он на сайте хорошо работает.
2. darin44 28.09.11 13:07 Сейчас в теме
а тип цен и скидки обработка переносит(например на основе Расходной накладной вводить Поступление товаров)?
4. Rus111 28.09.11 19:45 Сейчас в теме
Спасибо, бывают моменты, когда очень пригодится подобная вешь, только правда,
если бы она еще и табличные части заполняла - вот было бы здорово!
Не планируете доработать?
Если да, то когда?
5. Klinov 177 28.09.11 20:01 Сейчас в теме
(4) В данном варианте она табличные части заполняет при совпадении наименований табличных частей. Но в скором времени планирую дать возможность пользователю самому выбрать какую табличную часть "залить" в какую.
6. Rus111 28.09.11 20:46 Сейчас в теме
Понял, спасибо, это будет здорово, выбор - великая вещь...
А то возникают разные ситуации и когда есть возможность все сделать быстро - это очень хорошо!
7. Rus111 28.09.11 22:24 Сейчас в теме
Опробовал на УПП, работает, спасибо
8. Rus111 28.09.11 23:17 Сейчас в теме
Кстати, то, что я опробовал, табличная часть заполнилась.
Хорошо отрабатывает.
Попробую еще, пока не выявил неточностей.
Спасибо еще раз!
9. Rus111 28.09.11 23:21 Сейчас в теме
Да, я не уточнил, пробовал на УПП 8.2.1.3.16.1.
Заполнял на основании поступления возврат переданных товаров.
Все отработало на ура.
И шапка и подвал.
10. Одинец 242 29.09.11 00:58 Сейчас в теме
Для себя переделал как внешнюю печатную форму, чтоб можно было вызывать из любого документа с уже заполненным документом-основанием. Но и без этого обработка универсальна... МОЛОДЕЦ!
r00t; varkolak; Rus111; +3 Ответить
11. alex_fursov 4 29.09.11 12:23 Сейчас в теме
Полезная обработка. Однозначно плюс.
12. dkprim 5 29.09.11 17:41 Сейчас в теме
хорошая публикация и очень хочется увидеть поскорее развитие функционала :) автору спасибо :)
13. svetic 29.09.11 18:57 Сейчас в теме
Очень актуально, спасибо!
14. Rus111 29.09.11 23:32 Сейчас в теме
Одинец пишет:
Для себя переделал как внешнюю печатную форму, чтоб можно было вызывать из любого документа с уже заполненным документом-основанием. Но и без этого обработка универсальна... МОЛОДЕЦ! [+] [−] Прикрепленные файлы УниверсальныйВводДокументаНаОсновании82.epf (11.47 КБ) [ Скачать ]

Спасибо, тоже очень полезная штука.
Иногда может сэкономить кучу времени.
А иногда просто незаменима.
Респект за сие творение.
15. a31 29.09.11 23:35 Сейчас в теме
Одинец пишет:
Для себя переделал как внешнюю печатную форму, чтоб можно было вызывать из любого документа с уже заполненным документом-основанием. Но и без этого обработка универсальна... МОЛОДЕЦ! Прикрепленные файлы УниверсальныйВводДокументаНаОсновании82.epf (11.47 КБ)

Внешняя - как раз то что нужно, отлично
Спасибо!
16. dopolnenia 30.09.11 11:17 Сейчас в теме
Очень не хватает что бы и табличная часть заполнялась. Если кто знает пожалуйста сообщите где такую скачать (что бы заполнялась и табличная часть). А у этой буду ждать. Огромное спасибо автору.
17. Octopus 337 30.09.11 14:41 Сейчас в теме
Заполняется только для одного документа. Для своих нужд допилил, чтобы заполнялся по всем документам указанного вида.
18. IEmelya 02.10.11 21:13 Сейчас в теме
Спасибо! Очень нужная обработка.
20. dopolnenia 05.10.11 23:06 Сейчас в теме
Вопрос не в тему, а кто нибудь подскажет (если это возможно) как обработку 8.1 конвертнуть в 8.2
21. Alraune 1423 05.10.11 23:32 Сейчас в теме
(20) Открываете ее в конфигураторе 8.2, а там он сам все предложит сделать
22. Alexey55 07.10.11 10:01 Сейчас в теме
Спасибо! очень пригодилась!
25. 'njz 07.10.11 12:26 Сейчас в теме
Уважаемый автор! У меня Бух 8.2. для Украины.
Почему-то Ваша обработка не подключается.
Пишет: " Неверный формат хранилища данных " "Выбранный файл не является внешней обработкой. Либо данная обработка не предназначена для запуска в данной конфигурации". Помогите, пожалуйста, решить эту проблему.
Обработка просто необходима.
26. Klinov 177 07.10.11 12:52 Сейчас в теме
(25) проверьте расширение скачанного файла (должно быть epf)
27. KuponcheG 07.10.11 15:38 Сейчас в теме
28. СветикК 12.10.11 11:10 Сейчас в теме
29. demon852002 13.10.11 13:53 Сейчас в теме
Да и так есть ввод на основании! А вот с табличными частями - это интересно!
30. mg_ildar 14.10.11 09:15 Сейчас в теме
для любых конфигураций работает? кто пробовал?
31. vejda 14.10.11 22:52 Сейчас в теме
32. WKBAPKA 193 23.10.11 13:04 Сейчас в теме
и все же меня удивляет... в каталоге инфостарта есть куча работ, на которые время на разработку и знаний потрачено несравнимо больше ... написать такую обработку можно за пол часа, если возникнет необходимость, думать даже ничего не надо...
ВНИМАНИЕ!!!



Приемник = Документы[ИмяНовогоДокумента].СоздатьДокумент();
Приемник.Дата = ТекущаяДата();
Для Каждого Реквизит Из Источник.Метаданные().Реквизиты Цикл
  Если Приемник.Метаданные().Реквизиты.Найти(Реквизит.Имя) <> Неопределено Тогда 
    Приемник[Реквизит.Имя] = Источник[Реквизит.Имя];
  КонецЕсли;
КонецЦикла;

Для Каждого ТЧ Из Источник.Метаданные().ТабличныеЧасти Цикл
  Если Приемник.Метаданные().ТабличныйЧасти.Найти(ТЧ.Имя) <> Неопределено Тогда
    Для Каждого СтрокаИсточника Из Источник[ТЧ.Имя] Цикл
      СтрокаПриемника = Приемник[ТЧ.Имя].Добавить();
      Для Каждого Колонка Из ТЧ.Реквизиты Цикл
        СтрокаПриемника[Колонка.Имя] = СтрокаИсточника[Колонка.Имя];
      КонецЦикла;
    КонецЦикла;
  КонецЕсли;
КонецЦикла;

Приемник.Записать(РежимЗаписиДокумента.Запись); // или открыть форму нового документа, думаю, открыть лучше, т.к. при записи будут срабатывать проверки на незаполненные реквизиты!
Показать

можно еще типы значений реквизитов сравнивать для чегото не знаю для чего... но мало ли...
ух, за 5 минут написал...
Светлый ум; Shkipper; yku; AlexO; +4 Ответить
33. WKBAPKA 193 23.10.11 13:05 Сейчас в теме
demon852002 пишет:

Да и так есть ввод на основании! А вот с табличными частями - это интересно!

код с табличными частями выше...
боже, одни халявщики )
34. WKBAPKA 193 23.10.11 13:07 Сейчас в теме
СветикК пишет:

Зачетная обработка


35. dakinder 24.10.11 22:38 Сейчас в теме
36. dakinder 24.10.11 22:38 Сейчас в теме
Спасибо, очень хорошая обработка
38. napan 9 26.10.11 12:33 Сейчас в теме
Хорошая обработка, ничего не скажешь, мне понравилась, но пользуюсь все таки своими, свой труд, всегда лучше. Спасибо автору!
40. testy05 26.10.11 15:39 Сейчас в теме
41. mcarchi 27.10.11 19:00 Сейчас в теме
42. Zuzya_2 28.10.11 21:27 Сейчас в теме
работаем с БГУ, там практически везде реализован ввод на основании...даже не знаю куда ее приделать...а так вроде ничего.
44. ImPenguin 22 03.11.11 08:15 Сейчас в теме
Спасибо большое! Отличная обработка!!!
45. che444 13.11.11 11:14 Сейчас в теме
+ автору за еще один отличный инструмент в моем арсенале
46. itsimpossible 13.11.11 18:41 Сейчас в теме
Интересная обработка, спасибо попробую
47. camomile 16.11.11 10:09 Сейчас в теме
48. KliMich 22.11.11 22:52 Сейчас в теме
Спасибо! Полезная обработка! Попробую
49. AlexO 126 23.11.11 00:04 Сейчас в теме
"спасибо!""попробую!"
"класно отработала!"
"получилось! спасибо автору"
"Спасибо! Полезная обработка!"
а невдомек всем "авторам", что не обзови 1с одинаково реквизиты - и можно было бы выкинуть это все на помойку. вместе с поздравлениями.
да даже одни и теже доки из разных типровызх - с разными реквизитами. но "Спасибо! обработка отработала!"
а на самом деле - покупатель с поставщиком перепутаны...
ладно, ваши проблемы, раз во всем полагаетесь на "1с все предусмотрела!" и на "авторы обработок нам все сделают".
50. Dragonva 25.11.11 19:40 Сейчас в теме
Нужная обработка как опробую напишу недостатки если есть!
51. sevipa 06.12.11 23:29 Сейчас в теме
Спасибо! Скачал использую...
52. sb007 10.01.12 19:31 Сейчас в теме
мне понравилось и пригодилось. респект!
53. BalVlad 22.01.12 18:34 Сейчас в теме
Нужная обработка, спасибо!
54. Karglak 25.01.12 10:57 Сейчас в теме
Обработка нужная, можно доработать: ввод не по одному документу, а списком(или отбором); возможность задания соответствий табличных частей и реквизитов принудительно, так как часто названия не совпадают (СкладОтправитель --> СкладПолучатель). Удачи в дальнейших разработках.
55. Snowin 03.02.12 11:19 Сейчас в теме
Огромное спасибо за обработку! Перешли на 8.2 с 7.7 в которой формирование на основании работало из коробки. А в 8-ке почему то сразу работать отказалось. Надеюсь этой обработкой решим проблему. Попробую эту и ту в которой надо вручную задавать всё. Посмотрим какая из них будет лучше!
56. mute 19.02.12 14:44 Сейчас в теме
Здравствуйте! Помогите пожалуйста чайнику! Платформа 8.2.15.249 конф УТ 11.0.7.13 Скачал Вашу обработку,поскольку "самая продвинутая система учета 1с" не умеет "добавить из документа" как умела старенькая 7.7 .. зачем и почему так случилось - тайна покрытая мраком..Но! Я нашел Вашу обработку,которая возвращает прежний функционал..Но!!! Я не знаю как ее подключить,при добавлении внешней обработки пишет "Возможно, обработка (отчет) устарела или не является дополнительной:Метод объекта не обнаружен (СведенияОВнешнейОбработке)"
Я умею пользовать поиск ! Но! Он мне говорит что мне надо дописать функцию СведенияОВнешнейОбработке..извините меня дурака но я не умею писать функции! Я простой пользователь! Почему я внешнюю обработку не могу использовать ,как было во всех предыдущих версиях?? Помогите мне пожалуйста подключить Вашу чудесную обработку в мою как оказалось самую несовершенную систему учета! Спасибо!
60. AlexO 126 03.10.12 15:34 Сейчас в теме
(56) mute,
потому что на УФ, на чем написана УТ11, все в корне поменялось, в том числе - и подключение внешних обработок.
57. valya977 5 21.02.12 03:54 Сейчас в теме
Спасибо,полезная штука.Помогла сэкономить кучу времени.
58. antares_of 12 20.04.12 09:56 Сейчас в теме
А нет ли случайной такой же только для 7.7? Если кто видел ссылку в студию!
59. 1c8.2 03.10.12 15:25 Сейчас в теме
Плюсую!Отличная обработка. Спасибо. ТО что нужно!!!УРА!!!
61. serega3914 12.09.13 23:48 Сейчас в теме
Отличное решение некоторых проблем. +
62. yura1960 07.01.15 18:30 Сейчас в теме
Обработка - не зачет. Универсальность здесь заканчивается как только 1с-ники что-то поменяют. Да и написать такую может любой за пару часов. Здесь есть более универсальные. Поэтому соглашусь с AlexO. По крайней мере у меня подобных мулек штук 10 наваяно... Может их сюда выложить? Но один плюс - ребята копают и рано или поздно рождаются дельные вещи. Только за потуги поставим +
63. AlexO 126 12.01.15 11:53 Сейчас в теме
(62) yura1960, Эта тема у меня в избранном сугубо из-за сообщения 32 :)))
Да и написать такую может любой за пару часов.
Подобное этой обработке нет смысла писать, если нет конкретной задачи ввода на основании в конкретной конфе: вся привязка в ней - строго индивидуальна под задачи и конфы.
А если рассматривать обработку как пример - то сообщдение 32 дает все ответы и направления.
Оставьте свое сообщение