Особенность при создании своих ролей в конфигурациях на управляемых формах

Публикация № 932081

Администрирование - Информационная безопасность

Столкнулся с небольшой проблемкой при создании "своих" ролей в конфигураторе и добавлении их пользователям. Пользователю не добавляются созданные в конфигураторе роли, 1С 8.3, Управляемые формы. Гуглил много, ответа толкового не нашёл, поэтому пришлось разбираться самому и как результат, решил поделиться опытом. Возможно, кому-то пригодится.

Добрый день!

Столкнулся с небольшой проблемкой при создании "своих" ролей в конфигураторе и добавлении их пользователям. Гуглил много, ответа толкового не нашёл, поэтому пришлось разбираться самому и как результат, решил поделиться опытом. Возможно кому-то пригодится.

Итак, проблема заключалась в следующем:

В какой-либо конфигурации на управляемых формах создаём свою роль (или несколько ролей, как в примере) (см. рис.1), обновляем конфигурацию. В режиме предприятия создаём профиль групп доступа с нашей новой ролью (см. рис.2), добавляем пользователю этот профиль (см. рис.3) и... ничего не происходит, как-будто у этого пользователя не добавлена наша роль. Заходим в конфигуратор, администрирование, пользователи, заходим в пользователя, смотрим "доступные роли" и видим, что у нашего пользователя не выбрана наша роль (см. рис.4).

Почему так происходит? Всё очень просто, разработчики сделали так, что если пользователь "администратор", то есть у него полные права, то собственно говоря, зачем же ему ещё какие-то роли? Ведь у него же и так полные права!

В целом вполне логично и кстати если пользователь не администратор, то всё работает корректно (см. рис.5 и рис.6). Сложности возникают только в том случае, если мы хотим добавить нашу роль/роли пользователю с полными правами. Можно конечно просто в конфигураторе выбрать у пользователя нашу роль/роли, но всё будет работать ровно до тех пор, пока кто-нибудь не решит перезаписать в режиме предприятия права доступа у этого пользователя, после этого "галочка" у добавленной роли "слетит".

Что же делать и где это происходит?

Идём в общие модули - "УправлениеДоступомСлужебный", находим процедуру "ОбновитьРолиПользователей". В ней есть следующий код:

Если Администраторы[ТекущийПользователь] <> Неопределено Тогда
	ТекущиеНовыеРоли = НовыеРоли;
	НовыеРоли = ТекущиеНовыеРоли.Скопировать(Новый Массив);
	Для Каждого КлючИЗначение Из ОбязательныеРолиАдминистратора Цикл
		НовыеРоли.Добавить().Роль = КлючИЗначение.Ключ;
	КонецЦикла;
	Для Каждого КлючИЗначение Из ДополнительныеРолиАдминистратора Цикл
		Если ТекущиеНовыеРоли.Найти(КлючИЗначение.Ключ, "Роль") = Неопределено Тогда
			Продолжить;
		КонецЕсли;
		НовыеРоли.Добавить().Роль = КлючИЗначение.Ключ;
	КонецЦикла;	
КонецЕсли;

"НовыеРоли" это Таблица значений, в которой выбраны все роли пользователя, которые мы ему назначили в режиме предприятия (включая "наши" роли). Как видно далее по коду, эта таблица очищается, в неё добавляются "ОбязательныеРолиАдминистратора" (Администратор системы, Полные права) и если выбрано, "ДополнительныеРолиАдминистратора" (Интерактивное открытие внешних отчетов и обработок).

Как мне показалось, самый простой и очевидный вариант, это добавить "наши" роли в таблицу "НовыеРоли". Для этого нам надо как-то отделить эти роли от всех остальных, поэтому у всех добавленных нами в конфигураторе ролей, делаем префикс "Доп_". Те "наши" роли, которые мы выбрали для пользователя, собираем в массив "ВыбранныеДополнительныеРоли" и далее из этого массива добавляем роли в таблицу значений "НовыеРоли". Ниже представлен код:

Если Администраторы[ТекущийПользователь] <> Неопределено Тогда
	ТекущиеНовыеРоли = НовыеРоли;
	НовыеРоли = ТекущиеНовыеРоли.Скопировать(Новый Массив);
	Для Каждого КлючИЗначение Из ОбязательныеРолиАдминистратора Цикл
		НовыеРоли.Добавить().Роль = КлючИЗначение.Ключ;
	КонецЦикла;
	Для Каждого КлючИЗначение Из ДополнительныеРолиАдминистратора Цикл
		Если ТекущиеНовыеРоли.Найти(КлючИЗначение.Ключ, "Роль") = Неопределено Тогда
			Продолжить;
		КонецЕсли;
		НовыеРоли.Добавить().Роль = КлючИЗначение.Ключ;
	КонецЦикла;
	
	//Если для пользователя выбраны "наши" дополнительные роли, то добавляем их в таблицу "НовыеРоли"
	ВыбранныеДополнительныеРоли = Новый Массив;
	Для Каждого Стр Из ТекущиеНовыеРоли Цикл
		Если ВРег(Лев(Стр.Роль, 4)) = "ДОП_" Тогда
			ВыбранныеДополнительныеРоли.Добавить(Стр.Роль);
		КонецЕсли;
	КонецЦикла;
	Для Каждого Стр Из ВыбранныеДополнительныеРоли Цикл
		НовыеРоли.Добавить().Роль = Стр;
	КонецЦикла;
	
КонецЕсли;

И всё работает!

В заключение добавлю, процедура "ОбновитьРолиПользователей" абсолютна одинакова у многих конфигураций (благодаря "унификации" 1С), смотрел в УНФ 1.6, Бухгалтерия предприятия 3.0, Управление торговлей 11.4 (все конфигурации в нескольких версиях), поэтому сделал расширение, которое по идее должно работать на многих конфигурациях на управляемых формах. Можете скачать и добавить его себе, но предварительно не забудьте, что все добавленные роли должны иметь префикс "Доп_". Расширение написано на версии платформы: 8.3.12.1685. В расширение добавлен один общий модуль "УправлениеДоступомСлужебный", в котором только одна процедура "ОбновитьРолиПользователей" (&Вместо) с добавленным, по описанию выше, кодом. При добавлении расширения, не забываем снять галочки "безопасный режим" и "защита от опасных действий".

Скачать файлы

Наименование Файл Версия Размер
Расширение1 - Роли

.cfe 6,70Kb
28.10.18
10
.cfe 6,70Kb 10 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. PerlAmutor 107 29.10.18 12:05 Сейчас в теме
(0)
В заключение добавлю, процедура "ОбновитьРолиПользователей" абсолютна одинакова у многих конфигураций (благодаря "унификации" 1С), смотрел в УНФ 1.6, Бухгалтерия предприятия 3.0, Управление торговлей 11.4 (все конфигурации в нескольких версиях), поэтому сделал расширение,


В ERP 2.1.3.93 нет такого участка кода. Тоже заметил, что функция РольДоступна() с новой ролью срабатывает не всегда. А вот Пользователи.РолиДоступны() работает как надо, поэтому использую теперь её вместо встроенной.
2. A_Max 18 29.10.18 18:18 Сейчас в теме
(0) Потому что нужно придерживаться гайдлайнов от 1С и НЕ ИСПОЛЬЗОВАТЬ роль "Полные права" у реальных пользователей. Для администраторов заводятся специальные профили с определнным перечнем прави и эти особенные профили (как правильно заметил PerlAmutor) проверяются в функции Пользователи.РолиДоступны().

Так что, плохое решение предложено вами.
3. PerlAmutor 107 30.10.18 06:51 Сейчас в теме
Для полноты картины думаю правильным будет привести ссылку на "гайдлайн" от 1С: https://its.1c.ru/db/v8std/content/2149184386/hdoc
10. pvlunegov 158 18.03.20 12:22 Сейчас в теме
ваша ссылка уже не работает.
4. kwazi 399 30.10.18 11:10 Сейчас в теме
есть еще вариант решения проблемы.
Добавить в расширение роль Полные права и в ней дать права на объекты созданные в расширении.
BARBAROSSA88; +1 Ответить
5. almas 198 02.11.18 10:10 Сейчас в теме
Добрый день. Только вчера с ролями мучился. Хотел уже писать отдельную статью.

Ситуация такова: 1с ужесточили порядок назначения ролей.
Если пользователя включили в несколько групп доступа, то:
если вы включаете пользователя в группу администраторов в конфигураторе исчезают(снимаются галки) с ролей входящих в другие группы. Как только пользователя убираем из группы администратор - все восстанавливается.

Выход: скопировать роль полные права.
Создать профиль в котором добавить эту роль и создать отдельную группу "полные права без полных прав" включив в нее ранее созданный профиль.
6. orion_king 08.04.19 09:57 Сейчас в теме
Не проще ли разрешить добавлять новые роли администратору закомментив 1 строку?
//НовыеРоли = ТекущиеНовыеРоли.Скопировать(Новый Массив); // у администратора все равно добавлять роли
7. d.saladin 65 08.04.19 10:26 Сейчас в теме
(6) В таком случае у администратора будут добавлены вообще все выбранные роли. А в предложенном мной варианте, будут только те, что должны быть (Администратор системы, Полные права) и добавленные в конфигурацию роли с префиксом "Доп_".
8. orion_king 15.04.19 11:17 Сейчас в теме
А потом добавлять все роли с префиксом, если нужно другой префикс то его либо добавлять после "Доп_" либо вставлять еще кусок кода? (на мой взгляд лишний геморрой)

Гораздо проще и нужнее, на мой взгляд, добавлять то что именно ты ему проставил.
9. beerkeen 05.09.19 15:58 Сейчас в теме
Cамый простой и очевидный вариант - просто закомментарить этот кусок.
11. pvlunegov 158 18.03.20 12:36 Сейчас в теме
Огромное спасибо автору.
У меня была аналогичная ситуация. Конфигурация 1с ERP 2.4.8.82
Внес изменения в код общего модуля, все стало ок.
Должен заметить, доработал изменения в коде, обозначенные автором. Вот:
Код
   Если Администраторы[ТекущийПользователь] <> Неопределено Тогда
      ТекущиеНовыеРоли = НовыеРоли;
      НовыеРоли = ТекущиеНовыеРоли.Скопировать(Новый Массив);
      Для Каждого КлючИЗначение Из ОбязательныеРолиАдминистратора Цикл
         НовыеРоли.Добавить().Роль = КлючИЗначение.Ключ;
      КонецЦикла;
      Для Каждого КлючИЗначение Из ДополнительныеРолиАдминистратора Цикл
         Если ТекущиеНовыеРоли.Найти(КлючИЗначение.Ключ, "Роль") = Неопределено Тогда
            Продолжить;
         КонецЕсли;
         НовыеРоли.Добавить().Роль = КлючИЗначение.Ключ;
      КонецЦикла;
      
      //Если для пользователя выбраны "наши" дополнительные роли, то добавляем их в таблицу "НовыеРоли"
      
      // ДОБАВКИ +++
      Для каждого Строка Из ТекущиеНовыеРоли Цикл
         Если ВРег(Лев(Строка.Роль, 4)) = "рив_" или ВРег(Лев(Строка.Роль, 3)) = "ТС_" Тогда
            НовыеРоли.Добавить().Роль = Строка.Роль;
         КонецЕсли;
      КонецЦикла;
      // ДОБАВКИ ---
               
      ВыбранныеДополнительныеРоли = Новый Массив;
      Для Каждого Стр Из ТекущиеНовыеРоли Цикл
         Префикс = ВРег(Лев(Стр.Роль, 4));
         Если Префикс = "рив_" или Префикс = "ТС_" Тогда
            ВыбранныеДополнительныеРоли.Добавить(Стр.Роль);
         КонецЕсли;
      КонецЦикла;
      Для Каждого Стр Из ВыбранныеДополнительныеРоли Цикл
         НовыеРоли.Добавить().Роль = Стр;
      КонецЦикла;
   КонецЕсли;
Показать полностью
12. crash-16 27.03.20 15:46 Сейчас в теме
(11)
Как ВРег(Лев(Стр.Роль, 4)) может быть равно "ТС_"???

Другими словами как строка из 4 символов может быть равна строке из 3 символов?

Как ВРег(Лев(Стр.Роль, 4)) может быть равно "рив_"?

Зачем вы поднимаете в верхний регистр значение которое обрезаете и сравниваете его со строкой заведомо в нижнем?

Ну и самое главное зачем функционал добавок дублируется ниже, только через переменную?
13. resonance 27.06.20 03:03 Сейчас в теме
Мне помогло. Спасибо. Розница 2.2 (2.2.8.27)
Оставьте свое сообщение

См. также

Запуск 1С под любым пользователем (без необходимости указания пароля) Промо

Пароли v8 v8::Права 1cv8.cf Абонемент ($m)

Предназначается для запуска сеанса другого пользователя из своего сеанса 1С (если пароль вам неизвестен).

1 стартмани

02.07.2019    19824    197    sapervodichka    0    

Подсистема прав доступа к объектам с гибкими отборами (расширение)

Роли и права v8 ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Возможность без доработок конкретизировать пользователям права Просмотра и Изменения объектов базы 1С, установив ограничения с помощью отборов системы компоновки данных.

2 стартмани

02.07.2020    7349    58    sapervodichka    38    

Настройка ограничений входа пользователей в базу (расширение)

Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

Настраиваем для пользователей 1С разрешенное количество открытых сеансов к текущей базе данных 1С в привязке к компьютерам. (У пользователя не будет возможности превысить допустимое количество сеансов или зайти с чужого компьютера).

2 стартмани

19.05.2020    6823    10    sapervodichka    12    

Менеджер подключений к удаленным рабочим столам (RDP)

Роли и права v8 Абонемент ($m)

Менеджер подключений к удаленным рабочим столам для организации доступа сотрудникам, без передачи паролей для доступа.

2 стартмани

19.11.2019    4311    6    Shalnov    1    

Просмотр прав пользователей Промо

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Обработка наглядно показывает права доступа конкретного пользователя или роли к конкретному объекту метаданных.

1 стартмани

19.10.2012    32188    108    NILS2009    17    

Обозреватель криптографии

Инструментарий разработчика Защита ПО v8 Абонемент ($m)

Отчет для просмотра доступных провайдеров и сертификатов криптографии на сервере и клиенте.

2 стартмани

21.10.2019    9875    11    YPermitin    10    

Завершение работы пользователей

Роли и права v8 1cv8.cf Россия Абонемент ($m)

Завершение работы пользователей с помощью подключения обработчика ожидания.

1 стартмани

02.10.2019    6285    10    user921814    6    

Оптимизация прав ролей

Производительность и оптимизация (HighLoad) Роли и права v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Решение вопроса по неоптимальной настройке (избыточной) ролей, влияющей на производительность системы (потребление оперативной памяти). Алгоритм работы следующий: Выгрузка конфигурации в файлы - Обработка (изменение) файлов прав ролей - Загрузка измененных прав в конфигурацию. Проверено на платформе начиная с 8.3.12.

1 стартмани

09.09.2019    18337    7    toxilamer    11    

Отключение доступа уволенным пользователям Промо

Информационная безопасность Обработка справочников Администрирование данных 1С v8 v8::Права БП2.0 УПП1 Абонемент ($m)

Давно хотели навести порядок в пользователях? Надоело, что в списке мешаются давно уволенные сотрудники? Тогда эта обработка для Вас!

3 стартмани

15.10.2013    49473    51    VBod    17    

Автоматическая блокировка интерфейса 1С при простое в работе пользователя

Информационная безопасность v8::УФ 1cv8.cf Россия Абонемент ($m)

Простой способ реализации автоматической временной блокировки интерфейса программы при низкой активности пользователя некоторое время.

1 стартмани

28.08.2019    6900    6    shalex5    0    

PowerShell из 1С: создание пользователя Active Directory

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Пример создания пользователя Active Directory с помощью PowerShell из 1С.

2 стартмани

27.08.2019    9522    14    wowik    13    

Вход в программу под нужным пользователем из карточки пользователя [Расширение]

Информационная безопасность v8::УФ v8::Права 1cv8.cf Абонемент ($m)

При проверке прав пользователей и тестировании требуется быстро войти в программу под пользователем (не меняя пароль пользователю). Для этого в карточку пользователя добавлена кнопка "Запустить сеанс".

1 стартмани

03.07.2019    4372    22    WinnerOnLine    3    

Регистры правил [Расширение] Промо

Инструментарий разработчика Информационная безопасность v8 v8::Права УТ11 Абонемент ($m)

Регистры правил - права доступа, запрет редактирования, автоподстановка реквизитов и т.д.

10 стартмани

15.03.2018    17482    9    33lab    1    

Сравнение доступа профилей, ролей, пользователей по всем объектам конфигурации 8.3, 8.2 (обычные формы "ОФ" и управляемые формы "УФ") (выборочно)(НАБОР УТИЛИТ)

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Сравнение профилей доступа по всем объектам конфигурации 8.3 (полноценно функционирует с версии 1С:Предприятия 8.1.10 - 8.3.X). Очень хотелось иметь обработку, которая бы показывала различия профилей доступа по каждому конкретному объекту конфигурации и по всем сразу. Желание было воплощено в данной обработке.

1 стартмани

23.06.2019    6329    21    AlexandrSmith    0    

[1С: БП 3] Роль "Кладовщик"

Учет ТМЦ Учет ТМЦ Роли и права v8 v8::БУ v8::Права БП3.0 Россия БУ Абонемент ($m)

Расширение, которое позволяет использовать отдельные роли для доступа к складским документам, для доступа к документам "Отчет производства за смену" и для доступа к документам "Поступление товаров и услуг"

1 стартмани

21.05.2019    13020    125    dima21m    64    

Подсистема динамических прав

Информационная безопасность v8::Права 1cv8.cf Абонемент ($m)

Подсистема прав, позволяющая в реальном времени (без назначения ролей, перезапуска 1с, изменения конфигурации) менять права пользователя: Просмотр, Создание, Изменение, Проведение, Отмена проведения, Изменение проведенных, Неоперативное проведение. Существенно упрощает управление правами в базах с большим количеством пользователей. Версия платформы 8.3.12.1685.

2 стартмани

10.04.2019    8010    16    itmind    53    

Включение и выключение регистрации отказа в доступе если "У пользователя не достаточно прав над операцией с базой данных". Промо

Информационная безопасность Журнал регистрации v8 1cv8.cf Абонемент ($m)

Включает (выключает) регистрацию событий отказа доступа в журнале регистрации.

1 стартмани

12.01.2011    35014    66    nexts    32    

Запуск 1С под другим пользователем без ввода пароля

Информационная безопасность v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Для проверки настроек ролей и прав или для отладки можно использовать это решение.

1 стартмани

22.03.2019    7433    32    pridecom    0    

Наследование ролей в профилях групп доступа в конфигурациях на базе БСП

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

С помощью данной доработки можно создать новый профиль групп доступа, с наследованием ролей от базового (поставляемого) профиля. В созданном профиле можно добавить или исключить какие-либо роли относительно базового профиля.

1 стартмани

15.03.2019    9176    12    ids79    1    

PasswordHashViewer - просмотр хэшей пользовательских паролей

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Программа для просмотра хэшей паролей пользователей в файловых и клиент-серверных базах 1С. Зачем это нужно? Для их проверки на криптостойкость.

1 стартмани

25.02.2019    6029    9    GeraltSnow    5    

Права пользователей Промо

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Кросс-таблица прав пользователей (подсистема "Управление доступом")

1 стартмани

10.05.2016    27871    101    inspam    4    

Обезличивание базы ЗУП 3.1.*

Информационная безопасность Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Абонемент ($m)

Обработка по перемешиванию/скрытию конфиденциальной информации в базе ЗУП.

1 стартмани

05.02.2019    10305    59    Skin123    11    

Наводим порядок в Active Directory с помощью ЗУП / ЗИКГУ 3.1 (идентификация, отключение и актуализация учетных записей пользователей)

Информационная безопасность Администрирование данных 1С v8 v8::СПР ЗКБУ ЗУП3.x Россия Абонемент ($m)

Продолжаем использовать ЗУП 3.1 совместно с LDAP во имя автоматизации работы системного администратора. В этот раз займемся аудитом учетных записей. Обработка производит сопоставление учетной записи с данными сотрудников из ЗУП, причем с учетом недавних событий (для перехода на ЗУП 3.1 чаще всего используется рекомендованный перенос, не включающий уволенных сотрудников) есть возможность использовать объединенные с помощью COM-соединения данные ЗУП 2.5 и ЗУП 3.1. Также в данной обработке есть возможность массовой корректировки, заполнения данных и отключения учетных записей. Перед использованием обработки для душевного спокойствия необходимо сделать резервную копию Active Directory любым удобным способом. Протестировано на ЗУП 3.1.6 - 3.1.8.

5 стартмани

01.02.2019    8206    37    Туки Туки    12    

1С: Документооборот. Роли, использующие объекты адресации. Конфигурация остается типовой (используется расширение)

Информационная безопасность v8 ДО Абонемент ($m)

Расширение функционала документооборота. Реализована возможность использования ролей с объектами адресации. Конфигурация остается типовой (используется расширение)

5 стартмани

10.01.2019    8597    16    sulig    27    

Права по ролям Промо

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Отчет выводит установленные права

2 стартмани

16.09.2015    24421    75    nad11    1    

Обработка запуска под пользователем без смены пароля на управляемых формах

Информационная безопасность v8::УФ 1cv8.cf Россия Абонемент ($m)

Вариант обработки запуска сеанса под выбранным пользователем без смены пароля на управляемых формах. Может использоваться в целях отладки.

1 стартмани

08.12.2018    5615    32    user834357    7    

Получение логина и пароля ИТС из базы 1С

Информационная безопасность v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает пароль от сайта https://releases.1c.ru прямо из базы 1С.

1 стартмани

02.11.2018    23145    102    Timur.V    21    

Запуск платформы под любым пользователем без смены пароля

Информационная безопасность v8::УФ 1cv8.cf Россия Абонемент ($m)

Обработка позволяет запускать 1С от любого пользователя без смены пароля.

1 стартмани

12.09.2018    7371    26    bmk74    9    

Анализ ролей доступа (обычная и УФ) Промо

Информационная безопасность v8 v8::УФ 1cv8.cf Абонемент ($m)

Анализ ролей доступа. Определяет доступность к справочникам, документам, отчетам и т.д. Не нужно пересматривать кучу ролей, чтобы понять, что Вам нужно.

1 стартмани

25.08.2015    27239    187    fugu    9    

Запрет на запуск более одного сеанса для одного пользователя в 1С: Предприятие 8.3 ЗУП, БП, КА, ERP, УАТ и т.д.

Информационная безопасность v8 1cv8.cf Россия Абонемент ($m)

Ограничение запуска 1С: Предприятие нескольких сеансов под одним пользователем. Функционал разработан через расширение, конфигурацию с поддержки снимать НЕ НУЖНО. Функционал работает в файловом и клиент-серверном варианте работы конфигурации. Платформа 8.3.12.1529 Конфигурации КА 2.4.5.71; ERP 2.4.5.54; БП 3.0.64.21; ЗУП 3.1.7.87 (это релизы на которых была произведена проверка, так же будет работать на всех стандартных конфигурациях 1С с режимом совместимости Версия 8.3.10)

1 стартмани

29.08.2018    15002    71    mityushov.vv    36    

[Расширения] Управление видимостью разделов для разных пользователей

Работа с интерфейсом Информационная безопасность v8 1cv8.cf Россия Абонемент ($m)

Как скрыть/показать раздел в управляемом приложении используя расширение, на примере БП 3.0

1 стартмани

05.07.2018    12393    12    Alex_E    10    

Анализ и редактирование прав пользователей (управляемые формы)

Информационная безопасность v8 v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

В обработке реализовано два отчета - матрица ролей (пересечение ролей и пользователей), и анализ прав на объекты в разрезе пользователей / ролей. Также есть запуск под пользователем с временной подменой пароля и редактирование прав непосредственно в матрице.

2 стартмани

03.07.2018    10280    62    axelerleo    4    

Запуск 1С под пользователем без сброса пароля Промо

Информационная безопасность v8 Россия Абонемент ($m)

Обработка позволяет запустить пользовательский режим 1С, не сбрасывая полностью пароль пользователя. Что очень удобно при отладке прав и RLS. Также есть возможность быстро установить пароль 123, и вернуть старый пароль вручную.

1 стартмани

18.11.2013    45948    317    mylogin    38    

Выгрузка-загрузка профилей групп доступа пользователей

Роли и права v8::УФ v8::Права 1cv8.cf Россия Абонемент ($m)

Часто возникает необходимость перенести параметры доступа пользователей из одной базы в другую. Что касается групп доступа и профилей доступа, то данная обработка - удобный помощник! Она позволяет выгрузить в файл профиль доступа из одной базы и загрузить в другой (желательно аналогичной конфигурации). Также есть возможность объединять выбранный профиль с данными из файла. Задействована защита от случайного изменения предопределенных профилей, не рекомендованных к изменению.

1 стартмани

22.03.2018    10007    102    YannikAlx    23    

Обновление профилей доступа. БСП 2.x

Информационная безопасность v8::Права БП3.0 Абонемент ($m)

Обработка, позволяющая синхронизировать роли обновляемого профиля по исходному профилю, после обновления релиза конфигурации (когда обновляемый профиль создан на основе исходного профиля).

1 стартмани

12.03.2018    8600    17    Darklight    0    

Анализатор прав и ролей

Роли и права v8 v8::Права 1cv8.cf Россия Абонемент ($m)

"Достали!" - именно с такой фразы началась разработка) Все кто сталкивались с последними мега конфигурациями (не будем показывать пальцем на ERP) и видели этот нереальный список ролей, от которого даже скролл дымился, то вам однозначно пригодится эта обработка. Основной целью было дополнить типовой функционал "Все роли" отборами для быстрого поиска нужных доступов. Возможности: просмотр по метаданным список их ролей и прав, просмотр по роли ее список метаданных, просмотр по правам ограничения (RLS).

1 стартмани

02.01.2018    9348    60    denacid    6    

Отчет для анализа прав доступа в разрезах Право/Объект/Роль/Профиль/Пользователь Промо

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Удобный анализ прав доступа в различных разрезах, с промежуточным кэшированием набора данных. Только для конфигураций на БСП.

1 стартмани

16.04.2015    28281    332    unichkin    13    

Редактирование прав пользователя (анализ прав доступа)

Роли и права v8 v8::Права БП3.0 УТ11 Абонемент ($m)

Обработка для анализа и редактирования ролей пользователей 1С Предприятия.

1 стартмани

21.12.2017    13109    92    feniks_pro90    5    

Запуск ИБ 1С под любым пользователем (только для разработчиков/администраторов)

Информационная безопасность v8 v8::Права 1cv8.cf Россия Абонемент ($m)

Когда ведете разработку нового функционала, то есть необходимость протестировать алгоритмы под разными правами. Тогда Вам нужна данная обработка, которая ускорит процесс входа в базу под нужным пользователем.

1 стартмани

28.11.2017    10565    39    Diagnostiks    7    

Считывание заданных параметров Интернет-поддержки

Информационная безопасность v8 ERP2 ЗКГУ3.0 БП3.0 УТ11 КА2 ЗУП3.x Россия Абонемент ($m)

Обработка для чтения указанных параметров интернет-поддержки продукта.

1 стартмани

25.10.2017    10125    22    kudlach    4    

Настройка прав пользователей. БСП. Профиль доступа. Три клика. Промо

Информационная безопасность Сервисные утилиты БСП (Библиотека стандартных подсистем) v8 Розница УНФ БП3.0 УТ11 ЗУП3.x Абонемент ($m)

Простое и наглядное формирование профиля доступа с расширенными правами "EXPERT". Сопоставление ролей профилей конфигурации. Просмотр прав ролей. Управляемое приложение.

1 стартмани

06.03.2013    133446    818    StepByStep    83    

Перенос настроек пользователей между базами 1С 8.3 (УФ)

Роли и права v8 v8::УФ 1cv8.cf Абонемент ($m)

Задача была – скопировать одну базу в другую, причем перенести список пользователей и настройки пользователей. Потому что в настройках пользователей было очень много хитроумных разукрашиваний и отборов, следовательно, повторять это руками было бы долго. Была написана обработка, которая выгружает настройки пользователей из одной базы в файлы и потом позволяет их загрузить из файлов в другую базу. Можно использовать и для переноса настроек между одними пользователями, если типовое копирование не нравится.

1 стартмани

13.10.2017    22636    215    fixin    16    

Выгрузка и загрузка пользователей между различными конфигурациями 1С 8.3, включая пароли (Управляемое приложение, обычное приложение, БСП)

Роли и права v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m)

Предназначена для переноса пользователей между различными конфигурациями 1С 8.3, включая пароли. Только для БСП (библиотека стандартных подсистем). Проверено на "Документооборот 2.0", "Управление торговлей 11", БСП 2.3.

4 стартмани

07.07.2017    19401    96    TuneSoft    5    

Как помочь сисадмину при большой текучке кадров

Информационная безопасность v8 v8::СПР v8::Права ЗУП2.5 Россия Абонемент ($m)

Хотелось бы поделиться своим опытом создания пользователей AD из 1С:ЗУП 2.5.

1 стартмани

06.07.2017    13564    7    PhoenixAOD    31    

Управление пользователями / Создание терминальных пользователей из 1С Промо

Информационная безопасность v8 БП2.0 ЗУП2.5 УПП1 Россия Абонемент ($m)

Управление пользователями / Создание терминальных пользователей из 1С

1 стартмани

21.02.2012    24252    31    ravsan    24    

Создание и удаление пользователей в конфигурациях с БСП

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Быстрое создание пользователей с заранее известными правами в интерактивном режиме и из файла. По одному и списком. Быстрое удаление списком пользователей ИБ и пометка на удаление элементов справочника Пользователи.

1 стартмани

20.06.2017    9669    28    user768334    1    

Отключение/включение защиты от опасных действий пользователей

Информационная безопасность v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет управлять настройкой "Защита от опасных действий" пользователей информационной базы.

1 стартмани

16.05.2017    12514    30    Brawler    8    

Просмотр ролей по объектам метаданных конфигурации на 1С 8.3

Роли и права v8 1cv8.cf Россия Абонемент ($m)

Универсальная обработка для просмотра ролей по любому из объектов конфигурации 1С 8.3.для настройки пользовательских интерфейсов по стандартным ролям в конфигурации ERP 2.4, ЗУП 3.1, БП 3.0 и т.д.

1 стартмани

13.04.2017    16400    94    mityushov.vv    7    

Сравнение ролей по выгруженным из конфигураций файлам (XML). Промо

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Сравнение ролей по выгрузкам из конфигурации в файлы (XML). Для платформа 8.3, обычных и управляемых форм.

1 стартмани

05.02.2014    23266    29    KapasMordorov    8    

Загрузка пользователей в Документооборот 2.х из Active Directory

Документооборот и делопроизводство Информационная безопасность Документооборот и делопроизводство v8::УФ ДО УУ Абонемент ($m)

Обработка облегчит заведение новых пользователей в документооборот, в случае, если у вас есть доменный сервер (Active Directory).

2 стартмани

06.03.2017    14374    54    odineskin2    14    

Просмотр лицензий и сеансов пользователей

Информационная безопасность v8 1cv8.cf Абонемент ($m)

Просмотр лицензий и сеансов пользователей (тонкий, толстый клиент, управляемого или обычного приложения).

1 стартмани

01.03.2017    8307    22    diletant    7