Диаграмма Ганта и графическая схема сторонними средствами

Публикация № 935007

Разработка - Практика программирования

Обработка гантт диаграмма гантта amCharts амчартс графическая схема js raphael мобильный клиент работа с html гант ганта.

Примеры формирования диаграммы Ганта и графической схемы в 1С сторонними средствами.

Недавно возникла необходимость формировать отчеты на мобильных устройствах. Для реализации идеи решили попробовать мобильный клиент.
С обычными отчетами проблем не возникло, но были два отчета, которые "не смогли".
Один из них - Диаграмма Гантта, другой - построен при помощи Географической схемы. Эти типы не имеют отображения на мобильном клиенте.

Было решено попробовать вывести данные отчетов в поле html.


Диаграмма Гантта.

Самым простым способом показалось использовать amCharts. Спасибо публикации за примеры работы с библиотеками. 
 

В обработке подготовлен шаблон html, который всего лишь нужно дополнить выводимыми данными.
Формируем таблицу данных:
 

Функция ПолучитьДанные()
	
	Данные = Новый ТаблицаЗначений;
	
	Данные.Колонки.Добавить("category");
	Данные.Колонки.Добавить("segments");
	
	ТаблицаСегментов = Новый ТаблицаЗначений;
	ТаблицаСегментов.Колонки.Добавить("start");
	ТаблицаСегментов.Колонки.Добавить("end");
	ТаблицаСегментов.Колонки.Добавить("color");
	ТаблицаСегментов.Колонки.Добавить("task");
	
	НоваяСтрока = Данные.Добавить();
	НоваяСтрока.category = "Авиа";
	ТаблицаСегментов.Очистить();
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-01-01";
	НоваяСтрокаСегментов.end = "2016-01-14";
	НоваяСтрокаСегментов.color = "#b9783f";
	НоваяСтрокаСегментов.task = "Gathering requirements";
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-02-01";
	НоваяСтрокаСегментов.end = "2016-02-14";
	НоваяСтрокаСегментов.color = "#b9783f";
	НоваяСтрокаСегментов.task = "Gathering requirements";
	
	НоваяСтрока.segments = ТаблицаСегментов;
	
	НоваяСтрока = Данные.Добавить();
	НоваяСтрока.category = "Прокат";
	
	ТаблицаСегментов = Новый ТаблицаЗначений;
	ТаблицаСегментов.Колонки.Добавить("start");
	ТаблицаСегментов.Колонки.Добавить("end");
	ТаблицаСегментов.Колонки.Добавить("color");
	ТаблицаСегментов.Колонки.Добавить("task");
	ТаблицаСегментов.Очистить();
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-01-02";
	НоваяСтрокаСегментов.end = "2016-01-18";
	НоваяСтрокаСегментов.color = "#cc4748";
	НоваяСтрокаСегментов.task = "Producing specifications";
	НоваяСтрока.segments = ТаблицаСегментов;
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-02-02";
	НоваяСтрокаСегментов.end = "2016-02-18";
	НоваяСтрокаСегментов.color = "#cc4748";
	НоваяСтрокаСегментов.task = "Producing specifications";
	НоваяСтрока.segments = ТаблицаСегментов;
	
	НоваяСтрокаСегментов = ТаблицаСегментов.Добавить();
	НоваяСтрокаСегментов.start = "2016-03-02";
	НоваяСтрокаСегментов.end = "2016-03-18";
	НоваяСтрокаСегментов.color = "#cc4748";
	НоваяСтрокаСегментов.task = "Producing specifications";
	НоваяСтрока.segments = ТаблицаСегментов;
	
	Возврат Данные;
	
КонецФункции

Далее таблица преобразуется в строку и передается в шаблон.

В итоге получаем: 

 

Графическая схема.

В свое время возникла необходимость графически отображать цепочки продаж.

При анализе различных способов была найдена публикация, которая и помогла реализовать такой отчет.

При решении текущей задачи вспомнилась работа с графикой на js при помощи библиотеки raphael.
В итоге все свелось просто к рисованию фигур по точкам. Точки брались прямо из графической схемы:
 

Процедура ЗаполнитьПример()
	
	СписокИдентификаторов.Очистить();
	Уровень1 = ДеревоОбъектов.ПолучитьЭлементы();
	Уровень1.Очистить();
	
	ГрафСхемаXDTO=СериализаторXDTO.ЗаписатьXDTO(ГрафСхема);
	
	Для Каждого ОбъектГС Из ГрафСхемаXDTO.Item Цикл
		
		Если ОбъектГС.itemtype = 9 Тогда
			
			НовСтр = Уровень1.Добавить();
			
			ТочкиСтрокой = "";
			
			Для Каждого Точка Из ОбъектГС.point Цикл
				
				ТочкиСтрокой = ТочкиСтрокой + ?(ПустаяСтрока(ТочкиСтрокой), "", ", ") + СтрЗаменить(Строка(Точка.x), Символы.НПП, "") + ", " + СтрЗаменить(Строка(Точка.y), Символы.НПП, "");
				
			КонецЦикла;
			
			НовСтр.Шейп = ТочкиСтрокой;
			НовСтр.Цвет = "#ffa0e0";
			НовСтр.Описание = ОбъектГС.itemCode;
			НовСтр.Описание_Точка = "0, 0";
			СписокИдентификаторов.Добавить(НовСтр.ПолучитьИдентификатор());
			
		ИначеЕсли ОбъектГС.itemtype = 1 Тогда
			
			НовСтр = Уровень1.Добавить();
			
			ТочкиСтрокой = "";
			
			МассивТочек = Новый Массив;
			
			Для Каждого Точка Из ОбъектГС.point Цикл
				
				ТочкиСтрокой = ТочкиСтрокой + ?(ПустаяСтрока(ТочкиСтрокой), "", ", ") + СтрЗаменить(Строка(Точка.x), Символы.НПП, "") + ", " + СтрЗаменить(Строка(Точка.y), Символы.НПП, "");
				МассивТочек.Добавить(СтрЗаменить(Строка(Точка.x + 1), Символы.НПП, "") + ", " + СтрЗаменить(Строка(Точка.y), Символы.НПП, ""));
				
			КонецЦикла;
			
			Сч = МассивТочек.Количество() - 1;
			Пока Сч >= 0 Цикл
				
				ТочкиСтрокой = ТочкиСтрокой + ", " + МассивТочек[Сч];
				
				Сч = Сч - 1;
				
			КонецЦикла;
			
			НовСтр.Шейп = ТочкиСтрокой;
			НовСтр.Цвет = "#999999";
			НовСтр.Описание = "";
			НовСтр.Описание_Точка = "0, 0";
			НовСтр.Линия = Истина;
			СписокИдентификаторов.Добавить(НовСтр.ПолучитьИдентификатор());
			
		КонецЕсли;
		
	КонецЦикла;	
	
КонецПроцедуры

В итоге получаем:

Стрелочки рисовать уже не стал. Но, при желании, это можно сделать.

 

Обе обработки делались на платформе 8.3.11.2867

Тестировалось на конфигурации Управление нашей фирмой, редакция 1.6 (1.6.13.60), но должно работать на любой другой конфигурации под управляемыми формами. 

Скачать файлы

Наименование Файл Версия Размер
Диаграмма Гантта в html:

.epf 93,68Kb
01.11.18
5
.epf 1.0.0 93,68Kb 5 Скачать
Графическая схема в html

.epf 45,95Kb
01.11.18
0
.epf 1.0.0 45,95Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. 1segen1 32 02.11.18 08:05 Сейчас в теме
Не знал, что название диаграммы уже пишется по-другому (Гантт).
2. no_betrayal 26 02.11.18 11:18 Сейчас в теме
(1)Взято с Вики. Да и в амЧартс в английском варианте gantt. Хотя СП считает иначе)
3. user5300 543 06.02.20 08:52 Сейчас в теме
Как убрать гиперссылку "Js chart by amCharts" ?
4. no_betrayal 26 06.02.20 14:29 Сейчас в теме
(3)Эта ссылка - условие бесплатного использования библиотеки.

Но если очень сильно хочется заморочиться - можно сделать следующее:

1. Заменить процедуру в форме:
Процедура СформироватьГанттаНаСервере()
	
	Данные = ПолучитьДанные();
	
	ДанныеСтрокой = AmChartsДанные(Данные);
	
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	
	//Шаблон = ОбработкаОбъект.ПолучитьМакет("Шаблон").ПолучитьТекст();
	Шаблон = ОбработкаОбъект.ПолучитьМакет("Макет").ПолучитьТекст();
	amcharts = ОбработкаОбъект.ПолучитьМакет("amcharts").ПолучитьТекст();
	serial = ОбработкаОбъект.ПолучитьМакет("serial").ПолучитьТекст();
	light = ОбработкаОбъект.ПолучитьМакет("light").ПолучитьТекст();
	gantt = ОбработкаОбъект.ПолучитьМакет("gantt").ПолучитьТекст();
	
	Текст = СтрЗаменить(Шаблон, "&amcharts.js", amcharts);
	Текст = СтрЗаменить(Текст, "&serial.js", serial);
	Текст = СтрЗаменить(Текст, "&light.js", light);
	Текст = СтрЗаменить(Текст, "&gantt.js", gantt);
	
	ПолеХТМЛ = СтрЗаменить(Текст, "&DataProvider", " [ " + ДанныеСтрокой + " ] ");
	
КонецПроцедуры
Показать


Так перейдем на использование скриптом из шаблонов.
2. В шаблоне "amcharts" найти неугодную фразу и заменить, например, на пустую строку.

Но я настоятельно рекомендую в таком случае перенести ссылку хотя бы на форму, чтобы не нарушать пользовательское соглашение.
user5300; +1 Ответить
5. user5300 543 06.02.20 15:17 Сейчас в теме
(4) можно оставить на форме но скрыть видимость ))
и еще такой вопрос, можно ли добавить текст в шкалу времени (или рядом)
и можно ли отобразить числа месяца ?
6. no_betrayal 26 06.02.20 16:36 Сейчас в теме
(5)Если текст нужен под шкалу времени, в макете шаблона можно попробовать добавить еще один div элемент с текстом.

и можно ли отобразить числа месяца ?


Дата нужна в формате 06.02, а не фев 02?

Сейчас точно не подскажу, как сделать. Нужно курить документацию:
https://docs.amcharts.com/3/javascriptcharts/AmCharts


Я обычно открывал демку диаграммы https://www.amcharts.com/demos-v3/gantt-chart-dates-v3/
Там есть возможность перейти в редактор
"Open in:"
Я использую codepen.
Там можно поэкспериментировать с параметрами и прочим.

Но на скорую руку сделать не получилось.

У меня использована версия 3, в версии 4 сильно больше настроек для шкалы времени.
user5300; +1 Ответить
Оставьте свое сообщение

См. также

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула Промо

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    41573    28    agent00mouse    0    

Два способа реализации ABC-анализа контрагентов для БП 3.0

Практика программирования Оптовая торговля v8 БП3.0 Россия УУ Абонемент ($m)

В данной статье рассматриваются 2 способа реализации ABC анализа контрагентов для конфигурации Бухгалтерия предприятия 3.0 (версия  3.0.75.109).

1 стартмани

17.03.2020    2133    8    Астиг    8    

Задачка: Список всех документов за заданный период, используя СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Вывести все документы за заданный период, используя СКД.

1 стартмани

11.03.2020    2242    3    MaxxiMiliSan    7    

Подборка иконок для подсистем 1С:8.2, 8.3 (740 шт.) PNG 48х48 Промо

Практика программирования Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

Подборка иконок для подсистем 1С: Предприятие 8.2, 8.3 (УП) в формате PNG 48*48 с сохранением прозрачности.

3 стартмани

19.12.2011    104970    194    Lesha1C    74    

СКД: красивые надписи в заголовках колонок

Практика программирования Работа с интерфейсом v8 v8::СКД УПП1 Россия Абонемент ($m)

Необходимо немного исправить вывод надписей в заголовках колонок, сделать более читаемый вариант. Как это сделать?

2 стартмани

27.02.2020    10006    7    wowik    36    

Примерная схема проведения документов (Механизм проведения) в ERP 2.5.x.x

Практика программирования v8 ERP2 Абонемент ($m)

Некий шаблон "общей" картины связи процедур выполняемых типовым механизмом проведения в ERP 2.5.

1 стартмани

27.01.2020    6255    11    s14adow    7    

Отчет на СКД с выводом остатков по всем датам периода для УТ 10.3 (обычные формы)

Практика программирования v8::СКД УТ10 Россия УУ Абонемент ($m)

Требовалось получить остатки на каждую дату периода с целью дальнейшего вывода в любых целях. В обработке используется вспомогательный макет СКД, из которого и получается таблица остатков. Далее ее просто вывожу через другое СКД, так как это просто пример. Вы можете встроить это себе в любую обработку.

1 стартмани

23.12.2019    3607    4    jump0    0    

Решение задач по мотивам статьи "30 задач. Странных и не очень"

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка по мотивам статьи: https://infostart.ru/public/1161686/

1 стартмани

04.12.2019    3154    2    batsy66    9    

Программное добавление параметров редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

В данной публикации приводится пример программного добавления параметров редактирования для поля выборки в СКД.

1 стартмани

25.11.2019    5948    1    Isonic    8    

html + css + js в поле HTML документа 1С на примере решения задачи ханойских башен

Практика программирования v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Рассматривается пример использования html + css + js в полеHTMLдокумента 1с. Вызов функций javascript со стороны 1С с передачей параметров. Решение головоломки "Ханойская башня" с визуализацией в среде 1С.

1 стартмани

11.11.2019    6406    9    mangushov    0    

Инициалы имени иностранного сотрудника в ЗУП 3.1

Практика программирования Печатные формы документов v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Решение проблемы лишнего дефиса в двойном имени иностранного сотрудника с помощью простого расширения.

1 стартмани

10.10.2019    4783    0    accounting_cons    2    

Индикатор выполнения (прогресс-бар) с таймером остаточного времени выполнения (обычное приложение + УФ)

Практика программирования Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Индикатор (прогресс-бар) - элемент формы, отображающий ход выполнения операций по счетчику. В данном решении разработана возможность отслеживания остаточного времени выполнения.

1 стартмани

08.10.2019    5356    13    slayer-ekb    5    

Формирование внешнего отчета в фоне

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Принципы формирования внешнего отчета в фоновом режиме. Используя стандартную форму отчета БСП или свою. Вопросы передачи параметров от команды внешнего отчета в фоновом процессе к ожидающей завершения процедуре формы.

1 стартмани

07.08.2019    8934    4    partizand    14    

Расчет сложных итогов СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Малоизвестный прием для расчета итогов в отчетах на СКД.

1 стартмани

05.08.2019    20100    16    masterkio    17    

Иерархическая нумерация в отчете СКД с помощью макета поля

Практика программирования Разработка v8 v8::СКД 1cv8.cf Абонемент ($m)

Представляю Вашему вниманию вариант решения задачи нумерации строк иерархического отчета на СКД.

1 стартмани

28.06.2019    7965    5    Isonic    14    

Пример печатной формы в Word для УТ 11.4, ERP. КА 2.4, подложка и колонтитулы

Печатные формы документов Практика программирования Разработка v8 ERP2 УТ11 КА2 Россия Абонемент ($m)

Пример внешней печатной формы с выводом в MS Word для УТ 11.4, КА 2, ERP 2.4, печатная форма печатается из документа "Заказ клиента". Для примера разобрано програмнное заполнение верхнего и нижнего колонтитулов, а также печать в качестве подложки - логотипа организации (печать картинки на заднем фоне, при этом у логотипа уменьшена яркость и он повернут на 45 градусов).

1 стартмани

30.05.2019    3675    14    DarkPinch222    5    

Поле "Отбор" в управляемой форме используя СКД

Работа с интерфейсом Практика программирования Разработка v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Пример, который осуществляет отбор ссылок при помощи СКД, макет компоновки создается программно.

1 стартмани

17.05.2019    9751    10    artms    0    

Отладка сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    28492    97    maxx    58    

Шаблон кросс-таблицы с иерархией на СКД

Инструментарий разработчика Практика программирования v8::БУ v8::СКД БП3.0 Россия Абонемент ($m)

Шаблон для быстрой реализации отчета кросс-таблицы с иерархией и жестко заданной структурой вывода с использованием СКД.

1 стартмани

22.12.2018    10164    11    wizard.ilmir02    3    

Чат на управляемых формах

Практика программирования WEB v8 v8::УФ Абонемент ($m)

Чат для 1С на управляемых формах, для работы в браузере. Возможности: Есть общая комната Можно создавать открытые и закрытые комнаты Переписка между двумя пользователями (беседа) Протестировано на платформе 8.3.12.1714.

2 стартмани

14.12.2018    6312    10    panihinnv    13    

Печать QR кода

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Простой пример печати QR кода.

1 стартмани

18.11.2018    8962    13    ah7777777    4    

Объединение нескольких печатных форм в один табличный документ

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Простое решение, как объединить табличные документы с различной шириной колонок в один и чтобы ничего не разъехалось.

1 стартмани

17.11.2018    13940    7    echo77    6    

Отчет для демонстрации работы с программной расшифровкой СКД

Практика программирования v8::СКД 1cv8.cf Россия Абонемент ($m)

Программное добавление дополнительных пунктов меню в расшифровке и программное формирование отчета-детализации для отчета СКД.

1 стартмани

08.11.2018    7275    6    budidich    1    

И снова группировка столбцов в СКД

Практика программирования v8 v8::СКД УТ11 Россия Абонемент ($m)

В публикации описано создание отчета "Остатки по складам" с группировкой по строкам и столбцам.

1 стартмани

23.10.2018    11894    1    vasilievil    9    

Параметризованные заголовки полей СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Доработанный шаблон типового отчета, который это позволяет менять заголовки полей в зависимости от значений параметров.

2 стартмани

21.09.2018    8553    3    echo77    3    

Преобразование отбора компоновки данных к линейному условию для запроса

Практика программирования v8::БУ БП3.0 Россия БУ Абонемент ($m)

Описание механизма преобразования интерактивного отбора компоновки данных в условие для использования в запросе, данный механизм можно использовать в конфигурации Бухгалтерия предприятия 3.0 и везде в управляемых приложениях, где используется регистр бухгалтерии "Хозрасчетный", также можно адаптировать к любому источнику данных

10 стартмани

10.09.2018    4669    2    scarabey2006    4    

Табель учета рабочего времени или как создать календарик в табличной части документа

Практика программирования Учет рабочего времени Учет рабочего времени v8 УНФ ERP2 УУ Абонемент ($m)

Мой велосипед по созданию документа учета рабочего времени. Обработка предназначена для Управляемых форм, тестировалась на Управление нашей фирмой, редакция 1.6 (1.6.10.44),1С:ERP Управление предприятием 2 (2.4.4.124) платформы (8.3.12.1412),(8.3.11.2867)

1 стартмани

24.08.2018    4382    2    Doreng    2    

Вывод результата отчета СКД в разные табличные документы

Практика программирования Работа с интерфейсом v8::СКД 1cv8.cf Россия Абонемент ($m)

В ходе выполнения своей повседневной работы столкнулся с интересной клиентской задачей - требовалось результат отчета СКД вывести на форму отчета в разные вкладки формы в разные табличные документы. Как оказалось, информации по такому выводу отчета в интернете маловато, поэтому решил скомпоновать свой опыт решения этой задачи в одной статье.

1 стартмани

21.08.2018    13631    11    Dipod    4    

[Механизм интерфейса] Интерактивный выбор даты

Практика программирования Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Вариант механизма выбора даты для разработки интерфейса под сенсорный монитор. Особенно актуально для разработки терминалов или других подобных систем.

1 стартмани

16.08.2018    11293    8    rpgshnik    18    

Примеры программной работы с СКД, а также программного создания управляемой формы

Практика программирования v8 v8::УФ v8::СКД Абонемент ($m)

Примеры работы с СКД (четыре отчета с использованием сложных выражений), программного создания управляемой формы, а также программное формирование СКД в обработке и другие интересные механизмы на конфигурации "с нуля".

1 стартмани

12.08.2018    6485    28    MaxCreator    0    

Линия тренда в диаграмме на графике "Биржевая свеча"

Практика программирования WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Отчет демонстрирует, как можно отразить линию тренда на биржевом графике типа "свеча" средствами 1С.

1 стартмани

11.08.2018    6700    19    Scop    3    

Горячая клавиша для открытия ячеек таблиц, отчетов

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Задача: Открывать отчет Анализ движений номенклатуры по горячей клавише из документов, где в табличной части есть номенклатура, из списка номенклатуры и из любого отчета или в рмк в поиске товаров.

1 стартмани

10.08.2018    6279    2    leobrn    0    

Часы в 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Часы в 1с с использованием продвинутого рисования

1 стартмани

25.07.2018    5716    3    Plash    7    

Множество Мандельброта на 1С

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Реализация фрактала Множество Мандельброта на платформе 1С 8.3. Работает как в обычных, так и на управляемых формах в любой конфигурации. Прикладного смысла в обработке мало, может использоваться в качестве демонстрации динамической отрисовки в поле табличного документа.

1 стартмани

20.03.2018    4218    3    kylix90    3    

Таблица значений в параметрах СКД

Практика программирования Инструментарий разработчика v8 v8::СКД 1cv8.cf Абонемент ($m)

Шаблон отчета на СКД, где в качестве параметра передаётся таблица значений.

1 стартмани

31.01.2018    9510    24    skydivespb    4    

Пример реализации технологии Блокчейн в 1С 8.3

Практика программирования Блокчейн v8 Абонемент ($m)

Конфигурация предназначена для простого и понятного описания технологии блокчейн. Имеется 2 вида документов: Приходная накладная и Расходная накладная. Их постоянно кто-то создает и пробует изменить. В документе Блокчейн хранится контрольная сумма каждого документа, и их тоже какое-то чужое лицо может изменить и поправить. Так в базе 1С хранится информация с нулевым уровнем доверия.

10 стартмани

26.01.2018    10497    1    astracrypt    2    

Пример решения расчетной задачи с табелем (для 1С:Специалист)

Практика программирования Решение задач на 1С:Специалист Учет рабочего времени Учет рабочего времени v8 v8::СПР УУ Абонемент ($m)

Условие задачи собрано из нескольких экзаменационных задач и служит общим примером решения.

1 стартмани

25.01.2018    16928    7    perepetulichka    3    

Подпись в мобильном приложении

Практика программирования Мобильная разработка v8::Mobile 1cv8.cf Абонемент ($m)

Подпись клиента в вашем мобильном приложении.

1 стартмани

04.01.2018    15036    45    onec.developer    7    

Справочная библиотека программ и подпрограмм 1С

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Данная небольшая статья (и обработка для использования в практике своей работы) предлагается вниманию начинающим и опытным программистам 1С в качестве небольшого пособия по освоению программирования на платформе 1С. Есть такая книжка «1С: Предприятие Опыты программирования», написал ее небезысвестный в узких одинэсовских кругах О. В. Бартеньев (издательство «Диалог-МИФИ», 2004 г.), так вот, при внимательном ее изучении у пытливого пользователя возникает множество вопросов. Предлагаемая обработка позволяет решить некоторые из них.

1 стартмани

06.10.2017    9938    8    vik2006    12    

Решение задачи по созданию прикладного решения

Практика программирования Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 Россия УУ Абонемент ($m)

Создание прикладного решения для платформы «1С: Предприятие» для упрощенного учета хозяйственной деятельности некой торговой организации.

1 стартмани

25.08.2017    7590    15    alex1_1976    0