Документ закрытие счетов. Может закрыть в 0 вообще все счета!

Публикация № 93508

Учет и отчетность - Закрытие периода - Закрытие периода

29
Данный документ встраивается в любую конфигурацию, построенную на компоненте "Бухгалтерский учет". Просто скопируйте документ и назначьте ему нужный журнал. Что документ делает? Все очень просто: в табличной части указывается список балансовых счетов, которые нужно закрыть в 0. При проведении документ анализирует сальдо по счетам и формирует проводки, закрывающие счет, в корреспонденции с тем счетом, который указан в шапке документа. Может быть полезен, когда регламентные документы не позволяют закрыть, например, 90,44,20 счет из - за невыполнения каких - либо условий,  а также как шаблон для собственной разработки.

Привожу код модуля документа, для тех, кому не судьба скачать:

 


Перем Ит;

Перем
МСубконто[3];

//**********************************************************



Процедура СформироватьОперацию(ДК=0,СчетДвиж,Субконто_1,Субконто_2,Субконто_3,Сумма,Количество)

   
Операция.НоваяПроводка();

   
Операция.ПервичныйДокумент  = "Закрытие счетов № " + НомерДок;

   
Операция.Количество = Количество;

   
Операция.Сумма = Сумма;

    Если
ДК = 0 Тогда

        Если
СчетДвиж.Забалансовый = 0 Тогда

           
Операция.Дебет.Счет = СчетТранзита;

           
Операция.Дебет.Субконто(1,Субконто1);

           
Операция.Дебет.Субконто(2,Субконто2);

           
Операция.Дебет.Субконто(3,Субконто3);

        КонецЕсли;

       
Операция.Кредит.Счет = СчетДвиж;

        Если
МСубконто[1] <> 0 Тогда

           
Операция.Кредит.Субконто(МСубконто[1],Субконто_1);

        КонецЕсли;

        Если
МСубконто[2] <> 0 Тогда

           
Операция.Кредит.Субконто(МСубконто[2],Субконто_2);

        КонецЕсли;

        Если
МСубконто[3] <> 0 Тогда

           
Операция.Кредит.Субконто(МСубконто[3],Субконто_3);

        КонецЕсли;

    Иначе

        Если
СчетДвиж.Забалансовый = 0 Тогда

           
Операция.Кредит.Счет = СчетТранзита;

           
Операция.Кредит.Субконто(1,Субконто1);

           
Операция.Кредит.Субконто(2,Субконто2);

           
Операция.Кредит.Субконто(3,Субконто3);

        КонецЕсли;

       
Операция.Дебет.Счет = СчетДвиж;

        Если
МСубконто[1] <> 0 Тогда

           
Операция.Дебет.Субконто(МСубконто[1],Субконто_1);

        КонецЕсли;

        Если
МСубконто[2] <> 0 Тогда

           
Операция.Дебет.Субконто(МСубконто[2],Субконто_2);

        КонецЕсли;

        Если
МСубконто[3] <> 0 Тогда

           
Операция.Дебет.Субконто(МСубконто[3],Субконто_3);

        КонецЕсли;

    КонецЕсли;

КонецПроцедуры

//**************************************************

Процедура ЗакрытьСчет(Счет)

   
КолСубконто = 0;

    Для
Б = 1 По 3 Цикл

       
МСубконто[Б] = 0;

    КонецЦикла;

    Для
А = 1 По Счет.КоличествоСубконто() Цикл

       
//Оборотные субконто нас не интересуют!

       
Если Счет.ТолькоОбороты(А) = 0 Тогда

           
Ит.ИспользоватьСубконто(Счет.ВидСубконто(А),, 1);

           
КолСубконто = КолСубконто + 1;

           
МСубконто[КолСубконто] = А;

        КонецЕсли;

    КонецЦикла;

   
Ит.ВыполнитьЗапрос(ДатаДок, ДатаДок, Счет,,,1,, 1+4);

    Если
КолСубконто = 0 Тогда

        Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

           
СформироватьОперацию(0,Счет,,,,Ит.СКД(),Ит.СКД(3));

        ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

           
СформироватьОперацию(1,Счет,,,,Ит.СКК(),Ит.СКК(3));

        КонецЕсли;

    ИначеЕсли
КолСубконто > 0 Тогда

       
Ит.ВыбратьСубконто(Счет.ВидСубконто(МСубконто[1]));

        Пока
Ит.ПолучитьСубконто(Счет.ВидСубконто(МСубконто[1])) = 1 Цикл

            Если
КолСубконто > 1 Тогда

               
//Для материальных счетов = итоговые проводки по сумме делаем сразу

               
Если (Счет.УчетПосумме(2) = 0) и (Счет.УчетПоКоличеству(2) = 1) Тогда

                    Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                       
СформироватьОперацию(0,Счет,Ит.Субконто(1),,,Ит.СКД(),0);

                    ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                       
СформироватьОперацию(1,Счет,Ит.Субконто(1),,,Ит.СКК(),0);

                    КонецЕсли;

                ИначеЕсли (
Счет.УчетПосумме(2) = 1) и (Счет.УчетПоКоличеству(2) = 0) Тогда

                    Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                       
СформироватьОперацию(0,Счет,Ит.Субконто(1),,,0,Ит.СКД(3));

                    ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                       
СформироватьОперацию(1,Счет,Ит.Субконто(1),,,0,Ит.СКК(3));

                    КонецЕсли;

                КонецЕсли;

               
Ит.ВыбратьСубконто(Счет.ВидСубконто(МСубконто[2]));

                Пока
Ит.ПолучитьСубконто(Счет.ВидСубконто(МСубконто[2])) = 1 Цикл

                    Если
КолСубконто > 2 Тогда

                       
Ит.ВыбратьСубконто(Счет.ВидСубконто(МСубконто[3]));

                        Пока
Ит.ПолучитьСубконто(Счет.ВидСубконто(МСубконто[3])) = 1 Цикл

                            Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                               
СформироватьОперацию(0,Счет,Ит.Субконто(1),Ит.Субконто(2),Ит.Субконто(3),Ит.СКД(),Ит.СКД(3));

                            ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                               
СформироватьОперацию(1,Счет,Ит.Субконто(1),Ит.Субконто(2),Ит.Субконто(3),Ит.СКК(),Ит.СКК(3));

                            КонецЕсли;

                        КонецЦикла;

                    Иначе

                        Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                           
СформироватьОперацию(0,Счет,Ит.Субконто(1),Ит.Субконто(2),,Ит.СКД(),Ит.СКД(3));

                        ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                           
СформироватьОперацию(1,Счет,Ит.Субконто(1),Ит.Субконто(2),,Ит.СКК(),Ит.СКК(3));

                        КонецЕсли;

                    КонецЕсли;

                КонецЦикла;

            Иначе

                Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                   
СформироватьОперацию(0,Счет,Ит.Субконто(1),,,Ит.СКД(),Ит.СКД(3));

                ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                   
СформироватьОперацию(1,Счет,Ит.Субконто(1),,,Ит.СКК(),Ит.СКК(3));

                КонецЕсли;

            КонецЕсли;

        КонецЦикла;

    КонецЕсли;

КонецПроцедуры

//**************************************************

Процедура ОбработкаПроведения()

   
Ит = СоздатьОбъект("БухгалтерскиеИтоги");

   
Ит.ИспользоватьПланСчетов(ОсновнойПланСчетов());

   
//Ит.ИспользоватьРазделительУчета(Фирма);

   
ВыбратьСтроки();

    Пока
ПолучитьСтроку() = 1 Цикл

       
ЗакрытьСчет(СчетЗакрытия);

    КонецЦикла;

   
Операция.Записать();

КонецПроцедуры

 

29

Скачать файлы

Наименование Файл Версия Размер
1Cv7.MD
.MD 179,00Kb
07.10.11
91
.MD 179,00Kb 91 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. TrinitronOTV 07.10.11 11:17 Сейчас в теме
интересный вариант реализации...
2. DDos76 199 07.10.11 12:24 Сейчас в теме
Особенно если сделать кнопку "заполнить счетами". Нажал - провел- баланс по 0!. Вручную так и делал в Комплексной. Только по разделителю учета. Вычищал остатки по ликвидированным фирмам перед обрезанием базы. Чтоб хвосты не таскать.
3. TrinitronOTV 07.10.11 19:37 Сейчас в теме
DDos76 пишет:

Особенно если сделать кнопку "заполнить счетами". Нажал - провел- баланс по 0!. Вручную так и делал в Комплексной. Только по разделителю учета. Вычищал остатки по ликвидированным фирмам перед обрезанием базы. Чтоб хвосты не таскать.

спасибо за отчет
4. salli80 08.10.11 11:21 Сейчас в теме
А нельзя чуть (для блондинок ) подробнее.Я создала журнал в конфигураторе ,а вот куда скопировать файл не поняла .Подскажите пожалуста.Вещица нужная для меня ))
5. DDos76 199 09.10.11 16:18 Сейчас в теме
Специально для блондинок:
Код, приведенный на сайте, может быть полезен только тем, кто знаком с редактированием
документов в конфигураторе. В Вашем случае придется поступить по - другому:
Скачиваем файл 1CV7.MD с сайта. (там он есть, уже готовый)
Сохраняем его в отдельную папку на компьютере.
Прописываем путь запуска 1с в эту папку (регистрируем новую базу)
Запускаем конфигуратор этой базы. Далее в конфигураторе Конфигурация - открыть конфигурацию.
Раскрываем папочку "Документы". Там есть только один документ. Встаем на него - говорим "Ctrl+C"
(копировать в буфер), потом открываем свою, рабочую конфигурацию, открываем конфигурацию, встаем на
папочку "документы" и давим "ctrl+v" (вставить). Потом листаем содержимое этой папочки до самого
низа и видим вставленный документ. Щелкаем по нему и в открывшемся окне справа вверху выставляем журнал.
Сохраняем конфигурацю. Запускаемся в режиме бухгалтерии и работаем.
В Н И М А Н И Е! Перед всеми манипуляциями настоятельно рекомендую сделать архивную копию базы данных,
с которой Вы работаете. Хотя если все делать правильно , то ничего плохого не случится.
6. ezupowam 12.10.11 16:27 Сейчас в теме
Ух ты! Еще и субконто закрываются! Супер. А то у меня двадцатка от предыдущего бухгалтера досталась такая заросшая, листов на двадцать ))) Сальдо правильное, а по субконто все красное ((
Спасибо автору!
7. 2011b11 13.10.11 08:34 Сейчас в теме
Спасибо, класс а то вечная проблема по закрытию счетов.
8. NPodolsk 13.10.11 12:29 Сейчас в теме
Как вовремя, огромное спасибо! Закрываю вручную именно "из - за невыполнения каких - либо условий"
9. warenic 106 13.10.11 17:39 Сейчас в теме
А чем не устроила старая добрая обработка "Закрытие счетов" (UCAccCls.ert) ажно 2008 года выпуска? Там не требовалось создавать новый документ (менять конфигурацию. тем более она могла быть базовой). Просто формировалась операция. Остатки по счетам и субконто можно закрывать с коэффициентом...
Ну, человек старался, минус ставить смысла нет.
10. DDos76 199 13.10.11 18:57 Сейчас в теме
(9) warenic,
Есть такая обработка. Сам пользовался не раз. Кажется только 2005 года. На диске ИТС.
А теперь вопрос: Изменили что - то "задним числом", т.е раньше этой операции - и счет уже не закрыт. Надо "Ручками" запускать обработку заново. И за 1 месяц. И за второй. И за третий. И через пару недель опять что - то поменяли. И опять обработку. И опять разбирайся когда "хвосты" возникли. И опять... приличные слова кончились. А тут перепровел документ - и опять 0! Всегда ноль! Гарантированный! А перепроведение - это вообще признак хорошего тона в бухии. У меня так все работают - перепровели доки - после баланс сводят и НДС.
11. DDos76 199 13.10.11 19:18 Сейчас в теме
(9) warenic,
Не поленился. Посмотрел - ACCLS.ERT у меня 2000 года рождения. И прекрасно работает! До поры до времени.
12. Полковник 19.10.11 07:05 Сейчас в теме
Спасибо, проверила на копии базы, все отлично. Вспоминаю закрытие счетов в начале года, просто как ужас! Без конца изменение задним числом, проведение, перепроведение и счет опять не закрыт! Наконец-то это закончилось! ура!
16. simuljakr 172 13.07.12 12:31 Сейчас в теме
Спасибо за разработку !
Еще бы неплохо сделать возможность отбора по субконто: если я хочу закрыть не весь счет, а только по одному контрагенту.
17. simuljakr 172 13.07.12 14:27 Сейчас в теме
Столкнулся с ошибкой: при закрытии забалансового счета ГТД - документ рисует лишнюю проводку (по каждой номенклатуре - по которой есть остаток) с пустым ГТД (второе субконто)...
18. safia-med 14.03.14 11:04 Сейчас в теме
Оставьте свое сообщение

См. также

Закрытие отрицательных остатков на 41 и 10 счете (БП 3.0 и Бух 7.7) 8

Инструменты и обработки Бухгалтер Архив с данными v8 v77::БУ v8::БУ 1С7:Бух БП3.0 БУ Закрытие периода Учет ТМЦ Абонемент ($m) Обработка документов Закрытие периода

Предлагаемые обработки позволят сформировать документ "Поступление товаров и материалов" по отрицательным остаткам ТМЦ (счета 41 и 10) за выбранный период. Для БП 3.0 и Бух 7.7.

1 стартмани

02.04.2018    10514    70    Ant10    0       

У контрагента изменился КПП. Как это отразить в декларации НДС при формировании в 1С: Предприятии 7.7? 0

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1cv7.md Россия БУ НУ Закрытие периода Оптовая торговля НДС Абонемент ($m) Регламентированная отчетность

В связи с отсутствием в типовых решениях 1С Предприятие 7.7 возможностей для хранения периодического КПП, предлагается обработка, реализующая альтернативное решение по отражению в Декларации НДС изменения КПП контрагента. С помощью данной обработки изменения с привязкой к дате можно вносить в уже сформированный комплект файлов электронной декларации.

1 стартмани

29.06.2017    14219    2    Sergey1CSpb    0       

Выводим из suspect базу 1С 7.7 на sql server 2000, а также "Перемещение баз данных SQL Server в новое местоположение с помощью операций Detach и Attach" 2

Статья Системный администратор Программист Архив с данными v7.7 1cv7.md Windows Абонемент ($m) Тестирование и исправление

База данных помечается Suspect, когда SQL Server не может читать файлы данных, связанные с базой данных с жесткого диска. В этом случае сделать бекап базы нельзя, но можно попробовать образ диска. После того как возможность читать файлы данных восстановлена, вы можете перезапустить службу SQL Server, и если возможно, произойдет автоматическое восстановление. Что делать, если информационная база 1С7.7 на SQL Server 2000 перешла в состояние suspect? Если это произошло утром и бекап сделан, Вы, конечно, можете грохнуть и раскатать базу заново (вечером это проблематичнее), но не торопитесь - возможно, поможет detach+attach или другие методы, изложенные в данной публикации.

1 стартмани

08.11.2016    17048    ksnik    3       

Автоматическое восстановление индексов БД 1С 7.7 по регламенту, сервер терминалов 1

Инструменты и обработки Системный администратор Архив с данными v7.7 1cv7.md Windows Абонемент ($m) Тестирование и исправление

За день работы в 1С 7.7 накапливается множество операций, случаются завершения работы 1С аварийно, после этого приходится выполнять восстановление индексов, заходить монопольно и ждать, пока пройдет операция восстановления. Когда я начал сталкиваться с этой проблемой каждое утро, то задумался об автоматизации процесса.

1 стартмани

09.06.2016    10355    1    tux    1       

Обнуление счета 0

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Украина БУ Windows Закрытие периода Абонемент ($m) Закрытие периода

В бухгалтерии накопилась масса непонятных остатков на счетах. Новая главбухша решила навести порядок в базе, я не стал ей перечить. В результате родилась эта обработка.

1 стартмани

21.03.2016    11144    4    uus    3       

Декларация по НДС. Раздел 8 и 9 - конвертация в xml-формат из Excel 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Windows Закрытие периода НДС Абонемент ($m) Регламентированная отчетность Загрузка и выгрузка в Excel Обмен через XML

Обработка формирует xml-файлы декларации по НДС из книги покупок и книги продаж, сохраненных в Excel. Пригодится тем, кому нужно вручную подправить декларацию.

1 стартмани

26.02.2016    9821    23    sarpa82    4       

Автоматический перенос даты запрета редактирования документов для 1С: 7.7 ТиС 1

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Россия Windows Абонемент ($m) Закрытие периода

Внешняя обработка автоматического переноса даты запрета редактирования документов 1С: 7.7 ТиС. Запускается при входе в Систему.

1 стартмани

17.02.2016    12051    5    avers007    1       

Расчет прямых расходов помесячно нарастающим итогом для стр.010 пр.2 к листу 2 декларации по налогу на прибыль 2

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Бух Россия БУ НУ Windows Закрытие периода Налог на прибыль Абонемент ($m) Бухгалтерские Налоговые

В соответствии с НК РФ производственные предприятия должны производить ежемесячно нарастающим итогом расчет прямых расходов по специальному алгоритму. Это является трудоемким процессом из-за необходимости ввода большого количества исходных данных ежемесячно. Предлагаемая обработка позволяет резко упростить этот расчет, так как пользователю требуется ввести всего пару исходных значений на начало года. Все остальные данные будут взяты автоматически из бухгалтерских итогов.

1 стартмани

08.02.2016    8583    4    chkurs    3       

23:59:59 Быстрое исправление одним нажатием без перепроведений! 3

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Windows Абонемент ($m) Обработка документов Тестирование и исправление

"Нет возможности разместить документ после ТА!" Никакого перепроведения - никаких проблем! Универсальная обработка для ТиС 9.2 и вообще любой конфигурации на оперативном учете. Лечит какой угодно объем за 5 минут! (Оперативный учет 7.7, SQL-версия)

1 стартмани

17.09.2015    7337    24    PZh1753    3       

Быстрая Книга учета доходов и расходов для комплексной 7.7 2

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v7.7 1С7:Комплекс БУ Windows Закрытие периода УСН Абонемент ($m) Бухгалтерские

Ведете УСН в комплексной 7.7? То еще развлечение. Этот отчет для тех, кто не перебрался на "родную" программу УСН.

4 стартмани

01.08.2015    10572    10    aspirator23    0       

Книга покупок и книга продаж для последующей загрузки в СБиС "Электронная отчетность" 0

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Бух Россия БУ НУ Windows Закрытие периода НДС Абонемент ($m) Регламентированная отчетность Бухгалтерские Налоговые

Исправлены ошибки в шаблонах печатных форм типовых отчетов "Книга покупок по Постановлению № 1137" и "Книга продаж по Постановлению № 1137" для последующей выгрузки в Excel и загрузки в отчет "НДС" СБиС "Электронная отчетность".

1 стартмани

28.07.2015    15963    43    kuzmina_ann    1       

Декларация по НДС - Бухгалтерия 7.7 (Книга покупок и продаж) 2015 год 4 квартал. Быстрые переходы на книгах покупок и продаж! 3

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Бух Россия БУ НУ Закрытие периода НДС Абонемент ($m) Бухгалтерские

Данные печатные формы решают следующую проблему: в разделе несколько сотен дополнительных групп строк (где по 10 строк книги покупок/продаж), довольно проблематично переходить по одной [группе строк] до какой-нибудь 415, где, к примеру, возникла ошибка. В файлах добавлен переход по 10 и 50 строк. Для ускорения работы тем более на медленных машинах.

1 стартмани

23.07.2015    7823    7    program345    1       

НДС 2015. Объединение разделов 8 и 9 по обособленным подразделениям в отчете головной организации 0

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ПУБ Россия БУ Windows Закрытие периода НДС Абонемент ($m) Регламентированная отчетность Налоговые

Консолидация разделов 8 и 9 (только их) по обособленным подразделениям в отчете головной организации. Обмен данными происходит через внешние файлы.

2 стартмани

20.07.2015    10239    2    v_id    1       

Выгрузка выставленных и полученных счет-фактур в XML для загрузки в Налогоплательщик-ЮЛ 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1С7:Бух Россия БУ Windows Закрытие периода НДС Абонемент ($m) Обмен через XML

Обработки для выгрузки выставленных и полученных счет-фактур (книга покупок и книга продаж) в XML для загрузки в Налогоплательщик-ЮЛ

1 стартмани

08.05.2015    13453    39    zmaxst    1       

Кассовая книга и архив книг для 1С 7.7 любой конфигурации 3

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v7.7 1cv7.md Россия БУ Windows Закрытие периода Кассовые операции ИП, ПБОЮЛ, КФХ Абонемент ($m) Бухгалтерские

Комплекс внешних обработок для удобного ведения в электронной форме кассовой книги формы №КО-4. Все функции редактирования кассовой книги, добавление записей инкассации, сквозная нумерация, печать приходных кассовых ордеров №КО-1 и расходных кассовых ордеров №КО-2. Возможность автоматического заполнения кассовой книги из журнала документов вашей ИБ (любой конфигурации).

5 стартмани

27.04.2015    29586    19    etmarket    11       

23:59:59 Исправление для Бухгалтерия 7.7: Перенос всех документов на начало часа (23:00), а регламентных - на конец часа (23:50). Закрытие 76.АВ 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух 1С7:ББУ Россия БУ Windows Абонемент ($m) Обработка документов Закрытие периода

Столкнулись с проблемой закрытия 76.АВ. Оказалось, что много документов, сформированных задним числом, программа устанавливает на 23:59:59. При попытке перенести регламентные документы (формирование записей книг покупок и продаж, закрытие месяца) они все равно не становятся последними. Можно, конечно, вручную изменять время всех документов, но если их не один или два?

1 стартмани

15.04.2015    11503    3    pann    1       

Блок учета посредников во входящих Счетах-фактурах для 1С Бухгалтерский учет 7.7. Формирование Книги покупок и Декларации НДС с учетом посредников 2

Отчеты и формы Программист Бухгалтер Архив с данными v77::БУ 1С7:Бух Россия БУ Windows Закрытие периода НДС Абонемент ($m) Регламентированная отчетность Налоговые

Комплект внешних обработок, реализующий более-менее приемлемый учет посредников для формирования Книг покупок и раздела 8 Декларации по НДС 2015. Блок не требует внесения изменений в конфигурацию ИБ!

1 стартмани

01.04.2015    18824    54    Sergey1CSpb    14       

Глюки со временем документа в таблицах 1С (SQL Server) 2

Инструменты и обработки Системный администратор Программист Подсистема v7.7 1cv7.md Windows Абонемент ($m) Тестирование и исправление

При загрузке в монопольном режиме SQL ругается: SQL State: 23000 Native: 1505 Message: [Microsoft][ODBC SQL Server Driver][SQL Server]CREATE UNIQUE INDEX terminated because a duplicate key was found for index ID 2. Most significant primary key is ' 20MGJ '.

1 стартмани

30.01.2015    11062    4    leoner61    4       

Таблицы 1.1, 1.3 книги доходов и расходов ИП на ОСНО 0

Отчеты и формы Бухгалтер Архив с данными v77::БУ 1С7:Комплекс Россия БУ Windows Закрытие периода Абонемент ($m) Налоговые

Книга доходов и расходов ИП на ОСНО. Отчет написан для комплексной конфигурации, учёт с НДС. Таблицы с буквой "А".

1 стартмани

31.07.2014    10126    11    xeon    1       

Обработка для аккуратной смены периода в ЗиК 7.7 0

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия Windows Зарплата Абонемент ($m) Обработка документов Закрытие периода

Данная обработка предназначена для смены периода расчета зарплаты, без пересчета регистров. Используется для аккуратного исправления или пересчета прошлым месяцем.

1 стартмани

10.06.2014    8991    19    Vladraven    1       

Обнуление забалансовых счетов 4

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ НУ Windows Закрытие периода Абонемент ($m) Универсальные обработки

Результат обработки - нулевые конечное сальдо по Дт и Кт. Полезно для выравнивания остатков на начало периода по БУ и НУ.

1 стартмани

29.03.2013    5696    34    Smallensky    3       

Быстрое удаление документов после свертки ИБ с применением прямого доступа к БД 7

Инструменты и обработки Программист Внешний отчет (ert,erf) v7.7 1cv7.md БУ НУ Windows Закрытие периода Оборотно-сальдовая ведомость, Анализ счета Абонемент ($m) Чистка базы Обработка документов

Сворачивал ИБ большого объема на SQL платформе. Столкнулся с проблемой удаления документов после формирования документов ввода начальных остатков. Средствами встроенного языка 1С не реально, потребовалось бы несколько суток. Вдохновила статья - http://dmitnik.narod.ru/article/article_3_1.html. Написал обработку с применением технологии прямых запросов, не устаю благодарить разработчиков 1С++. Удалил все, что требовалось за 1,5 часа.

1 стартмани

19.02.2013    9554    77    ray-xp    3       

Индивидуальная установка даты запрета редактирования документов в торговле 1С 7.7 3

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Россия УУ Windows Закрытие периода Абонемент ($m) Информационная безопасность

Установка даты запрета редактирования документов индивидуально для каждого пользователя,а также предоставление в индивидуальном порядке разрешения изменения конкретных документов в определенные периоды или в конкретные дни.Срок действия установок устанавливается вами. Вы можете спокойно настроить и уехать в отпуск.

1 стартмани

17.01.2013    21165    48    agent007_1    10       

Внешний отчет книга покупок, книга продаж, журнал полученных и выданных счет-фактур 2012 для старых релизов Комплексной конфигурации 7.7 7

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Комплекс Россия БУ Windows Закрытие периода НДС Абонемент ($m) Бухгалтерские

Внешний отчет книга покупок, книга продаж, журнал полученных и выданных счетов-фактур для старых релизов Комплексной конфигурации 7.7, применяемых с 2012 года в соответствии с постановлением №1137

1 стартмани

30.10.2012    7455    159    AlexSkyMan    3       

Контроль алкогольных реквизитов номенклатуры в ТиС 5

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Россия Оптовая торговля Розничная торговля Учет ТМЦ Акцизы Абонемент ($m) Тестирование и исправление Обработка справочников

Полнота заполнения "алкогольных" реквизитов справочника "Номенклатура" дает надежду на правильность алкогольной декларации! Трудности бухгалтеров в контроле этих реквизитов послужили причиной создания предлагаемой простой обработки.

1 стартмани

04.10.2012    10662    20    BorisBelov    3       

Контроль заполнения "алкогольных" реквизитов справочника Номенклатура 2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Акцизы Абонемент ($m) Тестирование и исправление Обработка справочников

Полнота заполнения "алкогольных" реквизитов справочника "Номенклатура" дает надежду на правильность алкогольной декларации! Трудности бухгалтеров в контроле этих реквизитов послужили причиной создания предлагаемой простой обработки.

1 стартмани

24.09.2012    11839    24    BorisBelov    4       

Acc77: Зачет авансов по счету 76.АВ для «1С: Бухгалтерия 7.7 редакция 4.5» 3

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Закрытие периода Абонемент ($m) Обработка документов

Внешняя обработка "Зачет авансов по счету 76.АВ" для «1С: Бухгалтерия 7.7 редакция 4.5». Отличительной особенностью данной разработки является полностью автоматизированное программное создание комплекта документов "Запись книги покупок" и "Счет-фактура выданный (на аванс)" за произвольный период по данным бухгалтерского учета с возможностью неоднократной обработки рабочего периода. Таким образом, после проверки корректности взаиморасчетов с покупателями для закрытия периода по разделу "НДС с авансов полученных" бухгалтеру будет достаточно самостоятельно запустить обработку нужного периода.

3 стартмани

29.07.2012    28443    49    Chastiser    12       

Acc77: Книга учета доходов и расходов (Раздел 1) для организаций на УСН, ведущих учет в «1С: Бухгалтерия 7.7 редакция 4.5» 14

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Бух Россия БУ Закрытие периода УСН Абонемент ($m) Регламентированная отчетность Бухгалтерские

Внешний отчет "Книга учета доходов и расходов. Раздел 1" для организаций на УСН, ведущих учет в «1С: Бухгалтерия 7.7 редакция 4.5». Отличительной особенностью данной разработки является включение в состав расходов результата анализа по каждому договору с поставщиком (исполнителем) сумм полученных и оплаченных товаров (услуг), в т.ч. частично, с выделением входящего НДС. Таким образом, в состав расходов не попадет предоплата поставщику, если товар по договору не успел поступить за отчетный период. Также останется без внимания поставка товаров (оказание услуг) по договору, если мы за них ещё не оплатили в отчетном периоде.

3 стартмани

23.07.2012    36140    133    Chastiser    14       

Предварительный расчет НДС за квартал с учетом допустимых вычетов 9

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия НУ Закрытие периода НДС Абонемент ($m) Налоговые

Предварительный расчет НДС за квартал. Заново все пересчитала и исправила ошибки. и учла допустимый вычет НДС

1 стартмани

09.04.2012    10473    67    Доня    6       

Книга покупок и Журнал учета счетов-фактур для ПУБ 7.7 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::ОУ v77::БУ 1С7:ПУБ Россия БУ Закрытие периода НДС Абонемент ($m) Бухгалтерские

Журнал учета счетов фактур и Книга покупок для конфигурации 1С:Производство+Услуги+Бухгалтерия 7.7 (с небольшими исправлениями и доработками)

1 стартмани

06.04.2012    15005    89    aserg    5       

Сброс данных по периоду для формирования регламентированной отчетности 5

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Закрытие периода Абонемент ($m) Регламентированная отчетность

При запуске формы баланса за 2011 год форма открылась с периодом "Январь - Декабрь 2010 года". При попытке сменить период вывелось сообщение "Данная версия отчета действует за период начиная с 2011 года"

1 стартмани

28.03.2012    5091    15    Bratek    1       

Отчетная форма статистики №11 (краткая) за 2011 год с автозаполнением и проверкой контрольных соотношений (для казенных учреждений) 4

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:ББУ Россия БУ Закрытие периода Абонемент ($m) Регламентированная отчетность Статистики

Доработанный стандартный отчет регламентированной отчетности за 4 кв. 2011 года для государственных органов, государственных и муниципальных учреждений, работающих по плану счетов 162н. Доработка состоит в следующем. 1) На основной закладке добавлена кнопка «Заполнить», обеспечивающая автоматический расчет и заполнение показателей формы, а также проверку основных контрольных соотношений. Алгоритм расчета показателей и проверки контрольных соотношений выполнен в соответствии с Указаниями по заполнению формы 11 (краткая), утвержденными приказом Росстата №506 от 26.12.2011г. 2) На этой же закладке добавлено поле со списком для выбора основного вида экономической деятельности учреждения и раздела ОКВЭД, которые необходимы для автоматического заполнения строки 15 формы. 3) В таблицу формы добавлена дополнительная графа «Наличие на начало года по полной учетной стоимости», необходимая пользователям для сравнения данных на конец предыдущего и начало текущего отчетного года. В печатную форму, сдаваемую в органы статистики, эта графа не попадает.

1 стартмани

26.03.2012    21968    30    infotec    1       

Выгрузка из БГУ 7.7. бланков строгой отчетности - остатков счета 03 (формирование документов "Поступление БСО" по остаткам счета 03) 3

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v77::БУ 1С7:ББУ Государственные, бюджетные структуры Россия БУ Госбюджет Windows Управление персоналом (HRM) Абонемент ($m) Обработка документов Тестирование и исправление Перенос данных из 1С7.7 в 1C8.X

Штатная выгрузка из БГУ 7.7. в БГУ 8.2 неправильно и не полностью переносит остатки по счету 03 - не переносятся начальные и конечные номера бланков, бланки, принадлежащие одному лицу, при переносе оказывается у другого. При этом перенос документов по движениям бланков строгой отчетности реализован хорошо. Эта обработка предназначена для формирования документов "Поступление БСО" в базе БГУ 7.7 на основе остатков по счету А03. При дальнейшей выгрузке штатными средствами остатки в документах переносятся без ошибок.

1 стартмани

23.03.2012    10358    30    snegovik    4       

Перенос даты запрета редактирования 4

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС Россия Абонемент ($m) Закрытие периода Администрирование данных 1С

Обработка автоматического запуска восстановления последовательностей и установки даты запрета редактирования документов.

1 стартмани

15.02.2012    11079    42    avers007    3       

Скрипт для обновления регламентированной отчетности в нескольких базах сразу, не надо заходить в 1с. Скрипт сам распаковывает и копирует. 8

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v77::БУ 1С7:БМО 1С7:Бух 1С7:ЗиК 1С7:Комплекс 1С7:ПУБ 1С7:ББУ Россия БУ Windows Закрытие периода Абонемент ($m) Регламентированная отчетность Администрирование данных 1С

Скрипт извлекает файлы по временную папку. Затем по каждой базе из списка копирует файлы туда, где они должны быть. При необходимости создаёт каталог для файлов отчетности, обычно если это первая версия отчетности квартала. Если не первая - обновляет файлы. Корректно копирует по сети и локально. Необходимо лишь указать в файле полный путь к каждой базе.

1 стартмани

13.02.2012    8611    33    evgenum    14       

Неправильно выписанные счета-фактуры на аванс 4

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Закрытие периода Абонемент ($m) Бухгалтерские Анализ учета

Частенько в выписке по счету 62.2 пользователи меняют договор, а вот исправить сч-ф на аванс забывают, или забывают выписать сч-фактуру на аванс. Такие ошибки выявляет этот отчет. Документы с ошибками можно выводить прямо из отчета

1 стартмани

02.02.2012    7758    26    gga    4       

Формы 110,121,130,168,230 из комплекта от 19.01.2012 за 4кв. 2011 с фильтром по балансосодержателям. 1

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:ББУ Россия БУ Закрытие периода Абонемент ($m) Регламентированная отчетность

Формы 110,121,130,168,230 из комплекта от 19.01.2012 за 4кв. 2011 с фильтром по балансосодержателям, проставить галочки против выбранных и заполнить.

1 стартмани

26.01.2012    3953    10    Atol    2       

Подготовка формирования книг покупок/продаж 7.7 8

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух БУ НУ Windows НДС Абонемент ($m) Обработка документов Пакетная печать Закрытие периода

Обработка для подготовки формирования книги покупок, книги продаж для бухгалтерии 7.7. Запоздалая конечно (написано давно). Я думал уже не надо никому, оказывается, на форуме народ ещё обсуждает....

1 стартмани

02.01.2012    16562    95    Alex_E    7       

Замена элементов справочников в конфигурации 7

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Абонемент ($m) Поиск данных Универсальные обработки Тестирование и исправление

Групповая замена одних элементов справочников на другие в реквизитах справочников, документов, операций документов (без перепроведения)

1 стартмани

14.12.2011    7827    37    dimaster    3       

Обработка для принудительного удаления документов 1С 7.7 ТиС 1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1С7:ТиС Россия Закрытие периода Абонемент ($m) Свертка базы

Использует транзакции для быстрого удаления. Написана мною для быстрой очистки прошлого периода (свертка). Код простой, но проверенный и практичный. В помощь программеру свертывальщику.

1 стартмани

08.12.2011    14080    99    Deda    10       

Поиск и восстановление битых ссылок (объект не найден) в реквизитах документов с помощью УРБД 1с 7.7 2

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m) Распределенная БД (УРИБ, УРБД) Тестирование и исправление

Данная обработка выполняет два действия: 1. Ищет в реквизитах документов битые ссылки по фразе "" и записывает результаты в файл LostIn1c.txt на диск D. 2. С помощью данных в сохраненном файле в связанной через УРБД базе (предполагается, что в этой базе с данными все нормально) находит эти реквизиты и регистрирует их на выгрузку. Ну а дальше достаточно сделать обмен в УРБД между базами, чтобы ссылки восстановились.

1 стартмани

30.11.2011    14644    88    roms6    5       

Искатель v1.1: Поиск документов без проводок, без движений по регистрам 1C 7.7 6

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v77::ОУ v77::БУ 1cv7.md Windows Абонемент ($m) Обработка документов Поиск данных Тестирование и исправление

Искатель, версия 1.1 Данная обработка будет искать проведенные документы без проводок по бухгалтерскому учету и без движений по регистрам.

1 стартмани

22.11.2011    10537    52    Andruykha    12