Документ закрытие счетов. Может закрыть в 0 вообще все счета!

Публикация № 93508

Учет и отчетность - Закрытие периода - Закрытие периода

Данный документ встраивается в любую конфигурацию, построенную на компоненте "Бухгалтерский учет". Просто скопируйте документ и назначьте ему нужный журнал. Что документ делает? Все очень просто: в табличной части указывается список балансовых счетов, которые нужно закрыть в 0. При проведении документ анализирует сальдо по счетам и формирует проводки, закрывающие счет, в корреспонденции с тем счетом, который указан в шапке документа. Может быть полезен, когда регламентные документы не позволяют закрыть, например, 90,44,20 счет из - за невыполнения каких - либо условий,  а также как шаблон для собственной разработки.

Привожу код модуля документа, для тех, кому не судьба скачать:

 


Перем Ит;

Перем
МСубконто[3];

//**********************************************************



Процедура СформироватьОперацию(ДК=0,СчетДвиж,Субконто_1,Субконто_2,Субконто_3,Сумма,Количество)

   
Операция.НоваяПроводка();

   
Операция.ПервичныйДокумент  = "Закрытие счетов № " + НомерДок;

   
Операция.Количество = Количество;

   
Операция.Сумма = Сумма;

    Если
ДК = 0 Тогда

        Если
СчетДвиж.Забалансовый = 0 Тогда

           
Операция.Дебет.Счет = СчетТранзита;

           
Операция.Дебет.Субконто(1,Субконто1);

           
Операция.Дебет.Субконто(2,Субконто2);

           
Операция.Дебет.Субконто(3,Субконто3);

        КонецЕсли;

       
Операция.Кредит.Счет = СчетДвиж;

        Если
МСубконто[1] <> 0 Тогда

           
Операция.Кредит.Субконто(МСубконто[1],Субконто_1);

        КонецЕсли;

        Если
МСубконто[2] <> 0 Тогда

           
Операция.Кредит.Субконто(МСубконто[2],Субконто_2);

        КонецЕсли;

        Если
МСубконто[3] <> 0 Тогда

           
Операция.Кредит.Субконто(МСубконто[3],Субконто_3);

        КонецЕсли;

    Иначе

        Если
СчетДвиж.Забалансовый = 0 Тогда

           
Операция.Кредит.Счет = СчетТранзита;

           
Операция.Кредит.Субконто(1,Субконто1);

           
Операция.Кредит.Субконто(2,Субконто2);

           
Операция.Кредит.Субконто(3,Субконто3);

        КонецЕсли;

       
Операция.Дебет.Счет = СчетДвиж;

        Если
МСубконто[1] <> 0 Тогда

           
Операция.Дебет.Субконто(МСубконто[1],Субконто_1);

        КонецЕсли;

        Если
МСубконто[2] <> 0 Тогда

           
Операция.Дебет.Субконто(МСубконто[2],Субконто_2);

        КонецЕсли;

        Если
МСубконто[3] <> 0 Тогда

           
Операция.Дебет.Субконто(МСубконто[3],Субконто_3);

        КонецЕсли;

    КонецЕсли;

КонецПроцедуры

//**************************************************

Процедура ЗакрытьСчет(Счет)

   
КолСубконто = 0;

    Для
Б = 1 По 3 Цикл

       
МСубконто[Б] = 0;

    КонецЦикла;

    Для
А = 1 По Счет.КоличествоСубконто() Цикл

       
//Оборотные субконто нас не интересуют!

       
Если Счет.ТолькоОбороты(А) = 0 Тогда

           
Ит.ИспользоватьСубконто(Счет.ВидСубконто(А),, 1);

           
КолСубконто = КолСубконто + 1;

           
МСубконто[КолСубконто] = А;

        КонецЕсли;

    КонецЦикла;

   
Ит.ВыполнитьЗапрос(ДатаДок, ДатаДок, Счет,,,1,, 1+4);

    Если
КолСубконто = 0 Тогда

        Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

           
СформироватьОперацию(0,Счет,,,,Ит.СКД(),Ит.СКД(3));

        ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

           
СформироватьОперацию(1,Счет,,,,Ит.СКК(),Ит.СКК(3));

        КонецЕсли;

    ИначеЕсли
КолСубконто > 0 Тогда

       
Ит.ВыбратьСубконто(Счет.ВидСубконто(МСубконто[1]));

        Пока
Ит.ПолучитьСубконто(Счет.ВидСубконто(МСубконто[1])) = 1 Цикл

            Если
КолСубконто > 1 Тогда

               
//Для материальных счетов = итоговые проводки по сумме делаем сразу

               
Если (Счет.УчетПосумме(2) = 0) и (Счет.УчетПоКоличеству(2) = 1) Тогда

                    Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                       
СформироватьОперацию(0,Счет,Ит.Субконто(1),,,Ит.СКД(),0);

                    ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                       
СформироватьОперацию(1,Счет,Ит.Субконто(1),,,Ит.СКК(),0);

                    КонецЕсли;

                ИначеЕсли (
Счет.УчетПосумме(2) = 1) и (Счет.УчетПоКоличеству(2) = 0) Тогда

                    Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                       
СформироватьОперацию(0,Счет,Ит.Субконто(1),,,0,Ит.СКД(3));

                    ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                       
СформироватьОперацию(1,Счет,Ит.Субконто(1),,,0,Ит.СКК(3));

                    КонецЕсли;

                КонецЕсли;

               
Ит.ВыбратьСубконто(Счет.ВидСубконто(МСубконто[2]));

                Пока
Ит.ПолучитьСубконто(Счет.ВидСубконто(МСубконто[2])) = 1 Цикл

                    Если
КолСубконто > 2 Тогда

                       
Ит.ВыбратьСубконто(Счет.ВидСубконто(МСубконто[3]));

                        Пока
Ит.ПолучитьСубконто(Счет.ВидСубконто(МСубконто[3])) = 1 Цикл

                            Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                               
СформироватьОперацию(0,Счет,Ит.Субконто(1),Ит.Субконто(2),Ит.Субконто(3),Ит.СКД(),Ит.СКД(3));

                            ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                               
СформироватьОперацию(1,Счет,Ит.Субконто(1),Ит.Субконто(2),Ит.Субконто(3),Ит.СКК(),Ит.СКК(3));

                            КонецЕсли;

                        КонецЦикла;

                    Иначе

                        Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                           
СформироватьОперацию(0,Счет,Ит.Субконто(1),Ит.Субконто(2),,Ит.СКД(),Ит.СКД(3));

                        ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                           
СформироватьОперацию(1,Счет,Ит.Субконто(1),Ит.Субконто(2),,Ит.СКК(),Ит.СКК(3));

                        КонецЕсли;

                    КонецЕсли;

                КонецЦикла;

            Иначе

                Если (
Ит.СКД() <> 0) или (Ит.СКД(3) <> 0) Тогда

                   
СформироватьОперацию(0,Счет,Ит.Субконто(1),,,Ит.СКД(),Ит.СКД(3));

                ИначеЕсли (
Ит.СКК() <> 0) или (Ит.СКК(3) <> 0) Тогда

                   
СформироватьОперацию(1,Счет,Ит.Субконто(1),,,Ит.СКК(),Ит.СКК(3));

                КонецЕсли;

            КонецЕсли;

        КонецЦикла;

    КонецЕсли;

КонецПроцедуры

//**************************************************

Процедура ОбработкаПроведения()

   
Ит = СоздатьОбъект("БухгалтерскиеИтоги");

   
Ит.ИспользоватьПланСчетов(ОсновнойПланСчетов());

   
//Ит.ИспользоватьРазделительУчета(Фирма);

   
ВыбратьСтроки();

    Пока
ПолучитьСтроку() = 1 Цикл

       
ЗакрытьСчет(СчетЗакрытия);

    КонецЦикла;

   
Операция.Записать();

КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
1Cv7.MD

.MD 179,00Kb
90
.MD 179,00Kb 90 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. TrinitronOTV 7 07.10.11 11:17 Сейчас в теме
интересный вариант реализации...
2. DDos76 200 07.10.11 12:24 Сейчас в теме
Особенно если сделать кнопку "заполнить счетами". Нажал - провел- баланс по 0!. Вручную так и делал в Комплексной. Только по разделителю учета. Вычищал остатки по ликвидированным фирмам перед обрезанием базы. Чтоб хвосты не таскать.
3. TrinitronOTV 7 07.10.11 19:37 Сейчас в теме
DDos76 пишет:

Особенно если сделать кнопку "заполнить счетами". Нажал - провел- баланс по 0!. Вручную так и делал в Комплексной. Только по разделителю учета. Вычищал остатки по ликвидированным фирмам перед обрезанием базы. Чтоб хвосты не таскать.

спасибо за отчет
4. salli80 08.10.11 11:21 Сейчас в теме
А нельзя чуть (для блондинок ) подробнее.Я создала журнал в конфигураторе ,а вот куда скопировать файл не поняла .Подскажите пожалуста.Вещица нужная для меня ))
5. DDos76 200 09.10.11 16:18 Сейчас в теме
Специально для блондинок:
Код, приведенный на сайте, может быть полезен только тем, кто знаком с редактированием
документов в конфигураторе. В Вашем случае придется поступить по - другому:
Скачиваем файл 1CV7.MD с сайта. (там он есть, уже готовый)
Сохраняем его в отдельную папку на компьютере.
Прописываем путь запуска 1с в эту папку (регистрируем новую базу)
Запускаем конфигуратор этой базы. Далее в конфигураторе Конфигурация - открыть конфигурацию.
Раскрываем папочку "Документы". Там есть только один документ. Встаем на него - говорим "Ctrl+C"
(копировать в буфер), потом открываем свою, рабочую конфигурацию, открываем конфигурацию, встаем на
папочку "документы" и давим "ctrl+v" (вставить). Потом листаем содержимое этой папочки до самого
низа и видим вставленный документ. Щелкаем по нему и в открывшемся окне справа вверху выставляем журнал.
Сохраняем конфигурацю. Запускаемся в режиме бухгалтерии и работаем.
В Н И М А Н И Е! Перед всеми манипуляциями настоятельно рекомендую сделать архивную копию базы данных,
с которой Вы работаете. Хотя если все делать правильно , то ничего плохого не случится.
6. ezupowam 12.10.11 16:27 Сейчас в теме
Ух ты! Еще и субконто закрываются! Супер. А то у меня двадцатка от предыдущего бухгалтера досталась такая заросшая, листов на двадцать ))) Сальдо правильное, а по субконто все красное ((
Спасибо автору!
7. 2011b11 13.10.11 08:34 Сейчас в теме
Спасибо, класс а то вечная проблема по закрытию счетов.
8. NPodolsk 13.10.11 12:29 Сейчас в теме
Как вовремя, огромное спасибо! Закрываю вручную именно "из - за невыполнения каких - либо условий"
9. warenic 108 13.10.11 17:39 Сейчас в теме
А чем не устроила старая добрая обработка "Закрытие счетов" (UCAccCls.ert) ажно 2008 года выпуска? Там не требовалось создавать новый документ (менять конфигурацию. тем более она могла быть базовой). Просто формировалась операция. Остатки по счетам и субконто можно закрывать с коэффициентом...
Ну, человек старался, минус ставить смысла нет.
10. DDos76 200 13.10.11 18:57 Сейчас в теме
(9) warenic,
Есть такая обработка. Сам пользовался не раз. Кажется только 2005 года. На диске ИТС.
А теперь вопрос: Изменили что - то "задним числом", т.е раньше этой операции - и счет уже не закрыт. Надо "Ручками" запускать обработку заново. И за 1 месяц. И за второй. И за третий. И через пару недель опять что - то поменяли. И опять обработку. И опять разбирайся когда "хвосты" возникли. И опять... приличные слова кончились. А тут перепровел документ - и опять 0! Всегда ноль! Гарантированный! А перепроведение - это вообще признак хорошего тона в бухии. У меня так все работают - перепровели доки - после баланс сводят и НДС.
11. DDos76 200 13.10.11 19:18 Сейчас в теме
(9) warenic,
Не поленился. Посмотрел - ACCLS.ERT у меня 2000 года рождения. И прекрасно работает! До поры до времени.
12. Полковник 19.10.11 07:05 Сейчас в теме
Спасибо, проверила на копии базы, все отлично. Вспоминаю закрытие счетов в начале года, просто как ужас! Без конца изменение задним числом, проведение, перепроведение и счет опять не закрыт! Наконец-то это закончилось! ура!
16. simuljakr 181 13.07.12 12:31 Сейчас в теме
Спасибо за разработку !
Еще бы неплохо сделать возможность отбора по субконто: если я хочу закрыть не весь счет, а только по одному контрагенту.
17. simuljakr 181 13.07.12 14:27 Сейчас в теме
Столкнулся с ошибкой: при закрытии забалансового счета ГТД - документ рисует лишнюю проводку (по каждой номенклатуре - по которой есть остаток) с пустым ГТД (второе субконто)...
18. safia-med 14.03.14 11:04 Сейчас в теме
Оставьте свое сообщение

См. также

Acc77: Зачет авансов по счету 76.АВ для «1С: Бухгалтерия 7.7 редакция 4.5» Промо

Обработка документов Закрытие периода Закрытие периода v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Внешняя обработка "Зачет авансов по счету 76.АВ" для «1С: Бухгалтерия 7.7 редакция 4.5». Отличительной особенностью данной разработки является полностью автоматизированное программное создание комплекта документов "Запись книги покупок" и "Счет-фактура выданный (на аванс)" за произвольный период по данным бухгалтерского учета с возможностью неоднократной обработки рабочего периода. Таким образом, после проверки корректности взаиморасчетов с покупателями для закрытия периода по разделу "НДС с авансов полученных" бухгалтеру будет достаточно самостоятельно запустить обработку нужного периода.

3 стартмани

29.07.2012    33410    49    Chastiser    12    

Закрытие отрицательных остатков на 41 и 10 счете (БП 3.0 и Бух 7.7)

Обработка документов Закрытие периода Закрытие периода Учет ТМЦ Закрытие периода Учет ТМЦ v8 v77::БУ v8::БУ 1С7:Бух БП3.0 БУ Абонемент ($m)

Предлагаемые обработки позволят сформировать документ "Поступление товаров и материалов" по отрицательным остаткам ТМЦ (счета 41 и 10) за выбранный период. Для БП 3.0 и Бух 7.7.

1 стартмани

02.04.2018    19366    108    Ant10    0    

Автоматическое исправление ошибки в БД "Проверка уникальности внутреннего идентификатора ..."

Тестирование и исправление v7.7 1cv7.md Абонемент ($m)

Внешняя универсальная обработка для автоматизированного исправления ошибок в БД типа «Проверка уникальности внутреннего идентификатора в справочнике. ….. Исправить вручную»

1 стартмани

06.02.2018    8728    3    drako    0    

Документ Закрытие регистров для 1С: 7.7 Торговля и Склад

Закрытие периода v77::ОУ 1С7:ТиС УУ Абонемент ($m)

Нужен для обнуления ненужных остатков по регистрам, для ускорения работы 1С. Ненужные остатки: если по ним не было движений следующие 90 дней

1 стартмани

04.07.2017    12368    9    ManyakRus    5    

Закрытие периода в 1с77 Промо

Закрытие периода Закрытие периода Закрытие периода v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Россия БУ Абонемент ($m)

Набор документов и обработок для переноса остатков по регистрам

1 стартмани

11.02.2012    36791    122    fixin    5    

У контрагента изменился КПП. Как это отразить в декларации НДС при формировании в 1С: Предприятии 7.7?

Регламентированная отчетность Закрытие периода Оптовая торговля Закрытие периода Оптовая торговля v77::БУ 1cv7.md Россия БУ НУ НДС Абонемент ($m)

В связи с отсутствием в типовых решениях 1С Предприятие 7.7 возможностей для хранения периодического КПП, предлагается обработка, реализующая альтернативное решение по отражению в Декларации НДС изменения КПП контрагента. С помощью данной обработки изменения с привязкой к дате можно вносить в уже сформированный комплект файлов электронной декларации.

1 стартмани

29.06.2017    18625    2    Sergey1CSpb    0    

Автоматическое восстановление индексов БД 1С 7.7 по регламенту, сервер терминалов

Тестирование и исправление v7.7 1cv7.md Абонемент ($m)

За день работы в 1С 7.7 накапливается множество операций, случаются завершения работы 1С аварийно, после этого приходится выполнять восстановление индексов, заходить монопольно и ждать, пока пройдет операция восстановления. Когда я начал сталкиваться с этой проблемой каждое утро, то задумался об автоматизации процесса.

1 стартмани

09.06.2016    12718    2    tux    1    

Обнуление счета

Закрытие периода Закрытие периода Закрытие периода v77::БУ 1С7:Бух Украина БУ Абонемент ($m)

В бухгалтерии накопилась масса непонятных остатков на счетах. Новая главбухша решила навести порядок в базе, я не стал ей перечить. В результате родилась эта обработка.

1 стартмани

21.03.2016    14080    5    uus    3    

Отчеты и обработки для закрытия периода по НДС Промо

Закрытие периода Закрытие периода Закрытие периода v77::БУ 1С7:Бух Россия БУ НДС Абонемент ($m)

Отчеты и обработки для закрытия периода по НДС.

1 стартмани

15.04.2009    22466    2707    KapasMordorov    22    

Декларация по НДС. Раздел 8 и 9 - конвертация в xml-формат из Excel

Регламентированная отчетность Загрузка и выгрузка в Excel Обмен через XML Закрытие периода Закрытие периода v77::БУ 1С7:Бух Россия БУ НДС Абонемент ($m)

Обработка формирует xml-файлы декларации по НДС из книги покупок и книги продаж, сохраненных в Excel. Пригодится тем, кому нужно вручную подправить декларацию.

1 стартмани

26.02.2016    13535    23    sarpa82    4    

Автоматический перенос даты запрета редактирования документов для 1С: 7.7 ТиС

Закрытие периода v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Внешняя обработка автоматического переноса даты запрета редактирования документов 1С: 7.7 ТиС. Запускается при входе в Систему.

1 стартмани

17.02.2016    14344    4    avers007    1    

23:59:59 Быстрое исправление одним нажатием без перепроведений!

Обработка документов Тестирование и исправление v77::ОУ 1С7:ТиС Абонемент ($m)

"Нет возможности разместить документ после ТА!" Никакого перепроведения - никаких проблем! Универсальная обработка для ТиС 9.2 и вообще любой конфигурации на оперативном учете. Лечит какой угодно объем за 5 минут! (Оперативный учет 7.7, SQL-версия)

1 стартмани

17.09.2015    10183    25    PZh1753    3    

Поиск ошибок в регистрах 7.7 Промо

Поиск данных Тестирование и исправление Анализ учета v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Обработка позволяет найти ошибки в регистрах 7.7 в Вашей базе данных

1 стартмани

04.05.2010    25357    425    _Z1    31    

Проверка информационной базы 7.7 на некорректные символы

Тестирование и исправление v7.7 1cv7.md Абонемент ($m)

Поиск спецсимволов непосредственно в текстовых полях информационной базы 7.7.

1 стартмани

21.05.2015    10668    31    tedkuban    7    

Выгрузка выставленных и полученных счет-фактур в XML для загрузки в Налогоплательщик-ЮЛ

Обмен через XML Закрытие периода Закрытие периода v7.7 1С7:Бух Россия БУ НДС Абонемент ($m)

Обработки для выгрузки выставленных и полученных счет-фактур (книга покупок и книга продаж) в XML для загрузки в Налогоплательщик-ЮЛ

1 стартмани

08.05.2015    17075    37    zmaxst    1    

23:59:59 Исправление для Бухгалтерия 7.7: Перенос всех документов на начало часа (23:00), а регламентных - на конец часа (23:50). Закрытие 76.АВ

Обработка документов Закрытие периода v77::БУ 1С7:Бух 1С7:ББУ Россия БУ Абонемент ($m)

Столкнулись с проблемой закрытия 76.АВ. Оказалось, что много документов, сформированных задним числом, программа устанавливает на 23:59:59. При попытке перенести регламентные документы (формирование записей книг покупок и продаж, закрытие месяца) они все равно не становятся последними. Можно, конечно, вручную изменять время всех документов, но если их не один или два?

1 стартмани

15.04.2015    13673    3    pann    1    

Глюки со временем документа в таблицах 1С (SQL Server)

Тестирование и исправление v7.7 1cv7.md Абонемент ($m)

При загрузке в монопольном режиме SQL ругается: SQL State: 23000 Native: 1505 Message: [Microsoft][ODBC SQL Server Driver][SQL Server]CREATE UNIQUE INDEX terminated because a duplicate key was found for index ID 2. Most significant primary key is ' 20MGJ '.

1 стартмани

30.01.2015    13291    4    leoner61    4    

Обработка для аккуратной смены периода в ЗиК 7.7

Закрытие периода Зарплата Обработка документов Зарплата v77::Расчет 1С7:ЗиК Россия Абонемент ($m)

Данная обработка предназначена для смены периода расчета зарплаты, без пересчета регистров. Используется для аккуратного исправления или пересчета прошлым месяцем.

1 стартмани

10.06.2014    11113    21    Vladraven    1    

Обнуление забалансовых счетов

Универсальные обработки Закрытие периода Закрытие периода v77::БУ 1С7:Бух Россия БУ НУ Абонемент ($m)

Результат обработки - нулевые конечное сальдо по Дт и Кт. Полезно для выравнивания остатков на начало периода по БУ и НУ.

1 стартмани

29.03.2013    8254    35    Smallensky    3    

Быстрое удаление документов после свертки ИБ с применением прямого доступа к БД

Чистка базы Обработка документов Закрытие периода Оборотно-сальдовая ведомость, Анализ счета Закрытие периода Оборотно-сальдовая ведомость, Анализ счета v7.7 1cv7.md БУ НУ Абонемент ($m)

Сворачивал ИБ большого объема на SQL платформе. Столкнулся с проблемой удаления документов после формирования документов ввода начальных остатков. Средствами встроенного языка 1С не реально, потребовалось бы несколько суток. Вдохновила статья - http://dmitnik.narod.ru/article/article_3_1.html. Написал обработку с применением технологии прямых запросов, не устаю благодарить разработчиков 1С++. Удалил все, что требовалось за 1,5 часа.

1 стартмани

19.02.2013    12405    81    ray-xp    3    

Индивидуальная установка даты запрета редактирования документов в торговле 1С 7.7

Информационная безопасность Закрытие периода Закрытие периода v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Установка даты запрета редактирования документов индивидуально для каждого пользователя,а также предоставление в индивидуальном порядке разрешения изменения конкретных документов в определенные периоды или в конкретные дни.Срок действия установок устанавливается вами. Вы можете спокойно настроить и уехать в отпуск.

1 стартмани

17.01.2013    24915    46    agent007_1    10    

Выгрузка баланса и финансовых результатов в XML

Закрытие периода Обмен через XML Закрытие периода v7.7 1cv7.md Украина БУ Абонемент ($m)

Выгрузка баланса и финансовых результатов в XML

1 стартмани

14.10.2012    19171    14    Gazulo    1    

Контроль алкогольных реквизитов номенклатуры в ТиС

Обработка справочников Тестирование и исправление Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v77::ОУ 1С7:ТиС Россия Акцизы Абонемент ($m)

Полнота заполнения "алкогольных" реквизитов справочника "Номенклатура" дает надежду на правильность алкогольной декларации! Трудности бухгалтеров в контроле этих реквизитов послужили причиной создания предлагаемой простой обработки.

1 стартмани

04.10.2012    14163    20    BorisBelov    3    

Контроль заполнения "алкогольных" реквизитов справочника Номенклатура

Тестирование и исправление Обработка справочников v77::БУ 1С7:Бух Россия БУ Акцизы Абонемент ($m)

Полнота заполнения "алкогольных" реквизитов справочника "Номенклатура" дает надежду на правильность алкогольной декларации! Трудности бухгалтеров в контроле этих реквизитов послужили причиной создания предлагаемой простой обработки.

1 стартмани

24.09.2012    14541    23    BorisBelov    4    

Универсальная замена справочника

Обработка справочников Тестирование и исправление v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Заменяет один справочник на другой во всех объектах конфигурации, ссылающихся на справочник

1 стартмани

22.08.2012    9016    32    mic4    3    

Ошибка при формировании отчета 4-ФСС USN_12q1007_05.04.2012

Регламентированная отчетность Практика программирования Закрытие периода Закрытие периода v77::БУ 1С7:Бух Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Исправление ошибки при формировании ФСС раздел 7. Регламентированные отчеты. УСН. 7.7.

1 стартмани

13.04.2012    9085    2    sasha1610    1    

Выгрузка из БГУ 7.7. бланков строгой отчетности - остатков счета 03 (формирование документов "Поступление БСО" по остаткам счета 03)

Обработка документов Тестирование и исправление Управление персоналом (HRM) Перенос данных из 1С7.7 в 1C8.X Управление персоналом (HRM) v77::БУ 1С7:ББУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Штатная выгрузка из БГУ 7.7. в БГУ 8.2 неправильно и не полностью переносит остатки по счету 03 - не переносятся начальные и конечные номера бланков, бланки, принадлежащие одному лицу, при переносе оказывается у другого. При этом перенос документов по движениям бланков строгой отчетности реализован хорошо. Эта обработка предназначена для формирования документов "Поступление БСО" в базе БГУ 7.7 на основе остатков по счету А03. При дальнейшей выгрузке штатными средствами остатки в документах переносятся без ошибок.

1 стартмани

23.03.2012    12974    30    snegovik    4    

Пакетное создание документов на основании выписок (авансы) 1с 7.7 Бух Учет.

Обработка документов Закрытие периода Закрытие периода v77::БУ 1cv7.md 1С7:Бух Россия БУ Абонемент ($m)

Автоматическое закрытие счетов аванса 60 и 62. Создание документов для закрытия.

1 стартмани

17.02.2012    7705    30    Himik861    1    

Перенос даты запрета редактирования

Администрирование данных 1С Закрытие периода v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка автоматического запуска восстановления последовательностей и установки даты запрета редактирования документов.

1 стартмани

15.02.2012    12831    40    avers007    3    

Скрипт для обновления регламентированной отчетности в нескольких базах сразу, не надо заходить в 1с. Скрипт сам распаковывает и копирует.

Регламентированная отчетность Администрирование данных 1С Закрытие периода Закрытие периода v77::БУ 1С7:БМО 1С7:Бух 1С7:ЗиК 1С7:Комплекс 1С7:ПУБ 1С7:ББУ Россия БУ Абонемент ($m)

Скрипт извлекает файлы по временную папку. Затем по каждой базе из списка копирует файлы туда, где они должны быть. При необходимости создаёт каталог для файлов отчетности, обычно если это первая версия отчетности квартала. Если не первая - обновляет файлы. Корректно копирует по сети и локально. Необходимо лишь указать в файле полный путь к каждой базе.

1 стартмани

13.02.2012    10654    33    evgenum    14    

Подготовка формирования книг покупок/продаж 7.7

Обработка документов Пакетная печать Закрытие периода v77::БУ 1С7:Бух БУ НУ НДС Абонемент ($m)

Обработка для подготовки формирования книги покупок, книги продаж для бухгалтерии 7.7. Запоздалая конечно (написано давно). Я думал уже не надо никому, оказывается, на форуме народ ещё обсуждает....

1 стартмани

02.01.2012    19642    95    Alex_E    7    

Замена элементов справочников в конфигурации

Поиск данных Универсальные обработки Тестирование и исправление v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Групповая замена одних элементов справочников на другие в реквизитах справочников, документов, операций документов (без перепроведения)

1 стартмани

14.12.2011    10356    37    dimaster    3    

Обработка для принудительного удаления документов 1С 7.7 ТиС

Свертка базы Закрытие периода Закрытие периода v7.7 1С7:ТиС Россия Абонемент ($m)

Использует транзакции для быстрого удаления. Написана мною для быстрой очистки прошлого периода (свертка). Код простой, но проверенный и практичный. В помощь программеру свертывальщику.

1 стартмани

08.12.2011    16971    100    Deda    10    

Поиск и восстановление битых ссылок (объект не найден) в реквизитах документов с помощью УРБД 1с 7.7

Распределенная БД (УРИБ, УРБД) Тестирование и исправление v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Данная обработка выполняет два действия: 1. Ищет в реквизитах документов битые ссылки по фразе "<Объект не найден>" и записывает результаты в файл LostIn1c.txt на диск D. 2. С помощью данных в сохраненном файле в связанной через УРБД базе (предполагается, что в этой базе с данными все нормально) находит эти реквизиты и регистрирует их на выгрузку. Ну а дальше достаточно сделать обмен в УРБД между базами, чтобы ссылки восстановились.

1 стартмани

30.11.2011    17707    91    roms6    5    

Искатель v1.1: Поиск документов без проводок, без движений по регистрам 1C 7.7

Обработка документов Поиск данных Тестирование и исправление v77::ОУ v77::БУ 1cv7.md Абонемент ($m)

Искатель, версия 1.1 Данная обработка будет искать проведенные документы без проводок по бухгалтерскому учету и без движений по регистрам.

1 стартмани

22.11.2011    13170    53    Andruykha    12    

Автоматическое формирование счетов-фактур на аванс в "1С: Предприниматель 7.7"

Закрытие периода Закрытие периода Обработка документов Закрытие периода v77::ОУ 1cv7.md БУ НУ НДС Абонемент ($m)

В конфигурации "1С: Предприниматель 7.7" введенные вручную счета-фактуры на аванс, полученный от покупателя, автоматически зачитываются при последующей отгрузке покупателю. Но при большом количестве авансов от покупателя создание счетов-фактур на аванс вручную - трудоемкий процесс, и полезно было бы иметь механизм для автоматического создания счетов-фактур на аванс от покупателя по итогам налогового периода (квартала). Данная обработка позволяет устранить этот пробел.

1 стартмани

13.10.2011    24351    19    victuan    1    

Установить период зарплаты

Обработка документов Закрытие периода Зарплата Зарплата v77::Расчет 1С7:ЗиК Россия БУ Абонемент ($m)

Установить мягко любой период зарплаты

1 стартмани

04.10.2011    11837    16    ivlev2005    5    

Исправление баланса после неудачных корректировок * (7.7)

1С7.7<->1C7.7 Тестирование и исправление v77::БУ 1С7:БМО 1С7:Бух 1С7:Комплекс 1С7:ББУ Абонемент ($m)

Если вы случайно сломали/перепровели/удалили или еще что-то сделали и у вас "уплыл" баланс, но есть архивная копия, то эта обработка поможет вам восстановить обороты без ручного труда.

1 стартмани

27.09.2011    8874    22    andr2510    7    

Автоматический ввод документов "Перечисление НДФЛ в бюджет РФ" по документам "Выплата заработной платы"

Закрытие периода Обработка документов Закрытие периода Зарплата Закрытие периода Зарплата v77::Расчет 1С7:ЗиК Россия БУ НУ НДФЛ Абонемент ($m)

Обработка для автоматического ввода документов "ПЕРЕЧИСЛЕНИЕ НДФЛ В БЮДЖЕТ" по документам "ВЫПЛАТА З/П " .

1 стартмани

26.09.2011    13233    70    OLGA_65    21    

Распределение НДС косвенных расходов для 7.7 (как в 8.1)

Закрытие периода Закрытие периода Закрытие периода v77::БУ 1С7:Бух Россия БУ НДС Абонемент ($m)

Добавляет в типовую конфигурацию 1с 7.7 "Бухгалтерский учет" документ "Распределение НДС косвенных расходов" и печатную форму (полностью аналогичен по функционалу документу в 1с 8 "Бухгалтерия предприятия").

1 стартмани

12.09.2011    23755    61    bida    51