Полезности при работе с динамическими списками

Публикация № 1028787

Разработка - Практика программирования

Списки ДинамическийСписок Dev

Хочу поделиться с Вами несколькими на мой взгляд полезными вещами, при работе с динамическим списком.

Постараюсь построить повествование в виде: реализация решений вопросов по ходу разработки. 

Иногда мы сталкиваемся с необходимостью использовать динамические списки, лично я их стараюсь использовать по возможности и намедни столкнулся с такой задачей: 

У нас есть форма с динамическим списком, куда подтягиваются запросом документы нескольких типов (видов ведомостей, не суть) за все года. Пускай их сейчас не так уж и много, период эксплуатации программы у нас пока небольшой, но через пару лет список пополнится парой сотен-тысяч документов и искать вручную уже будет не удобно от слова очень. Я решил, что неплохо было бы перед вызовом формы задать период, который я потом смогу передать в этот динамический список и тем самым произведу нужный мне отбор. 

Далее встал вопрос реализации:

1) Штудируя синтаксис-помощник и саму конфигурацию я наткнулся на такую функцию:

//// Необходимая функция

Новый ДиалогРедактированияСтандартногоПериода()

//// Что нам говорит СП


ДиалогРедактированияСтандартногоПериода (StandardPeriodEditDialog)
Свойства:
Период (Period)
Методы:
Показать (Show)
Редактировать (Edit)   ///Как раз то, что нам нужно для интерактивной работы на клиенте
Конструкторы:
По умолчанию
Описание:
Предназначен для интерактивного редактирования объекта СтандартныйПериод.
Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, толстый клиент, внешнее соединение, мобильное приложение(клиент).

//// Синтаксис-помощник засыпает, просыпаются программисты

 

Добавляем кнопку на форму (которую в последствии будем использовать для открытия другой формы с динамическим списком), далее её функционал:

&НаКлиенте
Процедура ОткрытьСписокПодбора(Команда)
	Диалог = Новый ДиалогРедактированияСтандартногоПериода(); 
	Диалог.Период = Новый СтандартныйПериод(Объект.ДатаН, Объект.ДатаК); //Указываем, что дата начала и дата конца стандартного периода будут с пустыми значениями
	Диалог.Показать(Новый ОписаниеОповещения("ВыборПериодаЗавершение", ЭтотОбъект, Новый Структура("Диалог", Диалог))); //Вызываем форму подбора периода
КонецПроцедуры

Объект.ДатаН и Объект.ДатаК - реквизиты внешней обработки, в которых будут хранится значения, полученные с формы подбора периода. 

При обработке данной команды появляется следующая форма (так хорошо знакомая нам и наиболее встречающаяся в отчётах)

Здесь каких только вариантов нет, поэтому считаю этот вариант наиболее удобным в применении. 

Добавим ещё одну функцию, чтобы обработать наш выбор:

&НаКлиенте
Процедура ВыборПериодаЗавершение(Период, ДополнительныеПараметры) Экспорт

    Диалог = ДополнительныеПараметры.Диалог;
    ДатаНачала = Дата("20130724"); //Зададим дату, чтобы подстраховаться, вдруг пользователь не выберет ничего  
                                   //(это примерная дата ,когда документов ещё никаких не было, что бы отобразить весь список)  
     
    Если ЗначениеЗаполнено(Период) Тогда //Проверяем, заданы ли даты начала и конца, для отбора 
        Объект.ДатаН = Период.ДатаНачала; // Присваиваем значения
		Объект.ДатаК = Период.ДатаОкончания; //		
    Иначе
		Объект.ДатаН = ДатаНачала;  
        Объект.ДатаК = КонецДня(ТекущаяДата());
	КонецЕсли;

	ПараметрыФормы = Новый Структура("ДатаН, ДатаК", Объект.ДатаН,Объект.ДатаК); //заполняем структуру передаваемых параметров
	Форма = ОткрытьФорму("ВнешняяОбработка.Обработка.Форма.ФормаСпискаДокументов",ПараметрыФормы,ЭтаФорма); // Открываем форму с передачей параметров, которые используем при создании на сервере

КонецПроцедуры

В модуле второй формы-приемника параметров, пропишем следующую функцию "ПриСозданииНаСервере" (используется сервером при создании формы) - это стандартная процедура, в ней мы будем описывать присвоение параметров в динамический список.

 

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	СписокДокументов.Параметры.УстановитьЗначениеПараметра("ДатаН", Параметры.ДатаН);
	СписокДокументов.Параметры.УстановитьЗначениеПараметра("ДатаК",  Параметры.ДатаК);
	
КонецПроцедуры

Готово. Теперь данные появляются в разрезе указанного периода, который мы интерактивно выбрали и передали.

Следующий вопрос, который появился при разработке:

А как из открытой формы мне передать выбранные данные из динамического списка обратно, на форму родителя?  

Ответ пришёл как всегда из нашего любимого и всеми уважаемого СП:

ОповеститьОВыборе (NotifyChoice)
Синтаксис:
ОповеститьОВыборе(<ЗначениеВыбора>) 
Параметры:
<ЗначениеВыбора> (обязательный)
Тип: Произвольный. 
Результат выбора. 
Описание:
Посылает оповещение владельцу формы о выполнении выбора или подбора, передает ему выбранное значение. Закрывает форму в соответствии со значением свойства ЗакрыватьПриВыборе. Данное действие аналогично выполнению выбора в форме, открытой для выбора в поле ввода или ячейке табличного поля.
Доступность: 
Тонкий клиент, веб-клиент, мобильный клиент, толстый клиент, мобильное приложение(клиент). 
Примечание:
Может применяться в случае, когда открытие формы выбора или подбора выполнено средствами языка

Добавим соответствующую кнопочку "Отправить данные" и опишем её

&НаКлиенте
Процедура ОтправитьДокументы(Команда)
	
Данные = Элементы.СписокДокументов.ВыделенныеСтроки; //ловим выделенные строки
СписокДляОтправки = Новый Массив;	
	
Для Каждого Строка из Данные Цикл 
	СписокДляОтправки.Добавить(Элементы.СписокДокументов.ДанныеСтроки(Строка).Ссылка); // записываем данные выбора в массив
КонецЦикла;

ОповеститьОВыборе(СписокДляОтправки); //

КонецПроцедуры

// а на клиенте в модуле формы-родителя уже добавляем такую процедурку 

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
	
	ЗаполнитьТаблицу(ВыбранноеЗначение); // вызывается функция заполнения ТЧ формы-родителя
	
КонецПроцедуры

Фукнция ЗаполнитьТаблицу (ДанныеДляЗаполнения)
    
    Для Каждого Стр Из ДанныеДляЗаполнения
        НоваяСтрока = НашаОбработка.ТаблицаНаФорме.Добавить();  //Добавляем новую строку
        ЗаполнитьЗначенияСвойств(НоваяСтрока, Стр); // заполняем новую строку данными
    КонецЦикла;

КонецФункции

Возвращаясь к отборам в динамических списках, при выполнении задач, приходит на ум идея, а вдруг пользователь не все документы перенёс с первого раза и ему вдруг захотелось снова открыть форму подбора. Что это может значить? Необходимо теперь исключить из выводимого списка перенесённые документы, зачем ему видеть снова те документы, убрав тем самым возможность дублирования строк. Как один из вариантов, это доработать произвольный запрос в динамическом списке условиями и передать туда соответствующий параметр типа "Массив". В нём будет содержаться список уже выгруженных документов. 

Тогда добавим следующий функционал:

//После выбора периода допишем вызов функции

Функция ЗаписатьВыгруженные()

Таб = НашаОбработка.ТаблицаНаФорме.Выгрузить();	// Выгружаем ТЧ в переменную
Таб.Свернуть("Документ"); //Избавляемся от дублей, если таковые имеются
Объект.Адрес = ПоместитьВоВременноеХранилище(Таб.ВыгрузитьКолонку("Документ"),ЭтаФорма.УникальныйИдентификатор); //Помещаем информацию во временное хранилище

КонецФункции

//Временное хранилище будет доступно, пока открыта форма-родитель, перезапись будет осуществляться после каждого нового открытия формы-подбора

Дописав функцию, где мы передаём параметры периода, включив в неё адрес временного хранилища, можем уже исключить при создании на сервере ненужные уже нам документы. 

//Модификация записи во временное хранилище заключается в том, что мы во-первых, избавляемся от повторяющихся. 
//Во-вторых, если тч была ошибочно очищена, мы не запишем пустую таблицу и не заменим ею ту, где у нас хранятся данные 
Функция ЗаписатьВыгруженные()
		
	    Таб = Объект.ТаблицаНаФорме.Выгрузить();	
		Таб.Свернуть("Документ");
		Массив = Таб.ВыгрузитьКолонку("Документ");
		Если ЗначениеЗаполнено(Объект.Адрес) Тогда
		    МассивДляСверки = ПолучитьИзВременногоХранилища(Объект.Адрес);
			МассивДляСверки = ПроверкаПовторяющихся(Массив, МассивДляСверки);
			Объект.Адрес = ПоместитьВоВременноеХранилище(МассивДляСверки,ЭтаФорма.УникальныйИдентификатор);
		Иначе
			Объект.Адрес = ПоместитьВоВременноеХранилище(Массив,ЭтаФорма.УникальныйИдентификатор);
		КонецЕсли;
		
КонецФункции

//Не бросайтесь камнями в меня :), не эталонное сравнение, знаю 
Функция ПроверкаПовторяющихся(Массив1, Массив2)
	
	Для Каждого Стр Из Массив1 Цикл
		Если Массив2.Найти(Стр)=Неопределено Тогда
			Массив2.Добавить(Стр);
		КонецЕсли;
	КонецЦикла;
	Возврат Массив2
	
КонецФункции

//Заменим 2 последние строки в функции ВыборПериодаЗавершение()
&НаКлиенте
Процедура ВыборПериодаЗавершение(Период, ДополнительныеПараметры) Экспорт

    Диалог = ДополнительныеПараметры.Диалог;
    ДатаНачала = Дата("20130724"); //Зададим дату, чтобы подстраховаться, вдруг пользователь не выберет ничего  
                                   //(это примерная дата ,когда документов ещё никаких не было, что бы отобразить весь список)  
     
    Если ЗначениеЗаполнено(Период) Тогда //Проверяем, заданы ли даты начала и конца, для отбора 
        Объект.ДатаН = Период.ДатаНачала; // Присваиваем значения
		Объект.ДатаК = Период.ДатаОкончания; //		
    Иначе
		Объект.ДатаН = ДатаНачала;  
        Объект.ДатаК = КонецДня(ТекущаяДата());
	КонецЕсли;

	ПараметрыФормы = Новый Структура("ДатаН, ДатаК, Адрес", Объект.ДатаН,Объект.ДатаК, Объект.Адрес);
Форма = ОткрытьФорму("НашаОбработка.ТаблицаНаФорме.Форма.ФормаСпискаДокументов",ПараметрыФормы,ЭтаФорма);

КонецПроцедуры

//

 

А в модуле формы-приёмника изменим Процедуру "ПриСозданииНаСервере" дописав:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	СписокДокументов.Параметры.УстановитьЗначениеПараметра("ДатаН", Параметры.ДатаН);
	СписокДокументов.Параметры.УстановитьЗначениеПараметра("ДатаК",  Параметры.ДатаК);
	//Получаем массив из хранилища
    Попытка
		МассивИзХранилища = ПолучитьИзВременногоХранилища(Параметры.Адрес);
	Исключение
	    Сообщить("Ошибка получения данных из хранилища!",СтатусСообщения.Важное);
	КонецПопытки;
    //Проверяем заполнение его
	Если МассивИзХранилища.Количество() = 0 Тогда
		СписокДокументов.Параметры.УстановитьЗначениеПараметра("Ссылка", Документы.МоиДокументы.ПустаяСсылка());   
	Иначе
		СписокДокументов.Параметры.УстановитьЗначениеПараметра("Ссылка",МассивИзХранилища);   
	КонецЕсли;
	
КонецПроцедуры

 

Тестировалось всё на платформе 8.3.13.1513

Всем спасибо за уделённое время.

Надеюсь, что информация окажется Вам полезной.  

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. andryandry 108 28.03.19 10:30 Сейчас в теме
а что мешает через параметры формы передать все не использую хранилище?
3. nestokay 65 28.03.19 11:35 Сейчас в теме
(1) Можно и параметром конечно, Вы правы, если объём данных будет небольшой.
2. user1011897 28.03.19 10:40 Сейчас в теме
Все, конечно, круто! Но где здесь полезности? При всем уважении к автору, я бы назвал все это "стандартности". Но кому-то это будет, конечно полезно прочитать.
WellMaster; dabu-dabu; nestokay; mbalyukin; insurgut; bulpi; noprogrammer; Дмитрий74Чел; qwinter; mr.Kot; Xershi; mvxyz; cefew; for_sale; androgin; maksa2005; +16 Ответить
7. Дмитрий74Чел 199 29.03.19 10:12 Сейчас в теме
(2) Очередная (какая там по счету) копипаста синтаксис-помощника. Ну ладно, хоть пара примеров своего кода есть.
Вот на хабре есть "песочница". Как раз для совсем юных подаванов статья.
4. androgin 28.03.19 13:22 Сейчас в теме
выбор периода - вообще стандартная функция дин списков)
5. nestokay 65 28.03.19 13:37 Сейчас в теме
(4) Не мне Вам рассказывать, как пользователи не любят изучать состав вкладки "Ещё" и т.д. :) а так, конечно, отбор по дате там организовать ручками можно. Здесь идёт установка более привычная и удобная для конечного пользователя на мой взгляд.
6. androgin 28.03.19 20:25 Сейчас в теме
(5) если пользователь что-то не любит - он всегда может вернуться к журналам на столе. Это не значит, что нужна дублирующая функция. Вам, как программисту, ничего не мешает вынести кнопку периода на видное место.
insurgut; +1 Ответить
8. bulpi 179 29.03.19 15:49 Сейчас в теме
Замечание:
Не стоит называть переменную СписокДляОтправки и помещать туда не список, а массив.
9. nestokay 65 29.03.19 15:56 Сейчас в теме
(8) Спасибо за замечание. Буду внимательнее.
Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    4451    comol    22    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    39475    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    30681    John_d    22    

Шпаргалка (БСП). Добавление в новый документ механизма печати дополнительных печатных форм

Печать БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Постоянно приходится вспоминать, как добавить механизм печати (БСП) в новый документ. Поэтому решил написать шпаргалку.

10.10.2019    21791    John_d    17    

Как я начал администрировать сервер 1С: Предприятие 8.3 с телефона Промо

Администрирование данных 1С Мобильная разработка v8 Бесплатно (free)

Развитие инструментов управления кластером серверов 1С:Предприятие 8.3.

14.04.2017    63720    user700211_a.straltsou    29    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    33256    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    40379    Yashazz    50    

Самый примитивный HTTP-сервис в мире

WEB v8 Бесплатно (free)

Пошаговый пример создания простейшего HTTP-сервиса, который генерирует HTML-страницу для поиска товара, а также реализует асинхронное получение данных из базы.

12.09.2019    23069    YPermitin    27    

Копирование числовых ячеек из 1С в Excel Промо

Загрузка и выгрузка в Excel Администрирование данных 1С v8 1cv8.cf Бесплатно (free)

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    28786    itriot11    27    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    67746    rpgshnik    68    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    58503    ids79    55    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    107582    ids79    63    

Обмен данными. Консистентность vs Многопоточность Промо

Интеграция v8 1cv8.cf Бесплатно (free)

Рассмотрим теоретические основы обмена данными. Какие бывают обмены, какие гарантии при этом даются, зачем идти на компромиссы и что при этом может пойти не так. Есть ли идеальная схема?

03.09.2019    13547    m-rv    1    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    76439    ids79    14    

Обработчики событий при записи объектов. Зачем и что за чем?

Математика и алгоритмы v8 Бесплатно (free)

Программисту, имеющему немного опыта на платформе 1С 8.3, бывает сложно разобраться: ПередЗаписью, ПриЗаписи, ПослеЗаписи, на сервере, на клиенте, в модуле формы, в модуле объекта.... Эта шпаргалка была создана в процессе обучения и реального опыта с целью разложить всё по полочкам, чтобы было четкое понимание в каком случае какой обработчик нужно использовать и в какой последовательности они запускаются при записи и проведении документов. Данная статья будет полезна в большей степени начинающим разработчикам. Но и опытным позволит освежить информацию, упорядочить её.

25.07.2019    73807    AlbinaAAA    31    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    60596    ids79    26    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38475    unichkin    74    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    46931    YPermitin    52    

Выгрузка документа по условию

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16433    m-rv    2    

Как настроить правильную техподдержку (helpdesk, service desk на коленке)

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени v8 УУ Бесплатно (free)

Эта статья будет полезна для компаний, которые оказывают техническую поддержку своим пользователям - внешним или внутренним клиентам. В статье я расскажу, как оказываем поддержку мы, как выстроили этот бизнес-процесс, что контролируем и на что обращаем внимание в работе. Вы можете использовать наш опыт при построении собственной системы поддержки или обратиться к нам за помощью за построением такой системы, будем рады помочь. В статье формируется основной набор правил, которые мы сформировали при настройке системы для себя, а так же небольшие примеры того, как мы эти правила применяем.

24.04.2019    22830    siddy    0    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    32089    tormozit    104    

Как прикрутить ГУИД к регистру сведений

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20972    m-rv    17    

Excel vs 1С: битва с неожиданным исходом

Анализ учета Универсальные обработки Загрузка и выгрузка в Excel Финансовые Управленческие v8 1cv8.cf Россия Бесплатно (free)

Что лучше 1С или Excel? Разберемся, в казалось бы, очевидном, чтобы получить невероятное!

11.04.2019    38309    bolefirenko    120    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    37924    ellavs    126    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    79336    tormozit    131    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    28652    ellavs    90    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    45892    ids79    75    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    50103    tormozit    48    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    111951    GeterX    128    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    37454    ids79    40    

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git

Инструментарий разработчика Управление проектом v8 1cv8.cf Бесплатно (free)

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    79222    stas_ganiev    82    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    46805    tormozit    74    

Планы обмена 1С

Перенос данных из 1C8 в 1C8 Интеграция v8 Бесплатно (free)

В статье - мастер-классе Дмитрий Жичкин рассказывает, для чего нужны планы обмена 1С и какие задачи они решают. Он подробно описывает физическую структуру планов обмена и механизмов регистрации изменений, рассматривает основные проблемы, возникающие при выгрузке изменений и предлагает методы их решения.

10.09.2018    70624    zhichkin    32    

Из Excel в 1С запросом

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    20689    m-rv    5    

Тестер: частые вопросы

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    30156    grumagargler    31    

Повышаем эффективность разработки правил обмена

Практика программирования Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    29071    olegtymko    48    

Как сделать запрос на изменение данных

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    32347    m-rv    21    

Строим графы средствами 1С (без GraphViz)

Практика программирования v8 Бесплатно (free)

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    24807    slozhenikin_com    20    

Распределение расходов пропорционально продажам

Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Практика программирования Финансовый учет и бюджетирование (FRP) Учет доходов и расходов v8 v8::ОУ УТ10 УУ Бесплатно (free)

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    18520    Rustig    9    

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники

Перенос данных из 1C8 в 1C8 v8 Бесплатно (free)

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    23993    V.Stavinsky    11    

[ВсеПросто] "Оперативный" информатор из 1С за 5 мин.

Практика программирования v8 Бесплатно (free)

Быть всегда в курсе дел, даже в дороге!

22.02.2018    26888    DarkAn    25    

Минимализмы 3

Практика программирования Универсальные функции v8 Бесплатно (free)

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    47946    ildarovich    45    

Этюды по программированию. Взаимодействие с Microsoft Word

Практика программирования v8 Бесплатно (free)

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    32579    milkers    23    

Метод формирования движений в типовых регистрах нетиповыми регистраторами

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28860    itriot11    34