Парсер строки по шаблону с помощью RegExp 

Публикация № 1071042

Разработка - Практика программирования

шаблоны парсер бесплатно программирование алгоритмы v8

Возникла задача загрузки отчетов по эквайрингу в формате Экселя. Так как юр. лицо не одно, то информация, на какую организацию загружать, находится в самом файле в виде строки в определённом формате. Так как мне было лень писать парсер для конкретной строки с данными организации, написал более-менее универсальный парсер, который позволяет вытянуть данные по заданному шаблону.

ВНИМАНИЕ!!!! Требуется понимать, что такое регулярные выражения. Если данного знания нет, то гугл подскажет.

Сразу на примере. Есть строка типа.

ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "Ромашка", ИНН 1233455671, БИК 032405676, р/с - 10203810565780991778

Из неё нужно вытащить наименование организации, инн, бик и р/с. Вполне очевидно, представить себе строку в следующем виде

"Наименование организации", ИНН "ИНН", БИК "БИК", р/с - "Расчетный счет"

Теперь надо перевести это в более понятный машине формат

%[Наименование]%, ИНН %[ИНН]%, БИК %[БИК]%, р/с - %[РасчетныйСчет]%"

В квадратных скобках назовём параметром, остальное - разделители. Замечу, что подряд 2 разделителя или параметра быть не может (разделителем может быть и один пробел). 

Тут вроде бы всё хорошо, но возникает вопрос, а что если у самого параметра определённый формат? или есть строки, в целом, одинаковые, но определённый параметр отличается, типа формата даты? Делать кучу шаблонов - не вариант. А как вообще вытащить данные, которые относятся к тому или иному параметру?? Нужны ответы, их есть у меня. Достаточно сделать так, что бы пользователь сам описал нужный формат параметра, а если он не указан, то указать какой либо по умолчанию, и пустить через RegExp. 

Я это реализовал так. 

%[Наименование]%, ИНН %[%(ИНН,\d+)%]%, БИК %[%(БИК,\d+)%]%, р/с - %[%(РасчетныйСчет,\d+)%]%

Если в %[]% указаны скобки %()% то в них прописывается наименование параметра и формат параметра в тексте. По умолчанию, формат [0-9A-Za-zА-Яа-я\_\"\'\ \(\)]*. Это значит что берутся все числа, английские буквы, русские буквы, разные символы и их может быть от 0 до много. При необходимости формат можно подправить. Более того в %()% могут идти через запятую. К примеру %[%(ИНН_Юр,\d{10})%,%(ИНН_Ип,\d{12})%]%. То есть, если в инн 12 чисел, то вернёт параметр ИНН_Ип, если 10, то ИНН_Юр. 

Самое время начать вытягивать из текста информацию. Сделаю массив из параметров и разделителей. В данном случае получиться так.

%[Наименование]%
, ИНН
%[%(ИНН,\d+)%]%
, БИК
%[%(БИК,\d+)%]%
, р/с -
%[%(РасчетныйСчет,\d+)%]%

Теперь беру по 3 элемента массива. Именно 3, потому что при сборке паттерна после описания формата параметра обязательно должен быть разделитель. А так как параметр либо 1й, либо 2й элемент массива, то смотрю ещё и 3й.

Теперь, если в параметре прописаны отдельные форматы, название переменных, то парсю их через тот же RegExp, создаю тз с параметрами и шаблоном к ним, если отдельного формата нет, то тз будет с 1 строкой, где шаблон по умолчанию. Для каждого шаблона этого тз строю паттерн с разделителями. Если паттерн нашёлся, то вставляю имя параметра, значение паттерна, при этом со значение убираю последний разделитель, если он есть, а из разбираемой строки само значение.

То есть сначала программа пытается  найти текст по следующему паттерну "^ *[0-9A-Za-zА-Яа-я\_\"\'\(\)\ ]*", +ИНН + * *", находит

"ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "Ромашка", ИНН"

Видит, что ", ИНН " - это разделитель, удаляет его из результата, и результат удаляется из строки.

На следующем шаге в строке ", ИНН 1233455671, БИК 032405676, р/с - 10203810565780991778" ищет "^ *, +ИНН + *\d+, +БИК + *", находит

", ИНН 1233455671, БИК"

удаляет что надо и так далее. На выходе получаю структуру

Наименование: ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "Ромашка"
ИНН: 1233455671
БИК: 032405676
РасчетныйСчет: 10203810565780991778

Задача решена! 

Конечно, упущены нюансы, что не ищу точное количество пробелов, а допускаю что их может быть не один, спец символы в разделителях заменяю и прочее. Но на описание основной идеи это не влияет.


функция ПараметрВТЗШаблонов(знач Параметр, ИсключатьПробел, RegExp, Все = ложь)
	тз = новый ТаблицаЗначений;	
	тз.Колонки.Добавить("Параметр");
	тз.Колонки.Добавить("Шаблон");
	RegExp.pattern  = "\%\[[0-9A-Za-zА-Яа-я\_]*\]\%";	
	Поиск = RegExp.Execute(Параметр);
	если Поиск.count>0 тогда
		//обычное название параметра
		Параметр = СтрЗаменить(Параметр,"%[","");
		Параметр = СтрЗаменить(Параметр,"]%","");
		нов = тз.Добавить();
		нов.Параметр = Параметр;
		нов.Шаблон = ?(Все,".+","[0-9A-Za-zА-Яа-я\_\.\,\""\'\(\)"+?(не ИсключатьПробел,"\ ","")+"]*");		
	иначе
		RegExp.pattern  = "\%\([0-9A-Za-zА-Яа-я_\*\+]*\,[0-9A-Za-zА-Яа-я_\[\]\(\)\.\^\\\*\+\{\}\|]*\)\%";
		Поиск = RegExp.Execute(Параметр);
		Для инт=0 по Поиск.count-1 цикл
			ПараметрШаблон = Поиск.item(инт).Value;
			//формат такой (Параметр,шаблон), при этом запятые могут быть и в шаблоне
			мас = СтрРазделить(ПараметрШаблон,",");
			Параметр = СокрЛП(мас[0]);
			Параметр = прав(Параметр,СтрДлина(Параметр)-2);
			//Шаблон, слева %(, справа )%
			Шаблон = сокрЛП(СтрЗаменить(ПараметрШаблон,Параметр,""));
			//убирваю скобки
			Шаблон = сред(Шаблон,3,СтрДлина(Шаблон)-4);
			//убираю ,
			Шаблон = сокрЛП(Шаблон);
			Шаблон = прав(Шаблон,СтрДлина(Шаблон)-1);			
			нов = тз.Добавить(); 
			нов.Параметр = Параметр;
			нов.Шаблон = Шаблон;			
		КонецЦикла;
	КонецЕсли;
	возврат тз;
КонецФункции

функция ВставитьСлужебныеСимволы(Знач СтрокаШаблон)
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"\","\\");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"/","\/");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"+","\+");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"[","\[");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"]","\]");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"{","\{");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"}","\}");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"*","\*");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,".","\.");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"|","\|");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон," "," +");
	возврат СтрокаШаблон;
КонецФункции

функция РазложитьШаблонПоПараметрам(Шаблон,RegExp)
	RegExp.pattern  = "\%\[.+?]%";
	Поиск = RegExp.Execute(Шаблон);
	Мас = новый Массив;
	если Поиск.count>0 тогда
		Для инт = 0 по Поиск.count-1 цикл
			ТекЭл = Поиск.item(инт);
			если инт <= Поиск.count-2 тогда
				//беру текущий и следущий параметр, на основе их длины и начала заполняю массив
				СледЭл = Поиск.item(инт+1);
				если  инт = 0 и ТекЭл.FirstIndex <> 0 тогда
					Мас.Добавить(лев(Шаблон,ТекЭл.FirstIndex));
				КонецЕсли;
				Мас.Добавить(ТекЭл.value);
				//рассчитываем разделитель
				разделитель = сред(Шаблон,(ТекЭл.FirstIndex+ТекЭл.Length+1),(СледЭл.FirstIndex-(ТекЭл.FirstIndex+ТекЭл.Length)));
				если не разделитель = "" тогда
					мас.Добавить(разделитель);
				КонецЕсли;
			иначе
				//добавляю сам параметр и остаток строки, если он есть
				Мас.Добавить(ТекЭл.value);
				если ТекЭл.FirstIndex+ТекЭл.Length < СтрДлина(шаблон) тогда
					Мас.Добавить(прав(шаблон,СтрДлина(шаблон)-(ТекЭл.FirstIndex+ТекЭл.Length)));  				
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
	иначе
		Мас.Добавить(Шаблон);	
	КонецЕсли;	
	возврат мас;
КонецФункции

Функция РазложитьСтрокуПоШаблону(Знач Шаблон,Знач Текст, RegExpКомп = Неопределено) Экспорт
	если RegExpКомп = Неопределено тогда
		RegExp = новый COMОбъект("VBScript.RegExp");  	
		RegExp.IgnoreCase = Истина; 
		RegExp.Global = Истина; 
		RegExp.MultiLine = Истина;
	иначе
		RegExp = RegExpКомп;
	КонецЕсли;
	//1 выделяю параметры в квадратных скобках
	//нужна правильная скобочная запись, посчитаем
	МассивРазделенныхПараметров = РазложитьШаблонПоПараметрам(Шаблон,RegExp);
	//беру 3 элемента массива, если это начало строки или конец, то может быть и 2, и 1 элемент
	//смотрю, какие элементы являются разделителем параметров
	//возможны случаи: ПРР, ПРП, РПР - остальное ошибка и не обрабатывается		
	РасмТекст = Текст;
	РасмТекст = СтрЗаменить(РасмТекст,Символы.ПС," ");
	РасмТекст = СтрЗаменить(РасмТекст,Символы.ВТаб," ");
	РасмТекст = СтрЗаменить(РасмТекст,Символы.ВК," ");
	РасмТекст = СтрЗаменить(РасмТекст,Символы.НПП," ");
	УбратьДвойныеПробелы(РасмТекст);
	УбратьДвойныеПробелы(Шаблон);
	СтруктураРеквизитов = новый Структура;
	Пока МассивРазделенныхПараметров.Количество()<>0 цикл			
		Если МассивРазделенныхПараметров.Количество()>2 тогда
			ПодСтр1 = МассивРазделенныхПараметров[0];
			ПодСтр2 = МассивРазделенныхПараметров[1];
			ПодСтр3 = МассивРазделенныхПараметров[2];
		иначеЕсли МассивРазделенныхПараметров.Количество()>1 тогда
			ПодСтр1 = МассивРазделенныхПараметров[0];
			ПодСтр2 = МассивРазделенныхПараметров[1];
			ПодСтр3 = "";
		иначе
			ПодСтр1 = МассивРазделенныхПараметров[0];
			ПодСтр2 = "";
			ПодСтр3 = "";
		КонецЕсли;
		//нужно определить, какая подстрока разделитель. Так как если разделитель " ", и идет за параметром, 
		//и параметр без отдельного шаблона, то в шаблоне параметра нужно удалить пробел.
		ПодСтр1Разделитель = не (лев(ПодСтр1,2) = "%[" и прав(ПодСтр1,2)="]%");
		ПодСтр2Разделитель = не (лев(ПодСтр2,2) = "%[" и прав(ПодСтр2,2)="]%");
		ПодСтр3Разделитель = не (лев(ПодСтр3,2) = "%[" и прав(ПодСтр3,2)="]%");
		//элементы не могут быть одновременно ни разделителями, ни параметрами
		если МассивРазделенныхПараметров.Количество()>1 и не ((ПодСтр1Разделитель и ПодСтр2Разделитель) или не (ПодСтр1Разделитель и ПодСтр2Разделитель)) тогда
			//ошибка
			Найден = ложь;
			Прервать;
		ИначеЕсли МассивРазделенныхПараметров.Количество()>2 и не ((ПодСтр1Разделитель и ПодСтр2Разделитель) или не (ПодСтр1Разделитель и ПодСтр2Разделитель)) 
			и не ((ПодСтр2Разделитель и ПодСтр3Разделитель) или не (ПодСтр2Разделитель и ПодСтр3Разделитель)) тогда
			Найден = ложь;
			Прервать;
		КонецЕсли;
		если не ПодСтр3Разделитель тогда
			//нужно убрать этот параметр
			ПодСтр3 = "";
			ПодСтр3Разделитель = истина;
		КонецЕсли;
		
		//так как на одну позицию параметра возможны несколько вариантов отображения, то парсим варианты и проходим последователдьно 
		Если не ПодСтр1Разделитель тогда
			МассивШаблонов = ПараметрВТЗШаблонов(ПодСтр1,СокрЛП(ПодСтр1)="",RegExp,МассивРазделенныхПараметров.Количество()=1);
		ИначеЕсли не ПодСтр2Разделитель тогда
			МассивШаблонов = ПараметрВТЗШаблонов(ПодСтр2,СокрЛП(ПодСтр2)="",RegExp);				
		иначе
			МассивШаблонов = новый ТаблицаЗначений;
		КонецЕсли; 
		
		Для каждого шаблон из МассивШаблонов цикл
			СтрШаблон = "^ *";//начало строки
			Если ПодСтр1Разделитель тогда
				СтрШаблон = СтрШаблон + ВставитьСлужебныесимволы(ПодСтр1)+" *";
			КонецЕсли;
			СтрШаблон = СтрШаблон +  шаблон.Шаблон;
			Если ПодСтр2Разделитель тогда
				СтрШаблон = СтрШаблон +  ВставитьСлужебныесимволы(ПодСтр2)+" *";
			КонецЕсли;
			Если ПодСтр3Разделитель тогда
				СтрШаблон = СтрШаблон +  ВставитьСлужебныесимволы(ПодСтр3)+" *";
			КонецЕсли;
			RegExp.pattern  = СтрШаблон;
			Поиск = RegExp.Execute(РасмТекст);
			если Поиск.count>0 тогда
				НайдЗнач = Поиск.item(0).value;
				//нужно удалить разделители. 
				Если ПодСтр1Разделитель тогда
					НайдЗнач = прав(сокрЛП(НайдЗнач),СтрДлина(сокрЛП(НайдЗнач)) - СтрДлина(сокрЛП(ПодСтр1)));
				КонецЕсли;
				Если ПодСтр2Разделитель тогда
					НайдЗнач = Лев(сокрЛП(НайдЗнач),СтрДлина(сокрЛП(НайдЗнач)) - СтрДлина(сокрЛП(ПодСтр2)));
				КонецЕсли;
				Если ПодСтр3Разделитель тогда
					НайдЗнач = Лев(сокрЛП(НайдЗнач),СтрДлина(сокрЛП(НайдЗнач)) - СтрДлина(сокрЛП(ПодСтр3)));
				КонецЕсли;
				
				СтруктураРеквизитов.Вставить(шаблон.Параметр,сокрЛП(НайдЗнач));
				
				РасмТекст = прав(РасмТекст,СтрДлина(РасмТекст)-(Поиск.item(0).Length - ?(ПодСтр2Разделитель,СтрДлина(ПодСтр2),?(ПодСтр3Разделитель,СтрДлина(ПодСтр3),0))));
			иначе
				Найден = ложь; 		
			КонецЕсли;
		КонецЦикла;
		
		Если МассивРазделенныхПараметров.Количество()>1 и не ПодСтр2Разделитель тогда
			//значит параметр в середине, удалить первый разделитель и параметр
			МассивРазделенныхПараметров.Удалить(1);
			МассивРазделенныхПараметров.Удалить(0);	
		Иначе
			МассивРазделенныхПараметров.Удалить(0);	   				
		КонецЕсли;
		если Найден = ложь тогда
			прервать;
		КонецЕсли;
	КонецЦикла;
	
	если Найден = ложь тогда
		возврат новый Структура;
	иначе 
		возврат СтруктураРеквизитов;
	КонецЕсли;
КонецФункции

Процедура УбратьДвойныеПробелы(текст) Экспорт
	Пока найти(текст,"  ")>0 цикл
		текст = СтрЗаменить(текст,"  "," ");
	КонецЦикла;  	
КонецПроцедуры

Пример использования: СтруктураРеквизитов = РазложитьСтрокуПоШаблону(Шаблон,текст);

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. VmvLer 03.06.19 11:11 Сейчас в теме
за труд спасибо.
Но зачем эта возня с регуляркой в простейшем парсинге?

Что касается заявления об универсальности, то уже по структуре метода и комментариям понятно - вряд ли это будет работать стабильно.
Как по мне то проще:

РазделителиАтомов = " ,;:-"; // разделители пробел, запятая, точка с запятой и т.д.
мАтомыСтроки = СтрРазделить(СтрокаПарсинга, РазделителиТермов, Ложь); // Получаем атомы строки

// Обходим атомы и помещаем в структуру свойств, то что ищем
//...
pm74; AronMav; +2 Ответить
3. rusmil 223 03.06.19 13:49 Сейчас в теме
(1) Интересно где та, грань после которой лучше использовать регулярные выражения, а когда проще обойтись встроенными функциями 1С для работы со строками? Поделитесь опытом?
4. VmvLer 03.06.19 14:04 Сейчас в теме
(3) составляющие "грани" :
1. простота чтения кода;
2. простота расширения кода;
3. стабильность результата;
4. отсутствие обещаний универсальности.

Если составляющие "грани" разъедены сложностью, то на месте грани образуется дыра.
JohnyDeath; Mettem_Kirill; rusmil; +3 Ответить
5. trim89 99 03.06.19 15:05 Сейчас в теме
(1)что касается универсальности, написал же, более-меннее. Естественно, есть контрпримеры, но для обычных задач хватит. И поподробнее что видно по структуре и комментариям?
Зачем нужно? Что бы простейший парсинг был ещё проще.
Что касается атомов и прочего, вот как раз таки это очень узкий способ, который подбирается для каждой строки отдельно, от этого и хотел уйти. Особенно когда нужно проверить является ли параметр числом, или записывается определенным форматом. Рег выражения позволяют универсиализировать и упростить этот момент.
2. Поручик 4447 03.06.19 11:45 Сейчас в теме
Примерно так же я выдёргивал данные с Авито.
6. JohnyDeath 299 07.06.19 09:55 Сейчас в теме
Для тех, кто считает, что регулярки - это не от мира сего, есть вот такое: https://github.com/oscript-library/verbal-expressions
7. A_Max 18 07.06.19 11:54 Сейчас в теме
(6) .ЧтоНибудьНоНе(" ") - очуметь :о)
Может на первых порах это и проще дня начала понимания регулярных выражений, но лучше потренироватья день на кошечках в виде онлайн парсеров и тогда всё становится проще и понятней.
Оставьте свое сообщение

См. также

Как я начал администрировать сервер 1С: Предприятие 8.3 с телефона Промо

Администрирование данных 1С Мобильная разработка v8 Бесплатно (free)

Развитие инструментов управления кластером серверов 1С:Предприятие 8.3.

14.04.2017    62420    user700211_a.straltsou    29    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    31302    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    26809    John_d    22    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    31102    HostHost    40    

Копирование числовых ячеек из 1С в Excel Промо

Загрузка и выгрузка в Excel Администрирование данных 1С v8 1cv8.cf Бесплатно (free)

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    26224    itriot11    27    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    36070    Yashazz    50    

Самый примитивный HTTP-сервис в мире

WEB v8 Бесплатно (free)

Пошаговый пример создания простейшего HTTP-сервиса, который генерирует HTML-страницу для поиска товара, а также реализует асинхронное получение данных из базы.

12.09.2019    22200    YPermitin    26    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    56583    rpgshnik    65    

Обмен данными. Консистентность vs Многопоточность Промо

Интеграция v8 1cv8.cf Бесплатно (free)

Рассмотрим теоретические основы обмена данными. Какие бывают обмены, какие гарантии при этом даются, зачем идти на компромиссы и что при этом может пойти не так. Есть ли идеальная схема?

03.09.2019    12849    m-rv    1    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    53125    ids79    54    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    92840    ids79    56    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    66458    ids79    12    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37863    unichkin    74    

Обработчики событий при записи объектов. Зачем и что за чем?

Математика и алгоритмы v8 Бесплатно (free)

Программисту, имеющему немного опыта на платформе 1С 8.3, бывает сложно разобраться: ПередЗаписью, ПриЗаписи, ПослеЗаписи, на сервере, на клиенте, в модуле формы, в модуле объекта.... Эта шпаргалка была создана в процессе обучения и реального опыта с целью разложить всё по полочкам, чтобы было четкое понимание в каком случае какой обработчик нужно использовать и в какой последовательности они запускаются при записи и проведении документов. Данная статья будет полезна в большей степени начинающим разработчикам. Но и опытным позволит освежить информацию, упорядочить её.

25.07.2019    59665    AlbinaAAA    28    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    55901    ids79    26    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    43724    YPermitin    52    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    31086    tormozit    104    

Выгрузка документа по условию

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16221    m-rv    2    

Как настроить правильную техподдержку (helpdesk, service desk на коленке)

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени v8 УУ Бесплатно (free)

Эта статья будет полезна для компаний, которые оказывают техническую поддержку своим пользователям - внешним или внутренним клиентам. В статье я расскажу, как оказываем поддержку мы, как выстроили этот бизнес-процесс, что контролируем и на что обращаем внимание в работе. Вы можете использовать наш опыт при построении собственной системы поддержки или обратиться к нам за помощью за построением такой системы, будем рады помочь. В статье формируется основной набор правил, которые мы сформировали при настройке системы для себя, а так же небольшие примеры того, как мы эти правила применяем.

24.04.2019    19475    siddy    0    

Как прикрутить ГУИД к регистру сведений

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20628    m-rv    17    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78561    tormozit    131    

Excel vs 1С: битва с неожиданным исходом

Анализ учета Универсальные обработки Загрузка и выгрузка в Excel Финансовые Управленческие v8 1cv8.cf Россия Бесплатно (free)

Что лучше 1С или Excel? Разберемся, в казалось бы, очевидном, чтобы получить невероятное!

11.04.2019    37170    bolefirenko    119    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    36371    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27916    ellavs    90    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    49144    tormozit    48    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    43066    ids79    72    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    97297    GeterX    121    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    45593    tormozit    74    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    35840    ids79    40    

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git

Инструментарий разработчика Управление проектом v8 1cv8.cf Бесплатно (free)

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    71739    stas_ganiev    75    

Планы обмена 1С

Перенос данных из 1C8 в 1C8 Интеграция v8 Бесплатно (free)

В статье - мастер-классе Дмитрий Жичкин рассказывает, для чего нужны планы обмена 1С и какие задачи они решают. Он подробно описывает физическую структуру планов обмена и механизмов регистрации изменений, рассматривает основные проблемы, возникающие при выгрузке изменений и предлагает методы их решения.

10.09.2018    63580    zhichkin    32    

Из Excel в 1С запросом

Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    20318    m-rv    5    

Тестер: частые вопросы

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29630    grumagargler    28    

Повышаем эффективность разработки правил обмена

Практика программирования Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    28650    olegtymko    47    

Как сделать запрос на изменение данных

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    31390    m-rv    21    

Строим графы средствами 1С (без GraphViz)

Практика программирования v8 Бесплатно (free)

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    24453    slozhenikin_com    20    

Распределение расходов пропорционально продажам

Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Практика программирования Финансовый учет и бюджетирование (FRP) Учет доходов и расходов v8 v8::ОУ УТ10 УУ Бесплатно (free)

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    18341    Rustig    9    

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники

Перенос данных из 1C8 в 1C8 v8 Бесплатно (free)

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    23535    V.Stavinsky    11    

[ВсеПросто] "Оперативный" информатор из 1С за 5 мин.

Практика программирования v8 Бесплатно (free)

Быть всегда в курсе дел, даже в дороге!

22.02.2018    26572    DarkAn    25    

Минимализмы 3

Практика программирования Универсальные функции v8 Бесплатно (free)

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    47169    ildarovich    45    

Этюды по программированию. Взаимодействие с Microsoft Word

Практика программирования v8 Бесплатно (free)

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    32362    milkers    23    

Метод формирования движений в типовых регистрах нетиповыми регистраторами

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28530    itriot11    34    

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена)

Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML v8 КД Бесплатно (free)

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    200461    MaxS    299    

Обзор имеющихся библиотек OneScript

OneScript v8 Бесплатно (free)

Экосистема OneScript активно развивается. Количество пользователей данного интерпретатора и имеющихся библиотек неуклонно растет, количество решаемых проблем - тоже. Однако остро встает вопрос некоторой разобщенности и размазанности информации по имеющимся библиотекам, их функциональности и проблемам, которые они решают. Данная статья призвана навести порядок в этой теме.

14.11.2017    45153    nixel    87