Парсер строки по шаблону с помощью RegExp 

Публикация № 1071042

Разработка - Практика программирования

шаблоны парсер бесплатно программирование алгоритмы v8

8
Возникла задача загрузки отчетов по эквайрингу в формате Экселя. Так как юр. лицо не одно, то информация, на какую организацию загружать, находится в самом файле в виде строки в определённом формате. Так как мне было лень писать парсер для конкретной строки с данными организации, написал более-менее универсальный парсер, который позволяет вытянуть данные по заданному шаблону.

ВНИМАНИЕ!!!! Требуется понимать, что такое регулярные выражения. Если данного знания нет, то гугл подскажет.

Сразу на примере. Есть строка типа.

ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "Ромашка", ИНН 1233455671, БИК 032405676, р/с - 10203810565780991778

Из неё нужно вытащить наименование организации, инн, бик и р/с. Вполне очевидно, представить себе строку в следующем виде

"Наименование организации", ИНН "ИНН", БИК "БИК", р/с - "Расчетный счет"

Теперь надо перевести это в более понятный машине формат

%[Наименование]%, ИНН %[ИНН]%, БИК %[БИК]%, р/с - %[РасчетныйСчет]%"

В квадратных скобках назовём параметром, остальное - разделители. Замечу, что подряд 2 разделителя или параметра быть не может (разделителем может быть и один пробел). 

Тут вроде бы всё хорошо, но возникает вопрос, а что если у самого параметра определённый формат? или есть строки, в целом, одинаковые, но определённый параметр отличается, типа формата даты? Делать кучу шаблонов - не вариант. А как вообще вытащить данные, которые относятся к тому или иному параметру?? Нужны ответы, их есть у меня. Достаточно сделать так, что бы пользователь сам описал нужный формат параметра, а если он не указан, то указать какой либо по умолчанию, и пустить через RegExp. 

Я это реализовал так. 

%[Наименование]%, ИНН %[%(ИНН,\d+)%]%, БИК %[%(БИК,\d+)%]%, р/с - %[%(РасчетныйСчет,\d+)%]%

Если в %[]% указаны скобки %()% то в них прописывается наименование параметра и формат параметра в тексте. По умолчанию, формат [0-9A-Za-zА-Яа-я\_\"\'\ \(\)]*. Это значит что берутся все числа, английские буквы, русские буквы, разные символы и их может быть от 0 до много. При необходимости формат можно подправить. Более того в %()% могут идти через запятую. К примеру %[%(ИНН_Юр,\d{10})%,%(ИНН_Ип,\d{12})%]%. То есть, если в инн 12 чисел, то вернёт параметр ИНН_Ип, если 10, то ИНН_Юр. 

Самое время начать вытягивать из текста информацию. Сделаю массив из параметров и разделителей. В данном случае получиться так.

%[Наименование]%
, ИНН
%[%(ИНН,\d+)%]%
, БИК
%[%(БИК,\d+)%]%
, р/с -
%[%(РасчетныйСчет,\d+)%]%

Теперь беру по 3 элемента массива. Именно 3, потому что при сборке паттерна после описания формата параметра обязательно должен быть разделитель. А так как параметр либо 1й, либо 2й элемент массива, то смотрю ещё и 3й.

Теперь, если в параметре прописаны отдельные форматы, название переменных, то парсю их через тот же RegExp, создаю тз с параметрами и шаблоном к ним, если отдельного формата нет, то тз будет с 1 строкой, где шаблон по умолчанию. Для каждого шаблона этого тз строю паттерн с разделителями. Если паттерн нашёлся, то вставляю имя параметра, значение паттерна, при этом со значение убираю последний разделитель, если он есть, а из разбираемой строки само значение.

То есть сначала программа пытается  найти текст по следующему паттерну "^ *[0-9A-Za-zА-Яа-я\_\"\'\(\)\ ]*", +ИНН + * *", находит

"ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "Ромашка", ИНН"

Видит, что ", ИНН " - это разделитель, удаляет его из результата, и результат удаляется из строки.

На следующем шаге в строке ", ИНН 1233455671, БИК 032405676, р/с - 10203810565780991778" ищет "^ *, +ИНН + *\d+, +БИК + *", находит

", ИНН 1233455671, БИК"

удаляет что надо и так далее. На выходе получаю структуру

Наименование: ОБЩЕСТВО С ОГРАНИЧЕННОЙ ОТВЕТСТВЕННОСТЬЮ "Ромашка"
ИНН: 1233455671
БИК: 032405676
РасчетныйСчет: 10203810565780991778

Задача решена! 

Конечно, упущены нюансы, что не ищу точное количество пробелов, а допускаю что их может быть не один, спец символы в разделителях заменяю и прочее. Но на описание основной идеи это не влияет.


функция ПараметрВТЗШаблонов(знач Параметр, ИсключатьПробел, RegExp, Все = ложь)
	тз = новый ТаблицаЗначений;	
	тз.Колонки.Добавить("Параметр");
	тз.Колонки.Добавить("Шаблон");
	RegExp.pattern  = "\%\[[0-9A-Za-zА-Яа-я\_]*\]\%";	
	Поиск = RegExp.Execute(Параметр);
	если Поиск.count>0 тогда
		//обычное название параметра
		Параметр = СтрЗаменить(Параметр,"%[","");
		Параметр = СтрЗаменить(Параметр,"]%","");
		нов = тз.Добавить();
		нов.Параметр = Параметр;
		нов.Шаблон = ?(Все,".+","[0-9A-Za-zА-Яа-я\_\.\,\""\'\(\)"+?(не ИсключатьПробел,"\ ","")+"]*");		
	иначе
		RegExp.pattern  = "\%\([0-9A-Za-zА-Яа-я_\*\+]*\,[0-9A-Za-zА-Яа-я_\[\]\(\)\.\^\\\*\+\{\}\|]*\)\%";
		Поиск = RegExp.Execute(Параметр);
		Для инт=0 по Поиск.count-1 цикл
			ПараметрШаблон = Поиск.item(инт).Value;
			//формат такой (Параметр,шаблон), при этом запятые могут быть и в шаблоне
			мас = СтрРазделить(ПараметрШаблон,",");
			Параметр = СокрЛП(мас[0]);
			Параметр = прав(Параметр,СтрДлина(Параметр)-2);
			//Шаблон, слева %(, справа )%
			Шаблон = сокрЛП(СтрЗаменить(ПараметрШаблон,Параметр,""));
			//убирваю скобки
			Шаблон = сред(Шаблон,3,СтрДлина(Шаблон)-4);
			//убираю ,
			Шаблон = сокрЛП(Шаблон);
			Шаблон = прав(Шаблон,СтрДлина(Шаблон)-1);			
			нов = тз.Добавить(); 
			нов.Параметр = Параметр;
			нов.Шаблон = Шаблон;			
		КонецЦикла;
	КонецЕсли;
	возврат тз;
КонецФункции

функция ВставитьСлужебныеСимволы(Знач СтрокаШаблон)
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"\","\\");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"/","\/");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"+","\+");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"[","\[");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"]","\]");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"{","\{");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"}","\}");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"*","\*");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,".","\.");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон,"|","\|");
	СтрокаШаблон = СтрЗаменить(СтрокаШаблон," "," +");
	возврат СтрокаШаблон;
КонецФункции

функция РазложитьШаблонПоПараметрам(Шаблон,RegExp)
	RegExp.pattern  = "\%\[.+?]%";
	Поиск = RegExp.Execute(Шаблон);
	Мас = новый Массив;
	если Поиск.count>0 тогда
		Для инт = 0 по Поиск.count-1 цикл
			ТекЭл = Поиск.item(инт);
			если инт <= Поиск.count-2 тогда
				//беру текущий и следущий параметр, на основе их длины и начала заполняю массив
				СледЭл = Поиск.item(инт+1);
				если  инт = 0 и ТекЭл.FirstIndex <> 0 тогда
					Мас.Добавить(лев(Шаблон,ТекЭл.FirstIndex));
				КонецЕсли;
				Мас.Добавить(ТекЭл.value);
				//рассчитываем разделитель
				разделитель = сред(Шаблон,(ТекЭл.FirstIndex+ТекЭл.Length+1),(СледЭл.FirstIndex-(ТекЭл.FirstIndex+ТекЭл.Length)));
				если не разделитель = "" тогда
					мас.Добавить(разделитель);
				КонецЕсли;
			иначе
				//добавляю сам параметр и остаток строки, если он есть
				Мас.Добавить(ТекЭл.value);
				если ТекЭл.FirstIndex+ТекЭл.Length < СтрДлина(шаблон) тогда
					Мас.Добавить(прав(шаблон,СтрДлина(шаблон)-(ТекЭл.FirstIndex+ТекЭл.Length)));  				
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
	иначе
		Мас.Добавить(Шаблон);	
	КонецЕсли;	
	возврат мас;
КонецФункции

Функция РазложитьСтрокуПоШаблону(Знач Шаблон,Знач Текст, RegExpКомп = Неопределено) Экспорт
	если RegExpКомп = Неопределено тогда
		RegExp = новый COMОбъект("VBScript.RegExp");  	
		RegExp.IgnoreCase = Истина; 
		RegExp.Global = Истина; 
		RegExp.MultiLine = Истина;
	иначе
		RegExp = RegExpКомп;
	КонецЕсли;
	//1 выделяю параметры в квадратных скобках
	//нужна правильная скобочная запись, посчитаем
	МассивРазделенныхПараметров = РазложитьШаблонПоПараметрам(Шаблон,RegExp);
	//беру 3 элемента массива, если это начало строки или конец, то может быть и 2, и 1 элемент
	//смотрю, какие элементы являются разделителем параметров
	//возможны случаи: ПРР, ПРП, РПР - остальное ошибка и не обрабатывается		
	РасмТекст = Текст;
	РасмТекст = СтрЗаменить(РасмТекст,Символы.ПС," ");
	РасмТекст = СтрЗаменить(РасмТекст,Символы.ВТаб," ");
	РасмТекст = СтрЗаменить(РасмТекст,Символы.ВК," ");
	РасмТекст = СтрЗаменить(РасмТекст,Символы.НПП," ");
	УбратьДвойныеПробелы(РасмТекст);
	УбратьДвойныеПробелы(Шаблон);
	СтруктураРеквизитов = новый Структура;
	Пока МассивРазделенныхПараметров.Количество()<>0 цикл			
		Если МассивРазделенныхПараметров.Количество()>2 тогда
			ПодСтр1 = МассивРазделенныхПараметров[0];
			ПодСтр2 = МассивРазделенныхПараметров[1];
			ПодСтр3 = МассивРазделенныхПараметров[2];
		иначеЕсли МассивРазделенныхПараметров.Количество()>1 тогда
			ПодСтр1 = МассивРазделенныхПараметров[0];
			ПодСтр2 = МассивРазделенныхПараметров[1];
			ПодСтр3 = "";
		иначе
			ПодСтр1 = МассивРазделенныхПараметров[0];
			ПодСтр2 = "";
			ПодСтр3 = "";
		КонецЕсли;
		//нужно определить, какая подстрока разделитель. Так как если разделитель " ", и идет за параметром, 
		//и параметр без отдельного шаблона, то в шаблоне параметра нужно удалить пробел.
		ПодСтр1Разделитель = не (лев(ПодСтр1,2) = "%[" и прав(ПодСтр1,2)="]%");
		ПодСтр2Разделитель = не (лев(ПодСтр2,2) = "%[" и прав(ПодСтр2,2)="]%");
		ПодСтр3Разделитель = не (лев(ПодСтр3,2) = "%[" и прав(ПодСтр3,2)="]%");
		//элементы не могут быть одновременно ни разделителями, ни параметрами
		если МассивРазделенныхПараметров.Количество()>1 и не ((ПодСтр1Разделитель и ПодСтр2Разделитель) или не (ПодСтр1Разделитель и ПодСтр2Разделитель)) тогда
			//ошибка
			Найден = ложь;
			Прервать;
		ИначеЕсли МассивРазделенныхПараметров.Количество()>2 и не ((ПодСтр1Разделитель и ПодСтр2Разделитель) или не (ПодСтр1Разделитель и ПодСтр2Разделитель)) 
			и не ((ПодСтр2Разделитель и ПодСтр3Разделитель) или не (ПодСтр2Разделитель и ПодСтр3Разделитель)) тогда
			Найден = ложь;
			Прервать;
		КонецЕсли;
		если не ПодСтр3Разделитель тогда
			//нужно убрать этот параметр
			ПодСтр3 = "";
			ПодСтр3Разделитель = истина;
		КонецЕсли;
		
		//так как на одну позицию параметра возможны несколько вариантов отображения, то парсим варианты и проходим последователдьно 
		Если не ПодСтр1Разделитель тогда
			МассивШаблонов = ПараметрВТЗШаблонов(ПодСтр1,СокрЛП(ПодСтр1)="",RegExp,МассивРазделенныхПараметров.Количество()=1);
		ИначеЕсли не ПодСтр2Разделитель тогда
			МассивШаблонов = ПараметрВТЗШаблонов(ПодСтр2,СокрЛП(ПодСтр2)="",RegExp);				
		иначе
			МассивШаблонов = новый ТаблицаЗначений;
		КонецЕсли; 
		
		Для каждого шаблон из МассивШаблонов цикл
			СтрШаблон = "^ *";//начало строки
			Если ПодСтр1Разделитель тогда
				СтрШаблон = СтрШаблон + ВставитьСлужебныесимволы(ПодСтр1)+" *";
			КонецЕсли;
			СтрШаблон = СтрШаблон +  шаблон.Шаблон;
			Если ПодСтр2Разделитель тогда
				СтрШаблон = СтрШаблон +  ВставитьСлужебныесимволы(ПодСтр2)+" *";
			КонецЕсли;
			Если ПодСтр3Разделитель тогда
				СтрШаблон = СтрШаблон +  ВставитьСлужебныесимволы(ПодСтр3)+" *";
			КонецЕсли;
			RegExp.pattern  = СтрШаблон;
			Поиск = RegExp.Execute(РасмТекст);
			если Поиск.count>0 тогда
				НайдЗнач = Поиск.item(0).value;
				//нужно удалить разделители. 
				Если ПодСтр1Разделитель тогда
					НайдЗнач = прав(сокрЛП(НайдЗнач),СтрДлина(сокрЛП(НайдЗнач)) - СтрДлина(сокрЛП(ПодСтр1)));
				КонецЕсли;
				Если ПодСтр2Разделитель тогда
					НайдЗнач = Лев(сокрЛП(НайдЗнач),СтрДлина(сокрЛП(НайдЗнач)) - СтрДлина(сокрЛП(ПодСтр2)));
				КонецЕсли;
				Если ПодСтр3Разделитель тогда
					НайдЗнач = Лев(сокрЛП(НайдЗнач),СтрДлина(сокрЛП(НайдЗнач)) - СтрДлина(сокрЛП(ПодСтр3)));
				КонецЕсли;
				
				СтруктураРеквизитов.Вставить(шаблон.Параметр,сокрЛП(НайдЗнач));
				
				РасмТекст = прав(РасмТекст,СтрДлина(РасмТекст)-(Поиск.item(0).Length - ?(ПодСтр2Разделитель,СтрДлина(ПодСтр2),?(ПодСтр3Разделитель,СтрДлина(ПодСтр3),0))));
			иначе
				Найден = ложь; 		
			КонецЕсли;
		КонецЦикла;
		
		Если МассивРазделенныхПараметров.Количество()>1 и не ПодСтр2Разделитель тогда
			//значит параметр в середине, удалить первый разделитель и параметр
			МассивРазделенныхПараметров.Удалить(1);
			МассивРазделенныхПараметров.Удалить(0);	
		Иначе
			МассивРазделенныхПараметров.Удалить(0);	   				
		КонецЕсли;
		если Найден = ложь тогда
			прервать;
		КонецЕсли;
	КонецЦикла;
	
	если Найден = ложь тогда
		возврат новый Структура;
	иначе 
		возврат СтруктураРеквизитов;
	КонецЕсли;
КонецФункции

Процедура УбратьДвойныеПробелы(текст) Экспорт
	Пока найти(текст,"  ")>0 цикл
		текст = СтрЗаменить(текст,"  "," ");
	КонецЦикла;  	
КонецПроцедуры

Пример использования: СтруктураРеквизитов = РазложитьСтрокуПоШаблону(Шаблон,текст);

8

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. VmvLer 03.06.19 11:11 Сейчас в теме
за труд спасибо.
Но зачем эта возня с регуляркой в простейшем парсинге?

Что касается заявления об универсальности, то уже по структуре метода и комментариям понятно - вряд ли это будет работать стабильно.
Как по мне то проще:

РазделителиАтомов = " ,;:-"; // разделители пробел, запятая, точка с запятой и т.д.
мАтомыСтроки = СтрРазделить(СтрокаПарсинга, РазделителиТермов, Ложь); // Получаем атомы строки

// Обходим атомы и помещаем в структуру свойств, то что ищем
//...
pm74; AronMav; +2 Ответить
3. rusmil 180 03.06.19 13:49 Сейчас в теме
(1) Интересно где та, грань после которой лучше использовать регулярные выражения, а когда проще обойтись встроенными функциями 1С для работы со строками? Поделитесь опытом?
4. VmvLer 03.06.19 14:04 Сейчас в теме
(3) составляющие "грани" :
1. простота чтения кода;
2. простота расширения кода;
3. стабильность результата;
4. отсутствие обещаний универсальности.

Если составляющие "грани" разъедены сложностью, то на месте грани образуется дыра.
JohnyDeath; Mettem_Kirill; rusmil; +3 Ответить
5. trim89 101 03.06.19 15:05 Сейчас в теме
(1)что касается универсальности, написал же, более-меннее. Естественно, есть контрпримеры, но для обычных задач хватит. И поподробнее что видно по структуре и комментариям?
Зачем нужно? Что бы простейший парсинг был ещё проще.
Что касается атомов и прочего, вот как раз таки это очень узкий способ, который подбирается для каждой строки отдельно, от этого и хотел уйти. Особенно когда нужно проверить является ли параметр числом, или записывается определенным форматом. Рег выражения позволяют универсиализировать и упростить этот момент.
2. Поручик 4331 03.06.19 11:45 Сейчас в теме
Примерно так же я выдёргивал данные с Авито.
6. JohnyDeath 294 07.06.19 09:55 Сейчас в теме
Для тех, кто считает, что регулярки - это не от мира сего, есть вот такое: https://github.com/oscript-library/verbal-expressions
7. A_Max 17 07.06.19 11:54 Сейчас в теме
(6) .ЧтоНибудьНоНе(" ") - очуметь :о)
Может на первых порах это и проще дня начала понимания регулярных выражений, но лучше потренироватья день на кошечках в виде онлайн парсеров и тогда всё становится проще и понятней.
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 319

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    10260    ids79    42       

Обмен данными. Консистентность vs Многопоточность 25

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Интеграция

Рассмотрим теоретические основы обмена данными. Какие бывают обмены, какие гарантии при этом даются, зачем идти на компромиссы и что при этом может пойти не так. Есть ли идеальная схема?

03.09.2019    3205    m-rv    1       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 243

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    10655    ids79    24       

Подсистема "Варианты отчетов". Используете ли Вы ее правильно? 212

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    14462    YPermitin    49       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4877    m-rv    2       

Как настроить правильную техподдержку (helpdesk, service desk на коленке) 38

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8 УУ Управление взаимоотношениями с клиентами (СRM) Документооборот и делопроизводство Монитор заказов Учет рабочего времени Бесплатно (free) Управление услугами и сервисом

Эта статья будет полезна для компаний, которые оказывают техническую поддержку своим пользователям - внешним или внутренним клиентам. В статье я расскажу, как оказываем поддержку мы, как выстроили этот бизнес-процесс, что контролируем и на что обращаем внимание в работе. Вы можете использовать наш опыт при построении собственной системы поддержки или обратиться к нам за помощью за построением такой системы, будем рады помочь. В статье формируется основной набор правил, которые мы сформировали при настройке системы для себя, а так же небольшие примеры того, как мы эти правила применяем.

24.04.2019    7253    siddy    0       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7419    m-rv    16       

Копирование числовых ячеек из 1С в Excel 26

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Администрирование данных 1С

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    10543    itriot11    21       

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке 466

Статья Программист Нет файла v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные функции

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    32075    GeterX    93       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 126

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20924    ids79    40       

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git 268

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    33794    stas_ganiev    72       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20537    tormozit    100       

Из Excel в 1С запросом 33

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    13586    m-rv    5       

Повышаем эффективность разработки правил обмена 124

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19358    olegtymko    47       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21245    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    17023    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11391    Rustig    9       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники 96

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    16265    V.Stavinsky    11       

Минимализмы 3 352

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35713    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25904    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21356    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 722

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    137945    MaxS    251       

Обзор имеющихся библиотек OneScript 299

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) OneScript

Экосистема OneScript активно развивается. Количество пользователей данного интерпретатора и имеющихся библиотек неуклонно растет, количество решаемых проблем - тоже. Однако остро встает вопрос некоторой разобщенности и размазанности информации по имеющимся библиотекам, их функциональности и проблемам, которые они решают. Данная статья призвана навести порядок в этой теме.

14.11.2017    30853    nixel    85       

Программные перечисления, ч.2: приемы кэширования при разработке 66

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    21114    unichkin    17       

Легкий способ обновления измененной конфигурации 41

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Легкий способ обновления измененной конфигурации. Сервис подготовки расширения конфигурации

25.10.2017    18574    avk72    63       

Работа с Excel 289

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24850    arakelyan    39       

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере 125

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    34272    tormozit    72       

Ускоряем 1С: модули с повторным использованием возвращаемых значений 136

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    43209    m-rv    60       

Как просто запомнить алгоритм программного вывода в СКД 205

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования

Порой нужно быстро вывести на экран таблицу значений, используя СКД \ получить данные отчета в таблицу значений.. Несмотря на очевидность алгоритма - раньше мне проще было загуглить программный вывод, благо эта инфа есть везде. Но постепенно понял как его можно быстро вспомнить, и лишний раз ничего не искать. Конечно эта статья не для Гуру :) Но я думаю - что любой неопытный в СКД программист сделает для себя небольшое открытие...

01.09.2017    41548    unichkin    15       

Как формируется GUID? 463

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

"Коллеги, есть идеи, как получить последнюю созданную характеристику? Реквизиты полностью идентичны(код, наименование, и т.п.)."(c) "Насколько я знаю, ссылка не обеспечивает последовательность, а только уникальность."(c) "Я сделал по Максимум(Ссылка). Но, чета, мне кажется, это неправильно."(c) "Слышал что в ГУИд содержится как раз время создания и по всей логике вещей сортировка по ссылке должна сортировать по моменту создания объекта"(c) Сколько раз вы слышали такие фразы? На удивление я не обнаружил информации по этой теме, пришлось разбираться самому...

16.06.2017    52608    kuzyara    55       

Использование инструментов разработчика для отладки обменов КД 2.0 67

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Пара трюков, благодаря которым жить становится намного проще...

05.05.2017    22617    unichkin    3       

Работа с конвертацией данных 350

Статья Программист Нет файла v8 КД Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Поскольку к конвертации обращаюсь время от времени и какие-то детали забываются, хочу выделить несколько пунктов, чтобы "было где посмотреть". Статья сделана преимущественно «для себя», так что просьба не судить строго. (Примечание читающим/комментирующим: код в примерах очень сильно сокращен.)

16.03.2017    61991    perepetulichka    25       

Online телефонный справочник из 1С: Зарплата и управление персоналом 34

Статья Системный администратор Программист Нет файла v8 ЗУП3.x Россия Управление персоналом (HRM) Бесплатно (free) WEB

В интернете представлено много реализаций online телефонных справочников организаций. Есть справочники, которые использует для хранения информации базу Active Directory (LDAP), есть справочники, которые реализованы с использованием СУБД (например, MySQL). Но я не нашел справочника, который использует информацию из базы 1С. Далее я рассмотрю данную разработку.

10.03.2017    19092    ruha    14       

Библиотека стандартных подсистем (Механизм БСП) 74

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем)

Конфигурации в 1С пишутся для пользователей и по их «правилам» (клиент всегда прав), поэтому в основном все конфигурации разные, но достаточно часто в них используются одни и те же объекты, которые незначительно отличаются друг от друга. Действительно, сложно представить конфигурацию, где не фигурировали бы такие сущности как номенклатура, контрагенты, пользователи, валюта. И некоторые задачи являются типичными: возможность базового разграничения прав, работа с электронной почтой, задачи пользователям и т.д. Но...!

03.03.2017    51442    V.Stavinsky    21       

Автоматизированная проверка конфигураций… и пара слов о стандартах разработки 266

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Тестирование и исправление

Предлагаю познакомиться с инструментом "Автоматизированная проверка конфигураций" и получить практику его применения

18.01.2017    43560    3    Vladimir Litvinenko    20       

Отладка подключаемых обработок 195

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

На самом деле для этого не нужно ни изменять конфигурацию, ни пользоваться вспомогательной обработкой-отладчиком.. Все просто :)

04.01.2017    43632    unichkin    77       

Использование программных перечислений, ч.1: строковые константы 143

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    29950    unichkin    45       

РИБ 200 узлов. Середина пути 116

Статья Системный администратор Программист Нет файла v8 Розница Россия Бесплатно (free) Распределенная БД (УРИБ, УРБД)

Между настройкой и поддержкой РИБ на 2 узла и на 10 большой разницы нет, а вот когда число удаленных точек переваливает за сотню, приходится решать уже совсем другие вопросы

25.10.2016    34179    comol    215       

Использование git для доработки типовых конфигураций 1С 230

Статья Программист Нет файла v8 Беларусь Украина Россия Бесплатно (free) Математика и алгоритмы

Рассмотрены способы доработок типовой конфигурации 1C для различных изменений, и на картинках продемонстрирован подход к разработке с использованием git и частично с тестами.

11.10.2016    186362    pumbaE    31       

Отладка конфигураций на мобильной платформе 107

Статья Программист Нет файла v8 Бесплатно (free) Мобильная разработка

Настройка и подключение отладчика для отладки конфигураций на мобильной платформе.

25.09.2016    35099    spezc    44       

Обновление доработанной Бухгалтерии предприятия. Как проверить и убедиться, что все сделано хорошо? 89

Статья Системный администратор Программист Бухгалтер Нет файла v8 БП2.0 Бесплатно (free) Практика программирования

На тему обновления нетиповых конфигураций написано немало. Но в основном все это касается самого процесса обновления, его технической стороны. Что нажимать, на что не нажимать в том или ином случае. В данной статье хотелось бы обратить внимание на действия, которые требуются для последующего анализа обновленной конфигурации.

05.09.2016    24828    kraynev-navi    33       

Старые обработки в новом (Управляемом) интерфейсе 101

Статья Программист Нет файла v8 v8::УФ Windows Бесплатно (free) Практика программирования

Многие разработчики привыкли использовать какие-либо обработки, разработанные для приложений с обычным интерфейсом. Но они не работают в приложениях на управляемых формах. Как вариант, эту обработку можно включить в состав конфигурации, указать в свойствах конфигурации, что возможно использование обычных форм

12.08.2016    58007    valerasv    7       

Регистры сведений 1С. Как это устроено. 714

Статья Программист Нет файла v8 Бесплатно (free) Математика и алгоритмы

Основная идея публикации - собрать в одном месте информацию о внутреннем устройстве такой абстрактной сущности, как "Регистр сведений 1С" и ответить на ряд вопросов: Что происходит при записи регистра в различных режимах? Что такое на самом деле "СрезПервых" и "СрезПоследних"? Как оптимально выбрать структуру регистра? Это та информация, владея которой, начинаешь лучше понимать как это работает и как правильно использовать регистры сведений.

05.08.2016    147217    Sergey.Noskov    154       

Простая и быстрая эмуляция операций с битовыми строками 67

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Битовые строки могли бы упростить реализацию некоторых алгоритмов на языке платформы «1С: Предприятие 8». Но пока в платформе операций с битовыми строками нет. В то же время уже сделанные попытки смоделировать эти операции преобразованиями над числами опираются на циклы обработки отдельных битов, что плохо сказывается на скорости их работы. Предлагается новое простое решение, основанное на представлении битовых строк строками символов «0» и «1». Приводится примеры кода выполнения основных логических операций AND, OR, XOR, NO без использования циклов. В качестве прикладной задачи рассмотрено получение последовательных значений кода Грэя, который можно использовать для ускорения перебора вариантов.

22.06.2016    25980    ildarovich    14