Hello world в Vanessa-ADD bddRunner

Публикация № 1390222

Методология - DevOps - Сценарное тестирование

Минимальный пример на Vanessa-ADD bddRunner без теории. При написании использовались: 1С 8.3.10.2753, Vanessa add 6.6.5.

Создаем новую базу данных 1С без метаданных с установленным свойством "Основной режим запуска" = "Обычное приложение"

Создаем документ "Заказ" с реквизитами

  • Сумма типа Число
  • СуммаЗаполнена типа Булево

В модуль объекта документа помещаем:

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    СуммаЗаполнена = Сумма <> 0
КонецПроцедуры

Создаем роль со всеми правами

Создаем пользователя с установленной ролью, со сброшенным флагом "Защита от опасных действий"

Создаем текстовый файл "Фича1.feature" содержащий:

Функционал: Проверка корректности установки флага "Сумма заполнена" в документе "Заказ"

Контекст:
  Дано Создан документ Заказ

Сценарий: Установка флага при записи
  Когда Документ записан с НЕнулевой суммой
  Тогда В документе устанавлен флаг "Сумма заполнена"

Сценарий: Сброс флага при записи
  Когда Документ записан с нулевой суммой
  Тогда В документе сброшен флаг "Сумма заполнена"

Скачиваем файл add*.zip со страницы https://github.com/vanessa-opensource/add/releases/
Разархивируем.

В режиме предприятия конфигурации открываем файл bddRunner.epf

На закладке "Запуск сценариев" по кнопке "Загрузить фичи" выбираем каталог с файлом фичи.

На закладке "Генератор EPF" указываем путь к каталогу где находится файл 1cv8.exe

Нажимаем кнопку "Создать шаблоны обработок". В каталоге с фичей появится каталог с обработкой

Открываем обработку в конфигураторе

В следующих процедурах замещаем существующий код:

Процедура СозданДокументЗаказ() Экспорт
	Заказ = Документы.Заказ.СоздатьДокумент();
	Заказ.Дата = ТекущаяДата();
	Контекст.Вставить("Заказ", Заказ)
КонецПроцедуры

Процедура ДокументЗаписанСНЕнулевойСуммой() Экспорт
	Контекст.Заказ.Сумма = 1;
	Контекст.Заказ.Записать();
КонецПроцедуры

Процедура ДокументЗаписанСНулевойСуммой() Экспорт
	Контекст.Заказ.Сумма = 0;
	Контекст.Заказ.Записать();
КонецПроцедуры

Процедура ВДокументеУстанавленФлаг(Парам01) Экспорт
	Если НЕ Контекст.Заказ.СуммаЗаполнена Тогда
		ВызватьИсключение "Неуспех";
	КонецЕсли;
КонецПроцедуры

Процедура ВДокументеСброшенФлаг(Парам01) Экспорт
	Если Контекст.Заказ.СуммаЗаполнена Тогда
		ВызватьИсключение "Неуспех";
	КонецЕсли;
КонецПроцедуры

Записываем обработку

В режиме предприятия в обработке bddRunner нажимаем кнопку "Выполнить сценарии"

Получаем успешно пройденный тест с сообщением "Все сценарии обработаны!" и зелеными значками у сценариев

Специальные предложения

Автор запретил комментарии

См. также

Практика применения DevOps. Тестирование

DevOps Сценарное тестирование Vanessa Automation СППР v8 1cv8.cf Бесплатно (free)

В третьей части мастер-класса «Практика применения DevOps» на конференции Infostart Event 2019 Inception выступила Светлана Попова. Она рассмотрела возможности использования двух инструментов тестирования от фирмы «1С» – «Сценарного тестирования» и связки СППР и Vanessa Automation, и рассказала про плюсы и минусы каждого из этих вариантов.

11.12.2020    3160    SvVik    0    

Молчание "best practices": тестовые и эталонные данные, структура и связность, падения и новая функциональность, и другие неудобные вопросы к сценарному тестированию

Рефакторинг и качество кода Сценарное тестирование v8 Бесплатно (free)

Непонимание некоторых базовых вопросов мешает программистам начать применять инструменты тестирования в процессе разработки для 1С. Как разобраться в терминологии и интегрировать процесс тестирования в разработку 1С-решений на конференции Infostart Event 2019 Inception рассказал руководитель отдела разработки компании C.T.Consultants Решитко Дмитрий.

29.05.2020    4628    grumagargler    14    

Тестирование: Отлаживаем и тестируем REST интерфейс 1С с помощью SoapUI

Сценарное тестирование v8 Бесплатно (free)

Рассмотрим быстрый и удобный способ облегчения разработки и отладки REST, SOAP веб сервисов, а также создания автоматизированных тестов.

03.02.2020    5992    ivanov660    4