Ввод периода дат в отборах СКД

Публикация № 141560

Разработка - Практика программирования

Вы привыкли быстро указывать отбор на даты, пользуясь построителями и штатными окнами 1С? Вам неудобно и долго делать то же самое в отборах СКД? Ввод условия на период дат можно обеспечить с помощью простенькой процедуры, добавляемой в любое нужное место.

Надоело мне вводить периоды вручную - группу делай, границы указывай, лениво и ошибкоопасно. Разработал процедуру:

Процедура ВставитьУсловиеНаИнтервалДат(Элемент) Экспорт
Попытка
 
рТипГруппыОтбора=Тип("ГруппаЭлементовОтбораКомпоновкиДанных");
 
рТипЭлементаОтбора=Тип("ЭлементОтбораКомпоновкиДанных");

 
текдан=Элемент.ТекущиеДанные;
 
рТипТекдан=ТипЗнч(текдан);
 Если
рТипТекдан=Тип("ОтборКомпоновкиДанных") Тогда
 
рДоступныеПоля=текдан.ДоступныеПоляОтбора.Элементы;
 ИначеЕсли
рТипТекдан=рТипГруппыОтбора или рТипТекдан=рТипЭлементаОтбора Тогда
 
Сообщить("Если условие на интервал дат нужно во вложенной группе, создайте его на верхнем уровне и перетащите в нужную группу.",СтатусСообщения.Информация);
 
Предупреждение("Автоматическое добавление возможно только на верхнем уровне самого отбора!"); Возврат;
 Иначе
  Возврат;
// какой-то странный тип
 
КонецЕсли;

 
//================================================================================
 // Определяем доступные отборы типа "Дата"
 //
 
спв=Новый СписокЗначений; // если дата не одна, дадим выбор
 
Для каждого рПоле Из рДоступныеПоля Цикл
  Если
рПоле.ТипЗначения.СодержитТип(Тип("Дата")) Тогда
  
спв.Добавить(рПоле,рПоле.Заголовок);
  КонецЕсли;
 КонецЦикла;
 Если
спв.Количество()=0 Тогда
 
Предупреждение("В текущей СКД нет полей отбора типа ""Дата""!"); Возврат;
 ИначеЕсли
спв.Количество()=1 Тогда
 
рПоле=спв.Получить(0).Значение;
 Иначе
 
спв.СортироватьПоПредставлению();
 
выбзнч=спв.ВыбратьЭлемент("Укажите нужное поле:");
  Если
выбзнч=Неопределено Тогда Возврат КонецЕсли;
 
рПоле=выбзнч.Значение;
 КонецЕсли;

 
//================================================================================
 // Запрашиваем вид интервала
 //
 
спвар=Новый СписокЗначений;
 
спвар.Добавить(ВидСравнения.Интервал,"Не включая границы ( )");
 
спвар.Добавить(ВидСравнения.ИнтервалВключаяГраницы,"Включая границы [ ]");
 
спвар.Добавить(ВидСравнения.ИнтервалВключаяНачало,"Включая начало [ )");
 
спвар.Добавить(ВидСравнения.ИнтервалВключаяОкончание,"Включая конец ( ]");
 
выбзнч=спвар.ВыбратьЭлемент("Укажите тип интервала:");
 Если
выбзнч=Неопределено Тогда Возврат КонецЕсли;
 
// определяемся
 
Если выбзнч.Значение=ВидСравнения.ИнтервалВключаяГраницы
 или выбзнч.Значение=ВидСравнения.ИнтервалВключаяНачало
 Тогда
 
рВидСравненияНачГраницы=ВидСравненияКомпоновкиДанных.БольшеИлиРавно;
 Иначе
 
рВидСравненияНачГраницы=ВидСравненияКомпоновкиДанных.Больше;
 КонецЕсли;
 Если
выбзнч.Значение=ВидСравнения.ИнтервалВключаяГраницы
 или выбзнч.Значение=ВидСравнения.ИнтервалВключаяОкончание
 Тогда
 
рВидСравненияКонГраницы=ВидСравненияКомпоновкиДанных.МеньшеИлиРавно;
 Иначе
 
рВидСравненияКонГраницы=ВидСравненияКомпоновкиДанных.Меньше;
 КонецЕсли;

 
//================================================================================
 // Запрашиваем интервал
 //
 
рНачалоПериода=Дата(1,1,1); рКонецПериода=Дата(1,1,1);
 
// стандартный диалог
 
рНастройкаПериода=Новый НастройкаПериода;
 
рНастройкаПериода.УстановитьПериод(рНачалоПериода,рКонецПериода);
 
рНастройкаПериода.РедактироватьКакИнтервал=Истина;
 
рНастройкаПериода.РедактироватьКакПериод=Истина;
 
рНастройкаПериода.ВариантНастройки=ВариантНастройкиПериода.Период;
 Если не
рНастройкаПериода.Редактировать() Тогда Возврат КонецЕсли;
 
рНачалоПериода=НачалоДня(рНастройкаПериода.ПолучитьДатуНачала());
 
рКонецПериода=КонецДня(рНастройкаПериода.ПолучитьДатуОкончания());


 
//================================================================================
 // Ищем, нет ли уже такой группы и таких элементов в ней (только на текущем уровне отбора!)
 //
 
рГруппа=Неопределено;
 
рНачГраница=Неопределено;
 
рКонГраница=Неопределено;
 
//
 
рПредставлениеГруппы="Интервал "+СтрЗаменить(НРег(выбзнч.Представление),"ючая",".")+" для """+СокрЛП(рПоле.Заголовок)+"""";
 Для каждого
элотб Из текдан.Элементы Цикл
 
ОбработкаПрерыванияПользователя();
  Если
ТипЗнч(элотб)=рТипГруппыОтбора
  и элотб.Представление=рПредставлениеГруппы
  и элотб.ТипГруппы=ТипГруппыЭлементовОтбораКомпоновкиДанных.ГруппаИ
  Тогда
  
рГруппа=элотб; // ищем внутри неё
  
Для каждого элотбгр Из рГруппа.Элементы Цикл
   
ОбработкаПрерыванияПользователя();
    Если
ТипЗнч(элотбгр)=рТипЭлементаОтбора Тогда
     Если
элотбгр.ВидСравнения=рВидСравненияНачГраницы и элотбгр.ЛевоеЗначение=рПоле.Поле Тогда
     
рНачГраница=элотбгр;
     ИначеЕсли
элотбгр.ВидСравнения=рВидСравненияКонГраницы и элотбгр.ЛевоеЗначение=рПоле.Поле Тогда
     
рКонГраница=элотбгр;
     КонецЕсли;
    КонецЕсли;
   КонецЦикла;
// по элементам подходящей группы
 
КонецЕсли;
 КонецЦикла;

 
//================================================================================
 // Создаём недостающее, устанавливаем нужное
 //
 
Если рГруппа=Неопределено Тогда
 
рГруппа=текдан.Элементы.Добавить(рТипГруппыОтбора);
 
рГруппа.ТипГруппы=ТипГруппыЭлементовОтбораКомпоновкиДанных.ГруппаИ;
 КонецЕсли;
 
рГруппа.Представление=рПредставлениеГруппы;
 
рГруппа.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
 
рГруппа.Использование=Истина;
 
//
 
Если рНачГраница=Неопределено Тогда
 
рНачГраница=рГруппа.Элементы.Добавить(рТипЭлементаОтбора);
 
рНачГраница.ЛевоеЗначение=рПоле.Поле;
 КонецЕсли;
 
рНачГраница.ВидСравнения=рВидСравненияНачГраницы;
 
рНачГраница.ПравоеЗначение=рНачалоПериода;
 
рНачГраница.Использование=Истина;
 
рНачГраница.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
 
рНачГраница.Представление="Нач.граница";
 
//
 
Если рКонГраница=Неопределено Тогда
 
рКонГраница=рГруппа.Элементы.Добавить(рТипЭлементаОтбора);
 
рКонГраница.ЛевоеЗначение=рПоле.Поле;
 КонецЕсли;
 
рКонГраница.ВидСравнения=рВидСравненияКонГраницы;
 
рКонГраница.ПравоеЗначение=рКонецПериода;
 
рКонГраница.Использование=Истина;
 
рКонГраница.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
 
рКонГраница.Представление="Кон.граница";
Исключение
 
Сообщить("Ошибка при установке условий на интервал дат: "+ОписаниеОшибки(),СтатусСообщения.Важное);
КонецПопытки;
КонецПроцедуры


 

Сделал вызов этой процедуры в той форме, где находился нужный компоновщик:

РаботаСДиалогами.ВставитьУсловиеНаИнтервалДат(ЭлементыФормы.дОтборРК);

Стало можно быстро копипастить, а пользователям стало можно удобно вводить период.
Недостаток только в том, что текущей строкой отбора должна быть самая верхняя, корневая.
Плюсить особо не за что, а вот если пригодится кому, будет приятно. :)

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. VladZetRu 9 28.06.12 17:37 Сейчас в теме
И зачем так изгаляться, в СКД нужно использовать Параметр Стандартный период, и получением из него дополнительных Параметров НачальнаяДата(ДатаНачала или как Вы еще хотите) и КонечнаяДата используемых в запросе СКД.
Параметр СтандартныйПериод выводим на форму и пользуемся.
2. Yashazz 3474 28.06.12 19:07 Сейчас в теме
(1) СтандартныйПериод можно загнать в общее дерево отбора?
3. VladZetRu 9 28.06.12 22:52 Сейчас в теме
(2)Да. Создаешь параметр ПериодОтчета с типом Стандартный период доступный пользователю, а также параметры ДатаНач(Имя совпадает с тем, что в запросе) и ДатаКон не доступные Пользователю, назначаешь им значения в выражении типа &ПериодОтчета.ДатаНачала и соответвенно &ПериодОтчета.ДатаОкончания.
Параметру ПериодОтчета можешь задать значение по умолчанию типа ЭтотМесяц или ПроизвольныйПериод.
4. Serj1C 479 29.06.12 07:24 Сейчас в теме
(3) VladZetRu, В дерево отборов "Период отчета" не попадет, в параметрах останется
6. Yashazz 3474 02.07.12 10:03 Сейчас в теме
(4) Именно.
(5) Это я знаю. Цель была именно в том, чтоб все поля, имеющие тип даты, дать пользователю ставить самому удобно, а не обеспечивать это каждый раз через параметры. В дереве отборов параметры не позволяют использовать "стандартный период".
5. anton.fly7 149 29.06.12 09:02 Сейчас в теме
7. e.kogan 1856 24.05.17 16:21 Сейчас в теме +200 $m
Между прочим, сколько всего напридумывали в новых релизах, а дату интервалом до сих пор нельзя обусловить :( надо бы под тонкий клиент адаптировать, нэ?
8. Cooler 22 24.05.17 16:26 Сейчас в теме
Гм! Подарок к годовщине свадьбы?
9. e.kogan 1856 27.05.17 15:33 Сейчас в теме +1000 $m
(8) Не, к годовщине свадьбы мне бы лёгонький трассировщик кода... )
10. Cooler 22 27.05.17 18:44 Сейчас в теме
"Высокие, высокие отношения!" (с)
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37595    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    28272    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    24913    John_d    22    

СКД. Шаг 3. Используем макеты для оформления отчета

Работа с интерфейсом v8 v8::СКД 1cv8.cf Бесплатно (free)

В данной публикации рассмотрим базовый подход к использованию собственных макетов в СКД на примере формирования небольшого отчета.

13.01.2020    15581    aximo    14    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30642    tormozit    100    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    19148    kuzyara    33    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    17337    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8619    Sibars    19    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78261    tormozit    131    

Создание асинхронных виджетов

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Описание нескольких способов создания асинхронных виджетов для 1С:Предприятия. Рассматриваются способы с использованием HTTP-сервисов и фоновых заданий.

16.10.2019    13077    YPermitin    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    34317    Yashazz    50    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    52316    rpgshnik    63    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48731    tormozit    41    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    50774    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    29286    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25777    YPermitin    80    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    45106    tormozit    74    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    32027    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    86093    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    36777    avalakh    22    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16138    m-rv    2    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    24711    json    14    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    62136    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    36486    ids79    27    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20404    m-rv    17    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    26455    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19813    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    48411    ids79    17    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30931    m-rv    21    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    53851    ids79    25    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    25480    dmurk    145    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    42360    YPermitin    52    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28371    itriot11    34    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    44135    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35798    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27640    ellavs    90    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76761    Serginio    108    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31759    YPermitin    53    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    22451    Vladimir Litvinenko    27    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    40683    ids79    9    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    35255    ids79    40    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    27219    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    42150    ids79    72    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29408    grumagargler    28    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    37717    ids79    42    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    49033    Unk92    25    

Произвольный код в фоновом режиме

Практика программирования v8 1cv8.cf Бесплатно (free)

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    28464    zarankony    42    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    53128    m-rv    61