Расширение функционала произвольных отчетов (сохранение в настройках ориентации страницы и повтор области строк при выводе на печать)

Публикация № 148206

Разработка - Практика программирования

Расширение функционала вывода на печать произвольных отчетов для УПП, КА и других конфигураций, использующих механизм произвольных отчетов. Позврляет сохранять в настройках (справочник Сохраненные настройки) ориентации страницы, масштаб и повтор области строк при выводе на печать.

Расширение фунционала вывода на печать произвольных отчетов для УПП, КА и других конфигураций, использующих механизм произвольных отчетов. Позволяет сохранять в настройках (справочник Сохраненные настройки) ориентации страницы, масштаб и повтор области строк при выводе на печать.

Недавно потребовалось расширить функционал произвольных отчетов, чтобы была возможность сохранять ориентацию страницы по ширине, а также повторять строки  части шапки на каждой страницы при выводе на печать, в соответствии с требованиями минимального изменения типового функионала и неизменения диалогов типовых форм, чтобы уменьшить временные затраты при обновлении конфигураций на новые релизы.

 

Все изменения для реализации данной задачи коснулись только отчета "ПроизвольныйОтчет".

1) в отчет "ПроизвольныйОтчет" добавлены три реквизита (в именах реквизитов и др. объектах используется префикс "иц", чтобы можно было легко отличить добавленные объекты, формы, реквизиты и т.п. от типовых):

  • - ицНастройкиТабличногоДокумента (тип ТабличныйДокумент) - сохраняет АвтоМасштаб, ориентацию, значение Масштаба;
  • - ицПовторятьШапку (тип Булево);
  • - ицИспользоватьМакет (тип Булево).

2) Добавлена произвольная обычная форма ицФормаУстановокПараметровСтраницы (при установленной галочки "Повторять шапку" видны поля ввода номеров строк, в противном случае, они закрыты текстом), все реквизиты, кроме указанных выше, размещены прямо на форме: 

код формы:

 Процедура ОсновныеДействияФормыДействие(Кнопка)    

ВладелецФормы = ЭтаФорма.ВладелецФормы;  

ицНастройкиТабличногоДокумента = ВладелецФормы.ицНастройкиТабличногоДокумента;  

Если фПовторятьШапку и ЗначениеЗаполнено(НомерПервойСтроки) Тогда   

ОбластьШапкиПовтора = ицНастройкиТабличногоДокумента.Область(НомерПервойСтроки, ,?(ЗначениеЗаполнено(НомерПоследнейСтроки),НомерПоследнейСтроки,Неопределено), );

   ицНастройкиТабличногоДокумента.ПовторятьПриПечатиСтроки = ОбластьШапкиПовтора;  

Иначе   

 ицНастройкиТабличногоДокумента.ПовторятьПриПечатиСтроки = Неопределено;  

КонецЕсли;  

ВладелецФормы.ицИспользоватьМакет = ИспользоватьМакет;

 ВладелецФормы.ицПовторятьШапку = фПовторятьШапку;  

Если ПереключательМасштаб Тогда  

 ицНастройкиТабличногоДокумента.АвтоМасштаб    = Ложь;   

ицНастройкиТабличногоДокумента.МасштабПечати  = ЗначениеМасштаба;  

Иначе    ицНастройкиТабличногоДокумента.АвтоМасштаб    = Истина;   

ицНастройкиТабличногоДокумента.МасштабПечати  = Неопределено;  

КонецЕсли;  

Если Портрет Тогда  

 ицНастройкиТабличногоДокумента.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;

  Иначе

    ицНастройкиТабличногоДокумента.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;

  КонецЕсли;

  Закрыть();

 КонецПроцедуры

Процедура фПовторятьШапкуПриИзменении(Элемент)  ОбновитьВидимость();

КонецПроцедуры

Процедура ОбновитьВидимость()    Если фПовторятьШапку Тогда   ЭлементыФормы.НадписьНомерПервойСтроки.Видимость  = Истина;   ЭлементыФормы.НомерПервойСтроки.Видимость    = Истина;   

ЭлементыФормы.НадписьНомерПоследнейСтроки.Видимость  = Истина;

   ЭлементыФормы.НомерПоследнейСтроки.Видимость   = Истина;

   ЭлементыФормы.НадписьОписаниеПовторятьШапку.Видимость = Ложь;

  Иначе

    ЭлементыФормы.НадписьНомерПервойСтроки.Видимость  = Ложь;

   ЭлементыФормы.НомерПервойСтроки.Видимость    = Ложь;

   ЭлементыФормы.НадписьНомерПоследнейСтроки.Видимость  = Ложь;

   ЭлементыФормы.НомерПоследнейСтроки.Видимость   = Ложь;

   ЭлементыФормы.НадписьОписаниеПовторятьШапку.Видимость = Истина;

  КонецЕсли;

  Если ПереключательМасштаб Тогда

      ЭлементыФормы.ЗначениеМасштаба.Видимость = Истина;

  Иначе

       ЭлементыФормы.ЗначениеМасштаба.Видимость = Ложь;

   ЗначениеМасштаба = 0;

  КонецЕсли;

  ПроизвольныйОтчет = ЭтаФорма.ВладелецФормы.ПроизвольныйОтчет;

  СхемаКомпоновкиДанных = ПроизвольныйОтчет.СхемаКомпоновкиДанных.получить();

  Если СхемаКомпоновкиДанных.Макеты.Количество() > 0 Тогда

      ЭлементыФормы.ИспользоватьМакет.Видимость = Истина;

  Иначе

       ЭлементыФормы.ИспользоватьМакет.Видимость = Ложь;

   ИспользоватьМакет = Ложь;

  КонецЕсли;

   КонецПроцедуры 

Процедура ПриОткрытии()

    ВладелецФормы = ЭтаФорма.ВладелецФормы;

  ицНастройкиТабличногоДокумента = ВладелецФормы.ицНастройкиТабличногоДокумента;

  Если ицНастройкиТабличногоДокумента.АвтоМасштаб    = Ложь Тогда

   ПереключательМасштаб = Истина;

   ЗначениеМасштаба = ицНастройкиТабличногоДокумента.МасштабПечати;

  Иначе

    ПереключательМасштаб = Ложь;

   ЗначениеМасштаба = 0;

  КонецЕсли;

  Если ицНастройкиТабличногоДокумента.ОриентацияСтраницы = ОриентацияСтраницы.Портрет Тогда

   Портрет = Истина;

  Иначе

    Портрет = Ложь;

  КонецЕсли;

  фПовторятьШапку = ВладелецФормы.ицПовторятьШапку;

  Если ицНастройкиТабличногоДокумента.ПовторятьПриПечатиСтроки = Неопределено Тогда

   НомерПервойСтроки = 0;

   НомерПоследнейСтроки = 0;

  Иначе

    НомерПервойСтроки = ицНастройкиТабличногоДокумента.ПовторятьПриПечатиСтроки.Верх;

   ИмяОбласти = ицНастройкиТабличногоДокумента.ПовторятьПриПечатиСтроки.Имя;

   СимволДвоеточия = Найти(ИмяОбласти,":");

   Если СимволДвоеточия>0 Тогда

       НомерПоследнейСтроки = Число(Сред(ИмяОбласти,СимволДвоеточия+2,СтрДлина(ИмяОбласти)-1));

   Иначе

     НомерПоследнейСтроки = НомерПервойСтроки;

   КонецЕсли;

  КонецЕсли;

  ИспользоватьМакет = ВладелецФормы.ицИспользоватьМакет;

  ОбновитьВидимость();

   КонецПроцедуры

Процедура ПереключательМасштабПриИзменении(Элемент)

  ОбновитьВидимость();

 КонецПроцедуры

Процедура ПоШиринеСтраницыПриИзменении(Элемент)

  ОбновитьВидимость();

 КонецПроцедуры

 

3) Программно добавлена кнопка на основную форму отчета, для чего в процедуре ПриОткрытии добавден код;

 

// {{ИЦ 2012.08.15 начало

ицДобавитьЭУ();

// }}ИЦ 2012.08.15 окончание

 

и ниже сама процедура

 

 // Добавляет доп. реквизиты на форму

 //

  // Параметры

 // нет

 //

 // {{ИЦ 2012.08.15 начало

Процедура ицДобавитьЭУ()

 ТекПанель = ЭлементыФормы.КоманднаяПанель1;    

ТипКнопки = ТипКнопкиКоманднойПанели.Действие;  

тЭУ = ЭлементыФормы.КоманднаяПанель1.Кнопки.Добавить("ицПараметровСтраницы", ТипКнопки,,Новый  Действие("ицУстановитьПараметрыСтраницы"));

 тЭУ.Картинка = БиблиотекаКартинок.ПараметрыОтчета;      

КонецПроцедуры // ицДобавитьЭУ() }}И012.08.15 окончание

 

 

также в модуль формы нужно добавить обработчик нажатия кнопки

 

// {{ИЦ 2012.08.15 начало

Процедура ицУстановитьПараметрыСтраницы()

    ОткрытьФормуМодально("Отчет.ПроизвольныйОтчет.Форма.ицФормаУстановокПараметровСтраницы",,ЭтаФорма);

КонецПроцедуры // }}ИЦ 2012.08.15 окончание


4) Изменения в модуле объекта отчет "ПроизвольныйОтчет":

в Функции СформироватьОтчет в блоке Попытка перед строкой "МакетКомпоновки = ПроцедурыПроизвольныхОтчетов.ПолучитьМакетКомпоновки(" добавить код:

 

  //{{ ИЦ начало   //Описание изменеиния

   //   

Если НЕ ицИспользоватьМакет Тогда

    СхемаКомпоновкиДанных.Макеты.Очистить();

    СхемаКомпоновкиДанных.МакетыГруппировок.Очистить();

    СхемаКомпоновкиДанных.МакетыЗаголовковГруппировок.Очистить();

    СхемаКомпоновкиДанных.МакетыПолей.Очистить();

    СхемаКомпоновкиДанных.МакетыПолейИтога.Очистить();

        СхемаОтчета.Макеты.Очистить();

    СхемаОтчета.МакетыГруппировок.Очистить();

    СхемаОтчета.МакетыЗаголовковГруппировок.Очистить();

    СхемаОтчета.МакетыПолей.Очистить();

    СхемаОтчета.МакетыПолейИтога.Очистить();

   Иначе

     СхемаКомпоновкиДанных = ПроизвольныйОтчет.СхемаКомпоновкиДанных.получить();

    СхемаОтчетаХранилище = Новый ХранилищеЗначения(СхемаКомпоновкиДанных);

    СхемаОтчета    = СхемаОтчетаХранилище.Получить();

   КонецЕсли;   //}} ИЦ 2012.08.17 окончание  

 

и после завершения блока Попытка в блок инструкции препроцессору "#Если Клиент тогда" добавить откомментированный код:

 

 #Если Клиент тогда

   Если ВыводВТабличныйДокумент Тогда

    //{{ ИЦ 2012.08.15 начало

    //Описание изменеиния

    //

   Результат.ПовторятьПриПечатиСтроки = ицНастройкиТабличногоДокумента.ПовторятьПриПечатиСтроки;

    Результат.АвтоМасштаб        = ицНастройкиТабличногоДокумента.АвтоМасштаб;

    Результат.МасштабПечати      = ицНастройкиТабличногоДокумента.МасштабПечати;

    Результат.ОриентацияСтраницы = ицНастройкиТабличногоДокумента.ОриентацияСтраницы;

    Если ЗначениеЗаполнено(СохраненнаяНастройка.Наименование) Тогда

     Результат.ИмяПараметровПечати = "ПАРАМЕТР_ПЕЧАТИ_"+СохраненнаяНастройка.Наименование;

    КонецЕсли;

   //}} ИЦ 2012.08.15 окончание

    ТиповыеОтчеты.УправлениеОтображениемЗаголовкаТиповогоОтчета(ЭтотОбъект, Результат);

   КонецЕсли;

  #КонецЕсли

 

  

Это все необходимые изменения. Настройка позволяет в произвольных отчетах для одного итого же отчета использовать Макет в одной настройке и отказаться от его использования в другой настройке при необходимости.

 

Для настройки вывода повторяющихся строк нужно сформировать отчет, в меню Таблица - Вид - установить отборажать заголовки, чтобы точно определить номера строк для повтора, затем нажать кнопку "Установить параметры страницы" и в полях "Номер первой строки" и "Номер последней строки" установить номера строк. Для вывода одной строки в обоих полях следует ввести номер этой строки.

 

Результат вывода на печать с повторяющейся частью шапки таблицы:

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. melis 91 20.08.12 20:19 Сейчас в теме
если кому-то будет нужно, могу сохарнить как внешний "ПроизвольныйОтчет", с описанными изменениями, из последней УПП
2. sergiobargio1 115 22.08.12 14:33 Сейчас в теме
очень хорошая и часто необходимая настройка. в УПП произвольные отчёты есть. не подскажите: а для БП можно привинтить к самописным внешним отчётам Вашу настройку как есть или необходимо будет сначало подправить код? Спасибо.
3. melis 91 22.08.12 20:37 Сейчас в теме
Привинтить можно, если у отчтеов есть форма, но код тогда может оказаться немного другим
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37790    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    30635    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    26460    John_d    22    

СКД. Шаг 3. Используем макеты для оформления отчета

Работа с интерфейсом v8 v8::СКД 1cv8.cf Бесплатно (free)

В данной публикации рассмотрим базовый подход к использованию собственных макетов в СКД на примере формирования небольшого отчета.

13.01.2020    16885    aximo    14    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30979    tormozit    100    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    20141    kuzyara    33    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    17667    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8797    Sibars    19    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78493    tormozit    131    

Создание асинхронных виджетов

Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Описание нескольких способов создания асинхронных виджетов для 1С:Предприятия. Рассматриваются способы с использованием HTTP-сервисов и фоновых заданий.

16.10.2019    13186    YPermitin    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    30877    HostHost    40    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    35650    Yashazz    50    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    49049    tormozit    42    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    55472    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    52550    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    30107    YPermitin    24    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    45478    tormozit    74    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    26050    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    32786    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    91191    ids79    51    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16203    m-rv    2    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    38576    avalakh    25    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    25660    json    15    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    65434    ids79    12    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20579    m-rv    17    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    37335    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    26922    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19956    SeiOkami    50    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    31305    m-rv    21    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    51086    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    55439    ids79    25    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    25922    dmurk    146    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28499    itriot11    34    

Подсистема "Варианты отчетов". Используете ли Вы ее правильно?

Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    43362    YPermitin    52    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    45297    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    36216    ellavs    126    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77144    Serginio    110    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27848    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    32340    YPermitin    53    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    22850    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    35693    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    41994    ids79    9    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29590    grumagargler    28    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    27675    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    42839    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    38213    ids79    42    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    53542    m-rv    61    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    50812    Unk92    25