Правила переноса документа "Сторно" в Бухгалтерию 3.0 из любой конфигурации, где он есть

13.05.22

Интеграция - Перенос данных 1C

В данной статье представлен код обработчика "ПослеЗагрузки" документа бухгалтерии "Сторно".

Может, кому-нибудь будет полезно.

Как известно, в типовых правилах конвертации документ "Сторно" не представлен. 

В Бухгалтерии 3.0 сторнирование производится с помощью документа "ОперацияБух".

Если создавать этот документ руками, то он полностью заполняется проводками сторнируемого документа с противоположным знаком.

При создании правил обмена, важно правильно заполнить реквизит "СторнируемыйДокумент" и создать для этого типа ПКО.

Для этого реквизита обязательно указать в ПКС "ПередВыгрузкой": 

ВыгрузитьТолькоСсылку = Истина;

В ПКС "СпособЗаполнения" пишем: 

Значение = "Сторно";

Ну и наконец в обработчике "ПослеЗагрузки" пишем следующий код:

СуммаДокумента = 0;
//Если объект найден, очищаем движения
Если ОбъектНайден Тогда
	Для Каждого Движение ИЗ Объект.Движения Цикл
	    Если Движение.Количество() > 0 Тогда
	        Точка = Найти(Строка(Движение), ".");
	        ВидРегистра = Лев(Строка(Движение), Точка - 13);
	        РегистрИмя = СокрП(Сред(Строка(Движение), Точка + 1));

	        Если ВидРегистра = "РегистрНакопления" Тогда
	            НаборЗаписей = РегистрыНакопления[РегистрИмя].СоздатьНаборЗаписей();            
	        ИначеЕсли ВидРегистра = "РегистрБухгалтерии" Тогда
	            НаборЗаписей = РегистрыБухгалтерии[РегистрИмя].СоздатьНаборЗаписей();    
	        ИначеЕсли ВидРегистра = "РегистрСведений" Тогда
	            НаборЗаписей = РегистрыСведений[РегистрИмя].СоздатьНаборЗаписей();    
	        ИначеЕсли ВидРегистра = "РегистрРасчета" Тогда
	            НаборЗаписей = РегистрыРасчета[РегистрИмя].СоздатьНаборЗаписей();    
	        КонецЕсли;
	        НаборЗаписей.Отбор.Регистратор.Установить(Объект.Ссылка);
			Попытка
	        	НаборЗаписей.Записать();
	    	Исключение
	    	КонецПопытки;
		//Иначе
		//    НаборЗаписей = Движение;
	    КонецЕсли;
		
		//Попытка
		//	НаборЗаписей.Записать();
		//Исключение
		//КонецПопытки;
	    
	КонецЦикла;
КонецЕсли;
//Объект необходимо записать, чтобы была на него ссылка
Объект.Записать(РежимЗаписиДокумента.Запись);

//Копируем движения сторнируемого документа со знаком минус
ДокОбъект = Объект.СторнируемыйДокумент.ПолучитьОбъект();
Для Каждого Движение ИЗ ДокОбъект.Движения Цикл
    Точка = Найти(Строка(Движение), ".");
    ВидРегистра = Лев(Строка(Движение), Точка - 13);
    РегистрИмя = СокрП(Сред(Строка(Движение), Точка + 1));

    Если ВидРегистра = "РегистрНакопления" Тогда
        НаборЗаписей = РегистрыНакопления[РегистрИмя].СоздатьНаборЗаписей();            
		НовыйНаборЗаписей = РегистрыНакопления[РегистрИмя].СоздатьНаборЗаписей();            
    ИначеЕсли ВидРегистра = "РегистрБухгалтерии" Тогда
        НаборЗаписей = РегистрыБухгалтерии[РегистрИмя].СоздатьНаборЗаписей();    
		НовыйНаборЗаписей = РегистрыБухгалтерии[РегистрИмя].СоздатьНаборЗаписей();    
    ИначеЕсли ВидРегистра = "РегистрСведений" Тогда
		//Регистры сведений не сторнируются
		Продолжить;
    ИначеЕсли ВидРегистра = "РегистрРасчета" Тогда
        НаборЗаписей = РегистрыРасчета[РегистрИмя].СоздатьНаборЗаписей();
		НовыйНаборЗаписей = РегистрыРасчета[РегистрИмя].СоздатьНаборЗаписей();
	КонецЕсли;
	МетаданныеРегистра = НаборЗаписей.Метаданные();
			
    НаборЗаписей.Отбор.Регистратор.Установить(Объект.СторнируемыйДокумент);            
	НаборЗаписей.Прочитать();
	Если НаборЗаписей.Количество() > 0 Тогда
		НовыйНаборЗаписей.Отбор.Регистратор.Установить(Объект.Ссылка);
		Для Каждого ЗаписьРегистра Из НаборЗаписей Цикл
			НоваяЗапись = НовыйНаборЗаписей.Добавить();
			ЗаполнитьЗначенияСвойств(НоваяЗапись,ЗаписьРегистра);
			НоваяЗапись.Период = Объект.Дата;
			Если ВидРегистра = "РегистрБухгалтерии" Тогда
				Для Каждого Субконто Из ЗаписьРегистра.СчетДт.ВидыСубконто Цикл
					БухгалтерскийУчет.УстановитьСубконто(НоваяЗапись.СчетДт, НоваяЗапись.СубконтоДт, Субконто.ВидСубконто.ИмяПредопределенныхДанных, ЗаписьРегистра.СубконтоДт[Субконто.ВидСубконто]);
				КонецЦикла;
				Для Каждого Субконто Из ЗаписьРегистра.СчетКт.ВидыСубконто Цикл
					БухгалтерскийУчет.УстановитьСубконто(НоваяЗапись.СчетКт, НоваяЗапись.СубконтоКт, Субконто.ВидСубконто.ИмяПредопределенныхДанных, ЗаписьРегистра.СубконтоКт[Субконто.ВидСубконто]);
				КонецЦикла;
				СуммаДокумента = СуммаДокумента + ЗаписьРегистра.Сумма;
				//Ресурс количество, но по Дт и по Кт может быть разное
				Если ЗаписьРегистра.СчетКт.Количественный Тогда
					НоваяЗапись.КоличествоКт = -ЗаписьРегистра.КоличествоКт;
				КонецЕсли;	
				Если ЗаписьРегистра.СчетДт.Количественный Тогда
					НоваяЗапись.КоличествоДт = -ЗаписьРегистра.КоличествоДт;
				КонецЕсли;	
			КонецЕсли;	
			
			Для Каждого Ресурс из МетаданныеРегистра.Ресурсы Цикл
				Попытка
					//У всех ресурсов с типом "Число", кроме цены меняем знак на противоположный
					Если ТипЗнч(ЗаписьРегистра[Ресурс.Имя]) = Тип("Число") Тогда
						//У Цены знак не меняем
						Если СтрНайти(Нрег(Ресурс.Имя),"цена") = 0 Тогда
							НоваяЗапись[Ресурс.Имя] = -ЗаписьРегистра[Ресурс.Имя];
						КонецЕсли;	
					КонецЕсли;	
				Исключение
				КонецПопытки;	
			КонецЦикла;	
			
		КонецЦикла;
		
		Попытка
	        НовыйНаборЗаписей.Записать();
	    Исключение
	        Сообщить(ОписаниеОшибки());
	    КонецПопытки;	
	КонецЕсли;		
			
    
КонецЦикла;
Объект.СуммаОперации = -СуммаДокумента;

В общем, правило можно сделать для конвертации из любой конфигурации, хоть из 7.7. 

Главное правильно сконвертировать сторнируемый документ, а дальше после загрузки заполнятся все движения Сторно.

Конвертация данных Документ Сторно

См. также

SALE! 15%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    137310    748    292    

399

Перенос данных из УПП 1.3 в ERP 2 / УТ 11 / КА 2. Переносятся документы, справочная информация и остатки

Перенос данных 1C Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос документов, начальных остатков и справочной информации из УПП 1.3 в ERP 2 | из УПП 1.3 в УТ 11 | из УПП в КА 2 | Правила конвертации (КД 2) в продаже с 2015 года, постоянно работаем над их развитием | Более 360 предприятий выполнили переход с использованием этого продукта! | Сэкономьте время - используйте готовое решение для перехода! | Позволяет перенести из УПП 1.3 в ERP / УТ 11 / КА 2 всю возможную информацию | В переносе есть фильтр по организации и множество других опциональных параметров выгрузки | Есть несколько алгоритмов выгрузки остатков на выбор

45650 руб.

04.08.2015    161874    365    272    

357

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69756    172    143    

113

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    47890    207    64    

169

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184014    570    509    

514

Перенос данных из БП 3.0 в УТ 11 / КА 2 / ERP 2. Переносятся начальные остатки, документы и справочники

Перенос данных 1C Системный администратор Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

В продаже с 2014г. | Воспользовались более 122 предприятий! | Перенос данных из БП 3.0 в УТ 11 | из БП 3.0 в КА 2 | из БП 3.0 в ERP | Сэкономьте свое время - используйте готовое решение для перехода! | Постоянно работаем над развитием переноса данных | Обновляем на новые релизы 1С | Есть фильтр выгрузки по организациям | Переносятся начальные остатки на выбранную дату, документы за период времени и вся возможная справочная информация | Перенос сделан на технологии КД 2 (правила конвертации данных)

45650 руб.

31.10.2014    233536    91    329    

299

Переход и перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    61956    47    27    

78

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34983    84    59    

82
Оставьте свое сообщение