Создание обработки для выгрузки в Excel, PDF, Docx, TXT (управляемые формы)

18.07.22

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

В помощь начинающим программистам. Создание простой обработки для выгрузки табличного документа в файлы различных форматов, на примере справочника Контрагенты (релиз платформы 1С:Предприятие 8.3 (8.3.20.1674), самописная конфигурация).

Создадим обработку ВыгрузкаВФайл. Добавим реквизиты КаталогСохраненния (строка Неограниченная длина), ТипФайла (строка 50).

 

 

Создадим форму обработки (контекстное меню "Форма" нашей обработки  -- Добавить -- Готово).

Перенесем на нее ТипФайла (синоним Формат файла). В свойствах элемента ТипФайла на закладке Использование откроем СписокВыбора и добавим значения XLS, PDF, DOCX, TXT.

 

 

Далее на вкладке "Основное" свойство Вид выберем "Вид переключателя". А свойство ВидПереключателя - Тумблер.

 

 

Создадим команду формы "Выгрузить". Разместим на форме и создадим обработчик &НаКлиенте

 

 

В процедуре размещаем следующий код:

	&НаКлиенте
	Процедура КнопкаВыгрузить(Команда)
		
	Режим = РежимДиалогаВыбораФайла.ВыборКаталога; 
	ДиалогОткрытия = Новый ДиалогВыбораФайла(Режим); 
	ДиалогОткрытия.Каталог = ""; 
	ДиалогОткрытия.МножественныйВыбор = Ложь; 
	ДиалогОткрытия.Заголовок = "Выберите файл с контрагентами"; 

	Если ДиалогОткрытия.Выбрать() Тогда 
		ПутьККаталогу = ДиалогОткрытия.Каталог; 
	КонецЕсли;   
	
	Если Прав(ПутьККаталогу,1) <> "\" Тогда
		Объект.КаталогСохранения = ПутьККаталогу+"\";
	Иначе
		Объект.КаталогСохранения = ПутьККаталогу; 
		
	КонецЕсли;
	
	
	//Сформируем уникальное имя файла 
	ДатаИВремя = СтрЗаменить(ТекущаяДата(),":",".");
	ИмяФайла = "Импорт_" + ДатаИВремя;  
	
	//Создадим табличный документ
	ТабДок = Новый ТабличныйДокумент;
	
	ФорматФайла =  Объект.ТипФайла;
	
	//Добавим выбранный каталог к именя файла 
	ПолноеИмяФайла = Объект.КаталогСохранения + ИмяФайла + "." + ФорматФайла;
	
		// Определим в каком формате будет выгружен документ
	Если   ФорматФайла = "XLS" Тогда
		ЗадатьТип =  ТипФайлаТабличногоДокумента.xls; 
		
	ИначеЕсли 	ФорматФайла = "DOCX" Тогда   
		ЗадатьТип = ТипФайлаТабличногоДокумента.docx;
		
	ИначеЕсли ФорматФайла = "PDF" Тогда   
		ЗадатьТип = ТипФайлаТабличногоДокумента.pdf; 
		
	ИначеЕсли  ФорматФайла = "TXT" Тогда  
		ЗадатьТип = ТипФайлаТабличногоДокумента.txt;
		
	Иначе 
		Сообщить("Необходимо выбрать формат файла"); 
		Возврат;
	КонецЕсли;   
	
	 //Создадим файл и запишем в табличный документ
		ТабДок.Записать(ПолноеИмяФайла, ЗадатьТип); 
		
		//Заполним ТабДок на сервере
		ЗаполнитьТаблицуНаСервере(ТабДок);
		
		//Запишем заполненную таблицу в тот же файл
		ТабДок.Записать(ПолноеИмяФайла, ЗадатьТип);    		

	Сообщить("Выгрузка данных успешно завершена!");
 КонецПроцедуры

 

Создаем Макет у нашей обработки. У меня он максимально прост, всего два параметра: Наименование и Город; одна область - Строка.

 

 

Создаем в модуле формы следующую функцию.


Функция ЗаполнитьТаблицуНаСервере(ТабДок) Экспорт
	Макет = Обработки.ВыгрузкаВФайл.ПолучитьМакет("Макет");
	ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
	
		
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Контрагенты.Наименование,
		|	Контрагенты.Город
		|ИЗ
		|	Справочник.Контрагенты КАК Контрагенты
		|ГДЕ
		|	Контрагенты.ЭтоГруппа = Ложь";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ОбластьСтрока.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
		ТабДок.Вывести(ОбластьСтрока);
	КонецЦикла;
	
	Возврат(ТабДок);
	
КонецФункции

Как видите, нажатие на кнопку "Выгрузить" сначала открывает окно выбора каталога для выгрузки. Затем формируется Табличный документ, ему присваивается уникальное имя.

 

В процедуре вызывается функция ЗаполнитьТаблицуНаСервере(ТабДок), в которую передается наш табличный документ.

В функции в запросе отбираются необходимые поля и заполняются строки таблицы. ТабДок возвращается в процедуру и записывается документ в выбранном формате.

Обработка готова. Пробуйте :)

 

Вы можете отредактировать запрос, доработать макет и заполнение табДока под Ваши нужды.

Успешной работы!

обработка выгрузка в файл табличный документ XLS PDF DOCX TXT

См. также

[ED3] Обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    135396    725    291    

388

SALE! 10%

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

38500 34650 руб.

15.04.2019    68720    179    139    

111

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 руб.

23.07.2020    46634    199    64    

162

Загрузка номенклатуры из Excel в УТ11, КА 2, ERP 2, Розница 2. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка из файлов xls, xlsx, ods, csv, mxl в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    210816    627    525    

443

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.223.x) и БП 3.0 (3.0.149.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    20486    134    38    

92

SALE! 10%

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

48278 43450 руб.

03.12.2020    34344    81    58    

78

SALE! 10%

Перенос данных из БП 3.0 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочная информация

Обмен между базами 1C Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Оказываем техподдержку | В комплект файлов входит инструкция, авторская версия обработки "Универсальный обмен...", актуальные правила переноса данных и архив старых версий переноса | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

50722 45650 руб.

10.07.2018    67652    41    122    

46