Создание обработки для выгрузки в Excel, PDF, Docx, TXT (управляемые формы)

18.07.22

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

В помощь начинающим программистам. Создание простой обработки для выгрузки табличного документа в файлы различных форматов, на примере справочника Контрагенты (релиз платформы 1С:Предприятие 8.3 (8.3.20.1674), самописная конфигурация).

Создадим обработку ВыгрузкаВФайл. Добавим реквизиты КаталогСохраненния (строка Неограниченная длина), ТипФайла (строка 50).

 

 

Создадим форму обработки (контекстное меню "Форма" нашей обработки  -- Добавить -- Готово).

Перенесем на нее ТипФайла (синоним Формат файла). В свойствах элемента ТипФайла на закладке Использование откроем СписокВыбора и добавим значения XLS, PDF, DOCX, TXT.

 

 

Далее на вкладке "Основное" свойство Вид выберем "Вид переключателя". А свойство ВидПереключателя - Тумблер.

 

 

Создадим команду формы "Выгрузить". Разместим на форме и создадим обработчик &НаКлиенте

 

 

В процедуре размещаем следующий код:

	&НаКлиенте
	Процедура КнопкаВыгрузить(Команда)
		
	Режим = РежимДиалогаВыбораФайла.ВыборКаталога; 
	ДиалогОткрытия = Новый ДиалогВыбораФайла(Режим); 
	ДиалогОткрытия.Каталог = ""; 
	ДиалогОткрытия.МножественныйВыбор = Ложь; 
	ДиалогОткрытия.Заголовок = "Выберите файл с контрагентами"; 

	Если ДиалогОткрытия.Выбрать() Тогда 
		ПутьККаталогу = ДиалогОткрытия.Каталог; 
	КонецЕсли;   
	
	Если Прав(ПутьККаталогу,1) <> "\" Тогда
		Объект.КаталогСохранения = ПутьККаталогу+"\";
	Иначе
		Объект.КаталогСохранения = ПутьККаталогу; 
		
	КонецЕсли;
	
	
	//Сформируем уникальное имя файла 
	ДатаИВремя = СтрЗаменить(ТекущаяДата(),":",".");
	ИмяФайла = "Импорт_" + ДатаИВремя;  
	
	//Создадим табличный документ
	ТабДок = Новый ТабличныйДокумент;
	
	ФорматФайла =  Объект.ТипФайла;
	
	//Добавим выбранный каталог к именя файла 
	ПолноеИмяФайла = Объект.КаталогСохранения + ИмяФайла + "." + ФорматФайла;
	
		// Определим в каком формате будет выгружен документ
	Если   ФорматФайла = "XLS" Тогда
		ЗадатьТип =  ТипФайлаТабличногоДокумента.xls; 
		
	ИначеЕсли 	ФорматФайла = "DOCX" Тогда   
		ЗадатьТип = ТипФайлаТабличногоДокумента.docx;
		
	ИначеЕсли ФорматФайла = "PDF" Тогда   
		ЗадатьТип = ТипФайлаТабличногоДокумента.pdf; 
		
	ИначеЕсли  ФорматФайла = "TXT" Тогда  
		ЗадатьТип = ТипФайлаТабличногоДокумента.txt;
		
	Иначе 
		Сообщить("Необходимо выбрать формат файла"); 
		Возврат;
	КонецЕсли;   
	
	 //Создадим файл и запишем в табличный документ
		ТабДок.Записать(ПолноеИмяФайла, ЗадатьТип); 
		
		//Заполним ТабДок на сервере
		ЗаполнитьТаблицуНаСервере(ТабДок);
		
		//Запишем заполненную таблицу в тот же файл
		ТабДок.Записать(ПолноеИмяФайла, ЗадатьТип);    		

	Сообщить("Выгрузка данных успешно завершена!");
 КонецПроцедуры

 

Создаем Макет у нашей обработки. У меня он максимально прост, всего два параметра: Наименование и Город; одна область - Строка.

 

 

Создаем в модуле формы следующую функцию.


Функция ЗаполнитьТаблицуНаСервере(ТабДок) Экспорт
	Макет = Обработки.ВыгрузкаВФайл.ПолучитьМакет("Макет");
	ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
	
		
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Контрагенты.Наименование,
		|	Контрагенты.Город
		|ИЗ
		|	Справочник.Контрагенты КАК Контрагенты
		|ГДЕ
		|	Контрагенты.ЭтоГруппа = Ложь";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ОбластьСтрока.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
		ТабДок.Вывести(ОбластьСтрока);
	КонецЦикла;
	
	Возврат(ТабДок);
	
КонецФункции

Как видите, нажатие на кнопку "Выгрузить" сначала открывает окно выбора каталога для выгрузки. Затем формируется Табличный документ, ему присваивается уникальное имя.

 

В процедуре вызывается функция ЗаполнитьТаблицуНаСервере(ТабДок), в которую передается наш табличный документ.

В функции в запросе отбираются необходимые поля и заполняются строки таблицы. ТабДок возвращается в процедуру и записывается документ в выбранном формате.

Обработка готова. Пробуйте :)

 

Вы можете отредактировать запрос, доработать макет и заполнение табДока под Ваши нужды.

Успешной работы!

Загрузка документов и номенклатуры из Excel в 1С УТ, БП, УНФ, УПП, ERP, УХ, Розница

С помощью данной обработки вы сможете загружать любые товарные документы буквально в один клик! 

Для загрузки необходимо просто выбрать файлы Excel и нажать кнопку "Загрузить". Простейший интерфейс и мощный механизм поиска номенклатуры.

Обработка сама находит таблицу в файле Excel, необходимые для загрузки данные в ней (номенклатура, количество, НДС, цена, сумма) и загружает ее в 1С. 

Распознает документы любой формы (УПД, ТОРГ-12, заказ, отчет комиссионера и т.д.)

->Ознакомиться с программой<-

обработка выгрузка в файл табличный документ XLS PDF DOCX TXT

См. также

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    137507    752    292    

400

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    48033    209    64    

170

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69865    172    143    

113

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184201    570    509    

515

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21484    139    40    

98

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    35048    85    59    

82

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    62050    48    27    

79