Функция создания вложенных каталогов + ф-ции извлечения имен файлов для 1с 7.7

Публикация № 17051

Разработка - Практика программирования

Расширим возможности ФС.
Вы когда-нибудь пытались создать вложенные папки из 1с?
Как ни странно, стандартной функции для этой операции нет.

ФС.СоздатьКаталог() позволяет создать папку лишь на один уровень вглубь, а порой хочется глубже,
и чтобы функция нормально относилась к уже существующим папкам, не пыталась создавать их повторно.

Так появилась функция глСоздатьКаталог().

А вот пример использования - создание файла приказа на основании шаблона.
На форме расположен объект "СписокЗначений" с именем "спШаблоны".

1. Заполним список шаблонов
// ...
спШаблоны.УдалитьВсе();
ПутьКПапкеШаблонов = КаталогИБ()+"Приказы\\Шаблоны";
Если глСоздатьКаталог(ПутьКПапкеШаблонов) = 1 Тогда
	ФС.УстТекКаталог(ПутьКПапкеШаблонов);
	ИмяШаблона = ФС.НайтиПервыйФайл("*.doc");
	Пока ИмяШаблона <> "" Цикл
		Если Лев(ИмяШаблона, 1) <> "~" Тогда
			спШаблоны.ДобавитьЗначение(ИмяШаблона);
		КонецЕсли;	
		ИмяШаблона = ФС.НайтиСледующийФайл();
	КонецЦикла;	
КонецЕсли;	
// ...

2. Создаем подпапку по имени файла шаблона, и копируем туда файл на основании шаблона.
 //..
ИмяШаблонаКратко = спШаблоны.ПолучитьЗначение(спШаблоны.ТекущаяСтрока());
ИмяШаблонаКраткоБезРасширения = глИзвлечьИмяФайлаБезРасширения(ИмяШаблонаКратко);
ПутьКПапкеГотовых = КаталогИБ() + "Приказы\" + ИмяШаблонаКраткоБезРасширения + "\";
Если глСоздатьКаталог(ПутьКПапкеГотовых) = 0 Тогда
	Возврат;
КонецЕсли;	
		
ИмяШаблона = КаталогИБ()+"Приказы\\Шаблоны\"+ИмяШаблонаКратко;
ИмяФайла = ПутьКПапкеГотовых + ИмяШаблонаКраткоБезРасширения + " "
	+Формат(ТекущаяДата(), "ДГГГГММДД")+" "+СтрЗаменить(ТекущееВремя(), ":", "")+".doc";

Если ФС.СуществуетФайл(ИмяШаблона) = 0 Тогда
	Предупреждение("Шаблон "+ИмяШаблона+" не найден!");
	Возврат;
КонецЕсли;	

ФС.КопироватьФайл(ИмяШаблона, ИмяФайла, 1);
//..

Текст функций:
//-----------------------------------------------------
Функция глСоздатьКаталог(Знач Путь) Экспорт
	
	Пока Прав(Путь, 1) = "\" Цикл
		Путь = Сред(Путь, 1, СтрДлина(Путь) - 1);
	КонецЦикла;	
	
	// Проверим, возможно каталог существует
	Атрибуты = "";
	ФС.АтрибутыФайла(Путь, , Атрибуты);
	Если Сред(Атрибуты, 4, 1) = "1" Тогда
		Возврат 1;
	КонецЕсли;	
	
	спКСозданию = СоздатьОбъект("СписокЗначений");
	
	текПуть = Путь;
	врДлина = СтрДлина(Путь);
	Для к = -врДлина по -1 Цикл
		Если Сред(Путь, -к, 1) = "\" Тогда
			спКСозданию.ДобавитьЗначение(текПуть);
			текПуть = Лев(Путь, -к-1);
			
			// Проверяем наличие текущего уровня
			Атрибуты = "";
			ФС.АтрибутыФайла(текПуть, , Атрибуты);
			фЕстьТекПуть = ?(Сред(Атрибуты, 4, 1) = "1", 1, 0);
			
			Если фЕстьТекПуть = 0 Тогда
				Продолжить;
			КонецЕсли;	
			
			// Пытаемся создать с текущего уровня
			Для н = -спКСозданию.РазмерСписка() по -1 Цикл
				врПутьХ = спКСозданию.ПолучитьЗначение(-н);
				ФС.СоздатьКаталог(врПутьХ);
				Если н = - 1 Тогда
					Атрибуты = "";
					ФС.АтрибутыФайла(врПутьХ, , Атрибуты);
					Если Сред(Атрибуты, 4, 1) = "1" Тогда
						// Удачное создание с текущего уровня
						Возврат 1;
					КонецЕсли;	
				КонецЕсли;	
			КонецЦикла;	
		КонецЕсли;	
	КонецЦикла;	
	
	Предупреждение("Невозможно создать путь: "+РазделительСтрок+Путь, 4);
	Возврат 0;
	
КонецФункции

//-----------------------------------------------------
Функция глИзвлечьИмяФайла(ПолноеИмяФайла) Экспорт

	Файл = "";
	врДлина = СтрДлина(ПолноеИмяФайла);
	Для к = -врДлина по -1 Цикл
		Если Сред(ПолноеИмяФайла, -к, 1) = "\" Тогда
			Файл = Прав(ПолноеИмяФайла, врДлина+к);
			Прервать;
		КонецЕсли;	
	КонецЦикла;	
	
	Возврат(Файл);
КонецФункции

//-----------------------------------------------------
Функция глИзвлечьИмяФайлаБезРасширения(КраткоеИмяФайла) Экспорт

	Файл = "";
	врДлина = СтрДлина(КраткоеИмяФайла);
	Для к = -врДлина по -1 Цикл
		Если Сред(КраткоеИмяФайла, -к, 1) = "." Тогда
			Файл = Лев(КраткоеИмяФайла, -к-1);
			Прервать;
		КонецЕсли;	
	КонецЦикла;	
	
	Возврат(Файл);
КонецФункции


Все таки 1с это сила, даже если чего-то не хватает, всегда можно дописать.

Исправление.
Добавлена проверка на запрещенные символы и наличие в указанном пути файлов.
//-----------------------------------------------------
Функция глСоздатьКаталог(Знач Путь) Экспорт
	
	Пока Прав(Путь, 1) = "\" Цикл
		Путь = Сред(Путь, 1, СтрДлина(Путь) - 1);
	КонецЦикла;	
	
	Если СокрЛП(Путь) = "" Тогда
		Предупреждение("Невозможно создать пустой путь", 4);
		Возврат 0;
	КонецЕсли;	
	
	// Проверим, возможно каталог существует
	Если ФС.СуществуетФайл(Путь) = 1 Тогда
		Атрибуты = "";
		ФС.АтрибутыФайла(Путь, , Атрибуты);
		Если Сред(Атрибуты, 4, 1) = "1" Тогда
			Возврат 1;
		Иначе
			Предупреждение("Невозможно создать путь: "+РазделительСтрок+Путь
			+РазделительСтрок+"Так как существует одноименный файл.", 4);
			Возврат 0;
		КонецЕсли;
	КонецЕсли;	

	спКСозданию = СоздатьОбъект("СписокЗначений");
	
	врДлина = СтрДлина(Путь);
	// Проверка на запрещенные символы
	ЕстьБукваДиска = ?(Найти("abcdefghijklmnopqrstuvwxyz", Нрег(Лев(Путь, 1))) > 0, 1, 0);
	ЗапрещенныеСимволы = "/?|*<>:"""+РазделительСтрок+СимволТабуляции;
	Для к = 1 по врДлина Цикл
		Символ = Сред(Путь, к, 1);
		Если (Найти(ЗапрещенныеСимволы, Символ) > 0) или (КодСимв(Символ) < 32) Тогда
			Если не ((к = 2) и (Символ = ":") и (ЕстьБукваДиска = 1)) Тогда
				Предупреждение("Невозможно создать путь: "+РазделительСтрок+Путь
				+РазделительСтрок+"Так как использованы запрещенные символы.", 4);
				Возврат 0;
			КонецЕсли;
		КонецЕсли;	
	КонецЦикла;	
	// Основной цикл
	текПуть = Путь;
	Для к = -врДлина по -1 Цикл
		Если Сред(Путь, -к, 1) = "\" Тогда
			спКСозданию.ДобавитьЗначение(текПуть);
			текПуть = Лев(Путь, -к-1);
			
			// Проверяем наличие текущего уровня
			Если ФС.СуществуетФайл(текПуть) = 1 Тогда
				Атрибуты = "";
				ФС.АтрибутыФайла(текПуть, , Атрибуты);
				Если Сред(Атрибуты, 4, 1) = "0" Тогда
					Предупреждение("Невозможно создать путь: "+РазделительСтрок+Путь
					+РазделительСтрок+"Так как существует файл:"+РазделительСтрок+текПуть, 4);
					Возврат 0;
				КонецЕсли;
			Иначе
				Продолжить;
			КонецЕсли;	
			
			// Пытаемся создать с текущего уровня
			Для н = -спКСозданию.РазмерСписка() по -1 Цикл
				врПутьХ = спКСозданию.ПолучитьЗначение(-н);
				ФС.СоздатьКаталог(врПутьХ);
				Если н = - 1 Тогда
					Атрибуты = "";
					ФС.АтрибутыФайла(врПутьХ, , Атрибуты);
					Если Сред(Атрибуты, 4, 1) = "1" Тогда
						// Удачное создание с текущего уровня
						Возврат 1;
					Иначе
						Предупреждение("Невозможно создать путь: "+РазделительСтрок+Путь, 4);
						Возврат 0;
					КонецЕсли;	
				КонецЕсли;	
			КонецЦикла;	
		КонецЕсли;	
	КонецЦикла;	

	Предупреждение("Невозможно создать путь: "+РазделительСтрок+Путь, 4);
	Возврат 0;
	
КонецФункции
Функция очистки каталога от файлов. (Не подходит для вложенных каталогов.)
//-----------------------------------------------------
Процедура глОчиститьКаталог(Путь) Экспорт
	Попытка
		ФС.УстТекКаталог(Путь);
		ИмяФайла = ФС.НайтиПервыйФайл("*.*");
		Пока (ИмяФайла <> "") Цикл
			Если (ИмяФайла <> ".")
			и (ИмяФайла <> "..") Тогда
				ФС.УдалитьФайл(ИмяФайла);
			КонецЕсли;	
			ИмяФайла = ФС.НайтиСледующийФайл();
		КонецЦикла;	
	Исключение
	КонецПопытки;	
КонецПроцедуры

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. CheBurator 13.11.07 00:16 Сейчас в теме
хм.. как-то создание вложенных файлов красивше решается.. рекурсией...
а вариант
// Проверим, возможно каталог существует
Атрибуты = "";
ФС.АтрибутыФайла(Путь, , Атрибуты);
Если Сред(Атрибуты, 4, 1) = "1" Тогда
Возврат 1;
КонецЕсли;
..понравился
2. CheBurator 13.11.07 00:18 Сейчас в теме
ага, все-таки я ее чуток подломал... ;-)
глСоздатьКаталог("c:\Еуые1\еуые2") при условии что еуые2 - существующий файл в папке Еуые1
tarasenkov; +1 Ответить
3. CheBurator 13.11.07 00:28 Сейчас в теме
аналогично
глСоздатьКаталог("c:\Еуые1\eee*we")
+ еще Добился вывода сообщения "Невозможно создать путь:" - какой именно - не указано ;-)
tarasenkov; +1 Ответить
4. tarasenkov 13.11.07 07:42 Сейчас в теме
Вам бы только ломать :-)
Добавлена защита от взлома :-)
+ Спасибо за конструктивные замечания
5. CheBurator 13.11.07 12:12 Сейчас в теме
Ну, вообще-то представляется более праивльным искать запрещенные символы в именах каталогов, а не наоборот.. потому как правило, вложенный путь каталогво больше 10 запрещенных символов... ;-) Это я так, побрюзжать...
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77206    Serginio    110    

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Бухгалтерский учет Практика программирования Зарплата v7.7 1cv7.md Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    10168    Юджин58    39    

Маркировка лекарств - как передать код маркировки при продаже через ККТ Штрих-М

Практика программирования ККМ v7.7 Здравоохранение, медицина, стоматология Фармацевтика, аптеки Россия Бесплатно (free)

Пример программного кода для вывода чеков на ККМ Штрих-М с передачей информации о маркированных товарах (лекарства).

10.02.2020    8786    vovaapril    27    

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки.

Практика программирования Адаптация типовых решений v7.7 1С7:Комплекс 1С7:ТиС УУ Бесплатно (free)

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    4671    ksnik    14    

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция Промо

Практика программирования WEB v7.7 v8 Бесплатно (free)

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    56145    Serginio    33    

Заполнение реквизитов документов из предыдущего документа

Практика программирования Универсальные функции Разработка v7.7 1cv7.md Бесплатно (free)

Функция для автоматического заполнения реквизитов документов.

04.02.2019    5187    drevilo    1    

Проверка часового пояса

Практика программирования v7.7 Бесплатно (free)

При использовании терминалок для удаленных баз, иногда при входе в базу данных необходимо исключить возможность входа пользователей с компьютеров с другим часовым поясом. Например, работают в Новосибирской базе с временем UTC +6 и пытаются зайти в базу с UTC +3.

16.05.2016    11082    kudenzov    3    

[ПОЛЕЗНЯШКА, 7.7] Как посчитать итоги по документам черным запросом с изподвывертом?

Практика программирования v7.7 1cv7.md Бесплатно (free)

Мелкая полезняшка, считает запросом итоговую сумму документов и количество документов.

12.03.2016    19202    CheBurator    18    

1С:Предприятие 7.7. Оптимизация. Промо

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Разгоняем 1С:Предприятие 7.7. Выжимаем последние соки.

31.01.2009    47074    alexk-is    110    

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д.

Разработка внешних компонент Практика программирования WEB v7.7 v8 Бесплатно (free)

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    31956    Serginio    22    

Пример HTTP запроса к УТМ ЕГАИС на платформе 1С 7.7

Внешние источники данных Практика программирования Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v7.7 1cv7.md Россия Бесплатно (free)

Запрос реализован на объекте ServerXMLHTTP из встроенной в Windows библиотеки MSXML, результатом запроса является XML объект DOMDocument из той же библиотеки MSXML со встроенным интерфейсом его обработки

16.12.2015    25506    Palmer1976    3    

Экспорт нескольких MXL таблиц в один XLS файл, на отдельные листы. Простой алгоритм

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 Бесплатно (free)

Статья посвящена распространённому вопросу - как сохранить несколько таблиц (отчетов) в формате MXL, с которым работает 1С, на отдельные листы одного Excel файла. Освещается простой алгоритм решения проблемы штатными средствами, без использования внешних модулей и библиотек (не относящихся к 1С и Excel).

23.11.2015    17493    etmarket    14    

Как уменьшить количество заблокированных объектов Промо

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    15612    ShEvOvIcH    18    

Процедура расшифровки ячейки таблицы в отчетах 1С 7.7

Практика программирования Универсальные функции v7.7 1cv7.md Бесплатно (free)

Хочу поделиться с вами универсальной процедурой для расшифровки ячеек печатной формы отчетов в 1С 7.7.

24.09.2015    17805    Anzhey    14    

Универсальный способ сравнения таблиц

Практика программирования v7.7 v8 Бесплатно (free)

На эту тему уже есть статьи, но этот способ нигде не описан. Хотя я его использую с тех пор, как занимаюсь программированием. Его преимущество в простоте и универсальности: можно применять на 1С, SQL, а также в любом другом языке программирования.

05.07.2015    19213    json    1    

Числа прописью в родительном падеже в 7.7? Легко!

Практика программирования v7.7 1cv7.md Бесплатно (free)

Вывод числительных прописью в родительном падеже штатными средствами в три строчки кода.

20.06.2015    12819    gimalaj    3    

Технология обновления нетиповых конфигураций 1С:Предприятия 7.7 Промо

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Данная статья рассчитана на уже подготовленного пользователя, владеющего некоторыми навыками программирования и работы в конфигураторе. Статью можно использовать как поэтапное руководство к действию. Статья была написана для повышения качества работ выполняемых сотрудниками компании Информ Сервис при обновлении нетиповых конфигураций. Я надеюсь, что эта информация окажется полезной и для вас.

12.12.2008    63013    alexk-is    25    

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним

Загрузка и выгрузка в Excel Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    91474    shmellevich    38    

Отправка сообщения посредством почтового клиента Lotus Notes

Практика программирования v7.7 v8 1cv8.cf 1cv7.md Бесплатно (free)

Отправка сообщения посредством почтового клиента Lotus Notes из 1С 7,7 и 1с 8

21.08.2014    14666    iolko    8    

Исправление в типовой комплексной конфигурации глобальной функции глВсеРеквизитыДокументаЗаполнены()

Практика программирования v7.7 1С7:Комплекс Россия Бесплатно (free)

В типовых конфигурациях глобальная функция глВсеРеквизитыДокументаЗаполнены() не работает с реквизитами табличной части. Данная статья содержит текст исправленной функции, корректно проверяющей табличную часть.

20.08.2014    8185    hvv2002    0    

ЗаполнитьЗначенияСвойств - заставляем работать в 7.7

Практика программирования v7.7 1cv7.md Бесплатно (free)

Если вы используете в работе 1С:Предприятие 8.х, то наверняка знакомы и с замечательной системной процедурой, как ЗаполнитьЗначенияСвойств(). Ее использование помогает значительно упростить написание программного кода в ряде случае, делает его (код) более наглядным и простым. Но что же делать тем, кто до сих пор использует (постоянно или иногда) 1С:Предприятие 7.7?

24.07.2014    22183    tomvlad    5    

Контекстный поиск в 7.7

Инструментарий разработчика Практика программирования v7.7 1cv7.md Бесплатно (free)

Процедура контекстного поиска в журнале документов.

18.04.2014    9532    cushe    2    

Проверка ИНН v.7.7

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Проверка ИНН v.7.7

08.03.2014    9649    kras_71    1    

Полезные функции. Склонение (должность и фамилия подписантов). Любой язык

Практика программирования v7.7 v8 Бесплатно (free)

Уехал директор в командировку, отпуск... , оставил доверенность на хозяйственные операции на другого сотрудника. Все договора и другие документы в обмороке - "подписант" теперь другой, по тексту тоже много правок... Пересмотрел много публикаций, вариантов много, не приглянулось. Сделал свой "Баян" . У меня всего-то крутится пять фигурантов ... Нет простого, наглядного и всепогодного варианта без языкового барьера. Всем процессом управляет пользователь.

03.03.2014    18029    kompas-dm    5    

Реализация Ctrl+Z в 1С 7.7 (ТиС)

Практика программирования v7.7 1С7:ТиС Бесплатно (free)

В семерке отсутствует возможность отменять последнее действие в формах документов. В данной статье будет рассмотрен пример реализации данной функции. Возможно, кому-нибудь пригодится.

15.07.2013    8081    a.o.popova    10    

Копия напечатанного документа или как спрятать документ.

Журнал регистрации Практика программирования v7.7 Бесплатно (free)

Возникла необходимость, чтобы при печати определённого документа (даже потом не сохранённого), создавалась его копия, т.е. запись всех напечатанных документов. (В результате чего возникла такая потребность, полагаюсь на вашу фантазию). В итоге получилось два варианта решения, остановился на втором.

11.04.2013    15647    Dima_    8    

Чтение строк файла CSV в список значений с помощью метода ИзСтрокиСРазделителями

Практика программирования Внешние источники данных v7.7 Бесплатно (free)

Чтение строк файла CSV в список значений с помощью метода ИзСтрокиСРазделителями

04.04.2013    19521    ivisor_fil    11    

Автосохранение документа в 1С 7.7

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

В данной статье мы рассмотрим автосохранение документа в 1С 7.7!

22.03.2013    13574    aagubarev    25    

Конвертация данных 2.1 (2.1.3.1) 1С 7.7 - 1С 8.Х передача параметра ПКО

Практика программирования Перенос данных из 1С7.7 в 1C8.X v7.7 v8 КД Бесплатно (free)

Передача параметров по умолчанию доступна только для баз 1С 8.х -1С 8.х. Показан пример, как передать параметры из 1С 7.7 - 1С 8.х

10.12.2012    25512    serg_gres    6    

Устранение проблемы при работе с полем, которое ограничено маской ввода

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Для поля, у которого установлена маска ввода, перед программной инициализацией необходимо начальное значение преобразовать к значению в соответствии с маской, иначе буду потеряны символы в местах разделителях. В данной публикации приведена функция, которая универсально выполняет данное действие.

08.08.2012    16547    www2000    4    

Динамическая фильтрация в справочнике при вводе наименования

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Позволяет в открытой форме списка, выбора или подбора справочника производить динамическую фильтрацию по набранному наименованию.

02.07.2012    16430    maxpiter    62    

Обновление базы 1с 7.7. с помощью движка 1с 8.х

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    18689    Valerich    31    

Ошибка при формировании отчета Авансы по налогу на имущество. В 1С:Предприятие 7.7. Регламентированная отчетность за I квартал 2012 года Обновление 12q1009 от 18.04.2012 г.

Практика программирования v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free)

При формировании отчета NIMAVP1.ERT Авансы по налогу на имущество (версия 5.03) в разделе № 1-3 не сохраняет номера Страниц при выборе, что ведет к не сохранению и выводу печати двухмерного кода.

24.04.2012    9386    leo072    7    

Запуск внешней обработки по расписанию v7.7

Практика программирования Администрирование данных 1С v7.7 1cv7.md Россия Бесплатно (free)

Неоднократно возникали задачи организовать, например ежедневную выгрузку и отправку отчетов по эл.почте, и вот…

20.03.2012    44440    Yury1001    17    

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая

Практика программирования v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free)

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    6893    filh    19    

Регистрация текста окна сообщений

Практика программирования v7.7 1cv7.md Россия Бесплатно (free)

Для контроля работы пользователей потребовалось записывать текст окна сообщений в файл. Получился простейший механизм регистрации лог-файла. Удержать роста папки "Temp", в качестве рекомендации, может использование bat-файла, который будет чистить или архивировать получаемые логи. Таких батников в инете полным-полно. P.S. Особо по форуму не смотрел, может, есть уже такое.

28.11.2011    7932    sdin101    9    

Прямые запросы: ускорение получения цен для типовой ТиС 7.7

Практика программирования Разработка внешних компонент v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free)

Первая статья из цикла статей "Прямые запросы:...". Рассказывается о применении класса ПрямойЗапрос и компоненты 1С++ для ускорения функции глВернутьЦену() в типовой конфигурации Торговля и склад. Платформа 7.7.

15.11.2011    15662    leshik    21    

1С:Торговля и Склад - ошибка во всех релизах, При использовании нескольких фирм и префиксов номеров документов.

Практика программирования v77::ОУ 1С7:ТиС Россия Бесплатно (free)

Собственно сегодня обнаружил ошибку, которая присутствует во всех релизах конфигурации Торговля и Склад 7.7 вплоть до текущего 7.70.969, при использовании нескольких фирм и префиксов документов для некоторых из них.

04.11.2011    15665    twilight5023    8    

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7)

Практика программирования openconf v77::БУ 1cv7.md Россия Бесплатно (free)

Функция проверки валидности e-mail с использованием регулярных выражений RegExp (7.7). Данную функцию можно вставить в Глобальный модуль и пользоваться, например, при вводе или сохранении e-mail.

30.10.2011    11124    zaursoft    11    

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК

Практика программирования Зарплата Зарплата v77::Расчет 1cv7.md 1С7:ЗиК Россия Бесплатно (free)

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    9296    maxim305    18