CSV. Чтение многострочных полей с экранированными символами

12.09.22

Разработка - Механизмы платформы 1С

Как прочитать файл CSV встроенными средствами 1С, если файл содержит многострочные поля, а также экранированные символы.

Перейти сразу к коду

Функция последовательного чтения многострочных полей CSV

Пример чтения CSV в таблицу значений

Предисловие...

Совсем недавно была поставлена задача: нужно периодически скачивать и читать файл поставщика товара, и брать из него цены и остатки, для записи в 1С. Задача как бы тривиальная: берешь построчно из файла текст и разбиваешь его на подстроки по разделителю, хотя бы той же функциейСтрРазделить(СтрокаТекст,Разделитель) .

Но при первом же взоре на файл, немного был ошарашен. Потому что никогда не видел, чтобы в CSV записывали описание номенклатуры прямо как на сайте. То есть, в одном из полей данного файла CSV содержалась строка, которая включает в себе и разделители, и кавычки, и переносы строк. 

К слову сказать, сам файл содержал в себе 350 000 строк, которые впоследствии конвертируются в 32 000 строк данных. То есть на одну строку данных приходится где-то по 10 переводов строк в этом поле с описанием товара.

Примерный текст в файле и данные в виде таблицы
 
ARTIKUL; SKLAD; XARAKT; PRICE; OST
123331;"СВХ ""Северный""";"Пила цепная бензиновая
Длина шины: 4"";
Шаг цепи: 1/4"";
Степень защиты: IP20;
---------
отличное решение для Вас"; 1000,42;120
QW8 995;Южный склад;"Пила цепная электрическая
Длина шины: 4"";
Шаг цепи: 1/4"";
Мощность : 40WT;
@bk.com";500,99;22

ARTIKUL

SKLAD

XARAKT

PRICE

OST

123331 СВХ "Северный" Пила цепная бензиновая
Длина шины: 4";
Шаг цепи: 1/4";
Степень защиты: IP20;
---------
отличное решение для Вас
1000,42 120
QW8 995 Южный склад Пила цепная электрическая
Длина шины: 4";
Шаг цепи: 1/4";
Мощность : 40WT;
@bk.com
500,99 22

 

Для быстрого решения проблемы, поиск дал только решения с подключением с ADODB:

Основная публикация, которую чаще всего выдавал поиск на Инфостарт: Чтение CSV (быстрое).

У этого же автора нашел другую публикацию, где он решил проблему многострочных полей CSV, с написанием процедуры, в которой используются только встроенные средства 1С: 7 правил RFC 4180. Если честно, чтение кода для меня было не совсем понятным, и я попытался подойти к проблеме с другой стороны. Очень сильно помогли расписанные правила, в этой статье.

 

1. Читаем посимвольно.

Первая идея это было читать текст посимвольно, и следить открыта ли экранирующая кавычка, или же закрыта.

То есть если в тексте попадается кавычка, ставим флаг ЭтоЭкран, и все символы до следующей кавычки считаем символами одного поля CSV. Если снова попадается кавычка, то убираем флаг ЭтоЭкран, и обрабатываем последующий текст как данные CSV, смотрим на разделители и переносы строк. Единственный вариант, это если за кавычкой идет снова кавычка, тогда ЭтоЭкран не убирается, и продолжается чтение в одно поле.

Сразу скажу, что такой метод, возможно и точный, но оставляет желать лучшего по быстродействию. Когда текст обрабатывался уже минуту, я оставил развивать эту идею на корню. На всякий случай приведу код, хотя понимаю что он сырой:

 
Посимвольный разбор файла CSV

 

2. Метод четности кавычек

В последующем поиске решения, и благодаря описанию правил формата CSV, мне пришла идея, что мы можем через четность кавычек в тексте, определять, это полная строка данных CSV или же нужно добавить следующую строку текста.

На примере из текста выше: 

Читаем первую строку ARTIKUL; SKLAD; XARAKT; PRICE; OST - кавычки отсутствуют, значит их количество четное, значит можно уже эту строку разбивать по разделителю

2 строка - 123331;"СВХ ""Северный""";"Пила цепная бензиновая - 7 кавычек , количество нечетное: к этой строке нужно добавить следующую, пока не придем к четному количеству кавычек.

...

читаем 7 строку и добавляем к предыдущему тексту поля. Здесь уже получаем 12 кавычек и считаем что получившая строка и есть строка данных CSV

 

 
 Поочередное получение строкиCSV из файла
 
 

Возникает вопрос: а как разбить получившуюся строку данных по разделителям, ведь внутри могут содержаться собственно символы разделителя, означающие сами себя? Ну и хотелось бы очистить текст поля от лишних кавычек, двойных и экранирующих.

Здесь так же воспользуемся этим же методом: разделим текст строки по разделителю и будем перебирать элементы получившегося массива. Будем считать что поле не полное, если в нем нечетное количество кавычек.

Не полное поле дополняем следующим элемента массив, добавляя разделитель между элементами.

 

 
 Получение массива полей CSV из строки CSV

 

Итоговая функция

Для увеличение быстродействия эти функции лучше объединить в одну. Если в строке файла не будет кавычек вообще, то не имеет смысла проверять дополнительно проверять получившийся массив полей

В итоге получилась понятная функция, которая удовлетворяет по скорости быстродействия и использует только внутренние средства языка 1С. Файл с 350 000 строками парсится за 5-10 секунд. В режиме отладки правда почему то показывало 30 сек, что тоже устраивает заказчика.

Функция CSV_Reader(ЧтениеТекста,Разделитель = ";")  
	СтрокаТекста = ЧтениеТекста.ПрочитатьСтроку();
	Если СтрокаТекста = Неопределено Тогда
		Возврат Неопределено;
	КонецЕсли;
	КолКавычек = СтрЧислоВхождений(СтрокаТекста,"""");
	Если КолКавычек%2 Тогда
		МассивСложения = Новый Массив;
		МассивСложения.Добавить(СтрокаТекста);
		Пока КолКавычек%2 Цикл
			СтрокаТекста = ЧтениеТекста.ПрочитатьСтроку();
			КолКавычек = КолКавычек + СтрЧислоВхождений(СтрокаТекста,"""");
			МассивСложения.Добавить(СтрокаТекста);
		КонецЦикла;
		СтрокаТекста = СтрСоединить(МассивСложения,Символы.ПС);
	КонецЕсли;
	Если КолКавычек = 0 Тогда
		Возврат СтрРазделить(СтрокаТекста,Разделитель,Истина);
	КонецЕсли; 
	
	МассивПодстрок = СтрРазделить(СтрокаТекста,Разделитель,Истина);
	МассивЯчеек = Новый Массив;
	Сч = 0; КоличествоЭл = МассивПодстрок.Количество();
	Пока Сч <КоличествоЭл Цикл
		Подстрока = МассивПодстрок[Сч];	
		КолКавычек = СтрЧислоВхождений(Подстрока,"""");
		Если КолКавычек%2 Тогда
			МассивСложения = Новый Массив;
			МассивСложения.Добавить(Подстрока);
			Пока КолКавычек%2 Цикл
				Сч =Сч +1;
				Подстрока = МассивПодстрок[Сч];
				КолКавычек = КолКавычек + СтрЧислоВхождений(Подстрока,"""");
				МассивСложения.Добавить(Подстрока);
			КонецЦикла;
			Подстрока = СтрСоединить(МассивСложения,Разделитель);
		КонецЕсли;
		Если КолКавычек <> 0 Тогда	
			Подстрока = Сред(Подстрока,2,СтрДлина(Подстрока)-2);
			Подстрока = СтрЗаменить(Подстрока,"""""","""");	
		КонецЕсли;
		МассивЯчеек.Добавить(Подстрока);
		Сч =Сч +1;	
	КонецЦикла;
	
	Возврат МассивЯчеек;	
	
КонецФункции
Использование данной функции для получения таблицы значений с данными файла CSV.
Функция ПолучитьТаблицуДанныхЧерезREADeR(ИмяФайла_CSV,Разделитель = ";",ПерваяСтрокаСодержитЗаголовки = Истина) 
	ТаблицаЗначений = Новый ТаблицаЗначений;
	
	ЧтениеТекста = Новый ЧтениеТекста(ИмяФайла_CSV,"UTF-8");
	//Замер производительности
	Старт = ТекущаяУниверсальнаяДатаВМиллисекундах();
	//}}
	
	МассивПолейCSV = CSV_Reader(ЧтениеТекста);
	Если МассивПолейCSV = Неопределено Тогда
		Возврат ТаблицаЗначений;	
	КонецЕсли;
	// Устанавливаем колонки ТаблицыЗначений
	Если ПерваяСтрокаСодержитЗаголовки Тогда
		Для Каждого ПолеCSV Из МассивПолейCSV Цикл
			ТаблицаЗначений.Колонки.Добавить(ПолеCSV);
		КонецЦикла;
		МассивПолейCSV = CSV_Reader(ЧтениеТекста);// Читаем вторую строку
		
	Иначе
		Для Каждого ПолеCSV Из МассивПолейCSV Цикл
			ИндексКолонки = ТаблицаЗначений.Колонки.Количество(); 
			ТаблицаЗначений.Колонки.Добавить("Колонка_" + Формат(ИндексКолонки,"ЧН=; ЧГ=")); 
		КонецЦикла;		
		
	КонецЕсли;
	
	КоличествоКолонокТЗ = ТаблицаЗначений.Колонки.Количество(); 
	Пока МассивПолейCSV <> Неопределено Цикл
		СтрокаТЗ = ТаблицаЗначений.Добавить();
		ИндексКолонки = 0;
		Для Каждого ПолеCSV Из МассивПолейCSV Цикл 
			Если ИндексКолонки = КоличествоКолонокТЗ Тогда
				ТаблицаЗначений.Колонки.Добавить("Колонка_" + Формат(ИндексКолонки,"ЧН=; ЧГ="));
				КоличествоКолонокТЗ = КоличествоКолонокТЗ +1;
			КонецЕсли;
			СтрокаТЗ[ИндексКолонки] = ПолеCSV;
			ИндексКолонки = ИндексКолонки +1;
		КонецЦикла;
		
		МассивПолейCSV = CSV_Reader(ЧтениеТекста);
	КонецЦикла;
	
	//Замер производительности{{
	финиш = ТекущаяУниверсальнаяДатаВМиллисекундах();
	КоличествоСтрок = ТаблицаЗначений.Количество();
	Сообщить(СтрШаблон("Потрачено: %1 сек, количество строк: %2",(финиш - Старт)/1000, КоличествоСтрок));
	//}}
	
	Возврат ТаблицаЗначений;
КонецФункции

И, конечно же, остается открытым вопрос с преобразованием типов данных, потому что все читается как текст. Но, думаю, этот вопрос читатель решит указанием настроек колонок ТЗ. 

Также думаю, что если прочитать весь текст файла в переменную, можно немного ускорить обработку, но это увеличит объем использованной оперативной памяти. 

Интересная заметка при тестировании: конкатенация строк работает намного медленнее, чем функцияСтрСоединить(МассивПодстрок,Разделитель)

CSV многострочные поля экранированные символы ТаблицаЗначений

См. также

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    138185    761    292    

404

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    62388    51    27    

81

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21815    144    40    

104

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

45650 руб.

15.04.2019    70392    174    146    

117

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    48455    208    64    

170

SALE! %

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 27000 руб.

24.04.2015    192510    142    241    

272

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184550    573    509    

516

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

В продаже с 2015 года | Воспользовались более 287 предприятий! | Перенос данных из УПП 1.3 в БП 3.0 | из КА 1.1 в БП 3.0 | Переносятся документы, начальные остатки и вся справочная информация | Сэкономьте свое время - используйте готовое решение для перехода! | Есть фильтр по организации и множество других параметров выгрузки | Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов | Перенос данных возможен в "1С: Бухгалтерия 3.0" версии ПРОФ, КОРП или базовую | Переход с "1С: УПП1.3" / "1С:КА 1.1" на "1С:БП3.0" с помощью правил конвертации будет максимально комфортным! | Можно бесплатно проверить перенос на вашем сервере!

39500 руб.

25.02.2015    169764    293    253    

374
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. SerVer1C 785 12.09.22 19:32 Сейчас в теме
Сложно как-то. Я бы на вашем месте применил регулярки (тут на сайте отличная компонента есть, да и с 23-й платформы регулярки нам подвезут). Можно, перебирая строки, в каждой искать первую часть с помощью
(.*?);(.*?);(".*\n)
, а последнюю часть с помощью
([^\n]*");(.*);(.*)
. А то что не попало в поиск, считать частью многострочного поля.
2. Arxxximed 35 12.09.22 23:01 Сейчас в теме
(1) Спасибо за фитбэк )). Да, регулярки - это сила. Не понимаю почему их сразу не включили в платформу. Очень буду рад когда подвезут.
Есть ответов у меня на Ваше замечание:
1. Сложно как-то. Я искал решение, но все были из разряда - нужно покурить. Замены на какие то токены, поиски позиций кавычек и т.п. в статье дал ссылку, где автор тоже пытался сделать. По мне тут предельно просто - "считаем кавычки" и всё.
2а. Компонента - это хорошо, но мне нужно было именно решение средствами языка 1С. Более того, у заказчика конфигурация с совместимостью ниже версии 8.3.6. Там и
СтрРазделить
() и
СтрСоединить 
нету и их реализация использовалась из модуля ОбщегоНазначения.
2б. Если бы я мог воспользоваться компонентой, то наверное я бы воспользовался компонентой, которая сразу и читает CSV. В тех же ссылках из статьи есть варианты подключения через ADO.
3. Не уверен, но предполагаю, что отправка каждой строки в компоненту чем то может ускорить выполнение парсинга. Хотя интересно было бы сравнить показатели быстродействия.

В целом статейку написал , что бы это кому-нибудь помогло при решении таких задач по быстрому. Как то по большей части за мой опыт ко мне не приходили многострочные файлы CSV. И все всегда читались простым разбитием на строки, и разбивкой на разделители. В основном были только числовые показатели.
user890287; +1 Ответить
3. Serginio 940 13.09.22 20:25 Сейчас в теме
В свое время делал с оптимизацией https://infostart.ru/1c/articles/371887/
Можно посмотреть по скорости
4. Arxxximed 35 13.09.22 21:54 Сейчас в теме
(3) извините, у Вас не работающий код, В случае если поле содержит перенос строк останавливается на ошибке.

1. Как так можно оформлять код? это и не уважение к читателям публикации, и к тому , кто будет этот код читать из программистов.
2. А в чем смысл алгоритма? Посимвольный анализ строки? Ну так в этой публикации писал, что посимвольно - это очень мендленно на больших файлах. И привел свой пример, с меньшим количеством писанины в коде.
de0nis; it_depDi; triviumfan; +3 Ответить
5. Arxxximed 35 13.09.22 23:08 Сейчас в теме
(3) Проверил, Ваша обработка работает минимум в два раза медленнее. Как и предполагал из-за посимвольного разбора строки, и большого количества сравнений. Ну и плюс - не читает поля с переносом.
6. Serginio 940 15.09.22 15:24 Сейчас в теме
(5) Там нет посимвольного. Там есть

if ( Ch = QuoteChar) Тогда
State = ScanQuoted;
StartPos=Inx+1;
SB="";
Inx=НайтиВПодстроке(S,StartPos,QuoteChar);
продолжить;
else
if ( Ch = Delimiter) Тогда
aList.Add("");
else
State = ScanField;
StartPos=Inx;
Inx=НайтиВПодстроке(S,StartPos,Delimiter);
продолжить
КонецЕсли;
КонецЕсли;

А вот найти в подстроке
Функция НайтиВПодстроке(Стр1,Поз1,ИскомыйСимвол)
Стр=Сред(Стр1,поз1);
поз=Найти(Стр,ИскомыйСимвол);
Если поз=0 Тогда
возврат СтрДлина(стр1)+1
КонецЕсли;
Возврат поз1+поз-1
КонецФункции

На момент написания не было функции
СтрНайти(<Строка>, <ПодстрокаПоиска>, <НаправлениеПоиска>, <НачальнаяПозиция>, <НомерВхождения>)
Пэтому там лишнее копирование.
Если несложно провереь через СтрНайти
Понятно, что для скорости я лично обрабатываю на компилируемых языках. Но для не
7. Arxxximed 35 15.09.22 23:31 Сейчас в теме
(6) У Вас не читабельный код, можете хотя бы привести к стилистике 1С? Все таки не на форуме Delfi. Ну и также трудночитаемый со множеством поисков, установок позиций и так далее. Можете рассказать в чем идея кода?
Да, вы не получаете строку посимвольно, но посимвольно ищете, проверяете с нужными символами и возвращаете позиции. Хотя могу ошибаться, повторюсь код нечитаемый.
Ну и плюс... данная статья решает проблему с разделителями, кавычками и переносами строк внутри поля. Ваш же код этого не решает.

Вопрос про компилируемые языки: да, код написанный на других языка будет отрабатывать намного быстрее чем в 1С. Даже скриптовый питон быстрее работает. Но мы же говорим про алгоритмы. Попробуйте реализовать мой алгоритм в том же Delfi или C# (если речь не идет про использование готовых модулей чтения CSV) и сравните свой подход с моим.

Пожалуйста, уважайте своих читателей, обрамляйте код в тег кода [СODE]. Это не сложно. над полем комментария есть кнопочка </>

Жду Вашу алгоритм в стилистке  1С и готов к обсуждению
8. Serginio 940 16.09.22 10:14 Сейчас в теме
(7) Я просто попросил проверить заменив НайтиВПодстроке(Стр1,Поз1,ИскомыйСимвол)
на СтрНайти(<Строка>, <ПодстрокаПоиска>, <НаправлениеПоиска>, <НачальнаяПозиция>, <НомерВхождения>)
Как это скажется на производительность.
И сравнить твой алгоритм с моим.

Что касается стилистики и прочего, то каюсь это были мои первые статьи. Потом я постепенно исправлялся.
Ну и на тот момент просто хотел поделиться алгоритмом ибо в 7 ке то он был а в 8 ке не было, а обмен между 7 и 8 кой был нужен плюс обмен с другими системами построенный на CSV
И там были разные QuoteChar итд
9. user1207943 19.09.22 08:46 Сейчас в теме
Есть же регулярка, которая разбирает csv. Я понимаю, что в качестве упражнения это интересно, но в рабочем варианте мне было бы удобнее использовать проверенный вариант, который легко проанализировать.
10. Arxxximed 35 19.09.22 21:27 Сейчас в теме
(9)Про регулярки отвечал уже в комментарии (2)
11. kuzyara 2059 10.02.23 06:22 Сейчас в теме
Спасибо за более чем в 2 раза быстрый нативный алгоритм, чем в "7 правил RFC 4180".

Следует указать, что он предназначен только для соответствующих стандарту файлов (когда все кавычки экранированы).
ACDelco;OPEL Astra J/Insignia /для 17"диска;2357.00
Вот такую строку ваш алгоритм прочитать уже не сможет
12. Arxxximed 35 14.02.23 13:31 Сейчас в теме
(11) Проблема возникла с чтением текста соответствующего стандарту csv. Алгоритм и решает эту проблему. Строки данных по вашему примеру пока на своей практике не встречал. Для этого думаю должно быть другое решение, которое , скорее всего и отработает быстрее. Вопрос: а что за стандрат вашего примера? откуда вы получаете такие данные. Интересно.
13. kuzyara 2059 20.02.23 13:04 Сейчас в теме
(12) это не стандарт ;), это то что иногда приходит от поставщиков или контрагентов на почту
14. ДмитрийС 27.12.23 13:22 Сейчас в теме
Спасибо за пример!

Небольшое дополнение:
Во всех местах при вызове CSV_Reader(ЧтениеТекста) заменить на CSV_Reader(ЧтениеТекста, Разделитель).
15. MarksMan 12.02.24 11:38 Сейчас в теме
Спасибо за детализацию решения, вопрос - а если разделитель будет совпадать с элементами в многострочном поле - решение будет работать корректно?
Оставьте свое сообщение