Вывод суммы прописью с копейками на разных языках

09.04.23

Разработка - Работа с интерфейсом

Чаще всего в документах, распечатанных из программы 1С да и не только, окончательная сумма прописывается прописью. С одной стороны, это никак не регламентируется, но для всех документов является обязательным, сначала сумму прописывают цифрами, а потом прописью. Это касается практически всех документов, договоров, счетов-фактур, актов и т.д. В 1С реализовать вывод суммы прописью очень просто, можно даже написать её на разных языках.

Для примера я возьму документ «Поступление», у которого есть печатная форма следующего вида, в конец выводится итоговая сумма документа. Давайте сделаем так, чтобы она выводилась прописью с копейками.

 

 

Так как у меня данный макет сформирован с помощью конструктора печати, мне необходимо открыть процедуру «Печать» и изменить формат вывода параметра «Сумма Документа». Для этого необходимо дописать вот такую строку в раздел вывода и заполнения подвала.

 

Подвал.Параметры.СуммаДокумента = ЧислоПрописью(Выборка.СуммаДокумента, ,»рубль, рубля, рублей, м, копейка, копейки, копеек, ж»);

 

Сохраняем и проверяем, что получилось, видим, что итоговая сумма документа теперь выводиться прописью с копейками.

 

 

Если у вас цена, например, в долларах, то тогда пишем вот так.

 

Подвал.Параметры.СуммаДокумента = ЧислоПрописью(Выборка.СуммаДокумента,,»доллар,доллара,долларов,м,цент,цента,центов,м,2R43;);

 

 

Теперь итоговая сумма прописью будет выглядеть следующим образом.

 

 

Можно также реализовать вывод итоговой суммы на другом языке, например, английском.

 

Подвал.Параметры.СуммаДокумента = ЧислоПрописью(Выборка.СуммаДокумента,»L=en_US»,»dollar, dollars, cent, cents, 2R43;);

 

Язык можно изменить на любой, например, белорусский be_BY, французский fi_FI или казахский kk_KZ.

Как видите, все достаточно просто, если нужна более подробная информация, то её можно найти в синтакс-помощнике.

число прописью печатная форма итого прописью 1с прописью

См. также

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4830    10    5    

19

Расширение для 1С:УНФ. Автоматическое снятие резервов в Заказах покупателей

Логистика, склад и ТМЦ Адаптация типовых решений Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3220    5    0    

22

Богатый редактор картинок, хранимых в базе, с возможностью РИСОВАНИЯ. Редактор внешних файлов картинок. Объект, расширяющий возможности работы с картинками из встроенного языка (Три в одном) + Обработка «Стандартизация картинок»

Работа с интерфейсом Рабочее место Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Обработка предназначена для редактирования картинок в режиме «Предприятие», с возможностью РИСОВАТЬ на них. Поддерживается работа как в обычных формах (толстый клиент) так и на управляемых формах (тонкий клиент). Обработка позволяет редактировать как картинки, хранимые в базе, так и графические файлы с диска на файловой системе. Помимо базовых функций (изменение размеров, преобразование формата, обрезание картинки, повороты и т.п.) – редактор имеет богатый набор инструментов для рисования. Доступна функция вставки изображения из буфера обмена. Также обработка может быть использована из встроенного языка как объект для редактирования картинок. Объект может быть использован: на стороне клиента, на стороне сервера, из внешнего соединения. Данная обработка будет особенно полезна тем, кто вносит картинки в базу (изображения номенклатуры, фотографии физических лиц и т.п.). Функционал реализуется с использованием JavaScript и бесплатного ПО ImageMagick (без использования внешних компонент).

6000 руб.

16.01.2015    62222    43    59    

81

Управление дашбордами

Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Обработка предназначена для создания и управления дашбордами.

2400 руб.

29.06.2020    17051    22    4    

36

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2453    32    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ISChaplagin 42 09.04.23 19:32 Сейчас в теме
Процедура Печать(ТабДок, Ссылка) Экспорт
	//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
	Макет = Документы.Поступление.ПолучитьМакет("Печать");
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	Поступление.Дата,
	|	Поступление.Договора,
	|	Поступление.Контрагент,
	|	Поступление.Номер,
	|	Поступление.СписокМатериалов.(
	|		НомерСтроки,
	|		Материалы,
	|		Цена,
	|		Количество,
	|		Сумма
	|	)
	|ИЗ
	|	Документ.Поступление КАК Поступление
	|ГДЕ
	|	Поступление.Ссылка В (&Ссылка)";
	Запрос.Параметры.Вставить("Ссылка", Ссылка);
	Выборка = Запрос.Выполнить().Выбрать();

	ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
	Шапка = Макет.ПолучитьОбласть("Шапка");
	ОбластьСписокМатериаловШапка = Макет.ПолучитьОбласть("СписокМатериаловШапка");
	ОбластьСписокМатериалов = Макет.ПолучитьОбласть("СписокМатериалов");
	
	//*// 
	ПодвалТЧ = Макет.ПолучитьОбласть("ПодвалТЧ"); // Получать область ПодвалТЧ
    ПодвалВсего = Макет.ПолучитьОбласть("ПодвалВсего"); // Получать область ПодвалВсего 
	//*//

	ТабДок.Очистить();
	
	//*//
	// Переменная для подсчета суммы
	ОбщаяСумма=0;
	//*//
	
	ВставлятьРазделительСтраниц = Ложь;
	Пока Выборка.Следующий() Цикл
		Если ВставлятьРазделительСтраниц Тогда
			ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
		КонецЕсли;

		ТабДок.Вывести(ОбластьЗаголовок);

		Шапка.Параметры.Заполнить(Выборка);
		ТабДок.Вывести(Шапка, Выборка.Уровень());

		ТабДок.Вывести(ОбластьСписокМатериаловШапка);
		ВыборкаСписокМатериалов = Выборка.СписокМатериалов.Выбрать();
		Пока ВыборкаСписокМатериалов.Следующий() Цикл
			ОбластьСписокМатериалов.Параметры.Заполнить(ВыборкаСписокМатериалов);
			ТабДок.Вывести(ОбластьСписокМатериалов, ВыборкаСписокМатериалов.Уровень());
			
		//*//
		// Подсчет
		ОбщаяСумма=ОбщаяСумма+ВыборкаСписокМатериалов.Сумма;
		//*// 
			
	КонецЦикла;      
	   
		//*//
        //Вывести область подвалТЧ
		ПодвалТЧ.Параметры.Установить(0, ОбщаяСумма);
		ТабДок.Вывести(ПодвалТЧ);
         //*//   
		 
		 //*//  
         //Вывести область подвалВсего
		ОбщаяСуммаПропись= ЧислоПрописью(Строка(ОбщаяСумма),"Л=ru_RU; ДП=Истина","рубль, рубля, рублей, м, копейка, копейки, копеек, ж" );
		ПодвалВсего.Параметры.Установить(0, ОбщаяСуммаПропись);	
		ТабДок.Вывести(ПодвалВсего);
         //*// 
		
		 ВставлятьРазделительСтраниц = Истина;
	КонецЦикла;
	//}}
КонецПроцедуры

Показать
2. Slypower 3 10.04.23 10:58 Сейчас в теме
А так же в самой валюте есть параметры целой и дробной части прописи для русского для каждой валют
3. RayCon 785 16.04.23 19:14 Сейчас в теме
окончательная сумма прописывается прописью.

Это верно.
С одной стороны, это никак не регламентируется

А вот это для России неверно: суммы прописью в документах регламентируются различными документами, как ОКУД, так и ведомственными, например, Положением ЦБ РФ от 19.06.2012 №383-П "О правилах осуществления перевода денежных средств".
Но это отчасти верно для международных расчетов, где работают обычаи делового оборота. Так вот, эти обычаи таковы, что сумма прописью пишется только в части целых значений валюты и не пишется в части дробных значений валюты. => И вывод всяческих "центов" в типовых конфигурациях фирмы 1С, и в данной разработки - вещь не только не нужная, но и вредная, т.к. демонстрирует зарубежному контрагенту отсутствие компетенций в знании обычаев международного делового оборота.
Оставьте свое сообщение