Обработка данных банков (cbr.ru)

09.11.23

Интеграция - WEB-интеграция

Кусок кода для обработки данных(XML) по банкам с сайта cbr.ru. Пойдёт в любую самописку для простенького справочника с банками.
    ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);
    HTTP = Новый HTTPСоединение("www.cbr.ru",,,,,,ЗащищенноеСоединение);
    ХТТПЗапрос = Новый HTTPЗапрос;
    ХТТПЗапрос.АдресРесурса = "/s/newbik";
    HTTP.Получить(ХТТПЗапрос);
    ОтветСервера = HTTP.ВызватьHTTPМетод("GET", ХТТПЗапрос);
    Если ОтветСервера.КодСостояния = 301 Тогда
        АдресРесурса = ОтветСервера.Заголовки.Получить("Location");
        ХТТПЗапрос = Новый HTTPЗапрос;
        ХТТПЗапрос.АдресРесурса = АдресРесурса;
        HTTP.Получить(ХТТПЗапрос);
        ОтветСервера = HTTP.ВызватьHTTPМетод("GET", ХТТПЗапрос);
        Если ОтветСервера.КодСостояния = 200 Тогда
            Ответ = ОтветСервера.ПолучитьТелоКакДвоичныеДанные();
            ФайлДД = ПолучитьИмяВременногоФайла(".zip");
            Ответ.Записать(ФайлДД);
            Архив = Новый ЧтениеZipФайла(ФайлДД);
            Архив.ИзвлечьВсе(КаталогВременныхФайлов(), РежимВосстановленияПутейФайловZIP.Восстанавливать);
            Для Каждого Файл ИЗ Архив.Элементы Цикл
                ПутьКФайлу = КаталогВременныхФайлов() + Файл.Имя;
                Парсер = Новый ЧтениеXML;
                Парсер.ОткрытьФайл(ПутьКФайлу);
                Построитель = Новый ПостроительDOM;
                Документ = Построитель.Прочитать(Парсер);
                Для Каждого Элемент0 Из Документ.ЭлементДокумента.ДочерниеУзлы Цикл
                    Если Элемент0.ИмяУзла = "BICDirectoryEntry" Тогда
                        БИК = Элемент0.Атрибуты.ПолучитьИменованныйЭлемент("BIC").Значение;
                        Для Каждого Элемент1 ИЗ Элемент0.ДочерниеУзлы Цикл
                            Если Элемент1.ИмяУзла = "ParticipantInfo" Тогда
                                НазваниеБанка = Элемент1.Атрибуты.ПолучитьИменованныйЭлемент("NameP").Значение;
                                PtType = Элемент1.Атрибуты.ПолучитьИменованныйЭлемент("PtType").Значение;
                                Закрыт = ?(PtType = "90", Истина, Ложь);
                            ИначеЕсли Элемент1.ИмяУзла = "Accounts" Тогда
                                КоррСчет = Элемент1.Атрибуты.ПолучитьИменованныйЭлемент("Account").Значение;
                            КонецЕсли;
                        КонецЦикла;
                        ДанныеБанка = Новый Структура("БИК, НазваниеБанка, КоррСчет, Закрыт", БИК, НазваниеБанка, КоррСчет, Закрыт);
                        ОбработатьДанные(ДанныеБанка); //Здесь процедура для обработки полученных данных
                    КонецЕсли;
                КонецЦикла;
            КонецЦикла;
        КонецЕсли;
    КонецЕсли;

 

1. Из-за того, что основная ссылка ведёт на страницу с редиректом - получаем два HTTP запроса.

2. Разархивируем полученный файл.

3. Разбираем XML через ПостроительDOM.

Данных в полученном XML файле гораздо больше, чем я получил, но для просто справочника - достаточно.

Соответственно, вот в этой части кода по образу и подобию:

Если Элемент1.ИмяУзла = "ParticipantInfo" Тогда
     НазваниеБанка = Элемент1.Атрибуты.ПолучитьИменованныйЭлемент("NameP").Значение;
     PtType = Элемент1.Атрибуты.ПолучитьИменованныйЭлемент("PtType").Значение;
     Закрыт = ?(PtType = "90", Истина, Ложь);
ИначеЕсли Элемент1.ИмяУзла = "Accounts" Тогда
     КоррСчет = Элемент1.Атрибуты.ПолучитьИменованныйЭлемент("Account").Значение;
КонецЕсли;

добавляем нужные нам атрибуты.

На уникальность и "супер-крутость" кода не претендую:)

Просто решил поделиться, кому-нибудь будет полезно, уверен.

банки xml справочник

См. также

SALE! 10%

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    138145    761    292    

404

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    62367    51    27    

81

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21797    144    40    

104

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

45650 руб.

15.04.2019    70376    175    146    

117

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    48438    208    64    

170

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184532    573    509    

516

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

В продаже с 2015 года | Воспользовались более 287 предприятий! | Перенос данных из УПП 1.3 в БП 3.0 | из КА 1.1 в БП 3.0 | Переносятся документы, начальные остатки и вся справочная информация | Сэкономьте свое время - используйте готовое решение для перехода! | Есть фильтр по организации и множество других параметров выгрузки | Поддерживается несколько сценариев работы: как первичный полный перенос, так и перенос только новых документов | Перенос данных возможен в "1С: Бухгалтерия 3.0" версии ПРОФ, КОРП или базовую | Переход с "1С: УПП1.3" / "1С:КА 1.1" на "1С:БП3.0" с помощью правил конвертации будет максимально комфортным! | Можно бесплатно проверить перенос на вашем сервере!

39500 руб.

25.02.2015    169755    293    253    

374

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

45650 руб.

10.07.2018    69180    46    126    

49
Отзывы
2. user1880116 12.11.23 10:01 Сейчас в теме
(1)
как получить ссылку редиректа
https://httpwg.org/specs/rfc9110.html#status.301

The server SHOULD generate a Location header field in the response containing a preferred URI reference for the new permanent URI. The user agent MAY use the Location field value for automatic redirection.
Остальные комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. tsatsur 46 09.11.23 13:58 Сейчас в теме
Если кто-то знает как получить ссылку редиректа (301), подскажите:)
А то:
не по красоте, конечно:))
2. user1880116 12.11.23 10:01 Сейчас в теме
(1)
как получить ссылку редиректа
https://httpwg.org/specs/rfc9110.html#status.301

The server SHOULD generate a Location header field in the response containing a preferred URI reference for the new permanent URI. The user agent MAY use the Location field value for automatic redirection.
3. tsatsur 46 13.11.23 12:59 Сейчас в теме
(2)
server SHOULD generate a Location header field in the response containing a preferred URI reference for the new permanent URI.

Спасибо:) Тупанул. Сейчас поправлю код и обновлю.
Оставьте свое сообщение