Быстрая выгрузка отчетов в Excel + ярлычки листов

06.11.09

Интеграция - Загрузка и выгрузка в Excel

Вместо Таб.Показать() используем глобальную функцию - и отчет показывается сразу в Excel в удобоваримом виде...

Вместо Таб.Показать() используем глобальную функцию - и отчет показывается сразу в Excel в удобоваримом виде - с форматированием колонок по ширине, автофильтром и ярлычками листов

// ===============================
Процедура глОткрытьВЭкселе(Таб,ИмяФайла="",НеИзменятьВысотуСтроки=0) Экспорт
    Попытка 
        // запускаем Excel-Server 
        Excel = СоздатьОбъект("Excel.Application");
    Исключение       
        Excel = 0;
        Предупреждение("MS Excel не загружен!");
        Возврат;
    КонецПопытки;   
	
    Если ТипЗначенияСтр(Таб)="Строка" Тогда
        Excel.WorkBooks.Open(Таб);
    Иначе                                                          
        Если НеИзменятьВысотуСтроки=0 Тогда
            ШиринаТаблицы=Таб.ШиринаТаблицы();
            Область=Таб.Область(1,1,Таб.ВысотаТаблицы(),ШиринаТаблицы);
            Область.ВысотаСтроки(12);                 
        КонецЕсли;
		
        Если Найти(ИмяФайла,":")=0 Тогда
            ИмяФайла=КаталогПользователя()+ИмяФайла;
        КонецЕсли;
        Если Найти(Врег(ИмяФайла),"XLS")=0 Тогда
            ИмяФайла=ИмяФайла+".xls";
        КонецЕсли;
		
        Таб.Записать(?(ПустоеЗначение(ИмяФайла)=0,ИмяФайла,КаталогПользователя()+"Таблица.xls"),"XLS");
        Excel.WorkBooks.Open(ИмяФайла);
		
        Excel.Visible = 0;
		
        //добавляем автофильтр и форматирование колонок по ширине
        Excel.Columns.AutoFit();
        Range = Excel.Range(Excel.Cells(1, 1), Excel.Cells(1, ШиринаТаблицы));
        Range.Select();
        Range.AutoFilter();
		
        //показываем вечно прячущиеся ярлычки листов :)		
        Excel.ActiveWindow.DisplayWorkbookTabs = -1;
        Excel.ActiveWindow.TabRatio = 0.25;
    КонецЕсли;
	
    Excel.Visible=1;	  
    Excel=0;
КонецПроцедуры	//глОткрытьВЭкселе

См. также

Загрузка банковской выписки для 1С 7.7 любой конфигурации

Банковские операции Загрузка и выгрузка в Excel Бухгалтер Пользователь Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет Платные (руб)

Решение предоставляет комплексную загрузку банковской выписки из CSV, XLS, TXT файла в 1С 7.7 любой конфигурации. Позволяет создавать документы выбранного вида, например "Строка выписки банка (приход/расход)", или многострочный табличный документ, например Выписка, для каждой операции из загружаемого файла банковской выписки. Загружает реквизиты документа, а также создаёт контрагентов и другие необходимые элементы справочников.

3588 руб.

29.07.2021    21045    13    22    

14

Загрузка документов в 1С (7.7) из табличных файлов Excel,OpenOffice,1C,DBF,TXT (обработка)

Файловый обмен (TXT, XML, DBF), FTP Загрузка и выгрузка в Excel Платформа 1С v7.7 Конфигурации 1cv7 Платные (руб)

Обработка решает поставленную задачу по вводу документов, а кроме того обладает важной функцией: настраивается на ассортимент конкретного поставщика, запоминая соответствие между его номенклатурой и «нашей». Т.е. фактически – является самообучающейся системой ввода накладных. У разных поставщиков могут быть накладные различного типа, с разным количеством полей, поэтому для каждого из них может быть сохранена своя собственная настройка диалоговой формы так, что любая поступающая накладная может быть обработана. По отношению к программе "1С:Предприятие 7.7" данное решение является внешними файлами. Для использования данного продукта не требуется вносить изменения в алгоритм существующих программ или используемых конфигураций.

2400 руб.

10.12.2009    76891    58    93    

68

Сводная таблица Excel из 1С

Загрузка и выгрузка в Excel Программист Платформа 1С v7.7 Абонемент ($m)

Сводная таблица Excel из 1С - как сделать ее программно через COM соединение.

1 стартмани

30.07.2021    6283    1    atdonya    1    

2

Выгрузка товаров из 1С:Предприятия 7.7 "Торговля и Склад 9.2" в файл CSV для онлайн кассы МТС

Кассовые операции Оптовая торговля Розничная торговля Загрузка и выгрузка в Excel Бухгалтер Пользователь Оперативный учет 7.7 1С:Торговля и склад 7.7 Бухгалтерский учет Управленческий учет Абонемент ($m)

Данная обработка предназначена для выгрузки файла из программы 1С: Предприятие 7.7 Конфигурации «Торговля и Склад 9.2» в файл CSV для загрузки в кассу МТС. Тестирование проводилось на релизах 937 и 998. В теории должна работать на всех типовых релизах конфигурации «Торговля и Склад 9.2».

1 стартмани

07.02.2021    10030    5    Kuzya_brаtsk    1    

7

Выгрузка товаров из 7.7 для загрузки в личный кабинет АТОЛ для ньюджеров 91Ф, 92Ф и подобных

Оптовая торговля Загрузка и выгрузка в Excel Программист Бухгалтер Пользователь Платформа 1С v7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Бухгалтерский учет Управленческий учет Абонемент ($m)

Выполняет выгрузку товаров (всех, только с признаком в прайсе, только из указанной папочки) с гибкой настройкой выгружаемых данных. Формируется файл в формате XLSX подходящий для прямой удаленной загрузки в кассовый аппарат АТОЛ 91Ф/92Ф и им подобных, имеющих управление через Личный кабинет АТОЛ (lk.atol.ru).

1 стартмани

31.01.2021    8223    2    &-rey    1    

4

Дополнение реквизитов номенклатуры из Эксель в 7.7. Групповое редактирование реквизитов номенклатуры 7.7 в списке

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Программист Пользователь Платформа 1С v7.7 1С:Комплексная 7.7 Управленческий учет Абонемент ($m)

Обработки группового дополнения данных о номенклатуре. Ввод веса и объема существующих товаров вручную в форму таблицы значений и затем запись в справочник Номенклатуры и Единиц. Закачка весов и объемов существующих товаров из Эксель в справочник Номенклатуры и Единиц. Загрузка внешних кодов товаров из Эксель в справочник Номенклатуры. Редактирование внешних кодов товаров в форме списка. Дозаполнение реквизитов существующих товаров из Эксель (ключевые поля - штрихкод, наименование, внешний код).

1 стартмани

11.10.2019    11962    2    ksnik    2    

2

Оптовая торговля. Обработки дистрибьютора для обмена с поставщиками и покупателями через Excel в 1С 7.7

Оптовая торговля Загрузка и выгрузка в Excel Пользователь Платформа 1С v7.7 Конфигурации 1cv7 Оптовая торговля, дистрибуция, логистика Управленческий учет Абонемент ($m)

В данной публикации приведены примеры обработок обмена дистрибьютора с поставщиками и покупателями через Эксель. Создание товаров-новинок. Автоматическое формирование Заказа поставщику по продажам. Заполнение бланка заказа поставщику. Загрузка приходной накладной от поставщика. Загрузка любых справочников из Эксель, например товарных сертификатов. Выгрузка прайслиста в бланк заказа (создание бланка заказа). Загрузка заявки покупателя из произвольного файла Эксель. Загрузка заявки покупателя из бланка заказа.. Для работы требуется установленный MS Excel.

1 стартмани

08.09.2019    16322    10    ksnik    2    

3
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Ёпрст 1064 16.06.09 12:32 Сейчас в теме
Очередной [:]|||||||||[:]
И не обязательно 12, главное - не АВТО...
begemot; support; +2 Ответить
5. support 4449 16.06.09 16:41 Сейчас в теме
Интересное наблюдение.
(1) Ну, не все же такие продвинутые
2. Ёпрст 1064 16.06.09 12:33 Сейчас в теме
"И не надо никаких премудрых компонент )"

То же брехня... если нужно сохранить форматирование как есть - то очень даже нужно.
3. Душелов 4018 16.06.09 12:40 Сейчас в теме
(0) >Excel.WorkBooks.Open(ИмяФайла);

Ну а, если в отчете будет 70000 и более строк?
4. CheBurator 3123 16.06.09 13:54 Сейчас в теме
Ну и вообщем-то высота строк в москеле не в пикселях меряется..
???
6. mikukrnet 182 16.06.09 16:58 Сейчас в теме
Да, 70000 строк не выгрузится. Ну а что ж вы хотите от проги, которой уже 10 лет :))
7. bulpi 215 23.06.09 22:48 Сейчас в теме
Не понял ни фига :(. Похоже, в тексте процедуры куска не хватает ?
8. DitriX 2096 26.07.09 22:57 Сейчас в теме
Вот недавно делал отчет - 130к строк и 280 колонок :)
Вообщем сохранить отчет как ХТМЛ и потом копи паст в 2007 :)

Ждем пока 1С 8.1 сможет сохранять напрямую в 2007....
9. Hangmaster 07.09.11 16:29 Сейчас в теме
С таким скудным описанием так и не понял: что именно передавать в процедуру? Какой аргумент должен быть в "Таб"?
Оставьте свое сообщение