Сервисы интеграции. Уведомления через колокольчик

10.07.24

Интеграция - Перенос данных 1C

Отправим уведомление и ссылку на документ через колокольчик списку пользователей.

Часть процедур и функций была взята из статьи Сервисы интеграции без Шины и интеграции

Добавим новый сервис интеграции Д_Оповещения и канал Д_ОповещениеПользователей (направление сообщений Отправка)

 

 

 

Добавим общий модуль Д_ОповещениеПользователей (сервер, вызов сервера, привилегированный)

 

 

 

Добавим в этот модуль ниже перечисленные процедуры и функции

 
Д_ОповещениеПользователей

 

Найдем обработку БСП ТекущиеДела

 

 

 

В форму обработки ТекущиеДела добавим новую глобальную переменную, в событие ПриОткрытии добавим обработчик ожидания процедуру ПолучитьСообщенияДляОповещения каждые 15 секунд (можно событие ПриОткрытии перенести в расширение)

 

 

//КЕ
&НаКлиенте
Перем СтруктураПользователяФормы; 
//КЕ


&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	//КЕ  
	СтруктураПользователяФормы = Д_ОповещениеПользователей.ПолучитьСтруктуруПользователя();
	ПодключитьОбработчикОжидания("ПолучитьСообщенияДляОповещения", 15, Ложь);
	//КЕ
	
КонецПроцедуры 

//КЕ
&НаКлиенте
Процедура ПолучитьСообщенияДляОповещения()
	
	МассивСообщений = Д_ОповещениеПользователей.ПолучитьСообщения("Д_Оповещения", "Д_ОповещениеПользователей", СтруктураПользователяФормы);	
	Если МассивСообщений.Количество() > 0 Тогда
		Для Каждого ТекСообщение Из МассивСообщений Цикл 
			
			Если Не ТекСообщение.Свойство("Сообщение") Тогда 				
				Продолжить;
			КонецЕсли;	
			
			Если ТекСообщение.Свойство("НавигационнаяСсылка") Тогда	 	
				ПоказатьОповещениеПользователя(ТекСообщение.Сообщение
				,ТекСообщение.НавигационнаяСсылка
				,?(ТекСообщение.Свойство("Отправитель"),ТекСообщение.Отправитель,""),
				,СтатусОповещенияПользователя.Важное
				,ТекСообщение.Идентификатор);
				
			Иначе	
				ПоказатьОповещениеПользователя(ТекСообщение.Сообщение,
				,?(ТекСообщение.Свойство("Отправитель"),ТекСообщение.Отправитель,""),
				,СтатусОповещенияПользователя.Важное
				,ТекСообщение.Идентификатор);
			КонецЕсли;			
			
		КонецЦикла;
		
		
		Д_ОповещениеПользователей.ОчиститьВсеСообщенияНаСервере("Д_Оповещения", "Д_ОповещениеПользователей", МассивСообщений);			
	КонецЕсли;	
	
КонецПроцедуры    
//КЕ

 

Откроем стандартную обработку Управление сервисами интеграции, поставим галочку на новый сервис интеграции Оповещения

 

 

 

 

Создадим внешнюю обработку для теста сервиса интеграции. Со списком получатели (пользователи), полем сообщение (Строка), полем документ (ссылка на заказ покупателя)

 

 

 

В модуль формы внешней обработки добавим процедуры

 

 

&НаСервере
Процедура ОтправитьСообщениеВКолокольчикНаСервере()      
	
	МассивПолучатели = Получатели.Выгрузить().ВыгрузитьКолонку("Пользователь");
	Д_ОповещениеПользователей.ОтправитьСообщениеКолокольчикПользователям(МассивПолучатели,Сообщение,Док);
	
КонецПроцедуры 

&НаКлиенте
Процедура ОтправитьСообщениеВКолокольчик(Команда)      
	
	ОтправитьСообщениеВКолокольчикНаСервере();
	
КонецПроцедуры

 

Отправляем сообщение себе и другому пользователю с ссылкой на документ Заказ покупателя

 

 

 

Тестировал: 

  • Библиотека стандартных подсистем, редакция 3.1 (3.1.9.337)
  • 1С:Комплексная автоматизация 2 (2.4.13.209)
  • Платформа 1С:Предприятие 8.3 (8.3.24.1342)

Сервисы интеграции колокольчик

См. также

SALE! 10%

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    138061    760    292    

404

Перенос данных 1C Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос документов, начальных остатков и справочной информации из УПП 1.3 в ERP 2 | из УПП 1.3 в УТ 11 | из УПП в КА 2 | Правила конвертации (КД 2) в продаже с 2015 года, постоянно работаем над их развитием | Более 360 предприятий выполнили переход с использованием этого продукта! | Сэкономьте время - используйте готовое решение для перехода! | Позволяет перенести из УПП 1.3 в ERP / УТ 11 / КА 2 всю возможную информацию | В переносе есть фильтр по организации и множество других опциональных параметров выгрузки | Есть несколько алгоритмов выгрузки остатков на выбор

45650 руб.

04.08.2015    162717    371    273    

359

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

45650 руб.

15.04.2019    70343    173    146    

116

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21765    144    40    

104

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    62328    51    27    

80

Перенос данных 1C Системный администратор Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

В продаже с 2014г. | Воспользовались более 122 предприятий! | Перенос данных из БП 3.0 в УТ 11 | из БП 3.0 в КА 2 | из БП 3.0 в ERP | Сэкономьте свое время - используйте готовое решение для перехода! | Постоянно работаем над развитием переноса данных | Обновляем на новые релизы 1С | Есть фильтр выгрузки по организациям | Переносятся начальные остатки на выбранную дату, документы за период времени и вся возможная справочная информация | Перенос сделан на технологии КД 2 (правила конвертации данных)

45650 руб.

31.10.2014    234088    93    330    

301

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184481    573    509    

516

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    48392    208    64    

170
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Serg O. 270 10.07.24 09:28 Сейчас в теме
а зачем в условии Если МассивСообщений.Количество() > 0 Тогда
после цикла чтобы очистить массив сообщений - снова проверять
Если МассивСообщений.Количество() > 0 Тогда

и даже если Количество() = 0 очистке это не помещает никак
и вообще все Если - лишние, цикл по пустому массиву и так не пойдёт.

//КЕ
&НаКлиенте
Процедура ПолучитьСообщенияДляОповещения()
	
	МассивСообщений = Д_ОповещениеПользователей.ПолучитьСообщения("Д_Оповещения", "Д_ОповещениеПользователей", СтруктураПользователяФормы);

	Для Каждого ТекСообщение Из МассивСообщений Цикл 
						
		ПоказатьОповещениеПользователя(
			, ?(ТекСообщение.Свойство("Сообщение"), ТекСообщение.Сообщение, "Сообщение")
			, ?(ТекСообщение.Свойство("НавигационнаяСсылка"), ТекСообщение.НавигационнаяСсылка, "")
			, ?(ТекСообщение.Свойство("Отправитель"), ТекСообщение.Отправитель, ""),
			, СтатусОповещенияПользователя.Важное
			, ТекСообщение.Идентификатор);		
			
	КонецЦикла;
		
	Д_ОповещениеПользователей.ОчиститьВсеСообщенияНаСервере("Д_Оповещения", "Д_ОповещениеПользователей", МассивСообщений);			
	
КонецПроцедуры    
//КЕ
Показать
DMSDeveloper; +1 Ответить
5. John_d 5753 10.07.24 13:08 Сейчас в теме
(1) Согласен проверка перед циклом лишняя, убрал. Проверка перед Д_ОповещениеПользователей.ОчиститьВсеСообщенияНаСервере нужна, чтобы не вызывать лишний раз процедуру.
6. John_d 5753 10.07.24 13:47 Сейчас в теме
(1) Все таки вернул проверку перед циклом. Эта процедура выполняется каждый 15 секунда и пусть даже не пытается запустить цикл и в рамках этой проверки не отработает лишний раз Д_ОповещениеПользователей.ОчиститьВсеСообщенияНаСервере
2. Fox-trot 161 10.07.24 10:17 Сейчас в теме
ну и тогда мои 5 копеек
используем ИначеЕсли и тогда Продолжить уже не пригодится
3. Дмитрий74Чел 237 10.07.24 12:32 Сейчас в теме
Прошу уточнить:
1) для работы механизма надо устанавливать сервер взаимодействия, или какой-то другой компонент?
2) такое же сообщение ведь можно отправить через чат системы взаимодействия, без написания кода?
4. John_d 5753 10.07.24 13:02 Сейчас в теме
(3)
1) ничего не нужно
2) это если в конфигурацию уже внедрена система взаимодействий, по умолчанию нет
7. Дмитрий74Чел 237 10.07.24 16:30 Сейчас в теме
Для инфо читающим. За вывод в колокольчик отвечает СтатусОповещенияПользователя.Важное в ПоказатьОповещениеПользователя().
IIroxod4uk; dfgdsfgsdfg2011; TimurD; +3 Ответить
8. Sapiens_bru 4 11.07.24 17:46 Сейчас в теме
Всё то же можно сделать на обычном регистре сведений. С теми же трудозатратами и почти тем же кодом.

Не стоит использовать механизмы платформы в сценариях для них не предназначенных, тем более новые механизмы. Выйдет новая платформа и решение перестанет работать.
9. dsdred 3470 11.07.24 18:00 Сейчас в теме
(8) 1 не все тоже можно сделать на регистре сведений.
2 Между тем если изменят в платформе, то разом сломаются все интеграции через 1с шину.
Уверены, что 1с решится на такой подвиг?


П.С. Обойтись Регистром, справочником, документом можно, но есть ряд нюансов.
Может выйти вариант когда под каждый вид оповещений начнут плодится все новые и новые сущности.

В сервисах интеграции, в сообщении есть свойство "Параметр", в который можно добавлять сколько угодно ключей для выборки. Например добавить ключ "ТипОповещение" и т.д.
Соответственно мы получаем очень гибкий механизм. Добавив один канал на него можем вешать разные оповещалки без доработок.
10. Sapiens_bru 4 11.07.24 22:33 Сейчас в теме
(9) Что нельзя сделать на регистре того что можно только на сервисе интеграции? Канал сервиса интеграции это две простые таблички в базе данных. Там даже индекса по идентификатору нет. По сути это два регистра сведений, в одном лежит очередь сообщений, в другом тело сообщений.
Свойство "Параметр" хранится в виде текста, то есть проходит процедуру сериализации/десериализации каждый раз при обращении к базе. Например выбрать данные по значению параметра не получится, только выбрать всё и прочитать все параметры. Реализовать ту же логику на регистре сведений не проблема, но смысла нет. Гораздо проще в регистр сведений добавить ещё одно поле и получить возможность отбора/поиска по нему.
Регистр сведений гораздо более гибкий механизм, потому что составом колонок мы управляем напрямую, а не используем фиксированную структуру, к тому-же доступную только через методы сервисов интеграции.

Завтра вас попросят прикрутить к сообщению поле ДатаПрочтения, или сделать возможность сохранить уже доставленные уведомления Х дней для отчетности. И всё. И Конец. В сервис интеграции такое не впихнёшь.

А если в базе начинают плодится регистры сведений это не к добру, нужно искать причину такого размножения и устранять.
11. dsdred 3470 11.07.24 22:47 Сейчас в теме
(10)
Канал сервиса интеграции это две простые таблички в базе данных. Там даже индекса по идентификатору нет. По сути это два регистра сведений, в одном лежит очередь сообщений, в другом тело сообщений.


Одна таблица IntegChannelOutQueueXX
Тело лежит в поле MessageBody
Параметры лежат в поле MessageHeader

Статейка по этой информации -> https://infostart.ru/1c/articles/2042916/

Гораздо проще в регистр сведений добавить ещё одно поле и получить возможность отбора/поиска по нему.

И выгнать всех из 1С. А если окна обновления в данный момент нет, а добавить надо?

Завтра вас попросят прикрутить к сообщению поле ДатаПрочтения, или сделать возможность сохранить уже доставленные уведомления Х дней для отчетности. И всё. И Конец. В сервис интеграции такое не впихнёшь.

Я не спорю для каких то задач, например для обменов по старинке регистр сведений подходит лучше.
Но для каких то задач сервисы интеграции интереснее.

А если в базе начинают плодится регистры сведений это не к добру, нужно искать причину такого размножения и устранять.

Согласен, но в жизни так бывает.
12. rozer 309 12.07.24 16:01 Сейчас в теме
В чем отличия от оригинальной статьи ?
Новаторство только в "ТекущиеДела" и отправка списку ?
13. John_d 5753 12.07.24 17:19 Сейчас в теме
(12) -отправка списку,
-причесал код,
-вывел программный интерфейс отправка уведомления одной строкой Д_ОповещениеПользователей.ОтправитьСообщениеКолокольчикПользователям(МассивПолучатели,Сообщение,Док);
Оставьте свое сообщение