Мелкие полезные функции

Публикация № 313753

Разработка - Практика программирования

полезняшки

На Инфостарте некоторое время назад существовали блоги. Я записывал заметки туда. Сейчас обнаружил, что блоги кончились. Решил перенести некоторые заметки из бога в отдельную публикацию.
Вот заметки:
1. Поиск объекта по идентификатору.
2. Разрешение пользолваателям редактировать отдельные реквизиты документа без перепроведения.

1. Получение объекта по идентификатору.

Синхронизация справочников и документов с сайтом я предпочитаю выполнять по уникальным идентификаторам. Поэтому часто необходимо получать ссылку по идентификатору. Написал для этого универсальную функцию.

// Возвращает ссылку на найденный справочник или документ или Неопределено, если объекта нет.
// Параметры
// ИД - строковое представления уникального идентификатора
// Тип - наименование вида справочника или документа. Благо их наименования не пересекаются.
Функция ПолучитьСсылкуПоИД(ИД, Тип = Неопределено)
	Если ИД = "" и Тип <> Неопределено Тогда
		// Тип известен, элемент явно пустой, значит нужно вернуть пустую ссылку
		спр = Метаданные.Справочники.Найти(Тип);
		Если спр <> Неопределено Тогда
			Возврат Справочники[Тип].ПустаяСсылка();
		КонецЕсли;
		
		док = Метаданные.Документы.Найти(Тип);
		Если док <> Неопределено Тогда
			Возврат Документы[Тип].ПустаяСсылка();
		КонецЕсли;
		Возврат Неопределено
	КонецЕсли;
	
	Попытка
		УИД = Новый УникальныйИдентификатор(ИД);
	Исключение
		Возврат Неопределено
	КонецПопытки;
	
	// Если тип известен, то ищем только в одной таблице
	Если Тип <> Неопределено Тогда
		спр = Метаданные.Справочники.Найти(Тип);
		Если спр <> Неопределено Тогда
			Ссылка = Справочники[Тип].ПолучитьСсылку(УИД);
			Если Не Ссылка.Пустая() и Ссылка.ПолучитьОбъект() <> Неопределено Тогда
				Возврат Ссылка
			КонецЕсли;
			Возврат Неопределено
		КонецЕсли;
		
		док = Метаданные.Документы.Найти(Тип);
		Если док <> Неопределено Тогда
			Ссылка = Документы[Тип].ПолучитьСсылку(УИД);
			Если Не Ссылка.Пустая() и Ссылка.ПолучитьОбъект() <> Неопределено Тогда
				Возврат Ссылка
			КонецЕсли;
		КонецЕсли;
		Возврат Неопределено
	КонецЕсли;
	
	// Если тип неизвестен, то перебираем все справочники и документы.
	// Это долго. Поэтому тип очень хочется получить.
	Для Каждого спр из Метаданные.Справочники Цикл
		Ссылка = Справочники[спр.Имя].ПолучитьСсылку(УИД);
		Если Ссылка.ПолучитьОбъект() <> Неопределено Тогда
			Возврат Ссылка
		КонецЕсли;
	КонецЦикла;
	
	Для Каждого док из Метаданные.Документы Цикл
		Ссылка = Документы[док.Имя].ПолучитьСсылку(УИД);
		Если Ссылка.ПолучитьОбъект() <> Неопределено Тогда
			Возврат Ссылка
		КонецЕсли;
	КонецЦикла;
	
	Возврат Неопределено
КонецФункции

 

2. Разрешение пользователям редактировать отдельные реквизиты документа без перепроведения или просто одни реквизиты разрешать, а другие запрещать.

Иногда необходимо разрешить редактирование некоторых реквизитов документа без перепроведения. Например: Комментарий, АдресКонтрагента, КонтактноеЛицо. Ещё бывает необходимым разрешить изменение отдельных реквизитов в закрытых документах. Например, поставить отметку о состоянии доставки и написать комментарий.

В модуле менеджера документа пишем функцию, которая определяет массив допустимых к редактированию реквизитов

// Возвращает массив имён реквизитов, разрешённых для изменнения без перепроведения.
// Если получен параметр типа Массив, то имена реквизитов добавляются в него
Функция ПолучитьМассивРеквизитовИзменяемыхБезПерепроведения(МассивРеквизитовДопустимыхКИзменению =  Неопределено) Экспорт
	Если Не ТипЗнч(МассивРеквизитовДопустимыхКИзменению) = Тип("Массив") Тогда
		МассивРеквизитовДопустимыхКИзменению = Новый Массив;
	КонецЕсли;
	//Типовые реквизиты
	МассивРеквизитовДопустимыхКИзменению.Добавить("Грузополучатель");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьНомер");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьДата");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьНомер");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьВыдана");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьЧерезКого");
	МассивРеквизитовДопустимыхКИзменению.Добавить("Комментарий");
	МассивРеквизитовДопустимыхКИзменению.Добавить("АдресДоставки");
	//Добавленные реквизиты
	
	Возврат МассивРеквизитовДопустимыхКИзменению;
КонецФункции

В модуле ОбщегоНазначения пишем функции общие для всех документов.

// сравниваем реквизиты документа из базы данных с записываемым объектом
// имена изменённых реквизитов запихываем в массив
Функция ПолучитьСписокИзменённыхРеквизитов(ДокОбъект) Экспорт
	СписокИзменённыхРеквизитов = Новый Массив;
	
	Ссылка = ДокОбъект.Ссылка;
	мдОбъекта = ДокОбъект.Метаданные();
	// сравниваем стандартные реквизиты
	Для Каждого Реквизит из мдОбъекта.СтандартныеРеквизиты Цикл
		Если ДокОбъект[Реквизит.Имя] <> Ссылка[Реквизит.Имя] Тогда
			СписокИзменённыхРеквизитов.Добавить(Реквизит.Имя);
		КонецЕсли;
	КонецЦикла;
	
	// сравниваем реквизиты шапки
	Для Каждого Реквизит из мдОбъекта.Реквизиты Цикл
		Если ДокОбъект[Реквизит.Имя] <> Ссылка[Реквизит.Имя] Тогда
			СписокИзменённыхРеквизитов.Добавить(Реквизит.Имя);
		КонецЕсли;
	КонецЦикла;
	
	// сравниваем табличные части
	Для Каждого тч из мдОбъекта.ТабличныеЧасти Цикл
		Если ДокОбъект[тч.Имя].Количество() = Ссылка[тч.Имя].Количество() Тогда // Не добавляли и не убирали строки в тч
			Для Каждого строкаОбъекта Из ДокОбъект[тч.Имя] Цикл
				СтрокаСсылки = Ссылка[тч.Имя].Получить(строкаОбъекта.НомерСтроки - 1);
				Для Каждого Реквизит из тч.Реквизиты Цикл
					Если СтрокаСсылки[Реквизит.Имя] <> строкаОбъекта[Реквизит.Имя] Тогда
						СписокИзменённыхРеквизитов.Добавить(тч.Имя + "." + Реквизит.Имя);
					КонецЕсли;
				КонецЦикла;
			КонецЦикла;
		Иначе
			СписокИзменённыхРеквизитов.Добавить(тч.Имя);
		КонецЕсли;
	КонецЦикла;
	
	Возврат СписокИзменённыхРеквизитов;
КонецФункции

// Сравниваем массив изменённых реквизитов с массивом реквизитов, разрешённых к изменению
// возвращает пустую строку, если документ можно записывать или список изменённых реквизитов из-за которых документ нельзя записать
Функция МожноЗаписыватьБезПерепроведения(ДокОбъект, МассивРеквизитовДопустимыхКИзменению, СписокИзменённыхРеквизитов = Неопределено) Экспорт
	стр = "";
	Если СписокИзменённыхРеквизитов = Неопределено Тогда
		СписокИзменённыхРеквизитов = ПолучитьСписокИзменённыхРеквизитов(ДокОбъект);
	КонецЕсли;
	Для Каждого зн из СписокИзменённыхРеквизитов Цикл
		Если МассивРеквизитовДопустимыхКИзменению.Найти(зн) = Неопределено Тогда
			стр = стр + "
			|" + зн;
		КонецЕсли;
	КонецЦикла;
	Возврат стр;
КонецФункции

В модуле документа ПредЗаписью разрешаем запись без пререпроведения в случае, если были изменены только реквизиты, не вызывающие перепроведение.

РедактированиеЗаднимЧислом = Ложь;
МассивРеквизитовДопустимыхКИзменению = Документы.РеализацияТоваровУслуг.ПолучитьМассивРеквизитовИзменяемыхБезПерепроведения();
СписокИзменённыхРеквизитов = ОбщегоНазначения.ПолучитьСписокИзменённыхРеквизитов(ЭтотОбъект);
СписокИзменённыхРеквизитовВызывающихПерепроведение = ОбщегоНазначения.МожноЗаписыватьБезПерепроведения(ЭтотОбъект, МассивРеквизитовДопустимыхКИзменению, СписокИзменённыхРеквизитов);
Если СписокИзменённыхРеквизитовВызывающихПерепроведение = "" И Проведен И СписокИзменённыхРеквизитов.Количество() > 0 Тогда
	РежимЗаписи = РежимЗаписиДокумента.Запись;
ИначеЕсли НЕ РедактированиеЗаднимЧислом и Дата < НачалоДня(ТекущаяДата()) И Не РольДоступна("ПравоАдминистрирования") Тогда
	Сообщить("Недостаточно прав для проведения реализации " + Номер + " " + Строка(Дата) +
			" задним числом. Изменены реквизиты: " + СписокИзменённыхРеквизитовВызывающихПерепроведение);
	Отказ = Истина;
КонецЕсли;

В этой заметке не рассмотрена установка флага ТолькоПросмотр для реквизитов формы, которые нельзя редактить. Это делается сосем несложно.

Не знаю, может быть подобное решение уже есть в БСП. Не смотрел.

газета Суть Времени

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Князь 73 19.11.14 13:45 Сейчас в теме
С выбором режима проведения в зависимости от того, какие реквизиты были изменены, получилось очень необычно. Возьму на карандаш/клавиатуру. Ещё можно додумать идею и в несколько строк дополнить сию процедуру регистрацией события изменения реквизита, для детального журнала, кто когда и что именно изменил в документе.
2. Трактор 1203 19.11.14 13:49 Сейчас в теме
(1) Обрати внимание, что режим записи не меняется, если нет изменений. Это надо на случай перепроведения. А то как-то раз стукнулся, об то, что перепроведение не выполняется.
3. xzorkiix 32 19.11.14 16:57 Сейчас в теме
Из статьи узнал, что блогов нет. Зря они это. не пользовался, но в целом ветка была уместной (статьи и публикации для основательного труда, блог для мелких пометок на полях для себя и заинтересованных)
4. xzorkiix 32 19.11.14 17:04 Сейчас в теме
Функция А()
Возврат Неопределено;
КонецФункции

Эффект этого равносилен

Функция А()
КонецФункции
5. Трактор 1203 19.11.14 17:06 Сейчас в теме
(4) Читаемость кода тоже важна.
6. Armando 1393 19.11.14 21:58 Сейчас в теме
Буква ё не раскрашивается))
Ее кстати нельзя использовать в модулях.
7. Трактор 1203 19.11.14 23:32 Сейчас в теме
Ее кстати нельзя использовать в модулях.

(6) Armando, не знал. Использую. Работпет.
8. Armando 1393 20.11.14 00:00 Сейчас в теме
(7) нашел:

"4. В именах, синонимах и комментариях не допускается использовать букву "ё"."
http://its.1c.ru/db/v8std#content:2149184123:hdoc

"В текстах модулях не допускается использовать букву "ё"."
http://its.1c.ru/db/v8std#content:2149184105:hdoc
Трактор; +1 Ответить
10. Трактор 1203 20.11.14 10:39 Сейчас в теме
(8) Armando, проверил на типовой БП3. В ней есть функции ЗаменитьБуквуЁ ПодготовитьКПоискуПоФИОСБуквамиЕЁ, СтруктураПараметровДляРасчётаАпдекса. Так и называются. А в комментариях Ё встречается в полный рост. И это правильно. Незаслуженно букву обидели. 1С сама не придерживается своих рекомендаций. Но мы учтём.

(9) mtv:), хорошее решение. Замечание только одно. Объект.ОбменДанными.Загрузка = Истина возможно использовать не всегда. Если его не использовать то количество строк кода растёт.

Посмотрел на твою обработку. Редактирование с помощью функций ВвестиЧисло, ВвестиСтроку, ВвестиЗначение удобным никак никак не назовёшь. Это решение для очень редкого редактирования. Моё решение для случаев, когда вчерашние документы перепроводить нельзя, но вспомогательные данные вносить требуется.
11. ildarovich 7124 20.11.14 11:07 Сейчас в теме
(6)(10) А я вот как использовал букву ё, так и буду дальше использовать. Мне она нравится своей "нарядностью". Думаю, это ошибочная рекомендация.
SeiOkami; chernyakai; FrLenok; wolfsoft; Puk2; Светлый ум; Патриот; shootnik; Трактор; +9 Ответить
15. Князь 73 24.11.14 05:10 Сейчас в теме
(11) ildarovich, поддерживаю. С детства всем прививали, что в русском языке 33 (тридцать три) буквы. А сейчас принуждают самих себя ограничивать и незаслуженно дискредитиировать бедную букву.
И вообще, мало кто значет, что бёквё ё с лёгкёстьё мёжёт зёмёнёть всё ёстёльнёё бёквё.
albert.goncharov; BorisBelov; Светлый ум; Allexe8.1; Трактор; +5 Ответить
9. mtv:) 1012 20.11.14 08:44 Сейчас в теме
Хочу обратить Ваше внимание, что на Инфостарте есть еще одна публикация о редактировании реквизитов в закрытом периоде - "Есть ли жизнь в закрытом периоде? Или способ заставить работать "Обработку заполнения табличных частей" в закрытом периоде".
В этой публикации рассматриваются два способа:
1. С минимальными изменениями кофигурации (добавляется всего ОДНА строка!);
2. Без внесения изменений в конфигурацию.
rozer; endru; +2 Ответить
12. OdinAss 20.11.14 15:52 Сейчас в теме
Реализовывал вторую задачу внешней обработкой без изменения конфы (но новые значения реквизита пользователь выбирал в форме обработки, а не в документах) в БП 3.0. Не очень читабельно, но оставлю здесь ключевой кусок, может пригодиться кому =)

&НаСервере
Процедура УстановитьНаСервере()
	
	УстановитьПривилегированныйРежим(Истина);

// для отмены проверки даты запрета изменения можно использовать
// Док.ДополнительныеСвойства.Вставить("ПропуститьПроверкуЗапретаИзменения",
// Истина); 
// но т.к. вслед за РТУ/ПТУ перезаписываются связанные с/ф, для которых 
// доп. свойство не передать, то использовал следующее 
// (устанавливает параметр сеанса ПропуститьПроверкуЗапретаИзменения)

	ДатыЗапретаИзмененияСлужебный.ПропуститьПроверкуЗапретаИзменения(Истина);

//заполняю нужный реквизит в документах

	Для Каждого Строка Из Объект.СписокДокументов Цикл
		Если Строка.Статус <> Строка.НовСтатус 
			И Строка.НовСтатус <> Перечисления.СтатусыДокументов.ПустаяСсылка() Тогда
			Док = Строка.Документ.ПолучитьОбъект();
			Док.Статус = Строка.НовСтатус;
			Попытка
				Док.Записать(РежимЗаписиДокумента.Запись);
				Строка.Статус = Строка.НовСтатус;

// документ записан, но если период закрыт, то необходимо восстановить его 
// в последовательности проведения документов

				Если ДатыЗапретаИзмененияСлужебный.ИзменениеИлиЗагрузкаЗапрещена(Док,Док.Ссылка,Ложь) Тогда 
					ВернутьВПоследовательность(Док.Ссылка);
				КонецЕсли;

// тоже самое для счетов-фактур

				Если ТипЗнч(Док) <> Тип("ДокументОбъект.АктСверкиВзаиморасчетов") Тогда
					СчетФактура = УчетНДСПереопределяемый.НайтиПодчиненныйСчетФактуруВыданныйНаРеализацию(Док.Ссылка);
					Если СчетФактура <> Неопределено И Не СчетФактура.Пустая() Тогда
						Если ДатыЗапретаИзмененияСлужебный.ИзменениеИлиЗагрузкаЗапрещена(СчетФактура.ПолучитьОбъект(),СчетФактура,Ложь) Тогда
							ВернутьВПоследовательность(СчетФактура);
						КонецЕсли;
					КонецЕсли;
				КонецЕсли;				
			Исключение
				Сообщить("Не удалось изменить статус: " + Строка.Документ);
			КонецПопытки;
		КонецЕсли;
	КонецЦикла;

//возвращаем параметр сеанса

	ДатыЗапретаИзмененияСлужебный.ПропуститьПроверкуЗапретаИзменения(Ложь);
	УстановитьПривилегированныйРежим(Ложь);
	
КонецПроцедуры

&НаСервере
Процедура ВернутьВПоследовательность(ДокСсылка)

	НаборЗаписей = Последовательности.ДокументыОрганизаций.СоздатьНаборЗаписей();
		
	НаборЗаписей.Отбор.Регистратор.Значение = ДокСсылка;
	НаборЗаписей.Отбор.Регистратор.Использование = Истина;
	НаборЗаписей.Прочитать();
	НаборЗаписей.Очистить();
		
	Запись = НаборЗаписей.Добавить();
	//Запись.Период = Новый МоментВремени(ДокСсылка.Дата,ДокСсылка);
	Запись.Период = ДокСсылка.Дата;	
	Запись.Регистратор = ДокСсылка;
	Запись.Организация = ДокСсылка.Организация;
	Запись.СостояниеПроведения = Перечисления.СостоянияПроведенияВПоследовательности.ПроведенВПоследовательности;
	
	НаборЗаписей.Записать(Истина);
	
КонецПроцедуры
Показать
jobkostya1c8; Трактор; +2 Ответить
13. Allexe8.1 21.11.14 17:39 Сейчас в теме
Проверку на наличие ссылки в базе, думаю, лучше запросом делать:
//1) объектный способ, получаются все реквизиты, все ТЧ объекта:
НетСсылки = СсылкаНаОбъект.ПолучитьОбъект() = Неопределено

//2) метод запроса, только проверка:
Запрос = Новый Запрос("ВЫБРАТЬ ПЕРВЫЕ 1 1 ИЗ " + ИмяКласса+ "." + ИмяВида + " ГДЕ Ссылка = &Ссылка");
Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
РезультатЗапроса = Запрос.Выполнить();
НетСсылки = РезультатЗапроса.Пустой();
u_n_k_n_o_w_n; +1 Ответить
14. Трактор 1203 21.11.14 17:56 Сейчас в теме
(13) Allexe8.1,
1. СсылкаНаОбъект.ПолучитьОбъект() у меня используется. Это, кстати, довольно тяжёлый метод. Я всё думал как обойтись без него, но не придумал. Метод тяжёл так как при получении объекта происходит инициализация модуля объекта, а что там понаписал программист мы не знаем.

2. Читать запросом реквизиты ссылки, конечно прикольно, но в этом случае число запросов будет на один больше числа табличных частей объекта. А если читать реквизиты как Ссылка (точка) Имя реквизита, то значения реквизитов кэшируются и/или подтягиваются при чтении, точно не помню. Важно что число запросов к базе примерно такое же как и при чтении запросом. Только эти запросы выполняются в фоне. По сути разницы нет как читать реквизиты ссылки.
17. fishca 1183 24.11.14 15:59 Сейчас в теме
1. Тексты модулей должны быть написаны на русском языке. В текстах модулях не допускается использовать букву "ё".

Они вообще сами-то с русским языком дружат !!!???
18. DarLord 8 26.11.14 11:18 Сейчас в теме
(17) А какой оператор ты хочешь с буквой Ё написать???
19. DAnry 7 26.11.14 14:30 Сейчас в теме
Всё понимаю, вот только зачем мертвеца реанимировать (имею ввиду илюстрацию к статье)!?
22. Трактор 1203 26.11.14 15:33 Сейчас в теме
вот только зачем мертвеца реанимировать

(19) DAnry, капитализм принёс уже две мировые войны. Боюсь, что сейчас мы живём в начальный период третьей мировой войны. Капитализм смог развалить СССР. Но СССР жив пока жив, например, я и другие, разделяющие мои убеждения. Я надеюсь возродить СССР, исправив ошибки.

враньё. можно запросто создать документ и справочник с одинаковыми названиями.

(21) МихаилМ, это кусок кода и комментарий из работающей конфы. В ней имена справочников и документов не пересекаются.
Как-нибудь поправлю, уберу это замечание или напишу, что нежелательно пересекать названия.
dvsidelnikov; +1 Ответить
20. DAnry 7 26.11.14 14:51 Сейчас в теме
Насчёт буквы ё. Конечно нельзя ёё так "опускать". Это изюминка русского языка, не дайте ей исчезнуть. Сам я не русский, но думаю имею право высказать своё мнение, потому что у нас, украинцев, тоже есть похожая ситуация, даже две - "ї" и "ґ". Берегите родной язык.
BorisBelov; Allexe8.1; Трактор; +3 Ответить
21. МихаилМ 26.11.14 14:52 Сейчас в теме
"// Тип - наименование вида справочника или документа. Благо их наименования не пересекаются."

враньё. можно запросто создать документ и справочник с одинаковыми названиями.
те будут "пересекаться"
так что код условно рабочий.
Прикрепленные файлы:
23. jobkostya1c8 26.11.14 18:57 Сейчас в теме
Про доступ к сайту по ГУИД не понял. Наверное Вы говорили про доступ к базе 1С 8?
Про "перепроведение" тоже приемы могут пригодиться. Жаль что не всегда.
Вопрос как быть если конфигурация в желтых кубах "за замке" и трогать ее нельзя. Пишите что и нижеприведенный прием не помогает.

ДокОбъект.ОбменДанными.Записать = Истина;
ДокОбъект.Записать(РежимЗаписиДокумента.Запись);

Я спросил про задачи, когда нужно программно перезаполнить документы в прошлом закрытом периоде или установить значение нового реквизита.
Не всегда ведь даже признак в свойствах у документа может быть "записывать модифицированные при проведении" и прочие свойства формы документа "при записи перепроводить".
Когда все закрыто тут как быть то?
Прикрепленные файлы:
24. Трактор 1203 26.11.14 22:51 Сейчас в теме
Вопрос как быть если конфигурация в желтых кубах "за замке" и трогать ее нельзя

(23) kostyaomsk, тогда остаются только внешние обработки. О них написано выше. Можно хоть печатную форму, обработку заполнения табличной части использовать для этого. Открывать свою форму и из неё редактить что угодно.

Я не говорил, что нельзя использовать конструкцию
ОбменДанными.Записать = Истина; 

Можно. Но надо помнить о последствиях. Для распределённой базы, для логики, связанной с изменяемыми реквизитами. Короче говоря если осторожно, то можно всё.
jobkostya1c8; +1 Ответить
25. jobkostya1c8 28.11.14 07:21 Сейчас в теме
(24) спасибо, видел что можно внешними обработками реализовать такие функции записи без проведения. Возможно, в отраслевых конфигурациях опять что-то попалось из обработчиков. Проверю на типовых.
26. sas95 09.12.14 14:20 Сейчас в теме
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37611    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    28570    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    25126    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    19292    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30697    tormozit    100    

Сходство Джаро - Винклера. Нечеткое сравнение строк

Универсальные функции v8 Россия Бесплатно (free)

В области информатики и статистики сходство Джаро - Винклера представляет собой меру схожести строк для измерения расстояния между двумя последовательностями символов. В публикации рассмотрены некоторые особенности алгоритма, и представлен вариант его реализации на языке 1С.

25.12.2019    7100    brooho    17    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    17394    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8627    Sibars    19    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78294    tormozit    131    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    34508    Yashazz    50    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    12345    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    52716    rpgshnik    63    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48770    tormozit    41    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    51029    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    29383    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25808    YPermitin    80    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    45155    tormozit    74    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    32149    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    86750    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    37015    avalakh    22    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16147    m-rv    2    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    24856    json    14    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    62575    ids79    12    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    36617    ids79    27    

Excel vs 1С: битва с неожиданным исходом Промо

Анализ учета Универсальные обработки Загрузка и выгрузка в Excel Финансовые Управленческие v8 1cv8.cf Россия Бесплатно (free)

Что лучше 1С или Excel? Разберемся, в казалось бы, очевидном, чтобы получить невероятное!

11.04.2019    36750    bolefirenko    117    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    26524    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19828    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    48746    ids79    17    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20437    m-rv    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    54096    ids79    25    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    25528    dmurk    145    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    44298    YPermitin    30    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30981    m-rv    21    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35851    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27663    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31837    YPermitin    53    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28384    itriot11    34    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    40747    Смешной 1С    29    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    22518    Vladimir Litvinenko    27    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76814    Serginio    108    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    40865    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    27283    ids79    31    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    35321    ids79    40    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    42237    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    37772    ids79    42    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    91726    GeterX    121    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29436    grumagargler    28    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    49291    Unk92    25