Мелкие полезные функции

Публикация № 313753

Разработка - Практика программирования

полезняшки

87
На Инфостарте некоторое время назад существовали блоги. Я записывал заметки туда. Сейчас обнаружил, что блоги кончились. Решил перенести некоторые заметки из бога в отдельную публикацию.
Вот заметки:
1. Поиск объекта по идентификатору.
2. Разрешение пользолваателям редактировать отдельные реквизиты документа без перепроведения.

1. Получение объекта по идентификатору.

Синхронизация справочников и документов с сайтом я предпочитаю выполнять по уникальным идентификаторам. Поэтому часто необходимо получать ссылку по идентификатору. Написал для этого универсальную функцию.

// Возвращает ссылку на найденный справочник или документ или Неопределено, если объекта нет.
// Параметры
// ИД - строковое представления уникального идентификатора
// Тип - наименование вида справочника или документа. Благо их наименования не пересекаются.
Функция ПолучитьСсылкуПоИД(ИД, Тип = Неопределено)
	Если ИД = "" и Тип <> Неопределено Тогда
		// Тип известен, элемент явно пустой, значит нужно вернуть пустую ссылку
		спр = Метаданные.Справочники.Найти(Тип);
		Если спр <> Неопределено Тогда
			Возврат Справочники[Тип].ПустаяСсылка();
		КонецЕсли;
		
		док = Метаданные.Документы.Найти(Тип);
		Если док <> Неопределено Тогда
			Возврат Документы[Тип].ПустаяСсылка();
		КонецЕсли;
		Возврат Неопределено
	КонецЕсли;
	
	Попытка
		УИД = Новый УникальныйИдентификатор(ИД);
	Исключение
		Возврат Неопределено
	КонецПопытки;
	
	// Если тип известен, то ищем только в одной таблице
	Если Тип <> Неопределено Тогда
		спр = Метаданные.Справочники.Найти(Тип);
		Если спр <> Неопределено Тогда
			Ссылка = Справочники[Тип].ПолучитьСсылку(УИД);
			Если Не Ссылка.Пустая() и Ссылка.ПолучитьОбъект() <> Неопределено Тогда
				Возврат Ссылка
			КонецЕсли;
			Возврат Неопределено
		КонецЕсли;
		
		док = Метаданные.Документы.Найти(Тип);
		Если док <> Неопределено Тогда
			Ссылка = Документы[Тип].ПолучитьСсылку(УИД);
			Если Не Ссылка.Пустая() и Ссылка.ПолучитьОбъект() <> Неопределено Тогда
				Возврат Ссылка
			КонецЕсли;
		КонецЕсли;
		Возврат Неопределено
	КонецЕсли;
	
	// Если тип неизвестен, то перебираем все справочники и документы.
	// Это долго. Поэтому тип очень хочется получить.
	Для Каждого спр из Метаданные.Справочники Цикл
		Ссылка = Справочники[спр.Имя].ПолучитьСсылку(УИД);
		Если Ссылка.ПолучитьОбъект() <> Неопределено Тогда
			Возврат Ссылка
		КонецЕсли;
	КонецЦикла;
	
	Для Каждого док из Метаданные.Документы Цикл
		Ссылка = Документы[док.Имя].ПолучитьСсылку(УИД);
		Если Ссылка.ПолучитьОбъект() <> Неопределено Тогда
			Возврат Ссылка
		КонецЕсли;
	КонецЦикла;
	
	Возврат Неопределено
КонецФункции

 

2. Разрешение пользователям редактировать отдельные реквизиты документа без перепроведения или просто одни реквизиты разрешать, а другие запрещать.

Иногда необходимо разрешить редактирование некоторых реквизитов документа без перепроведения. Например: Комментарий, АдресКонтрагента, КонтактноеЛицо. Ещё бывает необходимым разрешить изменение отдельных реквизитов в закрытых документах. Например, поставить отметку о состоянии доставки и написать комментарий.

В модуле менеджера документа пишем функцию, которая определяет массив допустимых к редактированию реквизитов

// Возвращает массив имён реквизитов, разрешённых для изменнения без перепроведения.
// Если получен параметр типа Массив, то имена реквизитов добавляются в него
Функция ПолучитьМассивРеквизитовИзменяемыхБезПерепроведения(МассивРеквизитовДопустимыхКИзменению =  Неопределено) Экспорт
	Если Не ТипЗнч(МассивРеквизитовДопустимыхКИзменению) = Тип("Массив") Тогда
		МассивРеквизитовДопустимыхКИзменению = Новый Массив;
	КонецЕсли;
	//Типовые реквизиты
	МассивРеквизитовДопустимыхКИзменению.Добавить("Грузополучатель");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьНомер");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьДата");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьНомер");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьВыдана");
	МассивРеквизитовДопустимыхКИзменению.Добавить("ДоверенностьЧерезКого");
	МассивРеквизитовДопустимыхКИзменению.Добавить("Комментарий");
	МассивРеквизитовДопустимыхКИзменению.Добавить("АдресДоставки");
	//Добавленные реквизиты
	
	Возврат МассивРеквизитовДопустимыхКИзменению;
КонецФункции

В модуле ОбщегоНазначения пишем функции общие для всех документов.

// сравниваем реквизиты документа из базы данных с записываемым объектом
// имена изменённых реквизитов запихываем в массив
Функция ПолучитьСписокИзменённыхРеквизитов(ДокОбъект) Экспорт
	СписокИзменённыхРеквизитов = Новый Массив;
	
	Ссылка = ДокОбъект.Ссылка;
	мдОбъекта = ДокОбъект.Метаданные();
	// сравниваем стандартные реквизиты
	Для Каждого Реквизит из мдОбъекта.СтандартныеРеквизиты Цикл
		Если ДокОбъект[Реквизит.Имя] <> Ссылка[Реквизит.Имя] Тогда
			СписокИзменённыхРеквизитов.Добавить(Реквизит.Имя);
		КонецЕсли;
	КонецЦикла;
	
	// сравниваем реквизиты шапки
	Для Каждого Реквизит из мдОбъекта.Реквизиты Цикл
		Если ДокОбъект[Реквизит.Имя] <> Ссылка[Реквизит.Имя] Тогда
			СписокИзменённыхРеквизитов.Добавить(Реквизит.Имя);
		КонецЕсли;
	КонецЦикла;
	
	// сравниваем табличные части
	Для Каждого тч из мдОбъекта.ТабличныеЧасти Цикл
		Если ДокОбъект[тч.Имя].Количество() = Ссылка[тч.Имя].Количество() Тогда // Не добавляли и не убирали строки в тч
			Для Каждого строкаОбъекта Из ДокОбъект[тч.Имя] Цикл
				СтрокаСсылки = Ссылка[тч.Имя].Получить(строкаОбъекта.НомерСтроки - 1);
				Для Каждого Реквизит из тч.Реквизиты Цикл
					Если СтрокаСсылки[Реквизит.Имя] <> строкаОбъекта[Реквизит.Имя] Тогда
						СписокИзменённыхРеквизитов.Добавить(тч.Имя + "." + Реквизит.Имя);
					КонецЕсли;
				КонецЦикла;
			КонецЦикла;
		Иначе
			СписокИзменённыхРеквизитов.Добавить(тч.Имя);
		КонецЕсли;
	КонецЦикла;
	
	Возврат СписокИзменённыхРеквизитов;
КонецФункции

// Сравниваем массив изменённых реквизитов с массивом реквизитов, разрешённых к изменению
// возвращает пустую строку, если документ можно записывать или список изменённых реквизитов из-за которых документ нельзя записать
Функция МожноЗаписыватьБезПерепроведения(ДокОбъект, МассивРеквизитовДопустимыхКИзменению, СписокИзменённыхРеквизитов = Неопределено) Экспорт
	стр = "";
	Если СписокИзменённыхРеквизитов = Неопределено Тогда
		СписокИзменённыхРеквизитов = ПолучитьСписокИзменённыхРеквизитов(ДокОбъект);
	КонецЕсли;
	Для Каждого зн из СписокИзменённыхРеквизитов Цикл
		Если МассивРеквизитовДопустимыхКИзменению.Найти(зн) = Неопределено Тогда
			стр = стр + "
			|" + зн;
		КонецЕсли;
	КонецЦикла;
	Возврат стр;
КонецФункции

В модуле документа ПредЗаписью разрешаем запись без пререпроведения в случае, если были изменены только реквизиты, не вызывающие перепроведение.

РедактированиеЗаднимЧислом = Ложь;
МассивРеквизитовДопустимыхКИзменению = Документы.РеализацияТоваровУслуг.ПолучитьМассивРеквизитовИзменяемыхБезПерепроведения();
СписокИзменённыхРеквизитов = ОбщегоНазначения.ПолучитьСписокИзменённыхРеквизитов(ЭтотОбъект);
СписокИзменённыхРеквизитовВызывающихПерепроведение = ОбщегоНазначения.МожноЗаписыватьБезПерепроведения(ЭтотОбъект, МассивРеквизитовДопустимыхКИзменению, СписокИзменённыхРеквизитов);
Если СписокИзменённыхРеквизитовВызывающихПерепроведение = "" И Проведен И СписокИзменённыхРеквизитов.Количество() > 0 Тогда
	РежимЗаписи = РежимЗаписиДокумента.Запись;
ИначеЕсли НЕ РедактированиеЗаднимЧислом и Дата < НачалоДня(ТекущаяДата()) И Не РольДоступна("ПравоАдминистрирования") Тогда
	Сообщить("Недостаточно прав для проведения реализации " + Номер + " " + Строка(Дата) +
			" задним числом. Изменены реквизиты: " + СписокИзменённыхРеквизитовВызывающихПерепроведение);
	Отказ = Истина;
КонецЕсли;

В этой заметке не рассмотрена установка флага ТолькоПросмотр для реквизитов формы, которые нельзя редактить. Это делается сосем несложно.

Не знаю, может быть подобное решение уже есть в БСП. Не смотрел.

газета Суть Времени

87

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Князь 69 19.11.14 13:45 Сейчас в теме
С выбором режима проведения в зависимости от того, какие реквизиты были изменены, получилось очень необычно. Возьму на карандаш/клавиатуру. Ещё можно додумать идею и в несколько строк дополнить сию процедуру регистрацией события изменения реквизита, для детального журнала, кто когда и что именно изменил в документе.
2. Трактор 1191 19.11.14 13:49 Сейчас в теме
(1) Обрати внимание, что режим записи не меняется, если нет изменений. Это надо на случай перепроведения. А то как-то раз стукнулся, об то, что перепроведение не выполняется.
3. xzorkiix 32 19.11.14 16:57 Сейчас в теме
Из статьи узнал, что блогов нет. Зря они это. не пользовался, но в целом ветка была уместной (статьи и публикации для основательного труда, блог для мелких пометок на полях для себя и заинтересованных)
4. xzorkiix 32 19.11.14 17:04 Сейчас в теме
Функция А()
Возврат Неопределено;
КонецФункции

Эффект этого равносилен

Функция А()
КонецФункции
5. Трактор 1191 19.11.14 17:06 Сейчас в теме
(4) Читаемость кода тоже важна.
6. Armando 1391 19.11.14 21:58 Сейчас в теме
Буква ё не раскрашивается))
Ее кстати нельзя использовать в модулях.
7. Трактор 1191 19.11.14 23:32 Сейчас в теме
Ее кстати нельзя использовать в модулях.

(6) Armando, не знал. Использую. Работпет.
8. Armando 1391 20.11.14 00:00 Сейчас в теме
(7) нашел:

"4. В именах, синонимах и комментариях не допускается использовать букву "ё"."
http://its.1c.ru/db/v8std#content:2149184123:hdoc

"В текстах модулях не допускается использовать букву "ё"."
http://its.1c.ru/db/v8std#content:2149184105:hdoc
Трактор; +1 Ответить
10. Трактор 1191 20.11.14 10:39 Сейчас в теме
(8) Armando, проверил на типовой БП3. В ней есть функции ЗаменитьБуквуЁ ПодготовитьКПоискуПоФИОСБуквамиЕЁ, СтруктураПараметровДляРасчётаАпдекса. Так и называются. А в комментариях Ё встречается в полный рост. И это правильно. Незаслуженно букву обидели. 1С сама не придерживается своих рекомендаций. Но мы учтём.

(9) mtv:), хорошее решение. Замечание только одно. Объект.ОбменДанными.Загрузка = Истина возможно использовать не всегда. Если его не использовать то количество строк кода растёт.

Посмотрел на твою обработку. Редактирование с помощью функций ВвестиЧисло, ВвестиСтроку, ВвестиЗначение удобным никак никак не назовёшь. Это решение для очень редкого редактирования. Моё решение для случаев, когда вчерашние документы перепроводить нельзя, но вспомогательные данные вносить требуется.
11. ildarovich 6718 20.11.14 11:07 Сейчас в теме
(6)(10) А я вот как использовал букву ё, так и буду дальше использовать. Мне она нравится своей "нарядностью". Думаю, это ошибочная рекомендация.
SeiOkami; and-blag; FrLenok; wolfsoft; Puk2; Светлый ум; Патриот; shootnik; Трактор; +9 Ответить
15. Князь 69 24.11.14 05:10 Сейчас в теме
(11) ildarovich, поддерживаю. С детства всем прививали, что в русском языке 33 (тридцать три) буквы. А сейчас принуждают самих себя ограничивать и незаслуженно дискредитиировать бедную букву.
И вообще, мало кто значет, что бёквё ё с лёгкёстьё мёжёт зёмёнёть всё ёстёльнёё бёквё.
albert.goncharov; BorisBelov; Светлый ум; Allexe8.1; Трактор; +5 Ответить
9. mtv:) 997 20.11.14 08:44 Сейчас в теме
Хочу обратить Ваше внимание, что на Инфостарте есть еще одна публикация о редактировании реквизитов в закрытом периоде - "Есть ли жизнь в закрытом периоде? Или способ заставить работать "Обработку заполнения табличных частей" в закрытом периоде".
В этой публикации рассматриваются два способа:
1. С минимальными изменениями кофигурации (добавляется всего ОДНА строка!);
2. Без внесения изменений в конфигурацию.
rozer; endru; +2 Ответить
12. OdinAss 20.11.14 15:52 Сейчас в теме
Реализовывал вторую задачу внешней обработкой без изменения конфы (но новые значения реквизита пользователь выбирал в форме обработки, а не в документах) в БП 3.0. Не очень читабельно, но оставлю здесь ключевой кусок, может пригодиться кому =)

&НаСервере
Процедура УстановитьНаСервере()
	
	УстановитьПривилегированныйРежим(Истина);

// для отмены проверки даты запрета изменения можно использовать
// Док.ДополнительныеСвойства.Вставить("ПропуститьПроверкуЗапретаИзменения",
// Истина); 
// но т.к. вслед за РТУ/ПТУ перезаписываются связанные с/ф, для которых 
// доп. свойство не передать, то использовал следующее 
// (устанавливает параметр сеанса ПропуститьПроверкуЗапретаИзменения)

	ДатыЗапретаИзмененияСлужебный.ПропуститьПроверкуЗапретаИзменения(Истина);

//заполняю нужный реквизит в документах

	Для Каждого Строка Из Объект.СписокДокументов Цикл
		Если Строка.Статус <> Строка.НовСтатус 
			И Строка.НовСтатус <> Перечисления.СтатусыДокументов.ПустаяСсылка() Тогда
			Док = Строка.Документ.ПолучитьОбъект();
			Док.Статус = Строка.НовСтатус;
			Попытка
				Док.Записать(РежимЗаписиДокумента.Запись);
				Строка.Статус = Строка.НовСтатус;

// документ записан, но если период закрыт, то необходимо восстановить его 
// в последовательности проведения документов

				Если ДатыЗапретаИзмененияСлужебный.ИзменениеИлиЗагрузкаЗапрещена(Док,Док.Ссылка,Ложь) Тогда 
					ВернутьВПоследовательность(Док.Ссылка);
				КонецЕсли;

// тоже самое для счетов-фактур

				Если ТипЗнч(Док) <> Тип("ДокументОбъект.АктСверкиВзаиморасчетов") Тогда
					СчетФактура = УчетНДСПереопределяемый.НайтиПодчиненныйСчетФактуруВыданныйНаРеализацию(Док.Ссылка);
					Если СчетФактура <> Неопределено И Не СчетФактура.Пустая() Тогда
						Если ДатыЗапретаИзмененияСлужебный.ИзменениеИлиЗагрузкаЗапрещена(СчетФактура.ПолучитьОбъект(),СчетФактура,Ложь) Тогда
							ВернутьВПоследовательность(СчетФактура);
						КонецЕсли;
					КонецЕсли;
				КонецЕсли;				
			Исключение
				Сообщить("Не удалось изменить статус: " + Строка.Документ);
			КонецПопытки;
		КонецЕсли;
	КонецЦикла;

//возвращаем параметр сеанса

	ДатыЗапретаИзмененияСлужебный.ПропуститьПроверкуЗапретаИзменения(Ложь);
	УстановитьПривилегированныйРежим(Ложь);
	
КонецПроцедуры

&НаСервере
Процедура ВернутьВПоследовательность(ДокСсылка)

	НаборЗаписей = Последовательности.ДокументыОрганизаций.СоздатьНаборЗаписей();
		
	НаборЗаписей.Отбор.Регистратор.Значение = ДокСсылка;
	НаборЗаписей.Отбор.Регистратор.Использование = Истина;
	НаборЗаписей.Прочитать();
	НаборЗаписей.Очистить();
		
	Запись = НаборЗаписей.Добавить();
	//Запись.Период = Новый МоментВремени(ДокСсылка.Дата,ДокСсылка);
	Запись.Период = ДокСсылка.Дата;	
	Запись.Регистратор = ДокСсылка;
	Запись.Организация = ДокСсылка.Организация;
	Запись.СостояниеПроведения = Перечисления.СостоянияПроведенияВПоследовательности.ПроведенВПоследовательности;
	
	НаборЗаписей.Записать(Истина);
	
КонецПроцедуры
Показать
jobkostya1c8; Трактор; +2 Ответить
13. Allexe8.1 21.11.14 17:39 Сейчас в теме
Проверку на наличие ссылки в базе, думаю, лучше запросом делать:
//1) объектный способ, получаются все реквизиты, все ТЧ объекта:
НетСсылки = СсылкаНаОбъект.ПолучитьОбъект() = Неопределено

//2) метод запроса, только проверка:
Запрос = Новый Запрос("ВЫБРАТЬ ПЕРВЫЕ 1 1 ИЗ " + ИмяКласса+ "." + ИмяВида + " ГДЕ Ссылка = &Ссылка");
Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
РезультатЗапроса = Запрос.Выполнить();
НетСсылки = РезультатЗапроса.Пустой();
u_n_k_n_o_w_n; +1 Ответить
14. Трактор 1191 21.11.14 17:56 Сейчас в теме
(13) Allexe8.1,
1. СсылкаНаОбъект.ПолучитьОбъект() у меня используется. Это, кстати, довольно тяжёлый метод. Я всё думал как обойтись без него, но не придумал. Метод тяжёл так как при получении объекта происходит инициализация модуля объекта, а что там понаписал программист мы не знаем.

2. Читать запросом реквизиты ссылки, конечно прикольно, но в этом случае число запросов будет на один больше числа табличных частей объекта. А если читать реквизиты как Ссылка (точка) Имя реквизита, то значения реквизитов кэшируются и/или подтягиваются при чтении, точно не помню. Важно что число запросов к базе примерно такое же как и при чтении запросом. Только эти запросы выполняются в фоне. По сути разницы нет как читать реквизиты ссылки.
17. fishca 1154 24.11.14 15:59 Сейчас в теме
1. Тексты модулей должны быть написаны на русском языке. В текстах модулях не допускается использовать букву "ё".

Они вообще сами-то с русским языком дружат !!!???
18. DarLord 8 26.11.14 11:18 Сейчас в теме
(17) А какой оператор ты хочешь с буквой Ё написать???
19. DAnry 6 26.11.14 14:30 Сейчас в теме
Всё понимаю, вот только зачем мертвеца реанимировать (имею ввиду илюстрацию к статье)!?
22. Трактор 1191 26.11.14 15:33 Сейчас в теме
вот только зачем мертвеца реанимировать

(19) DAnry, капитализм принёс уже две мировые войны. Боюсь, что сейчас мы живём в начальный период третьей мировой войны. Капитализм смог развалить СССР. Но СССР жив пока жив, например, я и другие, разделяющие мои убеждения. Я надеюсь возродить СССР, исправив ошибки.

враньё. можно запросто создать документ и справочник с одинаковыми названиями.

(21) МихаилМ, это кусок кода и комментарий из работающей конфы. В ней имена справочников и документов не пересекаются.
Как-нибудь поправлю, уберу это замечание или напишу, что нежелательно пересекать названия.
20. DAnry 6 26.11.14 14:51 Сейчас в теме
Насчёт буквы ё. Конечно нельзя ёё так "опускать". Это изюминка русского языка, не дайте ей исчезнуть. Сам я не русский, но думаю имею право высказать своё мнение, потому что у нас, украинцев, тоже есть похожая ситуация, даже две - "ї" и "ґ". Берегите родной язык.
BorisBelov; Allexe8.1; Трактор; +3 Ответить
21. МихаилМ 26.11.14 14:52 Сейчас в теме
"// Тип - наименование вида справочника или документа. Благо их наименования не пересекаются."

враньё. можно запросто создать документ и справочник с одинаковыми названиями.
те будут "пересекаться"
так что код условно рабочий.
Прикрепленные файлы:
23. jobkostya1c8 26.11.14 18:57 Сейчас в теме
Про доступ к сайту по ГУИД не понял. Наверное Вы говорили про доступ к базе 1С 8?
Про "перепроведение" тоже приемы могут пригодиться. Жаль что не всегда.
Вопрос как быть если конфигурация в желтых кубах "за замке" и трогать ее нельзя. Пишите что и нижеприведенный прием не помогает.

ДокОбъект.ОбменДанными.Записать = Истина;
ДокОбъект.Записать(РежимЗаписиДокумента.Запись);

Я спросил про задачи, когда нужно программно перезаполнить документы в прошлом закрытом периоде или установить значение нового реквизита.
Не всегда ведь даже признак в свойствах у документа может быть "записывать модифицированные при проведении" и прочие свойства формы документа "при записи перепроводить".
Когда все закрыто тут как быть то?
Прикрепленные файлы:
24. Трактор 1191 26.11.14 22:51 Сейчас в теме
Вопрос как быть если конфигурация в желтых кубах "за замке" и трогать ее нельзя

(23) kostyaomsk, тогда остаются только внешние обработки. О них написано выше. Можно хоть печатную форму, обработку заполнения табличной части использовать для этого. Открывать свою форму и из неё редактить что угодно.

Я не говорил, что нельзя использовать конструкцию
ОбменДанными.Записать = Истина; 

Можно. Но надо помнить о последствиях. Для распределённой базы, для логики, связанной с изменяемыми реквизитами. Короче говоря если осторожно, то можно всё.
jobkostya1c8; +1 Ответить
25. jobkostya1c8 28.11.14 07:21 Сейчас в теме
(24) спасибо, видел что можно внешними обработками реализовать такие функции записи без проведения. Возможно, в отраслевых конфигурациях опять что-то попалось из обработчиков. Проверю на типовых.
26. sas95 09.12.14 14:20 Сейчас в теме
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 315

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9669    ids79    42       

Три костыля. Сказ про фокусы в коде 121

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    7650    YPermitin    67       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    8020    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 240

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    10035    ids79    22       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    9032    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 134

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8508    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6140    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 190

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17151    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 176

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11404    dmurk    134       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    17063    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9672    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4725    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7240    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16199    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12595    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12703    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 162

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15269    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12587    ids79    27       

Новый подход к обмену данными EnterpriseData 202

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21197    ids79    72       

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке 463

Статья Программист Нет файла v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные функции

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    31423    GeterX    93       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19378    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 125

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20697    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20335    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14467    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    21052    Rain88    42       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19194    olegtymko    43       

Введение в механизм представлений в ЗУП ред. 3 152

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24204    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21084    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16850    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11253    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24149    avfed@rambler.ru    19       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35395    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 108

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25746    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21230    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 720

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    136989    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22576    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 66

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    20954    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    23919    json    9       

Работа с Excel 287

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24465    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46549    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 127

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    18133    vardeg    31       

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере 125

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    34107    tormozit    72       

Ускоряем 1С: модули с повторным использованием возвращаемых значений 136

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    42975    m-rv    60