Отправка отчетов по заданному расписанию

Публикация № 399471

Разработка - Практика программирования

Не всегда есть возможность использовать регламентные задания для выполнения заданий по расписанию. Вашему вниманию представлен простой пример организации этого процесса с минимальными доработками системы. Есть только одно ограничение, должна быть запущена 1С (в моем примере под определенным пользователем). Регламентных заданий может быть неограниченное количество, т.к обработки заданий добавляются во внешние обработки.

1. В конфигурацию необходимо добавить  регистр сведений "ОтправкаОтчетов" (регистр "Непереодический", "Независимый"). 

    1.1 Добавить измерение "Внешняя обработка" (тип "СправочникСсылка.ВнешниеОбработки")

    1.2 Добавить ресурс "ДатаОтправки" (Тип "Дата);

2. В модуле обычного приложения добавить процедуру "Отправка отчетов".

    2.1. Данная процедура получает внешнюю обработку по имени

    2.2. Запускает процедуру внешней обработки (В моем примере все внешние обработки имеют процедуру "СформироватьОтчет()"

   2.3. Обновляет в регистре сведений дату отправки.

Процедура ОтправкаОтчетов() экспорт

Если СокрЛП(Константы.ИмяКомпьютераРеглЗаданий.Получить())<>Строка(ПользователиИнформационнойБазы.ТекущийПользователь()) Тогда 
Возврат;
КонецЕсли;
//Выборка списка отчетов
СписокОтчетов=РегистрыСведений.ОтправкаОтчетов.Выбрать();
Пока СписокОтчетов.Следующий() Цикл 
НадоОтправлять=ложь;
Если НачалоДня(СписокОтчетов.ДатаОтправки)<НачалоДня(ТекущаяДата()) тогда
Дт1=НачалоДня(СписокОтчетов.ДатаОтправки);
Дт2=КонецДня(СписокОтчетов.ДатаОтправки);
НадоОтправлять=Истина;
ИначеЕсли (НачалоДня(СписокОтчетов.ДатаОтправки)=НачалоДня(ТекущаяДата())) и (СписокОтчетов.ДатаОтправки<=ТекущаяДата()) Тогда 
Дт1=НачалоДня(ТекущаяДата());
Дт2=КонецДня(ТекущаяДата());
НадоОтправлять=Истина;
КонецЕсли;
Если НадоОтправлять=Истина Тогда 
ИмяФайла="C:\Temp\"+СокрЛП(СписокОтчетов.ВнешняяОбработка.Наименование)+".epf";
ВнешнийФайл=СписокОтчетов.ВнешняяОбработка.ХранилищеВнешнейОбработки.Получить();
ВнешнийФайл.Записать(ИмяФайла);
Обработка=ВнешниеОбработки.Создать(ИмяФайла);
Обработка.Дт1=Дт1;
Обработка.Дт2=Дт2;
Обработка.СформироватьОтчет();
//Обновляем регистрСведений
МенеджерЗаписи=СписокОтчетов.ПолучитьМенеджерЗаписи();
МенеджерЗаписи.Прочитать();
МенеджерЗаписи.ДатаОтправки=СписокОтчетов.ДатаОтправки+60*60*24;
МенеджерЗаписи.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры

3. В модуле обычного приложения необходимо подключить обработчик ожидания

ПодключитьОбработчикОжидания("ОтправкаОтчетов",120);

4. Пример Процедуры внешней обработки. (В приведенном примере, внешняя обработка производит формирования данных по продажам на основании универсального отчета) (Процедура должна находиться в модуле обработки)

Процедура СформироватьОтчет() экспорт
//Формирования Тотал
СЗФайлы=Новый СписокЗначений;
Табл=Новый ТабличныйДокумент; 
УниверсальныйОтчет=Отчеты.УниверсальныйОтчет.Создать();//.ЭтотОбъект.СформироватьОтчет(Табл);
/////////////////////////
УниверсальныйОтчет.мНазваниеОтчета = СокрЛП("Продажи");
УниверсальныйОтчет.мВыбиратьИмяРегистра = Ложь;
УниверсальныйОтчет.ИмяРегистра = "Продажи";
УниверсальныйОтчет.ДобавитьПолеГруппировка("НоменклатураБазоваяЕдиницаИзмерения", "Номенклатура", "БазоваяЕдиницаИзмерения", "Базовая единица измерения");
// Заполнение начальных настроек универсального отчета
УниверсальныйОтчет.УстановитьНачальныеНастройки(Истина);
УниверсальныйОтчет.ПоказыватьЗаголовок=Истина;
ВалютаУпр = Константы.ВалютаУправленческогоУчета.Получить().Наименование;
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоОборот","Количество", Истина);
УниверсальныйОтчет.ДобавитьПоказатель("НДСОборот", "НДС", Ложь);
УниверсальныйОтчет.ДобавитьПоказатель("СтоимостьБезСкидокОборот", "Сумма продажи без скидок в " + ВалютаУпр,ложь);
УниверсальныйОтчет.ДобавитьПоказатель("КоличествоОборот","Количество", Истина);
//УниверсальныйОтчет.ДобавитьПоказатель("Контрагент", "Контрагент", Истина);

УниверсальныйОтчет.ДобавитьИзмерениеСтроки("Подразделение");
УниверсальныйОтчет.ДобавитьИзмерениеСтроки("ДокументПродажи.Ответственный");
//УниверсальныйОтчет.ДобавитьИзмерениеСтроки("ДокументПродажи");

УниверсальныйОтчет.ДобавитьОтбор("Контрагент");
УниверсальныйОтчет.ДобавитьОтбор("Проект");
УниверсальныйОтчет.ДобавитьОтбор("Подразделение");

УниверсальныйОтчет.ДобавитьПорядок("Контрагент.Наименование");
УниверсальныйОтчет.ДобавитьПорядок("Номенклатура.Наименование");
УниверсальныйОтчет.ДобавитьДополнительноеПоле("НоменклатураБазоваяЕдиницаИзмерения");
//
//УниверсальныйОтчет.ИмяРегистра="Продажи";
УниверсальныйОтчет.ДатаНач=НачалоДня(Дт1);//Дата('20080801000000');
УниверсальныйОтчет.ДатаКон=КонецДня(Дт2);//Дата('20080801235959');
УниверсальныйОтчет.СформироватьОтчет(Табл);
УниверсальныйОтчет.УправлениеОтображениемЗаголовка(УниверсальныйОтчет, Табл);

КаталогНаДиске = Новый Файл("C:\Otchet1C");
Если не КаталогНаДиске.Существует() Тогда
СоздатьКаталог("C:\Otchet1C");
КонецЕсли;

ИмяФайла="ТОТАЛ_"+Строка(Формат(УниверсальныйОтчет.ДатаНач,"ДФ=ddMMyy"))+".xls";
Табл.Записать("C:\Otchet1C\"+ИмяФайла,ТипФайлаТабличногоДокумента.XLS);
СЗФайлы.Добавить("C:\Otchet1C\"+ИмяФайла,ИмяФайла);

ИПП = Новый ИнтернетПочтовыйПрофиль;
ИПП.АдресСервераSMTP ="Свои данные";
ИПП.ПарольSMTP = "пароль";
ИПП.ПользовательSMTP = "пользователь";
ИПП.ПортSMTP = 25;
ИПП.АутентификацияSMTP = СпособSMTPАутентификации.Login;

Сообщение = Новый ИнтернетПочтовоеСообщение;
Сообщение.Получатели.Добавить("Эл.адрес получателя");
Сообщение.Получатели.Добавить("Эл.адрес получателя");
Сообщение.Получатели.Добавить("Эл.адрес получателя");


Сообщение.Отправитель.Адрес = "Адрес отправителя";
Сообщение.Тема = "Тотал продаж за период с "+Строка(Формат(Дт1,"ДФ=dd.MM.yyyy"))+" по "+Строка(Формат(дт2,"ДФ=dd.MM.yyyy"));
//СЗФайлы=Новый СписокЗначений;
Для каждого СписокФайлов из СЗФайлы Цикл 
ДД=Новый ДвоичныеДанные("C:\Otchet1C\"+СписокФайлов);
Сообщение.Вложения.Добавить(ДД,ИмяФайла);
КонецЦикла;
Сообщение.Тексты.Добавить("Данные сформированы автоматически - "+ТекущаяДата());

Почта = Новый ИнтернетПочта;
Почта.Подключиться(ИПП);
Почта.Послать(Сообщение);
Почта.Отключиться();
КонецПроцедуры

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. vec435 15 23.09.15 09:34 Сейчас в теме
другой вариант: 1) создать ярлык с запуском 1с и определенной обработки 2) запускать этот ярлык по расписанию в назначенные задания Windows
можно запускать ярлык с определенными параметрами
2. andreyrosp 10 23.09.15 12:57 Сейчас в теме
(1) vec435, Бесспорно! Можно использовать и Ваш метод. Я использовал обработчик ожидания для возможности контроля и переотправки данных при каких-либо внештатных ситуациях (При отправке писем, может отсутствовать подключение к интернету, ошибки доступа к серверу...).Можно реализовать это все и с помощью вашего метода (все зависит от поставленных задач). Если есть возможность внесения изменений в конфигурацию, то лучше, на мой взгляд, использовать мой метод, т.к нет строгой привязки к ПК, а ели конфигурация находится на поддержке, тогда Ваш метод бесспорно выигрывает. Каждый выбирает самостоятельно реализацию поставленной задачи...
Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    4323    comol    22    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    10827    quazare    33    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    35349    user5300    16    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    38965    ids79    26    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38438    unichkin    74    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    30442    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    23158    kuzyara    38    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    18791    YPermitin    60    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    32038    tormozit    104    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    9830    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    33131    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    40071    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    79282    tormozit    131    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    14543    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    66920    rpgshnik    68    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    58110    ids79    55    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    50043    tormozit    48    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    33165    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    27039    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    35209    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    46705    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    106535    ids79    63    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    43849    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    29102    json    15    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16415    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    75687    ids79    14    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    39870    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    28311    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20947    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20400    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    59010    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    60319    ids79    26    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    32282    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    27012    dmurk    146    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    49565    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    37811    ellavs    126    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28837    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    28586    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    34448    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    48350    Смешной 1С    31    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    78351    Serginio    113    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    24116    Vladimir Litvinenko    28    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    37361    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    46245    ids79    11    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    28956    ids79    31    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    30121    grumagargler    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    45688    ids79    74