Цикл ввода данных, пример решения

Публикация № 535155

Разработка - Практика программирования

8.3 ввод данных

Отказ от модальности создает проблему организации последовательного ввода данных в рамках одной пользовательской операции. Цепочки процедур, обрабатывающих введенные данные и вызывающие следующий диалог - головная боль даже для самостоятельной поддержки или изменения логики ввода, не говоря о том уже, чтобы разбираться в чужом коде. Предлагаемое решение является некой заготовкой и может быть любым образом улучшено.

Данная тема уже обсуждалась //infostart.ru/public/305935/, но, столкнувшись с проблемой в реальной разработке, я решил изобретать свой "велосипед" =)

Основной целью являлось:

  • создание некого общего модуля, который будет отвечать непосредственно за организацию и контроль цикла ввода данных;
  • возможность запустить цикл на любое количество итерации обращений к пользователю и обработать результ ввода в 2 процедуры.
Начнем с разбора общего модуля "ВводДанныхКлиент":
//_____________________________________________________________
#Область ПрограммныйИнтерфейс

// Шаблон структуры, описывающий каждую итерацию ввода данных 
// 
&НаКлиенте
Функция ПолучитьШаблонОжидаемогоВвода() Экспорт
	
	Результат = Новый Структура;
	
	Результат.Вставить("Ключ", "");
	Результат.Вставить("Владелец", Неопределено);
	Результат.Вставить("ОбработчикВвода", "");
	
	Результат.Вставить("СписокЗначений", Новый СписокЗначений);
	
	Результат.Вставить("ОткрываемаяФорма", "");
	Результат.Вставить("ПараметрыФормы", Новый Структура);
	
	Результат.Вставить("ЧислоДлина", 0);
	Результат.Вставить("ЧислоТочность", 0);
	
	Результат.Вставить("Подсказка", "");
	Результат.Вставить("ПроизвольныйПараметр", Неопределено);
	
	Результат.Вставить("РежимДиалогаВопрос", РежимДиалогаВопрос.ДаНет);
	
	Результат.Вставить("Обязательный", Ложь);
	Результат.Вставить("ФлагЗавершения", Ложь);
	Результат.Вставить("ПостОбработка", Ложь);
	Результат.Вставить("Результат", Неопределено);
	
	Возврат Результат
	
КонецФункции

// Главная процедура. Является как и стартом цикла, так и обработкой каждой последующей итерации
//
// 	- ТочкаВозврата 		: структура, определяющая объект и имя его экспортной процедуры, 
//							куда передаются итоги ввода данных
// 	- МассивОжидаемогоВвода : массив структур из функции "ПолучитьШаблонОжидаемогоВвода", 
//							определяет действия и их поряд по вводу данных
// 	- СквозныеДанные		: служебная Структура("ФлагЗавершения, Ключ, Результат, ТочкаВозврата, МассивОжидаемогоВвода"), 
//							через нее возврат введенных в цикл 
//
&НаКлиенте
Процедура ЗапуститьЦикл(ТочкаВозврата, МассивОжидаемогоВвода, СквозныеДанные = Неопределено) Экспорт
	
	// проверка возврата в цикл после ввода данных
	Если СквозныеДанные <> Неопределено Тогда
		
		// запищем результат
		Для Каждого ОбработкаВвода Из МассивОжидаемогоВвода Цикл
			
			Если ОбработкаВвода.Ключ = СквозныеДанные.Ключ Тогда
				
				Если ОбработкаВвода.Обязательный И СквозныеДанные.Результат = Неопределено Тогда
					ОбработкаВвода.ФлагЗавершения = Ложь;
				Иначе
					
					ОбработкаВвода.ФлагЗавершения = СквозныеДанные.ФлагЗавершения;
					ОбработкаВвода.Результат = СквозныеДанные.Результат;
				
				КонецЕсли;
				
				Прервать;
				
			КонецЕсли; 
			
		КонецЦикла;
		
	КонецЕсли; 
	
	ВводЗакончен = Истина;
	
	// поиск и запуск следующей итерации ввода данных
	Для Каждого ОбработкаВвода Из МассивОжидаемогоВвода Цикл
		
		Если ОбработкаВвода.ФлагЗавершения И НЕ ОбработкаВвода.ПостОбработка Тогда
			Продолжить;
		ИначеЕсли ОбработкаВвода.ФлагЗавершения И ОбработкаВвода.ПостОбработка Тогда
			
			Выполнить("ТочкаВозврата.Объект." + ТочкаВозврата.ИмяПроцедуры + "(МассивОжидаемогоВвода)");
			Возврат;
			
		КонецЕсли;
		
		ВводЗакончен = Ложь;
		
		СквозныеДанные = Новый Структура("ФлагЗавершения, Ключ, Результат, ТочкаВозврата, МассивОжидаемогоВвода");
		
		СквозныеДанные.ФлагЗавершения = Ложь;
		СквозныеДанные.Ключ = ОбработкаВвода.Ключ;
		СквозныеДанные.Результат = Неопределено;
		СквозныеДанные.ТочкаВозврата = ТочкаВозврата;
		СквозныеДанные.МассивОжидаемогоВвода = МассивОжидаемогоВвода;
		
		Если ОбработкаВвода.ОбработчикВвода = "ВыборИзФормы" Тогда
			ВыборИзФормы(ОбработкаВвода.ОткрываемаяФорма, ОбработкаВвода.ПараметрыФормы, ОбработкаВвода.Владелец, СквозныеДанные);
		ИначеЕсли ОбработкаВвода.ОбработчикВвода = "ВыборИзСписка" Тогда
			ВыборИзСписка(ОбработкаВвода.СписокЗначений, ОбработкаВвода.Владелец, СквозныеДанные);
		ИначеЕсли ОбработкаВвода.ОбработчикВвода = "ВводСтроки" Тогда
			ВводСтроки(ОбработкаВвода.Подсказка, СквозныеДанные);
		ИначеЕсли ОбработкаВвода.ОбработчикВвода = "ВводЧисла" Тогда
			ВводЧисла(ОбработкаВвода.Подсказка, ОбработкаВвода.ЧислоДлина, ОбработкаВвода.ЧислоТочность, СквозныеДанные);
		ИначеЕсли ОбработкаВвода.ОбработчикВвода = "ОтветНаВопрос" Тогда
			ОтветНаВопрос(ОбработкаВвода.Подсказка, ОбработкаВвода.РежимДиалогаВопрос, СквозныеДанные);
		КонецЕсли;
		
		Прервать;
		
	КонецЦикла;
	
	// если все то возвращаем в точку возврата все введенные данные
	Если ВводЗакончен Тогда
		Выполнить("ТочкаВозврата.Объект." + ТочкаВозврата.ИмяПроцедуры + "(МассивОжидаемогоВвода)");	
	КонецЕсли; 
	
КонецПроцедуры

#КонецОбласти 

//_____________________________________________________________
#Область Диалоги

// Тут довольно все очевидно, обработка необбходимости вода данных
// с шаблонным возвратом в цикл

&НаКлиенте
Процедура ВыборИзФормы(ОткрываемаяФорма, ПараметрыФормы, Владелец, СквозныеДанные)
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ВыборИзФормы_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ОткрытьФорму(ОткрываемаяФорма, ПараметрыФормы, Владелец, , , , ОписаниеОповещения, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
	
КонецПроцедуры

&НаКлиенте
Процедура ВыборИзСписка(СписокВыбора, Владелец, СквозныеДанные)
	
	ПараметрыФормы = Новый Структура("СписокВыбора", СписокВыбора);
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ВыборИзСписка_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ОткрытьФорму("ОбщаяФорма.ФормаВыбораИзСписка", ПараметрыФормы, Владелец, , , , ОписаниеОповещения, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
		
КонецПроцедуры

&НаКлиенте
Процедура ВводСтроки(Подсказка, СквозныеДанные)
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ВводСтроки_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ПоказатьВводСтроки(ОписаниеОповещения, "", Подсказка);
	
КонецПроцедуры

&НаКлиенте
Процедура ВводЧисла(Подсказка, Длина, Точность, СквозныеДанные)
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ВводЧисла_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ПоказатьВводЧисла(ОписаниеОповещения, 0, Подсказка, Длина, Точность);
	
КонецПроцедуры

&НаКлиенте
Процедура ОтветНаВопрос(Подсказка, Кнопки, СквозныеДанные)
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ОтветНаВопрос_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ПоказатьВопрос(ОписаниеОповещения, Подсказка, Кнопки);
	
КонецПроцедуры

#КонецОбласти 

//_____________________________________________________________
#Область ОбработкиОповещений

// Закрывашки наших диалогов

&НаКлиенте
Процедура ВыборИзФормы_Завершение(ВыбЗнач, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = ВыбЗнач;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры

&НаКлиенте
Процедура ВыборИзСписка_Завершение(ВыбЗнач, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = ВыбЗнач;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры
 
&НаКлиенте
Процедура ВводСтроки_Завершение(ВведеннаяСтрока, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = ВведеннаяСтрока;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры 

&НаКлиенте
Процедура ВводЧисла_Завершение(ВведеннаяСтрока, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = ВведеннаяСтрока;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры 

&НаКлиенте
Процедура ОтветНаВопрос_Завершение(Ответ, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = Ответ;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры 

#КонецОбласти 

Теперь расмотрим живой пример изспользования данного модуля. 

Решим следующую задачу: при выборе товара в корзину нужно сразу запросить необходимое количество, спросить о необходимости поставить товар в резерв и, если будет положительный ответ, то дать выбрать место размещения товара.

Получаем следующие итерации ввода:

  • ввести число;
  • диалог вопроса;
  • если на диалог был ответ да, то выбрать ссылку.

Приступим.

&НаКлиенте
Процедура ТоварыПриИзменении(Элемент)
	
	// Товар был добавлен в корзину. 
	// Запросим необходимые данные.
	ЗапроситьДанные();
	
КонецПроцедуры

// Можно считать шаблоном. Обязательно экспортная, т.к. тут же происходит 
// пост-обработка итерации ввода данных (если была включена такая опция).
//
// - МассивОжидаемогоВвода   : 	параметр как флаг, либо это первый запуск, 
//								либо пост-обработка, либо завершение цикла
//
&НаКлиенте
Процедура ЗапроситьДанные(МассивОжидаемогоВвода = Неопределено) Экспорт
		
	// возврат происходит в эту же процедуру 
	ТочкаВозврата = Новый Структура("ИмяПроцедуры, Объект");
	
	ТочкаВозврата.ИмяПроцедуры = "ЗапроситьДанные";
	ТочкаВозврата.Объект = ЭтотОбъект;
	
	// проверка параметра
	Если МассивОжидаемогоВвода = Неопределено Тогда
		
		// первый запуск
		МассивОжидаемогоВвода = Новый Массив;
		
		// ожидаем ввода количества
		НовыйВводДаных = ВводДанныхКлинет.ПолучитьШаблонОжидаемогоВвода();
		
		НовыйВводДаных.Ключ = "КоличествоТовара";
		НовыйВводДаных.Владелец = ЭтаФорма;
		НовыйВводДаных.ОбработчикВвода = "ВводЧисла"; // наш тип обработчика
		НовыйВводДаных.ЧислоДлина = 5;
		
		МассивОжидаемогоВвода.Добавить(НовыйВводДаных);
		
		// спрашиваем
		НовыйВводДаных = ВводДанныхКлинет.ПолучитьШаблонОжидаемогоВвода();
		
		НовыйВводДаных.Ключ = "Вопрос";
		НовыйВводДаных.Владелец = ЭтаФорма;
		НовыйВводДаных.ПостОбработка = Истина; // признак пост-обработки перед следующим диалогом
		НовыйВводДаных.ОбработчикВвода = "ОтветНаВопрос";
		
		МассивОжидаемогоВвода.Добавить(НовыйВводДаных);
		
		// запускаем цикл	
		ВводДанныхКлинет.ЗапуститьЦикл(ТочкаВозврата, МассивОжидаемогоВвода);
		
	Иначе
		
		// цикл нам вернул данные, проверим что это: завершение либо пост-обработка 
		ВводЗакончен = Истина;
		ВводОтменен = Ложь;
		
		Для Каждого ОбработкаВвода Из МассивОжидаемогоВвода Цикл
			
			Если ОбработкаВвода.ФлагЗавершения И ОбработкаВвода.ПостОбработка Тогда
				
				ВводЗакончен = Ложь;
				
				Если ОбработкаВвода.Ключ = "Вопрос" Тогда
					
					// если ответили "Да" то добавим еще итерацию ввода данных
					Если ОбработкаВвода.Результат = КодВозвратаДиалога.Да Тогда
						
						// выбрать склад
						НовыйВводДаных = ВводДанныхКлинет.ПолучитьШаблонОжидаемогоВвода();
						
						НовыйВводДаных.Ключ = "Склад";
						НовыйВводДаных.Владелец = ЭтаФорма;
						НовыйВводДаных.Подсказка = "Наименование области";
						НовыйВводДаных.ОбработчикВвода = "ВводСтроки";
						
						МассивОжидаемогоВвода.Добавить(НовыйВводДаных);
						
					КонецЕсли;
					
					ОбработкаВвода.ПостОбработка = Ложь; // признак завершения пост-обработки
					
				КонецЕсли;
				
			ИначеЕсли ОбработкаВвода.ФлагЗавершения И НЕ ОбработкаВвода.ПостОбработка Тогда
				
				ВводОтменен = (ОбработкаВвода.Результат = Неопределено);	 
				Продолжить;
				
			КонецЕсли; 
			
		КонецЦикла;
		
		Если ВводОтменен Тогда
			Возврат;
		КонецЕсли;
		
		Если ВводЗакончен Тогда
			
			// завершим
			ЗапроситьДанные_ОбработкаВвода(МассивОжидаемогоВвода);
			
		Иначе
			
			// продолжим	
			ВводДанныхКлинет.ЗапуститьЦикл(ТочкаВозврата, МассивОжидаемогоВвода);
	
		КонецЕсли;
	
	КонецЕсли; 
		
КонецПроцедуры

&НаКлиенте
Процедура ЗапроситьДанные_ОбработкаВвода(МассивОжидаемогоВвода)
	// тут уже делаем с результатом ввода что хотим...	
КонецПроцедуры

Собственно все =)  Надеюсь данный пример раскрывает простоту использованиях представленного модуля.

Вот несколько примеров из рабочего проекта.

Пример выбора из произвольной формы

Пример вариативности диалога

Данная разработка представляется как есть. Можете дорабатывать как угодно для своих нужд. Всем успехов!

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Diversus 2114 13.07.16 12:34 Сейчас в теме
(0) Этот способ не будет работать в web-клиенте.
Вы используете процедуру Выполнить(...) на клиенте.
2. botokash 258 13.07.16 12:49 Сейчас в теме
(1) Diversus, Вы правы. Но веб-клиент не требовался поэтому как есть. На ум только приходит сделать #Если ВебКлиент Тогда и для него делать тоже самое через сервер. Может у кого еще какие идеи будут, что бы оставаться только в рамках клиента.
3. botokash 258 13.07.16 13:10 Сейчас в теме
В принципе можно попробовать сделать через Оповестить(). Если запуск цикла происходит в общем модуле то подключать процедуру возврата как обработчик оповещения, а если в форме - то через стандартную ОбработкаОповещения().
4. Сурикат 317 14.07.16 08:36 Сейчас в теме
Очень сильно радует появление таких статей на ИС=) Не обработок за стартмани, а аля библиотек =)

Не думали, что заполнение структуры "НовыйВводДаных" удобно оберточку в виде процедуры сделать. Чисто из-за подсказок, вы свой код хорошо знаете, а просто пользователям библиотеки придется скакать в общий модуль смотреть как параметры называются =)
5. botokash 258 14.07.16 09:07 Сейчас в теме
(4) Сурикат, была такая мысль, но каюсь - не было времени довести до ума.
(1) Diversus, идею вызовов через Оповестить() реализовал и проверил. Использованию в веб-клиенте быть =) Скоро выложу в этой же публикации, нужно еще пример актуализировать.
6. starik-2005 2212 17.07.16 11:42 Сейчас в теме
Не совсем понял, что за проблемы появляются при отказе от модальности? Чем они отличаются от проблем при ее использовании?
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37568    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    28047    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    24711    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    19016    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30573    tormozit    100    

Сходство Джаро - Винклера. Нечеткое сравнение строк

Универсальные функции v8 Россия Бесплатно (free)

В области информатики и статистики сходство Джаро - Винклера представляет собой меру схожести строк для измерения расстояния между двумя последовательностями символов. В публикации рассмотрены некоторые особенности алгоритма, и представлен вариант его реализации на языке 1С.

25.12.2019    7078    brooho    17    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    17262    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8585    Sibars    19    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78216    tormozit    131    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    34161    Yashazz    50    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    12233    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    51921    rpgshnik    63    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48691    tormozit    41    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    50537    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    29135    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25748    YPermitin    80    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    45039    tormozit    74    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31888    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    85487    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    36544    avalakh    22    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16129    m-rv    2    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    24587    json    14    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    61742    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    36366    ids79    27    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20386    m-rv    17    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    26379    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19789    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    48170    ids79    17    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30882    m-rv    21    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    53642    ids79    25    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    25396    dmurk    145    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    43984    YPermitin    30    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28352    itriot11    34    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35736    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27600    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31692    YPermitin    53    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76694    Serginio    108    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    40339    Смешной 1С    28    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    22392    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    35186    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    40523    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    27152    ids79    31    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29383    grumagargler    28    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    42044    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    37620    ids79    42    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    90593    GeterX    121    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    53068    m-rv    61    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    48823    Unk92    25