Цикл ввода данных, пример решения

Публикация № 535155

Разработка - Практика программирования

8.3 ввод данных

41
Отказ от модальности создает проблему организации последовательного ввода данных в рамках одной пользовательской операции. Цепочки процедур, обрабатывающих введенные данные и вызывающие следующий диалог - головная боль даже для самостоятельной поддержки или изменения логики ввода, не говоря о том уже, чтобы разбираться в чужом коде. Предлагаемое решение является некой заготовкой и может быть любым образом улучшено.

Данная тема уже обсуждалась //infostart.ru/public/305935/, но, столкнувшись с проблемой в реальной разработке, я решил изобретать свой "велосипед" =)

Основной целью являлось:

  • создание некого общего модуля, который будет отвечать непосредственно за организацию и контроль цикла ввода данных;
  • возможность запустить цикл на любое количество итерации обращений к пользователю и обработать результ ввода в 2 процедуры.
Начнем с разбора общего модуля "ВводДанныхКлиент":
//_____________________________________________________________
#Область ПрограммныйИнтерфейс

// Шаблон структуры, описывающий каждую итерацию ввода данных 
// 
&НаКлиенте
Функция ПолучитьШаблонОжидаемогоВвода() Экспорт
	
	Результат = Новый Структура;
	
	Результат.Вставить("Ключ", "");
	Результат.Вставить("Владелец", Неопределено);
	Результат.Вставить("ОбработчикВвода", "");
	
	Результат.Вставить("СписокЗначений", Новый СписокЗначений);
	
	Результат.Вставить("ОткрываемаяФорма", "");
	Результат.Вставить("ПараметрыФормы", Новый Структура);
	
	Результат.Вставить("ЧислоДлина", 0);
	Результат.Вставить("ЧислоТочность", 0);
	
	Результат.Вставить("Подсказка", "");
	Результат.Вставить("ПроизвольныйПараметр", Неопределено);
	
	Результат.Вставить("РежимДиалогаВопрос", РежимДиалогаВопрос.ДаНет);
	
	Результат.Вставить("Обязательный", Ложь);
	Результат.Вставить("ФлагЗавершения", Ложь);
	Результат.Вставить("ПостОбработка", Ложь);
	Результат.Вставить("Результат", Неопределено);
	
	Возврат Результат
	
КонецФункции

// Главная процедура. Является как и стартом цикла, так и обработкой каждой последующей итерации
//
// 	- ТочкаВозврата 		: структура, определяющая объект и имя его экспортной процедуры, 
//							куда передаются итоги ввода данных
// 	- МассивОжидаемогоВвода : массив структур из функции "ПолучитьШаблонОжидаемогоВвода", 
//							определяет действия и их поряд по вводу данных
// 	- СквозныеДанные		: служебная Структура("ФлагЗавершения, Ключ, Результат, ТочкаВозврата, МассивОжидаемогоВвода"), 
//							через нее возврат введенных в цикл 
//
&НаКлиенте
Процедура ЗапуститьЦикл(ТочкаВозврата, МассивОжидаемогоВвода, СквозныеДанные = Неопределено) Экспорт
	
	// проверка возврата в цикл после ввода данных
	Если СквозныеДанные <> Неопределено Тогда
		
		// запищем результат
		Для Каждого ОбработкаВвода Из МассивОжидаемогоВвода Цикл
			
			Если ОбработкаВвода.Ключ = СквозныеДанные.Ключ Тогда
				
				Если ОбработкаВвода.Обязательный И СквозныеДанные.Результат = Неопределено Тогда
					ОбработкаВвода.ФлагЗавершения = Ложь;
				Иначе
					
					ОбработкаВвода.ФлагЗавершения = СквозныеДанные.ФлагЗавершения;
					ОбработкаВвода.Результат = СквозныеДанные.Результат;
				
				КонецЕсли;
				
				Прервать;
				
			КонецЕсли; 
			
		КонецЦикла;
		
	КонецЕсли; 
	
	ВводЗакончен = Истина;
	
	// поиск и запуск следующей итерации ввода данных
	Для Каждого ОбработкаВвода Из МассивОжидаемогоВвода Цикл
		
		Если ОбработкаВвода.ФлагЗавершения И НЕ ОбработкаВвода.ПостОбработка Тогда
			Продолжить;
		ИначеЕсли ОбработкаВвода.ФлагЗавершения И ОбработкаВвода.ПостОбработка Тогда
			
			Выполнить("ТочкаВозврата.Объект." + ТочкаВозврата.ИмяПроцедуры + "(МассивОжидаемогоВвода)");
			Возврат;
			
		КонецЕсли;
		
		ВводЗакончен = Ложь;
		
		СквозныеДанные = Новый Структура("ФлагЗавершения, Ключ, Результат, ТочкаВозврата, МассивОжидаемогоВвода");
		
		СквозныеДанные.ФлагЗавершения = Ложь;
		СквозныеДанные.Ключ = ОбработкаВвода.Ключ;
		СквозныеДанные.Результат = Неопределено;
		СквозныеДанные.ТочкаВозврата = ТочкаВозврата;
		СквозныеДанные.МассивОжидаемогоВвода = МассивОжидаемогоВвода;
		
		Если ОбработкаВвода.ОбработчикВвода = "ВыборИзФормы" Тогда
			ВыборИзФормы(ОбработкаВвода.ОткрываемаяФорма, ОбработкаВвода.ПараметрыФормы, ОбработкаВвода.Владелец, СквозныеДанные);
		ИначеЕсли ОбработкаВвода.ОбработчикВвода = "ВыборИзСписка" Тогда
			ВыборИзСписка(ОбработкаВвода.СписокЗначений, ОбработкаВвода.Владелец, СквозныеДанные);
		ИначеЕсли ОбработкаВвода.ОбработчикВвода = "ВводСтроки" Тогда
			ВводСтроки(ОбработкаВвода.Подсказка, СквозныеДанные);
		ИначеЕсли ОбработкаВвода.ОбработчикВвода = "ВводЧисла" Тогда
			ВводЧисла(ОбработкаВвода.Подсказка, ОбработкаВвода.ЧислоДлина, ОбработкаВвода.ЧислоТочность, СквозныеДанные);
		ИначеЕсли ОбработкаВвода.ОбработчикВвода = "ОтветНаВопрос" Тогда
			ОтветНаВопрос(ОбработкаВвода.Подсказка, ОбработкаВвода.РежимДиалогаВопрос, СквозныеДанные);
		КонецЕсли;
		
		Прервать;
		
	КонецЦикла;
	
	// если все то возвращаем в точку возврата все введенные данные
	Если ВводЗакончен Тогда
		Выполнить("ТочкаВозврата.Объект." + ТочкаВозврата.ИмяПроцедуры + "(МассивОжидаемогоВвода)");	
	КонецЕсли; 
	
КонецПроцедуры

#КонецОбласти 

//_____________________________________________________________
#Область Диалоги

// Тут довольно все очевидно, обработка необбходимости вода данных
// с шаблонным возвратом в цикл

&НаКлиенте
Процедура ВыборИзФормы(ОткрываемаяФорма, ПараметрыФормы, Владелец, СквозныеДанные)
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ВыборИзФормы_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ОткрытьФорму(ОткрываемаяФорма, ПараметрыФормы, Владелец, , , , ОписаниеОповещения, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
	
КонецПроцедуры

&НаКлиенте
Процедура ВыборИзСписка(СписокВыбора, Владелец, СквозныеДанные)
	
	ПараметрыФормы = Новый Структура("СписокВыбора", СписокВыбора);
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ВыборИзСписка_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ОткрытьФорму("ОбщаяФорма.ФормаВыбораИзСписка", ПараметрыФормы, Владелец, , , , ОписаниеОповещения, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
		
КонецПроцедуры

&НаКлиенте
Процедура ВводСтроки(Подсказка, СквозныеДанные)
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ВводСтроки_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ПоказатьВводСтроки(ОписаниеОповещения, "", Подсказка);
	
КонецПроцедуры

&НаКлиенте
Процедура ВводЧисла(Подсказка, Длина, Точность, СквозныеДанные)
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ВводЧисла_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ПоказатьВводЧисла(ОписаниеОповещения, 0, Подсказка, Длина, Точность);
	
КонецПроцедуры

&НаКлиенте
Процедура ОтветНаВопрос(Подсказка, Кнопки, СквозныеДанные)
	
	ОписаниеОповещения = Новый ОписаниеОповещения("ОтветНаВопрос_Завершение", ЭтотОбъект, СквозныеДанные);
	
	ПоказатьВопрос(ОписаниеОповещения, Подсказка, Кнопки);
	
КонецПроцедуры

#КонецОбласти 

//_____________________________________________________________
#Область ОбработкиОповещений

// Закрывашки наших диалогов

&НаКлиенте
Процедура ВыборИзФормы_Завершение(ВыбЗнач, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = ВыбЗнач;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры

&НаКлиенте
Процедура ВыборИзСписка_Завершение(ВыбЗнач, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = ВыбЗнач;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры
 
&НаКлиенте
Процедура ВводСтроки_Завершение(ВведеннаяСтрока, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = ВведеннаяСтрока;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры 

&НаКлиенте
Процедура ВводЧисла_Завершение(ВведеннаяСтрока, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = ВведеннаяСтрока;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры 

&НаКлиенте
Процедура ОтветНаВопрос_Завершение(Ответ, СквозныеДанные) Экспорт
	
	СквозныеДанные.Результат = Ответ;
	СквозныеДанные.ФлагЗавершения = Истина;
	
	ЗапуститьЦикл(СквозныеДанные.ТочкаВозврата, СквозныеДанные.МассивОжидаемогоВвода, СквозныеДанные);
	
КонецПроцедуры 

#КонецОбласти 

Теперь расмотрим живой пример изспользования данного модуля. 

Решим следующую задачу: при выборе товара в корзину нужно сразу запросить необходимое количество, спросить о необходимости поставить товар в резерв и, если будет положительный ответ, то дать выбрать место размещения товара.

Получаем следующие итерации ввода:

  • ввести число;
  • диалог вопроса;
  • если на диалог был ответ да, то выбрать ссылку.

Приступим.

&НаКлиенте
Процедура ТоварыПриИзменении(Элемент)
	
	// Товар был добавлен в корзину. 
	// Запросим необходимые данные.
	ЗапроситьДанные();
	
КонецПроцедуры

// Можно считать шаблоном. Обязательно экспортная, т.к. тут же происходит 
// пост-обработка итерации ввода данных (если была включена такая опция).
//
// - МассивОжидаемогоВвода   : 	параметр как флаг, либо это первый запуск, 
//								либо пост-обработка, либо завершение цикла
//
&НаКлиенте
Процедура ЗапроситьДанные(МассивОжидаемогоВвода = Неопределено) Экспорт
		
	// возврат происходит в эту же процедуру 
	ТочкаВозврата = Новый Структура("ИмяПроцедуры, Объект");
	
	ТочкаВозврата.ИмяПроцедуры = "ЗапроситьДанные";
	ТочкаВозврата.Объект = ЭтотОбъект;
	
	// проверка параметра
	Если МассивОжидаемогоВвода = Неопределено Тогда
		
		// первый запуск
		МассивОжидаемогоВвода = Новый Массив;
		
		// ожидаем ввода количества
		НовыйВводДаных = ВводДанныхКлинет.ПолучитьШаблонОжидаемогоВвода();
		
		НовыйВводДаных.Ключ = "КоличествоТовара";
		НовыйВводДаных.Владелец = ЭтаФорма;
		НовыйВводДаных.ОбработчикВвода = "ВводЧисла"; // наш тип обработчика
		НовыйВводДаных.ЧислоДлина = 5;
		
		МассивОжидаемогоВвода.Добавить(НовыйВводДаных);
		
		// спрашиваем
		НовыйВводДаных = ВводДанныхКлинет.ПолучитьШаблонОжидаемогоВвода();
		
		НовыйВводДаных.Ключ = "Вопрос";
		НовыйВводДаных.Владелец = ЭтаФорма;
		НовыйВводДаных.ПостОбработка = Истина; // признак пост-обработки перед следующим диалогом
		НовыйВводДаных.ОбработчикВвода = "ОтветНаВопрос";
		
		МассивОжидаемогоВвода.Добавить(НовыйВводДаных);
		
		// запускаем цикл	
		ВводДанныхКлинет.ЗапуститьЦикл(ТочкаВозврата, МассивОжидаемогоВвода);
		
	Иначе
		
		// цикл нам вернул данные, проверим что это: завершение либо пост-обработка 
		ВводЗакончен = Истина;
		ВводОтменен = Ложь;
		
		Для Каждого ОбработкаВвода Из МассивОжидаемогоВвода Цикл
			
			Если ОбработкаВвода.ФлагЗавершения И ОбработкаВвода.ПостОбработка Тогда
				
				ВводЗакончен = Ложь;
				
				Если ОбработкаВвода.Ключ = "Вопрос" Тогда
					
					// если ответили "Да" то добавим еще итерацию ввода данных
					Если ОбработкаВвода.Результат = КодВозвратаДиалога.Да Тогда
						
						// выбрать склад
						НовыйВводДаных = ВводДанныхКлинет.ПолучитьШаблонОжидаемогоВвода();
						
						НовыйВводДаных.Ключ = "Склад";
						НовыйВводДаных.Владелец = ЭтаФорма;
						НовыйВводДаных.Подсказка = "Наименование области";
						НовыйВводДаных.ОбработчикВвода = "ВводСтроки";
						
						МассивОжидаемогоВвода.Добавить(НовыйВводДаных);
						
					КонецЕсли;
					
					ОбработкаВвода.ПостОбработка = Ложь; // признак завершения пост-обработки
					
				КонецЕсли;
				
			ИначеЕсли ОбработкаВвода.ФлагЗавершения И НЕ ОбработкаВвода.ПостОбработка Тогда
				
				ВводОтменен = (ОбработкаВвода.Результат = Неопределено);	 
				Продолжить;
				
			КонецЕсли; 
			
		КонецЦикла;
		
		Если ВводОтменен Тогда
			Возврат;
		КонецЕсли;
		
		Если ВводЗакончен Тогда
			
			// завершим
			ЗапроситьДанные_ОбработкаВвода(МассивОжидаемогоВвода);
			
		Иначе
			
			// продолжим	
			ВводДанныхКлинет.ЗапуститьЦикл(ТочкаВозврата, МассивОжидаемогоВвода);
	
		КонецЕсли;
	
	КонецЕсли; 
		
КонецПроцедуры

&НаКлиенте
Процедура ЗапроситьДанные_ОбработкаВвода(МассивОжидаемогоВвода)
	// тут уже делаем с результатом ввода что хотим...	
КонецПроцедуры

Собственно все =)  Надеюсь данный пример раскрывает простоту использованиях представленного модуля.

Вот несколько примеров из рабочего проекта.

Пример выбора из произвольной формы

Пример вариативности диалога

Данная разработка представляется как есть. Можете дорабатывать как угодно для своих нужд. Всем успехов!

41

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Diversus 2015 13.07.16 12:34 Сейчас в теме
(0) Этот способ не будет работать в web-клиенте.
Вы используете процедуру Выполнить(...) на клиенте.
2. botokash 80 13.07.16 12:49 Сейчас в теме
(1) Diversus, Вы правы. Но веб-клиент не требовался поэтому как есть. На ум только приходит сделать #Если ВебКлиент Тогда и для него делать тоже самое через сервер. Может у кого еще какие идеи будут, что бы оставаться только в рамках клиента.
3. botokash 80 13.07.16 13:10 Сейчас в теме
В принципе можно попробовать сделать через Оповестить(). Если запуск цикла происходит в общем модуле то подключать процедуру возврата как обработчик оповещения, а если в форме - то через стандартную ОбработкаОповещения().
4. Сурикат 264 14.07.16 08:36 Сейчас в теме
Очень сильно радует появление таких статей на ИС=) Не обработок за стартмани, а аля библиотек =)

Не думали, что заполнение структуры "НовыйВводДаных" удобно оберточку в виде процедуры сделать. Чисто из-за подсказок, вы свой код хорошо знаете, а просто пользователям библиотеки придется скакать в общий модуль смотреть как параметры называются =)
5. botokash 80 14.07.16 09:07 Сейчас в теме
(4) Сурикат, была такая мысль, но каюсь - не было времени довести до ума.
(1) Diversus, идею вызовов через Оповестить() реализовал и проверил. Использованию в веб-клиенте быть =) Скоро выложу в этой же публикации, нужно еще пример актуализировать.
6. starik-2005 1961 17.07.16 11:42 Сейчас в теме
Не совсем понял, что за проблемы появляются при отказе от модальности? Чем они отличаются от проблем при ее использовании?
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 317

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9962    ids79    42       

Три костыля. Сказ про фокусы в коде 122

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    7767    YPermitin    68       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    8224    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 241

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    10341    ids79    24       

Фоновое выполнение кода в 1С - это просто 117

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    9782    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    9250    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 135

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8678    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6207    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 192

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17386    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 176

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11514    dmurk    134       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    17208    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9814    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4802    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7335    m-rv    16       

О расширениях замолвите слово... 191

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16324    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12690    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12802    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 162

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15429    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12691    ids79    27       

Новый подход к обмену данными EnterpriseData 203

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21380    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 118

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    18872    ids79    20       

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке 464

Статья Программист Нет файла v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные функции

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    31719    GeterX    93       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19578    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 126

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20805    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20428    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14562    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    21224    Rain88    42       

Повышаем эффективность разработки правил обмена 123

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19291    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 153

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24332    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21158    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16944    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11317    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24327    avfed@rambler.ru    19       

Минимализмы 3 351

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35537    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25819    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21294    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 720

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    137440    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22666    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 66

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    21036    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    24014    json    9       

Работа с Excel 288

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24639    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46724    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 127

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    18202    vardeg    31