Net Core. Динамическая компиляция класса обертки для получения событий .Net объекта в 1С

Публикация № 548701

Разработка - Разработка внешних компонент

.Net Core ОбработкаВнешнегоСобытия

Часто нужно использовать события объектов .Net. Например событие от COM порта, поступление сообщений по WhatsAp, сообщение об изменение в директории итд. Напрямую этого сделать нельзя, но можно сделать класс обертку и через него получать ВнешнееСобытие

Это практическое применение из предыдущей статьи .Net Core, 1C, динамическая компиляция, Scripting API.

По сути это продолжение .NET(C#) для 1С. Динамическая компиляция класса обертки для использования .Net событий в 1С через ДобавитьОбработчик или ОбработкаВнешнегоСобытия, но для кроссплатформенного .Net Core. Но в той разработке я использовал CodeDom. В .Net Core удобнее использовать Roslyn Scripting API.

В свое время делал вручную обертку для WhatsApp, а там более 30 событий. При этом весь процесс можно автоматизировать с помощью кодогенерации и в конечном итоге можно этот код динамически скомпилировать.

В «Создание компонент с использованием технологии Native API» есть метод для вызова внешнего события в 1С ExternalEvent. Синтаксис:

bool ExternalEvent(WCHAR_T* wsSource, WCHAR_T* wsMessage, WCHAR_T* wsData) 


Параметры:

• Тип: WCHAR_T*. Строка с наименованием источника события.
• Тип: WCHAR_T*. Строка с наименованием события.
• Тип: WCHAR_T*. Строка c параметрами события.

Но в качестве wsData будем передавать ссылку на объект созданный из параметров события.

Итак, начнем.
Сначала создадим описание класса на примере моего любимого System.IO.FileSystemWatcher, который в .Net Core находится в System.IO.FileSystem.Watcher

Чистые 1С ники могут пропустить вражеский код.

     public class ВрапперДляSystem_IO_FileSystemWatcher
    {
        Action<string,string,object> СобытиеДля1С;
        System.IO.FileSystemWatcher РеальныйОбъект;
  
        public   ВрапперДляSystem_IO_FileSystemWatcher(Action<string,string,object> СобытиеДля1С, System.IO.FileSystemWatcher РеальныйОбъект)
          {

            this.СобытиеДля1С = СобытиеДля1С;
            this.РеальныйОбъект = РеальныйОбъект;
            
            РеальныйОбъект.Changed += (sender,e) =>
            {
               var  Changed =  new { sender=sender,e=e};
               this?.СобытиеДля1С("System_IO_FileSystemWatcher","Changed",Changed);
            };

РеальныйОбъект.Created += (sender,e) =>
            {
               var  Created =  new { sender=sender,e=e};
               this?.СобытиеДля1С("System_IO_FileSystemWatcher","Created",Created);
            };

РеальныйОбъект.Deleted += (sender,e) =>
            {
               var  Deleted =  new { sender=sender,e=e};
               this?.СобытиеДля1С("System_IO_FileSystemWatcher","Deleted",Deleted);
            };

РеальныйОбъект.Error += (sender,e) =>
            {
               var  Error =  new { sender=sender,e=e};
               this?.СобытиеДля1С("System_IO_FileSystemWatcher","Error",Error);
            };

РеальныйОбъект.Renamed += (sender,e) =>
            {
               var  Renamed =  new { sender=sender,e=e};
               this?.СобытиеДля1С("System_IO_FileSystemWatcher","Renamed",Renamed);
            };

        }

public static object СоздатьОбъект(Action<string,string,object> СобытиеДля1С, System.IO.FileSystemWatcher РеальныйОбъект)
{

    return new ВрапперДляSystem_IO_FileSystemWatcher(СобытиеДля1С, РеальныйОбъект);
}
    }

return new Func<Action<string,string,object>,System.IO.FileSystemWatcher,object>(ВрапперДляSystem_IO_FileSystemWatcher.СоздатьОбъект);



Создаем класс, подписываемся на события. В событии создаем анонимный класс из параметров и вызываем метод, который в итоге вызовет вышеописанную функцию в 1С.

Для того, чтобы закэшировать результат компиляции, создадим класс.

public class КомВраперДляСобытий<T>
    {
        public static readonly Func<Action<string, string, object>, T, object> СоздательОбертки;


        public static Func<Action<string, string, object>, T, object> СоздатьОбертку()
        {
            Type типРеальногоОбъекта = typeof(T);
            string ТипСтрРеальногоОбъекта = типРеальногоОбъекта.FullName;
            var ИмяКласса = "ВрапперДля" + ТипСтрРеальногоОбъекта.Replace(".", "_").Replace("+", "_");

            var ДСМВ = new ДляСозданияМодуляВрапера();
            string строкаКласса = ДСМВ.СоздатьОписания(типРеальногоОбъекта);

            var scr = Microsoft.CodeAnalysis.Scripting.ScriptOptions.Default;
            var Сборки = ДСМВ.СборкиВПараметрах.Keys.ToArray();

            scr = scr.WithReferences(Сборки)
            .WithImports("System");

           var res = (Func<Action<string, string, object>, T, object>)Microsoft.CodeAnalysis.CSharp.Scripting.CSharpScript.EvaluateAsync(строкаКласса, scr).Result;
            return res;
        }
        static КомВраперДляСобытий()
        {
            СоздательОбертки= СоздатьОбертку();
        }
    }



Создаем поле:

public static readonly Func<Action<string, string, object>, T, object> СоздательОбертки;


Которое инициализируется при создании класса в статическом конструкторе. При компиляции используются сборки типов параметров и тип оборачиваемого объекта. Этот подход часто используется при универсальном создании сериализаторов.

Теперь мы можем вызвать делегат для создания объекта обертки для событий так.

public static void ВызватьВнешнееСобытиеСОбъектом(string Источник,string Событие, object Данные)
        {
 // Задача из объекта Данные получить строку
// И вызвать внешнее событие в 1С
// И в зависимости от переданного типа получить строковое представление.

            var ДанныеДля1с = AutoWrap.ОбернутьОбъект(Данные);

            string res="";

            if (Данные == null)
                res = "";
            else if (ДанныеДля1с is AutoWrap)
                res = ((AutoWrap)ДанныеДля1с).ПолучитьСсылку();
            else
                res = ДанныеДля1с.ToString();

            AutoWrap.ВызватьВнешнееСобытие1С(Источник, Событие, res);
        }
        public static object СоздатьОберткуДляСобытий(Object ОбъектССобытиями)
        {

            Type тип = ОбъектССобытиями.GetType();
            Type genType = typeof(КомВраперДляСобытий<>);
            Type constructed = genType.MakeGenericType(new Type[] { тип });
            var ИмяСвойства = "СоздательОбертки";

              var fi = constructed.GetField(ИмяСвойства);
              Delegate функция = (Delegate)fi.GetValue(null);
             // Получили делегат
             // И из него получим объект обертку для событий который передадим в 1С для хранения ссылки на него
            object обертка = функция.DynamicInvoke(new Action<string,string,object>(ВызватьВнешнееСобытиеСОбъектом), ОбъектССобытиями);
            return обертка;

        }



Теперь перейдем к коду в 1С. В качестве получения кода на C# и 1С используется внешняя обработка ТестСобытийИзмененийВДиректории.epf.

Процедура СообщитьОбИзменении(знач Событие)
	e=Событие.e;
	Если e<>Неопределено  Тогда
		e=ъ(e);
		ChangeType=ъ(e.ChangeType);
		Сообщить( e.FullPath + " " + Врап.ВСтроку(ChangeType.ПолучитьСсылку()));
	КонецЕсли;
КонецПроцедуры // СообщитьОбИзменении


//  параметр Данные:Анонимный Тип
// Свойства параметра
// sender:System.Object
// e:System.IO.FileSystemEventArgs

Процедура Changed(Данные)
	Сообщить("Changed "+Врап.ВСтроку(Данные.ПолучитьСсылку()));
	СообщитьОбИзменении(Данные)
	
КонецПроцедуры

//  параметр Данные:Анонимный Тип
// Свойства параметра
// sender:System.Object
// e:System.IO.FileSystemEventArgs

Процедура Created(Данные)
	Сообщить("Created "+Врап.ВСтроку(Данные.ПолучитьСсылку()));
	СообщитьОбИзменении(Данные)
	
КонецПроцедуры

//  параметр Данные:Анонимный Тип
// Свойства параметра
// sender:System.Object
// e:System.IO.FileSystemEventArgs

Процедура Deleted(Данные)
	Сообщить("Deleted "+Врап.ВСтроку(Данные.ПолучитьСсылку()));
	СообщитьОбИзменении(Данные)
	
КонецПроцедуры

//  параметр Данные:Анонимный Тип
// Свойства параметра
// sender:System.Object
// e:System.IO.ErrorEventArgs

Процедура Error(Данные)
	Сообщить("Error "+Врап.ВСтроку(Данные.ПолучитьСсылку()));
	СообщитьОбИзменении(Данные)
	
КонецПроцедуры

//  параметр Данные:Анонимный Тип
// Свойства параметра
// sender:System.Object
// e:System.IO.RenamedEventArgs

Процедура Renamed(Данные)
	Сообщить("Renamed "+Врап.ВСтроку(Данные.ПолучитьСсылку()));
	СообщитьОбИзменении(Данные)
КонецПроцедуры

Функция ОбернутьОбъектНеопределенногоТипа(знач Ссылка)
	
	Если Ссылка=null или Ссылка=Неопределено Тогда
		возврат неопределено
	КонецЕсли; 
	
	Если ТипЗнч(ссылка)=Тип("Строка") Тогда
		
		Если найти(Ссылка,"ёЁ<Ьъ>№_%)Э?&")= 1 Тогда
			возврат ъ(Ссылка)
		КонецЕсли;
	КонецЕсли;
	
	возврат Ссылка
КонецФункции // ОбернутьОбъектНеопределенногоТипа()

Процедура ОбработкаВнешнегоСобытия(Источник, ИмяСобытия, Данные)
	Сообщить(Источник);
	Если Источник = "System_IO_FileSystemWatcher" Тогда
		Объект= ОбернутьОбъектНеопределенногоТипа(Данные);
		Выполнить(ИмяСобытия + "(Объект)");
	КонецЕсли;
КонецПроцедуры // ОбработкаВнешнегоСобытия 


Формируются методы обработчики по имени события которые вызываются через

Объект= ОбернутьОбъектНеопределенногоТипа(Данные);
Выполнить(ИмяСобытия + "(Объект)");


Такой подход сокращает ручное написание кода. Ну и создание отслеживания изменений в директории

Процедура Остановить()
	Если watcher<>Неопределено Тогда
		watcher.EnableRaisingEvents = false;	
	КонецЕсли;
	
КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)
	Остановить();
	
	WatcherСборка=ъ(Врап.Сборка("System.IO.FileSystem.Watcher"));
	
	WatcherТип=ъ(WatcherСборка.GetType("System.IO.FileSystemWatcher"));
	NotifyFilters=ъ(WatcherСборка.GetType("System.IO.NotifyFilters"));
	
	
	Директория=ОтслеживаемыйКаталог;//"c:\tmp\";
	watcher=ъ(Врап.Новый(WatcherТип.ПолучитьСсылку(),Директория));
	//watcher.NotifyFilter = NotifyFilters.LastAccess | NotifyFilters.LastWrite
	//        | NotifyFilters.FileName | NotifyFilters.DirectoryName;
	// Only watch text files.
	LastAccess=ъ(NotifyFilters.LastAccess);
	LastWrite=ъ(NotifyFilters.LastWrite);
	FileName=ъ(NotifyFilters.FileName);
	DirectoryName=ъ(NotifyFilters.DirectoryName);
	рез=ъ(Врап.OR(LastAccess.ПолучитьСсылку(),LastWrite.ПолучитьСсылку(),FileName.ПолучитьСсылку(),DirectoryName.ПолучитьСсылку()));
	watcher.NotifyFilter=рез.ПолучитьСсылку();
	watcher.Filter = "*.*";
	watcher.IncludeSubdirectories = true;
	
	watcher.EnableRaisingEvents = true;
	
	СоздатьОбертку(Watcher);
КонецПроцедуры


По окончании нужно позаботиться об освобождении ресурсов.

Процедура ПриЗакрытии()
	Если watcher<>Неопределено Тогда
		Остановить();
		Врап.ЗакрытьРесурс(watcher.ПолучитьСсылку());
		watcher=Неопределено;
		ОберткаСобытий=Неопределено;
		GC=ъТип("System.GC");
		GC.Collect();
		GC.WaitForPendingFinalizers();
		Врап= Неопределено;
	КонецЕсли
КонецПроцедуры



Теперь можно использовать не только методы и свойства объектов .Net, но и события. При этом используя только родной для 1С ка язык программирования. И ни одной строчки на вражеском языке.

В заключении я хочу поделиться свои недоумением по поводу обсуждения статей. Все обсуждение сводится к Русслишу и ъ.

Я подниму проблемы при использовании Native API в Кроссплатформенное использование классов .Net в 1С через Native ВК. Или замена COM на Linux

Так, при создании Native API видны ноги из IDispatch. Но там использовались диспинтерфейсы для вызова только Invoke

1. Абсолютно не нужны методы FindMethod, FindProp, GetNParams, HasRetVal, GetParamDefValue
(IsPropReadable, IsPropWritable только для отладчика). Так как у методов bool CallAsProc, bool CallAsFunc, bool SetPropVal и bool GetPropVal есть возвращаемое значение об успешном выполнении. Информация об ошибке возвращается через AddError. Да и вызов по индексу это анахронизм от IDiapatch где было описание диспинтерфейсов для увеличения скорости вызова.
2. При возвращении методами SetPropVal и GetPropVal исключение не вызывается
3. Зачем-то происходит установка свойств, там, где в коде этого не требуется.
4. Вызывается метод как функция, там где метод вызывается как процедура.
5. Один из основных - это нельзя вернуть и передать экземпляр ВК из методов ВК.

Я лично не вижу никаких проблем. Определить значение для такого типа и установить ссылку в поле pInterfaceVal.
В Native API есть структура


struct _tVariant
        {
.....
         _ANONYMOUS_STRUCT struct
            {
                void* pInterfaceVal;
               IID InterfaceID;
           }     
...... 
   TYPEVAR vt;
       };


В которой можно использовать void* pInterfaceVal; IID InterfaceID. А в vt; указать, что это ВК. С недавних пор Можно передавать byte[]. Так можно пойти и дальше.

Подсчет ссылок происходит на стороне 1С. Передавать можно в том числе и объекты 1С только на время вызова метода. Так при использовании IDispatch в 1С нет проблем при передачи IDispatch в параметрах метода. Сейчас скорость вызова метода ВК почти в 15 раз медленнее вызова из С++ только

public static bool CallAsFunc(int Target, IntPtr ИмяМетодаPtr, IntPtr ReturnValue, IntPtr МассивПараметров, int РазмерМассива)


И медленнее в 5 раз аналогичного метода 1С. При этом вместо одного метода вызывается FindMethod, GetNParams, CallAsFunc. А если вызывать напрямую без ВК то и скорость будет аналогичной с использованием внутренних методов.

Сейчас при передаче в метод ВК через свойство метод(Объект.Свойство) или в метод по ссылке без знач. 1С пытается присвоить значение, даже если это значение не изменилось. Можно в ВК предустмотреть передачу измененных параметров.

Сейчас на Windows множество компонент на COM. Те же ADO,Excel итд. Можно легко создать свою COM библиотеку на любом языке.

Поэтому при опросе почему не используют Использование сборок .NET в 1С 7.x b 8.x. Создание внешних Компонент

Большинство отвечает, что не намерены использовать продукт неизвестно от кого. Эта ситуация аналогична с ЯП Nemerle. Язык который мощнее C#, но за которым стоят энтузиасты никому не нужен. Но при этом все соглашаются, что если бы эта компонента была интегрирована в 1С на подобии ComОбъект то все ею бы пользовались.

Что касается кроссплатформенности, то .Net Core дает эту возможность. При этом эта технология сейчас активно развивается .NET Core Roadmap

Как я показал можно использовать любые классы .Net Core только на языке 1С. Можно использовать динамическую компиляцию скриптов или написать свою Сборку на C#, что значительно проще чем писать ВК.

Я знаю, что на данной площадке много разработчиков 1С. И у меня большая просьба к ним дать совет по развитию данной разработки. Если 1С не намерена изменять Native API, то я силы кину на что-то другое. Хотя на данную разработку ушли годы, и мне очень жалко её. Она как ребенок.

Я готов бесплатно участвовать в исследовательском проекте по применение .Net Core в 1С. Главное, что бы силы были потрачены не зря.

А возможности кроссплатформенного использования .Net Core в 1С колосcальные. Но вот мне интересно почему 1С не нужны? Вот ответ на этот вопрос я хотел бы услышать. Что касается Linux то на мои вопросы, чего не хватает по сравнению с Windows основным было это

Главная проблема — клиентов на линукс перевести. А тут главный тормоз — работа с торговым оборудованием. Плохо дело с готовыми и надежными дровами под Native API под всякое разное. А высокоуровневая байда как-то и не держит особо. Технически, во всяком случае.



В свое время работая с Торговым оборудованием обязательно были SDK на C#. Даже под WiCE. Многие были интероп обертками над нативными библиотеками. С появлением .Net Core будут делать под NetStandart. И на Линукс станет повеселее.

Исходники и примеры можно скачать Здесь

Специальные предложения

Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77290    Serginio    110    

Работа с журналом регистрации. Выходим за границы платформы

Журнал регистрации Бесплатно (free)

Работа с журналом регистрации нестандартными средствами. А также немного про использование платформы .NET в экосистеме 1С.

12.05.2020    6649    YPermitin    27    

.Net Core, обмен с 1C по TCP/IP между различными устройствами

Разработка внешних компонент v8 Бесплатно (free)

Часто нужно обмениваться данными с клиентом 1С из различных устройств, между клиентами 1С, а также при виртуализации между разными ОС на компьютере. Это кроссплатформенная ВК, позволяющая обмениваться сообщениями по TCP/IP между различными устройствами по определенному протоколу.

28.09.2016    21471    Serginio    12    

.Net Core, 1C, динамическая компиляция, Scripting API

Разработка внешних компонент Практика программирования v8 Бесплатно (free)

Очень часто приходится использовать динамический код в 1С, используя Выполнить или Вычислить. Аналогичная задача и для использования скриптов на .Net. Я постарался показать, как можно скрестить ежа с ужом и получить удобный код. В этой статье много вражеского кода для чистого одноэсника, но все когда-то бывает впервые.

07.09.2016    19035    Serginio    7    

1С, Linux, Excel, Word, OpenXML, ADO, Net Core

Разработка внешних компонент v8 Бесплатно (free)

В данной статье показаны примеры кроссплатформенной работы с файлами Excel и Word (xlsx,docx) с помощью библиотеки OpenXML и Net Core

22.08.2016    21374    Serginio    14    

Асинхронное программирование в 1С через использование классов .Net из Native ВК

Разработка внешних компонент v8 Бесплатно (free)

Это продолжение статьи Кроссплатформенное использование классов .Net в 1С через Native ВК. Или замена COM на Linux II http://infostart.ru/public/541518/ В этой статье покажу, как можно асинхронно вызывать асинхронные методы и вызывать ВнешнееСобытие в 1С из сборки .Net

09.08.2016    17685    Serginio    3    

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д.

Разработка внешних компонент Практика программирования WEB v7.7 v8 Бесплатно (free)

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    31977    Serginio    22    

Быстрое создание Внешних Компонент на C#. Примеры использования Глобального Контекста, IAsyncEvent, IExtWndsSupport, WinForms и WPF

Практика программирования Разработка внешних компонент v8 Бесплатно (free)

В большинстве случаев хватает и обычного COM объекта, учитывая, что в 8.х можно использовать события. Но иногда нужно использовать Глобальный Контекст для вызова глобальных функций, таких как Сообщить, NewObject и т.д. Кроме того, для использования форм нужен дескриптор окна 1С. Это продолжение статей Использование сборок .NET в 1С 7.x b 8.x. Создание внешних Компонент. http://infostart.ru/public/238584/ Там же лежат и исходники .NET(C#) для 1С. Динамическая компиляция класса обертки для использования .Net событий в 1С через ДобавитьОбработчик или ОбработкаВнешнегоСобытия http://infostart.ru/public/417830/ 1C Messenger для отправки сообщений, файлов и обмена данными между пользователями 1С, вэб страницы, мобильными приложениями а ля Skype, WhatsApp http://infostart.ru/public/434771/ Использование классов .Net в 1С для новичков http://infostart.ru/public/448668/

15.02.2016    29682    Serginio    13    

Подсветка синтаксиса 1С в текстовых редакторах Atom, Sublime Text, VS Code

Инструментарий разработчика Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Пакеты, добавляющие поддержку синтаксиса языка 1С:Предприятие 8 в текстовые редакторы Atom, Sublime Text и VS Code. И не только.

02.02.2016    27792    nixel    38    

.NET(C#) для 1С. Динамическая компиляция класса обертки для использования .Net событий в 1С через ДобавитьОбработчик или ОбработкаВнешнегоСобытия

Разработка внешних компонент Математика и алгоритмы v7.7 v8 Бесплатно (free)

Динамическая компиляция класса обертки для использования .Net событий в 1С через ДобавитьОбработчик или ОбработкаВнешнегоСобытия, а так же генерация модулей на C# и 1С для подключения к событиям. Использование DynamicMethod и ILGenerator. Представлены примеры для использовании событий System.IO.FileSystemWatcher (Ожидает уведомления файловой системы об изменениях и инициирует события при изменениях каталога или файла в каталоге.) и SerialPort (обработка сканера штрих кода подключенного к COM порту). Обертка позволяет использовать классы .Net только на языке 1С. Реализация 1C Messenger описанного здесь http://infostart.ru/public/434771/

12.11.2015    46832    Serginio    36    

1С с "плюсами"

Разработка внешних компонент Математика и алгоритмы Универсальные функции v8 Бесплатно (free)

- Разработана методика подключения внешней компоненты, снимающая ограничения на типы данных аргументов и возвращаемого значения. - Проведено документирование основных типов данных (объектов, интерфейсов) платформы. - Разработан объект «Делегат» для реализации функциональных объектов (указатель-на-функцию). - Разработана концепция итератора произвольного доступа для основных контейнеров платформы с целью сопряжения со стандартной C++ библиотекой. - В процессе разработки механизм 1С классов (наследование, интерфейсы) для возможности использования парадигм объектно-ориентированного программирования на уровне кода.

14.10.2015    23209    IntelInside    48    

Генерация штрих-кода для вставки его в 1С при работе в Linux

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

В Linux есть отличная команда barcode, которая генерирует штрих-коды в векторном формате ps. Но 1С не понимает такие форматы. Более того, barcode генерирует штрих-код на размер листа А4 или Letter. Установка пользовательского размера листа не увенчалась успехом. Но не будем же мы вставлять изображение штрих-кода размером с лист А4… Однако есть способ, как решить данные проблемы.

01.07.2015    16652    rudjuk    4    

Простейший способ создания штрих-кода в формате PNG из командной строки в Linux Ubuntu

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

В Linux есть огромное количество способов создания линейного штрих-кода. В данной статье мы рассмотрим, как сгенерировать графическое изображение штрих-кода прямо из командной строки. При этом, решение будет совершенно бесплатным и очень простым как в установке, так и в использовании.

29.06.2015    12293    rudjuk    15    

Компилирование внешней компоненты AddInNative в ОС Linux

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

В статье отражены некоторые моменты, которые нужно учесть, чтобы скомпилировать пример 1С-вской внешней компоненты AddInNative в ОС Linux.

14.01.2015    20830    q_i    22    

Использование внешних COM-компонент (.dll) или любых клиентских методов в регламентных заданиях серверной базы.

Практика программирования Разработка внешних компонент Математика и алгоритмы v8 1cv8.cf Бесплатно (free)

Для расширения возможностей платформы 1С существует огромное количество внешних компонент (дополнительные функции, взаимодействие с софтом и железом других производителей, ключи защиты). К сожалению, большинство из них написано на технологии .COM и не могут использоваться на сервере. Для использования в регламентных заданиях серверной базы их приходится переписывать на Native API. Однако, иногда нет возможности переписать компоненту на новую технологию, но нужно вызвать ее в регламентном задании на сервере.

10.12.2014    46337    ekaruk    51    

Обработка изображений 1С средствами .Net framework

Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

1С:Предприятие не предоставляет штатных средств работы с изображениями по изменению размеров и наложению водяных знаков. Данный функционал часто востребован, например, в Интернет-магазинах, когда из 1С происходит экспорт товаров с фотографиями. Раньше для этого использовали выгрузку фотографий на диск и вызов утилит через командную строку. Понятно, что гибкостью и скоростью такой вариант не обладает, плюс еще могут возникнуть проблемы с безопасностью и учетом временных файлов.

19.04.2013    20807    Elisy    13    

Подсистема "COMExchange": ускорение выгрузки запросов ADO или «игра с огнём».

Практика программирования Разработка внешних компонент v8 1cv8.cf Россия Бесплатно (free)

Описана поддержка подсистемой "COMExchange"работы с ВК GameWhithFire.dll и в частности ускоренная выгрузка результата запроса ADO средствами ВК.

11.03.2013    20043    yuraos    4    

Простой пример создания ActiveX-control на Qt

Практика программирования Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Мне была поставлена задача разработать некий ActiveX-control. Так как основным языком программирования для разработки у нас используется C++, то C# не рассматривался. Я решил выбрать Qt, так как он мне интересен. Создание ActiveX объектов на Qt достаточно простой процесс, в примерах к QtCreator есть несколько вариантов, показывающих как можно использовать ActiveQt (например этот). При написании компонента пришлось много времени потратить на поиск ответов на казалось бы простые вопросы, по крупицам их собирать. В результате я получил, что требовалось и решил написать простой пример, чтобы ускорить процесс старта разработки ActiveX-control другим. Сразу обращу внимание, что не описываю всю технологию ActiveQt, подробную информацию можно получить в документации Qt Assistant и в интернете (например здесь), это пример и пара интересных на мой взгляд моментов.

25.02.2013    9231    theshadowco    3    

Finger-биометрия в 1С

Разработка внешних компонент v8 Россия Бесплатно (free)

О различных методиках использования сканеров отпечатков пальцев в 1С.

02.07.2012    27435    fixin    22    

Решение проблем с регистрацией внешних компонент в терминале

Разработка внешних компонент Розничная торговля Учет ТМЦ Розничная торговля Учет ТМЦ v8 УТ10 Россия УУ Бесплатно (free)

Зачастую у программистов возникают проблемы с подключением внешних компонент (например, драйверов торгового оборудования), когда пользователи работают с 1С, подключаясь к серверу через терминал. Это связано с некоторыми особенностями работы функции глобального контекста ПодключитьВнешнююКомпоненту().

22.09.2011    69452    Spacer    41    

Новая версия 1С:Предприятие 8.2 конфликтует с C# и .Net framework

Практика программирования Разработка внешних компонент v8 1cv8.cf Бесплатно (free)

Суть конфликта 1С 8.2 с C# и .Net framework в следующем. В версии 8.2 1С анонсировала новый способ написания внешних компонент 1С с использованием так называемого Native API. Самое интересное, что на C# предложенный подход реализовать невозможно, а реализация Native API на VC++/CLI теоретически возможна, но при попытке подключения DLL, скомпилированных с опцией /CLR, происходит зависание 1С (версия 8.2.13.202). Еще один конфликт – в новой версии 1С нет поддержки технологии ActiveX, на основе которой многие разработчики вставляли в формы 1С свои WinForms-приложения.

15.12.2010    21394    Elisy    128    

Учим внешнюю компоненту правильному склонению не только ФИО, но и должностей, и подразделений (ЗУП 2.5)

Разработка внешних компонент Практика программирования v8 ЗУП2.5 Россия Бесплатно (free)

Многие из нас сталкивались с проблемой неверного склонения должностей и подразделений внешней компонентой склонения ФИО. Результат при этом может напоминать следующее: 1.Именительный "Главный специалист" 2.Родительный "Главныя специалиста" 3.Дательный "Главныю специалисту " 4.Винительный "Главныя специалиста " 5.Творительный "Главныем специалистом " 6.Предложный "Главные специалисте " Метод борьбы с данным недугом предлагаю ниже.

21.11.2010    61556    director04    64