Универсальный механизм печати подписей согласующих лиц в отчетах конфигурации

Публикация № 71773

Разработка - Практика программирования

Данный алгоритм можно использовать в любой конфигурации.
Небольшие изменения конфигурации ЗУП с целью  создания инструмента, с помощью которого пользователь без труда сможет управлять отображением подписей согласующих лиц в печатных формах отчетов конфигурации. Плюсом предложенного алгоритма является то, что для реализации вышеописанного инструмента нет необходимости в изменении всего множества шаблонов отчетов конфигурации, для пользователя управление печатью подписей всех отчетов будет происходить из одной "точки входа" -  обработки. При этом, подписи можно добавлять, практически, в любое место отчета.

Для этого воспользуемся стандартным механизмом : "Настройка колонтитулов" (Сервис/Настройка колонтитулов). Придеться  добавить доп. функционал , не испортив старого.

 

Здесь мы добавили возможность выбора конкретного отчета , для которого будут применяться настройки, а так же дополниельные настрйки из созданного нами нового перечисления с макетом: "РазделыОтчётов"

 

Создадим и заполним новый регистр сведений для хранения имеющих право подписи: "ДопРазделыОтчётов"

 

Теперь нам осталось внести изменения только в процедуру "УстановитьКолонтитулыПоУмолчанию" общего модуля "УправлениеОтчетами".

В модули отчетов и в макеты никаких изменений вносить не требуется (для стандартного механизма печати колонтитулов вызов вышеуказанной процедуры уже во всех отчетах присутствует).

Организация берется из параметров текущего пользователя.

тзПечатьСтраниц в параметрах - это таблица для расширения данного алгоритма на печать подписей в документах, а так же, если потребуется, печать подписей на каждой странице  (в данный момент, печать подписей в документах не реализована).

 

 Код , примерно, такой:

// Установка колонтитулов для отчета
//
// Параметры
//  ТабличныйДокумент  – ТабличныйДокумент – Отчет, у которого необходимо установить колонтитулы
//  НазваниеОтчета     – Строка            – Название отчета для вывода в колонтитул
//  Пользователь       – Строка            – Имя пользователя для вывода в колонтитул
//
Процедура УстановитьКолонтитулыПоУмолчанию(ТабличныйДокумент, НазваниеОтчета, Пользователь, Дата = Неопределено,тзПечатьСтраниц=Неопределено) Экспорт
Перем
КолСтрокВсего,КолСтраниц;
 
КолСтрокВсего = 0;
 
КолСтраниц = 0;
 
Настройка = ПолучитьНастройкиКолонтитулов();
 Если НЕ
тзПечатьСтраниц = Неопределено Тогда
  Если
тзПечатьСтраниц.Количество() > 0 Тогда
  
тзПечатьСтраниц.Сортировать("Отчёт Возр,НомерСтраницы Возр");
  
СтруктураПоиска = Новый Структура("Отчёт", НазваниеОтчета);
  
МассивНайденныхСтрок = тзПечатьСтраниц.НайтиСтроки(СтруктураПоиска);
   Если
МассивНайденныхСтрок.Количество()> 0 Тогда
    
КолСтрокВсего = МассивНайденныхСтрок[МассивНайденныхСтрок.ВГраница()].ВсегоРазмер;
    
КолСтраниц МассивНайденныхСтрок[МассивНайденныхСтрок.ВГраница()].НомерСтраницы;
   КонецЕсли;
   Если
ТабличныйДокумент.ВысотаТаблицы <= КолСтрокВсего Тогда
    
//начали с начала
    
тзПечатьСтраниц.Очистить();
   КонецЕсли;
  КонецЕсли;
  Если
тзПечатьСтраниц.Количество() = 0 Тогда
     
НоваяСтрока  = тзПечатьСтраниц.Добавить();
   
НоваяСтрока.НомерСтраницы = 0;
   
НоваяСтрока.Отчёт = НазваниеОтчета;
   
НоваяСтрока.ВсегоРазмер = 0;
            
КолСтрокВсего = 0;
   
КолСтраниц = 0;
  КонецЕсли;
 
НоваяСтрока  = тзПечатьСтраниц.Добавить();
 
НоваяСтрока.НомерСтраницы = КолСтраниц+1;
 
НоваяСтрока.Отчёт = НазваниеОтчета;
 
НоваяСтрока.ВсегоРазмер = 0;
 КонецЕсли;
 
//ищим имя объекта по синониму
 
Синоним = СокрЛП(НазваниеОтчета);
 
Имя = "";
 
номСимв = Найти(Синоним,"[");
 Если
номСимв > 0 Тогда
  
Синоним = СокрЛП(Лев(Синоним,номСимв-1));
 КонецЕсли;
 Если НЕ
ПустаяСтрока(Синоним) Тогда
   Для Каждого
ДокументМет из Метаданные.Документы Цикл
    Если
СокрЛП(ДокументМет.Синоним) = Синоним Тогда
     
Имя = "Документ"+СокрЛП(ДокументМет.Имя);
      Прервать;
//->Для Каждого ДокументМет из Метаданные.Документы Цикл
   
КонецЕсли;
    Если
Найти(СокрЛП(ДокументМет.Синоним),Синоним) > 0 Тогда
     
Имя = "Документ"+СокрЛП(ДокументМет.Имя);
      Прервать;
//->Для Каждого ДокументМет из Метаданные.Документы Цикл
   
КонецЕсли;
   КонецЦикла;
   Если
ПустаяСтрока(Имя) Тогда
    Для Каждого
ОтчетМет из Метаданные.Отчеты Цикл
     Если
СокрЛП(ОтчетМет.Синоним) = Синоним Тогда
      
Имя = "Отчет"+СокрЛП(ОтчетМет.Имя);
       Прервать;
//Для Каждого ОтчетМет из Метаданные.Отчеты Цикл
    
КонецЕсли;
     Если
Найти(СокрЛП(ОтчетМет.Синоним),Синоним) > 0 Тогда
      
Имя = "Отчет"+СокрЛП(ОтчетМет.Имя);
       Прервать;
//Для Каждого ОтчетМет из Метаданные.Отчеты Цикл
    
КонецЕсли;
    КонецЦикла;
   КонецЕсли;
   Если НЕ
ПустаяСтрока(Имя) Тогда
    Если
Настройка.Свойство("ПодписиМакетов") Тогда
    
ПодписиМакетов = Настройка["ПодписиМакетов"];
     Если
ПодписиМакетов.Свойство(Имя) Тогда
      Если (
ПодписиМакетов[Имя].ВерхнийКолонтитул.Выводить) или (ПодписиМакетов[Имя].НижнийКолонтитул.Выводить) Тогда
        
Настройка = ПодписиМакетов[Имя];
      КонецЕсли;
     КонецЕсли;
    КонецЕсли;
   КонецЕсли;
  КонецЕсли;
 
ШиринаСимвола  = 1;
 
ШиринаДокумента = ТабличныйДокумент.ШиринаТаблицы;
 
ВысотаДокумента = ТабличныйДокумент.ВысотаТаблицы;

 
тзСрезПоследних = РегистрыСведений.ДопРазделыОтчётов.СрезПоследних(?((Дата = Неопределено) или (Дата = Дата(1, 1, 1)),РабочаяДата,Дата),);
 
Запрос = Новый Запрос;
 
Запрос.Текст = "ВЫБРАТЬ
                | НастройкиПользователей.Значение как Организация
                |ИЗ
                | РегистрСведений.НастройкиПользователей КАК НастройкиПользователей
                |  ЛЕВОЕ СОЕДИНЕНИЕ ПланВидовХарактеристик.НастройкиПользователей КАК НастройкиПользователей1
                |  ПО НастройкиПользователей.Настройка = НастройкиПользователей1.Ссылка
                |ГДЕ
                | НастройкиПользователей.Пользователь = &Пользователь
                | И НастройкиПользователей.Настройка = &Организация"
;

 
Запрос.УстановитьПараметр("Пользователь", ПараметрыСеанса.ТекущийПользователь);
 
Запрос.УстановитьПараметр("Организация",ПланыВидовХарактеристик.НастройкиПользователей.ОсновнаяОрганизация);
 
тзРезультат = Новый ТаблицаЗначений;
 
тзРезультат = Запрос.Выполнить().Выгрузить();
 
Организация = Справочники.Организации.ПустаяСсылка();
 Если
тзРезультат.Количество()>0 Тогда
  Если НЕ
тзРезультат[0]["Организация"] =  Неопределено  тогда
   Если НЕ
тзРезультат[0]["Организация"].Пустая()  тогда
    
Организация = тзРезультат[0]["Организация"].Ссылка;
   КонецЕсли;
  КонецЕсли;
 КонецЕсли;

 
//***МЕТКА1
 
ОтступСлева    = 0;
 
ОтступСправа   = 0;
 
ОтступСверху   = 0;
 
ВысотаПодписи   = 0;
 
ВысотаПодписиВсего = 0;
 
ВысотаПодписиТек  = 0;
 
ШиринаПодписиВсего  = 40;

 
//вверх - лево
 
ПерваяОрганизация = Справочники.Организации.ПустаяСсылка();
 Если
Настройка.ВерхнийКолонтитул.Свойство("ТекстСлева") //Если Настройка.ВерхнийКолонтитул.Свойство("ТекстСлева") Тогда
 
Для Сч = 0 По Перечисления.РазделыОтчётов.Количество()-1 //Для Сч = 0 По Перечисления.РазделыОтчётов.Количество()-1 Цикл
  
ВыбЭлемент = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Имя;
   Если (
Найти(Настройка.ВерхнийКолонтитул.ТекстСлева,"[&"+СокрЛП(ВыбЭлемент)+"]")>0) и (Настройка.ВерхнийКолонтитул.Выводить) Тогда
   
Синоним    = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Синоним;
   
Отбор = Новый Структура;
   
Отбор.Вставить("РазделОтчёта",Перечисления.РазделыОтчётов.Получить(Сч));
    Если НЕ
Организация.Пустая() Тогда
    
Отбор.Вставить("Организация",Организация);
    КонецЕсли;
   
МассивСтрок  = тзСрезПоследних.НайтиСтроки(Отбор);
   
ОтступСверху  = КолСтрокВсего;
   
ПерваяОрганизация = Справочники.Организации.ПустаяСсылка();
   
ИтоговыйДокумент   = Новый ТекстовыйДокумент;
   
ИтоговыйДокумент.Очистить();
   
Макет       = Перечисления.РазделыОтчётов.ПолучитьМакет("МакетТекст");
   
обМакет         = Макет.ПолучитьОбласть("Заголовок");
   
обМакет.Параметры.Заголовок = СокрЛП(Синоним);
   
ИтоговыйДокумент.Вывести(обМакет);
   
обМакет         = Макет.ПолучитьОбласть("Раздел");
   
ОтступСлева      = 0;
   
//ОтступСправа     = Макс(ШиринаДокумента - РазмерОбласти,0);
   
ОтступСправа     = Макс(ШиринаДокумента - 1,0);
   
//вывожу элементы
   
Для Каждого  строкаТЗ ИЗ МассивСтрок Цикл
     Если
ПерваяОрганизация.Пустая() Тогда
      
ПерваяОрганизация = строкаТЗ.Организация;
     КонецЕсли;
     Если
ПерваяОрганизация <> строкаТЗ.Организация Тогда
       Продолжить;
     КонецЕсли;
    
ФИО = "";
     Если НЕ
строкаТЗ.ФизЛицо.Пустая() Тогда
      
ФИО = СокрЛП(строкаТЗ.ФизЛицо.Наименование);
     КонецЕсли;
    
Инициалы ="";
    
МассивФИО = ОбщегоНазначения.ПолучитьМассивФИО(ФИО);
     Если (НЕ
ПустаяСтрока(МассивФИО[1])) И (НЕ ПустаяСтрока(МассивФИО[2])) Тогда
      
Инициалы =" "+Лев(МассивФИО[1],1) + "." + Лев(МассивФИО[2],1)+".";
     КонецЕсли;
    
ФИО        = СокрЛП(МассивФИО[0] + Инициалы);
    
обМакет.Параметры.Должность  = СокрЛП(строкаТЗ.Должность);
    
обМакет.Параметры.ФИО    = ФИО;
    
ИтоговыйДокумент.Вывести(обМакет);
    КонецЦикла;
   
обТД         = ТабличныйДокумент.Область(ОтступСверху+1,1,ОтступСверху+2,ШиринаДокумента);
   
ТабДок     = Новый ТабличныйДокумент;
   
обТДИсточник  = ТабДок.Область(ОтступСверху+1,1,ОтступСверху+2,ШиринаДокумента);
   
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.ПоВертикали,Ложь);
   
обТД         = ТабличныйДокумент.Область(ОтступСверху+1,1,ОтступСверху+1,1);
   
обТД.Текст    = ИтоговыйДокумент.ПолучитьТекст();
   
обТД.Шрифт    = Новый Шрифт(обТДИсточник.Шрифт,"Courier",8,Ложь,Ложь,Ложь,Ложь);
   
обТД.ВертикальноеПоложение  = ВертикальноеПоложение.Верх;
   
обТД1         = ТабличныйДокумент.Область(,,,);
   
обТД1.ВысотаСтроки  = 0;
   
Настройка.ВерхнийКолонтитул.ТекстСлева = СтрЗаменить(Настройка.ВерхнийКолонтитул.ТекстСлева,"[&"+СокрЛП(ВыбЭлемент)+"]","");
   
ВысотаПодписиВсего  = ВысотаПодписиВсего + 1;
   КонецЕсли;
  КонецЦикла;
//Для Сч = 0 По Перечисления.РазделыОтчётов.Количество()-1 Цикл
 
КонецЕсли;//Если Настройка.ВерхнийКолонтитул.Свойство("ТекстСлева") Тогда
//***МЕТКА2
//вверх - центр
 
ВысотаПодписи = ?(ВысотаПодписиВсего>0,2*ВысотаПодписиВсего-2,0);
 Если
Настройка.ВерхнийКолонтитул.Свойство("ТекстВЦентре") Тогда
  Для
Сч = 0 По Перечисления.РазделыОтчётов.Количество()-1 Цикл
  
ВыбЭлемент = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Имя;
   Если (
Найти(Настройка.ВерхнийКолонтитул.ТекстВЦентре,"[&"+СокрЛП(ВыбЭлемент)+"]")>0) и (Настройка.ВерхнийКолонтитул.Выводить) Тогда
   
Синоним     = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Синоним;
   
Отбор   = Новый Структура;
   
Отбор.Вставить("РазделОтчёта",Перечисления.РазделыОтчётов.Получить(Сч));
    Если НЕ
Организация.Пустая() Тогда
    
Отбор.Вставить("Организация",Организация);
    КонецЕсли;
   
МассивСтрок = тзСрезПоследних.НайтиСтроки(Отбор);
   
ОтступСверху = КолСтрокВсего;
   
ОтступСлева  = 0;
   
ОтступСправа = 0;
   
//найдем ширину документа в средних символах:
   
ШиринаДокументаВСимволах = 0;
    Для
СчЯчейка = 1 По ШиринаДокумента Цикл
    
обТД        = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху+1,СчЯчейка,ВысотаПодписи + ОтступСверху+1,СчЯчейка);
    
ШиринаДокументаВСимволах= ШиринаДокументаВСимволах + окр(обТД.ШиринаКолонки,0,1);
    КонецЦикла;
   
ЛеваяГраница = 1;
   
ПраваяГраница = ШиринаДокумента;
   
ШагВперёд = Истина;
   
ТекШирина = ШиринаДокументаВСимволах;
    Пока (
ПраваяГраница > ЛеваяГраница) и (ТекШирина > ШиринаПодписиВсего*ШиринаСимвола) Цикл
    
//слева шагаем
    
Если ШагВперёд Тогда
     
обШаг    = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,ЛеваяГраница,ВысотаПодписи + ОтступСверху+1,ЛеваяГраница);
     
ШагШирина   = окр(обШаг.ШиринаКолонки,0,1);
     
ЛеваяГраница  = ЛеваяГраница+1;
     
ТекШирина  = ТекШирина - ШагШирина;
     КонецЕсли;
    
//справа шагаем
    
Если НЕ ШагВперёд Тогда
     
обШаг    = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,ПраваяГраница,ВысотаПодписи + ОтступСверху+1,ПраваяГраница);
     
ШагШирина   = окр(обШаг.ШиринаКолонки,0,1);
     
ПраваяГраница  = ПраваяГраница - 1;
     
ТекШирина  = ТекШирина - ШагШирина;
     КонецЕсли;
    
ШагВперёд = НЕ ШагВперёд;
    КонецЦикла;
   
ОтступСлева    = ЛеваяГраница - 1;
   
ОтступСправа   = ШиринаДокумента - ПраваяГраница;
   
ПерваяОрганизация  = Справочники.Организации.ПустаяСсылка();
   
ИтоговыйДокумент   = Новый ТекстовыйДокумент;
   
ИтоговыйДокумент.Очистить();
   
Макет       = Перечисления.РазделыОтчётов.ПолучитьМакет("МакетТекст");
   
обМакет         = Макет.ПолучитьОбласть("Заголовок");
   
обМакет.Параметры.Заголовок = СокрЛП(Синоним);
   
ИтоговыйДокумент.Вывести(обМакет);
   
обМакет         = Макет.ПолучитьОбласть("Раздел");
    Для Каждого 
строкаТЗ ИЗ МассивСтрок Цикл
     Если
ПерваяОрганизация.Пустая() Тогда
      
ПерваяОрганизация = строкаТЗ.Организация;
     КонецЕсли;
     Если
ПерваяОрганизация <> строкаТЗ.Организация Тогда
      Продолжить;
     КонецЕсли;
    
ФИО = "";
     Если НЕ
строкаТЗ.ФизЛицо.Пустая() Тогда
      
ФИО = СокрЛП(строкаТЗ.ФизЛицо.Наименование);
     КонецЕсли;
    
Инициалы ="";
    
МассивФИО = ОбщегоНазначения.ПолучитьМассивФИО(ФИО);
     Если (НЕ
ПустаяСтрока(МассивФИО[1])) И (НЕ ПустаяСтрока(МассивФИО[2])) Тогда
      
Инициалы =" "+Лев(МассивФИО[1],1) + "." + Лев(МассивФИО[2],1)+".";
     КонецЕсли;
    
ФИО        = СокрЛП(МассивФИО[0] + Инициалы);
    
обМакет.Параметры.Должность  = СокрЛП(строкаТЗ.Должность);
    
обМакет.Параметры.ФИО    = ФИО;
    
ИтоговыйДокумент.Вывести(обМакет);
    КонецЦикла;
   
ТабДок     = Новый ТабличныйДокумент;
    Если (
ВысотаПодписиТек  < ВысотаПодписиВсего) и (ВысотаПодписиВсего <> 0) Тогда
    
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,ОтступСлева + 1,ВысотаПодписи + ОтступСверху + 2,ШиринаДокумента);
                   
обТДИсточник  = ТабДок.Область(ОтступСверху+1,ОтступСлева + 1,ОтступСверху+2,ШиринаДокумента);
    
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.БезСмещения,Ложь);
    Иначе
    
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,1,ВысотаПодписи + ОтступСверху + 2,ШиринаДокумента);
                   
обТДИсточник  = ТабДок.Область(ОтступСверху+1,1,ОтступСверху+2,ШиринаДокумента);
    
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.ПоВертикали,Ложь);
    КонецЕсли;
   
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху+1,ОтступСлева + 1,ВысотаПодписи + ОтступСверху+1,ОтступСлева + 1);
   
обТД.Текст    = ИтоговыйДокумент.ПолучитьТекст();
   
обТД.Шрифт    = Новый Шрифт(обТДИсточник.Шрифт,"Courier",8,Ложь,Ложь,Ложь,Ложь);
   
обТД.ВертикальноеПоложение  = ВертикальноеПоложение.Верх;
   
обТД1         = ТабличныйДокумент.Область(,,,);
   
обТД1.ВысотаСтроки  = 0;
   
Настройка.ВерхнийКолонтитул.ТекстВЦентре = СтрЗаменить(Настройка.ВерхнийКолонтитул.ТекстСлева,"[&"+СокрЛП(ВыбЭлемент)+"]","");
   
ВысотаПодписиТек   = ВысотаПодписиТек  1;
    Если
ВысотаПодписиТек >= ВысотаПодписиВсего Тогда
    
ВысотаПодписи = 0;
    Иначе
    
ВысотаПодписи = 2*(ВысотаПодписиВсего-ВысотаПодписиТек)-2;
    КонецЕсли;
   КонецЕсли;
  КонецЦикла;
 КонецЕсли;
   
ВысотаПодписиВсего  = Макс(ВысотаПодписиТек,ВысотаПодписиВсего);
 
ВысотаПодписиТек  = 0;
 
ВысотаПодписи = ?(ВысотаПодписиВсего>0,2*ВысотаПодписиВсего-2,0);
//***МЕТКА3
//вверх - право
 
Если Настройка.ВерхнийКолонтитул.Свойство("ТекстСправа") Тогда
  Для
Сч = 0 По Перечисления.РазделыОтчётов.Количество()-1 Цикл
  
ВыбЭлемент = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Имя;
   Если (
Найти(Настройка.ВерхнийКолонтитул.ТекстСправа,"[&"+СокрЛП(ВыбЭлемент)+"]")>0) и (Настройка.ВерхнийКолонтитул.Выводить)  Тогда
   
Синоним     = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Синоним;
   
Отбор   = Новый Структура;
   
Отбор.Вставить("РазделОтчёта",Перечисления.РазделыОтчётов.Получить(Сч));
    Если НЕ
Организация.Пустая() Тогда
    
Отбор.Вставить("Организация",Организация);
    КонецЕсли;
   
МассивСтрок = тзСрезПоследних.НайтиСтроки(Отбор);
   
ОтступСлева = 0;
   
ОтступСправа = 0;
   
ОтступСверху = КолСтрокВсего;
   
ШиринаВсего = 0;
   
НомЯчейки = ШиринаДокумента + 1;
    Для
СчЯчейки  = - ШиринаДокумента По -1 Цикл
    
НомЯчейки  = - СчЯчейки;
    
обПодпись  = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху+1,НомЯчейки,ВысотаПодписи + ОтступСверху+1,НомЯчейки);
    
ШиринаВсего = ШиринаВсего+окр(обПодпись.ШиринаКолонки,0,1);
     Если
ШиринаВсего >= ШиринаПодписиВсего*ШиринаСимвола  Тогда
       Прервать;
     КонецЕсли;
    КонецЦикла;
   
ПерваяОрганизация = Справочники.Организации.ПустаяСсылка();
   
ОтступСлева = НомЯчейки  - 1;
   
ИтоговыйДокумент   = Новый ТекстовыйДокумент;
   
ИтоговыйДокумент.Очистить();
   
Макет       = Перечисления.РазделыОтчётов.ПолучитьМакет("МакетТекст");
   
обМакет         = Макет.ПолучитьОбласть("Заголовок");
   
обМакет.Параметры.Заголовок = СокрЛП(Синоним);
   
ИтоговыйДокумент.Вывести(обМакет);
   
обМакет         = Макет.ПолучитьОбласть("Раздел");
    Для Каждого 
строкаТЗ ИЗ МассивСтрок Цикл
     Если
ПерваяОрганизация.Пустая() Тогда
      
ПерваяОрганизация = строкаТЗ.Организация;
     КонецЕсли;
     Если
ПерваяОрганизация <> строкаТЗ.Организация Тогда
      Продолжить;
     КонецЕсли;
    
ФИО = "";
     Если НЕ
строкаТЗ.ФизЛицо.Пустая() Тогда
      
ФИО = СокрЛП(строкаТЗ.ФизЛицо.Наименование);
     КонецЕсли;
    
Инициалы ="";
    
МассивФИО = ОбщегоНазначения.ПолучитьМассивФИО(ФИО);
     Если (НЕ
ПустаяСтрока(МассивФИО[1])) И (НЕ ПустаяСтрока(МассивФИО[2])) Тогда
      
Инициалы =" "+Лев(МассивФИО[1],1) + "." + Лев(МассивФИО[2],1)+".";
     КонецЕсли;
    
ФИО        = СокрЛП(МассивФИО[0] + Инициалы);
    
обМакет.Параметры.Должность  = СокрЛП(строкаТЗ.Должность);
    
обМакет.Параметры.ФИО    = ФИО;
    
ИтоговыйДокумент.Вывести(обМакет);
    КонецЦикла;
   
ТабДок      = Новый ТабличныйДокумент;
    Если (
ВысотаПодписиТек  < ВысотаПодписиВсего) и (ВысотаПодписиВсего <> 0) Тогда
    
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,ОтступСлева + 1,ВысотаПодписи + ОтступСверху + 2,ШиринаДокумента);
    
обТДИсточник  = ТабДок.Область(ОтступСверху+1,ОтступСлева + 1,ОтступСверху+2,ШиринаДокумента);
    
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.БезСмещения,Ложь);
    Иначе
    
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,1,ВысотаПодписи + ОтступСверху + 2,ШиринаДокумента);
    
обТДИсточник  = ТабДок.Область(ОтступСверху+1,1,ОтступСверху+2,ШиринаДокумента);
    
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.ПоВертикали,Ложь);
    КонецЕсли;
   
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху+1,ОтступСлева + 1,ВысотаПодписи + ОтступСверху+1,ОтступСлева + 1);
   
обТД.Текст    = ИтоговыйДокумент.ПолучитьТекст();
   
обТД.Шрифт    = Новый Шрифт(обТДИсточник.Шрифт,"Courier",8,Ложь,Ложь,Ложь,Ложь);
   
обТД.ВертикальноеПоложение  = ВертикальноеПоложение.Верх;
   
обТД1         = ТабличныйДокумент.Область(,,,);
   
обТД1.ВысотаСтроки  = 0;
   
ВысотаПодписиТек   = ВысотаПодписиТек  1;
    Если
ВысотаПодписиТек >= ВысотаПодписиВсего Тогда
    
ВысотаПодписи = 0;
    Иначе
    
ВысотаПодписи = 2*(ВысотаПодписиВсего-ВысотаПодписиТек)-2;
    КонецЕсли;
   
Настройка.ВерхнийКолонтитул.ТекстСправа = СтрЗаменить(Настройка.ВерхнийКолонтитул.ТекстСправа,"[&"+СокрЛП(ВыбЭлемент)+"]","");
   КонецЕсли;
  КонецЦикла;
 КонецЕсли;
 
ВысотаПодписиВсего  = 0;
 
ВысотаПодписиТек  = 0;
 
ВысотаПодписи   = 0;
 
ВысотаДокумента  = ТабличныйДокумент.ВысотаТаблицы;
//МЕТКА4
//низ-лево
 
Если Настройка.НижнийКолонтитул.Свойство("ТекстСлева") Тогда
  Для
Сч = 0 По Перечисления.РазделыОтчётов.Количество()-1 Цикл
  
ВыбЭлемент = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Имя;
   Если (
Найти(Настройка.НижнийКолонтитул.ТекстСлева,"[&"+СокрЛП(ВыбЭлемент)+"]")>0) и (Настройка.НижнийКолонтитул.Выводить) Тогда
   
ОтступСлева  = 0;
   
ОтступСправа = Макс(ШиринаДокумента - 1,0);
   
ОтступСверху = ТабличныйДокумент.ВысотаТаблицы;
   
Синоним    = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Синоним;
   
Отбор = Новый Структура;
   
Отбор.Вставить("РазделОтчёта",Перечисления.РазделыОтчётов.Получить(Сч));
    Если НЕ
Организация.Пустая() Тогда
    
Отбор.Вставить("Организация",Организация);
    КонецЕсли;
   
МассивСтрок  = тзСрезПоследних.НайтиСтроки(Отбор);
   
ПерваяОрганизация = Справочники.Организации.ПустаяСсылка();
   
ИтоговыйДокумент   = Новый ТекстовыйДокумент;
   
ИтоговыйДокумент.Очистить();
   
Макет       = Перечисления.РазделыОтчётов.ПолучитьМакет("МакетТекст");
   
обМакет         = Макет.ПолучитьОбласть("Заголовок");
   
обМакет.Параметры.Заголовок = СокрЛП(Синоним);
   
ИтоговыйДокумент.Вывести(обМакет);
   
обМакет         = Макет.ПолучитьОбласть("Раздел");
   
Настройка.НижнийКолонтитул.ТекстСлева = СтрЗаменить(Настройка.НижнийКолонтитул.ТекстСлева,"[&"+СокрЛП(ВыбЭлемент)+"]","");
    Для Каждого 
строкаТЗ ИЗ МассивСтрок Цикл
     Если
ПерваяОрганизация.Пустая() Тогда
      
ПерваяОрганизация = строкаТЗ.Организация;
     КонецЕсли;
     Если
ПерваяОрганизация <> строкаТЗ.Организация Тогда
      Продолжить;
     КонецЕсли;
    
ФИО = "";
     Если НЕ
строкаТЗ.ФизЛицо.Пустая() Тогда
      
ФИО = СокрЛП(строкаТЗ.ФизЛицо.Наименование);
     КонецЕсли;
    
Инициалы ="";
    
МассивФИО = ОбщегоНазначения.ПолучитьМассивФИО(ФИО);
     Если (НЕ
ПустаяСтрока(МассивФИО[1])) И (НЕ ПустаяСтрока(МассивФИО[2])) Тогда
      
Инициалы =" "+Лев(МассивФИО[1],1) + "." + Лев(МассивФИО[2],1)+".";
     КонецЕсли;
    
ФИО        = СокрЛП(МассивФИО[0] + Инициалы);
    
обМакет.Параметры.Должность  = СокрЛП(строкаТЗ.Должность);
    
обМакет.Параметры.ФИО    = ФИО;
    
ИтоговыйДокумент.Вывести(обМакет);
    КонецЦикла;
   
обТД         = ТабличныйДокумент.Область(ОтступСверху+1,1,ОтступСверху+2,ШиринаДокумента);
   
ТабДок     = Новый ТабличныйДокумент;
   
обТДИсточник  = ТабДок.Область(ОтступСверху+1,1,ОтступСверху+2,ШиринаДокумента);
   
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.ПоВертикали,Ложь);
   
обТД         = ТабличныйДокумент.Область(ОтступСверху+2,1,ОтступСверху+2,1);
   
обТД.Текст    = ИтоговыйДокумент.ПолучитьТекст();
   
обТД.Шрифт    = Новый Шрифт(обТДИсточник.Шрифт,"Courier",8,Ложь,Ложь,Ложь,Ложь);
   
обТД.ВертикальноеПоложение  = ВертикальноеПоложение.Верх;
   
обТД1         = ТабличныйДокумент.Область(,,,);
   
обТД1.ВысотаСтроки  = 0;
   
ВысотаПодписиВсего  = ВысотаПодписиВсего + 1;
   КонецЕсли;
  КонецЦикла;
 КонецЕсли;
//МЕТКА5
//низ - центр
 
ВысотаПодписиВсего  = Макс(ВысотаПодписиТек,ВысотаПодписиВсего);
 
ВысотаПодписиТек  = 0;
 
ВысотаПодписи = 0;
 Если
Настройка.НижнийКолонтитул.Свойство("ТекстВЦентре") Тогда
  Для
Сч = 0 По Перечисления.РазделыОтчётов.Количество()-1 Цикл
  
ВыбЭлемент = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Имя;
   Если (
Найти(Настройка.НижнийКолонтитул.ТекстВЦентре,"[&"+СокрЛП(ВыбЭлемент)+"]")>0) и (Настройка.НижнийКолонтитул.Выводить) Тогда
   
ОтступСлева  = 0;
   
ОтступСправа = 0;
   
ОтступСверху = ВысотаДокумента;
   
Синоним      = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Синоним;
   
Отбор    = Новый Структура;
   
Отбор.Вставить("РазделОтчёта",Перечисления.РазделыОтчётов.Получить(Сч));
    Если НЕ
Организация.Пустая() Тогда
    
Отбор.Вставить("Организация",Организация);
    КонецЕсли;
   
МассивСтрок = тзСрезПоследних.НайтиСтроки(Отбор);
   
ШиринаДокументаВСимволах = 0;
    Для
СчЯчейка = 1 По ШиринаДокумента Цикл
    
обТД    = ТабличныйДокумент.Область(ОтступСверху+1,СчЯчейка,ОтступСверху+1,СчЯчейка);
    
ШиринаДокументаВСимволах=ШиринаДокументаВСимволах + окр(обТД.ШиринаКолонки,0,1);
    КонецЦикла;
   
ЛеваяГраница = 1;
   
ПраваяГраница = ШиринаДокумента;
   
ШагВперёд = Истина;
   
ТекШирина = ШиринаДокументаВСимволах;
    Пока (
ПраваяГраница > ЛеваяГраница) и (ТекШирина > ШиринаПодписиВсего*ШиринаСимвола) Цикл
    
//слева шагаем
    
Если ШагВперёд Тогда
     
обШаг    = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,ЛеваяГраница,ВысотаПодписи + ОтступСверху+1,ЛеваяГраница);
     
ШагШирина   = окр(обШаг.ШиринаКолонки,0,1);
     
ЛеваяГраница  = ЛеваяГраница+1;
     
ТекШирина  = ТекШирина - ШагШирина;
     КонецЕсли;
    
//справа шагаем
    
Если НЕ ШагВперёд Тогда
     
обШаг    = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,ПраваяГраница,ВысотаПодписи + ОтступСверху+1,ПраваяГраница);
     
ШагШирина   = окр(обШаг.ШиринаКолонки,0,1);
     
ПраваяГраница  = ПраваяГраница - 1;
     
ТекШирина  = ТекШирина - ШагШирина;
     КонецЕсли;
    
ШагВперёд = НЕ ШагВперёд;
    КонецЦикла;
   
ОтступСлева    = ЛеваяГраница - 1;
   
ОтступСправа   = ШиринаДокумента - ПраваяГраница;
   
ПерваяОрганизация  = Справочники.Организации.ПустаяСсылка();
   
ИтоговыйДокумент   = Новый ТекстовыйДокумент;
   
ИтоговыйДокумент.Очистить();
   
Макет          = Перечисления.РазделыОтчётов.ПолучитьМакет("МакетТекст");
   
обМакет            = Макет.ПолучитьОбласть("Заголовок");
   
обМакет.Параметры.Заголовок    = СокрЛП(Синоним);
   
ИтоговыйДокумент.Вывести(обМакет);
   
обМакет            = Макет.ПолучитьОбласть("Раздел");
   
Настройка.НижнийКолонтитул.ТекстВЦентре = СтрЗаменить(Настройка.НижнийКолонтитул.ТекстВЦентре,"[&"+СокрЛП(ВыбЭлемент)+"]","");
   
//вывожу элементы
   
Для Каждого  строкаТЗ ИЗ МассивСтрок Цикл
     Если
ПерваяОрганизация.Пустая() Тогда
      
ПерваяОрганизация = строкаТЗ.Организация;
     КонецЕсли;
     Если
ПерваяОрганизация <> строкаТЗ.Организация Тогда
      Продолжить;
     КонецЕсли;
    
ФИО = "";
     Если НЕ
строкаТЗ.ФизЛицо.Пустая() Тогда
      
ФИО = СокрЛП(строкаТЗ.ФизЛицо.Наименование);
     КонецЕсли;
    
Инициалы ="";
    
МассивФИО = ОбщегоНазначения.ПолучитьМассивФИО(ФИО);
     Если (НЕ
ПустаяСтрока(МассивФИО[1])) И (НЕ ПустаяСтрока(МассивФИО[2])) Тогда
      
Инициалы =" "+Лев(МассивФИО[1],1) + "." + Лев(МассивФИО[2],1)+".";
     КонецЕсли;
    
ФИО        = СокрЛП(МассивФИО[0] + Инициалы);
    
обМакет.Параметры.Должность  = СокрЛП(строкаТЗ.Должность);
    
обМакет.Параметры.ФИО    = ФИО;
    
ИтоговыйДокумент.Вывести(обМакет);
    КонецЦикла;
   
ТабДок     = Новый ТабличныйДокумент;
    Если (
ВысотаПодписиТек  < ВысотаПодписиВсего) и (ВысотаПодписиВсего <> 0) Тогда
    
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,ОтступСлева + 1,ВысотаПодписи + ОтступСверху + 2,ШиринаДокумента);
    
обТДИсточник  = ТабДок.Область(ОтступСверху+1,ОтступСлева + 1,ОтступСверху+2,ШиринаДокумента);
    
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.БезСмещения,Ложь);
    Иначе
    
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,1,ВысотаПодписи + ОтступСверху + 2,ШиринаДокумента);
    
обТДИсточник  = ТабДок.Область(ОтступСверху+1,1,ОтступСверху+2,ШиринаДокумента);
    
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.ПоВертикали,Ложь);
    КонецЕсли;
   
обТД           = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху+2,ОтступСлева + 1,ВысотаПодписи + ОтступСверху+2,ОтступСлева + 1);
   
обТД.Текст      = ИтоговыйДокумент.ПолучитьТекст();
   
обТД.Шрифт      = Новый Шрифт(обТДИсточник.Шрифт,"Courier",8,Ложь,Ложь,Ложь,Ложь);
   
обТД.ВертикальноеПоложение  = ВертикальноеПоложение.Верх;
   
обТД1           = ТабличныйДокумент.Область(,,,);
   
обТД1.ВысотаСтроки    = 0;
   
ВысотаПодписиТек     = ВысотаПодписиТек  1;
   
ВысотаПодписи   = ВысотаПодписи + 2;
   КонецЕсли;
  КонецЦикла;
 КонецЕсли;
 
ВысотаПодписиВсего  = Макс(ВысотаПодписиТек,ВысотаПодписиВсего);
 
ВысотаПодписиТек  = 0;
 
ВысотаПодписи = 0;
//МЕТКА6
//низ - право
 
Если Настройка.НижнийКолонтитул.Свойство("ТекстСправа") Тогда
   Для
Сч = 0 По Перечисления.РазделыОтчётов.Количество()-1 Цикл
  
ВыбЭлемент = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Имя;
   Если (
Найти(Настройка.НижнийКолонтитул.ТекстСправа,"[&"+СокрЛП(ВыбЭлемент)+"]")>0) и (Настройка.НижнийКолонтитул.Выводить) Тогда
   
ОтступСлева   = 0;
   
ОтступСправа  = 0;
   
ОтступСверху  = ВысотаДокумента;
   
Синоним      = Перечисления.РазделыОтчётов.Получить(Сч).Метаданные().ЗначенияПеречисления[Сч].Синоним;
   
Отбор    = Новый Структура;
   
Отбор.Вставить("РазделОтчёта",Перечисления.РазделыОтчётов.Получить(Сч));
    Если НЕ
Организация.Пустая() Тогда
    
Отбор.Вставить("Организация",Организация);
    КонецЕсли;
   
МассивСтрок = тзСрезПоследних.НайтиСтроки(Отбор);
   
ШиринаВсего = 0;
   
НомЯчейки = ШиринаДокумента + 1;
    Для
СчЯчейки  = - ШиринаДокумента По -1 Цикл
    
НомЯчейки  = - СчЯчейки;
    
обПодпись  = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху+1,НомЯчейки,ВысотаПодписи + ОтступСверху+1,НомЯчейки);
    
ШиринаВсего = ШиринаВсего+окр(обПодпись.ШиринаКолонки,0,1);
     Если
ШиринаВсего >= ШиринаПодписиВсего*ШиринаСимвола  Тогда
       Прервать;
     КонецЕсли;
    КонецЦикла;
   
ПерваяОрганизация = Справочники.Организации.ПустаяСсылка();
   
ОтступСлева = НомЯчейки  - 1;
   
ИтоговыйДокумент   = Новый ТекстовыйДокумент;
   
ИтоговыйДокумент.Очистить();
   
Макет       = Перечисления.РазделыОтчётов.ПолучитьМакет("МакетТекст");
   
обМакет         = Макет.ПолучитьОбласть("Заголовок");
   
обМакет.Параметры.Заголовок = СокрЛП(Синоним);
   
ИтоговыйДокумент.Вывести(обМакет);
   
обМакет         = Макет.ПолучитьОбласть("Раздел");
   
Настройка.НижнийКолонтитул.ТекстСправа = СтрЗаменить(Настройка.НижнийКолонтитул.ТекстСправа,"[&"+СокрЛП(ВыбЭлемент)+"]","");
    Для Каждого 
строкаТЗ ИЗ МассивСтрок Цикл
     Если
ПерваяОрганизация.Пустая() Тогда
      
ПерваяОрганизация = строкаТЗ.Организация;
     КонецЕсли;
     Если
ПерваяОрганизация <> строкаТЗ.Организация Тогда
      Продолжить;
     КонецЕсли;
    
ФИО = "";
     Если НЕ
строкаТЗ.ФизЛицо.Пустая() Тогда
      
ФИО = СокрЛП(строкаТЗ.ФизЛицо.Наименование);
     КонецЕсли;
    
Инициалы ="";
    
МассивФИО = ОбщегоНазначения.ПолучитьМассивФИО(ФИО);
     Если (НЕ
ПустаяСтрока(МассивФИО[1])) И (НЕ ПустаяСтрока(МассивФИО[2])) Тогда
      
Инициалы =" "+Лев(МассивФИО[1],1) + "." + Лев(МассивФИО[2],1)+".";
     КонецЕсли;
    
ФИО        = СокрЛП(МассивФИО[0] + Инициалы);
    
обМакет.Параметры.Должность  = СокрЛП(строкаТЗ.Должность);
    
обМакет.Параметры.ФИО    = ФИО;
    
ИтоговыйДокумент.Вывести(обМакет);
    КонецЦикла;
   
ТабДок      = Новый ТабличныйДокумент;
    Если (
ВысотаПодписиТек  < ВысотаПодписиВсего) и (ВысотаПодписиВсего <> 0) Тогда
    
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,ОтступСлева + 1,ВысотаПодписи + ОтступСверху + 2,ШиринаДокумента);
    
обТДИсточник  = ТабДок.Область(ОтступСверху+1,ОтступСлева + 1,ОтступСверху+2,ШиринаДокумента);
    
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.БезСмещения,Ложь);
    Иначе
    
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху + 1,1,ВысотаПодписи + ОтступСверху + 2,ШиринаДокумента);
    
обТДИсточник  = ТабДок.Область(ОтступСверху+1,1,ОтступСверху+2,ШиринаДокумента);
    
ТабличныйДокумент.ВставитьОбласть(обТДИсточник,обТД,ТипСмещенияТабличногоДокумента.ПоВертикали,Ложь);
    КонецЕсли;
   
обТД         = ТабличныйДокумент.Область(ВысотаПодписи + ОтступСверху+2,ОтступСлева + 1,ВысотаПодписи + ОтступСверху+2,ОтступСлева + 1);
   
обТД.Текст    = ИтоговыйДокумент.ПолучитьТекст();
   
обТД.Шрифт    = Новый Шрифт(обТДИсточник.Шрифт,"Courier",8,Ложь,Ложь,Ложь,Ложь);
   
обТД.ВертикальноеПоложение  = ВертикальноеПоложение.Верх;
   
обТД1         = ТабличныйДокумент.Область(,,,);
   
обТД1.ВысотаСтроки  = 0;
   
ВысотаПодписиТек   = ВысотаПодписиТек  1;
   
ВысотаПодписи   = ВысотаПодписи + 2;
   КонецЕсли;
  КонецЦикла;
 КонецЕсли;


 Если НЕ
тзПечатьСтраниц = Неопределено Тогда
 
НоваяСтрока.ВсегоРазмер = ТабличныйДокумент.ВысотаТаблицы;
 КонецЕсли;
 
//}
 
Если Настройка.ВерхнийКолонтитул.Свойство("Выводить") Тогда
 
ТабличныйДокумент.ВерхнийКолонтитул.Выводить          = Настройка.ВерхнийКолонтитул.Выводить;
 
ТабличныйДокумент.ВерхнийКолонтитул.НачальнаяСтраница = Настройка.ВерхнийКолонтитул.НачальнаяСтраница;
 
ТабличныйДокумент.ВерхнийКолонтитул.ВертикальноеПоложение = ВертикальноеПоложение.Низ;
 
ТабличныйДокумент.ВерхнийКолонтитул.ТекстСлева   = ЗаполнитьТекстКолонтитула(Настройка.ВерхнийКолонтитул.ТекстСлева, НазваниеОтчета, Пользователь);
 
ТабличныйДокумент.ВерхнийКолонтитул.ТекстВЦентре = ЗаполнитьТекстКолонтитула(Настройка.ВерхнийКолонтитул.ТекстВЦентре, НазваниеОтчета, Пользователь);
 
ТабличныйДокумент.ВерхнийКолонтитул.ТекстСправа  = ЗаполнитьТекстКолонтитула(Настройка.ВерхнийКолонтитул.ТекстСправа, НазваниеОтчета, Пользователь);
 КонецЕсли;
 Если
Настройка.НижнийКолонтитул.Свойство("Выводить") Тогда
 
ТабличныйДокумент.НижнийКолонтитул.Выводить          = Настройка.НижнийКолонтитул.Выводить;
 
ТабличныйДокумент.НижнийКолонтитул.НачальнаяСтраница = Настройка.НижнийКолонтитул.НачальнаяСтраница;
 
ТабличныйДокумент.НижнийКолонтитул.ВертикальноеПоложение = ВертикальноеПоложение.Верх;
 
ТабличныйДокумент.НижнийКолонтитул.ТекстСлева   = ЗаполнитьТекстКолонтитула(Настройка.НижнийКолонтитул.ТекстСлева, НазваниеОтчета, Пользователь);
 
ТабличныйДокумент.НижнийКолонтитул.ТекстВЦентре = ЗаполнитьТекстКолонтитула(Настройка.НижнийКолонтитул.ТекстВЦентре, НазваниеОтчета, Пользователь);
 
ТабличныйДокумент.НижнийКолонтитул.ТекстСправа  = ЗаполнитьТекстКолонтитула(Настройка.НижнийКолонтитул.ТекстСправа, НазваниеОтчета, Пользователь);
 КонецЕсли;
КонецПроцедуры
// УстановитьКолонтитулы()

Скачать файлы

Наименование Файл Версия Размер
Печать подписей

.rar 1,17Mb
15.06.10
158
.rar 1,17Mb 158 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    33005    tormozit    44    

Загрузка, скачивание, удаление файлов с помощью НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера()

Практика программирования v8 1cv8.cf Абонемент ($m)

В платформе 8.3.15 появились новые методы НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера(). В данной статье рассмотрено готовое решение проверенное и прекрасно работающее на тонком и веб-клиенте.

1 стартмани

25.07.2020    1498    Flashill    9    

Параллельные вычисления расчета факториала числа N

Практика программирования v8 1cv8.cf Абонемент ($m)

Распараллеливание алгоритма с помощью фоновых заданий (асинхронные вычисления)

1 стартмани

29.06.2020    2138    Rustig    17    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    6821    tormozit    13    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    26576    wowik    3    

Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

1 стартмани

05.03.2020    5029    user5300    3    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    5179    burni4    16    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    15884    sapervodichka    41    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    69819    ildarovich    117    

Универсальные функции: разложение произвольной строки адреса в структуру

Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Процедуры и функции раскладывают произвольную строку адрес в структуру по ключевым словам.

1 стартмани

30.12.2019    3243    vik070777    10    

"Живые" картинки со Snap.SVG

Практика программирования WEB Работа с интерфейсом v8 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    12886    blackhole321    7    

RLS - дубли условий в запросах к СУБД

Практика программирования Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    8122    geron4    4    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    39046    ildarovich    22    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    28065    HostHost    40    

Полное копирование одной формы в другую

Практика программирования Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Однажды я столкнулся с необходимостью открыть форму ЛЮБОГО документа с определенными изменениями, не зависящими от структуры объекта (например, заблокировать все кнопки). В интернете решения я не нашел. Обычно на форумах на запросы подобного рода отвечают чем-то вроде "покажи первоначальную задачу, а не спрашивай как реализовать то, что ты придумал". Тем не менее, мне стало интересно, как это можно сделать.

1 стартмани

03.10.2019    4520    nekit_rdx    23    

Многопоточная обработка данных на примере перепроведения документов

Обработка документов Практика программирования v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    8644    ids79    46    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    34580    rpgshnik    49    

Отображение истории выполнения по всем задачам комплексного процесса в документообороте

Документооборот и делопроизводство Практика программирования v8 ДО Абонемент ($m)

Коллеги, предлагаю вашему вниманию доработку для вывода полной истории в задачах комплексного процесса.

1 стартмани

15.09.2019    6418    pavelpribytkin96    8    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    18674    Dementor    30    

Удобный просмотр результата запроса с большим количеством временных таблиц

Практика программирования v8 Абонемент ($m)

Если Вам часто приходится просматривать в отладчике сложные пакетные запросы с большим количеством временных таблиц, то эта статья для Вас.

1 стартмани

27.08.2019    10544    ids79    21    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному Промо

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    43207    dsdred    36    

Запуск фонового задания во внешней обработке. Отключение предупреждений защиты от опасных действий в фоновом задании

Практика программирования v8 1cv8.cf Абонемент ($m)

Как запустить фоновое задание из модуля внешней обработки используя БСП. Как отключить безопасный режим и сообщения защиты от опасных действий независимо от профиля безопасности пользователя в фоновом задании во внешней обработке.

2 стартмани

24.08.2019    9742    BenGunn    22    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    14686    signum2009    16    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    34471    vasilev2015    63    

Некоторая работа с данными через COM Промо

Практика программирования v8 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    56881    wowik    32    

10 способов получить модуль числа (а может, и больше)

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Пишем функцию вычисления модуля числа. Сколько способов существует? Давайте посчитаем!

1 стартмани

11.07.2019    7209    sam441    29    

Ловец дедлоков СУБД

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Россия Абонемент ($m)

Анализ простейшего дедлока СУБД в рабочей базе с использованием ЦУП (центра управления производительностью) и profiler MS SQL (Microsoft SQL Server). Эта статья будет полезна людям, изучающим вопросы оптимизации работы 1С, или тем, у кого возникают дедлоки в рабочей базе. UPD 09.07.2019 добавлено воспроизведение блокировки в случае установки управляемой блокировки перед чтением набора записей регистра сведений. UPD 10.07.2019 добавлена тестовая база с примером.

1 стартмани

08.07.2019    10702    azazana    79    

Мониторинг производительности и искусственный интеллект

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Абонемент ($m)

Расскажем и покажем практически, как использовать искусственный интеллект на страже мониторинга производительности. У вас появится возможность создать собственного помощника Ларису, которая возьмет на себя вопросы по контролю и диагностике состояния обслуживаемой системы.

1 стартмани

01.07.2019    8955    ivanov660    28    

Работа со схемой запроса Промо

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    42488    kalyaka    34    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    14199    informa1555    17    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    27572    Evil Beaver    122    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    28314    Hatson    22    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    48495    DarkAn    86    

Графики работы из БСП

Практика программирования Разработка v8 1cv8.cf Россия Абонемент ($m)

Не очень давно на канале 1С:БСП была опубликована заметка по использованию Графиков работы и Календарных графиков.

1 стартмани

23.05.2019    3013    fenixnow    0    

Создание внешней печатной формы в формате документа Word

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье написано, как создать внешнюю печатную форму (для конфигураций с БСП) в формате Word.

1 стартмани

17.05.2019    11768    ВикторП    20    

Пример настройки шаблонов и реализации печати отчетов в документ MS Word используя функциональную часть "Библиотеки Стандартных Подсистем 1С" (БСП)

Практика программирования Разработка v8 Россия Абонемент ($m)

В конфигурации выбраны и использованы только необходимые объекты библиотеки стандартных подсистем для реализации вывода отчёта, с табличными частями, в документ MS Word. Показан пример создания необходимых областей в шаблоне для вывода параметров в отчёт.

1 стартмани

23.04.2019    5712    olegpkc    11    

Новый запрос и новая таблица значений как функции Промо

Практика программирования v8 Абонемент ($m)

Предлагается две простые функции, использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

1 стартмани

27.11.2012    44899    ildarovich    46    

Ops средствами 1С:Предприятие

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье описан программный пакет "Автоматизация ИТ-процессов" (АИТП), позволяющий автоматизировать задачи по администрированию, управлению и обслуживанию ИТ-инфраструктуры.

1 стартмани

23.04.2019    17039    blackhole321    28    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    31352    riposte    63    

Вывод вариантов СКД в таблицы на управляемой форме

Практика программирования Работа с интерфейсом v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Задача стояла такая: есть 2 различных запроса, результаты которых выгружаются на форму обработки в таблицы значений (далее ТЗ) и программно "соприкасаются" между собой определенным образом (как именно- в рамках данной статьи неважно). Нюанс в том, что запросы должны иметь свой компоновщик настроек и могут интерактивно на форме изменяться пользователем. На оригинальность публикации не претендую - изначально в рамках поставленной задачи пытался найти что-то подобное (уже готовый шаблон) на инфостарте, возможно "плохо искал" ;)

05.04.2019    10496    artkor    1    

Уровни, глубина, прародители, циклы и аналоги запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В продолжение публикации «Транзитивное замыкание запросом» [http://infostart.ru/public/158512/] добавлены другие варианты использования того же приема. Приведены запросы для быстрого определения уровней всех элементов справочника, максимальной глубины справочника, прародителей произвольных элементов справочника, запрос для быстрого определения циклов (на примере справочника спецификаций «1С:Управление производственным предприятием») и определения множеств аналогов номенклатуры (также на примере конфигурации «1С:Управление производственным предприятием»).

1 стартмани

13.11.2012    110484    ildarovich    98    

Функциональное программирование в 1С

Практика программирования Математика и алгоритмы Разработка v8 1cv8.cf Абонемент ($m)

Статья о функциональном программировании в 1С. Добавляем новые возможности. Пример передачи функций в качестве аргумента.

1 стартмани

28.03.2019    8160    alexey.kutya    26    

[EnterpriseData] Антисвертка характеристик номенклатуры при выгрузке в Бухгалтерию

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 v8::ПВХ КД УНФ БП3.0 Россия БУ Абонемент ($m)

Рассмотрена выгрузка каждой пары значений Номенклатура - Характерстика из УНФ 1.6 в отдельную номенклатуру в Бухгалтерию 3.0 путём доработки правил обмена в формате EnterpriseData.

1 стартмани

27.03.2019    4337    nforce    4    

Интеграция 1С и SharePoint

Практика программирования Разработка v8 УНФ ДО ERP2 БП3.0 УТ11 УХ КА2 Россия Абонемент ($m)

Заказчики поставили задачу автоматизации согласования заявок на оплату в программе 1С:Бухгалтерия предприятия 3.0. Согласно ТЗ, данные должны подтягиваться из действующей электронной системы документаоборота на MS SharePoint (в дальнейшем СЭД MS SP).

1 стартмани

22.03.2019    5163    -I-    4    

Неоплаченные долги при распределении оплаты по правилу ФИФО одним запросом и намного быстрее, чем Вы думали Промо

Практика программирования Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::СКД КА1 УТ10 УПП1 УУ Абонемент ($m)

Предлагается метод для быстрого нахождения неоплаченных долгов при распределении оплаты по правилу ФИФО, основанный на дихотомии. Описывается реализация метода в виде достаточно простого запроса, решающего за линейное время указанную задачу, считавшуюся ранее существенно более трудоемкой. Приводятся примеры использования запроса в отчетах на СКД для конфигураций УТ, КА, УПП.

1 стартмани

28.02.2014    67626    ildarovich    123    

Легкий "тюнинг" УТ 10.3

Практика программирования Разработка v8 v8::ОУ УТ10 Россия УУ Абонемент ($m)

Вариант программной реализации изменения форм типовых объектов для конфигурации Управление торговлей 10.3.

1 стартмани

15.03.2019    4236    pm74    6    

Пример использования СКД и данных расшифровки на мобильной платформе

Практика программирования Разработка v8 v8::Mobile v8::СКД 1cv8.cf Россия Абонемент ($m)

СКД в мобильном приложении и меню действий на основе данных расшифровки (отчет, совместимый с мобильной платформой 8.3.13.45).

1 стартмани

12.03.2019    5324    majoram    0    

Программное создание реквизита управляемой формы с помощью механизма расширений

Практика программирования Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

В ЗУП 3 возникла задача добавить реквизит в справочник не внося изменений в конфигурацию. БСП с механизмом дополнительных реквизитов использовать было нежелательно, поэтому был использован механизм расширений. Для вывода данного реквизита на форму добавлять саму форму в расширение не хотелось по ряду причин, описанных ниже. Создание реквизита и элемента формы, соответствующего данному реквизиту было решено сделать программно в самом расширении, следуя принципу минимального воздействия на конфигурацию.

1 стартмани

12.03.2019    32119    ni_cola    29    

Транзитивное замыкание запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В частности, показывается, как одним пакетным запросом найти ВСЕХ предков (потомков) в иерархическом справочнике. Аналогично можно определять входимость деталей в узлы и готовые изделия по их спецификациям, определять подмножества аналогичных запчастей по цепочке аналогов, решать другие подобные задачи. Приложен файл с примером отчета для замыкания иерархии произвольного справочника, позволяющий протестировать быстродействие запроса в разных условиях.

1 стартмани

29.10.2012    83510    ildarovich    118    

Иерархия библиотек. Автоматическое обновление или как отказаться от переопределяемых модулей

Практика программирования Математика и алгоритмы Разработка v8 Абонемент ($m)

В статье рассмотрен один из вариантов библиотечного подхода к разработке, позволяющий организовать иерархический вызов библиотечных процедур и упростить автоматическую сборку готового продукта из нескольких библиотек. Предлагаемый подход может служить одним из элементов CI/CD при разработке ПО на платформе 1С.

1 стартмани

04.03.2019    5604    Alxby    4    

Асинхронная работа с текстовыми файлами в 1С 8.3

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В этой статье я рассмотрю основные моменты работы с текстовым файлом в 1С 8.3. (загрузка - выгрузка) в режиме отключенной модальности (асинхронно).

1 стартмани

28.02.2019    6977    signum2009    6    

Баг или фича? Неожиданное поведение платформы

Практика программирования Тестирование и исправление Разработка v8 1cv8.cf Абонемент ($m)

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    22573    YPermitin    89