Решение проблемы автоматического утверждения расчета кадровиком документов. Разграничение прав кадровиков и расчетчиков. ЗУП 3.1

Публикация № 810634

Администрирование - Информационная безопасность

ЗУП 3.1. Автоматическая установка (Убрать) "Расчет утвердил". ЧтениеДанныхДляНачисленияЗарплатыРасширенная и ДобавлениеИзменениеДанныхДляНачисленияЗарплатыРасширенная для кадровиков.Разграничение прав между кадровиками и расчетчиками.

Статья посвящена тем, кто столкнулся с проблемой автоматической установки "Расчет утвердил". Также рассматривается решение проблемы с отображением ФОТ и оклада у кадровика. Добавление роли ЧтениеДанныхДляНачисленияЗарплатыРасширенная кадровику без последствий для расчетчика.

Вечная проблема – выяснение, кто прав, между кадровиками и бухгалтерией. Наверняка  есть организации, где этой проблемы не существует, но я еще такой компании не встречал. Проблемы обостряются после перехода с ЗУП 2.5 на ЗУП 3.1.

Дело в том, что разработчик конфигурации убрал разделение между документами кадровыми и документами начисления. Грубо говоря – в ЗУП 3.1 кадровый документ это документ и для расчетчика. То есть и расчетчики, и кадровики пользуются одними и теми же документами. Кадровик видит свою часть, которая необходима ему для работы, а расчетчик видит свою часть. Разработчик поделил функциональность и дал возможность регулировать ее в «Профиле групп доступа»(Ролями). Все бы ничего, но есть небольшие проблемы:

  1. Кадровикам нужен доступ к печати «Справки расчета».
  2. Кадровикам нужна возможность изменять начисления в кадровых переводах.
  3. Кадровикам нужна возможность посмотреть начисляемый ФОТ и размер аванса.

Все эти возможности у кадровиков есть, но только при включенных ролях «ЧтениеДанныхДляНачисленияЗарплатыРасширенная» или «ДобавлениеИзменениеДанныхДляНачисленияЗарплатыРасширенная».  Вроде бы добавь в «Профиль групп доступа» кадровику эти роли и все будет работать, а нет!  

При включении любой из этих ролей в набор прав «Кадровика» появляется одна особенность – в некоторых документах автоматически рассчитывается средний заработок и устанавливается галочка «Расчет утвердил». То есть при включенных ролях кадровик,  формируя отпуск сотруднику, при создании самого документа автоматом устанавливается галочка «Расчет утвердил», а так же рассчитывается средний заработок, плюс открывается вкладка «Начислено (подробно)».  Далее расчетчик в своем списке документов уже видит, что документ рассчитан (документ не выделен жирным цветом) и не обрабатывает его. Так же бывает так, что расчетчик, рассчитав зарплату за месяц (Бывает хуже, если уже выплатили зарплату),  обнаруживает, перерасчет некоторых сотрудников (Оказывается, что кадровики задним числом провели отпуск или командировку или же оклад поменяли кому либо). Расчетчик в недоумении откуда разность в начислении и выплате щелкает по всем отчетам и ищет источник возникшей проблемы, тратя на это кучу времени и сил в дальнейших выяснениях отношений с кадрами. На мой взгляд - это не совсем правильно.

При выключенных ролях «ЧтениеДанныхДляНачисленияЗарплатыРасширенная» или «ДобавлениеИзменениеДанныхДляНачисленияЗарплатыРасширенная». Ситуация в ЗУП 3.1 такова: кадровик создает приказ о переводе сотрудника на другую должность. Так же кадровику требуется увеличить оклад, но кадровик не видит вкладку «Оплата труда». В данной ситуации изменить оклад может только расчетчик, потому что у него вышеперечисленные роли как раз включены в «Профиль групп доступа». Я согласен с тем, что нужно подстраиваться под программу и изменять сам процесс работы кадровиков и расчетчиков, но по разным причинам не всегда это удается.

Такая же ситуация и с другими документами.

Решение:

  1. Включить кадровикам роль  «ЧтениеДанныхДляНачисленияЗарплатыРасширенная» и обязательно отключить роль «ДобавлениеИзменениеДанныхДляНачисленияЗарплатыРасширенная» .
  2. Если конфигурация на поддержке, то снять ее с поддержки. Снять с поддержки рекомендую только один общий модуль, дабы обновлять было в дальнейшем легче. С поддержки снимаем общий модуль «ЗарплатаКадрыРасширенный».
  3. Далее открываем общий модуль «ЗарплатаКадрыРасширенный», ищем в нем функцию «ПраваНаМногофункциональныйДокумент», в конце функции, перед строкой «Возврат ПраваНаДокумент;» добавляем строки:
	//alex.swon.2+
	Если Пользователи.РолиДоступны("ЧтениеНачисленнойЗарплатыРасширенная", , Ложь) И НЕ Пользователи.РолиДоступны("ДобавлениеИзменениеНачисленнойЗарплатыРасширенная", , Ложь) тогда
		Если ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.ПриемНаРаботу") ИЛИ ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.ПриемНаРаботуСписком")
			ИЛИ ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.КадровыйПеревод") ИЛИ ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.КадровыйПереводСписком") тогда
			ПраваНаДокумент.ПолныеПраваПоРолям = Истина;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ЧтениеБезОграничений = Истина;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеБезОграничений = Истина;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеКадровыхДанных = Истина;
		Иначе
			ПраваНаДокумент.ПолныеПраваПоРолям = Ложь;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ЧтениеБезОграничений = Ложь;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеБезОграничений = Ложь;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеКадровыхДанных = Истина;
		КонецЕсли;
	КонецЕсли;
	//alex.swon.2-

Итоговый код функции:

Функция ПраваНаМногофункциональныйДокумент(Объект) Экспорт 
	
	МногофункциональныеДокументы = ЗарплатаКадрыРасширенныйКлиентСервер.ТипыМногофункциональныхДокументов();
	ОписаниеДокумента = МногофункциональныеДокументы.Получить(ТипЗнч(Объект.Ссылка));
	
	ДанныеДляПроверкиОграничений = ДанныеДляПроверкиОграниченийНаУровнеЗаписейМногофункциональногоДокумента(Объект);
	ИспользуетсяРасчетЗарплаты = ПолучитьФункциональнуюОпцию("ИспользоватьРасчетЗарплатыРасширенная");
	ПолныеПраваНаДокумент = ИспользуетсяРасчетЗарплаты И ПолныеПраваНаМногофункциональныйДокумент(Объект.Ссылка);
	
	ЧтениеБезОграничений = Ложь;
	ИзменениеБезОграничений = Ложь;
	
	Если ПолныеПраваНаДокумент Тогда 
		ИзменениеБезОграничений = Не ЕстьОграниченияНаУровнеЗаписейПоВидуУчета("Изменение", ОписаниеДокумента.ВидУчета, ДанныеДляПроверкиОграничений);
		ЧтениеБезОграничений = ИзменениеБезОграничений;
		Если Не ЧтениеБезОграничений Тогда
			ЧтениеБезОграничений = Не ЕстьОграниченияНаУровнеЗаписейПоВидуУчета("Чтение", ОписаниеДокумента.ВидУчета, ДанныеДляПроверкиОграничений);
		КонецЕсли;
	КонецЕсли;	
		
	ИзменениеКадровыхДанных = ИзменениеБезОграничений;
	Если Не ИзменениеКадровыхДанных Тогда
		ИзменениеКадровыхДанных = Не ЕстьОграниченияНаУровнеЗаписейПоВидуУчета("Изменение", "КадровыеДанные", ДанныеДляПроверкиОграничений);
	КонецЕсли;
	
	ПраваНаДокумент = Новый Структура(
		"ПолныеПраваПоРолям, 
		|ОграниченияНаУровнеЗаписей"); 
	ПраваНаДокумент.ПолныеПраваПоРолям = ПолныеПраваНаДокумент;
	
	ОграниченияНаУровнеЗаписей = Новый Структура(
		"ЧтениеБезОграничений, 
		|ИзменениеБезОграничений, 
		|ИзменениеКадровыхДанных");
		
	ОграниченияНаУровнеЗаписей.ЧтениеБезОграничений = ЧтениеБезОграничений;
	ОграниченияНаУровнеЗаписей.ИзменениеБезОграничений = ИзменениеБезОграничений;
	ОграниченияНаУровнеЗаписей.ИзменениеКадровыхДанных = ИзменениеКадровыхДанных;
	
	ПраваНаДокумент.ОграниченияНаУровнеЗаписей = ОграниченияНаУровнеЗаписей;
	
	Если ОбщегоНазначения.ПодсистемаСуществует("ЗарплатаКадрыКорпоративнаяПодсистемы.УправленческаяЗарплата") Тогда
		Модуль = ОбщегоНазначения.ОбщийМодуль("УправленческаяЗарплата");
		Модуль.ПриПолученииПравНаМногоФункциональныйДокумент(ПраваНаДокумент, ОписаниеДокумента, ДанныеДляПроверкиОграничений);
	КонецЕсли;
	
	//alex.swon.2+
	Если Пользователи.РолиДоступны("ЧтениеНачисленнойЗарплатыРасширенная", , Ложь) И НЕ Пользователи.РолиДоступны("ДобавлениеИзменениеНачисленнойЗарплатыРасширенная", , Ложь) тогда
		Если ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.ПриемНаРаботу") ИЛИ ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.ПриемНаРаботуСписком")
			ИЛИ ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.КадровыйПеревод") ИЛИ ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.КадровыйПереводСписком") тогда
			ПраваНаДокумент.ПолныеПраваПоРолям = Истина;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ЧтениеБезОграничений = Истина;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеБезОграничений = Истина;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеКадровыхДанных = Истина;
		Иначе
			ПраваНаДокумент.ПолныеПраваПоРолям = Ложь;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ЧтениеБезОграничений = Ложь;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеБезОграничений = Ложь;
			ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеКадровыхДанных = Истина;
		КонецЕсли;
	КонецЕсли;
	//alex.swon.2-
	
	Возврат ПраваНаДокумент;									
										
КонецФункции

4. Далее в этом же модуле ищем процедуру «УстановитьВторогоОтветственногоВМногофункциональныхДокументах». В конце процедуры перед строкой «УстановитьПредупреждающуюНадписьВМногофункциональныхДокументах(Форма, ОписаниеДокумента.РеквизитСостояние);» добавляем строки:

//alex.swon.2+
	//Включим РОЛЬ ЧтениеНачисленнойЗарплатыРасширенная и уберем возможность установки "Рассчитал" в кадровых документов
	Если ПолныеПраваНаДокумент И Пользователи.РолиДоступны("ДобавлениеИзменениеНачисленнойЗарплатыРасширенная", , Ложь) Тогда
		ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.РеквизитСостояние, "Доступность", Истина);
		Если Форма.Объект[ОписаниеДокумента.РеквизитСостояние] Тогда 
			ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.ВторойОтветственный, "Доступность", Истина);
			Если Не ЗначениеЗаполнено(Форма.Объект[ОписаниеДокумента.ВторойОтветственный]) Тогда 
				Форма.Объект[ОписаниеДокумента.ВторойОтветственный] = ПользователиКлиентСервер.ТекущийПользователь();
			КонецЕсли;	
		Иначе 
			ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.ВторойОтветственный, "Доступность", Ложь);
			Если ЗначениеЗаполнено(Форма.Объект[ОписаниеДокумента.ВторойОтветственный]) Тогда 
				Форма.Объект[ОписаниеДокумента.ВторойОтветственный] = Неопределено;
			КонецЕсли;	
		КонецЕсли;
	Иначе 
		ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.РеквизитСостояние, "Доступность", Ложь);
		ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.ВторойОтветственный, "Доступность", Ложь);
		Форма.Объект[ОписаниеДокумента.РеквизитСостояние] = Ложь;
	КонецЕсли;
	//alex.swon.2-

Итоговый код всей процедуры

Процедура УстановитьВторогоОтветственногоВМногофункциональныхДокументах(Форма, ПолныеПраваНаДокумент) Экспорт 
	
	Если Не Форма.ПолучитьФункциональнуюОпциюФормы("ИспользоватьРасчетЗарплатыРасширенная") Тогда
		Возврат;
	КонецЕсли;
	
	МногофункциональныеДокументы = ЗарплатаКадрыРасширенныйКлиентСервер.ТипыМногофункциональныхДокументов();
	ОписаниеДокумента = МногофункциональныеДокументы.Получить(ТипЗнч(Форма.Объект.Ссылка));
	
	//alex.swon.2+
	//Включим РОЛЬ ЧтениеНачисленнойЗарплатыРасширенная и уберем возможность установки "Рассчитал" в кадровых документов
	Если ПолныеПраваНаДокумент И Пользователи.РолиДоступны("ДобавлениеИзменениеНачисленнойЗарплатыРасширенная", , Ложь) Тогда
		ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.РеквизитСостояние, "Доступность", Истина);
		Если Форма.Объект[ОписаниеДокумента.РеквизитСостояние] Тогда 
			ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.ВторойОтветственный, "Доступность", Истина);
			Если Не ЗначениеЗаполнено(Форма.Объект[ОписаниеДокумента.ВторойОтветственный]) Тогда 
				Форма.Объект[ОписаниеДокумента.ВторойОтветственный] = ПользователиКлиентСервер.ТекущийПользователь();
			КонецЕсли;	
		Иначе 
			ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.ВторойОтветственный, "Доступность", Ложь);
			Если ЗначениеЗаполнено(Форма.Объект[ОписаниеДокумента.ВторойОтветственный]) Тогда 
				Форма.Объект[ОписаниеДокумента.ВторойОтветственный] = Неопределено;
			КонецЕсли;	
		КонецЕсли;
	Иначе 
		ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.РеквизитСостояние, "Доступность", Ложь);
		ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.ВторойОтветственный, "Доступность", Ложь);
		Форма.Объект[ОписаниеДокумента.РеквизитСостояние] = Ложь;
	КонецЕсли;
	//alex.swon.2-
	
	УстановитьПредупреждающуюНадписьВМногофункциональныхДокументах(Форма, ОписаниеДокумента.РеквизитСостояние);
	
КонецПроцедуры	

Готово.

Теперь у кадровиков есть возможность :

  1. Создавать Кадровые перемещения с возможностью указания начислений.
  2. Печатать справку расчет при увольнении сотрудника.
  3. Видеть ФОТ, оклад и размер аванса сотрудника.
  4. Создавать командировки и отпуска без изначально установленной галочки «Расчет утвердил» и без автоматического расчета среднего заработка.
  5. Доступ к отчетам по начислению заработной платы.

Проверено на платформе                               8.3.11.3034

Версия конфигурации ЗУП                               3.1.5.129

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. yegorovnv 11.04.18 08:56 Сейчас в теме
Ничего не понимаю зачем весь этот огород. Дело в том, что в типовом ЗУПе 3 есть разделение. Кадровики и расчетчики прекрасно сосуществуют рядом, не мешая друг другу. При расчете документа расчетчиками кадровики уже ничего не могут поменять в документе.
Включите функцию "Использовать многофункциональность документов".
Мне кажется, что вы вашей статьей собьете с толку новичков, которые ищут информацию по данной теме.
Winstoncuk; OpKc; +2 Ответить
5. leaderonex 31 11.04.18 16:44 Сейчас в теме
В идеальной организации взаимодествие между кадровиками и расчетчиками происходит именно так, как вы описали. Но позвольте уточнить такой момент: - Как кадровику, не включая роли ЧтениеДанныхДляНачисленияЗарплатыРасширенная, можно распечатать "Справку расчет" или изменить начисление в документе "Кадровый перевод сотрудника"?
А если вы все же включили роль, то как боретесь с моментом, когда после проведения кадровиком документа "Больничный лист", автоматически происходит расчет и в документе устанавливается галочка "Расчет утвердил"?
2. leaderonex 31 11.04.18 12:19 Сейчас в теме
В идеальной организации взаимодествие между кадровиками и расчетчиками происходит именно так, как вы описали. Но позвольте уточнить такой момент: - Как кадровику, не включая роли ЧтениеДанныхДляНачисленияЗарплатыРасширенная, можно распечатать "Справку расчет" или изменить начисление в документе "Кадровый перевод сотрудника"?
А если вы все же включили роль, то как боретесь с моментом, когда после проведения кадровиком документа "Больничный лист", автоматически происходит расчет и в документе устанавливается галочка "Расчет утвердил"?
3. Mx00 230 11.04.18 13:33 Сейчас в теме
Константин, с интересом прочитал статью, мне скоро тоже придется решать эту задачу, но снимать с поддержки базу очень не хочется... я обычно пытаюсь решить такие задачи с помощью расширений, не рассматривали ли вы такой подход?
например включить роль ЧтениеДанныхДляНачисленияЗарплатыРасширенная и снимать признак "Расчет утвердил" при закрытии документа?
вопрос рассматривали ли вы такой подход к решению проблемы?
4. leaderonex 31 11.04.18 16:39 Сейчас в теме
Если снять признак с включенной ролью ЧтениеДанныхДляНачисленияЗарплатыРасширенная, то документ не проводится, ругается на то, что расчет не утвержден.
7. leaderonex 31 12.04.18 09:09 Сейчас в теме
(3)Через расширения не пытался... Сейчас прорабатываю этот вариант.
6. MuxaH 12.04.18 04:36 Сейчас в теме
Мы тоже через расширение эту проблему разрулили - зачем с поддержки снимать...
8. leaderonex 31 12.04.18 11:10 Сейчас в теме
(6) Можете описать Ваш вариант решения? Я думаю, что многим будет полезно и интересно
9. Mx00 230 12.04.18 12:58 Сейчас в теме
(6) да-да, все замерли в надежде :-)
Михаил, поделитесь расширением!
10. MuxaH 13.04.18 06:44 Сейчас в теме
Да пожалуйста, описываю.
1. Включаем Многофункциональность документов (Константы -> Использовать многофункциональность документов)
2. У кадровиков вообще убираем роль ДобавлениеИзменениеНачисленнойЗарплатыРасширенная. Я им оставил профиль Старший кадровик - в кадровых перемещениях начисления добавлять могут. И Табельщик - чтобы табели проводить могли.
3. Создаем свой профиль для кадровика, обзываем по желанию. Там даем ему роли: Чтение выплаченной зарплаты, Чтение начисленной зарплаты. Это надо, чтоб они могли печатать справку-расчет.
4. Создаем расширение, Добавляем в него документ Увольнение, Увольнение списком. У расширения сразу отключаем Безопасный режим, чтоб можно было менять модуль менеджера. Собственно в расширении в Модуле менеджера для обоих документов добавляем процедуру
&После("ДобавитьКомандыПечати")
Процедура НашеРасш_ДобавитьКомандыПечати(КомандыПечати) Экспорт
	Если КомандыПечати.Найти("ПФ_MXL_Т61") = Неопределено Тогда
		// Записка-расчет при увольнении.
		КомандаПечати = КомандыПечати.Добавить();
		КомандаПечати.Обработчик = "ЗарплатаКадрыКлиент.ВыполнитьКомандуПечати";
		КомандаПечати.МенеджерПечати = "Обработка.ПечатьКадровыхПриказовРасширенная";
		КомандаПечати.Идентификатор = "ПФ_MXL_Т61";
		КомандаПечати.Представление = НСтр("ru = 'Записка-расчет при увольнении (Т-61)'");
		КомандаПечати.Порядок = 20;
		КомандаПечати.ФункциональныеОпции = "РаботаВХозрасчетнойОрганизации";
		КомандаПечати.ДополнительныеПараметры.Вставить("ТребуетсяЧтениеБезОграничений", Истина);
		КомандаПечати.ПроверкаПроведенияПередПечатью = Истина;
	КонецЕсли;	
КонецПроцедуры
Показать


Оно добавляет команду печати записки-расчета вне зависимости от наличия роли ДобавлениеИзменениеНачисленнойЗарплатыРасширенная.

5. Потом я ещё расширял модуль менеджера документа Командировка:
&Вместо("ПолныеПраваНаДокумент")
Функция НашеРасш_ПолныеПраваНаДокумент() Экспорт 
	
        //Возврат Пользователи.РолиДоступны("ДобавлениеИзменениеНачисленнойЗарплатыРасширенная, ЧтениеНачисленнойЗарплатыРасширенная", , Ложь);
	Возврат Пользователи.РолиДоступны("ДобавлениеИзменениеНачисленнойЗарплатыРасширенная", , Ложь);
	
КонецФункции
Показать


Т.к. разделение функций на тот документ почему-то не действовала для профиля Аудитор - вроде как он должен только читать документы, а при наличии роли ЧтениеНачисленнойЗарплатыРасширенная он тоже вовсю мог их утверждать. Но может в последних релизах это уже и поправили.

6. Собственно всё. Кадровики видят свои данные, расчетные данные не видят. Документы (под кадровиком) проводятся только по кадровым регистрам, а расчетчики уже утверждают расчет, при необходимости.
korppinen; Mx00; +2 Ответить
11. leaderonex 31 13.04.18 10:24 Сейчас в теме
Спасибо большое Михаил Кравченко (MuxaH) за то, что поделился своим вариантом.
Не мог бы ты описать, как ты решил остальные моменты, на которые влияют включенные роли "ЧтениеДанныхДляНачисленияЗарплатыРасширенная" ИЛИ "ДобавлениеИзменениеНачисленнойЗарплатыРасширенная" :
1. Отражение Оклада, ФОТ и Аванса в карточке сотрудника. Ведь без включенной одной из этих ролей данные не доступны кадровику.
2. При создании документа "Кадровое перемещение", нет возможности установить новые начисления или же изменить старые.
3. Командировку поправил, а как дело обстоит с отпусками? с больничными?.
4. Иногда кадровику требуется смотреть расчетные листы. Но при выключенных ролях это не возможно. Как этот момент решил?
13. Mx00 230 13.04.18 17:00 Сейчас в теме
12. MuxaH 13.04.18 13:10 Сейчас в теме
1.- 2. Да так же, формы в расширениях можно курочить как твоей душе угодно. Сначала ищешь типовой код, который скрывает от кадровика нужные данные. Создаешь корректировки в расширении. Даже описанный тобой в статье подход (исправление общих модулей) можно расширением без снятия с поддержки разрулить. А с начислениями кадровики настроили штатное расписание, при выборе позиции все начисления сразу встают в ТЧ, они её не смотрят даже. Да и профилю Старший кадровик доступно изменение начислений.
3. Отпуска, больничные нормально разграничивались, с командировками почему-то такая проблема всплыла.
4. На расчетки давал роль Аудитор. Как раз для пользователей с такой ролью и всплыла проблема, что они утверждать могли Командировки.
14. leaderonex 31 13.04.18 17:01 Сейчас в теме
Согласен, что можно расширениями все сделать. Но...
В моем решении нужно только снять с поддержки 1 модуль и добавить десятка два строк кода, а ты предлагаешь изменить кучу форм документов, справочников и отчетов в расширениях.
Согласен, что можно сделать и по моему сценарию и без снятия с поддержки, с помощью расширения. Но только в платформе 8.3.11 расширения еще не поддерживают общие модули. Можно обойти этот момент, создав обработку в расширении. Использовать модуль менеджера обработки, как общий модуль. Но все равно придется создавать расширения форм и припиливать к ним обработчики из модуля обработки.
1. Вариант с расширениями - очень затратный по времени. Этот вариант не подойдет тем, кому нужно сделать "Сейчас"...
2. В случае, если разработчик изменит какую либо из форм, то придется допиливать расширения каждый раз. Ты скажешь, - "Ну и общий модуль разработчик может изменить". Конечно, может, но вероятность изменения куда меньше, нежели вероятность изменения одной из множества форм: справочника, документа или отчета. В случае же изменения одного модуля, его легко при обновлении можно поправить, так как там исправлений в коде не много.
3. В твоем варианте решения, ты предлагаешь кадровикам все изменения начислений использовать из штатного расписания. Такой вариант не каждому кадровику понравится. Может быть ты умеешь лучше убеждать людей, которые работают в программе, что твои варианты правильнее, но у меня такого дара к сожалению нет. И убедить кадровиков делать иначе, нежели они привыкли как в ЗУП 2.5 у меня не получалось.
Согласен, что оба варианта решения этих проблем имеют шанс на существование. Какой вариант выбрать решать Вам форумчане.
Я лишь описал как я решил эти проблемы.
15. MuxaH 16.04.18 05:14 Сейчас в теме
(14) Я не предлагаю менять кучу форм, я предлагаю те же 2 десятка строк кода подписать в расширении. А 8.3.11 уже вовсю изменение модулей в расширении поддерживает. У меня ещё 8.3.10 стоит.
1. По временным затратам - не соглашусь. Неудобство только в сравнении при обновлении измененного и типового модуля.
2. Соглашусь, но я и не настаиваю на изменении форм.
3. Это не вариант решения, это так кадровики упростили себе работу. Пока штатку настраивали - так же в перемещениях назначали/убирали начисления, просто я не понимаю зачем им роль ДобавлениеИзменениеНачисленнойЗарплатыРасширенная, и без неё всё прекрасно редактируется.

Но дело хозяйское. Сейчас в 8.3.12 уже можно в расширениях и свои объекты добавлять, и движения по типовым регистрам делать, но лично мне страшно - как оно себя поведёт при отключении расширения. Но тем не менее, за расширениями будущее, как говорят на :)
16. leaderonex 31 16.04.18 08:43 Сейчас в теме
3. У кадровиков убираем роль "ДобавлениеИзменениеНачисленнойЗарплатыРасширенная" и оставляем только "ЧтениеДанныхДляНачисленияЗарплатыРасширенная"
17. almas 199 22.05.18 16:57 Сейчас в теме
проверьте публикацию.
мне кажется у вас пункт 2 и 4 одинаковый листинг в обоих процедурах в публикации.
18. leaderonex 31 20.07.18 10:26 Сейчас в теме
(17)Исправил. Извиняюсь, за этот момент.
19. ivan65 04.09.18 14:03 Сейчас в теме
где правда говорим
Включить кадровикам роль «ЧтениеДанныхДляНачисленияЗарплатыРасширенная» и обязательно отключить роль «ДобавлениеИзменениеДанныхДляНачисленияЗарплатыРасширенная» .

а пишем
//Включим РОЛЬ ЧтениеНачисленнойЗарплатыРасширенная и уберем возможность установки "Рассчитал" в кадровых документов
Если ПолныеПраваНаДокумент И Пользователи.РолиДоступны("ДобавлениеИзменениеНачисленнойЗарплатыРасширенная", , Ложь) Тогда
ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Форма.Элементы, ОписаниеДокумента.РеквизитСостояние, "Доступность", Истина);
20. leaderonex 31 04.09.18 17:14 Сейчас в теме
(19)Именно так и делаем, как написано в моей публикации. Отключаем роль "ДобавлениеИзменениеДанныхДляНачисленияЗарплатыРасширенная" кадровику и включаем только "ЧтениеДанныхДляНачисленияЗарплатыРасширенная"
21. ElenkaLisenka 22 30.07.19 13:30 Сейчас в теме
В кадровом переводе все равно на вкладке оплаты стоит галочка "Перевод утвержден" и отладка в ваш исправленный модуль в процедуру УстановитьВторогоОтветственногоВМногофункциональныхДокумента­х не заходит.
22. leaderonex 31 31.07.19 01:27 Сейчас в теме
(21) Проверьте релиз вашей ЗУП. Все работало, но на версии 3.1.5.129
23. user1311387 06.03.20 08:45 Сейчас в теме
Была похожая проблема с документом "Премия". Данный документ заводил планово-финансовый отдел (далее ПФО), после чего с ним работали расчетчики. Расчетчикам было важно знать утвержден документ или нет (в форме списка отслеживали по жирности), но после проведения у ПФО автоматом ставилась галка "Расчет утвержден" и имя текущего пользователя (без данной галки документ не проводился). Вылечилось отключением роли "Чтение начисленной зарплаты расширенная" для профиля группы доступа ПФО. (Зарплата и кадры государственного учреждения, редакция 3.1 (3.1.13.76) )
Оставьте свое сообщение

См. также

Online телефонный справочник из 1С: Зарплата и управление персоналом Промо

WEB Управление персоналом (HRM) Управление персоналом (HRM) v8 ЗУП3.x Россия Бесплатно (free)

В интернете представлено много реализаций online телефонных справочников организаций. Есть справочники, которые использует для хранения информации базу Active Directory (LDAP), есть справочники, которые реализованы с использованием СУБД (например, MySQL). Но я не нашел справочника, который использует информацию из базы 1С. Далее я рассмотрю данную разработку.

10.03.2017    26059    ruha    14    

Кадровые данные сотрудников ЗУП 3.1 в запросе

Зарплата Практика программирования v8 v8::СПР ЗУП3.x Россия БУ Бесплатно (free)

Получение кадровый данных сотрудников в запросе при помощи функции КадровыйУчет.СоздатьНаДатуВТКадровыеДанныеСотрудников().

26.10.2020    685    Danila7Zz    4    

Об отрицательном доходе замолвите слово...

Зарплата v8 v8::СПР ЗУП2.5 ЗКБУ ЗКГУ3.0 ЗУП3.x Россия БУ НУ НДФЛ ФОМС, ПФ, ФСС Бесплатно (free)

В данной статье речь пойдет о проблемах сдачи нашими любимыми бухгалтерами регламентированных отчетов «Расчет по страховым взносам» и «2-НДФЛ» в части т.н. "отрицательного дохода". Формируются и сдаются эти отчеты через 1С, а, значит, проблемы бухгалтеров касаются и нас, специалистов по техподдержке и сопровождению 1С.

20.10.2020    711    Богатырев Артур    1    

Настраиваем PWA приложение на платформе 8.3.18 с бесплатным действительным сертификатом SSL

Информационная безопасность ИТ-инфраструктура IIS v8 1cv8.cf Бесплатно (free)

Вышла платформа 8.3.18 с поддержкой PWA приложений. Получаем БЕСПЛАТНЫЙ действительный сертификат SSL. Настраиваем прогрессивное веб приложение для опубликованной бухгалтерии 3.0 на IIS сервере.

18.10.2020    3306    IamAlexy    24    

Права доступа в 1С:Документооборот 2.1 Промо

Информационная безопасность Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Бесплатно (free)

В программе 1С:Документооборот ред 2.1 механизм системы прав доступа сильно изменился. С одной стороны, права доступа в данной версии стали проще и быстрее, с другой стороны - права по рабочим группам объектов теперь могут противоречить политикам доступа. Разберемся в данной статье как работает механизм прав доступа в 1с документообороте 2.1.

16.09.2016    76023    vlush78    0    

Просто о 1С:ЗУП 3.1 за 10 минут

Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ УУ Бесплатно (free)

Когда начинал работать с конфигурацией 1С ЗУП 2.5 не было никакого краткого описания этой конфигурации. Приходилось читать умные книги. Статья представляет собой вводный инструктаж в 1С: ЗУП 3.1 для начинающих.

04.09.2020    3685    Kaval88    30    

RLS добавление ограничения доступа к данным по произвольному справочнику через штатные механизмы

БСП (Библиотека стандартных подсистем) Информационная безопасность Роли и права v8 КА2 Россия УУ Бесплатно (free)

Решал задачу ограничения доступ к объектам по справочнику "Банковские счета" штатными средствами БСП. Конфигурация КА 2.2. В остальных на БСП должно работать так же. Хотел сделать инструкцию для себя на будущее, решил поделиться.

05.08.2020    1665    ER34    2    

Странное поведение склонений в 1С: ЗУП 3.1

Зарплата v8 v8::СПР ЗУП3.x Россия Бесплатно (free)

Отдел кадров обратился с жалобой на непонятное поведение программы 1С: ЗУП 3.1 при печати приказов (некоторые фамилии не склоняются, или склоняются неверно). Причем, по их словам, совсем недавно все было нормально и те же самые фамилии склонялись верно.

26.07.2020    1383    vad    4    

ERP Управление Предприятием 2.0. Сдельная оплата Промо

Управленческий учет (прочее) Бухгалтерский учет Зарплата Зарплата v8 УПП1 ERP2 БУ УУ Бесплатно (free)

За некоторыми маленькими цифрами, которые нужно вносить в базу данных, прячется большой объем работ. К таким цифрам относится расценка по сдельной заработной плате. Как ее рассчитать? Как она меняется и от чего зависит?

24.11.2014    40080    PAVI    6    

Изменение RLS в ЗУП 3.1 для ограничения доступа к списку сотрудников

Роли и права v8 v8::Права ЗУП3.x Россия Бесплатно (free)

При переезде из УПП в ЗУП 3.1 бизнесом было поставлено условие, система должна ограничивать видимость сотрудников по подразделениям организации. Позиция 1С по этому вопросу однозначна, так делать нельзя. Но с определенными оговорками и условиями можно...

10.07.2020    2140    Zhilyakovdr    0    

Учет заработной платы на предприятиях оборонно-промышленного комплекса на 1С:ERP 2.4

Зарплата v8 ERP2 Россия БУ Бесплатно (free)

За последние годы на предприятиях оборонно-промышленного комплекса (далее по тексту – ОПК) ужесточились требования к ведению учета, участились проверки. Одним из учетных разделов, которые проверяются особенно тщательно была и остаётся заработная плата. В этой статье поговорим про опыт Внедренческого центра «Раздолье» в автоматизации расчета и учета заработной платы, налогов и резервов на отпуск на крупных промышленных предприятиях с учетом требований раздельного учета, которые установлены 47м постановлением (постановление Правительства РФ №47 от 19.01.1998 «О правилах ведения организациями, выполняющими государственный заказ за счет средств федерального бюджета, раздельного учета результатов финансово-хозяйственной деятельности») и 275-ФЗ (закона от 29.12.2012 №275 «О государственном оборонном заказе»).

25.05.2020    3037    1СERP    1    

Снижение тарифа страховых взносов по 102-ФЗ в комплексной автоматизации (КА) 1.1

Зарплата v8 КА1 Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Комплексная автоматизация (КА) 1.1 снята с поддержки, соответственно обновлений по новым ставкам нет. Необходимые доработки представлены в статье.

08.05.2020    2913    v.krivenko    10    

Доработки RLS. Примеры шаблонов. (в т.ч исключения из ограничений) Промо

Информационная безопасность v8 Бесплатно (free)

Допиливаем шаблоны RLS. Даем доступ пользователям к некоторым объектам

19.06.2013    64394    EvilDoc    38    

Получение нормы времени между двумя датами из Производственного календаря

Зарплата Практика программирования v8 v8::СПР ЗУП3.x Россия БУ УУ Бесплатно (free)

Понадобилось для решения задачи автоматизировать ручной расчет сверхурочных часов по очень "замудренной" формуле, в которой нужно получить норму времени между двумя определенными датами из Производственного календаря.

06.05.2020    1800    ivnik    4    

Тестируем быстро. Запуск сеанса под другим пользователем за 6 секунд!

Роли и права Пароли v8 v8::Права 1cv8.cf Бесплатно (free)

Как часто вам приходится запускать отладку под другим пользователем? Сколько времени у вас занимает запуск "чужого" сеанса? Убрать (если имеется) у себя аутентификацию ОС, сбросить пароль пользователя и восстановить его потом и т.д. Есть простой и действенный код, который поможет запускать сеансы под другим пользователем без ручной смены параметров аутентификации.

06.05.2020    4176    feva    15    

Перечисленный НДФЛ и как с этим бороться Промо

Зарплата Бухгалтерский учет Зарплата v8 ЗУП2.5 УПП1 Россия БУ НДФЛ Бесплатно (free)

Описание простой методики избавления от висящих остатков по НДФЛ перечисленному

20.02.2012    75145    kondrp    52    

Подробная инструкция для перехода с ЗУП 2.5 КОРП на ЗУП 3.1

Зарплата v8 v8::СПР ЗУП3.x Россия БУ Бесплатно (free)

Инструкция по переходу с ЗУП 2.5 КОРП на ЗУП 3.1 для программиста и бухгалтера.

06.04.2020    3944    user1233082    3    

Настройки зарплаты с учетом важных изменений от 25.03.2020

Зарплата v8 v8::СПР ERP2 ЗУП3.x Россия БУ ЕСН ФОМС, ПФ, ФСС Бесплатно (free)

В телевизионном выступлении Президента РФ, которое было опубликовано во второй половине 25 марта 2020 года, было заявлено несколько важных изменений, влияющих на настройки контура учета зарплаты.

26.03.2020    11887    Nikola23    39    

Заполнение ведомости на выплату в банк, когда у человека несколько зарплатных проектов (ЗУП 3.1)

Зарплата Банковские операции v8 v8::СПР ЗУП3.x Россия Бесплатно (free)

По долгу работы не раз приходилось сталкиваться с проблемой, когда у сотрудника несколько зарплатных карт. Я предлагаю небольшое решение данного вопроса, т.к. не нашёл в интернете и на форуме информацию, которая бы помогла решить вопрос.

04.03.2020    2502    nestokay    5    

Отправка "Заявления на подключение к ЭДО ПФР" из программы "1С: Бухгалтерия предприятия, ред. 2" для СЗВ-ТД

Документооборот и делопроизводство Зарплата Управление персоналом (HRM) v8 v8::БУ БП2.0 Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Инструкция по отправке "Заявления на подключение к ЭДО ПФР" из программы "1С Бухгалтерия предприятия, ред. 2" для обмена сведениями об электронных трудовых книжках и отправки отчетов по форме СЗВ-ТД.

11.02.2020    22345    rusmil    8    

Электронные трудовые книжки, СЗВ-ТД в ЗУП 3.1 - сборник ответов на вопросы и полезные ссылки

Документооборот и делопроизводство Зарплата v8 v8::СПР ЗУП3.x Россия БУ Бесплатно (free)

С 1 января 2020 г. начался переход на электронные трудовые книжки. До середины февраля 2020 г. все работодатели должны сдать первый отчет по форме СЗВ-ТД. Не смотря на то, что срок сдачи уже достаточно близок, информация по данному направлению постоянно изменяется и уточняется. Я постаралась собрать ключевые моменты, касающиеся перехода на электронный формат ведения трудовых книжек сотрудников в программе ЗУП 3.1, которые возникли при изучении этого нововведения. Данный сборник будет полезен как бухгалтеру/кадровику, так и 1С программисту или консультанту, сопровождающему переход. Весь предложенный материал можно найти самостоятельно, моей целью было собрать разные источники воедино дабы облегчить работу моим коллегам. В связи с тем, что информация может корректироваться и уточняться, необходимо проверять ее актуальность, поэтому в каждом найденном ответе указан источник для проверки. Внимание - данный сборник является справочным, работодатель должен руководствоваться исключительно Законодательством об электронных трудовых книжках. В сборник первоначально вошли только те вопросы, с которыми я столкнулась в своей работе лично, поэтому критика и предложения по дополнению приветствуются! !!!UPD - произошло значительное изменение функционала СЗВ - ТД https://its.1c.ru/db/updinfo#content:701:1:issogl2_2

28.01.2020    50281    Bene_Valete    220    

Секреты 1С:ЗУП 3

Зарплата Пользователю системы v8 v8::СПР ЗУП3.x Бесплатно (free)

В этой статье описаны несколько небольших секретов, позволяющих упростить работу с программой: 1. Как не забыть о Дне рождения сотрудника 2. Как в списке сотрудников отличить сотрудника по основному месту работы от совместителя 3. Как автоматически устанавливать организацию в документах

22.01.2020    5583    Neti    7    

Права пользователя исключительно на просмотр (чтение) для УТ 11.4

Роли и права v8 v8::Права УТ11 Россия Бесплатно (free)

Простая и понятная инструкция по шагам для создания профиля группы доступа «Только чтение» для УТ 11.4. Выполняется в режиме пользователя, без использования конфигуратора и снятия базы с поддержки.

21.11.2019    6860    Aleksandr55555    8    

WiseAdvise: Настройка расчета управленческой зарплаты в 1С:ЗУП КОРП 3.1

Зарплата Управление персоналом (HRM) v8 ЗУП3.x Россия УУ Бесплатно (free)

В статье описан механизм настройки расчета управленческой заработной платы в 1С ЗУП 3.1 КОРП в сравнении с аналогичным механизмом в ЗУП 2.5.

23.10.2019    8785    tamriko666@gmail.com    6    

Объединение организаций в ЗУП при реорганизации с переносом данных из ЗУП 2.5 в ЗУП 3.1

Зарплата Управление персоналом (HRM) Перенос данных из 1C8 в 1C8 v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Бесплатно (free)

В этой статье описан опыт объединения 2-х организаций при реорганизации в ЗУП 3.1 с переносом данных одной организации из ЗУП 2.5 (релизы баз более или менее свежие, но не самые последние на момент перехода, примерно двух- и трехмесячной давности). За основу было взято решение из этой статьи https://infostart.ru/public/833658/, в которой описан алгоритм решения задачи, за что автору статьи огромная благодарность! Здесь же даны некоторые комментарии и пояснения к алгоритму переноса и объединения, описаны выявленные мною ошибки. Также приведена небольшая инструкция по использованию обработки ирПодборИОбработкаОбъектовБД — она будет полезна для пользователей — «не программистов», впервые работающих в не управляемых формах.

09.10.2019    8138    Neti    2    

Типичные ошибки при разработке прав доступа

Роли и права v8 v8::Права Бесплатно (free)

Рассмотрим самые распространенные ошибки в разработке прав доступа.

02.10.2019    20338    YPermitin    57    

Отчеты ЗУП. Решения всех отчетов из сборника задач для подготовки к Специалист-консультант ЗУП с картинками

Решение задач на 1С:Специалист Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Бесплатно (free)

Когда готовился к сдаче экзамена на Специалист консультант по ЗУП, в процессе решения задач из сборника обнаружил, что те решения отчетов, которые есть в сети и на Инфостарте, недостаточно проиллюстрированы, и для новичка это может быть довольно тяжело и затратно по времени - разобраться, что к чему, с "нуля". Делал как шпаргалку для себя. Экзамен сдал на отлично. Рекомендую тем, кто готовится - прорешать все отчеты.

26.08.2019    16891    user1024932    19    

Постановка на воинский учет организации

Бухгалтерский учет Управление персоналом (HRM) Управление персоналом (HRM) v8::СПР ЗУП3.x Россия БУ Бесплатно (free)

Привет! Я тут знаете, что поняла? Что за всю свою практику не встречала более или менее конкретных статей про постановку на воинский учет (далее – ВУ) в организациях. Все, конечно, не просто так: довелось организовывать полностью с нуля вот не далее, чем только что. В процессе вспомнились мои первые попытки что-то на этом поприще сделать, сотни общих статей и вот это вот все. В общем, подумала я и решила, что время пришло. Надо написать нормальную статью про ВУ в коммерческих организациях и рассказать тем, кто автоматизировался на 1С зачем вообще нужны эти отчеты. Отмечу, что не претендую на истину любой инстанции. Сегодня я просто хочу рассказать о том, что за зверь такой постановка на воинский учет, опираясь на мой собственный опыт.

06.08.2019    6750    VKuser24804875    2    

Проверка наличия роли у пользователя

Роли и права v8 v8::Права 1cv8.cf Бесплатно (free)

Допустим, мы добавили новую роль в конфигурацию. Потом добавили её в профиль группы доступа и назначили соответствующую группу доступа пользователю. Однако, в конфигурациях на основе БСП все известные программные проверки данной роли при включении пользователя в предопределенную группу доступа "Администраторы" не работают. В статье приведено решение данной задачи.

29.06.2019    20955    ni_cola    17    

Назад в прошлое! Небольшие заметки по администрированию пользователей в УПП

Роли и права v8 УПП1 Бесплатно (free)

Небольшие заметки по функционалу "Администрирование пользователей" конфигурации "Управление производственным предприятием" версии 1.3. Затрагиваются такие темы как: роли, профили доступа, дополнительные права, настройки пользователей и ограничения доступа на уровне записей (RLS).

06.06.2019    13661    YPermitin    18    

Подсистема БСП «Управление доступом», основные объекты и регистры

БСП (Библиотека стандартных подсистем) Роли и права v8 v8::УФ v8::Права 1cv8.cf Бесплатно (free)

Основные принципы работы подсистемы «Управление доступом» из состава БСП. Виды доступа, ограничение доступа на уровне записей. Описание основных объектов и регистров, используемых подсистемой.

23.05.2019    23263    ids79    9    

Неверный расчет СЗВ-СТАЖ. ЗУП 3.1

Адаптация типовых решений Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ ФОМС, ПФ, ФСС Бесплатно (free)

При заполнении отчета СЗВ-СТАЖ на последних релизах ЗУП (ошибка не исправлена и в релизе 3.1.9.107) выявлены ошибки при расчете периодов, а также неверное выделение стажа ДЛОТПУСК.

01.03.2019    7688    dbachinsky    2    

Как сделать в ЗУП 2.5 зарплатную отчетность за 2018 год; полезности для ЗУП 3.1 и БП 3.0 (обзор)

Зарплата Управление персоналом (HRM) Бухгалтерский учет Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР ЗУП2.5 БП3.0 ЗУП3.x БУ НДФЛ ФОМС, ПФ, ФСС Бесплатно (free)

Нашла на Инфостарте весьма полезные вещи для бухгалтеров, занимающихся зарплатной отчетностью. Если точнее, для тех, кто делает 2-НДФЛ в «Бухгалтерии 3.0», 6-НДФЛ – в «ЗУП 3.1», либо работает в «ЗУП 2.5» и должен подготовить 2-НДФЛ и СЗВ-СТАЖ за 2018 год.

27.02.2019    9273    udb2007    6    

Как вывести дополнительные реквизиты на форму списка справочника Графики работы сотрудников. Управляемые формы. Без снятия конфигурации с поддержки

Работа с интерфейсом Зарплата Зарплата v8 ERP2 ЗУП3.x Россия БУ Бесплатно (free)

Как вывести дополнительные реквизиты на форму списка справочника Графики работы сотрудников Подходит для ERP, ЗУП v. 3.0; 3.1

24.02.2019    10310    EVP_EVP    7    

Загрузка ЭЛН (электронных листов нетрудоспособности) из файлов

Внешние источники данных Зарплата Зарплата v8 УПП1 Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Что делать, если по каким-то причинам нет возможности разместить 1С и Крипто-Про на одном рабочем месте? Правильно - открывать конфигуратор и пилить. Благо, там не сложно. Непосредственно решение для УПП 1.3. Для ЗиК 2.5 и Комплексной автоматизации должно быть аналогично.

07.02.2019    6812    SatanClaws    4    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    42008    ids79    9    

Переход на "Зарплату и управление персоналом 3.1"

Интеграция Управление персоналом (HRM) Пользователю системы Бухгалтерский учет Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Бесплатно (free)

Сменила я тут работу и уже после того, как я приступила к исполнению обязанностей, мой новый начальник мне призналась, что выбор пал на меня только из-за того, что я знаю программу. Справедливости ради, эта уверенность была основана только на том, что я прошла тестирование, включающее только основные операции кадрового делопроизводства. Так или иначе, а работодатель попал в точку, нанимая меня в надежде, что я решу проблему: нужно перейти «с 8.2 на 8.3». Ничего сложного, скажет большинство, я тоже так говорю, но ситуация осложнялась некоторым количеством предшественников, которые уже «нафеячили» в программах до меня. Взять и сделать все заново мне не разрешили, так что пришлось исходить из того, что есть, и именно это дало пищу для размышлений и, в конце концов, привело к написанию этих рекомендаций. Если перед Вами стоит задача перехода с ЗУП 2.5 на ЗУП 3.1, я попробую облегчить Вам жизнь этой статьей.

01.02.2019    13542    VKuser24804875    33    

Влияние настройки роли на потребление памяти

Роли и права v8::Права 1cv8.cf Бесплатно (free)

На днях разбирался с проблемой с потреблением памяти процессами конфигуратора и rphost. Как оказалось - причина в настройках ролей. Один поворот не туда, и настройки роли приводят к чрезмерному потреблению оперативки.

29.01.2019    13545    mickey.1cx    15    

Сдача 2-НДФЛ за 2018 год из конфигурации Зарплата и Управление Персоналом, редакция 2.5 (2.5.130.2)

Зарплата Регламентированная отчетность Зарплата v8 v8::СПР ЗУП2.5 Россия БУ НДФЛ Бесплатно (free)

В статье я пошагово описал процесс сдачи отчётности из 1С ЗУП редакции 2.5 через программу "Налогоплательщик ЮЛ". Весь процесс я разбил на 5 шагов, подробно и с картинками описал каждый шаг.

05.01.2019    23305    busa_nn    23    

Использование утилиты ring для выяснения данных о программных лицензиях

Информационная безопасность v8 Бесплатно (free)

Использование утилиты ring для управления программными лицензиями без ее установки на компьютер пользователя.

22.12.2018    11641    Vovan58    20    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    95590    GeterX    121    

Кадровые данные сотрудников в ЗУП 3.1 в отчетах

Универсальные функции Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия Бесплатно (free)

Параметры используемые для получения данных сотрудников в ЗУП 3.1. Пригодится для разработки отчетов как напоминалка.

07.11.2018    35663    fromlion    23    

Работа с подразделом "Специальная оценка условий труда" раздела "Охрана труда" в программе "1С:Зарплата и управление персоналом Корп, редакция 3.1"

Пользователю системы Управление персоналом (HRM) Бухгалтерский учет Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Бесплатно (free)

В процессе ввода в эксплуатацию блока "Охрана труда" столкнулась со скудным количеством информации по работе с данным разделом в сети Интернет, поэтому решила поделиться с сообществом своими наработками по данной теме. В публикации описана работа с подразделом "Специальная оценка условий труда" раздела "Охрана труда" в программе "1С:Зарплата и управление персоналом Корп, редакция 3.1".

16.10.2018    13969    opolyakova    1