БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Публикация № 827126

Разработка - Практика программирования

РЗ Регламентное задание БСП Дополнительные обработки Отладка Обработка

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

Если у Вас возник вопрос, как можно вообще напортачить с регламентными заданиями? Почитайте живые примеры из статьи -> Велостыли: Регламентные задания

Для экспериментов я использовал Платформы 8.3.10.2650 и 8.3.12.1412, конфигурации БСП 2.4.6.56 и 3.0.1.127.

Устанавливаем демо конфигурацию БСП и поехали! Работать будем со Справочником «Заметки». У него есть реквизит Содержание с типом ХранилищеЗначения, а это значит, туда много, что записать можно, ну и присутствуют другие реквизиты, с которыми тоже поработаем.

Содержание:

1 Один регламент

2 Регламент и форма с ручным запуском.

3 Два регламента, форма с ручным запуском и сохранение параметров для регламентов.

Рекомендации по отладке.

Задачи и решения.

Задача 1. Создать с помощью регламента новый элемент справочника Заметки и записать в реквизит содержание «Заметка создана регламентом в Время создания»

Создаем внешнюю обработку, назовем ее, например, «БСП_ДО_Регламенты»

Добавляем код в модуль:

// Возвращает сведения о внешней обработке.
Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.4.5.71");
	
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
	ПараметрыРегистрации.Версия = "1.0.01";
	
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 1 регламент'");
	НоваяКоманда.Идентификатор = "Задача1Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	Возврат ПараметрыРегистрации;
	
КонецФункции

// Интерфейс для запуска логики обработки.
Процедура ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения) Экспорт
	
	// Диспетчеризация обработчиков команд.
	Если ИмяКоманды = "Задача1Регламент" Тогда
		Команда_ЗаДача1(ПараметрыВыполнения);
	КонецЕсли;
	
КонецПроцедуры

Процедура Команда_ЗаДача1(ПараметрыВыполнения)
	
	СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения);
		
КонецПроцедуры	

Процедура СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения)
	//Создаем новый элемент справочника
	ТекущийОбъект = Справочники.Заметки.СоздатьЭлемент();
	
	ДатаТекСеанса = ТекущаяДатаСеанса();
	
	//Формируем текст для Содержания
	ФорматированныйТекст = Новый ФорматированныйДокумент;
	ФорматированныйТекст.Добавить("Заметка создана регламентом в " + Строка(ДатаТекСеанса),Тип("ТекстФорматированногоДокумента"));
	
	ТекущийОбъект.Содержание = Новый ХранилищеЗначения(ФорматированныйТекст, Новый СжатиеДанных(9));
	
	ТекстHTML = "";
	Вложения = Новый Структура;
	ФорматированныйТекст.ПолучитьHTML(ТекстHTML, Вложения);
	
	ТекущийОбъект.ТекстСодержания	= СтроковыеФункцииКлиентСервер.ИзвлечьТекстИзHTML(ТекстHTML);
	
	ТекущийОбъект.ДатаИзменения 	= ДатаТекСеанса;
	ТекущийОбъект.Автор 			= ПараметрыСеанса.ТекущийПользователь;
	ТекущийОбъект.Пометка 			= Перечисления.ЦветаЗаметок.Красный;
	ТекущийОбъект.ДляРабочегоСтола	= Истина;
	
	ТекущийОбъект.Записать();
КонецПроцедуры

Сохраняем обработку и добавляем ее в нашу конфигурацию для тестов БСП демо.

Моя настройка: C 6 мая 2018 г. каждый день; по 23:59:59 каждые 60 секунд.

Записываем и проверяем.

Вот так просто можно добавить регламент, не изменяя типовой конфигурации. Когда-нибудь РЗ возможно можно будет добавлять через расширение, а пока можно использовать БСП.

Задача 2. В созданную нами дополнительную обработку необходимо добавить форму с возможностью ручного запуска регламентного задания. При этом в содержание надо писать создана заметка вручную или по регламенту.

Меняем код в модуле обработки:

// Возвращает сведения о внешней обработке.
Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.4.5.71");
	//ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
	
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
	ПараметрыРегистрации.Версия = "1.0.02";
	
	//Открываем форму
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Форма задач по регламентам'");
	НоваяКоманда.Идентификатор = "НастроитьИВыполнитьЗадачиВручную";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
	НоваяКоманда.ПоказыватьОповещение = Ложь;
	
	//Регламент1
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 1 регламент'");
	НоваяКоманда.Идентификатор = "Задача1Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	Возврат ПараметрыРегистрации;
	
КонецФункции

// Интерфейс для запуска логики обработки.
Процедура ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения) Экспорт
	//Если в структуре параметров не передан вид запуска считаем что это запуск регламентом
	Если не ПараметрыВыполнения.свойство("ВидЗапускаРегламент") Тогда 
		ПараметрыВыполнения.Вставить("ВидЗапускаРегламент",Истина);	
	КонецЕсли;	
	
	// Диспетчеризация обработчиков команд.
	Если ИмяКоманды = "Задача1Регламент" Тогда
		Команда_ЗаДача1(ПараметрыВыполнения);
	КонецЕсли;
	
КонецПроцедуры

Процедура Команда_ЗаДача1(ПараметрыВыполнения)

	СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения);
		
КонецПроцедуры	

Процедура СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения)
	//Создаем новый элемент справочника
	ТекущийОбъект = Справочники.Заметки.СоздатьЭлемент();
	
	ДатаТекСеанса = ТекущаяДатаСеанса();
	
	//Формируем текст для Содержания
	ФорматированныйТекст = Новый ФорматированныйДокумент;
	
	//Добавили проверку регламент\форма
	ФорматированныйТекст.Добавить("Заметка создана " + ?(ПараметрыВыполнения.ВидЗапускаРегламент,"регламентом","вручную") + " в "+Строка(ДатаТекСеанса), Тип("ТекстФорматированногоДокумента"));
	
	ТекущийОбъект.Содержание = Новый ХранилищеЗначения(ФорматированныйТекст, Новый СжатиеДанных(9));
	
	ТекстHTML = "";
	Вложения = Новый Структура;
	ФорматированныйТекст.ПолучитьHTML(ТекстHTML, Вложения);
	
	ТекущийОбъект.ТекстСодержания	= СтроковыеФункцииКлиентСервер.ИзвлечьТекстИзHTML(ТекстHTML);
	
	ТекущийОбъект.ДатаИзменения 	= ДатаТекСеанса;
	ТекущийОбъект.Автор 			= ПараметрыСеанса.ТекущийПользователь;
	ТекущийОбъект.Пометка 			= Перечисления.ЦветаЗаметок.Красный;
	ТекущийОбъект.ДляРабочегоСтола	= Истина;
	
	ТекущийОбъект.Записать();
КонецПроцедуры	

Добавляем форму и создаем команду «Задание2»

&НаКлиенте
Процедура Задание2(Команда)
	Задание2НаСервере();
КонецПроцедуры

&НаСервере
Процедура Задание2НаСервере()
	ПараметрыВыполнения = новый Структура("ВидЗапускаРегламент",Ложь);
	ИмяКоманды = "Задача1Регламент";
	
	ОбрОбъект = РеквизитФормыВЗначение("Объект");
	ОбрОбъект.ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения);
КонецПроцедуры

Записываем и заменяем предыдущую дополнительную обработку на эту.

Проверяем результат:

Задача 3. Создать второе регламентное задание и сделать  так, чтобы можно было сохранять параметры настроек, текст содержания и цвет (Пометка). При выполнении заданий параметры заполняют элемент справочника «Заметки». Ранее созданная кнопка должна запускать выбранное задание.

Редактируем функцию СведенияОВнешнейОбработке в модуле обработки. Добавляем второе регламентное задание.

// Возвращает сведения о внешней обработке.
Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.4.5.71");
	
	ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
	ПараметрыРегистрации.Версия = "1.0.06";
	
	//Открываем форму
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Форма задач по регламентам'");
	НоваяКоманда.Идентификатор = "НастроитьИВыполнитьЗадачиВручную";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
	НоваяКоманда.ПоказыватьОповещение = Ложь;
	
	//Регламент1
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 1 регламент'");
	НоваяКоманда.Идентификатор = "Задача1Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;
	
	//Регламент2
	НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
	НоваяКоманда.Представление = НСтр("ru = 'Задача 2 регламент'");
	НоваяКоманда.Идентификатор = "Задача2Регламент";
	НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
	НоваяКоманда.ПоказыватьОповещение = Истина;

	Возврат ПараметрыРегистрации;
	
КонецФункции

К модулю вернемся позже. Переходим к редактированию формы.

Создаем параметр формы "ДополнительнаяОбработкаСсылка" с типом "СправочникСсылка.ДополнительныеОтчетыИОбработки"

Создаем реквизиты формы.

"РегламентноеЗаданиеСписок" с типом "Строка"

"СписокРЗ" с типом "ТаблицаЗначений"

                -"КлючРЗ" с типом "Строка"

                -"ТекстСодержания" с типом "Строка"

                -"Пометка" с типом "ПеречислениеСсылка.ЦветаЗаметок"

Переименовываем команду «Задание2» в команду «ВыполнитьРЗ», соответственно процедуру тоже приводим к такому имени.

Создаем команду «ЗаписатьИзменения»

Форму делаем вот такого вида

Подготовительные работы выполнены, переходим к программированию.

Список для списка РЗ и ключи РЗ будем брать из модуля обработки, из функции СведенияОВнешнейОбработке она Экспортная. Нас интересуют все команды где Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();

Дальше мы будем считывать параметры, сохраненные в обработке Хранить их будем в ХранилищеНастроек

Для того чтобы делать меньше телодвижений в модуле обработки пропишем структуру для чистых настроек, для этого создадим экспортную функцию ПолучитьЧистуюСтруктуруНастроек

//Чистые настройки
Функция ПолучитьЧистуюСтруктуруНастроек() Экспорт
	СтруктураДанных = Новый Структура;
	СписокРЗ = Новый ТаблицаЗначений;
	СписокРЗ.Колонки.Добавить("КлючРЗ");
	СписокРЗ.Колонки.Добавить("ТекстСодержания");
	СписокРЗ.Колонки.Добавить("Пометка");
	
	СтруктураДанных.Вставить("СписокРЗ",СписокРЗ);
	Возврат СтруктураДанных;
КонецФункции

Создаем процедуру ПриСозданииНаСервере

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ЗаполнитьЗаписаннымиДанными();
КонецПроцедуры
Процедура ЗаполнитьЗаписаннымиДанными()
	ОбрОбъект = РеквизитФормыВЗначение("Объект");
	
	//Читаем информацию по доп обработке
	ПолучитьСведеньяОбработки = ОбрОбъект.СведенияОВнешнейОбработке();
	
	//В ТЗ Команды будем забирать только регламенты
	ПараметрыОтбора = Новый Структура;
	ПараметрыОтбора.Вставить("Использование", ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода());
	СтрокиРЗ = ПолучитьСведеньяОбработки.Команды.НайтиСтроки(ПараметрыОтбора);
	
	ОбъектСсылка = Параметры.ДополнительнаяОбработкаСсылка;
	
	перСтруктураНормальная = Ложь;
	Если ЗначениеЗаполнено(ОбъектСсылка) Тогда	
		//Читаем ХранилищеНастроек
		перОбщиеПараметры = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ОбъектСсылка, "ХранилищеНастроек");
		СтруктураОбщиеПараметры = перОбщиеПараметры.Получить();
		
		Если Не ЗначениеЗаполнено(СтруктураОбщиеПараметры) Тогда 
			//записываем чистую структуру
			СтруктураОбщиеПараметры = ОбрОбъект.ПолучитьЧистуюСтруктуруНастроек(); 
		
		КонецЕсли;
		
		Если СтруктураОбщиеПараметры.Свойство("СписокРЗ") Тогда
			Если ТипЗнч(СтруктураОбщиеПараметры.СписокРЗ) = Тип("ТаблицаЗначений") Тогда 
				перСтруктураНормальная = Истина;	
	        КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	
	МассивРЗ = Новый Массив;
	Если перСтруктураНормальная Тогда
		//Собираем данные для вывода на форму
		Для Каждого СтрокаРЗ Из СтрокиРЗ Цикл
			//Собираем Элементы.РегламентноеЗаданиеСписок.СписокВыбора
	        МассивРЗ.Добавить(СтрокаРЗ.Идентификатор);
			
			ПараметрыОтбора		= Новый Структура;
			ПараметрыОтбора.Вставить("КлючРЗ", СтрокаРЗ.Идентификатор);
			НайденныеСтрокиРЗ	= СтруктураОбщиеПараметры.СписокРЗ.НайтиСтроки(ПараметрыОтбора);	
			
			Если НайденныеСтрокиРЗ.Количество() = 0 Тогда 
				НовСтрока 			= СписокРЗ.Добавить();
	        	НовСтрока.КлючРЗ	= СтрокаРЗ.Идентификатор;	
			Иначе	
				Для Каждого нСтрокаРЗ из НайденныеСтрокиРЗ Цикл 
					НовСтрока = СписокРЗ.Добавить();
					ЗаполнитьЗначенияСвойств(НовСтрока,нСтрокаРЗ);
				КонецЦикла;	
			КонецЕсли;	
		КонецЦикла;	
	Иначе
		//Если настройки отсутствуют в сохраненных настройках, добавляем их в таблицу со значениями по умолчанию
		Для Каждого СтрокаРЗ Из СтрокиРЗ Цикл	
			//Собираем Элементы.РегламентноеЗаданиеСписок.СписокВыбора
			МассивРЗ.Добавить(СтрокаРЗ.Идентификатор);
			
			НовСтрока 					= СписокРЗ.Добавить();
	        НовСтрока.КлючРЗ			= СтрокаРЗ.Идентификатор;
	    КонецЦикла;	
	КонецЕсли;
	//Заполняем список заданий
	Элементы.РегламентноеЗаданиеСписок.СписокВыбора.ЗагрузитьЗначения(МассивРЗ);	
КонецПроцедуры

Создаем процедуру для команды «ЗаписатьИзменения»

&НаКлиенте
Процедура ЗаписатьИзменения(Команда)
	ЗаписатьИзмененияНаСервере();
КонецПроцедуры
&НаСервере
Процедура ЗаписатьИзмененияНаСервере()
	Если не ЗначениеЗаполнено(Параметры.ДополнительнаяОбработкаСсылка) Тогда 
		Сообщить("Запись работает только в режиме встроенной доп обработки!",СтатусСообщения.Важное);
		Возврат;	
	КонецЕсли;	
	
	СтруктураДанных = Новый Структура("СписокРЗ",СписокРЗ.Выгрузить());
	
	ДополнительнаяОбработкаОбъект = Параметры.ДополнительнаяОбработкаСсылка.ПолучитьОбъект();
	ДополнительнаяОбработкаОбъект.ХранилищеНастроек = Новый ХранилищеЗначения(СтруктураДанных);
	ДополнительнаяОбработкаОбъект.Записать();
КонецПроцедуры

Изменяем процедуру для команды «ВыполнитьРЗ»

&НаКлиенте
Процедура ВыполнитьРЗ(Команда)
	ВыполнитьРЗНаСервере();
КонецПроцедуры

&НаСервере
Процедура ВыполнитьРЗНаСервере()
	Если не ЗначениеЗаполнено(РегламентноеЗаданиеСписок) Тогда 
		Сообщить("Выберите РЗ!!!",СтатусСообщения.Важное);
		Возврат;
	КонецЕсли;	
	
	ПараметрыОтбора		= Новый Структура;
	ПараметрыОтбора.Вставить("КлючРЗ", РегламентноеЗаданиеСписок);
	НайденныеСтрокиРЗ	= СписокРЗ.НайтиСтроки(ПараметрыОтбора);	
			
	Если НайденныеСтрокиРЗ.Количество() = 0 Тогда
		Сообщить("Не найдено параметров РЗ!!! "+РегламентноеЗаданиеСписок,СтатусСообщения.Важное);
		Возврат;
	КонецЕсли;	
	
	//ПараметрыРЗ формируем на клиенте, вдруг не записали в ТЗ изменения
	ПараметрыВыполнения = новый Структура("ПараметрыРЗ");
	ПараметрыВыполнения.Вставить("ВидЗапускаРегламент",Ложь);
	ИмяКоманды = РегламентноеЗаданиеСписок;
	
	ОбрОбъект = РеквизитФормыВЗначение("Объект");
	//Если вдруг умудрились задублировать в ТЗ регламенты
	Для Каждого СтрокаРЗ из НайденныеСтрокиРЗ Цикл 
	    ПараметрыВыполнения.ПараметрыРЗ = Новый Структура("ТекстСодержания,Пометка",
										СтрокаРЗ.ТекстСодержания,
										СтрокаРЗ.Пометка);
		ОбрОбъект.ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения);	
	КонецЦикла;	
КонецПроцедуры

Изменяем в модуле обработки процедуру «ВыполнитьКоманду»

// Интерфейс для запуска логики обработки.
Процедура ВыполнитьКоманду(ИмяКоманды, ПараметрыВыполнения) Экспорт
	//Если в структуре параметров не передан вид запуска считаем что это запуск регламентом
	Если не ПараметрыВыполнения.свойство("ВидЗапускаРегламент") Тогда 
		ПараметрыВыполнения.Вставить("ВидЗапускаРегламент",Истина);	
	КонецЕсли;	
	
	// Диспетчеризация обработчиков команд.
	Если ИмяКоманды = "Задача1Регламент" 
		или ИмяКоманды = "Задача2Регламент" Тогда
		
		Если ПараметрыВыполнения.ВидЗапускаРегламент Тогда 
			ОбъектСсылка = ПараметрыВыполнения.ДополнительнаяОбработкаСсылка;	
			Если ЗначениеЗаполнено(ОбъектСсылка) Тогда	
				//Читаем ХранилищеНастроек
				перОбщиеПараметры = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ОбъектСсылка, "ХранилищеНастроек");
				СтруктураОбщиеПараметры = перОбщиеПараметры.Получить();
				
				Если Не ЗначениеЗаполнено(СтруктураОбщиеПараметры) Тогда 
					//записываем чистую структуру
					СтруктураОбщиеПараметры = ПолучитьЧистуюСтруктуруНастроек(); 
				
				КонецЕсли;
				
				Если СтруктураОбщиеПараметры.Свойство("СписокРЗ") Тогда
					Если ТипЗнч(СтруктураОбщиеПараметры.СписокРЗ) = Тип("ТаблицаЗначений") Тогда 
						
						//Все проверки прошли
						ПараметрыОтбора		= Новый Структура;
						ПараметрыОтбора.Вставить("КлючРЗ", ИмяКоманды);
						НайденныеСтрокиРЗ	= СтруктураОбщиеПараметры.СписокРЗ.НайтиСтроки(ПараметрыОтбора);
						
						Если НайденныеСтрокиРЗ.Количество() > 0 Тогда

							//Если вдруг умудрились задублировать в ТЗ регламенты
							Для Каждого СтрокаРЗ из НайденныеСтрокиРЗ Цикл 
								
								Если ПараметрыВыполнения.Свойство("ПараметрыРЗ") Тогда 
								
							    	ПараметрыВыполнения.ПараметрыРЗ = Новый Структура("ТекстСодержания,Пометка",
																СтрокаРЗ.ТекстСодержания,
																СтрокаРЗ.Пометка);
								Иначе
									ПараметрыВыполнения.Вставить("ПараметрыРЗ",Новый Структура("ТекстСодержания,Пометка",
																СтрокаРЗ.ТекстСодержания,
																СтрокаРЗ.Пометка));							
								КонецЕсли;
								
								Команда_ЗаДача1(ПараметрыВыполнения);
							
							КонецЦикла;	
						КонецЕсли;
						
			        КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		Иначе	
			Команда_ЗаДача1(ПараметрыВыполнения);
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

и процедуру «СоздатьНовыйЭлементСправочникаЗаметки»

Процедура Команда_ЗаДача1(ПараметрыВыполнения)
     
	СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения);
		
КонецПроцедуры	

Процедура СоздатьНовыйЭлементСправочникаЗаметки(ПараметрыВыполнения)
	//Создаем новый элемент справочника
	ТекущийОбъект = Справочники.Заметки.СоздатьЭлемент();
	
	ДатаТекСеанса = ТекущаяДатаСеанса();
	
	//Формируем текст для Содержания
	ФорматированныйТекст = Новый ФорматированныйДокумент;
	
	//Обрабатываем Параметры
	перТекстСодержания = "Заметка создана ";
	перПометка = Перечисления.ЦветаЗаметок.Красный;
	Если ПараметрыВыполнения.Свойство("ПараметрыРЗ") Тогда 
		Если ТипЗнч(ПараметрыВыполнения.ПараметрыРЗ) = Тип("Структура") Тогда 
			Если ПараметрыВыполнения.ПараметрыРЗ.Свойство("ТекстСодержания") Тогда 
				Если ЗначениеЗаполнено(ПараметрыВыполнения.ПараметрыРЗ.ТекстСодержания) Тогда 
					перТекстСодержания = ПараметрыВыполнения.ПараметрыРЗ.ТекстСодержания;	
				КонецЕсли;	
			КонецЕсли;
			
			Если ПараметрыВыполнения.ПараметрыРЗ.Свойство("Пометка") Тогда 
				Если ЗначениеЗаполнено(ПараметрыВыполнения.ПараметрыРЗ.Пометка) Тогда 
					перПометка = ПараметрыВыполнения.ПараметрыРЗ.Пометка;	
				КонецЕсли;	
			КонецЕсли;

		КонецЕсли;	
	КонецЕсли;

	//Добавили проверку регламент\форма		
	ФорматированныйТекст.Добавить(перТекстСодержания + ?(ПараметрыВыполнения.ВидЗапускаРегламент,"регламентом","вручную") + " в "+Строка(ДатаТекСеанса), Тип("ТекстФорматированногоДокумента"));
	
	ТекущийОбъект.Содержание = Новый ХранилищеЗначения(ФорматированныйТекст, Новый СжатиеДанных(9));
	
	ТекстHTML = "";
	Вложения = Новый Структура;
	ФорматированныйТекст.ПолучитьHTML(ТекстHTML, Вложения);
	
	ТекущийОбъект.ТекстСодержания	= СтроковыеФункцииКлиентСервер.ИзвлечьТекстИзHTML(ТекстHTML);
	
	ТекущийОбъект.ДатаИзменения 	= ДатаТекСеанса;
	ТекущийОбъект.Автор 			= ПараметрыСеанса.ТекущийПользователь;

	ТекущийОбъект.Пометка 			= перПометка;
	ТекущийОбъект.ДляРабочегоСтола	= Истина;
	
	ТекущийОбъект.Записать();
КонецПроцедуры

Записываем и заменяем предыдущую дополнительную обработку на эту.

Заполняем настройки.

Проверяем ручной запуск и регламеты

Проверяем результат:

В коде можно было бы проверки вынести в одну процедуру\функцию. Как вы видите просто безграничные возможности предоставлены программистам по разработке сложных регламентов без доработки конфигурации.

Отладка.

Отладку регламентов можно проводить по описанию из этой статьи Отладка подключаемых обработок

Корректную отладку запуска из формы можно производить после того как в Параметры.ДополнительнаяОбработкаСсылка будет закинута ссылка на добавленную дополнительную обработкую. В нашем случае, достаточно просто в процедуру формы "ПриСозданииНаСервере" добавить одну строчку.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	//Для тестирования ХранилищеНастроек
	Параметры.ДополнительнаяОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоРеквизиту("ИмяОбъекта","БСП_ДО_Регламенты");
	ЗаполнитьЗаписаннымиДанными();
КонецПроцедуры

 

П.С. Пока писал данную статью в голову пришла еще одна по данной тематике.  БСП: Дополнительная обработка (Регламенты) + Расширения, примеры от сложного к универсальному

UPD 27.07.2019. Добавил файлы (Одна обработка несколько форм Файлы.rar) к статье БСП: Дополнительные отчеты и обработки - одна обработка несколько форм

Данная статья ответ на вопрос: Можно ли сделать так, чтобы у обработки было регл задание и две формы - работающие по-разному?

Скачать файлы

Наименование Файл Версия Размер
Дополнительная обработка (Регламенты) финальная

.epf 11,30Kb
09.05.18
31
.epf 1.0.8 11,30Kb 31 Скачать
БСП: Дополнительные отчеты и обработки - одна обработка несколько форм

.rar 35,62Kb
27.07.19
4
.rar 1 35,62Kb 4 Скачать

Специальные предложения

Лучшие комментарии
18. dsdred 1468 15.10.18 11:33 Сейчас в теме
(16)
Задача: из формы элемента ДополнительныеОтчетыИОбработки (или по-другому) открыть форму внешней обработки, один раз выбрать параметры, сохранить в ХранилищеНастроек, чтобы потом регл. задание считывало их оттуда. Как это лучше сделать для БСП 2.3.2.51?

Не нашел БСП 2.3.2.51 поэтому протестировал на 2.3.2.195

-добавляем обработку в доп очеты и обработки
-копию обработки открываем в конфигураторе

В обработке приложенной в данной статье раскоментируем код в модуле формы

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
//Для тестирования ХранилищеНастроек
Параметры.ДополнительнаяОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоРеквизиту("ИмяОбъекта","БСП_ДО_Регламенты");
ЗаполнитьЗаписаннымиДанными();
КонецПроцедуры

Открываем в клиенте и сохраняем параметры для рег. задания.
aleksey_korol; +1 Ответить
21. dsdred 1468 17.10.18 11:53 Сейчас в теме
(19)Прикладываю обработку.

скопировал в нее форму элемента справочника ДополнительныеОтчетыИОбработки из БСП 2.3.2.195

и создал простую форму с выбором ссылки из справочника ДополнительныеОтчетыИОбработки и команду открыть форму
Код команды: ОткрытьФорму("ВнешняяОбработка.ВнешняяОбработка1.Форма.ФормаЭлемента",новый Структура("Ключ",ДопОбработкаСсылка),ЭтаФорма);

Прин скрины прикладываю.
Прикрепленные файлы:
ВнешняяОбработка1.epf
aleksey_korol; +1 Ответить
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Dream_kz 109 10.05.18 08:17 Сейчас в теме
Как раз нужны были примеры по запуску доп. обработок по времени + хранение настроек этих самых обработок. Спасибо
2. dsdred 1468 10.05.18 08:21 Сейчас в теме
(1)
Как раз нужны были примеры по запуску доп. обработок по времени + хранение настроек этих самых обработок. Спасибо

Отлично, значит не зря писал статью.
jONES1979; +1 Ответить
3. rafaiil 10.05.18 08:51 Сейчас в теме
Отлично! Большое спасибо!;) Очень полезный для меня материал.
rutony; dsdred; +2 Ответить
4. TrinitronOTV 5 10.05.18 09:16 Сейчас в теме
Спасибо, пригодится
rutony; dsdred; +2 Ответить
5. jONES1979 10.05.18 09:18 Сейчас в теме
Эта статья интересна! Напишите еще одну, более интересную! :)
EGOLEGE; Max27; rutony; dsdred; +4 Ответить
6. dsdred 1468 10.05.18 09:23 Сейчас в теме
(5)
Эта статья интересна! Напишите еще одну, более интересную! :)

Ну судя по тому, что статья быстро набирает положительные голоса. Скорее всего будет продолжение.
7. Ava1or 10.05.18 16:40 Сейчас в теме
Спасибо! Огонь статья!
Эх, написал бы ты ее месяцок назад... Но уже сам разобрался)
8. dsdred 1468 10.05.18 21:30 Сейчас в теме
(7)Знал бы, что будет так интересна читателям, написал бы раньше))
9. serega_new 11.05.18 11:51 Сейчас в теме
Вот интересно почему в БСП четко не прописали в описании как хранить настройки для регламентных обработок, в демо БСП есть пример с хранением, но такой же не очевидный как и у вас. В голову не ложится, вот кстати уже шаблон делали - https://infostart.ru/public/627824/
10. dsdred 1468 11.05.18 12:01 Сейчас в теме
(9)Спасибо, не видел данную статью.
На счет описания 1с. Не знаю почему они пишут поверхностное описание. По сути желтые книжки могут служить только как справочник о том, что можно сделать и удобной подпоркой дивана если отпала ножка... А то как сделать google в помощь. Если не нашел сиди сам пробуй...

Да, в БСП есть пример (если кому понадобится)-> Демо: Загрузка номенклатуры из прайс-листа (профили безопасности)
Код сохранения настроек из обработки:

&НаСервереБезКонтекста
Процедура СохранитьНастройкиФормы(ДополнительнаяОбработкаСсылка, АдресФайла)
СохраняемоеЗначение = Новый Структура("АдресФайла", АдресФайла);

ДополнительнаяОбработкаОбъект = ДополнительнаяОбработкаСсылка.ПолучитьОбъект();
ДополнительнаяОбработкаОбъект.ХранилищеНастроек = Новый ХранилищеЗначения(СохраняемоеЗначение);
ДополнительнаяОбработкаОбъект.Записать();
КонецПроцедуры

чтение ПриСозданииНаСервере
11. Danilov 21.05.18 04:48 Сейчас в теме
Отличная статья. Возьму на заметку.
12. dsdred 1468 21.05.18 07:26 Сейчас в теме
(11) На этой неделе будет продолжение. Вторая часть на 90% готова.
13. aleksey_korol 11.10.18 18:25 Сейчас в теме
Как долго я искал, как передать параметры в регламент!
14. dsdred 1468 11.10.18 18:36 Сейчас в теме
(13)Рад, что статья пригодилась
15. aleksey_korol 13.10.18 18:26 Сейчас в теме
В БСП 2.3.2.51 нет кнопки "Выполнить" на странице "Команды" в форме элемента. Как вручную выполнить команду "Форма задач по регламентам"?
16. aleksey_korol 13.10.18 18:37 Сейчас в теме
(15) Задача: из формы элемента ДополнительныеОтчетыИОбработки (или по-другому) открыть форму внешней обработки, один раз выбрать параметры, сохранить в ХранилищеНастроек, чтобы потом регл. задание считывало их оттуда. Как это лучше сделать для БСП 2.3.2.51?
18. dsdred 1468 15.10.18 11:33 Сейчас в теме
(16)
Задача: из формы элемента ДополнительныеОтчетыИОбработки (или по-другому) открыть форму внешней обработки, один раз выбрать параметры, сохранить в ХранилищеНастроек, чтобы потом регл. задание считывало их оттуда. Как это лучше сделать для БСП 2.3.2.51?

Не нашел БСП 2.3.2.51 поэтому протестировал на 2.3.2.195

-добавляем обработку в доп очеты и обработки
-копию обработки открываем в конфигураторе

В обработке приложенной в данной статье раскоментируем код в модуле формы

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
//Для тестирования ХранилищеНастроек
Параметры.ДополнительнаяОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоРеквизиту("ИмяОбъекта","БСП_ДО_Регламенты");
ЗаполнитьЗаписаннымиДанными();
КонецПроцедуры

Открываем в клиенте и сохраняем параметры для рег. задания.
aleksey_korol; +1 Ответить
17. dsdred 1468 15.10.18 10:26 Сейчас в теме
(15)Первый вариант у меня описан в конце статьи в описании как отлаживать.

Корректную отладку запуска из формы можно производить после того как в Параметры.ДополнительнаяОбработкаСсылка будет закинута ссылка на добавленную дополнительную обработкую. В нашем случае, достаточно просто в процедуру формы "ПриСозданииНаСервере" добавить одну строчку.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
//Для тестирования ХранилищеНастроек
Параметры.ДополнительнаяОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоРеквизиту("ИмяОбъекта","БСП_ДО_Регламенты");
ЗаполнитьЗаписаннымиДанными();
КонецПроцедуры



Второй вариант сейчас протестирую и отпишусь.
aleksey_korol; +1 Ответить
19. aleksey_korol 17.10.18 09:54 Сейчас в теме
(17) Хотя бы вкратце: на чем основан 2-й вариант?
20. dsdred 1468 17.10.18 11:18 Сейчас в теме
(19)Вкраце просто создание команды по открытию формы через

ДополнительныеОтчетыИОбработкиКлиент.ВыполнитьОткрытиеФормыОбработки

ну или посмотреть какие в том модули еще варианты есть.
aleksey_korol; +1 Ответить
21. dsdred 1468 17.10.18 11:53 Сейчас в теме
(19)Прикладываю обработку.

скопировал в нее форму элемента справочника ДополнительныеОтчетыИОбработки из БСП 2.3.2.195

и создал простую форму с выбором ссылки из справочника ДополнительныеОтчетыИОбработки и команду открыть форму
Код команды: ОткрытьФорму("ВнешняяОбработка.ВнешняяОбработка1.Форма.ФормаЭлемента",новый Структура("Ключ",ДопОбработкаСсылка),ЭтаФорма);

Прин скрины прикладываю.
Прикрепленные файлы:
ВнешняяОбработка1.epf
aleksey_korol; +1 Ответить
22. sparhh 21.06.19 15:27 Сейчас в теме
А если создавать регламентное задание не через внешнюю обработку, а через встроенный объект.
То получается и теряется возможность гибко настраивать параметры регл. задания?
23. dsdred 1468 21.06.19 15:37 Сейчас в теме
(22)Да, потеряете возможность хранить параметры и придется либо создавать константу с типом Хранилище значений, но это неудобно если регламентов будет несколько. Либо создать справочник с реквизитом хранилище значений. И еще не забывайте про форму которая должна быть создана для работы с данными.

В этом и удобство данной подсистемы. У вас все в одном месте: параметры, форма и регламент.
24. sparhh 21.06.19 16:14 Сейчас в теме
(23) С одной стороны да, с другой же стороны. У тебя начинает копиться логика программы с кодом во внешних файлах.
25. sparhh 21.06.19 17:04 Сейчас в теме
(23) Я вот что не понимаю.. все таки.. если хочу сделать Регламентное задание через расширение, то в таком случае теряется легкость и гибкость, которая есть в механизме БСП Доп. обработки.
Так?
Я видел вашу статью на эту тему, но похоже на самописность..

К примеру есть механизм БСП "Заполнение объекта" и в расширениях он умеет преобразовываться уже в другой механизм.
В для регламентных заданиях нет такого, как я понял.
26. dsdred 1468 21.06.19 21:54 Сейчас в теме
(25)Не понимаю в чем вопрос?
27. user_2010 517 25.07.19 17:30 Сейчас в теме
можно ли сделать так, чтобы у обработки было регл задание и две формы - работающие по-разному?
28. dsdred 1468 26.07.19 18:28 Сейчас в теме
(27)
можно ли сделать так, чтобы у обработки было регл задание и две формы - работающие по-разному?

Огромное спасибо за вопрос, вы мне прям час работы скрасили!
Я дам подробный ответ в статье БСП: Дополнительные отчеты и обработки - одна обработка несколько форм опубликую ее в понедельник-вторник.

Огромная просьба описать ситуацию для которой Вам понадобилось несколько форм. Заранее спасибо!
29. user_2010 517 26.07.19 21:08 Сейчас в теме
(28) Большое спасибо!
Ваша статья мне очень помогла.
Вопрос возник при реализации задачи по загрузке данных из сторонних источников. Процедуры по чтению данных и загрузке - одни и те же. Но вот работать они могут по-разному:
1. Как регламентное задание - без участия пользователя.
2. Как обработка, запущенная пользователем, но без параметров - только одна кнопка "Загрузить", все параметры устанавливаются по умолчанию.
3. Как полноценная обработка пользователя с возможность указания своих параметров для чтения данных и настройки параметров для дальнейшей загрузки данных - при необходимости, и прочей дальнейшей обработки загруженных данных ....
Не хочется для этих целей плодить несколько обработок - хочется одну.
30. dsdred 1468 29.07.19 09:01 Сейчас в теме
31. user_2010 517 29.07.19 09:56 Сейчас в теме
32. Светлый ум 260 30.07.19 09:25 Сейчас в теме
Возьмем на вооружение, +1
33. Vyacheslide 9 14.08.19 11:18 Сейчас в теме
Огромное спасибо автору, искал как делать фоновые задания как то раз, ничего путного не нашел. Это же статья прямо разжевала и в рот положила. Респект!!!
34. dsdred 1468 14.08.19 11:22 Сейчас в теме
(33)Рад, что пригодилась статья.
Vyacheslide; +1 Ответить
35. Xershi 1020 09.12.19 20:21 Сейчас в теме
Нужно было написать регламентное задание с параметрами. Пилить в коде крайне не хотелось. Тем более хотелось все сделать универсально. Наткнулся сначала на аналогичную обработку, но там не было расписано как работает. А здесь все как на ладони.
Убрал всю лишнюю шелуху, которую вы описали и получилась универсальная обработка с параметрами.
Буду повсеместно теперь использовать, плюс 1 раз написал, как шаблон, а далее пользователь может плодить о однотипные регламенты многократно!
36. dsdred 1468 10.12.19 01:54 Сейчас в теме
(35)Спасибо за отзыв к статье. Рад, что описание механизма пригодилось в работе.
Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    34385    tormozit    44    

Загрузка, скачивание, удаление файлов с помощью НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера()

Практика программирования v8 1cv8.cf Абонемент ($m)

В платформе 8.3.15 появились новые методы НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера(). В данной статье рассмотрено готовое решение проверенное и прекрасно работающее на тонком и веб-клиенте.

1 стартмани

25.07.2020    2489    Flashill    10    

Параллельные вычисления расчета факториала числа N

Практика программирования v8 1cv8.cf Абонемент ($m)

Распараллеливание алгоритма с помощью фоновых заданий (асинхронные вычисления)

1 стартмани

29.06.2020    2477    Rustig    17    

История данных и БСП

БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

История данных от платформы и Версионирование объектов от БСП. Как мигрировать историю из подсистемы БСП и начать использовать функции платформы уже сейчас.

1 стартмани

09.06.2020    3398    zeegin    15    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    26970    wowik    3    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    7568    tormozit    13    

Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

1 стартмани

05.03.2020    5501    user5300    3    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    5625    burni4    16    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    70255    ildarovich    117    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    16742    sapervodichka    41    

Универсальные функции: разложение произвольной строки адреса в структуру

Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Процедуры и функции раскладывают произвольную строку адрес в структуру по ключевым словам.

1 стартмани

30.12.2019    3575    vik070777    10    

"Живые" картинки со Snap.SVG

Практика программирования WEB Работа с интерфейсом v8 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    13335    blackhole321    7    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    39324    ildarovich    22    

RLS - дубли условий в запросах к СУБД

Практика программирования Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    8360    geron4    4    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    29460    HostHost    40    

Полное копирование одной формы в другую

Практика программирования Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Однажды я столкнулся с необходимостью открыть форму ЛЮБОГО документа с определенными изменениями, не зависящими от структуры объекта (например, заблокировать все кнопки). В интернете решения я не нашел. Обычно на форумах на запросы подобного рода отвечают чем-то вроде "покажи первоначальную задачу, а не спрашивай как реализовать то, что ты придумал". Тем не менее, мне стало интересно, как это можно сделать.

1 стартмани

03.10.2019    4874    nekit_rdx    23    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    34894    rpgshnik    49    

Многопоточная обработка данных на примере перепроведения документов

Обработка документов Практика программирования v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    8960    ids79    46    

Отображение истории выполнения по всем задачам комплексного процесса в документообороте

Документооборот и делопроизводство Практика программирования v8 ДО Абонемент ($m)

Коллеги, предлагаю вашему вниманию доработку для вывода полной истории в задачах комплексного процесса.

1 стартмани

15.09.2019    6689    pavelpribytkin96    8    

Хороший заказчик - плохой заказчик

О жизни Россия Бесплатно (free)

Лайфхак о том, как стать легендарным клиентом.

13.09.2019    7719    dsdred    24    

Некоторая работа с данными через COM Промо

Практика программирования v8 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    57297    wowik    32    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    19170    Dementor    30    

Удобный просмотр результата запроса с большим количеством временных таблиц

Практика программирования v8 Абонемент ($m)

Если Вам часто приходится просматривать в отладчике сложные пакетные запросы с большим количеством временных таблиц, то эта статья для Вас.

1 стартмани

27.08.2019    10759    ids79    21    

Запуск фонового задания во внешней обработке. Отключение предупреждений защиты от опасных действий в фоновом задании

Практика программирования v8 1cv8.cf Абонемент ($m)

Как запустить фоновое задание из модуля внешней обработки используя БСП. Как отключить безопасный режим и сообщения защиты от опасных действий независимо от профиля безопасности пользователя в фоновом задании во внешней обработке.

2 стартмани

24.08.2019    10417    BenGunn    22    

Работа со схемой запроса Промо

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    43594    kalyaka    35    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    15338    signum2009    16    

БСП: Дополнительные отчеты и обработки - одна обработка, несколько форм

Практика программирования Работа с интерфейсом БСП (Библиотека стандартных подсистем) v8 Бесплатно (free)

Как в одной дополнительной обработке разместить несколько форм с типом команды "ОткрытиеФормы"?

29.07.2019    10768    dsdred    9    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    37287    vasilev2015    64    

Отладка подключаемых обработок Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

На самом деле для этого не нужно ни изменять конфигурацию, ни пользоваться вспомогательной обработкой-отладчиком.. Все просто :)

04.01.2017    60060    unichkin    83    

10 способов получить модуль числа (а может, и больше)

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Пишем функцию вычисления модуля числа. Сколько способов существует? Давайте посчитаем!

1 стартмани

11.07.2019    7914    sam441    29    

Ловец дедлоков СУБД

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Россия Абонемент ($m)

Анализ простейшего дедлока СУБД в рабочей базе с использованием ЦУП (центра управления производительностью) и profiler MS SQL (Microsoft SQL Server). Эта статья будет полезна людям, изучающим вопросы оптимизации работы 1С, или тем, у кого возникают дедлоки в рабочей базе. UPD 09.07.2019 добавлено воспроизведение блокировки в случае установки управляемой блокировки перед чтением набора записей регистра сведений. UPD 10.07.2019 добавлена тестовая база с примером.

1 стартмани

08.07.2019    10950    azazana    79    

Мониторинг производительности и искусственный интеллект

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Абонемент ($m)

Расскажем и покажем практически, как использовать искусственный интеллект на страже мониторинга производительности. У вас появится возможность создать собственного помощника Ларису, которая возьмет на себя вопросы по контролю и диагностике состояния обслуживаемой системы.

1 стартмани

01.07.2019    9147    ivanov660    28    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    48890    DarkAn    86    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    15276    informa1555    17    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    28677    Evil Beaver    126    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    29402    Hatson    31    

Новый запрос и новая таблица значений как функции Промо

Практика программирования v8 Абонемент ($m)

Предлагается две простые функции, использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

1 стартмани

27.11.2012    45135    ildarovich    46    

Графики работы из БСП

Практика программирования Разработка v8 1cv8.cf Россия Абонемент ($m)

Не очень давно на канале 1С:БСП была опубликована заметка по использованию Графиков работы и Календарных графиков.

1 стартмани

23.05.2019    3170    fenixnow    0    

Создание внешней печатной формы в формате документа Word

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье написано, как создать внешнюю печатную форму (для конфигураций с БСП) в формате Word.

1 стартмани

17.05.2019    13006    ВикторП    21    

Пример настройки шаблонов и реализации печати отчетов в документ MS Word используя функциональную часть "Библиотеки Стандартных Подсистем 1С" (БСП)

Практика программирования Разработка v8 Россия Абонемент ($m)

В конфигурации выбраны и использованы только необходимые объекты библиотеки стандартных подсистем для реализации вывода отчёта, с табличными частями, в документ MS Word. Показан пример создания необходимых областей в шаблоне для вывода параметров в отчёт.

1 стартмани

23.04.2019    6065    olegpkc    11    

Уровни, глубина, прародители, циклы и аналоги запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В продолжение публикации «Транзитивное замыкание запросом» [http://infostart.ru/public/158512/] добавлены другие варианты использования того же приема. Приведены запросы для быстрого определения уровней всех элементов справочника, максимальной глубины справочника, прародителей произвольных элементов справочника, запрос для быстрого определения циклов (на примере справочника спецификаций «1С:Управление производственным предприятием») и определения множеств аналогов номенклатуры (также на примере конфигурации «1С:Управление производственным предприятием»).

1 стартмани

13.11.2012    111482    ildarovich    98    

Ops средствами 1С:Предприятие

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье описан программный пакет "Автоматизация ИТ-процессов" (АИТП), позволяющий автоматизировать задачи по администрированию, управлению и обслуживанию ИТ-инфраструктуры.

1 стартмани

23.04.2019    17290    blackhole321    28    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    32616    riposte    65    

Вывод вариантов СКД в таблицы на управляемой форме

Практика программирования Работа с интерфейсом v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Задача стояла такая: есть 2 различных запроса, результаты которых выгружаются на форму обработки в таблицы значений (далее ТЗ) и программно "соприкасаются" между собой определенным образом (как именно- в рамках данной статьи неважно). Нюанс в том, что запросы должны иметь свой компоновщик настроек и могут интерактивно на форме изменяться пользователем. На оригинальность публикации не претендую - изначально в рамках поставленной задачи пытался найти что-то подобное (уже готовый шаблон) на инфостарте, возможно "плохо искал" ;)

05.04.2019    10968    artkor    1    

Неоплаченные долги при распределении оплаты по правилу ФИФО одним запросом и намного быстрее, чем Вы думали Промо

Практика программирования Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::СКД КА1 УТ10 УПП1 УУ Абонемент ($m)

Предлагается метод для быстрого нахождения неоплаченных долгов при распределении оплаты по правилу ФИФО, основанный на дихотомии. Описывается реализация метода в виде достаточно простого запроса, решающего за линейное время указанную задачу, считавшуюся ранее существенно более трудоемкой. Приводятся примеры использования запроса в отчетах на СКД для конфигураций УТ, КА, УПП.

1 стартмани

28.02.2014    68089    ildarovich    125    

[EnterpriseData] Антисвертка характеристик номенклатуры при выгрузке в Бухгалтерию

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 v8::ПВХ КД УНФ БП3.0 Россия БУ Абонемент ($m)

Рассмотрена выгрузка каждой пары значений Номенклатура - Характерстика из УНФ 1.6 в отдельную номенклатуру в Бухгалтерию 3.0 путём доработки правил обмена в формате EnterpriseData.

1 стартмани

27.03.2019    4532    nforce    5    

Интеграция 1С и SharePoint

Практика программирования Разработка v8 УНФ ДО ERP2 БП3.0 УТ11 УХ КА2 Россия Абонемент ($m)

Заказчики поставили задачу автоматизации согласования заявок на оплату в программе 1С:Бухгалтерия предприятия 3.0. Согласно ТЗ, данные должны подтягиваться из действующей электронной системы документаоборота на MS SharePoint (в дальнейшем СЭД MS SP).

1 стартмани

22.03.2019    5318    -I-    4    

Легкий "тюнинг" УТ 10.3

Практика программирования Разработка v8 v8::ОУ УТ10 Россия УУ Абонемент ($m)

Вариант программной реализации изменения форм типовых объектов для конфигурации Управление торговлей 10.3.

1 стартмани

15.03.2019    4343    pm74    6    

Транзитивное замыкание запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В частности, показывается, как одним пакетным запросом найти ВСЕХ предков (потомков) в иерархическом справочнике. Аналогично можно определять входимость деталей в узлы и готовые изделия по их спецификациям, определять подмножества аналогичных запчастей по цепочке аналогов, решать другие подобные задачи. Приложен файл с примером отчета для замыкания иерархии произвольного справочника, позволяющий протестировать быстродействие запроса в разных условиях.

1 стартмани

29.10.2012    84751    ildarovich    118    

Пример использования СКД и данных расшифровки на мобильной платформе

Практика программирования Разработка v8 v8::Mobile v8::СКД 1cv8.cf Россия Абонемент ($m)

СКД в мобильном приложении и меню действий на основе данных расшифровки (отчет, совместимый с мобильной платформой 8.3.13.45).

1 стартмани

12.03.2019    5477    majoram    0    

Программное создание реквизита управляемой формы с помощью механизма расширений

Практика программирования Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

В ЗУП 3 возникла задача добавить реквизит в справочник не внося изменений в конфигурацию. БСП с механизмом дополнительных реквизитов использовать было нежелательно, поэтому был использован механизм расширений. Для вывода данного реквизита на форму добавлять саму форму в расширение не хотелось по ряду причин, описанных ниже. Создание реквизита и элемента формы, соответствующего данному реквизиту было решено сделать программно в самом расширении, следуя принципу минимального воздействия на конфигурацию.

1 стартмани

12.03.2019    34694    ni_cola    31    

Иерархия библиотек. Автоматическое обновление или как отказаться от переопределяемых модулей

Практика программирования Математика и алгоритмы Разработка v8 Абонемент ($m)

В статье рассмотрен один из вариантов библиотечного подхода к разработке, позволяющий организовать иерархический вызов библиотечных процедур и упростить автоматическую сборку готового продукта из нескольких библиотек. Предлагаемый подход может служить одним из элементов CI/CD при разработке ПО на платформе 1С.

1 стартмани

04.03.2019    5711    Alxby    4