Золотые костыли

Публикация № 833094 Дата создания: 23.08.18 16:16

Разработка - Практика программирования

блокировки взаимоблокировки

Немного о программировании.

Золотые костыли

Мне кажется это название лучше всего подходит к тому, чем мы все занимаемся. Статья «Удачный пример блокировки», получилась небольшая, поэтому следующие заметки добавляю сюда же.

8. Поиск на инфостарте.

Для сложных условий поиска можно пользоваться сторонними средствами.

Пример поисковой строки в Yandex.

site:infostart.ru "РегистрНакопления.Продажи"&&"РегистрСведений.ЦеныНоменклатуры"

Постоянно пользуюсь, дает очень точные результаты.

7. Группировка документов по произвольным реквизитам.

В типовой 1С версии 11.4 есть возможность создавать документ Приобретения на основании массива Заказов поставщику. При этом, само собой, происходит проверка что ключевые реквизиты для всех Заказов поставщику совпадают. Проверка выполняется в модуле ЗакупкиВызовСервера.СформироватьДанныеЗаполненияПоступления, обратите внимание какой громоздкий запрос возвращает ТекстЗапросаПоЗаказам(). Допустим, у нас есть массив ЗаказыПоставщику (различающихся документов Заказ поставщику), мы хотим этот массив перегруппировать в несколько массивов одинаковых документов и создать несколько документов Приобретения. Перечень реквизитов - массив со строками например "Контрагент, Договор, Соглашение". Имя документа - строка "Документ.ЗаказПоставщику". Чтобы было можно обрабатывать документы любых типов.

Функция РазбитьПоПризнакам(ЗаказыПоставщику, ПереченьРеквизитов, ИмяДокумента) Экспорт
	
	РезультатФункции = Новый Массив;
	
	ТекстРеквизиты = "";	
	
	Для каждого Реквизит Из ПереченьРеквизитов Цикл
		НакоплениеСтроки(ТекстРеквизиты, Реквизит);
	КонецЦикла;

	РеквизитыВТаблице = РеквизитыВТаблице(ЗаказыПоставщику, ТекстРеквизиты, ИмяДокумента);	
	НаборыРеквизитов = РеквизитыВТаблице.Скопировать();	
	НаборыРеквизитов.Свернуть(ТекстРеквизиты,"");
	
	Для каждого НаборРеквизитов Из НаборыРеквизитов Цикл
		
		ОтборРеквизитов = Новый Структура;
		Для каждого Элемент Из ПереченьРеквизитов Цикл
			ОтборРеквизитов.Вставить( Элемент, НаборРеквизитов[Элемент] );
		КонецЦикла; 
		
		ЗаказыПоставщикуРазбитые = Новый Массив;
		
		РеквизитыСтроки = РеквизитыВТаблице.НайтиСтроки(ОтборРеквизитов);
		Для каждого Элемент из РеквизитыСтроки Цикл
			ЗаказыПоставщикуРазбитые.Добавить(Элемент.Ссылка);
		КонецЦикла;
		
		РезультатФункции.Добавить(ЗаказыПоставщикуРазбитые);
		
	КонецЦикла;
	
	Возврат РезультатФункции;

КонецФункции

Функция РеквизитыВТаблице(ЗаказыПоставщику, ПереченьРеквизитов, ИмяДокумента)

	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ЗаказПоставщику.Ссылка КАК Ссылка
	|ИЗ
	|	Документ.ЗаказПоставщику КАК ЗаказПоставщику
	|ГДЕ
	|	ЗаказПоставщику.Ссылка В(&ЗаказыПоставщику)";
	
	Запрос.Текст = СтрЗаменить(Запрос.Текст, "Документ.ЗаказПоставщику", "Документ."+ИмяДокумента);
	Запрос.Текст = СтрЗаменить(Запрос.Текст, "КАК Ссылка", ","+ПереченьРеквизитов);

	Запрос.УстановитьПараметр("ЗаказыПоставщику", ЗаказыПоставщику);
	
	Возврат Запрос.Выполнить().Выгрузить();	

КонецФункции

Процедура НакоплениеСтроки(Основа, Добавление)

	Если Основа = "" Тогда
		Основа = Строка(Добавление);
	Иначе
		Основа = Основа + "," +Добавление;
	КонецЕсли;	

КонецПроцедуры

6. Проверка html средствами 1С.

Похожие задачи дают в ЕГЭ, на первом курсе некоторых институтов. Так что сын-студент мне помог. В нашей базе для каждого товара содержится небольшой html-текст, возникла потребность проверять, чтобы количество открытых и количество закрытых тегов были равны на каждом уровне вложенности. Процедура ПроверитьПолеHTML вызывается при записи номенклатуры. Теги <br /> ,<hr /> являются исключениями: их проверять не нужно. Штатная процедура проверки работает немного иначе, для решения не подходит. Код для обычного (не-управляемого) приложения.

Процедура ПроверитьПолеHTML(Отказ)
	
	СуществующиеТеги = СуществующиеТеги();
	СуществующиеТеги.Свернуть("ИмяТега, Уровень", "Знак");
	
	ТекстОшибки = "Не совпадает количество открытых/закрытых тегов.";
	
	Для каждого Тег Из СуществующиеТеги Цикл
		
		Если Тег.Знак <> 0 Тогда
			
			ТекстОшибки = ТекстОшибки  + Символы.ПС + "Имя тега " + Тег.ИмяТега + " Уровень " + Тег.Уровень;
			
		КонецЕсли;	
		
	КонецЦикла; 
	
	Если СтрЧислоСтрок(ТекстОшибки) > 1 Тогда
		
		ОбщегоНазначения.СообщитьОбОшибке( ТекстОшибки, Отказ);
		
	КонецЕсли;	

КонецПроцедуры

Функция СуществующиеТеги() 
	
	РезультатФункции = Новый ТаблицаЗначений;
	РезультатФункции.Колонки.Добавить("ИмяТега");
	РезультатФункции.Колонки.Добавить("Уровень");
	РезультатФункции.Колонки.Добавить("Знак");
	
	ТекущийСимвол = "";
	ПозицияВСтроке = 1;
	
	Пока ПозицияВСтроке < СтрДлина(ДополнительноеОписаниеНоменклатурыHTML) Цикл
		
		ПрошлыйСимвол = ТекущийСимвол;		
		ТекущийСимвол = Сред(ДополнительноеОписаниеНоменклатурыHTML,ПозицияВСтроке,1);
		
		Если ПрошлыйСимвол = "<" 
			И ТекущийСимвол = "/" Тогда
			
			ПозицияВСтроке = ПозицияВСтроке+1;
			ДобавитьТег(ПозицияВСтроке, РезультатФункции, -1);
			
		ИначеЕсли ПрошлыйСимвол = "<" 
			И ТекущийСимвол <> "/" Тогда
			
			ДобавитьТег(ПозицияВСтроке, РезультатФункции, 1);
			
		Иначе
			
			ПозицияВСтроке = ПозицияВСтроке + 1;			
			
		КонецЕсли;
		
	КонецЦикла; 
	
	Возврат РезультатФункции;
	
КонецФункции

Процедура ДобавитьТег(ПозицияВСтроке, РезультатФункции, Знак)

	ИмяТега = "";
	
	Пока ПозицияВСтроке <= СтрДлина(ДополнительноеОписаниеНоменклатурыHTML) Цикл
		
		ТекущийСимвол = Сред(ДополнительноеОписаниеНоменклатурыHTML,ПозицияВСтроке,1);
		ПозицияВСтроке = ПозицияВСтроке + 1;		
		
		Если ТекущийСимвол = ">" Или ТекущийСимвол = " " Тогда
			
			Если Найти(ИмяТега, "br") + Найти(ИмяТега, "hr") = 0 Тогда

				НоваяСтрока = РезультатФункции.Добавить();
				НоваяСтрока.ИмяТега = ИмяТега;
				НоваяСтрока.Уровень = ?(Знак = 1, РезультатФункции.Итог("Знак"), РезультатФункции.Итог("Знак")-1);
				НоваяСтрока.Знак = Знак;
				
			КонецЕсли;
			
			Возврат;			
			
		Иначе
			
			ИмяТега = ИмяТега + ТекущийСимвол;
			
		КонецЕсли;
		
	КонецЦикла;	

КонецПроцедуры

 

5. Пример отладки.

После обновления конфигурации при первом запуске вышла ошибка, с комментарием ОбщийМодуль.ДлительныеОперации.Модуль(376): Недопустимое значение параметра. По этому адресу находится код

ТекстОшибки = КраткоеПредставлениеОшибки(Задание.ИнформацияОбОшибке);
ВызватьИсключение(ТекстОшибки);

В отладчике настроил остановку, удалось получить более подробную информацию из переменной Задание.ИнформацияОбОшибке. Оказывается, ошибка происходила в модуле ОбновлениеИнформационнойБазы, код

ПланыОбмена.ЗарегистрироватьИзменения(Узел, Данные);

Тут не подходит безусловная остановка или остановка с условием. Останавливаться по каждой ошибке – тоже не подходит: слишком много ошибок завершения фоновых заданий. В отладчике настроил остановку по ошибке 

Нашел данные, на которых происходит ошибка регистрации и исключил их из обработки.

4. Потерянное регламентное задание.

После обновления конфигурации в журнале регистрации появились записи "{ОбщийМодуль.ОбщегоНазначения.Модуль(2385)}: Регламентное задание недоступно по функциональным опциям или не поддерживает работу в текущем режиме работы программы. Выполнение прервано.". Еще в сообщении есть название регламентного задания, но в диспетчере регламентных заданий такого задания нет. В режиме конфигуратора не удается найти, откуда задание запускается.

По названию задания нашел связанную с ним функциональную опцию. Остановил регламентные задания в консоли кластера. Включил опцию. Задание появилось в диспетчере задач. Отключил выполнение регламентного задания. Все просто. Для осознания этой простоты мне потребовалось всего пару дней. )))

Список функциональных опций для регламентных заданий находится модуль РегламентныеЗаданияПереопределяемый, процедура ПриОпределенииНастроекРегламентныхЗаданий(Настройки)

3. Нестандартное использование замера производительности.

Бывает, что код плохо структурирован, в нем трудно разобраться. )) Например, нам нужно быстро найти, какой макет используется в печатной форме. Запускаем замер производительности, выполняем печать, завершаем замер. Получаем листинг выполненных команд. Выполняем поиск (Ctrl+F) слов "Макет", выбираем нужную строку.

2. Попытка, еще попытка…

Используйте конструкцию Попытка … Исключение … КонецПопытки правильно. ))

Между Исключение … КонецПопытки обязательно должна находиться команда ЗаписьЖурналаРегистрации(); и возможно Сообщить(); ВызватьИсключение; Программа не должна прятать происходящие ошибки, их обязательно выводить в журнал. Кто-то должен ежедневно анализировать и устранять причины ошибок. Казалось бы, это банально, но многие ли из нас начинают день просмотром журнала регистрации ? Кстати, даже некоторые «коробочные» решения не всегда используют ЗаписьЖурналаРегистрации(). Поэтому приходится мучительно долго искать причину очередного "отказа программы".

Далее, не нужно создавать такую ситуацию, когда конструкция выполняется в транзакции, а внутри ее прячется еще одна транзакция, например

Процедура ПриЗаписи(Отказ)

Попытка

ДокументПродажи = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
...
ДокументПродажи.Записать();

Исключение
....
КонецПопытки.

...
КонецПроцедуры;

В этом случае конструкция "Попытка … Исключение … КонецПопытки" бесполезна и вредна. В случае, если во вложенной транзакции произойдет ошибка, внешняя транзакция тоже откатится, но причины никто не увидит. Это фатум.

 

1. Удачный пример блокировки

В нашей информационной системе есть некоторые неоптимальности. Куда же без них. Как указал С.Носков, идеальных программ не бывает. Процесс создания и печати документов у нас потреблял довольно много ресурсов, возникали взаимоблокировки с процессом перепроведения документов. Программа «вылетала» или прерывала пакетную печать. Очень неприятно. Но решить эту проблему «в лоб» долгое время не удавалось. Взаимоблокировки смотрел в технологическом журнале, для регистров накопления поставил галочки «разрешить разделение итогов» (это помогает производить параллельную запись в регистр, если регистр в модуле проведения используется только для записи) – стало немного лучше. Остались взаимоблокировки из-за разного порядка записи в регистры. Оба процесса используют много тысяч строк кода и сделать порядок записи регистров одинаковым практически невозможно. Постепенно пришло понимание, что на момент печати нужно приостанавливать перепроведение документов (выполняется регламентным заданием).

Вариант 1. Сделать блокировку чего-либо на время печати документов кодом типа

Блокировка = Новый БлокировкаДанных;
ЭлементБлокировки = Блокировка.Добавить();
ЭлементБлокировки.Область = …
ЭлементБлокировки.Режим = РежимБлокировкиДанных.Исключительный;
ЭлементБлокировки.УстановитьЗначение…
Блокировка.Заблокировать(); 

Не представлялось возможным: ведь тогда всю процедуру печати нужно было выполнять в транзакции.

Вариант 2. Записывать в регистр сведений информацию о том, что регламентное задание должно ожидать некоторое время – тоже отпадает. Как обеспечить корректную работу такого регистра в случае ошибок, сбоев и аварийного завершения программы ?

Вариант 3. На помощь пришли объектные пессимистические блокировки, которые не используют транзакции. Когда пользователь начинает печатать – устанавливается блокировка. Регламентное задание перед тем как начать перепроведение – проверяет что установленных блокировок нет (для всех пользователей). Примеры кода:

Функция УстановитьБлокировку()
	Попытка
		ФлагБлокировки = ПараметрыСеанса.ТекущийПользователь.ПолучитьОбъект();
		ФлагБлокировки.Заблокировать();
		Возврат ФлагБлокировки;
	Исключение
		Возврат Неопределено;
	КонецПопытки;
КонецФункции

При вызове из модуля функция возвращает объект с установленной на него блокировкой. Объект и его блокировка существует в памяти, пока объект не уничтожить или пока выполнение кода модуля не закончится (штатно или нештатно).
 

Функция ЕстьБлокировка(Пользователь)
Попытка
	Пользователь.ПолучитьОбъект().Заблокировать();
Исключение
	Возврат Истина;
КонецПопытки;
Возврат Ложь;
КонецФункции

Функция проверяет для выбранного пользователя, не установлена ли по нему блокировка. Если пользователей много – вызывайте в цикле. Штатная функция Заблокирован() почему-то не отрабатывает. Возможно, фича моей платформы 8.3.11.

Таким способом, удалось избавиться от взаимоблокировок в работе. Всем успехов !

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. login1020 94 23.08.18 16:46 Сейчас в теме
такое решение актуально только для печати же?
А как быть с блокировками и ожиданиями на параллельном проведении Прихода и расхода по одной и той же группе товаров. Есть решение?
3. herfis 418 23.08.18 17:14 Сейчас в теме
Вполне рабочий костыль. Одобрям!
Штатная функция Заблокирован() почему-то не отрабатывает

Прямо в описании функции написано - почему не отрабатывает. Потому что гладиолус.
Сделали каку и оставалось только ее узаконить :)
Следует учитывать, что этот метод используется для проверки блокировки объекта базы данных конкретным объектом встроенного языка. Он не может быть использован для проверки, заблокирован ли вообще объект базы данных, например, другими пользователями

(1) Не обязательно для печати. Для любых случаев, где требуется глобальный "флаг" работы какого-либо процесса. К транзакционным блокировкам это не имеет отношения. Преимущество перед состоянием флага, хранимым в БД, очевидно - в случае сбоев флаг будет сброшен автоматически.
2. vasilev2015 2209 23.08.18 17:08 Сейчас в теме
Здравствуйте !

Это решение позволило не заключать печать в транзакцию.

Если возникают ошибки из-за одновременного прихода и расхода, то можно таким же способом разделить их по времени.

Если нужно обязательно выполнять одновременно - используйте стандартные рекомендации для улучшения параллельной работы:
включить разделение итогов регистров накопления, перейти в режим совместимости 8.3 управляемые блокировки.
login1020; +1 Ответить
4. Goleff74 184 23.08.18 19:17 Сейчас в теме
Эм. А что за действия такие происходят при печати, что это каким-то образом мешает проведению?
ice-net; Plotks2017; zqzq; +3 Ответить
5. vasilev2015 2209 23.08.18 19:28 Сейчас в теме
(4) Там неудачный алгоритм. Документы создаются, проводятся частично, печатаются через модуль объекта. Когда ИТ отдел предлагает все оптимизировать, руководство соглашается. Но чтобы через два-три часа уже все было оптимально :-)
6. Goleff74 184 23.08.18 19:37 Сейчас в теме
(5)
Т.е. во время печати еще и что-то записывается в регистры, которые используются проведением, раз печать в транзакции нежелательно?
ice-net; Plotks2017; +2 Ответить
7. tormozit 6344 24.08.18 07:05 Сейчас в теме
Регламентное задание перед тем как начать перепроведение – проверяет что установленных блокировок нет (для всех пользователей)
Так если оно проверило и начало перепроведение, и тут же пользователь начал печать?
8. vasilev2015 2209 24.08.18 08:42 Сейчас в теме
(7) Здравствуйте, Сергей !
Такая ситуация возможна, но к проблемам не приводит.
При желании можно поставить проверку и в обратную сторону.
9. ladon 24.08.18 09:01 Сейчас в теме
Я так понимаю, всё это можно было бы решить установкой одного флага на всю систему?

Например, используя значение регистра постоянных значений. Начал печать - флаг установил. Закончил печать - флаг снял.
Тогда не пришлось бы по всем пользователям проверять блокировки.

А так да - неплохой обход.
10. vasilev2015 2209 24.08.18 10:27 Сейчас в теме
(9) Здравствуй, Андрей !
Рад тебя видеть ))). Это практически наша общая статья )))

Да, можно было бы выбрать один объект и установить на него пессимистическую объектную блокировку.
11. ladon 24.08.18 10:31 Сейчас в теме
(10)
Да, можно было бы выбрать один объект и установить на него пессимистическую объектную блокировку.

Привет-привет.
Да, память об этой печати будет жить вечно. :))
12. vasilev2015 2209 25.08.18 09:59 Сейчас в теме
(11)
Да, можно было бы выбрать один объект и установить на него пессимистическую объектную блокировку.


я сообразил: один глобальный флаг подойдет для других целей, а в данном случае важно, что пользователей много. Первый наложил блокировку, второй не думая о состоянии глобального флага наложил блокировку... Проведение начнется, когда все они освободят ресурс. Получается, что все сделано оптимально. Флагов должно быть много. Все флаги в гости будут к нам и запируем на просторе.
13. ladon 25.08.18 13:12 Сейчас в теме
(12) параллельная печать двумя пользователями.. Ну да, вариант. :)
14. PerlAmutor 124 26.08.18 17:38 Сейчас в теме
Я правильно понимаю,что смысл всех этих действий заключается в том, что вы нашли аналог глобального семафора, и в случае, если флаг стоит хотя бы у одного пользователя базы данных, то ничего не делать и просто ждать следующего запуска регламентного задания по расписанию?
15. vasilev2015 2209 27.08.18 09:08 Сейчас в теме
(14) Здравствуйте !

Да, глобальный семафор (в разрезе пользователей), обладающий многими полезными свойствами: простота, устойчивость к аварийным завершениям, малый расход ресурсов.
16. PerlAmutor 124 27.08.18 09:34 Сейчас в теме
(15) Единственная проблема заключается только в том, что свойства пользователя (пароль, логин и т.д.) невозможно изменить на момент печати?
18. vasilev2015 2209 27.08.18 10:33 Сейчас в теме
(16) Интерактивно не удастся изменить реквизиты заблокированного элемента справочника. Но объектная блокировка не запрещает их изменять программно. В моем случае выбран справочник пользователи, но это могла быть искусственная конструкция: Справочник1 с реквизитом пользователь. Решение используется каждый день, пять человек печатают документы, регламентное задание приостанавливается. Все довольны.
17. Evil Beaver 7065 27.08.18 09:51 Сейчас в теме
Так же через объектные блокировки решаются задачи обработки всевозможных очередей. Очень полезный механизм, по сути mutex на уровне платформы.
19. vasilev2015 2209 27.08.18 10:37 Сейчас в теме
(17) в первую очередь для меня привлекательно отсутствие транзакции по сравнению с "обычными" блокировками. С языками программирования кроме 1С я не знаком, сравнивать не могу. ))
20. PerlAmutor 124 27.08.18 12:29 Сейчас в теме
А что если повесить блокировку на константу?

Вот еще один вариант нашел: https://infostart.ru/public/384485/
21. scientia_vinces 27.08.18 14:19 Сейчас в теме
(20) Совсем плохая идея. Если и делать софтовую эмуляцию, то только на основании регистра сведений.
23. vasilev2015 2209 27.08.18 14:40 Сейчас в теме
(21) Согласен, использовать внешний файл - совсем плохой вариант. Регистр сведений - чуть лучше плохого варианта, но тоже плох.
28. СергейК 51 29.08.18 11:51 Сейчас в теме
(21) Почему Константа плохая идея? Или вы не про неё?
Сейчас, вроде, каждая константа находится в отдельной таблице, блокировка не должна никому мешать...
29. herfis 418 29.08.18 12:07 Сейчас в теме
(28) Во-первых, все константы находятся мало того, что в одной таблице, так еще и в одной строке :)
Во-вторых, пессиместическую объектную блокировку на константу наложить нельзя. А транзакционная блокировка плоха не только по вышеуказанной причине, но еще и тем что в транзакцию попадают и все остальные операции с БД в задании.
Любой же семафор на нетранзакционной записи значения в БД плох тем, что он останется взведенным в случае, когда выполнение задания будет прервано аварийно.
Другое дело, что круг применений таких "мьютексов" в 1С довольно ограничен. Гораздо чаще нужна классическая очередь заданий.
32. СергейК 51 29.08.18 21:38 Сейчас в теме
(29)
Не нашел ссылки с 1С сайта, но такое уже читал из разных источников, кажется можно верить:
Способ хранения констант в 1С:Предприятие 8 менялся в зависимости от версии платформы. Так, в платформе до версии 8.2.14 (или платформах выше версии, но с включенным режимом совместимости 8.2.13 и ниже), константы хранятся в одной таблице СУБД, начиная с версии 8.2.14, для каждой константы создается своя таблица СУБД. Данное изменение было сделано для увеличения параллельности работы пользователей.


Во-вторых, пессиместическую объектную блокировку на константу наложить нельзя...

Как это можно проверить, может уже можно?
Почитал документацию, да, нельзя получить константу как объект. Понятно вроде. Спсб.
33. herfis 418 30.08.18 09:12 Сейчас в теме
(32) По-поводу констант ты прав. Заглянул в базу 8.3 с отключенным режимом совместимости - таки по таблице на константу уже. Надо же, а я и не знал. Спасибо за инфу.
22. vasilev2015 2209 27.08.18 14:39 Сейчас в теме
(20) Если на единственную константу, то непонятно как снимать блокировку, когда обработки идут параллельно и оканчиваются в разное время.
24. herfis 418 28.08.18 09:13 Сейчас в теме
(20) Транзакционную блокировку? Это дорого, неудобно и не всегда допустимо.
В варианте по ссылке (с файликами) главный минус - неявное ограничение на один рабочий сервер в кластере.
Сабжевый вариант лишен этих недостатков. Как правильно заметили - это почти полный аналог мьютексов. Механизмы платформы обеспечивают автоматическое снятие блокировки при уничтожении объекта-владельца (завершении процесса). В отличие от классических мьютексов предоставляемых операционками (базирующихся на "монопольных" инструкциях процессора), можно разруливать параллельную работу процессов на разных рабочих серверах.
Если мне не изменяет память, в 7.7 пессиместические блокировки объектов реализовывались как раз на файловых блокировках (блокировались соответствующие биты/байты в спец-файликах). В 8-ке, подозреваю, реализовано примерно также, только на компе менеджера кластера и какой-то сервис менеджера кластера отвечает за дистрибуцию этой информации.
25. asved.ru 35 29.08.18 10:33 Сейчас в теме
Кажется, вернее было бы расследовать причины задержек печати (есть подозрение, что речь о задержке в выводе документа на принтер).

В текущей реализации вы избавились не от взаимоблокировок, а от исключений при наложении управляемой блокировки. Ничего удачного не вижу: ожидания по-прежнему присутствуют, возможность дедлока на порядке записи сохраняется для параллельного проведения пользователями. Т.е. вы замаскировали проблему, вместо того, чтобы ее решать.

руководство соглашается. Но чтобы через два-три часа уже все было оптимально


Вы с руководством подходите друг другу.
26. vasilev2015 2209 29.08.18 11:41 Сейчас в теме
(25) Здравствуйте !

Кажется, вернее было бы расследовать причины задержек печати (есть подозрение, что речь о задержке в выводе документа на принтер).


у нас при так называемой печати происходит частичное проведение, поэтому взаимоблокировки с процедурой проведения из-за разного порядка записей в регистры. Видно в ТЖ.

В текущей реализации вы избавились не от взаимоблокировок, а от исключений при наложении управляемой блокировки. Ничего удачного не вижу: ожидания по-прежнему присутствуют, возможность дедлока на порядке записи сохраняется для параллельного проведения пользователями. Т.е. вы замаскировали проблему, вместо того, чтобы ее решать.


Простой тест: один пользователь проводит документ, тормозит в отладчике на последней строке. Второй пользователь проводит документ - взаимоблокировок нет. Параллельное проведение работает. Правильное решение.

Вы с руководством подходите друг другу.


Они уважают мой талант, я уважаю их нужды. Лишних денег ни у кого нет.
Dementor; +1 Ответить
27. СергейК 51 29.08.18 11:48 Сейчас в теме
Правильно понимаю, если только один пользователь захочет из под двух своих сессий 1С печатать, то не получится?
Пока не приходилось делать как бы "множественный" семафор, т.е. не выполнять процедуру пока куча других пользователей делают критические операции. Было наоборот, одна процедура, много пользователей но выполнить её должен кто-то один.
Интересно, спсб.
p.s.
в лоб напрашивается только одна альтернатива: справочник, в который добавляем элемент когда печатаем, удаляем(помечаем) когда закончили. А в регламентном задании запросом проверяем можно ли работать.
Но так кажется будет накладнее.
30. vasilev2015 2209 29.08.18 12:18 Сейчас в теме
(27) Здравствуйте !

Один пользователь, две сессии - эта процедура печати не получится. Альтернативы хуже.
31. WellMaster 104 29.08.18 15:23 Сейчас в теме
Нормальное решение. Пригодится, спасибо.
34. vasilev2015 2209 20.09.18 09:36 Сейчас в теме
Пункт 2 (Попытка, еще попытка) сильно похож на https://its.1c.ru/db/v8std#content:2149184148:hdoc. Но у меня доступнее, короче и правильно расставлены акценты. )))
35. Casey1984 3 14.10.18 09:06 Сейчас в теме
К разделу Удачный пример блокировки. Это сработает, если ТекущийПользователь в процедуре печати совпадает с пользователем переданным в ЕстьБлокировка(), т.е. вы последовательно всех пользователей в регламентном задании проведения проверяете? Или я что-то не понял?
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    82546    Serginio    113    

Полезные примеры СКД, ч.2

Практика программирования v8 v8::СКД Бесплатно (free)

Еще несколько примеров решения задач в СКД.

06.04.2021    7510    Neti    8    

Неочевидные нюансы записи управляемой формы

Практика программирования v8 v8::УФ Платформа 1C v8.2 1cv8.cf Бесплатно (free)

Разберем несколько нюансов записи управляемой формы.

02.04.2021    8501    SeiOkami    52    

Обзор полезных методов БСП 3.1.4

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Бесплатно (free)

Библиотека стандартных подсистем (далее - БСП) является частью любой типовой конфигурации, поэтому умение применять готовые процедуры и функции повышает качество разработки и избавляет от написания лишнего кода. К сожалению, не у всех есть время и упорство овладеть всей документацией, поэтому я собрал воедино наиболее популярный функционал.

25.03.2021    27310    rayastar    49    

Звуковое управление в 1С 8.3 Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

В данной статье описано создание библиотеки для звукового управления (выполнение команд голосом) для платформы 1С 8.3. Задача была поставлена так, чтобы модуль функционировал непосредственно на клиенте 1С, осуществляя управление формами, и взаимодействовал с интерфейсом.

16.03.2021    5209    velemir    31    

Доработка проведения в ERP 2.5. (Регистры накопления, Регистры сведений)

Практика программирования v8 ERP2 БУ Бесплатно (free)

Покажу точки входа для доработки "типового" проведения документов в ERP для регистров оперативного учета. Рассмотрим три основные ситуации: нужно изменить имеющееся проведение документа; нужно сделать записи в существующие регистры; нужно с нуля описать алгоритм проведения в добавленный регистр. Пример реализован на 1С:ERP Управление предприятием 2 (2.5.4.120)

10.01.2021    8574    BuriyLesha    9    

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    6956    comol    31    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    16554    quazare    34    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    39715    unichkin    74    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    57936    user5300    18    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    53828    ids79    26    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    34335    tormozit    106    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    37871    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    29940    kuzyara    38    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    21581    YPermitin    61    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    81249    tormozit    131    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    11247    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    36810    HostHost    41    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    47924    Yashazz    55    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    52386    tormozit    51    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    17833    budidich    29    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    85972    rpgshnik    71    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    68939    ids79    55    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    48995    tormozit    74    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    40614    YPermitin    25    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    28831    YPermitin    81    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    41534    ids79    19    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    17029    m-rv    3    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    132045    ids79    75    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    53580    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    36219    json    15    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    22066    m-rv    17    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    93219    ids79    15    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    44425    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    31564    YPermitin    14    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    34804    m-rv    22    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    21424    SeiOkami    52    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    73622    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    69445    ids79    27    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    29907    itriot11    34    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    29201    dmurk    148    

Регистры накопления. Виртуальные таблицы. Часть №2: "Остатки" и "Остатки и обороты"

Практика программирования v8 1cv8.cf Бесплатно (free)

Описание работы платформы 1С:Предприятие 8.2 с виртуальными таблицами регистров накопления "Остатки" и "Остатки и обороты". Анализ SQL-запрос при работе с виртуальными таблицами

22.05.2019    38778    YPermitin    8    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    57461    YPermitin    30    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    41664    ids79    45    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    40788    ellavs    131    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    30495    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    38368    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    59370    Смешной 1С    32